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About Advanced Assembly Mode Functionality
Pro/ENGINEER provides basic assembly tools, and various Pro/ENGINEER modules give you additional

functionality for assembly operations.

Two separate modules are available for performing basic and advanced operations in Assembly mode:

� Foundation Pro/ASSEMBLY users can work in Assembly mode and modify�but not create�skeleton

models. Online Help documentation for Foundation Pro/ASSEMBLY provides detailed information about

basic Assembly functionality.

� Advanced ASSEMBLY Extension supports the design and management of large and complex assemblies

through the use of powerful tools such as simplified representations, interchange assemblies, and the Design

Manager.

Advanced Assembly Functions

An Advanced ASSEMBLY Extension license is necessary to create advanced models and features, to include

unplaced components, and to work with advanced tools. Advanced ASSEMBLY provides the following

specialized functionality:

� Skeleton models

� Simplified representations

� Interchange assemblies

� Exploded states

� Unplaced components

� Shrinkwrap models

� Geometry features

� Inheritance features

� Shrinkwrap features

� Reference Control

� Global Reference Viewer

� Layouts

Skeleton Models

The skeleton model of the assembly is the framework of the assembly. A skeleton model is a specialized

component of an assembly that defines skeletal, space claim, interface, and other physical properties of an

assembly design that you can use to define geometry of components. In addition, you can use skeleton models

to perform motion analysis on an assembly by creating placement references to the skeleton model and then

modifying the skeleton dimensions to imitate motion. All the Simp Rep functionality available in Part mode is

now available in a skeleton model allowing for better visibility and improved performance.

Skeleton models can be used to capture in a central location design criteria defined in the subassembly or

delivered from a higher-level assembly. Using skeleton models in more than one assembly allows you to

distribute design criteria associatively throughout the product structure. When design criteria change, updating

is propagated to affected components. Skeleton models provide a clearly understood hierarchy of driving design

criteria, they provide an organized display, and they allow improved performance. Skeleton models are the

recommended mechanism for controlling top-level design iterations, and you can use them to facilitate task

distribution.

Foundation users can use and modify skeleton models; however, an Advanced ASSEMBLY Extension license

is required for creating them.

Simplified Representations

Simplified representations are variations of a model you can use to change the view of a particular design,
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enabling you to control which members of an assembly Pro/ENGINEER brings into session and displays. This

lets you tailor your work environment to include only the information of current interest to you. You can, for

example, temporarily remove a complicated subassembly from memory that is unrelated to the portion of the

assembly on which you need to work. You can also substitute a complicated subassembly or part with a simpler

part or envelope.

Using advanced performance tools, you can speed up the retrieval process and general work performance of

large assemblies using simplified representations.

Data Sharing Features

Geometry features and Shrinkwrap features are available for sharing design information from model to model

and are used to accomplish top down design objectives.

Interchange Assemblies

An interchange assembly is a special kind of assembly that you can create and then use in a design assembly.

An interchange assembly consists of models that are related either by function or representation. You can create

two kinds of interchange groups in the same interchange assembly:

� Functional interchanges�To replace functionally equivalent components

� Simplify interchanges�To substitute components in a simplified representation

Interchange assemblies, like family tables and layouts, provide a powerful method of automatic replacement.

Foundation users can use interchange assemblies; however, an Advanced ASSEMBLY Extension license is

required for creating them.

The Design Manager

Design Manager functionality provides top-down design tools, reference control and investigation tools, and

advanced performance tools.

� Using top-down design tools, you can set up a well-structured design containing skeleton models and copied

geometric and datum references.

� Using reference control and investigation tools, you can view and manage the complex web of dependencies

that evolve with the design. These tools enable you to easily trace and understand the references that you

make among features in a design. They clarify the external reference relationships that exist among models

in an assembly.

Pro/NOTEBOOK

The optional Pro/NOTEBOOK module supports top-down assembly design with tools that enable you to create

hierarchically-linked assembly layouts.

Pro/PROCESS for ASSEMBLIES

The optional Pro/PROCESS for ASSEMBLIES module enables you to create explode states in assemblies to

define the exploded position of all components.

Working with Assemblies

To work with an assembly, use the File menu to open or create an assembly file. The ASSEMBLY menu

displays the following options:

� Component—Manipulates assembly components (using the COMPONENT menu).

� Feature—Manipulates assembly features (using the ASSY FEAT menu).

� Modify—Modifies assembly or component dimensions and features (using the ASSEM MOD and MODIFY

menus).

� Restructure—Modifies assembly groupings, moving components from one assembly or subassembly to

another (using the RESTRUCTURE menu).

� Mechanism—Allows you to study the allowable motion of the assembly using Mechanism Design
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Extension (MDX).

� Simplfd Rep—Creates, modifies, or sets a simplified representation (using the SIMPLFD REP menu).

� Design Mgr—Accesses tools to manage assembly design (using the DESIGN MGR menu).

� ExplodeState—Creates, sets, and modifies explode states of an assembly (using the EXPLD STATE menu).

� Regenerate—Updates modified part and assembly dimensions (using the PRT TO REGEN menu).

� Relations—Edits parametric labels and adds or edits constraint equations (using the MODEL REL and

RELATIONS menus).

� Family Tab—Edits assembly family tables or creates assembly instances (using the Family Tree dialog box).

� Set Up—Assigns assembly mass properties, and specifies length units, mass units, dimension bounds, and

other set up properties (using the ASSEM SETUP menu).

� Program—Provides an option (Pro/PROGRAM) to create a program to control the design of parts in an

assembly (using the PROGRAM menu).

� Integrate—Retrieves integration project files (created in Pro/PDM) and generates difference reports to

resolve differences between source and target assemblies (using the INTEGRATE menu).

� Copy From—Copies entire assemblies or subassemblies into the new assembly.

About Exploded Views
Using basic Pro/ENGINEER, you can create and modify exploded views of components using the "drag and

drop" functionality.

If you have a license for the optional module Pro/PROCESS for ASSEMBLIES, you can create and modify

multiple explode states in assemblies to define the exploded position of all components. You can also create and

modify offset lines to show how explode components align when they are in their exploded positions.

Online Help documentation for Advanced ASSEMBLY Extension, Using Pro/PROCESS for ASSEMBLIES,

provides detailed information about exploding an assembly.

Using the ExplodeState command in the ASSEMBLY menu, you can automatically create an exploded view of

an assembly. Exploding an assembly only affects the display of the assembly; it does not alter true design

distances between components. You create explode states to define the exploded position of all components.

For each explode state, you can switch the explode status of components, change the explode locations of

components, and create explode offset lines.

You can define multiple explode states for each assembly, and then explode the assembly using any of these

explode states at any time. You can also set an explode state for each drawing view of an assembly.

The system gives each component a default explode position determined by the placement constraints. By

default, the reference component of the explode is the parent assembly (top-level assembly or subassembly).

The Explode mode Component Move functionality is the same as the Package Move functionality.

You can add two types of explode instructions to a set of components. The children components follow the

component being exploded or they do not follow it. Each explode instruction consists of a set of components,

explode direction references, and dimensions that define the exploded position from the final (installed) position

with respect to the explode direction references.

When using the explode functionality, keep in mind the following:

� You can select individual parts or entire subassemblies. Use Query Select to select a subassembly from the

screen.

� If you explode a subassembly, in the context of a higher level assembly, the system does not explode the

components in the subassembly. You can specify the explode state to use for each subassembly.

� You do not lose component explode information when you turn the status off. The system retains the

information so that the component has the same explode position if you turn the status back on.

� All assemblies have a default explode state called "Default," which is the default explode state the system

creates from the component placement instructions.
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� Multiple occurrences of the same subassembly can have different explode characteristics at a higher level

assembly.

To Set the Explode Position of Components
1. From the ASSEMBLY menu, choose ExplodeState > Redefine.

2. Select an explode state from the SEL STATE menu. The MOD EXPLODE menu appears.

3. Choose Position. The MTNPREF menu appears.

4. Choose a command to set up preferences for components.

To Change the Explode Status of Components
1. From the ASSEMBLY menu, choose ExplodeState > Redefine.

2. Select an explode state from the SEL STATE menu. The MOD EXPLODE menu appears.

3. Choose Expld Status. The EXPLD STATUS and the SELECT MDL menus appear.

4. Do one of the following:

� Apply the selected action to all components in the Model Tree window by choosing Toggle Expld

from the EXPLD STATUS menu and Pick Mdl from the SELECT MDL menu.

� Use rules to select components and perform actions on them by choosing Toggle Expld from the

EXPLD STATUS menu and By Rule from the SELECT MDL menu.

About Unplaced Components
Unplaced components belong to an assembly without being assembled or packaged. These components appear

in the Model Tree, but not in the graphics window. Unplaced components are represented by a distinct icon in

the Model Tree. Unplaced components can be constrained or packaged by selecting them from the model tree

for redefinition. Unplaced components can be included or excluded when creating the Bill of Materials, and are

not accounted for in mass properties calculations. Once a component is constrained or packaged, it cannot be

made unplaced again. When its parent assembly is retrieved into memory, an unplaced component is also

retrieved.

On unplaced components, you can perform actions that do not involve any knowledge of either the placement of

the component in the assembly, or the geometry of the component. For instance, you can associate an unplaced

component with a layer, but you cannot create a feature on an unplaced component.

Note: When a component is declared to belong to an assembly by modifying its relationship in PDM or

Intralink, that component will be left unplaced in the assembly until it is explicitly either constrained or

packaged.

To Create an Unplaced Component
1. Create a component either by copying from an existing component or making an empty component.

2. Select the Leave Component Unplaced checkbox in the Creation Options dialog box.

3. Continue the creation process. The component is added to the Model Tree but does not appear in the graphic

window.

Online Help documentation for Foundation Pro/ASSEMBLY provides detailed information about basic

Assembly functionality.

To Include an Unplaced Component
1. Select ASSEMBLY > Component > Adv Utils > Include. The File Open dialog box appears.

2. Select a component.

The component is added to the Model Tree but does not appear in the graphics window.
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To Place an Unplaced Component
To place an unplaced component, redefine the component and establish placement constraints.

1. Choose Component > Redefine. The Component Placement dialog box opens.

2. Proceed through the standard procedure to place a component.

To Redefine an Unplaced Declared Component
You can redefine an unplaced component that is declared to a layout. When you start to redefine the component,

the AUTOMAN menu appears, and you can choose Automatic or Manual.

� If you choose Automatic and the component has layout declarations, but not enough to completely

define all constraints to assemble the component for assembly, the Component Placement dialog box

opens, displaying the partial constraints. You can then fully constrain the component.

� If you choose Manual, the system ignores the layout declarations and allows only manual assembly.

Tip: Reorder an Unplaced Component for Automatic
Assembly
If you declare an unplaced component to a layout, automatic assembly fails if the layout has references to a

component that appears later (below it) in the feature list. When this situation occurs, the system prompts you to

reorder the unplaced component to the end of the feature list to make automatic assembly possible. Later, you

can use reorder functionality to raise the component higher in the feature list.

To Place a Component Multiple Times
To place a component multiple times in the assembly, you can use the Repeat command in the ADV COMP UTL

menu. You decide which references you want to vary, then define new locations for those references.

1. After assembling the component, choose Component > Adv Utils > Repeat. The Repeat Component dialog

box appears.

2. Select the component to repeat. The system highlights the selected component and displays the references

available to vary.

3. Select as many of the references as you want to vary. You can clear selected references before you continue.

4. Click Add to begin the placement.

5. Follow the prompts in the message window to select the appropriate references of the assembly for

placement. When you have defined all the references, the system automatically adds a new component.

6. Continue to define reference placements until all occurrences are placed.

7. Click Confirm when you have placed all occurrences.

8. To remove an occurrence, select its row in the Place Component window, then click Remove.

About Skeleton Models
Skeletons models make up the frame of an assembly and contain entities for assembling other components.

Skeletons are generally made with surfaces and datum features, though they can have solid geometry also.

Skeletons do not show up in the BOM and do not contribute to mass or surface properties.

Skeletons are represented by a unique icon in the Model Tree because their functional characteristics are

significantly different from those of other components. Skeleton models can be filtered out of the BOM and

drawing views and can be specially handled during the creation and manipulation of simplified representations

and Shrinkwrap features. Skeleton models are placed before all other components with solid geometry in the

Model Tree. Reference scope control settings can be used to restrict making assembly placement references to

skeleton models only.

Reference Scope Control tools control references in the same way for a single skeleton model as for multiple
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skeleton models. If the scope setting is Skeleton Model, references are allowed to each skeleton model in the

subassembly, as well as to any higher-level skeleton models, even when the object being modified is a skeleton

model.

Skeleton models can maintain their own family tables. This enhancement allows assemblies to maintain

different skeleton instances across a family table.

Beginning with release 2001, you can create a simplified representation from a skeleton model. All Simp Rep

functionality available in Part mode is available in a skeleton model. Additionally, skeleton simplified reps are

accessible from the assembly Simp Rep to allow the viewing of a graphics or geometry skeleton representation

or for substituting skeleton with its user defined Simp Rep.

Skeleton models, like regular components, can be replaced by both family table instances and other skeleton

models. You can copy a part model component into a new skeleton model, as long as the part model satisfies

the skeleton model criteria. You can generate a native skeleton model, based on a native part model, and have it

replace the part model in an assembly, with all references remapped to the new skeleton model. This effectively

allows a part to be designated as a native skeleton model, through the use of a new model file. Online Help

documentation for Foundation Pro/ASSEMBLY provides detailed information about replacing components.

You can create or assemble one or multiple skeleton models in a single assembly. The default file name

assemblyname_skel0001 is used for the first skeleton model created in an assembly. Subsequently

created skeleton models are named assemblyname_skel0002, assemblyname_skel0003, and so
forth.

An existing skeleton model can be assembled into an assembly, in the same way as any other component,

except that the assembly is rolled back to the last skeleton model in the component list. That is, all skeleton

models appear ahead of any design components, regardless of when they were created or assembled. Skeletons

can be reordered relative to one another, but they cannot be reordered after any design components. The first

skeleton model is placed by default, but you must place subsequent skeleton models manually, using the

Component Placement dialog box.

You can create or assemble skeleton models before or after creating components. However, if components or

features already exist in the assembly when you define the skeleton model, the system inserts the newly created

skeleton model before all components and assembly features, places it as the first component, and regenerates

the assembly. You can then redefine the first nonskeletal component and locate it with respect to the skeleton

model.

Note: If Insert Mode is active when you are in the assembly mode, you cannot create the skeleton model.

Because the skeleton model behaves differently from parts, it is not affected by assembly-level features.

Assembly features such as cuts and holes do not intersect the skeleton model geometry. If you want to intersect

the skeleton model with a cut, choose Modify and then Mod Skel, select the skeleton model; and then create a

cut local to the skeleton model.

Pro/REPORT recognizes skeleton models as a type of assembly member (asm.mbr.type), so you can filter
them accordingly. You can use skeleton models in a report to obtain additional information about the model, as

well as to obtain a name of an indexed drawing.

The following rules apply to skeleton models:

� A skeleton model is comparable to a component of an assembly, in that it has most of the properties of a

normal part. It has features, layers, relations, views, and so on. However, a component color is not

automatically assigned to a newly created or assembled skeleton.

� Skeleton models created prior to Release 20.0 are assigned the system-defined default color blue. This color

cannot be changed. Starting with Release 20.0, a component color is not automatically assigned to a newly

created or assembled skeleton. The skeleton default color is white and is set only to the model, not to the

component. You can create a user-defined color to display new skeleton models.

� You can exclude skeleton models from the Bill of Materials and from drawings.

� You can select skeleton models By Rule when managing simplified representations.

� You can reuse skeleton models in more than one assembly.
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You can freely create references between components in a subassembly with a skeleton model, as well as create

references to the skeleton model itself; however, keep in mind the following restrictions:

� A part that references a skeleton model only informs Pro/PDM that it references the assembly, not the

skeleton model.

� A skeleton model with an external reference only knows that it refers to an assembly that contains both itself

and the referenced model. Pro/PDM cannot identify the referenced model.

� To fully regenerate a component (in a subassembly that has a skeleton model) that references another

component in the same subassembly, you must retrieve both components and the subassembly.

Although skeletons can be created only in an assembly, they can be retrieved, operated upon, and saved as

ordinary parts.

With a Foundation Pro/ASSEMBLY license, you can use and modify skeleton models; however, an Advanced

ASSEMBLY Extension license is required for creating them.

To Create a Skeleton Model
Note: If Insert Mode is active, you cannot create the skeleton model.

1. Do one of the following:

� Choose ASSEMBLY > Modify > Mod Subasm, and select a subassembly for which to create a

skeleton. The SUBMODEL menu appears. Choose Component > Create. The Component Create

dialog box appears.

� Choose ASSEMBLY > Component > Create, or choose Component > Create from the pop-up menu

in the Model Tree window. The Component Create dialog box appears.

2. Click Skeleton Model.

3. Accept the default name or enter a new skeleton model name, and click OK. The Creation Options dialog

box opens.

4. Do one of the following:

� Click Empty to create an empty skeleton model in which you can create geometry later.

� Click Copy From Existing, and enter the name of a skeleton to be copied, or click Browse, select the

name of a component to copy, and click Open. The name of the selected component appears in the

Copy From text box.

5. Click OK.

The system creates the skeleton model and places it in the assembly and the Model Tree window.

The Model Tree window for an assembly that contains a skeleton model is the same as the one that appears for

regular assemblies except that skeleton models appear as the first node, regardless of when you created them.

You can expand the skeleton model to show its features.

Tip: Specify a Default Layer Name for Skeleton
Models
Skeleton models can be added automatically to a default layer, allowing you to select them and modify their

display easily, by layer.

To specify a default layer name for skeleton models, set the type option to layer_skeleton_model in the
def_layer configuration file option.

To Create a Display Color for Skeleton Models
Use the configuration option skeleton_model_default_color <RGB color values> to set a user-
defined default color used by Pro/ENGINEER to display new skeleton models. Enter three decimal values in

the range of 0 through 100 to specify the percentages of red, green, and blue (in this order) in the resulting
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color.

You can redefine the configuration color at any time; however, the color applies only to newly created

skeletons.

Skeleton Model Display Color
A new skeleton’s display color is controlled as follows:

� Default color white—The new skeleton displays in white when no color has been set.

� User-defined configuration color—Your configuration color applies to a new skeleton. Your configuration

color also applies to all newly created skeletons created by copying a part or skeleton that has no user-

defined color set using View > Model Setup > Colors&Appearances, even if the source skeleton already

has a configuration color.

� Source part color—The new skeleton takes the color of the source part or skeleton (whether or not you

have defined a configuration color) when you create a skeleton by copying from a part or skeleton that has a

user-defined color set using View > Model Setup > Colors&Appearances.

When you reuse (assemble) a skeleton, it does not change its color to that of your configuration option. The

skeleton already has a color, and the model is already referenced.

Note: After you set a default skeleton color, you can override it manually by changing the color of the skeleton

model.

About Data Sharing Features
Using the Data Sharing command, you can access the menus for creating an inheritance feature, a geometry

feature or a Shrinkwrap feature.

Click See Also for the procedures about which you want to display information.

About Geometry Features
Geometry features (Copy Geometry, External Copy Geometry, and Publish Geometry features) are

Pro/ENGINEER top-down design tools that allow you to communicate design criteria associatively. These tools

provide a simple, easy-to-use method for propagating a great deal of information by copying reference

geometry from model to model.

Geometry features are very useful for communicating information in a large design environment. Each design

group can create skeleton models in their own subassemblies with Copy Geometry features that reference the

top-level product skeleton. This allows them to work on their individual subsystems without needing access to

the top-level assembly. Because each group's skeleton is made of copied references from the top level, everyone

works with the same design criteria, which will remain associative.

Copying Geometry in Top-Down Design Methodology

The first step in a top-down design process is to define the design intent in a top-level skeleton model. Because

it is easier to manage a team working on individual subassemblies of a complex design, use the Copy Geometry

functionality to provide the appropriate design criteria for each subassembly.

As the higher-level information is copied down into the respective subassemblies, you can then proceed as

follows:

� Distribute the subassemblies to individual designers, who can base the design on the information from those

subassemblies.

� Add additional design intent to the subassemblies that is unique to these subassemblies. This additional

information then can be further distributed to the subassemblies of this subassembly.

The individual designers are, to a controllable degree, insulated from the work of others. They can see how the
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design is progressing by opening the top-level assembly with all of the latest modifications.

In addition to using Copy Geometry features in skeleton models, you can also use Copy Geometry features to

communicate geometry to or from any part, subassembly, or skeleton model. Accordingly, this procedure of

downwardly propagating top-level design intent while adding appropriate system-specific information can be

repeated through as many levels of the assembly as desired. Ultimately, the appropriate references for the

design of a single part can be copied into that part and then handed off to a low-level designer for component

design relative to global references.

Rarely is there a good reason to Copy Geometry from a part to a skeleton. This procedure is by definition not

part of a true top-down methodology. However, sometimes you must accommodate existing parts in a bottom-

up fashion. This technique can undermine the stability of a top-down design by introducing the likelihood that

the skeleton model will fail due to missing or changed external references. Circular references may also become

a concern.

Copy Geometry References

Copy Geometry features can be used to copy any geometric information from component to component. Follow

these guidelines when selecting Copy Geometry references:

� Surfaces, Edges, and Curves are selected using standard Pro/ENGINEER reference collection tools�the

same tools used to select references for creating drafts, rounds, and sweeps.

These are parametric collection tools. You can define a rule for collecting references, and as the design

changes and new entities satisfy this rule, they will be added to the Copy Geometry feature. For example,

you can select a group of surfaces by specifying a seed and a boundary surface. The appropriate surfaces

will be copied through the Copy Geometry feature. If you subsequently modify the original geometry by

placing a new cut feature that intersects the surfaces that were collected, the resulting surfaces of the cut

feature will also be included in the Copy Geometry feature.

� Quilts, vertices, and datum features, including planes, points, axes, and coordinate systems, can be copied

with the Copy Geometry feature.

� Copy Geometry features can be nested. Previously defined Copy Geometry features that exist in a different

component in the assembly can be selected for copying with a Copy Geometry feature. As a result, nesting

can help avoid duplicate reference selections. Furthermore, nesting can assist the top down design method

by supplying consistent access to primary design information in all skeletons down an assembly path

without creating large generational jumps from low-level Copy Geometry features to high-level skeletons.

External Dependency of Copy Geometry Features

The main dependency properties of Copy Geometry features are as follows:

� You create the dependency by selecting references, that is, explicitly copying geometry, from one

component into another as a Copy Geometry feature.

� You select all references for a single Copy Geometry feature from the same component.

� You can reference all Pro/ENGINEER geometry, plus existing Copy Geometry and Publish Geometry

features.

� When the parent component is not in session, the geometry copied by the Copy Geometry feature remains

frozen while the parent component is unavailable.

� You can control the behavior of Copy Geometry when the parent component is in session but some of the

referenced entities are missing. When parent geometry that was copied is missing (for example, it was

deleted or suppressed), a dependent Copy Geometry feature fails regeneration. However, you can prevent

Copy Geometry features from failing when a reference is missing. If you set the configuration file option

fail_ref_copy_when_missing_orig to no (the default is yes), during regeneration the system
automatically freezes any copied geometry for which the original is missing, preventing the Copy Geometry

feature from failing.

� Using the Dependency element, you can change the dependency of an individual Copy Geometry feature

and switch easily between dependency states. You can use the Dependency element to stop feature update,

in order to gain improved regeneration performance.
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� After it is selected as a reference, the geometry is available to the user. The geometry appears relative to the

rest of the part’s geometry, as it did in the context of the assembly where the geometry was selected.

� The information about the reference that is copied includes geometry, entity names, colors, line styles, and

layer information.

� Copy Geometry features create external dependencies and are not allowed in start models.

� Reference status information is available in the Model Tree. Copy Geometry features can have a Copied Ref

status of Active, Frozen, Suppressed, Missing, or Independent.

� Parent information about a model that contains a Copy Geometry feature can be viewed in the Global

Reference Viewer.

Regenerating Geometry Features

The order of Copy Geometry and Publish Geometry features affects the regeneration cycle. If a Publish

Geometry feature is regenerated in a model, all Copy Geometry features that reference it also regenerate. As a

result, from the Copy Geometry feature forward, the system regenerates all models that have a Copy Geometry

feature that references that Publish Geometry feature. Therefore, you should place all static information in a

skeleton as early as possible, and all dynamic information later in the cycle. If you create a Publish Geometry

feature that references the static information, you should place it in the feature list before the dynamic

information. This way, the Publish Geometry will not move every time the dynamic part of the skeleton

changes.

About Copy Geometry Features
You can create a Copy Geometry feature only in the context of an assembly. You can use the Copy Geometry

feature to pass any type of geometric reference information to and from parts, skeleton models, and assemblies.

Copy Geometry features copy reference geometry only�that is, surfaces and datum features, not solid features

You can externalize a Copy Geometry feature; if you do so, this action is irreversible. Using this technique, you

can create features in one model that reference the geometry of another model that is not in session. You can

also create an External Copy Geometry feature in Part mode and copy references from one part to another.

Using a Copy Geometry feature in a top-down design allows you to reduce the amount of data in session by not

requiring the retrieval of entire reference source models. You can also copy surfaces twice as efficiently using

Copy features as using a regular Surface Copy feature�that is, the Copy Geometry feature takes up only half

the space on disk and in session.

In Pro/ENGINEER 2001, Copy Geometry Features can be used in UDF’s and local groups.

To Create a Copy Geometry Feature
You can create a Copy Geometry feature in part, skeleton, and assembly models.

Note: When a Publish Geometry reference is selected, other references cannot be made, and vice versa.

1. Choose Feature > Create > Data Sharing > CopyGeom. The COPY GEOMETRY element definition dialog

box opens.

2. Click an element, and then click Define. Then select references of the specified type.

All the elements are optional, but you must define at least one of the following reference elements to

complete the Copy Geometry feature:

� Surface Refs—Select surfaces to add.

� Edge Refs—Select edges to add.

� Curve Refs—Select curves to add.

� Misc Refs—Select various reference features.

� Publish Geom—Select Publish Geometry reference features.

3. At any time, you can define one of the following elements:
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� Dependency—Control the dependency of the Copy Geometry feature.

� Externalize—Make the feature an External Copy Geometry feature.

4. Click OK to complete the Copy Geometry feature.

Tip: Specify a Default Layer Name for Copy
Geometry Features
To specify a default layer name for Copy Geometry features, set the type option to layer_copy_geometry
in the def_layer configuration file option.

To Define Misc Refs
1. Click Misc Refs, and click Define. The Misc Refs dialog box opens. In the Add Item area of the dialog box,

select a type of reference to be included in the current feature. Then select references of the specified type.

Select any of the following features to include in the current feature:

� Axis�Select an axis to copy.

� Coord Sys�Select a coordinate system to copy.

� Copy Geom Feat�Select a previously defined Copy Geometry feature from another part to copy. You

can include other geometric types in a new Copy Geometry feature that contains an existing Copy

Geometry feature.

� Dtm Point�Select a datum point to copy.

� Ext Geom Feat�Select a previously defined External Copy Geometry feature from another part to

copy. You can include other geometric types in a new External Copy Geometry feature that contains an

existing External Copy Geometry feature.

� Dtm Plane (selected by default)�Select a datum plane to copy.

� Quilt�Select a quilt to copy.

� Vertices�Select a vertex to copy. The copied vertex is represented on screen as a point. The first

vertex copied is tagged PNT1; subsequently copied vertices are tagged PNT2, PNT3, and so forth.

2. Click OK. The references are included in the current feature definition, and the Misc Refs dialog box closes.

To Redefine Misc References
As you select references to be included in the definition of the current feature, each specified reference is listed

in the Items list area of the dialog box.

1. Use the following buttons to add or remove items from the list to redefine the current feature.

� Click  and select list items from the screen.

� Click  and deselect all items in the Items list.

� Click  and select all items in the Items list.

� Click  and add new items to the current feature.

� Click  and delete selected items from the current feature.

2. Click OK. The references are included in the current feature definition, and the Misc Refs dialog box closes.

After you have redefined Misc Refs, you can repeatedly access the dialog box and redefine the feature. Click

the Add button to display the Add Item area of the dialog box that contains reference selections. You can select

any type of reference to include, as when you are initially defining the current feature.
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To Define a Publish Geom Reference
1. Click Publish Geom, and click Define.

2. Choose Add from the GCPY menu, and use the Model Tree or Sel By Menu to select a previously defined

Publish Geometry feature from a part�you can select a Publish Geometry feature only by name, not from

the screen.

Only one Publish Geometry reference can be included in the current feature.

Note: If a Publish Geometry feature is selected for a reference, no other geometry references are allowed, and

vice versa.

To Set Dependency
The new feature you are creating is dependent by default; that is, if you change the original part from which you

copied geometry, the geometry in the current feature is updated accordingly the next time both components are

in session, and the assembly where the current feature was created is in session.

1. Click Dependency, and click Define.

2. You can define the dependency of the feature and switch between dependent and independent states:

� To break the dependency, click Dependency, and then choose Independent from the COPY DEPND

menu. The system temporarily suspends the relationship between the current feature and the original

geometry. If you change the original part, this current feature does not change.

� To establish dependency again, click Dependency, and then choose Dependent from the COPY DEPND

menu.

To Externalize a Data Sharing Feature
You can change a local feature into an external feature.

1. Click Externalize, and click Define.

2. Choose Confirm from the CONFIRMATION menu. The LOCATION menu appears.

At this stage, the feature is converted irreversibly to an external feature.

3. Use the LOCATION menu to specify the external placement reference for the copied geometry.

To Select a Model Using the LOCATE MDL Menu
1. Click Ext Model, and click Define. The LOCATE MDL menu appears.

2. Select the model from which to copy geometry:

� Click Select to select a model in an open window.

If there is an assembly model in an open window, you can select the top level as the reference model,

or you can select any of its individual parts. The model must be an assembly; you cannot select a part

outside the context of an assembly.

� Click Open to invoke the File > Open dialog box to select a model on disk or in session.

The current window containing the selected model pops forward as the active window, or the selected

model is displayed in a new window if it is not already in its own window. The Location element is

activated automatically, and the LOCATION menu appears.

Proceed to define the external placement references.

To Specify the External Placement Reference Using
the LOCATION Menu
Choose one of the following commands from the LOCATION menu to specify the external placement reference

for the copied geometry:

� Default�Locates the copied geometry in the current model using the default internal coordinate
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systems of each model to locate the geometry.

� Cur Placement (available only for redefining a Copy Geometry feature to an External Copy Geometry

feature�Locates the copied geometry in the current model using the current relative placement.

� Coord Sys�Locates the copied geometry in the current model by aligning coordinate systems.

First select or create a coordinate system on the external reference model, and then select or create a

coordinate system on the local (target) model.

Note: To preserve geometry location, use a coordinate system that is coincident with the one chosen in

the external model.

The system locates the geometry by internally "lining up" the default or selected coordinate system of

the reference model with that of the target model (as if the external reference model were assembled to

the target model with a coordinate system constraint).

You can create a coordinate system on the fly. You cannot create a datum on the fly in the reference

model. Only existing coordinate systems can be selected on the reference model. If the reference model

is an assembly, the coordinate system must be a feature of the top-level assembly (that is, no part-level

or subassembly-level coordinate systems are allowed).

To Show Current References
Select an element and click Refs to show the current references for the active element. Choose Next and

Previous from the SHOW REFS menu to step through the geometry as the system highlights each element on the

active model.

To Display Information About the Feature
References
Click Info to display an information window (feature.inf) containing information about the feature.

To Preview Current References
Click Preview, and click Define.

The system displays the current reference selections.

To Resolve Feature Creation Failure
If the feature cannot be created, click Resolve, and click Define.

The system displays the Failure Diagnostics information window and the RESOLVE FEAT menu.

To Rename a Feature
Data sharing features are given generic names by the system such as CopyGeom, External CopyGeom,

Shrinkwrap, and so forth. Although the feature can be identified by its assigned id number, you can rename the

feature to assign it an easily identifiable, unique name. Naming a feature allows it to be listed by this name in

the Model Tree. The feature is also listed by this name in menus, allowing it to be selected By Name.

1. Choose Set Up > Name > Feature, and select the feature.

2. Enter the new name.

To Redefine a Copy Geometry to an External Copy
Geometry Feature
You can redefine a local Copy Geometry feature to an External Copy Geometry feature.
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Note: You cannot change an External Copy Geometry feature to a Copy Geometry feature.

1. Select the Copy Geometry feature from the Model Tree, and choose Redefine from the right mouse button

pop-up menu. The COPY GEOMETRY element definition dialog box opens.

2. Click Externalize, and click Define.

3. Choose Confirm from the CONFIRMATION menu. The LOCATION menu appears.

4. Choose one of the following commands from the LOCATION menu to specify the external placement

reference for the copied geometry:

� Default�Locates the copied geometry in the current model using the default location.

Click Ext Model, and click Define. The LOCATE MDL menu appears. Choose Select or Open to select

a model from which to copy geometry.

� Cur Placement�Locates the copied geometry in the current model using the current relative

placement.

� Coord Csys�Locates the copied geometry in the current model by aligning coordinate systems.

First select a coordinate system on the reference model, and then select a coordinate system on the

target model.

Note: To preserve geometry location, use a coordinate system that is coincident with the one chosen in

the external model.

5. Click OK.

About Operating on Copy Geometry Features
Listed below are some operations that can be performed on Copy Geometry features:

� Rename a data sharing feature

� Specify a default layer name for Copy Geometry features

� Display reference status in the Model Tree

� Update frozen external reference placement

� Reroute references to implicitly copied edges and surfaces

� Reroute Copy Geometry features to another Publish Geometry feature

� Reroute Copy Geometry features to higher levels in the assembly than the level where the feature was

created

� Include Copy Geometry features in local groups

� Redefine a Copy Geometry feature to change it to an external Copy Geometry feature

To Display Copied Ref Status in the Model Tree
In the Copied Refs column of the Model Tree window, the system displays the status of references for all Copy

Geometry features in all components in the assembly. It also shows the status of any local copies of external

references that have been created as a result of reference control settings.

1. Choose Tree > Column Display > Add/Remove to add a column to the Model Tree. The Add/Remove

Columns dialog box opens. If the Model Tree is embedded, choose View > Model Tree Setup > Column

Display.

2. Click the Type list, click Copied Refs from the list of types of information, and then click the right arrow

command button to add a Copied Refs column to the Current list of columns.

3. Click OK to close the dialog box. The new Copied Refs column now appears in the Model Tree window.

Note: You can expand and collapse the Model Tree window, and the system updates the Copied Refs column

accordingly. The Copied Refs column displays the status information about each Copy Geometry feature as

well as any external references created by manually overriding the reference control settings. That is, with the

reference handling option Copy Out-Of-Scope References enabled, an external reference has been created that

violates the current reference control setting by confirming at the warning prompt. This causes "invisible"

copies of the reference geometry to be created in the model that has the external reference. The status of this

invisible copied reference is also displayed in the Copied Refs column, in the row of the feature that referenced
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the external geometry.

Copied Ref Status
Copy Geometry features can have the following Copied Ref status:

� Active—The parent component of the referenced entity is in session, and the referenced entity exists.

� Frozen—The parent component of the referenced entity is not in session and, therefore, the references are

frozen.

� Suppressed—The parent component of the referenced entity is in session, and some of the referenced

entities are suppressed.

� Missing—The parent component is in session, and some of the referenced entities are missing.

� Independent—There is no dependency between the Copy Geometry feature and the referenced entities in

the parent component. The Copy Geometry feature references are temporarily frozen and are not updated to

the referenced entities.

To Replace or Prevent Missing References
When the original geometry that was copied is missing (for example, it was deleted), a dependent Copy

Geometry feature fails the regeneration. You can then redefine it and select a replacement reference.

If the Copy Geometry feature is suppressed and the reference object is missing, the suppressed Copy Geometry

object is resumed in a frozen state.

You can also use the Make Indep command in the QUICK RESOLVE menu to make the Copy Geometry feature

independent so that it no longer depends on the original geometry and, therefore, is not affected by any missing

references.

Tip: Freeze Copied Geometry to Prevent Failure
You can prevent Copy Geometry features from failing when a reference is missing. If you set the configuration

file option fail_ref_copy_when_missing_orig to no (the default is yes), during regeneration the
system automatically freezes any copied geometry for which the original is missing, preventing the Copy

Geometry feature from failing. The system displays a warning instead.

To Update Frozen Copy Geometry Location
When you delete the model that contains a Copy Geometry feature from the assembly in which the Copy

Geometry feature was created, the Copy Geometry feature loses its reference path and loses its associativity and

becomes frozen, that is, it does not update to changes in the referenced geometry. However, when you

reassemble the model, you can redefine the Copy Geometry feature to update its external reference placement

location. The Copy Geometry feature status then changes from Frozen to Active and returns to full associativity.

1. Select the Copy Geometry feature in the Model Tree, and choose Redefine from the right mouse button

pop-up menu. The COPY GEOMETRY element definition dialog box opens.

2. Click Update Location, and click Define. The system displays a confirmation prompt.

3. When you select Confirm, the system moves the copied geometry to the correct current location on the

source part.

If you choose Cancel from the CONFIRMATION menu, the Copy Geometry feature updates when parent

geometry changes, but its placement is incorrect.

To Reroute References to Implicitly Copied Edges
When you reroute a Copy Geometry feature from one surface to another, you can reroute the implicitly copied

edge references as well. If children of the Copy Geometry feature reference implicit entities (such as surface

edges), these implicitly copied references need to be rerouted as well.
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1. Select the feature from the Model Tree, and choose Reroute from the pop-up menu.

2. The system displays a prompt: "Would you like to individually map the original implicitly copied entities to

newly copied entities?"

� If you enter No, the system attempts the mapping on its own.

� If you enter Yes, the Reroute References dialog box opens, displaying a list of edges to be mapped.

You can select and reroute edges.

To Reroute References to Implicitly Copied Surfaces
When you reroute a Copy Geometry feature from one edge to another, you can reroute the implicitly copied

surface references as well. If children of the Copy Geometry feature reference such implicit entities (such as

implicitly copied surfaces), these implicitly copied references need to be rerouted as well.

Explicitly and Implicitly Copied Geometry
When you create a Copy Geometry feature, two types of geometry are copied: explicitly copied geometry and

implicitly copied geometry. With some geometry references that you select (that is, explicitly copy), some

implicitly copied geometry also joins the feature. For example, if you select a surface for your Copy Geometry

feature, the surface itself is explicitly copied and the edges of the surface are implicitly copied.

If you reference any implicitly copied geometry of a Copy Geometry feature, and then reroute the Copy

Geometry feature references to new source geometry, the implicit reference fails because the original parent

geometry (the implicitly copied references) are no longer available. Therefore, you should make sure that you

explicitly copy (select) all pertinent geometry in a Copy Geometry feature. Otherwise, you may need to redefine

features that reference implicitly copied geometry.

To Reroute Copy Geometry Features to Another
Publish Geometry Feature
You can reroute Copy Geometry features with children from one Publish Geometry feature to another.

1. Choose Reroute from the FEAT menu. The system prompts you to select another Publish Geometry feature

to use as a reference.

2. Select another Publish Geometry feature.

3. The system displays a prompt, "Would you like to individually map the originally referenced entities to the

newly referenced entities?"

� If you enter No, the system attempts the mapping on its own.

� If you enter Yes, the Reroute References dialog box opens, displaying a list of entities to be mapped.

You can select and reroute entities.

About External Copy Geometry Features
The purpose of External Copy Geometry functionality is to copy geometry from model to model of an assembly

without needing to copy the geometry in the context of the assembly, thus avoiding the dependency on the

assembly and all models along the path between the two components. This is most useful for an assembly that

uses an origin coordinate system to assemble all of its components.

If all the components are assembled to the same coordinate system, it is very easy to copy geometry from one

component to another by using the Select location option of the External Copy Geometry feature and selecting

the coordinate system on the reference and target models that will be used for their assembly. Using this

method, when all of the components are assembled, the externally copied geometry of the target models will be

coincident to the referenced geometry of the external reference model.

This means that components can be deleted from the assembly without losing the associativity of copied

geometry (as will happen with regular Copy Geometry features if the target component model is deleted) or
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causing any of the other External Copy Geometry features that reference the component to fail.

Even though the models are associative to each other via the External Copy Geometry features, the components

are completely independent of each other in the assembly. That is, the associativity is not controlled by the

assembly model.

An independent External Copy Geometry feature remains frozen in its original state, whether or not its external

reference model is in session and its geometry has been updated. It also does not fail when the copied references

are missing from the parent model.

If the external reference model is an assembly, all of the geometric references must be chosen from the same

model. The first selection determines which model this is. If the first reference is selected from geometry (an

assembly surface, datum, and so forth) of the top-level assembly, all subsequent references must be from top-

level assembly geometry. If the first reference is chosen from a component model of the assembly, all

subsequent reference selection must be made from that component model.

To Create an External Copy Geometry Feature
An External Copy Geometry feature copies geometry from an external model, located relative to a coordinate

system. You can create an External Copy Geometry feature in part, skeleton, and assembly models. You can

also create an External Copy Geometry feature by redefining a local Copy Geometry feature to an External

Copy Geometry feature. However, you cannot redefine an External Copy Geometry to a Copy Geometry

feature.

Note: When a Publish Geometry reference is selected, other references cannot be made, and vice versa.

1. In the model to which you want to copy geometry, choose Feature > Create > Data Sharing >

ExtCopyGeom. The EXTERN COPY GEOMETRY dialog box opens, with the Ext Model element selected

by default. The LOCATE MDL menu appears.

2. Use the LOCATE MDL menu to select the model from which to copy geometry. The LOCATION menu

appears.

3. Use the LOCATION menu to specify how the copied geometry will be located in the target model:

� Choose Default from the LOCATION menu to use the default internal coordinate systems of each

model to locate the geometry.

� Choose Coord Sys, and first select a coordinate system on the reference model, and then select a

coordinate system on the target model.

Note: To preserve geometry location, use a coordinate system that is coincident with the one chosen in

the external model.

4. Click an element, and then click Define. Then select references of the specified type from the external

source model. The description in the Info column in the dialog box changes from Optional to Defined for

each element that you define.

The elements are the same as those available for creating a local Copy Geometry feature. All the elements

are optional, but you must define at least one of the following reference elements:

� Surface Refs—Select surfaces to add.

� Edge Refs—Select edges to add.

� Curve Refs—Select curves to add.

� Misc Refs—Select various reference features.

� Publish Geom—Select a Publish Geometry feature.

� Dependency—Control the dependency of the External Copy Geometry feature.

5. Click OK to complete the Copy Geometry feature.

About Publish Geometry Features
A Publish Geometry feature contains independent, local geometry references. Only local geometry can be

referenced in a Publish Geometry feature�external references are not allowed. A Publish Geometry feature has
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no geometry. It does not create local copies of the references selected for its definition. It simply consolidates

multiple local references in a model so that they can be copied to other models. When you create a Copy

Geometry or External Copy Geometry feature, you can reference a Publish Geometry feature. By so doing, you

copy, with a single selection, a local collection of model geometry to other models as a single entity. This

reduces the number of menu picks required to copy the same geometric references to several other models and

also allows an efficient way to control what references are used.

Publish Geometry functionality is an important tool for capturing design intent. Publish Geometry features

provide a way for you to specify the geometry from a component that should be used when others copy

geometry from that model. Using Publish Geometry features, you can predetermine the geometry to be

referenced by a Copy Geometry feature. You can define your interfaces, and by "publishing" references that are

meant to drive other designs, you can considerably reduce the possibility that designers will select incorrect

geometry to create the driven models. When a Publish Geometry feature fails, a Copy Geometry feature

referencing the Publish Geometry will fail also.

You can create a Publish Geometry feature in part, skeleton, and assembly models. If a Publish Geometry

feature is created in the context of an assembly, the reference geometry must be selected in the source model.

For example, if the feature is created in the top-level assembly, only top-level assembly surface features and

datums can be referenced�you cannot reference geometry from the components of the assembly. Similarly, if a

Publish Geometry feature is created in a part component using Modify > Mod Part > Feature > Create, all

geometry references must be selected from that part component.

A Publish Geometry feature cannot be selected graphically. It must be selected either from the Model Tree or

by name from the menus. Because of this, Publish Geometry features are named when they are created.

To Create a Publish Geometry Feature
1. Choose Feature > Create > Data Sharing > PublishGeom. The PUBLISHED GEOMETRY dialog box

opens.

2. The first element listed is Name. By default, the Publish Geometry feature is given the name

"PUBGEOM_x" where "x" is some integer. To give the Publish Geometry feature a new name, click Name

and then click Define and enter a new name. This is the equivalent of choosing Set Up > Name > Feature

and then selecting the Publish Geometry feature to give it the new name. This allows a Publish Geometry

feature to be selected "By Name" and to be listed by this name in the Model Tree.

Note: The Name field of the Publish Geometry feature can be changed only during initial creation. It cannot

be changed when the feature is redefined. To change the name of an existing Publish Geometry feature, you

must use the Set Up > Name > Feature command.

3. Click an element, and then click Define. Then select references of the specified type. Unlike Copy

Geometry and External Copy Geometry features, Publish Geometry does not list a Publish Geometry

reference element—Publish Geometry features cannot reference other Publish Geometry features.

All the elements are optional, but you must define at least one of the following reference elements to

complete the Publish Geometry feature:

� Surface Refs—Select surfaces to add.

� Edge Refs—Select edges to add.

� Curve Refs—Select curves to add.

� Misc Refs—Select various reference features.

4. Click OK to complete the Publish Geometry feature.

About Shrinkwrap Features
A Shrinkwrap feature is a collection of surfaces and datum features of a model that represents the exterior of the

model. You can use a part, skeleton, or top-level assembly as the source model for a Shrinkwrap feature. You

can control the components and the surface subset to include in the Shrinkwrap feature.

Unlike the Shrinkwrap model, a Shrinkwrap feature is associative and automatically updates to reflect changes

in the parent copied surfaces. The Shrinkwrap feature detects when components have been added or removed,
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and updates accordingly. You can control updates with dependency control and switch between making the

feature dependent on referenced additional surfaces or independent. The independent state can be useful to

avoid unwanted regeneration cycles.

The Shrinkwrap feature gives an accurate representation of the exterior of a model without the need for having

the entire model in memory�so less memory is required. When created in an assembly, a Shrinkwrap feature

can be seen in an empty simplified representation (one that does not have any components). This empty

simplified representation (of this subassembly) can be assembled to another assembly (the parent assembly).

Thus the detail of a complex subassembly can be represented in its parent assembly by a subset of surfaces that

requires a fraction of the memory space that would be used if the actual assembly had been assembled instead

of the empty simplified representation. This can be a powerful tool in the manipulation of large assemblies.

The system creates the Shrinkwrap feature in the object that is currently being modified. All created geometry

appears in the modified object. The system captures source geometry by means of a surface method, along with

datum geometry and such shrinkwrap attributes as surface selection and hole removal, according to your

specifications. You can create a Shrinkwrap feature in an envelope part or in an empty component.

Note: Shrinkwrap features are associative�they update when the source model is modified.

To Create a Shrinkwrap Feature
Using the Shrinkwrap command from the DATA SHARING menu, you can create an associative Shrinkwrap

feature. The system creates the feature in the object (part, skeleton, or assembly) currently being modified. The

Shrinkwrap feature references geometry from the currently active top-level assembly (or part) in session. All

created geometry appears in the modified object.

1. Choose Feature > Create > Data Sharing > Shrinkwrap. The SHRINKWRAP element definition dialog

box opens, with the Attributes element and Define automatically selected and, below it, the Shrinkwrap

Attributes dialog box opens.

Note: All the elements are optional. You can automatically create a Shrinkwrap feature containing default

Shrinkwrap information simply by clicking OK.

2. In the Quality area of the the Shrinkwrap Attributes dialog box, enter an integer in the range from 1 to 10 to

specify the level of quality for the system to use when identifying contributors to the Shrinkwrap feature.

The default setting is 1. As the level is increased, processing time also increases.

3. In the Attributes area of the Shrinkwrap Attributes dialog box, select any of the following options to specify

creation attributes:

� Auto Hole Filling�The system identifies all holes or cuts that intersect a single surface and closes

those holes for the purpose of shrinkwrapping.

� Include Skeletons�The system includes skeleton model geometry in the Shrinkwrap feature.

� Include Quilts�The system includes external quilts in the Shrinkwrap feature.

� Ignore Small Surfaces�The system does not include surfaces smaller than the specified percentage of

the model's size in the Shrinkwrap model. Enter an integer (zero is the default) to specify the relative

size of the surface to ignore.

Click Done. The Shrinkwrap Attributes dialog box closes.

4. Click any of the following elements in the SHRINKWRAP element definition dialog box, and then click

Define:

� Comp Subset�Define a component subset of the assembly's components to work with.

� Subset Handling����Specify how the system will handle the specified subset of components in creating

the feature. The Subset Handling dialog box opens. Select one of the following Subset options, and

then click Done:

Shrinkwrap and Select (selected by default)�Shrinkwraps entire assembly and uses the surface

subsets from the selected components only.

Select and Shrinkwrap�Builds Shrinkwrap based on selected components.

� Additional Srfs�Select individual surfaces to be included in the current feature.

� Include Datums�Select additional datum geometry to be included in the current feature. The Misc
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Refs dialog box opens. In the Add Item area of the dialog box, select any of the following types of

datum geometry to be included in the Shrinkwrap feature, and then select references of the specified

type:

Axis�Select an axis to copy.

Coord Sys�Select a coordinate system to copy.

Dtm Point�Select a datum point to copy.

Dtm Plane (selected by default)�Select a datum plane to copy.

Click OK. The references are included in the Shrinkwrap feature definition, and the Misc Refs dialog

box closes.

� Geometry Dependency�Control the dependency of the Shrinkwrap feature.

The new Shrinkwrap feature you are creating is dependent by default on referenced additional surfaces.

This means that if you change the original part from which you copied surfaces, the surfaces in the

Shrinkwrap feature update to changes in position and size as the referenced models change.

� Externalize�Make the feature an External Shrinkwrap feature.

5. Click OK to complete the Shrinkwrap feature.

To Define a Component Subset
The system automatically analyzes all components in the assembly and determines which contribute to the

Shrinkwrap. However, you can select the components of the active model that will contribute to the Shrinkwrap

feature�which components of the assembly the system will consider (include) when identifying Shrinkwrap

geometry and which it will ignore (exclude)�as you do when specifying components for a simplified

representation.

1. Click Comp Subset in the SHRINKWRAP element definition dialog box, and then click Define.

The Model Tree opens, with all components showing a default status of Consider. The SHRINKWRAP

COMPS temporary column lists the components that the system will consider when creating the Shrinkwrap

feature. The column shows the current status of each component in the active assembly, as either Consider

or Ignore. All components of the top-level assembly have Consider status by default.

You can set the status of components manually by selecting them in the Model Tree, and you can also set

component status by using rules.

2. Assign a status of Consider or Ignore to assembly components manually or by using rules.

� Use Pick Mdl from the SELECT MDL menu to select components, choose Consider or Ignore on the

SEL SHRWRP menu, and then select a component. The component status changes accordingly in the

temporary column. After assigning status to the components, choose SEL SHRWRP > Done.

� You can select components to remove from the Shrinkwrap by changing their status to Ignore.

� You can choose Pick Mdl > All to set all components to Ignore or Consider, and then selectively

change the status of components manually or by using rules.

To Select a Component Using the SELECT MDL
Menu

� Pick Mdl—Uses the Model Tree window to select components in the assembly tree structure. If you

choose a subassembly, the system "marks" it and all of its components.

� All—Selects all the components in the assembly.

� From/To—Selects the first and the last component in the assembly tree structure. The system "marks"

these components and all the components in between. If a subassembly falls into this range, it "marks"

the subassembly and all of its components.

� By Rule—Sets up a rule for component selection. The By Rule dialog box opens.

� By Rep—Selects models active in other representations.
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To Specify Subset Handling
You can specify how the system will handle the specified subset of components in creating the Shrinkwrap

feature.

1. Click Subset Handling in the SHRINKWRAP element definition dialog box, and then click Define. The

Subset Handling dialog box opens.

2. Select one of the following Subset options, and then click Done:

� Shrinkwrap and Select (selected by default)�Shrinkwraps the entire assembly and uses the surface

subsets from the selected components only.

When you select a subset of components to shrinkwrap, you are actually specifying a subset of

surfaces from the full-blown assembly shrinkwrap which will be captured. That is, the system will

shrinkwrap the entire assembly, as it is displayed on the screen, and then actually copy only those

surfaces included in the shrinkwrap which are based on components in the selected subset. All other

surfaces will be ignored.

This capability allows you to create multiple Shrinkwrap features, based on various subsets of the

original assembly's components, and each Shrinkwrap can have a diffferent quality setting. This allows

you to accurately represent the interface points of complex designs, and less accurately (and more

quickly) create looser representations of less interesting areas of the design.

� Select and Shrinkwrap�Builds the Shrinkwrap feature based on selected components.

When you select a subset, you are specifying the components to be considered for the Shrinkwrap

operation. All other components are ignored, and the system creates a Shrinkwrap based on the

external surfaces of the selected components only. This is similar to creating a simplified

representation of the selected components and then shrinkwrapping that representation.

To Update a Shrinkwrap Feature
1. Select the Shrinkwrap feature from the Model Tree.

2. Choose Update Shrinkwrap from the right mouse button pop-up menu. This command forces the system to

reanalyze and recreate the Shrinkwrap feature.

Updating a Shrinkwrap Feature
As the design progresses, you may add additional components to the assembly.

When you redefine the Shrinkwrap feature and change either the Component Subset element or the Subset

Handling element, the system recreates the Shrinkwrap feature. Any references made to surfaces of the

Shrinkwrap feature that are not removed based on the recreation of the feature do not fail. Any surfaces that are

removed due to the addition or subtraction of components to be considered for the Shrinkwrap feature are

deleted from the feature, and any references to those surfaces fail.

When you redefine the Shrinkwrap feature and do not change either the Component Subset element or the

Subset Handling element, the system does not recreate the Shrinkwrap feature unless otherwise necessary (for

example, Ignore Quilts is changed). However, if, for example, additional components or assembly-level

surfaces or datum references are selected, the entire feature is recreated.

Note: The default rule for Shrinkwrap features is Consider. This means that when you recreate the Shrinkwrap

feature, the system will consider any component that contributes to the definition of the Shrinkwrap (whether

the Component Subset element has never been defined, or whether the newly added component has not been

explicitly set to Ignore).

To Create an External Shrinkwrap Feature
Using the Ext Shrinkwrap command from the DATA SHARING menu, you can create an associative external

Shrinkwrap feature. The system creates the feature in the object (part, skeleton, or assembly) currently being

modified. The external Shrinkwrap feature references geometry from an external model (part, skeleton, or
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assembly) specified during creation. All created geometry appears in the modified object.

You can use a geometry representation, but not a graphics representation, as the source model for an External

Shrinkwrap feature.

1. Choose Feature > Create > Data Sharing > ExtShrinkwrap. The EXTERNAL SHRINKWRAP element

definition dialog box opens, with the External Model element and Define automatically selected. The

LOCATE MDL menu appears.

2. Select the model from which to copy geometry:

� Click Select to select a model in an open window. If there is an assembly model in an open window,

you can select the top level as the reference model, or you can select any of its individual parts. The

model must be an assembly; you cannot select a part outside the context of an assembly.

� Click Open to invoke the File > Open dialog box to select a model on disk or in session. The

LOCATION menu appears.

3. Use the LOCATION menu to specify the external placement reference for the copied geometry.

The Shrinkwrap Attributes dialog box opens.

Note: All the elements are optional. You can automatically create a Shrinkwrap feature containing default

Shrinkwrap information simply by clicking OK.

4. In the Quality area of the the Shrinkwrap Attributes dialog box, enter an integer in the range from 1 to 10 to

specify the level of quality for the system to use when identifying contributors to the Shrinkwrap feature.

The default setting is 1. As the level is increased, processing time also increases.

5. In the Attributes area of the Shrinkwrap Attributes dialog box, select any of the following options to specify

creation attributes:

� Auto Hole Filling�The system identifies all holes or cuts that intersect a single surface and closes

those holes for the purpose of shrinkwrapping.

� Include Skeletons�The system includes skeleton model geometry in the Shrinkwrap feature.

� Include Quilts�The system includes external quilts in the Shrinkwrap feature.

� Ignore Small Surfaces�The system does not include surfaces smaller than the specified percentage of

the model's size in the Shrinkwrap model. Enter an integer (zero is the default) to specify the relative

size of the surface to ignore.

Click Done. The Shrinkwrap Attributes dialog box closes.

6. Click any of the following elements in the SHRINKWRAP element definition dialog box, and then click

Define:

� Comp Subset�Define a component subset of the assembly's components to work with.

� Subset Handling����Specify how the system will handle the specified subset of components in creating

the feature. The Subset Handling dialog box opens. Select one of the following Subset options, and

then click Done:

Shrinkwrap and Select (selected by default)�Shrinkwraps entire assembly and uses the surface

subsets from the selected components only.

Select and Shrinkwrap�Builds Shrinkwrap based on selected components.

� Additional Srfs�Select individual surfaces to be included in the current feature.

� Include Datums�Select additional datum geometry to be included in the current feature. The Misc

Refs dialog box opens. In the Add Item area of the dialog box, select any of the following types of

datum geometry to be included in the Shrinkwrap feature, and then select references of the specified

type:

Axis�Select an axis to copy.

Coord Sys�Select a coordinate system to copy.

Dtm Point�Select a datum point to copy.

Dtm Plane (selected by default)�Select a datum plane to copy.

Click OK. The references are included in the Shrinkwrap feature definition, and the Misc Refs dialog

box closes.

� Geometry Dependency�Control the dependency of the Shrinkwrap feature.

The new Shrinkwrap feature you are creating is dependent by default on referenced additional surfaces.

This means that if you change the original part from which you copied surfaces, the surfaces in the
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Shrinkwrap feature update to changes in position and size as the referenced models change.

Note: Dependency does not control whether or not newly added or removed components affect the

Shrinkwrap collection.

7. Click OK to complete the Shrinkwrap feature.

About Shrinkwrap Models
To share data with internal and external design groups and improve performance in large assembly design, you

can capture lightweight representations of models, called "Shrinkwrap models." A Shrinkwrap model is based

on the external surfaces of the source part or assembly model and captures the "skin," or outer shape, of the

source model.

Note: Exported Shrinkwrap models are not associative.

Using Shrinkwrap functionality, you can perform the following operations:

� Represent complex design assemblies with a single lightweight part

� Improve performance of large assembly modeling—a Shrinkwrap model takes much less time to load than

does a complex design

� Provide an accurate external representation of the design to other design teams, suppliers, or customers

without providing the internal design intent�allowing others to visualize the product and conduct space

claim studies, form and fit studies, interference checking, and so forth, while protecting design intent, trade

secrets, patented designs, and other proprietary information

� Create the Shrinkwrap model automatically and/or control the handling and amount of information included

in the Shrinkwrap model:

� Close holes and gaps while creating a Shrinkwrap model

� Control the level of detail of the Shrinkwrap model

� Assign exact mass properties from the original model to the Shrinkwrap model

� Include additional datum geometry referenced from the original model

� Export the Shrinkwrap model to standard formats, such as IGES, STEP, and VRML

� Assemble Shrinkwrap models to an assembly as a standard component

� Produce a Shrinkwrap model that allows visualization of a complex assembly using tools such as Pro/FLY-

THROUGH, Windchill, and the Web

To access this tool, click File > Save a Copy. The Save As dialog box opens. In the Type drop-down list box,

click Shrinkwrap. Using the Create Shrinkwrap dialog box, you can create an exported Shrinkwrap model

automatically�by letting the system consider and collect surfaces�or manually�by specifying surfaces to be

included in the Shrinkwrap model. The Shrinkwrap model is stored as a separate Pro/ENGINEER part.

Shrinkwrap Metrics

The following figure shows a normal shaded version of a model:
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Shrinkwrapping a model usually results in significant file savings, often upwards of 90% reduction in disk and

session memory usage. The percentage of file size saved varies according to the complexity of the source model

and the quality setting used to generate the Shrinkwrap model. For assemblies with a large number of hidden

components, the savings are very large. Similarly, a low- to mid-range quality setting for a surface subset

Shrinkwrap model collects a reduced number of surfaces and thus also realizes large reductions in size. The

recommended method for creating a Shrinkwrap model is to try various combinations of settings for different

models to obtain a firsthand account of the differences in file size.

Shrinkwrap Exported Models

You can create the following types of nonassociative exported Shrinkwrap models:

Surface Subset

The figure shows a full color surface subset Shrinkwrap model at level 5 quality:

This type consists of a subset of the original model's surfaces. The system collects external surfaces from a

reference model (from either a part or an assembly) and copies selected external surfaces into the Shrinkwrap

model. You can adjust the quality of the model�applying higher quality increases the amount of surfaces to be

included in the shrinkwrap. You can exclude surfaces that are smaller than a user set percentage of the model

size. You can also add further manual selections to better represent the source model.

The surface subset procvides an exact visual representation of the original model. It is the fastest Shrinkwrap

method and results in the smallest model size, one comprised of surfaces only. Each collected surface from the

exterior of the original design is copied (with its color) into the shrinkwrap model. Colors are retained. Creating

a surface subset Shrinkwrap model produces external Copy Geometry features.

Faceted Solid

The figure shows a faceted shaded Shrinkwrap model at level 5 quality:
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This type is a faceted solid representing the original model. The system collects external surfaces from a

reference model (from either a part or an assembly), computing faceted solid geometry to represent the external

surfaces.

The faceted solid Shrinkwrap model provides an approximate visual representation of the original model. It is a

single solid model, representing all external surfaces, with additional surfaces added to bridge gaps and

complete the solid. You can adjust the quality level; applying higher quality increases the accuracy of the

representation.

This is analogous to wrapping the assembly in virtual cellophane wrap and then heating it—the longer you heat

it, the tighter the skin, and thus the more accurate the representation. The tradeoff is a larger output file size. No

colors are retained. Creating a faceted solid Shrinkwrap model produces an external Copy Geometry feature and

protrusion.

Merged Solid

The following figure shows a merged shaded Shrinkwrap model at level 5 quality:

This type is based on the external components of the original model. The system merges external components

from the reference assembly model into a single part representing the solid geometry in all collected

components.

The merged solid Shrinkwrap model provides a very accurate solid representation of the original model. It is a

single solid model, accurately representing all external components—all of the solid geometry of all external

models is placed in a single part. No colors are retained. Creating a merged solid Shrinkwrap model produces an

external Copy Geometry feature and protrusion. The quality level can be changed; the higher the quality setting,

the more components get added to the merge Shrinkwrap.
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To Create a Surface Subset Exported Shrinkwrap
Model
A surface subset Shrinkwrap model is a single part�composed of a collection of surfaces and datum

features�that represents the external surfaces of a source model. You can adjust the quality level that the

system uses to collect external surfaces to copy into the Shrinkwrap model; alternatively, you can manually

select surfaces. The system creates the exported Shrinkwrap model by collecting and copying external surfaces

from the reference model into the Shrinkwrap model.

Note: An exported Shrinkwrap model is not associative—it does not update when the source model is modified.

1. Retrieve a part or an assembly (or a simplified representation of an assembly) as the source model, and

choose File > Export > Model > Shrinkwrap. The Create Shrinkwrap dialog box opens.

2. In the Creation Method area of the dialog box, select Surface Subset.

3. In the Quality area of the dialog box, specify the quality level for the system to use when identifying

surfaces to be copied into the Shrinkwrap model. Enter an integer in the range of 0 to 10 (the default value is

1).

Entering zero means that the system does not collect any surfaces. Instead, you can select surfaces manually

using the Select Surfaces selection button.

4. In the Special Handlings area of the dialog box, you can select or clear any of the options:

� Auto Hole Filling (selected by default)—The system identifies all holes or cuts that intersect a single

surface and fills those holes for the purpose of shrinkwrapping.

� Ignore Skeletons (selected by default)—The system does not include skeleton model geometry when

creating the Shrinkwrap model.

� Ignore Quilts (selected by default)—The system does not include external quilts in the Shrinkwrap

model.

� Ignore Small Surfaces (selected by default)—The system does not include surfaces smaller than the

specified percentage of the model's size in the Shrinkwrap model. Enter an integer (0 is the default).

� Assign Mass Properties—The system assigns the mass properties of the source model to the

Shrinkwrap model.

5. In the Include Datum References area of the dialog box, you can include additional geometry to be copied

into the Shrinkwrap model. Click the Select Datums selection button, and then use the GET SELECT menu

to select datum planes, points, curves, axes, and coordinate system references to include in or remove from

the Shrinkwrap model.

If you change the Shrinkwrap creation method after specifying some references, these references are no

longer displayed. If you switch back to surface subset creation, the references are again displayed.

6. In the Preview Options area of the dialog box, you can select one of the following options to view selected

surfaces:

� Real Colors (selected by default)—During preview, displays only selected surfaces, that is, the

surfaces that will be copied into the Shrinkwrap model, in their original colors. You can select invisible

(unselected) surfaces manually using the Select Surfaces selection button and, during the next preview,

these surfaces are displayed in their original colors. This method provides faster preview display.

� Gray-Orange—During preview, displays the active model in orange, with selected surfaces shown in

gray. You can select visible orange surfaces manually using the Select Surfaces selection button and,

during the next preview, these surfaces are displayed in gray. The message window provides

information in the format "X of Y surfaces have been collected."

7. In the Additional Surfaces area of the dialog box, you can select individual surfaces to be included in the

Shrinkwrap model.

Click the Select Surfaces selection button, and then use the GET SELECT menu to select surfaces to add to

or remove from those that the system selected or those that you previously selected manually using Select

Surfaces.

If you change the quality level after selecting surfaces, all surfaces that you manually selected previously

remain selected.

8. In the Output File Name area of the dialog box, specify the export output.
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The system assigns the Shrinkwrap model a default file name based on the name of the source model.

Accept the default file name in the format model_name_sw0001 or enter a new name for the Shrinkwrap

model. The system automatically appends the extension .prt to the file name. When the source model is a

simplified representation of an assembly, the default name of the Shrinkwrap model is

simplifiedrepname_sw.prt.
You can select or clear Use default template (selected by default).

9. Click Preview to display the current reference selections, to obtain graphical and textual feedback about the

subset of information that will be captured in the Shrinkwrap model. The model is displayed according to

the preview method selected, Real Colors or Gray-Orange. You can zoom in and select unselected

surfaces to include, or you can undo selections using the Select Surfaces selection button.

If you choose View > Repaint during preview, the display of selected surfaces disappears from the source

model, leaving it on display in its original colors. When you click Preview again, the selected surfaces are

again displayed.

10. Click Create. The system copies a subset of information from the source model to create a Shrinkwrap

model, saves the new part to disk, and displays it in its own window. The subset consists of selected

surfaces from the source model, along with mass properties and additional geometry according to your

specifications. The Create Shrinkwrap dialog box remains open, and the wrapped part or assembly, that is,

the source model, with its selections displayed, remains in session as the current object.

11. Click Close. The Create Shrinkwrap dialog box closes.

To Set the Quality Level for Shrinkwrap Models and
Features
You can adjust the quality level settings for exported Shrinkwrap models and for Shrinkwrap features.

The first time you raise the setting from the default value, the system displays a warning message, "At high

quality levels, performing a Shrinkwrap may take a long time and require a lot of memory. It is best to try low

levels first, and move up only if the results at those levels are unsatisfactory. You can set the configuration file

option shrinkwrap_alert to no to disable this warning."

Increasing the quality level makes for a more complete representation that contains more of the source model’s

external surfaces but also increases the creation time. The recommended method for creating a Shrinkwrap

model or feature is to set a low quality setting and preview the results, only gradually increasing the quality

level as necessary.

Faceted Solid Exported Shrinkwrap Models

Quality is inversely proportional to the size of the triangles used to create the faceted model. At a lower setting,

the system creates fewer, larger triangles more quickly, producing a roughly accurate representation of the

object’s shape. At a higher setting, the system creates many smaller triangles, producing a more detailed, more

accurate representation of the object’s shape. The system automatically joins triangles when needed to bridge

gaps. Increasing the quality level makes for a more complete representation but also increases the creation time.

The recommended method for creating a Shrinkwrap model is to set a low quality setting and preview the

results, only gradually increasing the quality level as necessary.

Merged Solid Exported Shrinkwrap Models

For a merged solid exported Shrinkwrap model: At a low setting, the system performs a rough collection of

contributing components. At a higher setting, the system performs a more accurate collection of contributing

components, producing a more accurate representation of the object's shape. Increasing the quality level makes

for a more accurate representation of the source model but also increases the creation time. The recommended

method for creating a Shrinkwrap model is to set a low quality setting and preview the results, only gradually

increasing the quality level as necessary.
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To Use a Default Template
If you have specified a default template (you can set the configuration file option start_model_dir to
specify its location and the option template_solidpart to specify the template name), the system uses

that template, or start model, for the part. Using a template as a start model allows you to include critical layers,

datum features, and views in the model.

To Create a Faceted Solid Exported Shrinkwrap
Model
Using the Shrinkwrap command from the EXPORT menu, you can create an exported Pro/ENGINEER part

that represents the geometry and spatial claims of a complex model. A faceted solid Shrinkwrap model is a

single part that is created by collecting external surfaces from a reference model (from either a part or an

assembly). A faceted solid part is based approximately on a reference model.

Note: An exported Shrinkwrap model is not associative—it does not update when the source model is modified.

1. Retrieve a part or an assembly (or a simplified representation of an assembly) as the source model, and

choose File > Export > Model > Shrinkwrap. The Create Shrinkwrap dialog box opens.

2. In the Creation Method area of the dialog box, select Faceted Solid.

3. In the Quality area of the dialog box, specify the quality level for the system to use when identifying

surfaces that will contribute to the Shrinkwrap model. Enter an integer in the range of 1 to 10 (the default

value is 1).

4. In the Special Handling area of the dialog box, you can select or clear any of the options:

� Auto Hole Filling (selected by default)—The system identifies all holes or cuts that intersect a single

surface and fills those holes for the purpose of shrinkwrapping.

� Ignore Skeletons (selected by default)—The system does not include skeleton model geometry when

creating the Shrinkwrap model.

� Ignore Quilts (selected by default)—The system does not include external quilts in the Shrinkwrap

model.

� Assign Mass Properties—The system assigns the mass properties of the original model to the

Shrinkwrap model. Mass properties cannot be assigned for faceted solid models created in VRML or

STL.

5. In the Include Datum References area of the dialog box, you can include additional geometry to be copied

into the Shrinkwrap model. Click the Select Datums selection button, and then use the GET SELECT menu

to select datum planes, points, curves, axes, and coordinate system references to include in or remove from

the Shrinkwrap model.

If you change the Shrinkwrap creation method after specifying some references, these references are no

longer displayed. If you switch back to faceted solid creation, the references are again displayed.

6. In the Faceted Solid Options area of the dialog box, you can select Invert Triangle Pairs.

7. In the Output Format area of the dialog box, specify one of the following output file formats:

� Part (selected by default)�Creates a Pro/ENGINEER part with normal geometry

� LW Part�Creates a lightweight Pro/ENGINEER part with lightweight, faceted geometry; for detailed

information about LW parts, click See Also.

� STL�Creates an STL file

� VRML�Creates a VRML file

The system assigns the Shrinkwrap model a default file name based on the name of the source model.

Accept the default file name in the format model_name_sw0001 or enter a new name for the Shrinkwrap

model. The system automatically appends the extension .prt to the file name. When the source model is a

simplified representation of an assembly, the default name of the Shrinkwrap model is

simplifiedrepname_sw.prt. The system automatically appends the extension .stl to STL file
names and the extension .wrl to VRML file names.

You can select or clear Use default template (selected by default for Part and LW Part file formats; not
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available for STL or VRML file formats).

8. Click Preview to obtain graphical and textual feedback about the subset of information that will be captured

in the Shrinkwrap model, that is, to see the previewed triangles that will be created. All triangles are

displayed, even those that are coplanar, but when the Shrinkwrap model is created, coplanar triangles are

merged. The message window also provides textual feedback, for example, "X triangles have been created."

9. Click Create. The system computes faceted solid geometry to represent the source model's external surfaces

to create a solid Shrinkwrap model, saves the new part to disk, and displays it in its own window. The

subset consists of faceted solid geometry from the source model, along with mass properties and additional

geometry according to your specifications. The Create Shrinkwrap dialog box remains open, and the

wrapped part or assembly, that is, the source model, with its selections displayed, remains in session as the

current object.

10. Click Close. The Create Shrinkwrap dialog box closes.

Lightweight Faceted Solid Shrinkwrap Parts
Lightweight parts can be created by importing an STL, VRML, or faceted Catia file, as well as by creating a

faceted solid Shrinkwrap model in LW Part file format.

Creating a faceted solid Shrinkwrap model in LW Part file format produces a new part with an LW feature.

All the surfaces of lightweight parts are planar (hence, all their edges are straight.). Lightweight parts take up

less space than equivalent Pro/ENGINEER parts would (if there were a real Pro/ENGINEER surface for each

facet). Thus, using LW Part instead of Part as the output file format for a faceted solid Shrinkwrap model

reduces the size of the result even further.

Lightweight parts can be viewed in wireframe or shaded mode. Normal HLR is not available and would be

extremely slow. However, fast HLR, which is based on shading, is available. You can also make cross sections,

or compute a whole-model projected area (because that is based on shading, as well). You can select and

assemble lightweight parts. They are not parametric or modifiable in any way.

In fact, parts are not really lightweight; features are. Using Import > Create New Model, you get a new part

with a lightweight feature in it as well as a coordinate system. You can use Import > Append To Model to

append the LW feature to the current part. Thus, a part can have both normal geometry and lightweight faceted

geometry.

To Create a Merged Solid Exported Shrinkwrap
Model
A merged solid Shrinkwrap model is a single part that represents the geometry and spatial claims of a source

assembly model. You can adjust the quality level that the system uses to collect components to copy into the

Shrinkwrap model, and you can manually select components. The system creates the exported Shrinkwrap

model by merging and copying components from the reference model into the Shrinkwrap model.

When a merged solid Shrinkwrap model has an enclosed cavity in the middle of it, the system fills it with solid

geometry.

Note: An exported Shrinkwrap model is not associative—it does not update when the source model is modified.

1. Retrieve an assembly (or a simplified representation of an assembly) as the source model, and choose File >

Export > Model > Shrinkwrap. The Create Shrinkwrap dialog box opens.

2. In the Creation Method area of the dialog box, select Merged Solid.

3. In the Quality area of the dialog box, specify the quality level for the system to use when identifying

components that will contribute to the Shrinkwrap model. Enter an integer in the range of 1 to 10 (the

default value is 1).

4. In the Special Handling area of the dialog box, you can select or clear any of the options:

� Auto Hole Filling (selected by default)—The system identifies all holes or cuts that intersect a single

surface and fills those holes for the purpose of shrinkwrapping.

� Ignore Skeletons (selected by default)—The system does not include skeleton model geometry when
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creating the Shrinkwrap model.

� Ignore Quilts (selected by default)—The system does not include external quilts in the Shrinkwrap

model.

� Assign Mass Properties—The system assigns the mass properties of the original model to the

Shrinkwrap model.

5. In the Include Datum References area of the dialog box, you can include additional geometry to be copied

into the Shrinkwrap model. Click the Select Datums selection button, and then use the GET SELECT menu

to select datum planes, points, curves, axes, and coordinate system references to include in or remove from

the Shrinkwrap model.

If you change the Shrinkwrap creation method after specifying some references, these references are no

longer displayed. If you switch back to merged solid creation, the references are again displayed.

6. In the Additional Components area of the dialog box, you can select individual components to contribute to

the Shrinkwrap model.

Click the Select Components selection button, and then use the GET SELECT menu to select components to

add to or remove from those that the system selected or those that you previously selected manually using

Select Components.

If you change the quality level after selecting components, all components that you manually selected

previously remain selected.

7. In the Output File Name area of the dialog box, specify the export output.

The system assigns the Shrinkwrap model a default file name based on the name of the source model.

Accept the default file name in the format model_name_sw0001 or enter a new name for the Shrinkwrap

model. The system automatically appends the extension .prt to the file name. When the source model is a

simplified representation of an assembly, the default name of the Shrinkwrap model is

simplifiedrepname_sw.prt.
You can select or clear Use default template (selected by default).

8. Click Preview to obtain graphical and textual feedback about the subset of information that will be captured

in the Shrinkwrap model. The message window provides information about how many components were

included and how many excluded from the representation, in the format "X of Y components have been

selected." You can zoom in and select unselected components to include, or you can undo selections using

the Select Components selection button.

9. Click Create. The system copies a subset of information from the source model to create a Shrinkwrap

model, saves the new part to disk, and displays it in its own window. The subset consists of solid geometry

collected from all collected components from the source model, along with mass properties and additional

geometry according to your specifications. The Create Shrinkwrap dialog box remains open, and the

wrapped assembly, that is, the source model remains in session as the current object.

10. Click Close. The Create Shrinkwrap dialog box closes.

About Inheritance Features
An inheritance feature allows a one-way associate merge of geometry and feature data from one part to another.

You can select dimensions in the base model for value changes both at the time of the inheritance feature

creation and later. You can select features in the base model for status changes both at the time of the

inheritance feature creation and later.

Inheritance features are always created by referencing existing parts. An inheritance feature begins with all of

its geometry and data identical to the part from which it is derived. Then you can identify the geometry and

feature data that can change on the inherited feature without changing the original part.

An inheritance feature is used similarly to a merge feature. More than one inheritance feature can be used in one

part. The following are some inheritance feature capabilities:

� Access to parameters of inherited models, its features, and their usage provided the prefix "IID_" is used.

� Access to dimensions of the inheritance feature in drawing mode as well as part and assembly mode.  This

means that inheritance feature dimensions can be shown in a drawing of the derived object, which is a

limitation if you use a merged part in a drawing.

� Multilevel nesting of inheritance features
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� Support of RefPattern

� Special Resolve Mode for inheritance failure cases

� Non-geometry elements are copied in addition to 3D Notes (GeomTols, Surface Finish, and so forth)

� Parent-child relationship

� Different dimension status including VarDims:Locked (suppressed features and so forth) and Not Applied

(for nested inheritance with independent sublevel)

To Create an Inheritance Feature
1. Open an existing standard part.

2. Click Feature > Create > Data Sharing > Inheritance or Insert > Shared Data to open the Inheritance

dialog box and the LOCATE MDL menu.

3. Use the LOCATE MDL menu to open the base model, the model from which geometry will be copied.

Initially, all data from the base model are present in the inheritance feature.

The model opens in a separate window. The LOCATION menu opens.

4. Define the placement of the inheritance feature as Default or External coordinate system.

5. Click Var Dims > Define to open the Varied Dimensions dialog box and select specific base model

dimensions. These dimensions will be added to the Varied Dimensions table. You may then change the

value of the dimension in the table by entering a New Value.

6. Use the Var Feats element definition to open the Varied Features dialog box. Select the features from the

base model that you would like to define as variable. You may then chose to suppress the variable feature

before creating the inheritance feature by using the Suppress button.  When you choose to suppress a

feature, you are prompted whether to suppress children of the feature also.  If you choose not to suppress a

variable feature upon creation of the inherited feature, you will be allowed to suppress that feature within

the inheritance feature later.

7. Use the Dependency element to make the Inheritance feature dependent or independent of the base model.

Making an inheritance feature Dependent will create a dependency between the derived object and the base

model.  If changes are made in the base model, they will be reflected in the derived object.  An independent

inheritance feature will not update when the base model is modified.

8. Use Copy Notes to define whether 3D notes will be copied to the inheritance feature.  In Pro/ENGINEER

2001, 3D notes can be copied to the derived object, but they will not be modifiable in the derived object.

Inherited 3D notes can not be deleted or erased except by using the Copy Notes option in the inheritance

feature.

About Simplified Representations
Pro/ENGINEER provides assembly tree-based tools for managing large assemblies. Simplified representations

control which members of an assembly the system brings into session and displays. You can create multiple

simplified representations for an assembly, each corresponding to an area or level of detail of the assembly

where individual designers or groups are working.

You can use simplified representation tools to simplify an assembly by excluding components in a particular

representation or substituting one component (part or assembly) for another. Substituting enables you to

simplify your working environment significantly, while still including critical geometry.

Simplified representations improve the regeneration, retrieval, and display times of assemblies, enabling you to

work more efficiently. You can use them to control which members of an assembly the system retrieves and

displays. This lets you tailor your work environment to include only the information of current interest to you.

For example, to speed the regeneration and display process, you can temporarily remove a complicated

subassembly that is unrelated to the portion of the assembly on which you need to work.

Simplified representations enable you both to conceptualize your design and to simplify the representation of

complex assemblies. Simplified representations support both top-down and bottom-up assembly design

approaches.

The top-down design approach starts with creating envelopes (or space claims) for components in an assembly,

then building detailed parts and subassemblies to fit the various envelopes. For example, in an automotive
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design you might create envelopes for the engine, transmission, and many other complex subassemblies. As

each department creates detailed designs of its subassembly, you can substitute the fully detailed subassembly

for the corresponding envelope.

The bottom-up approach starts with a complex assembly and simplifies it. One simplified representation could

serve as the "table of contents" for the design by substituting a lower level simplified representation for each

subassembly. Another simplified representation might exclude portions of the design to focus on specific areas.

The By Rule dialog box provides a collection tool for specifying the components to be included into or

excluded from the current simplified representation. Using the By Rule options, you can filter components by

rules, including zones, model names, geometric size, geometric distance, parent and child relationships, and

parametric expression.

Create simplified representation for skeletons of the assembly by using procedures described in Part Modeling

documentation.

The Definition Rules dialog box allows you to create a simplified representation and also to set up the behavior

of simplified representations in advance by defining rules and conditions. The system remembers the rules and

conditions, so that the filter's selection has the ability to update parametrically. Simplified representations

created by definition rules automatically update parametrically upon retrieval and regeneration according to

changes made to the model. These simplified representations accurately reflect the rules specified, as the design

changes.

Simplified representations are available in Assembly, Manufacturing, Part, and Drawing modes, as well as in

Pro/MOLDESIGN, Pro/CASTING, and Pro/PROCESS for ASSEMBLIES. The name of the active simplified

representation appears in the Assembly window as a label, in the form SIMPLFD REP: name.

In Part mode, use simplified representations to simplify the geometry of a part by including or excluding

individual features, defining a work region to include only the areas of interest on the part, or copying part

surfaces to create a surface "envelope."

In Drawing mode, create multiple views of an assembly using different simplified representations. You must

specify the simplified representation before adding a view.

Types of Representations

There are three main types of simplified representations: master representations, graphics representations, and

geometry representations. Designate which representation appears, using the Retrieve Rep command.

Graphics and geometry representations speed up the retrieval process of large assemblies. All simplified

representations provide access to components in the assembly and are based upon the Master Representation.

You cannot modify a feature in a graphics representation, but you can do so in a geometry representation.

Assembly features are displayed when you retrieve a model. Subtractive assembly features such as cuts and

holes are represented in graphics and geometry representations, making it possible to use these simplified

representations for performance improvement while still displaying on screen a completely accurate geometric

model.

You can access model information for graphics and geometry representations of part models from the

Information menu and also from the Model Tree. Because part graphics and geometry representations do not

contain feature history of the part model, information for individual features of the part is not accessible from

these representations.

� The Master Representation always reflects the fully detailed assembly, including all of its members. The

Model Tree lists all components in the Master Representation of the assembly, and indicates whether they

are included, excluded, or substituted.

� Graphics representations contain information for display only and allow you to browse through a large

assembly quickly; however, you cannot modify or reference graphics representations. The type of graphics

display that is available depends on the setting of the save_model_display configuration option the
last time that the assembly was saved:
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� wireframe—(default) The wireframe of the components will appear.

� shading_low (shading_med, shading_high)—A shaded version of the components will

appear. The different levels indicate the density of the triangles used for shading.

� shading_lod—The level of detail will depend on the setting in the View Performance dialog box

(access this dialog box by selecting View > Performance).

Assembly and part files store graphical and geometrical data in separate sections of the files. This division

of the data allows partial retrieval of the file and thereby improves retrieval performance.

The configuration file option save_model_display controls the amount of graphical data stored in the

assembly and part files. By default, the system always stores wireframe data in both parts and assemblies.

The system always stores wireframe data for parts. The only information that the system saves in the

assembly .asm file is the display setting of components that are intersected by assembly features. The

system also saves the tessellated data for the low, medium, high and lod options. The display setting at the

time the assembly is saved is stored in the part and assembly files.

For example, Assembly A has component P1, which is intersected by an assembly feature. When you save

Assembly A, the graphical display of part P1 is stored within the assembly file A. Component P1 also has

its nonintersected graphical display stored in its part file. When you retrieve a graphics representation of an

assembly with assembly features, the system retrieves the assembly file with all its data, including assembly

feature intersections. The system opens the part file and retrieves its relations, parameters, and graphical

data. The system then displays the intersected graphics, that is, the graphical data from the assembly file,

and has access to the parameters, and so on.

The graphics representation displays the assembly features only if newly saved. It also displays only what

was last saved with the assembly file. If parts have been modified outside the context of the assembly, the

intersected display of the part is not updated until the Master Representation of the assembly is retrieved and

then saved again with these changes.

� Geometry representations provide complete geometry for components and require more time to retrieve and

use more memory than the graphics representations. You can use them to remove hidden lines, obtain

measure information, and accurately calculate mass properties. You can also reference them when working

with assemblies. For example, you can assemble a component and mate it to a geometry representation of

another part.

When the geometry representation of an assembly is retrieved, the intersection geometry is "placed on top

of" the geometry retrieved from the part files of the intersected components. The same functionality is

available for these intersections as is available for intersections with master representations. The geometry

representation feature intersections can be referenced for the placement and creation of components and

features. Unlike graphics representations, geometry representation intersections update to changes made to

the assembly (but not changes made to the part), such as dimension modification, feature redefinition,

change in component placement, and so forth. Also, intersections can be added or removed from part

geometry representations, and new features can be created that intersect the part geometry representations.

While in a simplified representation, the system applies changes to an assembly, such as creation or assembly of

new components, to the Master Representation. It reflects them in all of the simplified representations

(Pro/PROGRAM processing also affects the Master Representation). It applies all suppressing and resuming of

components to the Master Representation. However, it applies the actions of a simplified representation only to

currently resumed members, that is, to members that are present in the BOM of the Master Representation.

Note: Simplified representations saved prior to Release 18.0 may not access all current simplified

representation and assembly functionality.

About Creating Simplified Representations
You can create a simplified representation using the Simplfd Rep command in the ASSEMBLY menu. When

you create a simplified representation, you must select a default rule for it, and then designate the way that

individual components will be represented in the new simplified representation.

To create a simplified representation, you select components and specify them for inclusion or exclusion. The

simplified representation comprises only the components specified for inclusion. You can select the components

manually or by using rules and conditions to select them automatically. The By Rule dialog box is a collection



 ProASSEMBLY (Advanced)46

tool that allows you to specify various rules and conditions for selecting models for inclusion into or exclusion

from simplified representations. Rules can be saved in the context of the assembly or the simplified

representation and can be reused whenever necessary.

Choose ASSEMBLY > Simplfd Rep > Create, and use any of the following methods to create a simplified

representation:

� Select conditions and components manually�Choose Default from the EDIT REP menu to select a default

rule, and then select the type of representation from the EDIT REP menu, and then select the components

using the SELECT MDL menu.

� Use the By Rule dialog box as a shortcut for creating a simplified representation�specify or reuse existing

rules for selection of components to include in the current simplified representation. Rules can be saved in

the context of the assembly or the simplified representation and can be reused whenever necessary.

To select components to include into or exclude from simplified representations, you can filter components

by rules. Once the simp rep is created, however, the actions of this filter are left as is, with no parametric

ability to later automatically or manually update the filter's selection. This forces users to re-create the simp

rep at a later time to effectively update to newer situations.

� Use the Definition Rules dialog box as an advanced method for setting up simplified

representations�specify various rules and conditions for selecting models for inclusion into or exclusion

from simplified representations. Rules can be saved in the context of the assembly or the simplified

representation and can be reused whenever necessary. A simplified representation with Definition Rules

automatically updates upon retrieval and regeneration according to changes made to the model.

Excluding and Substituting Components

Simplified representations either include all members except for members that you specifically exclude or

substitute, or exclude all members (except for members specifically included or substituted).

Excluding or substituting affects only the current simplified representation and alters the displayed appearance

of the assembly, but has no effect on other features or components in the assembly.

You can exclude components or subassemblies from a particular simplified representation, or exclude selected

components of an included subassembly.

If you exclude an entire subassembly, the system also excludes all of its components except those that have

other states attached to them.

Rules and Restrictions

If you want to assemble a simplified representation of a part or subassembly into an assembly, the top-level

assembly also must be a simplified representation. It cannot be the Master Representation.

In Assembly mode, when you are in a simplified representation (that is, not in the Master Representation), you

can use the Assemble, Create, Package, Delete, Suppress, Replace, Redefine, Reorder, Pattern, and Del

Pattern commands in the COMPONENT menu.

The following restrictions apply to simplified representations. From within a simplified representation, you

cannot do the following:

� Use the Restructure, Family Tab, and Integrate commands in the ASSEMBLY menu

� Use the Cutout command in the ADV COMP UTL menu

� Delete or suppress substituted components

� Redefine components that are excluded or substituted.

To Create a Simplified Representation
When you create a simplified representation, you must select a default rule for it, then designate the way that

individual components will be represented in the new simplified representation.

1. Choose ASSEMBLY > Simplfd Rep > Create. Enter the simplified representation name (without spaces).
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The DEFAULT RULE menu appears.

As you enter a new name, keep in mind that when you show a list of existing simplified representations, the

names are listed in alphanumeric order. You may wish to plan the list of names in advance, for example to

make it easier to find specific representations in a long list of items for operations such as Redefine, Set

Current, and Delete.

2. Select a default rule for components of the new representation. The EDIT REP and SELECT MDL menus

appear.

3. Select an action from the EDIT REP menu and select the components using the SELECT MDL menu. Actions

include:

� Exclude—Does not include the component in the representation.

� Master Rep—Includes/displays the component in the representation.

� Graphics Rep—Includes the component as a wireframe.

� Substitute—Substitutes the component to the default rule for the representation.

� Default—Returns the component to the default rule for the representation.

The system records your actions in the Model Tree window. If you perform an action on a subassembly, the

system applies it to the whole subassembly tree.

4. Select Update Screen to display the current state of the simplified representation in the graphics window.

Select Display Mode to display either the currently marked components or all the components in the Model

Tree window.

5. Select Done to finalize the simplified representation.

Tip: Retrieve Components Before Saving a
Simplified Representation
When you start to back up or save an assembly in a simplified representation when only a subset of the

assembly components are in memory, the system displays a warning that some required models may not be in

memory and prompts you to continue or cancel the operation. The warning appears when some components are

missing when you begin to perform a save operation such as File > Backup to a local directory, or File > Save

to a connected workspace, for example, from a local disk into an Intralink database.

You may want to bring all necessary components of the assembly into session before storing the assembly file.

Otherwise, the missing components are not saved. When you try to open the file, the system will not find the

missing unsaved components and the file will not be retrievable.

Selecting Components Using the SELECT MDL
Menu
The SELECT MDL menu appears either when you have named a new simplified representation and defined the

default rule or when you are redefining an existing representation.

This menu allows you to select components on which to apply actions from the EDIT REP menu, and displays

the following options:

� Pick Mdl—Selects a component feature in the Model Tree window.

� All—Selects all features shown in the Model Tree window.

� From/To—Selects a range of models in the Model Tree window.

� By Rule—Uses rules to select components and perform actions on them.

� By Rep—Selects models that are active in another simplified representation.

To Select Components By Rep
When creating a simplified representation, you can use the By Rep command in the SELECT MDL menu to use

components within another simplified representation. The By Rep command is a selection tool only. The new
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representation will not be updated if the representation referenced when using the By Rep command is

modified. There is no associativity created between the two representations.

When you choose the Master, Exclude, Geometry, Graphics, or Default action from the EDIT REP menu, the

system affects components in the selected representation as follows:

� If the default rule for the selected simplified representation is Master, Geometry, or Graphics, the system

applies the action to a component unless it has been explicitly excluded or substituted in the selected

simplified representation.

� If the default rule for the selected simplified representation is Exclude, the system applies the action to a

component unless it has been explicitly included or substituted in the selected simplified representation.

To Use the Default Rule
The default rule determines whether or not a simplified representation should initially include all components,

and what kind of information about those components should be available. You can then change the definition

of individual components within that framework. If you change the definition of a component, select Default

from the EDIT REP menu to return the component to the default rule.

Types of Default Rule
There are four types of default rule, as listed below:

� Master Rep—Initially includes all assembly components and makes available all information.

� Graphics Rep—Initially includes all assembly components and makes available only display information.

� Geometry Rep—Initially includes all assembly components and makes available only geometry

information.

� Exclude Comp—Initially excludes all assembly components from the simplified representation.

Note: When assembling or creating a component when a representation is active, the system always

includes a new component in the active representation even if the default rule is Exclude.

To Use the EDIT REP Menu on Selected
Components
The EDIT REP menu appears either when you have named a new simplified representation and defined the

default rule or when you are redefining an existing representation. It displays the following commands:

� Master Rep—Includes the master representation for the selected component. This command does not

appear if the default rule is "Master Rep."

� Exclude—Excludes the selected component from the current simplified representation. This command does

not appear if the default rule is "Exclude."

� Graphics Rep—Includes display information only for the selected component. This command does not

appear if the default rule is "Graphics Rep."

� Geometry Rep—Includes geometry information only for the selected components. This command does not

appear if the default rule is "Geometry Rep."

� Substitute—Substitutes another model for the selected component using the Component Substitute dialog

box. The Component Substitute dialog box displays the following options:

� By Family Table Member—Substitutes another instance from the family table of the component.

� By Interchange Assembly—Substitutes a member of a simplify interchange assembly to which the

selected component belongs.

� By Simplified Rep—Substitutes a simplified representation for a subassembly or a part.

� Default—Applies the default rule to the selected component. This removes any other setting.

� Info—For a selected component, displays an Information window listing the assembly name, component
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number, internal component ID, part name, and children.

� Definition Rules—Sets or changes the rules that define the content and settings of the components in the

display state. Opens the Definition Rules dialog box.

� Undo Last—Undoes the last action that you applied.

� UpdateScreen—Displays the simplified representation as it is currently defined.

� Display Mode—Displays in the text window a list of the components that are shown. The DISPLAY MODE

menu displays these options:

� Show All—Displays in the Model Tree window the names of all of the assembly components.

� Marked—Displays in the Model Tree window only those components set to something other than the

default rule of the simplified representation.

Example: Excluding a Component from a Simplified
Representation
The Master representation is shown below:

The figure below shows a simplified representation that excludes all parts except those relating to the frame:

The figure below shows a simplified representation that excludes all parts except those relating to the engine:

The figure below shows a simplified representation that excludes all parts except those relating to hydraulics:
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To Substitute a Simplified Representation for a
Subassembly or Part
1. Choose EDIT REP > Substitute; then select the component to substitute. The Component Substitute dialog

box appears.

2. Choose By Simplfd Rep; then click Browse. The Select a Rep dialog box appears. It lists all existing

simplified representations for the given subassembly or part.

3. Choose a simplified representation for the component. After you make your choice, the system substitutes

the indicated representation for the component.

Substituting Components
With simplified representations, you can substitute one or all occurrences of a component. In effect, when you

substitute a component in a simplified representation, you temporarily exclude the substituted component and

superimpose the substituting component in its place. Substitution of a component in a simplified representation

does not change the master assembly as does the replacement of a component using the Replace command from

the ADV UTIL menu. Substitution is merely a way to create an alternate or simplified visual representation of

the master assembly.

When you select Substitute from the EDIT REP menu and select a substituted component, the Component

Substitute dialog box appears. This dialog box allows you to select the substituting component. Methods of

substitution are available based on the substituted component you select.

The method of substitution can be one of the following:

� By Family Table Member—A member of the family table of the substituted component. When suppressing

components through a family table, the family table instructions take precedence over simplified

representation instructions. For example, when a representation is created that substitutes a component by

any method, if an instance of the assembly replaces the substituted component in the family table with a

family table member, the representation of that instance will not perform the substitute action.

� By Interchange Assembly—A member of a simplify interchange assembly to which the substituted

component belongs. If you make a substitution from an interchange assembly, the placement of the

substituting part or subassembly will be updated either according to changes in the position of the original

part or according to changes in the interchange assembly. To place the substituting component, the system

uses the placement constraints of the substituted component.

� By Simplified Rep—A simplified representation of the component. If you make a substitution from a

simplified representation of the subassembly or component, the system reflects any changes in the

subassembly simplified representation in the top-level assembly. You cannot expand the subassembly in the

Model Tree window.

Changes to the position of the substituted component might be made in other simplified representations of the

parent assembly. The placement of a substituting component in a representation is always based on the relative

placement of the substituted original components in the interchange assembly. To fully update the placement,

both the design and the interchange assemblies must be in memory. If either is not in memory, Pro/ENGINEER

uses the last stored relative placement. For every successful regeneration with new placements, it stores the new

relative placement for the component when you use Save in the File menu.

When you have substituted components in a simplified representation, you can perform the following

procedures on the substituting components while the representation is active. The system should automatically
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reflect them in the Master Representation:

� Packaging—If a substituted component is packaged and you reposition the substituting component, the

substituted component updates its position.

� Moving—If you move a substituting component, the original and its children in memory is updated as well.

If you substitute a component model for one instance of a repeated subassembly, then move the substituting

component, the system reflects the change in all instances of the subassembly, regardless of whether they

have been substituted.

� Modifying dimensions—If you select a substituting component, the dimensions of the substituted component

appear, and you can then select and modify them.

� Regenerating—If you regenerate, both the substituting component and the substituted component are

updated.

To Substitute All Occurrences of a Component in
One Action
1. Choose EDIT REP > Substitute and SELECT MDL > By Rule > Model Name. The Component Substitute

dialog box appears.

Note: You can use any selection by rule functionality. If different models satisfy the rule, the system

prompts you to select one of them.

2. Use the Component Substitute dialog box to select the substituting component. The system substitutes all

components with the same name.

Example: Substituting a Subassembly
The figure below shows the Master representation of an assembly with a complex subassembly:

The figure below shows a simplify interchange with a simplified subassembly and the complex subassembly.

The figure below shows a simplified representation with a simplified representation of the complex
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subassembly substituted:

About Selecting Components by Rule
Using the By Rule dialog box, you can specify rules for selecting components to include in a simplified

representation. You can define new rules and reuse existing rules. You can also reuse an existing rule when you

select components for a Shrinkwrap feature and when you modify a component display state.

You can use the following rules to filter components:

� Zones

� Geometric distance

� Geometric size

� Exterior Components

� Relationships

� Model names

� Parametric expression

� Skeletons of the assembly

To determine the location and model size of the part relative to the assembly, the system uses the bounding

box.

To Set New Rules for Selecting Components
You can define or designate the rules for selecting components to be included or excluded from a simplified

representation.

1. Click ASSEMBLY > Simplfd Rep > Create. Enter the simplified representation name (without spaces). The

DEFAULT RULE menu appears.

As you enter a new name, keep in mind that when you show a list of existing simplified representations, the

names are listed in alphanumeric order. You may wish to plan the list of names in advance, for example to

make it easier to find specific representations in a long list of items for operations such as Redefine, Set

Current, and Delete.

2. Select a default rule for components of the new representation. The EDIT REP and SELECT MDL menus

appear.

3. Select an action from the EDIT REP menu and choose By Rule from the SELECT MDL menu. The By Rule

dialog box opens.

4. Click New Rule.

5. Click Geometric, and define any of the following settings:

� Zone

� Distance

� Size
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� Exterior Comps

6. Click Properties, and define any of the following settings:

� Model Name

� Expression

� Comp Type

7. Click Parent/Child, and define one of the following relationship types:

� Parent

� Child

8. Click Evaluate. The system selects components that satisfy the selected rule for the current operation.

9. Click Clear to undo selections.

10. Click Close to close the dialog box.

11. Select Done to finalize the simplified representation.

Pro/ENGINEER applies the action to all components for which the rule evaluates as true. The system records

your actions in the Model Tree window. If you perform an action on a subassembly, the system applies it to the

whole subassembly tree.

To Select Components by Zone
You can select components based on their location relative to the assembly. If no zones have been defined in

this assembly, the Zone option is not available, and the Model Name option is selected by default.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Geometric, and then select Zone. In the Zones area of the dialog box, previously defined zones that

have been created in the active assembly are listed by name.

3. Select one or more zones from the list (use the CTRL and Shift keys for multiple selection).

4. Select Show Selected Zones to display zone references on the screen as they are selected.

5. Click Clear to undo selections.

6. Click Evaluate. The system selects all components that are included in the specified zones. The EDIT REP

column in the Model Tree updates the representation status of the selected components, reflecting these

selections.

Note: If a component lies in more than one zone, the system includes it in both zones. If a zone intersects a

component’s bounding box, the system includes it in that zone.

7. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

To Select Components by Distance
You can select components based on their location relative to the assembly. Using the Distance option, you can

select components by distance from a specified point or from the center point of a specified component. The

system selects all components within a sphere whose bounding boxes intersect the sphere at a certain distance

from a given point or from the center point of a given component. After you specify the center of the sphere, the

screen is updated to display both the sphere and its center point in green.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Geometric, and then select Distance. Select one of the following options from the From pull-down

list:

� Point/Vertex—Selects a vertex or datum point from which to evaluate the distance.

� Component Center—Selects the center of a component from which to evaluate the distance.

� On Surface—Enables you to use the mouse to select a point on an existing surface.

� Offset Coordinate System—Selects an existing coordinate system. You then specify the x-, y-, or z-

offset from it.

3. The selection arrow is selected by default, allowing you to select the appropriate type of reference. Select a

reference (point, vertex, component). The system provides defaults for the radius, as well as the x-, y-, and

z- offsets when appropriate.
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4. Modify the X, Y, and Z offset values.

5. Enter the radius of the sphere. The size of the sphere updates on the screen as the radius value is modified.

6. Click Clear to undo selections.

7. Click Evaluate. The system selects all models that are intersected by, or that are included within, the

sphere (defined by the radius). If you enter a new radius value, and select ENTER, the graphical display of
the sphere updates. The EDIT REP column in the Model Tree updates the representation status of the

selected components, reflecting these selections.

8. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

When you return to the Distance option, all initial default values are the last accepted values even if new

references are selected.

To Select Components by Size
You can select components by size. Using the Size option, you can specify the absolute or relative value of the

size of the model based on the length of the diagonal of the bounding box.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Geometric, and then select Size.

3. In the Relation area of the dialog box, select relative or absolute size to be considered, and specify whether

to select components with a size greater than or less than the specified value:

� Select Relative, and in the Rel Value (0-1): text box, enter a relative value for size. This value

specifies a limit size relative to the size of the top-level assembly (a value between 0 and 1, where 1

represents the size of the bounding box of the top-level assembly).

� Select Absolute, and in the Abs Value (0-1): text box, enter an absolute value for size. This value

specifies an absolute limit size relative to the units of the top-level assembly.

4. In the Operand area of the dialog box, select one of the following options

� Greater Than—Selects only models of a size that is greater than the limit.

The system applies the action to a part if its bounding box is greater than the given value.

The system does not apply the action to a part or subassembly if its bounding box is less than (or equal

to) the given value.

If the bounding box of the subassembly is greater than the given value, the system automatically

evaluates its components.

� Less Than—Selects only models of a size that is less than the limit.

The system applies the action to a part or subassembly if its bounding box is less than the given value.

The system does not apply the action to a part if its bounding box is greater than (or equal to) the given

value.

If the bounding box of the subassembly is greater than (or equal to) the given value, the system

automatically evaluates its components.

5. Click Clear to undo selections.

6. Click Evaluate. The system selects all models greater than or less than the specified size. The EDIT REP

column in the Model Tree updates the representation status of the selected components, reflecting these

selections.

7. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

To Select Components by Exterior Components
You can select components that contribute to the exterior shape of the assembly.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Geometric, and then select Exterior Comps.

3. From the Quality pull-down, select the quality level setting, in the range 1 through 4. The default is 1.

4. Click Clear to undo selections.

5. Click Evaluate. The system selects all components that contribute to the Shrinkwrap model created using

the specified quality level of accuracy. The EDIT REP column in the Model Tree updates the representation

status of the selected components, reflecting these selections.
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6. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

To Select Components by Model Name
You can select components using the model name.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Properties, and then select Model Name.

3. In the Name to Compare against area of the dialog box, enter the name of the model. You can enter a search

string. You can use wildcards to search for a name.

� The system applies the action to a part of subassembly if the name matches the string you enter.

� It does not apply the action to a part if the part name does not match the string you enter.

� If a subassembly name does not match the string you enter, the system automatically evaluates its

components.

4. Click Clear to undo selections.

5. Click Evaluate. The system selects all components (including those in subassemblies) with the specified

name. The EDIT REP column in the Model Tree updates the representation status of the selected

components, reflecting these selections.

6. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

To Select Components by Expression
You can select components by expression. Using the Expression option, you can select components using

parameters. You enter boolean expressions to be evaluated. You specify a logical expression containing

designated parameters from assembly components. You must designate parameters and save them in the model.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Properties, and then select Expression.

3. In the Expression area of the dialog box, enter the following:

� In the first text box, specify a designated parameter.

� Select an operand from the drop-down list:

!=
=
<=
=>
<
>

� Enter a value for that designated parameter.

4. Select OR or AND.

5. Click Add/Change to add the expression to the list and allow for definition of another expression, with an

OR or an AND between them. Expressions are listed as you create them.

6. Click Remove to remove an expression from the list.

7. Click Clear to undo selections.

8. Click Evaluate. The system selects all models that satisfy the expressions. The EDIT REP column in the

Model Tree updates the representation status of the selected components, reflecting these selections.

9. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

Using this selection method, the following occurs:

� The system applies the action to a part or subassembly if the parameter satisfies the expression.

For expressions using "or" (for example, type=="electrical" or cost<=10), the rule evaluates as true

if either expression is true even if the second parameter is not defined.

� It does not apply the action to a part or subassembly if the parameter does not satisfy the expression or the

parameter does not exist.

� If a subassembly has undefined symbols, the system automatically evaluates its components.
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To Include or Exclude Skeleton Models
You can select components by component type to include or exclude skeleton models. When selecting

components to use in a simplified representation, you can expand each subassembly and include the skeleton

models, and/or their components.

1. Choose By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Select Properties, and then select Comp Type.

3. Select Skeleton to select all skeleton models in the assembly.

When you create VRML output by exporting an assembly that is in session, the system exports all objects

that are in the current representation. If you do not want to export skeleton models to VRML, you can

exclude them from the representation of the assembly by clearing Skeleton.

4. Click Clear to undo selections.

5. Click Evaluate. The system selects all skeleton models. The EDIT REP column in the Model Tree updates

the representation status of the selected components, reflecting these selections.

6. Click Close to exit the By Rule dialog box, or select another rule to use to select additional components.

To View the Bounding Box
1. Select Info > Model Size.

2. Select the component for which you want to view the bounding box.

The bounding box appears in green around the component, and the message window displays the length of

the bounding box diagonal.

System Calculations Based on a Bounding Box
The bounding box is the smallest box that fully encloses the part or assembly in three-dimensional space. It

encloses all solid geometry, datums, and surfaces. When you modify an assembly while you are in a simplified

representation (for example, adding or deleting a component), the bounding box is not updated because the

system calculates it from the display outline of the simplified representation, not the complete assembly.

Therefore, the assembly bounding box is updated only when you switch to the Master Representation. If you are

working on a simplified representation, and you worked on the Master Representation previously, the system

records the bounding box correctly on the disk.

Pro/ENGINEER stores bounding boxes for part and assembly instances correctly with the generic models so

that rules apply accurately to the instances. However, it can not determine the location of parts in instances

without retrieving the instance and the generic model and regenerating them unless you are using instance

accelerator files. Online documentation for Core applications provides information about Family Tables.

Because this is extremely time-consuming, the rules applied to instances that are not in memory use the position

of the components as recorded in the generic model. This also applies to assembly features. If an assembly

feature (not visible at the part level) cuts away half of a part in an assembly, the system applies the rule as if the

assembly feature were not there.

Tip: See the Length of the Bounding Box Diagonal
from the Model Tree
You can use the Model Size column in the Model Tree window to see the length of the bounding box diagonal.

To Reuse Rules for Selecting Components
You can reuse previously defined rules for selecting components to be included into or excluded from a

simplified representation.

1. Choose ASSEMBLY > Simplfd Rep. > Redefine.

2. Select the name of the simplified representation from the Open Rep dialog box; then click OK.
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3. Select a default rule for components of the new representation. The EDIT REP and SELECT MDL menus

appear.

4. Select an action from the EDIT REP menu and choose By Rule from the SELECT MDL menu. The By Rule

dialog box opens.

5. Click Reuse Rule. This tab is available only when previously defined rules exist for the active simplified

representation (or the active component display state).

6. In the Existing Rules area of the dialog box, one of the following options is automatically selected and the

previously defined rules are listed:

� Show Rules from this Rep only�Selected by default when previously defined rules exist for the

active representation or component display state

� Show all Rules from entire Assembly����Selected by default if no rules exist for the active

representation or component display state

7. To remove a single rule from the list, select a rule and click Remove Rule. The rule is removed from the list

and deleted. The deleted rule is not recoverable.

8. Select one or more rules from the list.

9. Click Evaluate. The system selects components that satisfy the selected rules.

10. Choose the following commands from EDIT REP or EDIT DISPLAY menu:

� Undo Last�Undo any selections made in the By Rule dialog box.

11. Click Clear to undo the selections.

12. Click Close.

13. Select Done to finalize the simplified representation.

Pro/ENGINEER applies the action to all components for which the rule evaluates as true. The system records

your actions in the Model Tree window. If you perform an action on a subassembly, the system applies it to the

whole subassembly tree.

About Selecting Components by Definition Rules
Using the Definition Rules dialog box, you can specify various rules and conditions for selecting models for

inclusion into or exclusion from simplified representations. Rules can be saved in the context of the assembly or

the simplified representation and can be reused. A simplified representation with definition rules automatically

updates upon retrieval and regeneration according to changes made to the model.

A condition is a collection of rules. After you create and name a condition and add rules to it, the system

evaluates the rules when determining whether or not to select components and updates the simplified

representation status of components accordingly.

The system remembers the rules and conditions. A simplified representation created by defining rules and

conditions automatically updates parametrically upon retrieval. For example, when you create a rule for the

active simplified representation to exclude all skeleton models, whenever you retrieve that simplified

representation, the system checks the representation status of skeleton models. If you have added skeleton

models to the assembly, the system automatically changes their representation status and excludes them from

the simplified representation in accordance with the rule.

When a simplified representation has conditions and rules, and you later add new components to that simplified

representation, the system always checks and enforces the specified rules on the new components.

To Create Simplified Representations Using
Definition Rules
Each condition consists of an action and a condition name, and each condition can contain one or more rules.

The conditions appear in an editable list and are executed in bottom-up order.

1. Choose ASSEMBLY > Simplfd Rep > Create. Enter the simplified representation name (without spaces).

Or, choose ASSEMBLY > Simplfd Rep > Redefine. The DEFAULT RULE menu appears.

As you enter a new name, keep in mind that when you show a list of existing simplified representations, the

names are listed in alphanumeric order. You may wish to plan the list of names in advance, for example to
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make it easier to find specific representations in a long list of items for operations such as Redefine, Set

Current, and Delete.

2. Select a default rule for components of the new representation. The EDIT REP and SELECT MDL menus

appear.

3. Choose Definition Rules from the EDIT REP menu. The Definition Rules dialog box opens. The default rule

is displayed at the top of the dialog box.

4. In the Conditions area of the dialog box, click Add to add a condition, and select an action from the list:

� Exclude

� Master Rep

� Geometry Rep

� Graphics Rep

5. To name the condition, in the Name text box, modify the default condition name COND01. Type a name

for the condition, and click New, or click Change. The new or modified condition appears in the list of

conditions.

6. Define one or more rules for the condition.

7. You can specify multiple conditions, each with its own name and associated rules. For example, the

conditions list, displaying Action and Name, can appear as follows:

Exclude:  Bolts_size5

Geom Rep:  Engine_block

Graphics Rep:  Drive_train

8. Select a condition and use the up and down arrows to reorder the list and set priorities for the specified

conditions.

Note: The order of the conditions in the list is important. The system applies the rules in order to update the

simplified representation, from the bottom of the list upward; the lowest rule overrides those above it.

9. Select a condition and click Remove to remove that condition from the list.

10. Click Update to see the updated simplified representation in the main graphics window.

11. Click OK. The system accepts all the specified parametric rules, and the dialog box closes.

12. Click Cancel to close the dialog box without saving any rules.

Note: The system remembers all the rules and conditions specified when you create a new simplified

representation, or when you redefine an existing simplified representation to become a parametric simplified

representation. When you delete a parametric simplified representation, all the information associated with it is

of course deleted with it.

The system automatically updates a simplified representation upon retrieval, when you select a simplified

representation to redefine or to set current. When you select a simplified representation and set it current and

then choose Regenerate, the system regenerates and updates the active simplified representation. The

simplified representation does not update when the top-level assembly regenerates.

About On-Demand Simplified Representations
Simplified representations are a powerful tool that help simplify the working environment, providing improved

performance and improved understanding of assembly navigation. In Pro/ENGINEER, you can work with both

normal simplified representations and also with dynamic simplified representations that update on demand

while you are working.

You create simplified representations by defining the state of the components in each representation of the

assembly. The simplified representations remain static while you work. When you need to redefine, reroute, or

repeat components that are excluded from the simplified representation with which you are working, or in their

graphics states, you must redefine that simplified representation or retrieve a different one. Instead of

reconfiguring or switching from one simplified representation to another, however, you can also work with

simplified representations that update dynamically when demanded. You can define the conditions under which

dynamic, on-demand simplified representations update, and you can enable and disable dynamic updating.

When you enable dynamic simplified representations, the system can reconfigure your simplified

representations to retrieve and erase components on demand, that is, components that you need to reference

temporarily while you are working. The system retrieves and erases components while you work, and you do
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not have to specify components manually to include and exclude. Dynamic, on-demand simplified

representations improve performance by allowing you to work with the absolute minimum amount of

geometrical design data. The system provides additional design content as you need it. Dynamic simplified

representations allow you to work on a lightweight representation of a very large assembly while the system

dynamically takes care of Master Representations or geometry representations for objects that are needed during

workflow.

You cannot modify a graphics representation; however, if you need to do so, a dynamic on-demand simplified

representation brings a component into memory. After you finish modifying the model, you can reset the states

of the components back to their original states. This allows modification of models in the graphics state without

having to redefine or switch the current simplified representation. You can also specify whether to bring in

parents along with components. Using the On-Demand Simplified Rep Settings dialog box, accessed from the

Preferences command on the SIMPLFD REP menu, you can control the behavior of dynamic, on-demand

simplified representations. You can enable and disable on-demand simplified representations as you select a

simplified representation to open or set current.

To Define On-Demand Settings
You can define the settings for on-demand simplified representations to control what and how much to bring

into session. While you are working in a simplified representation, the system automatically configures and

updates the simplified representation according to your specified preferences and thus provides additional

component information as needed. The preferences are set as system-wide, global settings.

1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose Preferences. The On-Demand Simplified Rep Settings dialog box opens.

3. Specify on-demand information.

Select either or both of the following:

� When required, retrieve Master Rep of components to be modified (selected by default)

� When required, retrieve referenced components (selected by default)

Select the type of representation to be retrieved, and specify whether to retrieve parents:

� Master Representations (selected by default)

� Geometry Representations

� Retrieve Ancestors of referenced components

Select one or more of the following:

� Ask me for confirmation before retrievals

� Remove added components from rep when no longer required

� Automatically Erase models when no longer needed (available only when Remove added

components is selected)

� Remove components referenced for graphics selections (available only when Automatically Erase

is selected)

4. Click OK.

On-Demand Settings
The following Preference settings in the On-Demand Simplified Rep Settings dialog box allow you to tailor the

way in which the system handles the retrieval of components in excluded or graphics states in simplified

representations.

� When When required, retrieve Master Rep of components to be modified is selected, the system

retrieves the Master representation of components that are in their graphics state and are selected for

modification. The Master representation remains in session until you select Remove Components

referenced. While the components are in session, they are marked as On-Demand in the Model Tree;

however, the system treats them as normal objects, and you can make any modification or redefinition to

them.
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� When When required, retrieve referenced components is selected, the system retrieves the Master or

geometry representation of all the parents of the component or feature that is being redefined, rerouted, or

repeated, depending on whether Master Representations or Geometry Representations is currently

selected. While these retrieved components are in session, they are marked as On-Demand in the Model

Tree; however, the system treats them as normal. If you have not selected Master Representations or

Geometry Representations, you cannot modify components in their graphics state

� When Retrieve Ancestors of referenced components is selected, the system retrieves parents as well as

the ancestors (parents of parents) when any component in its graphics or excluded states are redefined or

modified

� When Ask me for confirmation before retrievals is selected, the system prompts you to select yes or no
whenever an object is retrieved that is not already in session.

Note: An object may not be visible but may still be in session on the disk; hence, the system does not

prompt for a confirmation.

� When Remove added components from rep when no longer required is selected, the system

automatically removes referenced components from the current simplified representation upon the

completion of redefinition, rerouting, or repeating. In turn, if Automatically Erase models when no longer

required is selected, the system erases from session any models that were not in session before the

redefinition or modification. Models that were already in session (whether visible or not) are not erased.

The system removes or erases only objects that are retrieved because of redefinition, rerouting, repeating, or

modifications performed using Modify > Modify Part. The system does not remove or erase models that

are retrieved because of the modification of components in a graphics state from the Model Tree or the

assembly level. To remove these components, you must select Remove components retrieved for

graphics selections (active only when Automatically Erase models when no longer required is selected).

When you modify values of components in graphics states, the changes do not take effect until the model is

regenerated in its Master representation state. Also, the changes cannot be seen visually in the graphics

model until the modified component has been saved.

Note: Regenerate the assembly after you modify a component in its graphics state before you remove the

retrieved components; otherwise, you may lose your changes.

To Open a Simplified Representation and Enable
On-Demand Updating
When you open a simplified representation, you can enable and disable on-demand updating.

1. Choose File > Open. The Open Rep dialog box opens.

2. Select a simplified representation.

3. Select Enable on Demand Updating.

This option is available only when you select a graphics or geometry representation. It is not available when

you select a Master representation.

4. Click OK. The On-Demand Simplified Rep Settings dialog box opens.

To Select a Simplified Representation and Enable
On-Demand Updating
When you select a simplified representation to set current, you can enable and disable on-demand updating.

1. Choose ASSEMBLY > Simplfd Rep.

2. Choose Set Current. The Open Rep dialog box opens.

3. Select a type of representation:

� Graphics Rep

� Geometry Rep

� Master Rep

4. Select Enable on Demand Updating.
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This option is available only when you select a graphics or geometry representation. It is not available when

you select a Master representation.

5. Click OK. The On-Demand Simplified Rep Settings dialog box opens if this is the first time a

representation has been set in the active model.

About Assembly Zones
To make large assemblies more manageable, you can define specific regions within a model, called "zones".

You can use zones to help organize the assembly. You can use zones to select components in an assembly for a

simplified representation (selecting a component based on its location), to create component display states and

to define envelope parts.

You can access this large assembly tool by using the Zone command in the ASSEM SET UP menu to open the

Zone Manager dialog box. You give each zone a name, and store it with the top-level assembly.

In the Zone Definition dialog box, you can create an assembly zone based on datum plane references or non-

datum planar references; closed assembly feature surfaces; 2-D elements such as curves; or by specifying a

distance from an entity. Zone references can come from any level of the assembly. You can define the zone to

include all components either inside or outside the boundary. You can define the datum planes or the surfaces

while you create a zone, or you can use preexisting datum planes or surfaces.

You can use flat datum planes or extruded or revolved surfaces to define what is inside the zone or outside the

zone. For example, if you define a zone to include everything on one side of a datum plane, that side is a "half-

space" of the datum plane. You can combine any number of half-spaces.

Using closed surfaces to define the boundaries of assembly zones provides powerful zone capability, allowing

you to manage almost any collection of components or any area of the assembly. You can sketch a closed

section and extrude it to get a surface with capped ends. This closed section then defines the zone’s boundaries,

and you can specify that the zone includes components that are inside or outside the quilt. The system includes

components in zones as follows:

� If a component lies in more than one zone, the system includes it in both zones.

� If a zone intersects a component’s bounding box, the system includes it in that zone.

Pro/ENGINEER provides the following methods for defining zones:

� Reference an existing assembly datum plane

� Create an assembly datum plane during zone definition

� Reference an existing assembly closed quilt

� Create an assembly closed quilt during zone definition

� Reference a non-datum planer surface

� Reference a 2-D element (a plane ,  curve, or vertex)

� Reference a distance from a 2-D element

To Create a Zone Using Datum Planes
1. Click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.

2. Click New to open the Zone Definition dialog box.

3. Accept the default name or enter a new zone name.

4. Below the reference list area of the dialog box, select the Half-Space button  from the drop-down list

box. The Half-Space button is selected by default. To define the zone using datum planes, accept the

default.

If you change the reference type after specifying some references, those references are no longer displayed.

If you switch back to that type of reference, the references appear again.

5. Click the plus sign (+) button to add a datum plane reference for defining the zone. The datum plane does

not have to be in the top-level assembly.

6. Select a datum plane by clicking the selection arrow to open the GET SELECT menu, or select the datum



 ProASSEMBLY (Advanced)62

plane in the Model Tree. The datum plane name appears in the text box next to the selection arrow. At the

same time, the nine arrows appear in the graphics window, showing which side of the datum is used to

define the zone. Direction of the arrows can be flipped with the flip button located below the reference list.

7. When there are two or more references, they have logical AND and OR and capabilities. These are

selectable with the AND and OR, buttons in the dialog box. The system maintains an order of operations

denoted by parentheses. Placement of the parentheses is not changeable. Note that OR operations are always

grouped within parenthesis while the AND operation separates operations into new parentheses.

8. When you select a reference in the References list area of the dialog box, that plane is highlighted and its

name displayed in the text box below the list.

You can select each reference to see one reference at a time highlighted.

9. You can use the minus sign (-) button to remove a reference at any time.

10. Click OK to close the Zone Definition dialog box and display the name of the new zone in the Zone

Manager dialog box or  to preview the change.

Note: The preview button works in conjunction with View > Display. You must select one of the following

options, and then click the preview button:

� Zone Refs — To preview zone references

� Zone Comps — To preview zone components

� Zone Only — To preview zone only

Features and Components Used in Zone Definition
All created features used for zone definition also appear in the assembly’s feature list and Model Tree.

If a component lies in more than one zone, the system includes it in both zones.

If a zone intersects a component’s bounding box, the system includes it in that zone.

Example: A Zone Defined Using a Plane
This zone is located on the front side (half-space) of the datum plane (ADTM1), as indicated by the direction of

the arrows.
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To Create a Zone Using Closed Surfaces
1. Click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.

2. Click New to open the Zone Definition dialog box.

3. Accept the default name or enter a new zone name.

4. Below the reference list area of the dialog box, select the Inside - Outside (quilt) button  from the

drop-down list box.

5. Click the plus sign (+) button to add a closed surface reference for defining the zone. The closed surface

does not have to be in the top-level assembly.

6. Select the surface.You can do either of the following:

� Use the GET SELECT menu to select an existing closed quilt in the assembly. The name appears in the

text box below the References list area of the dialog box.

� Choose Create to create a new surface in the assembly; the SRF OPTS menu appears. Create a new

surface feature that is a closed quilt; its name appears in the text box below References list area of the

dialog box.

7. When you select one of the surfaces in the References list area of the dialog box, that surface is highlighted

in the assembly that is displayed in the graphics window.

You can select each name to see one reference at a time highlighted.

8. Part of the reference definition is whether components inside or outside the boundary defined by the closed

surface are to be included in the zone. The default is Inside. Change the default with the flip button.

9. You can use the minus sign (-) button to remove a reference at any time.

10. Click OK to close the Zone Definition dialog box and display the name of the new zone in the Zone

Manager dialog box or  to preview the change.

Note: The preview button works in conjunction with View > Display. You must select one of the following

options, and then click the preview button:

� Zone Refs — To preview zone references

� Zone Comps — To preview zone components

� Zone Only — To preview zone only
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To Remove a Reference from a Zone
1. Click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone.

The Zone Manager dialog box appears, listing all zones defined in the assembly.

2. Select the name of the zone to be changed.

3. Click Edit. The Zone Definition dialog box opens.

4. Select the reference to be removed from the list in the dialog box.

5. Click the minus sign (-) button to remove the reference.

6. Click OK to close the Zone Definition dialog box and display the name of the new zone in the Zone

Manager dialog box.

To Redefine a Reference in a Zone
1. Click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone.

The Zone Manager dialog box appears, listing all zones defined in the assembly.

2. Select the name of the zone to be changed and click Edit.

The Zone Definition dialog box opens with the zone references displayed.

3. Select the reference to be redefined.

4. Modify zone references.

5. Click OK to close the Zone Definition dialog box and display the name of the new zone in the Zone

Manager dialog box or  to preview the change.

6. Click Done.

To Delete a Zone from an Assembly
1. Click Design Mgr > Zone or click ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.

2. Select the zone to delete from the list in the dialog box.

3. Click Delete.

4. Click Done.

To View a Zone
1. To view a zone in an assembly, click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone to open the

Zone Manager dialog box.

2. Select a zone from the list.

3. From the top level menu, click  View  to display a menu with the following options:

Show References—The defining references for the selected zone are highlighted in the graphics window.

� If the zone was defined using a datum plane, the defining plane for the selected zone appears

highlighted in the graphics window with red arrows showing direction.

� If the zone was defined using a closed surface, the defining surface is highlighted on the screen.

Highlight Comps—The components that are in the selected zone appear in the highlight color.

Show Zone Only—Only the components that are in the selected zone or zones appear in the graphics

window.

Mark Tree—Opens a column in the Model Tree for each selected zone. The column title is the name of the

zone. For each component in the tree that is in the zone, the words "In Zone" appear in the column.

4. Choose a command.

The system displays the defining references, the components, or a column in the Model Tree for each selected

zone.

To List All Zones in an Assembly
Choose Design Mgr > Zone, or choose ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.
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This dialog box lists all zones in the assembly.

About Envelopes
An envelope is a special kind of part created by the user to represent a pre-determined set of components (parts

and sub-assemblies). It is used by substituting it in a simplified representation to replace the components it

represents. Envelope parts are generally created with simple geometry and take less memory than the

components they represent. Envelope parts, when substituted in simplified representations reduce memory

usage, while still giving the user the ability of representing the geometry of the replaced components.  The

envelope can be made to look similar  to its components using the different options offered during envelope

creation. You can use envelopes to select components in an assembly for a simplified representation. To create

an envelope, use the Envelope command in the ASSEM SETUP menu or DESIGN MGR menu.

The default rule, used to create simplified representations, does not affect envelopes; the system excludes them

from the simplified representation unless you explicitly substitute them for the models that they represent.

Beginning with 2001, you can create envelopes from shrinkwraps, and you can use zones to select components

and create envelope parts.

You can use envelopes in multiple simplified representations, and display them in any representation by using

the visibility option. You can also create an envelope while a simplified representation is active, without the

entire Master Representation being in session.

Pro/ENGINEER stores envelopes as individual part files. When it retrieves a simplified representation

containing envelopes, it only retrieves the assembly file and the envelope part files. Envelope parts do not

appear in the assembly BOM. They appear in the Information window along with information concerning the

part geometry and the list of reference components. Envelopes must have both geometry and a (non-empty) list

of reference components.

Use the Envelope menu, to control the visibility of envelopes, highlight desired envelopes, list and get

information on existing envelopes.

Note: Although the system stores envelopes as part files with a .prt extension, you can only use them as

envelopes in the assembly in which you created them.

To Create an Envelope by Creating a New
Component
1. Click Design Mgr (or Set UP) > Envelope > Create. Enter a name for the envelope. The SEL MEMBRS

menu appears.

2. Using commands in the SEL MEMBRS menu, select the parts to use in the envelope. The selection

commands are the same as the ones you use for simplified representations. You may also use the From

Zone menu pick to select all components from an existing zone.

3. Click Done. The MOD ENVELOPE menu appears with Define highlighted. The Noname dialog box also

opens.

4. Click Create new component; then enter a name for the envelope part and click OK. The Creation

Options dialog box opens.

5. Create the part and locate it with respect to the assembly. Instead of creating geometry "on-the-fly," you

can select an existing component in the assembly to use as an envelope by using the Select command in the

ENV COMP menu. Since you are choosing that component as the geometry of the envelope, the system

removes it from the assembly.

To Create an Envelope by Selecting an Existing
Component
1. Click Design Mgr (or Set UP)  > Envelope > Create. Enter a name for the envelope. The SEL MEMBRS
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menu appears.

2. Using commands in the SEL MEMBRS menu, select the parts to use in the envelope. The selection

commands are the same as the ones you use for simplified representations. You may also use the From Zone

menu pick to select all components from an existing zone.

3. Click Done. The MOD ENVELOPE menu appears with Define highlighted. The NoName dialog box

opens.

4. Click Select existing assembly component; then enter a name for the envelope part.

5. Create the part and locate it with respect to the assembly. Instead of creating geometry "on-the-fly," you can

select an existing component in the assembly to use as an envelope by using the Select command in the

ENV COMP menu. Since you are choosing that component as the geometry of the envelope, the system

removes it from the assembly. This option is used only if you assembled an alternate component to the same

assembly just to be used for the purpose of an envelope.  If not, then it is recommended that you create an

envelope using one of the other options .

To Modify an Envelope
When you modify the list of members in an envelope, all simplified representations using that envelope are also

updated to reflect the changes.

1. Click Redefine from the ENVELOPE menu. The SEL ENV menu appears.

2. Choose the envelope from the list. The MOD ENVELOPE menu displays the following options:

� Define—Creates new  elements (ones that are not already defined).

� Change—Modifies envelope geometry or members. Displays the SEL ELEMENT menu with the

following options:

Name—Renames the envelope using a name that is independent of the part name.

Members—Sets up or modifies the list of substituted components. Displays the Model Tree window

and the SEL MEMBRS menu.

Geometry—Modifies geometry of an envelope part.

� Show Refs—Highlights the envelope reference components in magenta.

� Info—Displays an Information window listing information such as the Component ID, substituted

members, and envelope part name.

3. Click Change; then click Members or Geometry.

� If you choose Members, use commands in the SEL MEMBRS menu to modify the list of substituted

components in the Model Tree window. Modifying the list of components represented by an envelope

automatically updates all simplified representations using this envelope (if components are added to the

envelope, they do not appear in the simplified representation).

� If you choose Geometry, use commands in the MODIFY PART menu to modify the envelope part.

To Include an Envelope
After you have created an envelope part, you can include it in a simplified representation and automatically

substitute its reference components by using the By Envelope command in the SELECT MDL menu.

The Model Tree window marks the reference components with "Envelope: ENVLP#" in the action column.

You can still include, exclude, or substitute the components represented by the envelope explicitly.

1. Choose Substitute from the EDIT REP menu and By Envelope from the SELECT MDL menu. The SEL ENV

menu appears.

2. Choose the envelope from the list.

3. After the envelope part appears, you can explicitly select individual reference components for actions such

as Include, Default, or Substitute.

To Display an Envelope
After an envelope part appears, you can explicitly select individual reference components for actions such as
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Include, Default, or Substitute.

To display an envelope in an assembly,

1. Choose Show from the ENVELOPE menu

2. Choose an envelope from the SEL ENV menu.

The selected envelope is highlighted on the screen in magenta.

To make a particular envelope visible in any simplified representation (including the Master Representation),

3. Choose Visibility from  the ENVELOPE menu

4. Choose an envelope from the VISIBILITY menu.

To Delete an Envelope
1. Click DESIGN MGR > Envelope to open the ENVELOPE menu.

2. Click Delete.

3. Choose the envelope from the SEL ENV menu.

The system removes the envelope geometry from the representation.

About Operating on Simplified Representations
You can use the Model Tree and commands on the SIMPLFD REP menu to perform operations on simplified

representations. To access the SIMPLFD REP menu, choose Simplfd Rep from the ASSEMBLY menu.

To Set a Simplified Representation to Current
1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose Set Current. The Open Rep dialog box opens.

3. When setting a representation to be current, you can choose any pre-existing user-defined representation, or

one of the following predefined system representations from the Open Rep dialog box:

� Graphics Rep—includes the graphics representation of each part component of the assembly

� Geometry Rep—includes the geometry representation of each part component of the assembly

� Master Rep—includes the master representation of each part component of the assembly

4. Click OK, and choose Done/Return from the SIMPLFD REP menu.

To Copy a Simplified Representation
You can copy an assembly simplified representation and use it in a drawing. When you select a normal

simplified representation to copy, the Copy command allows you to perform a simple copy.

When you copy a simplified representation with definition rules, the definition rules are also copied; and when

you copy a simplified representation with on-demand updating enabled, the updating functionality is also

copied. However, a simplified representation that is defined by definition rules or that is set to enable on-

demand updating may cause instability because the contents of the representation may change as the assembly

changes. Therefore, the system allows you to copy a simplified representation without copying its definition

rules.

1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose Copy. The Existing Reps dialog box opens, displaying a list of existing simplified representations.

3. Select the simplified representation to copy.

4. If you select a simplified representation that has user-defined definition rules or that has on-demand

updating enabled, or both, the system prompts you to select one of the following:

� Current Snapshot�Copy current statuses of all components into the new Rep

A snapshot copy of the simplified representation contains the current status of all components but does

not copy the definition rules and does not enable on-demand updating.

� Rep Definition�Copy last saved component statuses into the new Rep

A rep definition copy of the simplified representation contains the last saved status of all components,
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along with the definition rules, and also enables on-demand updating if it is enabled in the source

representation.

5. Click OK. The system prompts you to enter a name for the new copy.

6. Enter a unique name, and choose Done.

If you enter a name that already exists, the system prompts for a different new name.

To Redefine Component Status
You can change the status of individual components in a simplified representation. You can redefine

components that are not substituted or excluded.

1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose Redefine.

3. Select the name of the simplified representation from the Open Rep dialog box; then click OK.

4. Make selections from the EDIT REP menu.

5. Specify the components to modify by choosing a command from the SELECT MDL menu.

6. Select the item(s) in the Model Tree.

7. Choose Done from the EDIT REP menu.

The status of the component changes on the screen and the column disappears from the Model Tree window.

Redefining or Retrieving References
If the component you are redefining was assembled in another representation, you can select another

representation. Use the Component Placement dialog box to redefine the component constraints. You must

define all references fully to redefine the component. If the system informs you that some references are not in

memory, you can use the Retr Refs button in the Component Placement dialog box to retrieve the appropriate

assemblies and parts into session. Alternatively, you can redo the constraints to assign other references to it.

To Change Component Status from the Model Tree
Note: You cannot modify the status using the Model Tree if the EDIT REP menu is active.

1. Choose Tree > Columns > Add/Remove. The Add/Remove Columns dialog box appears.

2. Select Simplified Rep from the Type pull-down menu and add Current Rep (or any of the simplified

representations listed) to the Current column list.

3. Select OK. A new column labeled Current Rep or REP000# appears in the Model Tree window.

4. Using your left mouse button, click on a simplified representation status for a component in the tree. A pull-

down list of simplified representation statuses appears at the top of the Model Tree window

5. Select a new status from the pull-down menu. The status of the component changes.

To Rename a Simplified Representation
1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose Rename. The Open Rep dialog box opens, displaying a list of existing simplified representations.

3. Select the simplified representation to rename.

4. Click OK. The system prompts you to enter a new name for the simplified representation.

5. Enter a unique name, and choose Done.

If you enter a name that already exists, the system prompts for a different new name.

To Delete a Simplified Representation
You can select and delete one simplified representation at a time, or you can select several simplified

representations at a time by dragging the mouse or by using the SHIFT or CONTROL key with the left mouse

button.

1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.
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2. Choose Delete.

The Delete Rep dialog box opens, displaying a list of existing simplified representations.

3. Select one simplified representation from the list, or extend the selection using one of the following

methods:

� Drag�Drag the mouse over one or more items while holding down the left mouse button (selects all

the items that the cursor passes over).

� Use the SHIFT key�Hold down the SHIFT key while clicking on an item to extend the selection

(selects that item and all the items between it and the last selected item).

� Use the CONTROL key�Hold down the CONTROL key while clicking on an item to extend the selection

to a nonadjacent item (adds only the clicked item to the selection.

� To deselect a simplified representation, hold down the CONTROL key, click on a highlighted item, and

release the CONTROL key.

4. Click OK�All currently selected simplified representations are deleted.

To List Simplified Representations
1. Choose ASSEMBLY > Simplfd Rep. The SIMPLFD REP menu appears.

2. Choose List.

The system displays a list of existing simplified representations in alphanumeric order.

To Retrieve a Simplified Representation
1. Choose File > Open. The File Open dialog box opens.

2. Select the name of the assembly, and then click Open Rep. The Open Rep dialog box appears.

3. Do either of the following:

� Select any of the existing simplified representations of the assembly, and then click OK to open that

representation.

� Click Create New Simplified Rep, and then click OK to open the Model Tree for the assembly and

create the new representation.

Note: If you saved a simplified representation when some of the assembly components were not in session, the

system will not find the missing unsaved components and will not be able to open the assembly file.

Retrieving Simplified Representations
Using the Open Rep command in the File Open dialog box, you can retrieve an assembly in an existing

simplified representation or create a new simplified representation as you retrieve the assembly. When

retrieving a representation of an assembly, if the representation excludes all instances of a particular component,

that component is not retrieved into memory.

The system only retrieves and regenerates models that are active in the current state; it does not regenerate ones

that are missing external references because of simplified representations. When retrieving the Master

Representation of an assembly, it brings all models into session before retrieving substitute components. It

retrieves the substitute component into session only if references to it exist.

To Open a Simplified Representation by Default
Pro/ENGINEER now provides the ability to customize the system to prompt you to select a simplified

representation to retrieve. With the configuration file option open_simplified_rep_by_default set to
yes (the default is no), whenever an appropriate object is opened, the system automatically opens the Open

Rep dialog box, prompting you to select a simplified representation to retrieve. Working with simplified

representations is recommended best practice, and presenting the Open Rep dialog box helps you avoid opening

large objects in their Master Representations by mistake, thereby tying up significant amounts of time

unnecessarily.
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Renaming a Zone
1. Click Design Mgr > Zone  or click ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.

2. Select the zone to rename from the list in the dialog box.

3. Click Rename to open the Zone Name text box.

4. Enter the new name and press Enter.

To Create an Envelope by Zone
1. Click Design Mgr (or Set UP)  > Envelope > Create. This opens the MOD ENVELOPE menu with the

Define command highlighted.

2. Enter a name for the envelope to open the SEL ENV COMP menu.

3. Click From Zone to open the SEL ZONE menu.

4. Select the name of a zone. This selects all the components in that zone for inclusion in the envelope.

5. The Noname dialog box opens. The dialog box has four methods for defining the envelope. Select one of

them:

� Create new component—define the envelope with a new component

� Select existing assembly component—define the envelope with an existing component

� Surface Subset Shrinkwrap—define the envelope with a surface shrinkwrap

� Faceted Solid Shrinkwrap—define the envelope with a faceted solid shrinkwrap

� Closed quilt zone—creates a solid part using the closed quilt defining the selected zone.

6. Enter a name for the new part and click OK.

To Create an Envelope Using Shrinkwrap Methods
1. Click Design Mgr (or Set UP) > Envelope > Create. This opens the MOD ENVELOPE menu with the

Define command higlighted.

2. Enter a name for the envelope to open the SEL ENV COMP menu.

3. Using the commands on the SELECT MDL menu to select components for inclusion in the envelope. You

may also use the From Zone menu pick to select all components from an existing zone.

4. Click Done on the SEL MEMBRS menu to open the Noname dialog box. The dialog box has 2

Shrinkwrap methods for defining the envelope. Choose one:

� Surface Subset Shrinkwrap—Define the envelope with a surface shrinkwrap. This type consists of a

subset of the original model's surfaces. The system collects external surfaces from a reference and

copies selected external surfaces into the Shrinkwrap.

� Faceted Solid Shrinkwrap—Define the envelope with a faceted solid shrinkwrap. This type is a

faceted solid representing the original. The system collects external surfaces computing faceted solid

geometry to represent the external surfaces.

5. Enter a name for the newly created part and click Done.

To Create a Zone Using a Distance from an Element
1. Click Design Mgr > Zone, or click ASSEMBLY > Set Up > Zone to open the Zone Manager dialog box.

2. Click New to open the Zone Definition dialog box.

3. Accept the default name or enter a new zone name.

4. Below the reference list area of the dialog box, select the Measure Distance button  from the drop-

down list box. This adds a reference of Undefined status as well as opening the portion of the dialog box

where you can select the entity to measure from and the distance to measure.

5. Select the type of entity to measure from on the pull-down list. They are:

� Any

� Vertex

� Point
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� Scan Point

� Line/Axis

� Curve/Feature

� Plane

� Surface

� Cable

� Part

� Subassembly

� Component Center

� Coordinate System (offset)

6. Use the GET SELECT menu to select the specific entity from which to measure.

7. Enter a distance in the text box below.

8. Click OK to close the Zone Definition dialog box and display the name of the new zone in the Zone

Manager dialog box or  to preview the change.

Notes:

� The preview button works in conjunction with View > Display. You must select one of the following

options, and then click the preview button:

� Zone Refs — To preview zone references

� Zone Comps — To preview zone components

� Zone Only — To preview zone only

� When there are two or more references, they have logical ANDand OR capabilities. These are selectable

with the AND and OR buttons in the dialog box. The system maintains an order of operations denoted by

parentheses. Placement of the parentheses is not changeable.

� When you select a reference in the References list area of the dialog box, that plane is highlighted and its

name displayed in the text box below the list.

� You can select each reference to see one reference at a time highlighted.

� You can use the minus sign (-) button to remove a reference at any time.

To Select Components by Relationship
You can select components based on their relationship (parent or child) to a selected component or group of

components. A simplified rep created using this rule regenerates quickly and can be used to evaluate the effects

of modifying a parent component without including unnecessary components.

1. Click By Rule from the SELECT MDL menu. The BY RULE dialog box opens. Click the New Rule tab.

2. Click Relationship.

3. Select an object(s) on which to base the relationships defined by the rule.

Names of selected objects appear in the Selected objects list.

4. Click Parent or Children, to define the relationship of included components to the selected object.

5. Select an object and click if you want to include All features of selected object in the simplified rep, or

One feature or component in the simplified rep

6. In the Filter Settings area of the dialog box you can decide what scope the evaluation should take. If you

earlier clicked Parent to define the relationship of included components, the following choices are

available:

� Direct Parents

� Up to Skeleton

� All Ancestors

If you clicked Children, the following choices are available:

� Direct Children
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� Down to Skeleton

� All Descendants

In all cases you define the extent to which references are evaluated:

� Local

� External

� Both

7. If you are evaluating Parents of the selected object, you can select the checkbox to Include components in

ref paths as parents.

8. Click Evaluate to investigate the results of modifying the selected component.

To Modify Envelope Geometry with Shrinkwrap
Methods
To modify an envelope previously created using the shrinkwrap option and change the envelope components,

you must redefine the shrinkwrap feature to update the geometry after you redefined its components.

1. Click ASSEMBLY > Design Mgr > Envelope > Redefine.

2. Select the shrinkwrap envelope to modify and then click MOD ENVELOPE > Change. The SEL

ELEMENT menu appears.

3. Click the Members box and then Done.

4. Click on the component subset and then click SELECT MDL > By Envelope. The component subset is

updated to include only those components selected currently for envelope.

About Interchange Assemblies
Interchange assemblies are of three types:

� Functional interchange assembly—Contains interchangeable models, that is, groups of parts and

assemblies that have the same engineering function. These parts can be exchanged for one another in the

same design assembly (using Replace from the ADV COMP UTL menu).

� Simplify interchange assembly—Contains interchangeable representations of parts or assemblies that

convey different information about an object (such as detailed, envelope, schematic, or symbolic

information). One representation of a part or assembly can be changed to another (using Substitute from the

EDIT REP menu).

� Consolidated interchange assembly—Contains parts and assemblies that can replace one another in the

design assembly as well as simplify interchange components, representing each of these functional

members.

You can place interchange assembly members on a layer. You can then blank the members for ease of viewing.

The following rules apply for creating interchange assemblies:

When you replace a component by using an interchange assembly, you preserve the parent/child relationships

between the components.

� Interchange assemblies have the name extension .asm; however, you cannot assemble an interchange

assembly into a regular design assembly.

� If you copy and rename an interchange member using the Save As command in the File menu, the system

does not create a part that you can interchange with the original.

� You should create an interchange assembly only if one is necessary. For instance, members of a part or

assembly family table are already interchangeable, using Replace from the ADV UTILS menu.

� Interchange mode replaces the former Part and Assembly mode interchange functionality. You can still use

the previous style of an interchange group created in versions earlier than Release 13.0. However, you

cannot add models created in Release 13.0 and later to interchange assemblies that were created in Release

12.0. You must create an interchange assembly in Release 13.0 or later. For replacing and automatic

assembly, you can use interchange assemblies that were created in Release 12.0.
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� Interchange assemblies created in Release 13.0 are functional interchange assemblies.

To Create an Interchange Assembly
1. Choose File > New > Assembly > Interchange and enter a name for the new interchange assembly.

2. When the configuration option use_new_intchg is set to yes (the default), the Model Tree window and

the ASSEMBLY menu appear, and you can build the interchange assembly. When use_new_intchg is set

to no, the Interchange Type dialog box opens. Click either Functional or Simplify, then click OK. The

Model Tree window and the ASSEMBLY menu appear, and you can build the interchange assembly.

To Display a List of Interchange Groups of which
the Model Is a Member
Using the Interchange command from the ASSEM SETUP menu, you can list interchange groups to which a

model belongs.

1. Choose ASSEM SETUP > Interchange. The SETUP INTER menu appears.

2. Choose Show. The SEL MENU appears, listing the interchange groups of which the model is a member.

To Remove the Reference to a Selected Interchange
Group from a Part or Assembly
Using the Remove command from the ASSEM SETUP menu, you can remove a relation reference dependency

that the model has on the interchange group.

You can remove the reference to a selected interchange group from the part or assembly. As a result, the model

no longer has the relation reference dependency on the interchange group; you are able to submit the model to

Pro/PDM without the interchange group.

When you choose ASSEM SETUP > Remove, the SEL MENU appears, listing interchange groups. The selected

interchange group no longer is available for selection by Component/Replace. However, if the interchange

group is stored later, this component is reinstated as a member.

About Functional Interchange Assemblies
For a functional interchange assembly, you must create reference tags and  then assign them to corresponding

entities on each functional interchange assembly member, in order to replace components automatically in an

assembly that uses parametric assembly constraints.

The ability to automatically exchange functionally equivalent members in an assembly is useful for several

applications. You can do the following:

� Easily replace old or obsolete members in an assembly with new ones to accommodate changes in your

design or part availability.

� Interchange different design models of two different bolts, kinds of fasteners, and so on.

� Design your assembly using concept blocks or part envelopes and later replace them with fully detailed

parts or subassemblies.

With Interchange mode, you can view interchangeable members placed relative to each other. To simplify this

view, suppress selected members of the functional interchange assembly or use layer functionality to blank

components.

Examples of Applications
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1 2

1 Exchanging two differenct designs

2 Exchanging a concept block with an actual assembly

Creating a Functional Interchange Assembly

You cannot include both a part and a subassembly in the same family table. However, using functional

interchange assemblies, you can replace a part in an assembly with a subassembly or vice versa.

For example, if you want to use different types of fasteners in an assembly, such as either bolts or

subassemblies of rods with nuts, you cannot include them in the same part family. The only way to replace one

with the other automatically is to use an interchange assembly. The following rules are important:

� When using a subassembly as an interchangeable member, be sure to establish functional interchangeability

on the subassembly itself, not on its component parts.

� When creating the functional interchange assembly, use the information obtained from the AutoTag option

to assign tags to each of the references (that is, all surfaces, axes, and datum planes used for assembly

constraint references, feature references, and so on) that were used in the assembly process. This applies to

the following kinds of references:

� Those made to the component in the context of the assembly

� Those used to assemble the component

� Those used to assemble child components of that component

� Those used to create assembly features on any level

� Those used to create part features in other components (external feature references).

These reference tags establish geometric correspondence between the assembly and the member to be

replaced.

Once you have established the correspondence, the system can use the placement constraints from the original

to place the interchanged member by automatically positioning it and all of the parts around it.

Child references are automatically updated only when you have established geometric correspondence.

You do not need to create enough reference tags to fully place a member of an interchange assembly. When you

attempt to replace a component with such a member, the Component Placement dialog box will appear. You

can specify the remaining references, leave the member packaged, or leave the member unplaced.

To Create a Functional Interchange Assembly
To create a functional interchange assembly, you replace interchangeable models in a design.

1. Choose File > New > Assembly > Interchange > Functional.

2. Choose ASSEMBLY > Component > Add. Enter the name of the first interchange member to add. The

system packages it into the assembly. Enter the name of the second interchange member.

When you are adding new members to functional interchange assemblies, you do not assemble members

with respect to one another. The system packages members into the assembly automatically. You can use

the Redefine command to move them.

3. Create reference tags.
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4. Assign the tags to corresponding component geometry.

5. You can now replace the components in Assembly mode using Replace from the ADV COMP UTL menu.

To Assign Reference Tags to a Functional
Interchange Component
Use the Reference Tag command to access the Reference Tags dialog box to assign references, or "tags," to

members of the functional interchange assembly, or to display the placement and reference information for a

selected component and its children in the reference assembly.

1. Choose the Reference Tag command from the ASSEMBLY menu. The Reference Tags dialog box opens.

2. Click Tags, and then click New

3. Enter a name for the reference tag in the Name box. The default type for a tag is GEOMETRY. This will

change once you assign the tag to a component.

4. Select one of the tags that you have created.

5. To assign a tag to a member of the interchange assembly, click Assign, and then select an entity on the first

model to reference (such as a surface, edge, curve, or axis). If you want to create a datum plane "on the fly,"

use the Make Datum command in the GET ENTITIES menu. As you assign each reference tag, the

referenced entity is highlighted in cyan.

6. Select a similar entity on the next component to reference. Continue until you have referenced each

component in your interchange assembly.

7. To redo the assignment or deassign a tag, select an entity on the model again, or click UnAssign.

To Create Reference Tags Using AutoTag
The AutoTag functionality makes it easier for you to see exactly which reference tags you need to define to

fully reference a component with respect to a particular assembly.

You can create tags for the references as you see them, view parent and child information for references, and

view the tags which you have already assigned.

1. Choose ASSEMBLY > Reference Tag > AutoTag.

2. Select a functional interchange component to use to define reference tags.

3. Specify an assembly that contains the selected component.

The AutoTag dialog box opens and displays the selected assembly in the area at the left side of the box.

4. If there is more than one occurrence of the component in the assembly, select the particular instance of the

component that you will reference.

All entities from the interchange component that are used by the assembly or by other components appear in

the dialog box.

5. Create corresponding tags by selecting a reference and entering the name of the tag for that reference.

About Simplify Interchange Assemblies
Simplify interchange assemblies are used by the simplified representation functionality to substitute a member

of the interchange assembly for any of the other members.

You can assemble, package, or create the components in the interchange and you can assign mass properties

from one representation to another. Using this functionality, the mass properties of simplified representations

with substituted interchange members can be made the same as the mass properties of the master representation.

In a simplify interchange assembly, you can create simplified visual representations of the design assembly with

the simplified representation functionality. You can define a simplified rep of the assembly and substitute

components with any other components belonging to common interchange assemblies. The ability to do this

helps you to

� Design parts in an assembly based on an envelope part that you substitute for the actual parts in the

assembly

� Calculate the mass properties for an entire assembly with just the envelopes substituted in the assembly
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As with functional interchanges, the first step in using simplify interchange assemblies is to establish

interchangeability by creating a new interchange assembly or adding a new part or subassembly to an existing

interchange assembly.

While in a simplify interchange assembly, you can add models to interchange assemblies by creating a

component or by assembling or packaging existing components to one another to establish their relative

placement.

Substituting a component is an easier process to perform than replacing a component because the system places

substitute components into an assembly based on their relative placement in the interchange, not using

parametric constraints (such as Mate, Align, and Insert).

Thus, you do not need to assign reference tags. However, the children of substituted components are not

automatically updated when you change their parents.

Simplified representations enable you to substitute individual occurrences of a component.

When you substitute a component in a simplified representation, you temporarily exclude the original

component and superimpose the substitute in its place. This alters the displayed appearance of the assembly but

does not change the master assembly.

To Assemble a Member to a Simplify Interchange
Assembly
1. Choose Component > Add > Assemble.

2. Enter the name of an interchange member to add to the assembly.

When you are adding new members to simplify interchange assemblies, the ADD INT MBR menu appears

immediately after you choose Add from the COMPONENT menu. You can use the Package command to

place simplify members, or you can assemble to the simplify interchange assembly.

3. Choose Package. Enter the name of another interchange member to add to the assembly.

4. You can now substitute either member for the other in a simplified representation in any assembly

containing one of these components.
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Example: Interchange by Assembling Members
Assembling the two components results in the interchange assembly shown below them.

To Add a New Component to a Simplify Interchange
Assembly
1. Choose Component > Add > Create. Enter the name of an interchange member to add to the assembly.

2. Define the new model. Create the component in the interchange assembly just as you would in Assembly

mode.

3. You can now substitute either member for the other in a simplified representation in any assembly

containing one of these components.
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Example: Substituting Interchangeable Components
in a Simplified Representation

1 3

2
5

4

1 Assembly, with complex subassembly

2 Assemble a complex component into an interchange assembly

3 Simplified representation with simplify interchange part

4 Substitute for the complex subassembly

5 Assemble or create a simple mocel in the interchange assembly

To Assign Mass Properties to Members of a Simplify
Interchange Assembly
Using the Assign Props command from the ASSEMBLY menu, you can assign mass properties from one

member of a simplify interchange assembly to all other members. As a result, one of the members of a group

can drive the mass properties of the other members in the group.

This causes a simplified representation with a simplified version of a part to display the same mass properties as

a fully detailed assembly. Pro/ENGINEER calculates the mass properties in that member and copies them into

all of the other members. The system uses this copied information when computing mass property information

on that model.
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1. Choose Assign Props from the ASSEMBLY menu. The ASSIGN PROPS menu contains the following

commands:

� Define—Selects one member to drive the mass properties of the group and indicates which properties

to assign. Performs calculations and stores information in the other members.

� Undo—Deletes assigned information in the other members.

� Update—Recalculates properties in the member that is driving the mass properties and stores updated

information in the other members.

� Info—Displays an Information window showing the name of the member that is driving the mass

properties and the mass property values currently stored.

2. Choose Define. The names of members in the interchange assembly appear.

3. Select a member of the group to drive the mass properties of the others, or choose Done/Return.

About Consolidated Interchange Assemblies
Consolidated interchange assemblies combine functional and simplified interchange assemblies. They contain

both functional and simplify components. Consolidation reduces your object count, and allows you to access all

interchange options from the same menu structure.

The configuration file option use_new_intchg (set to yes by default) allows you to access consolidated

interchange functionality.

If you set use_new_intchg to no, you can build only a functional or a simplify interchange assembly.

In a consolidated interchange assembly, the first component you add is, by default, a functional component.

Subsequent components can be either functional or simplified.

When you add subsequent components, you will need to specify whether the component is a simplify

component or a functional component. If you add a simplify component, you can either assemble or create the

component. You can assemble functional components, but you cannot create them.

Once you have determined the kind of component you are adding to the interchange assembly, you can perform

the same operations that you would in either a functional or a simplify interchange assembly. However, the

methods of some operations are different for simplify components.

The following rules apply for creating a consolidated interchange assembly:

� You can assemble simplify components to packaged functional components, but not functional components

to packaged functional components.

� You can reference only a functional component for creation or assembly of a simplify component.

� You cannot reference a simplify component for the assembly or creation of another simplify component.

� Simplify components can substitute only for functional components, not for other simplify components.

� You can use the same model only twice in a combined interchange: once as a functional component, and

once as a simplify component.

� You cannot add an instance of a component if the generic is already in the interchange, and you cannot add

the generic of a component if an instance is already in the interchange.

To Add a Simplify Component to a Consolidated
Interchange Assembly
After you assemble or create a simplify interchange member, you must specify which functional member the

simplify member will represent. This can be done using the Simplify Component dialog box.

Whether you are creating or assembling the simplify component, you are allowed to reference only the

functional member selected for representation.

Once the simplify member is fully defined or constrained, additional functional members can be selected, and

additional occurrences of the simplify member can be assembled relative to them.
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1. The Components page displays a list of functional components in the interchange assembly:

� Use the Add and Remove buttons to designate which of the existing functional components can be

substituted by the new simplify component.

� Use the Placement button to update the placement of the new simplify component in the assembly.

2. Use the Mass Properties page to select which mass properties to use when the new component is used in

substitution.

� Click Assigned properties of simplify component to use mass properties of the particular simplify

component.

� Click Properties of original model if it is in session to use mass properties of the component for

which the simplify component is substituting.

� Click Properties of a specified functional component to use the mass properties of a functional

component within the interchange assembly. Select the functional component from the list, then click

Compute to enter the mass properties of the functional component.

3. To associate a particular simplify component with another functional component after you have closed the

Simplify Component dialog box, you must select the main simplify node in the Model Tree and use the right

mouse button to select Redefine.

Selecting a single occurrence of a simplify component for Redefine will simply allow you to redefine its

placement relative to the functional component it is simplifying.

Note: To completely remove a simplify component from a combined interchange, you must select the main

node of the simplify component in the Model Tree for deletion.

About Environment Reference Control
Pro/ENGINEER provides reference control tools for specifying system behavior when you create external

references among features in a design.

Using the Reference Control command in the Utilities menu, you can specify global settings that apply to all

components in the current session except objects that have an object-specific scope setting and objects that have

a less restrictive object-specific scope control. These settings are runtime; that is, they apply only during the

session in which they are set. They do not affect the internal database of the object.

You can also specify object-specific scope settings and reference control. This information is stored with the

object and is in effect for each assembly in which the object appears.

The Reference Control dialog box first opens with an Environment settings area containing a Scope of

Components to be Referenced area and a Reference Handling area. These options allow you to control scope

control. In addition, when you click Selection Feedback Settings, a drop-down area opens, containing two

Color Feedback options and two Selection options.

Using the Reference Control dialog box, you can specify global environment settings to control scope, reference

handling, reference selection, color feedback during selection of references:

� Publish Geometry Settings—Checking this box activates an additional Publish Geometry filter. This filter

is used in conjunction with the four scope settings, restricting them further.

� Scope of Components to be Referenced—In the Environment settings area of the dialog box, you can

define a scope where creating external references to other models is allowed in the context of an assembly,

manufacturing model, or process plan.

� Reference Handling—In the Environment settings area of the dialog box, you can specify how the system

behaves when you attempt to create an external reference that violates the defined scope. The external

references are controlled for both feature and component assembly constraint references.

� Color Feedback for Out-of-Scope References—In the Selection Feedback area of the dialog box, you can

enable highlighting to distinguish between components available for referencing and components that are

not available for referencing.

For example, the system highlights (or reshades) all invalid components (that are either prohibited, or from

which local copies must be made) in user-defined colors. The models that are out of scope and available for

copying are highlighted in a user-specified color while you are selecting geometry items for referencing.
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Selection Options for Out-of-Scope References—You can disable the selection of out-of-scope references

or of components that are either prohibited or from which local copies must be made.

To Define Object-Specific Reference Control
In addition to the global environment scope settings, you can specify a particular scope setting and reference

handling scheme for a particular object. The information is stored with the object and is in effect for each

assembly in which the object appears.

You can use any of the following methods to control the reference scope and handling for a component:

� Use Set Up > Ref Control to set the reference scope and handling for a part in Part mode.

� Use Modify > Mod Part > Ref Control to set the reference scope and handling for a part within an

assembly.

� Use Modify > Mod Subasm > Design Mgr > Ref Control to set the reference scope and handling for a

subassembly within an assembly.

� Open the Ref Control column in the Model Tree, and then use the right mouse button to select Ref Control

for a part or subassembly within an assembly.

Each of these methods opens the External Reference Control dialog box. The dialog is divided into two areas:

Incoming References and Outgoing References.

The Incoming References tab of the dialog box refers to setting the allowable references of the current model to

be used by other models. Outgoing references refer to setting the allowable external references from other

models when working in the intended model.  This tab includes external references for feature creation, and also

allowed component placement constraint references.  Settings are the same as for environmental reference

control. If there are object-specific settings, as well as an environmental setting for scope control on an object,

the system enforces the more restrictive setting for the object.

Incoming References

� All—Allow external references to any component.

� Inside Subassembly— Allow external references only to components within the same subassembly.

� Skeleton Model— Allow external references only to the skeleton of high level subassemblies.

� None—Allow no external references.

You may choose to use backup of forbidden references by selecting the Backup Forbidden References check

box.

Outgoing References

Geometry Allowed for Referencing

� All—Allow external references to any geometry in the model.

� Published Geometry— Allow external references to published geometry in the model.

� None—Allow no external references.

Allowed Placement References

� All—When assembling this model, allow all geometry to be used a component constraints

� Component Interfaces—Allow only component interfaces to be used as component constraints

� None—Allow no geometry to be used a component constraints (Fix of Default must be used).
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Tip: View Object-Specific Settings from the Model
Tree
You can see current object-specific reference control settings for each model in the Ref Scope column of the

Model Tree window.

To Define Global Reference Scope Control Settings
Using the Scope of Components to be Referenced area of the Reference Control dialog box, you can specify

one of four settings to control which models can be externally referenced in an assembly: All, Subassembly,

Skeleton Model, or None.

Note: The reference capability of a skeleton model is not affected by the scope setting of its associated

subassembly.

Choose one of the following settings:

� All�Allow external references to any other component. The All setting allows any external references

to be created. This setting is equivalent to having no scope control at all.

For Part—The part can make external references to any other part, subassembly, or skeleton model in

the assembly.

For Subassembly—The subassembly can make external references to any other subassemblies, parts,

or skeleton models in the assembly.

For Skeleton Model—The skeleton model can make external references to any other skeleton model,

part, or subassembly in the assembly.

� Subassembly�Allow external references only to components of the same subassembly.

For Part—The part can make external references to other parts that are in the same subassembly object

anywhere in the assembly as the part being modified, to subassemblies and their subcomponents that

are in the same subassembly as the part being modified, and to the skeleton model of the subassembly

to which the part being modified belongs.

For Subassembly—The subassembly can make external references to other subassemblies and their

subcomponents that are in the same parent subassembly as the subassembly being modified. Also, the

skeleton model of the parent subassembly can be referenced, as well as any parts that also exist in the

parent subassembly.

For Skeleton Model—The skeleton model can make external references to any parts or subassemblies

(and their subcomponents) of the subassembly to which it belongs, and also to those of a higher-level

subassembly to which the subassembly belongs.

� Skeleton Model�Allow external references to skeleton models only.

For Part—The part can reference the skeleton model of the subassembly to which it belongs, or any

higher-level skeleton model that is its direct ancestor.

For Subassembly—The subassembly can reference the skeleton model of the parent subassembly to

which it belongs, or any higher-level skeleton model that is its direct ancestor.

For Skeleton Model—The skeleton model can reference any higher-level skeleton model that is its

direct ancestor.

� None�Allow no external references.

For Part—The part cannot have external references. Part features can reference only other features in

the part being modified.

For Subassembly—The subassembly cannot have external references. (References to its own

components and their subcomponents are allowed). Assembly features can reference only other

features in the assembly being modified.

For Skeleton Model—The skeleton model cannot have external references.
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Example: The Scope Settings of Subassembly and
None
The illustration shows the Subassembly reference control scope setting:

41

52
3 6

1 Assembly

2 Modified component

3 Allowed scope

4 Skeleton model

5 Modified component

6 Allowed scope

The illustration shows the None reference control scope setting:

41

52
3 6

1 Assembly

2 Modified component

3 Allowed scope

4 Skeleton model

5 Modified component

6 Allowed scope
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To Channel All External References Through
Skeleton Models
You can use reference control settings so that only external references via skeletons from the top downward are

allowed:

1. Create a skeleton for each subassembly.

2. Set an object-specific reference control None/Prohibit Out-of-Scope References to each subassembly

model.

3. Set an object-specific reference control Skeleton Model/Prohibit Out-of-Scope References to each

skeleton model.

These reference control settings are stored with the assembly and are not environment dependent.

To Prohibit or Copy Out-of-Scope External
References
In the Reference Handling area of the Reference Control dialog box, you can specify how the system behaves

when you attempt to create an external reference to a model that is outside the specified scope.

The following options are available when the scope is set to Subassembly, Skeleton Model, or None:

� Prohibit Out-Of-Scope References—The system aborts the action if you attempt to create an external

reference that violates the scope. The system also displays a message identifying the model whose

scope has been violated.

� Copy Out-Of-Scope References—The system allows you to create out-of-scope references as a local

copy only.

If you attempt to create an external reference that violates the specified scope, the system displays a

warning. You can then either abort the reference creation or explicitly copy such an out-of-scope

reference.

If you copy a reference, the system copies its local copy automatically to the part or assembly and

references this local copy (but still checks for changes to the parent reference when it is in session).

Keep in mind that this local copy is not visible. A feature with a local copy looks and behaves like any

other feature. The only difference is that if its reference parent is not in session when you retrieve the

part with the locally copied reference, the feature reference is temporarily frozen and the system uses

the local copy. When the parent reference is again in session, the dependency returns.

Note: The system cannot create an internal local copy of external dependencies for some feature types,

such as cut out, merge, gather, copy surface, trim, extract, split, and shadow.

To Set Color Feedback for Out-of-Scope External
References
Using the Color Feedback for Out-of-Scope Refs area of the Reference Control dialog box, you can define a

color for displaying out-of-scope components during reference selection. You can also specify settings to turn

this color display on and off.

Scope color display in selection mode is independent of the environment cosmetic color setting. If you switch

off the environment setting (Model Display/Color), color scope feedback highlighting still applies.

The following options are available:

� Change color of prohibited—Selecting this check box causes the color of out-of-scope prohibited

references to change to the user-specified color during reference selection. Click the button next to this

option to display the Color Editor dialog box, and set the user-defined color. A bitmap on this button

shows the current user-defined color for these references.



 ProASSEMBLY (Advanced) 85

� Change color of allowed to copy—Selecting this check box causes the color of out-of-scope

references that are allowed as local copies to change to the user-specified color during reference

selection. Click the button next to this option to display the Color Editor dialog box, and set the user-

defined color. A bitmap on this button shows the current user-defined color for these references.

Selecting this check box also selects Change color of prohibited if it is not already selected.

To Set Selection Options for Out-of-Scope External
References
Using the Selection Options for Out-of-Scope Refs area of the Reference Control dialog box, you can disable

the selection of out-of-scope references. These settings apply during reference selection and also during other

kinds of selection such as Pick, Query Sel, and Sel by Menu.

The following options are available:

� Disable selecting prohibited—Selecting this check box makes it impossible to select out-of-scope

prohibited references—these references are not selectable.

� Disable selecting allowed to copy—Selecting this check box makes it impossible to select out-of-

scope references that are allowed as local copies—these references are not selectable.

Selecting this check box selects Disable selecting prohibited if it is not already selected.

Selection settings do not apply for the following exceptions:

� Selecting reference parts for merge or cut out functionality using Component > Adv Utils commands

� Using multiple models; that is, using the same part in several assemblies and trying to modify one of the

parts or assemblies

When the same model is used in the same top assembly a number of times in different locations on different

levels, creating any external reference is unsafe and may cause unpredictable results. For such assemblies,

using reference control usually means that any external references are prohibited, usually because an

allowed reference for one location violates reference control for another location. However, when the same

model is present in the same top assembly a number of times but only under the same subassembly,

references inside the subassembly can be allowed.

To Replace or Prevent Missing Locally Copied
References
When the locally copied references that are backed up are missing in the original part (if, for example, they

were deleted or suppressed), the feature that depends on that reference fails the regeneration.

� You can redefine or reroute a missing reference and select a replacement reference.

� You can prevent features with backed up references from failing when a reference is missing by setting

the configuration file option fail_ref_copy_when_missing_orig to no. This automatically

freezes all copied references with missing parents.

Tip: View the Status of Locally Copied References
from the Model Tree
When you have set the configuration file option fail_ref_copy_when_missing_orig to no, you can

view information on the status of locally copied references in the Copied Refs column of the Model Tree

window.

To Specify Default Scope Settings
You can use the following configuration file options to specify the default settings for external reference scope,
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out-of-scope reference handling, and reference scope modification.

Note: A license for Advanced ASSEMBLY Extension is required to set and redefine settings. With the license,

all configuration file options are effective; without the license, only the configuration file option

ignore_all_ref_scope_settings is effective.

� To specify the default settings for the reference control environment, set the configuration file option

default_ext_ref_scope to all (the default), none, skeletons, or subassemblies.

� To specify the default setting in the Reference Control dialog box for reference handling, set the

configuration file option scope_invalid_refs to prohibit or copy.

� To set the default reference scope and not allow anyone to change that setting from inside the

Pro/ENGINEER interface, specify the appropriate value for default_ext_ref_scope. Then set the

configuration file option allow_ref_scope_change to no (yes is the default). You cannot use this

option unless you have set default_ext_ref_scope.

� To specify the default settings for the reference control in a new object, set the configuration file option

default_object_scope_setting to all (the default), none, skeletons, or subassemblies.

� To specify the default setting in the Reference Control dialog box for reference handling of new objects, set

the configuration file option default_object_invalid_refs to prohibit or copy.

� To control whether users can change the scope setting of components, set the configuration file option

model_allow_ref_scope_change to yes or no.

� To ignore object-specific reference scope settings, set the configuration file option

ignore_all_ref_scope_settings to no (yes is the default). The Environment scope settings will

still be enforced.

About Reference Investigation
From the Info menu and from the DESIGN MGR menu, you can access the Global Reference Viewer when

working on individual parts or assemblies. This tool provides a means to investigate the current model's

references, as well as other models in the same assembly, enabling increased management of design intent. By

using filters, you can customize the contents of the Reference Viewer to show only dependencies of interest.

You can identify external references and, if any are unwanted, you can either reroute or redefine the feature to

break the dependency.

You can use the Global Reference Viewer to identify the features in a model that have external or local

references and the chain of dependencies from the feature to the referenced entity. You can also obtain

information about the models that have external or local references to a specified model.

The Global Reference Viewer also provides information about relation references. With the Relations reference

type as a filter, you can investigate model and feature relations and you can filter to investigate local and/or

external references created by relations.

The Global Reference Viewer allows you to understand fully the relationships among various models,

components, and features in an efficient and flexible manner. The Reference Graph, a graphical window

accessed from the Global Reference Viewer, displays relationships in the form of a tree and uses arrows to

present multiple dependencies in an easily viewable form. The Reference Graph can display multiple levels of

parents and children at one time, allowing you to see an entire assembly structure and all interdependencies

among all models.

The Parent/Child allows similar access to reference information for just one model.

Investigating References and Dependencies

The Global Reference Viewer allows you to investigate three types of references, or dependencies, in an

assembly: feature references, relations references, and component references.

Feature References

Feature references are the dependencies between different features in a design, created in the context of a single
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part, or in the context of an assembly.

Feature dependencies can be local references or external references. Local references are created by features

that only reference geometry of the model in which they were created. External dependencies are created by a

feature referencing some geometry which does not belong to the model where the feature is created. For

external references, the assembly where the two components existed when the dependency was created is

another important characteristic of the dependency.

For example, an assembly cut intersecting the assembly components and using their geometry is a local

reference in the context of this assembly. However, if an assembly feature of a subassembly component

references geometry outside the subassembly, such as a top-level part component, then this type of reference is

considered external for the subassembly.

If a feature is set as current, all models that are referenced by this feature or that are referencing this feature

appear in the Parent and Children trees. You can expand these models to show the features that participate in

dependencies with the current feature. If a component is set as current, all parents and children of its features

appear.

Models that have only placement dependencies do not expand to features because their features do not

participate in the dependency (exceptions are feature relations using external parameters and merge references).

Relations References

Relations references consist of dimensions and parameters that are used in relations. The Relations references

filter setting displays objects with dependencies resulting from relations. Note that no information about local

symbols is given, and the system does not supply any other information about relations here. The Global

Reference Viewer is not designed for investigation of relations but only for an investigation of references

created in relations and references that were created in Pro/PROGRAM to other objects.

Relations references displays relations using parameters and dimensions from other models or features. For

example: if the following symbols are used in the relations of a specified feature:
feat_param:FID_DTM1, surf_param:sid_surf1, model_param:5

the feature DTM1, the Surface surf1, and the model that corresponds to session id 5 are displayed as parents of

this feature when you use the Relations references setting as a filter.

As with parameters, relations can belong to various objects: assemblies, skeletons, parts, features, and patterns.

Because patterns can have relations (P52:2 = P6:9, for example), and accordingly, can now have parents, the

Global Reference Viewer also shows patterns, as does the Model Tree, so that they can be expanded to show

their contents (the features that they contain).

Because a relation can be maintained without the assembly, the full path for a relation appears in the following

format:

Relation d54:4 = d42:2 + 10 --> Cut id 496 --> A_WHITE_BRASS_CONNECTION.PRT
-->
A_CYL_END_TOP.PRT --> Protrusion id 323 --> Dimension d42:2

Component References (Placement Dependencies)

Component references are references used to place a component in an assembly. These references are created

when components are placed relative to one another in an assembly. When you add a part to an assembly, the

system creates a component feature in the assembly to remember the part that is included in the subassembly, as

well as the part entities and assembly entities that were used to place the part.

External placement dependencies occur when some geometry that does not belong to the subassembly or its

components is used in placing a component of a subassembly. When you investigate a component reference,

you may find an external reference exists because the component belongs to one subassembly but has been

assembled to a component that does not belong to the same subassembly. If such an external reference is used

for placement, the design intent of the subassembly is unclear outside the context of the higher level assembly

in which the reference was created. Also, the subassembly will always have an external dependency to this

parent assembly, making it difficult to reuse in other designs.

Local placement dependencies occur when placement uses geometry of components of the same subassembly
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(or their subcomponents).

When you set a subassembly as current, the system first considers it as a component and checks whether its own

placement in a higher level subassembly is using some external geometry (in the context of the higher level

subassembly); then it checks components of the current subassembly (only its own components) to see if it is

using some of them for placement geometry out of the current subassembly.

External References

When investigating dependencies in an assembly, features may exist that were created in the context of another

assembly. Therefore, these external dependencies point to a component in another assembly.

In the case when the other assembly is in session, the corresponding parent (or child) component has a name of

the assembly next to it in parentheses, for example, PARENT.PRT (OTHERASM). Setting such an object as

current replaces the current assembly tree with a filtered tree of OTHERASM.ASM. You can investigate other

dependencies in the context of this assembly. When you select a previous item from the first assembly tree, you

restore the tree of your initial assembly.

In the case when the other assembly is not in session, the system cannot determine which component inside this

other assembly participates in an external dependency. It can only show the other assembly as the context of the

dependency. You then see the following parent OTHERASM.ASM (you cannot show a child from another

assembly that is not in session). If you select this parent and try to set it as current, the system tells you that you

should retrieve the assembly first. If you confirm this, the Global Reference Viewer automatically retrieves it

and shows its tree. The system behaves then as described above for an assembly that is in session.

To Investigate References
1. Choose Info > Global Ref Viewer (for the top level assembly or in Part mode); or choose ASSEMBLY >

Design Mgr, and then choose Global Ref Viewer from the DESIGN MGR menu (for the current assembly

level). The Global Reference Viewer dialog box opens.

To activate the Global Reference Viewer for a subassembly, from the ASSEMBLY menu choose Modify,

then Mod Subasm, select an assembly, and then choose Design Mgr, and then Global Ref Viewer.

2. Use the Filter settings to specify the references to be displayed in the Reference Graph.

3. In the Current Object browser, select the object to investigate. You can double-click an object, or select an

object and then choose Set Current from the Actions menu or from the Model Tree pop-up menu.

4. Click Show/Hide Reference Graph in the Current Object area of the dialog box. A window opens,

containing the Reference Graph, a graph representation of the assembly structure. This window contains the

same contents as the Model Tree, including all collapsible and expandable objects, as well as the menu bar

with a File and a Tree menu, with the same contents in them as in the Model Tree. However, all nodes can

be moved independently around the graph window, for the sake of better groupings and visualizations. The

current filter setting is identified in the blank space at the top of the Main Tree, for example, Objects with

Parents due to External and Local Feature References.

5. Select the [+] icon next to a node, or use the Tree menu to expand the linkage branch to investigate

references. Select an assembly node in the Global Reference Viewer, and choose Tree > Expand > Branch.

6. You can highlight references that exist in the assembly and investigate them to identify their cause. Choose

Tree > Highlight and select an object. The Current Object pull-down lists objects in the filtered Model

Tree. The selected component highlights on the model, appearing in the default highlight color in the

assembly on the graphic screen.

7. You can investigate the specific external reference of the selected component. Select a component or feature

to investigate, and then set it as current either by choosing Actions > Set Current or by double-clicking that

object in the tree.

Note: Right-click an item in the tree to access commands in the Actions menu directly.

8. Choose Actions > Full Path to open the Full Path window for the current object.

9. Choose Actions > Info to open the Info window for the current object.
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Using the Global Reference Viewer
The Global Reference Viewer dialog box provides access to the Reference Graph, a graphical representation of

a filtered version of the Model Tree of the assembly that you are working on. The Global Reference Viewer

allows you to set the filter for the objects displayed in the tree, specify whether parents or children or both are

displayed, and select a component for investigation, and open the following:

� Reference Graph� Main Assembly Structure Tree and a Parent/Child Tree

� Full Path window—Displays information about the path of the reference.

� Info window—Displays other information about references.

The following menus and areas are available:

File—This menu allows you to exit or close the Global Reference Viewer.

� Save As Text—Save tree view as a text file.

� Close—Close the Global Reference Viewer and keep all reference information. The Global Reference

Viewer opens faster next time. When the assembly is changed, the Global Reference Viewer

information is updated automatically. For large assemblies, this can occupy quite a bit of memory,

however, save significantly on performance.

� Exit—Exit from the Global Reference Viewer and erase all information. If you open the Global

Reference Viewer again, it will need to reinvestigate all references. However, memory which would

have been occupied by reference information is available.

Tree—This menu determines the displayed Model Tree through the following options:

� Expand—Expand the whole tree, an entire branch of the tree, or one particular model on the tree.

� Collapse—Collapse the whole tree, an entire branch of the tree, or one particular model on the tree.

� Show Parameters—Show dimensions and parameters in the Global Reference Viewer tree when the

filter is set to Relations.

� Entities—Show entities in the Global Reference Viewer tree.

Features/Components—Shows features as well as components in the Global Reference Viewer.

Suppressed—Shows features or components that are suppressed.

Excluded—Shows features or components that are excluded.

Filter—Opens the Tree Filter dialog box.

� Search—Locates parents and children.

� Columns—Displays Info Columns in the Global Reference Viewer.

� Highlight—Highlights objects (such as assemblies, components, and features) in the graphics window

to allow you to graphically view their location.

Actions (available when an object is selected)—This menu opens dialog boxes or windows with the following

commands:

� Set Current—Sets the selected object as the current object. Calls or updates the Parent and Child

References window to display the selected component or feature as current for investigation.

� Relations—Shows the relations between references.

� Info—Shows information about the current object's references. Displays information about specified

external and/or local (depending on the filter setting) dependencies of a selected component or feature.

� Feature Info—Shows information about the dimension when the part is selected.

� Full Path—Shows the full path between the referencing features and the referenced entities. Shows

external and/or local (depending on the filter setting) reference chains or threads, detailing the path that

the reference traverses.

� All Full Path—Shows the full path for all referencing features in the object. Shows external and local

reference chains or threads for all references in the current view.

Filter Setting—This area of the dialog box allows you to specify the categories of objects whose references are

to be displayed in the Main Tree of the Reference Graph.
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Notes:

� If the Global Reference Viewer dialog box is on the screen, you cannot modify the assembly.

� If you close the Global Reference Viewer (using File>Close) and open it again in the same session, it keeps

the reference information and updates only the changes to the assembly. If you exit the Global Reference

Viewer (using File>Exit), it throws away the reference information and needs to reinvestigate the entire

assembly when you open it again. However, this frees all the memory that the Global Reference Viewer was

using, and may improve performance while you are not working in the Global Reference Viewer.

� If you choose a command from a Pro/ENGINEER menu while the Global Reference Viewer dialog box is

open, the Global Reference Viewer automatically closes. However, you can select information options from

the Model Tree pop-up windows without exiting the Global Reference Viewer.

Tip: Display External References Only
If you set the configuration file option erv_show_external_only to yes (the default is no), the Global

Reference Viewer does not collect information about local references and represents external references only.

This will increase performance, allowing the dialog box to open much faster, especially for large assemblies.

To Filter the Reference Viewer Display
The Global Reference Viewer allows you to view feature references, relations references, and component

references. To view these dependencies, you can filter the reference scope to display local, external, or all

references, and you can filter the displayed objects to display objects with parents, objects with children, or all

objects.

References created by relations can be both external and local. You can view both. When you investigate

dependencies created because of relations, all components and features that have dimensions involved in

external relations are displayed.

� If you choose Objects with Parents, only features and components that contain relations (which use

dimensions from other objects) are displayed.

� If you choose Objects with Children, only features and components that contain dimensions that are used

elsewhere (by children) are displayed.

You can view these types of placement references separately by selecting Component in the Filter Setting area

of the Global Reference Viewer dialog box and Component as the Reference Owner Type in the Parent/Child

Tree dialog box.

1. Click Filter Setting.

2. Select Ref Type, and select one of the following:

Ref Type identifies how the reference was created. Select one of the following:

� Feature—Displays objects with feature dependencies, that is, features that are children or parents.

� Relations—Displays objects with dependencies resulting from relations.

� Component—Displays components with dependencies resulting from placement.

Ref Extent indicates the extent of the reference, local or external. Select one of the following:

� External—Displays only objects with external references.

� Local—Displays only objects with local references.

� All—Displays objects with either local or external parents and children.

Displayed Objects allows you to show parents, children, or both. Select one of the following:

� Objects with Parents—Displays only objects that are dependent upon other objects.

� Objects with Children—Displays only objects that are referenced by other objects.

� All Objects—Displays all objects.

To Use the Tree Filter Dialog Box
You can use the Tree Filter dialog box to select features by type to display.
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1. Click one of the tabs: General, Cabling, or Piping.

2. Select or deselect any of the features listed on the current page of the dialog box, or click the Select all or

Unselect all buttons.

3. Click OK.

The selected types of features are displayed or removed from the display in the Global Reference Viewer.

To Show Dependencies in the Reference Graph
In the Reference Graph, a red arrow next to the part icon indicates the active component that has been set

current, and dependency arrows indicate parent features.

1. Set a node to current, and click the right mouse button on an item in the tree to access commands on the

pop-up menu:

� Show Parents�Shows components and features

� Show Children�Shows components, features, and entities

When you choose one of the above commands, dependency arrows appear, connecting the icons from

parents to children. Arrows appear whenever you display parents or children and remain on the graph until

you close the graph or select Repaint Graph.

2. Expand unexpanded nodes.

If an arrow needs to be created to point to a nondisplayed object (for example, a feature inside a

nonexpanded part), the arrow will be created directly to the unexpanded node (the part). If you then expand

the part, the arrow will update and point at the appropriate feature within the part. If the feature is then

expanded, the arrow will point to the appropriately referenced entity. Note: Only the referenced entities

within a feature will be shown, to reduce the unnecessary content in the Reference Graph.

3. If an external reference is shown, a node will be made for the model containing the external reference.

4. If you collapse a node (either by using the [-] icon next to it or by using Tree > Collapse), all children

disappear.

5. Children nodes are not repositioned after the parent is dropped. To move them, collapse and then expand the

node, or choose Realign Tree.

Reference Graph Buttons
Use the following buttons and click Close.

Realign Tree Subnodes According to Assembly Structure�Repositions assembly components of selected

node so that assembly structure hierarchy is realigned vertically

Realign Nodes by Generation�Repositions nodes in path of current object so that children are to the right of

parents, regardless of assembly structure hierarchy

Show Reference Parents of the Selected Object�Displays dependency arrows to parents

Show Reference Children of the Selected Object�Displays dependency arrows to children

Remove All Arrows from the Graph�Cleans all dependency arrows from the Graph

Select Arrow Color�Allows modification of the color of the dependency arrows

Example: Displaying Dependencies
The following is a sample image of the Reference Graph. A red arrow next to the part icon indicates the active

component that has been set current, and dependency arrows indicate parent features.
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To Pan the Reference Graph to Include References
Using Locate from the pop-up menu, you can pan the view upon the Reference Graph to shift the view to a

selected parent or child node.

1. After displaying either parent or child dependencies, you can select Locate > Parents or Locate >

Children. The Sel Node dialog box opens, listing the available node references.

2. Select a node, and click OK. The Global Reference Viewer view pans to include the specified reference.

To Expand or Collapse the Tree
1. Use the Expand and Collapse commands from the Tree menu:

Expand—Expand the whole tree, an entire branch of the tree, or one particular model on the tree.

� All—Expands all the models.

� Branch—Expands the selected model and its submodels.

� One—Expands the selected assembly only, not its component subassemblies.

Collapse—Collapses the current node.

Select the [+] icon next to a node, or use the Tree menu to expand the linkage branch to investigate references.

Select an assembly node in the Global Reference Viewer, and choose Tree > Expand > Branch.

When a node is expanded, the children are placed below the node, with tabbed justification below the node's

current location. This allows you to manage a large assembly tree effectively, by placing major groups where

desired.
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Select the [-] icon next to the node to collapse that branch, or choose Tree > Collapse. All children disappear as

normal.

To Set the Arrow Color
Arrows point between referenced items in the tree, from source object to its parents and children. You can use

color coding as a visual aid so that the arrows make it easier to see the relationships graphically. In this way,

you can build a path of dependent references and see the whole path.

Arrow colors can be set to rotate through a predefined palette, allowing a unique color per node. This can be

turned on or off with the Arrow Color > Rotate through command. Alternatively, you can select a specific

color to be used with the Arrow Color palette.

1. Click the Select arrow color button in the Reference Graph, or from the Tree menu, choose Arrow Color,

and choose one of the following:

� Rotate through����The arrows are displayed in one of the available colors, a different color each time.

� Select Arrow Color���� The Arrow Color dialog box opens, providing a color palette that allows you to

create user-defined colors for the reference graph arrows.

Select a color to specify the active color (the default is dark Red, composed of Red 128, Green 0, Blue 0)).

All subsequently created arrows display in the specified color.You can select a basic color, or you can use

the Red, Green, and Blue settings to create custom colors.

2. Click OK.

To Display Parent and Child References
When you set a component as the current item, the Parent and Children Trees appear with a list of components

that are referenced by the selected component (parents), and components that reference the selected component

(children).

When you select another component or feature in the Global Reference Viewer dialog box and set it as current,

the Parent and Children Trees are updated to show the newly selected item as current and lists its parents and

children.

You can expand parent references down to the feature that is referenced. If a parent (or child) component has

only dependencies related directly to its model (for example, a relation using an external parameter), it does not

expand.

If you have selected Tree > Highlight, you can also highlight objects (such as assemblies, components, and

features) in the graphics window by selecting a component in either list.

You can also right-click an item in either the Child or Parent window to open the Full Path or Info window, or

set the item as current.

Note: When you are working with a single part, if you set the part itself as current in the Global Reference

Viewer dialog box, the part will appear in the Parent window of the Parent and Children Trees with an

expanded list of parent features and also in the Child area with an expanded list of children features.

To Show Reference Chains or Threads in the Full
Path Window
Using the Actions > Full Path selection or the right mouse button pop-up menu in the Global Reference

Viewer dialog box, you can show reference chains or threads in the following format:

Referencing feature > Part to which the Referencing Feature Belongs > Assembly > Referenced Part >

Referenced Feature (of Referenced Part) > Referenced Entity

The chain details the path that the reference traverses. When you choose a component or feature from the Parent

or Children Tree, you can show dependency chains that end at the selected object or start from it. The chain
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always goes from referencing feature to referenced entity, regardless of whether a parent or child is selected.

If you choose Actions > All Full Path, the Full Path window displays the reference paths for all dependencies

in the entire assembly appearing in the Global Reference Viewer dialog box.

Note: The system shows the reference path in a separate Full Path window. Simultaneously, it creates a file

ermfullpath.inf in a local directory that contains the same information. When you choose Actions > Full

Path for other objects, the system reuses the file ermfullpath.inf.

To Show Dependency Information in the Information
Window
Use the Actions > Info selection from the Global Reference Viewer dialog box (or in the right mouse button

pop-up menu) to obtain information about specified dependencies.

When you choose a component or feature from the Parent or Children Tree, you can show information about

dependencies in which the selected object participates.

If you do not select either a parent or child, choosing Info provides you with information concerning all the

dependencies of the current model or feature.

Notes:

The system displays the information in a separate Information dialog box. Simultaneously, it creates a file

erm_info.inf in a local directory that contains the same information. When you choose the Info command

button for other objects, the system reuses the file erm_info.inf.

The Global Reference Viewer also displays system-created references. These are references that are not

specifically selected by the user, but that are still required by the feature. They are automatically selected during

feature creation. These references are designated as System Refs in the Full Path and Information windows.

To View Parent Child Information from the Info
Menu
1. To view information about the relationships between features, choose Info > Parent/Child, and use the GET

SELECT menu to select a feature. The Reference Information Window opens.

2. The system displays both children and parents of the current feature. The filter setting All Objects is

selected by default. To change the filter setting, click Filter Setting, and select one of the following:

� Objects with Parents

� Objects with Children

� All Objects

The reference information about feature relationships is displayed in the same way as in the Global Reference

Viewer although the Parent/Child dialog box allows a more isolated view on only the active component or

feature. Click See Also for detailed information about displaying dependency information.

About the Publish Geometry Reference Filter
The Publish Geometry Settings on the Utilities, Reference Control dialog box enable isolation of only Publish

Geometry features for allowed references using the Geometry tab. This filter is not a separate setting that

allows referencing to only Publish Geometry features in the whole model. Instead, it works in conjunction with

the existing scope settings, restricting them further.

The following options allow you to apply the filter to only models that contain Publish Geometry features, or to

all models.

Geometry to be Referenced

� All—Allow external references to any geometry
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� Published Geometry if Exists in a Model—Allow external references to only published geometry if it

exists in a model (if it does not exist, allow external references to any geometry).

� Published Geometry Only—Allow external references to only published geometry.

Note: The Publish Geometry filter is unaffected by Reference Handling settings in the dialog box. These

settings are functional during runtime actions. Any references already established do not fail during

regeneration.

Export Geometry Settings
The Export Geometry dialog box is accessed from the ASSEM SETUP menu. It contains three settings to

control the allowable scope of incoming children references for the model:

� All—Allows any incoming reference.

� Publish Geometry—Restricts incoming references to Publish Geometry within the model.

� None—Completely restricts incoming references.

These settings are functional during runtime actions. Any references already established do not fail during

regeneration.

About Layouts
To enter Layout mode, open or create a layout. This functionality is available with the optional module

Pro/NOTEBOOK. Pro/NOTEBOOK acts as an engineering notebook, enabling you to create two-dimensional

(2-D) conceptual sketches, called layouts, for beginning the design process and maintaining design intent as you

develop solid models.

If you have a license for Pro/INTERFACE, you can use interface functions in Layout mode. If you have a

license for Pro/DETAIL, you can create tables, modify text, and perform additional procedures on detail items.

You create, detail, and annotate layouts using the sketching capability and tools of Draft mode.

Pro/NOTEBOOK offers you the ability to sketch and manipulate draft entities, so you do not need a license for

Pro/DETAIL. However, you must have a license for Pro/DETAIL to define and store drawing symbols, modify

the drawing setup file, or create drawing tables.

A layout enables you to define the basic requirements and constraints of an assembly without having to deal

with extensive or detailed geometry. It is a 2-D sketch you create in Layout mode to document and annotate

parts and assemblies in a conceptual way. For instance, a layout can be a conceptual block diagram or reference

sketch for your solid models, establishing parameters and relationships for their dimensions and placement to

facilitate automatic assembly of the members. Layouts are not precision-scaled drawings and are not associative

with actual three-dimensional (3-D) model geometry.
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The figure shows a layout sketch. The axis is shown in a dotted-dashed line. Both the red and yellow sides of

the datum plane are visible.

PIN LAYOUT

1 3

2

4

5

A 1214-5

1 Global datum axis

2 Balloon note

3 Global datum plane

4 Red side

5 Yellow side

There are four reasons to create layouts:

� To develop the envelopes or basic part geometry for component parts

� To define mounting points and placement relationships between parts

� To determine fits, sizes, and other relationships between critical design parameters

� To document the assembly as a whole

Use layouts also to define a set of global parameters for use in an assembly and its members, or as spreadsheets

for calculating important values based on changes in the values of a set of parameters.

Layouts fulfill their purpose by providing global relations for use with dimensions, and global placement

constraints in the form of reference datums. Use layouts to establish the presence of references, datum planes,

axes, coordinate systems, and points. Later, as you design and assemble parts together, Pro/ENGINEER

recognizes the presence of datums that correspond to the references established in the layout.

For example, when two parts reference the same reference axis, Pro/ENGINEER knows to align those axes.

When two parts reference the same reference datum, Pro/ENGINEER knows to align those surfaces.

Establishing these references facilitates assembly and at the same time preserves design intent while you modify

the detail of the parts.

Pro/ENGINEER stores in a layout file the sketched geometry and annotations that you create in a layout. You

create, store, and access the reference information (global parameters and datums) through the layout.

To save layouts, use the Save command in the File menu. The system saves layouts referenced by a model

whenever it saves the model, and gives them a .lay file extension.

When you regenerate an assembly, the system first automatically regenerates all out-of-date declared

layouts�including all layouts declared to any subassemblies and parts�and then regenerates the assembly

itself. The system automatically regenerates the layouts that drive an assembly to ensure that the assembly's

driven parameters that are referenced through relations or nested layouts have up-to-date values in the

regenerated assembly. You can set the configuration file option regen_layout_w_assem to no to turn off
automatic layout regeneration.
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About Creating Layouts
To create a layout, create a 2-D sketch, as in Drawing mode, to represent your design intent.

To Create a Layout
1. Choose File > New > Layout and enter a name for the layout. The New Layout dialog box appears.

2. To retrieve an existing format, specify the format you will use.

or

To set the size of the sheet, select the orientation and the size of the new layout.

3. Click OK. The LAYOUT and DETAIL menus appear.

To Add, Reorder, or Switch Sheets
Like drawings, layouts can consist of multiple sheets.

When you choose the Sheets command from the LAYOUT menu, the SHEETS menu appears for adding,

removing, and reordering sheets of the layout, as well as moving layout entities from one sheet to another.

To Create Draft Entities for a Layout
1. Choose Sketch from the DETAIL menu.

2. Use the DRAFT GEOM menu to create draft entities.

To Delete Draft Entities from a Layout
Using the Delete command in the DETAIL menu, you can delete all entities sketched on a layout.

To Add Balloon Notes to a Layout
You can use the Balloon command to add indexed notes with balloons to a layout. The system numbers balloon

notes sequentially in their order of creation, with the index number contained within the balloon. Balloon notes

can be free, or have single or multiple leaders, if necessary.

1. Choose DETAIL > Create > Balloon.

2. The NOTE TYPES menu appears, with most of the commands dimmed. You can choose only Leader or No

Leader; then Make Note. If you choose No Leader, go to Step 4.

3. If you choose Leader, the ATTACH TYPE menu appears. Choose the type of attachment and the arrow style.

Select start point(s) for the leader. If the leader is attached, the start point has to be on an edge or entity.

Make as many selections as you need for one balloon.

4. Select the location of the balloon, and enter balloon text at the prompt. The balloon with an index number

appears at the specified location, and the balloon text under this number appears in the lower-left corner of

the screen.

5. Continue creating balloon notes, starting from Step 2. When you have finished, choose Done/Return from

the NOTE TYPES menu.

To Create a Reference Datum for a Layout
1. Choose Create from the DETAIL menu; then choose Datum, Axis, Coord System, or Datum Point from

the DETAIL ITEM menu.

2. To create a datum plane or axis, start drawing a line (indicating the axis/datum plane) by clicking the left

mouse button in the desired location. Extend the axis or datum plane to its proper orientation and location;

then pick the endpoint by clicking the left mouse button again.

3. To create a datum point or coordinate system, click the left mouse button at the desired location.

4. Enter the global name for the datum.
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Note: If you have a Pro/DETAIL license, you can use the GET POINT menu commands to select the start

point and endpoint.

Reference Datums in Layout Mode
You can sketch and name global reference datum planes, axes, coordinate systems, and points in Layout mode.

Place the reference datums so that they constrain the placement of parts represented in the layout. Although the

datum geometry in layouts has only visual significance, the system uses the datum names established in a layout

to relate corresponding datums in associated parts to prepare for automatic assembly.

Because layouts are two-dimensional, the system always displays datum planes on edge, with both their red and

yellow sides visible. You can represent them only with their surfaces normal to the layout sheet. Datum

coordinate systems always have their xy plane in the plane of the layout sheet.

Example: A Reference Datum and Axis for a Layout
The illustration shows a reference datum and axis. Notice that both the red and yellow sides of the datum plane

are visible:

1

2

1 AXIS_1

2 DATUM_1

About Global Dimensions and Relations
Dimensions and relations that you create in a layout are global, and you can access them in any other mode

through the use of local relations.

In all other modes, you can access global dimensions and relations that you have added to a layout; however,

you can create global dimensions only in Layout mode. In this way, dimension and relation values specified in a

layout can directly affect the dimension values of components in an assembly. You must create local relations

for the model in order to access both global dimensions and relations. All other dimensions are "local," meaning

that they apply only to the object in which they were created.

Pro/ENGINEER creates layout dimensions with both symbolic and numeric values.

You can create user-defined variables by writing relations that define them. All objects associated with the

active layout can then access them. For example, if you have defined the relation XYZ = 27.4 * 1.7 in a layout,

you can access the variable XYZ and its value in any other mode through local relations.

You can use parameters in the dimensions and relations of a layout to assign values for different configurations

of a model.
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To Create Parameters in Layout Mode
You can create model parameters in Layout mode using the same procedure that you use in Part or Assembly

mode.

1. Choose LAYOUT > Advanced > Parameters.

2. Create parameters.

To Create a Global Dimension
1. Create and place a dimension.

2. Enter a symbolic name for the global dimension.

3. Enter a numeric value for the dimension. The system then displays the dimension with its symbolic name.

Use the Switch Dim command to switch between the symbolic and numeric values of the dimension.

To Modify a Global Dimension
You can modify global dimensions by choosing Modify from the DETAIL menu and then entering a new value

for the specified dimension. You can also modify them by entering the global dimension as a dependent

parameter of a global relation in another mode. When a relation determines the value of a dimension, you can

modify the value only by changing the value to which the relation evaluates.

To Write Relations for Global Dimensions
Using the Relation command, you can create relationships among global dimensions in the layout.

Global Relations
The following restrictions apply to relations in Layout mode:

� You can define only global relations in Layout mode.

� If a relation was created in another mode, you cannot access it in Layout mode.

� The system does not reevaluate relations unless you choose Show Rel or Regenerate.

To Create a Parameter Table in Layout Mode
You can set up a parameter table to save several sets of parameter values. The parameter table, like a family

table, allows you to store multiple instances of values and simplifies the process of storing and accessing

families of values.

Note: Before you can create a parameter table, you should have created parameters.

1. Choose LAYOUT > Advanced > Set Up > Parameters > Param  Tbl  > Add Param. The PARAMETER

menu appears.

2. Select the parameter names to add to the table, then choose Done.

3. Choose Edit to add sets of values to the table. The Family Table Editor appears.

4. Type in a new instance name, and the values that the parameters in the table should have when that instance

is active in the layout. You can create as many instances as you want.

Note: The instance names cannot contain spaces.

5. Choose File > Exit to return to the layout and save your changes.

To Change the Parameter Set in Layout Mode
1. Choose LAYOUT > Advanced > Parameters > Param  Tbl > Apply Set. The INSTANCES menu appears.

2. Select the instance.

3. Choose LAYOUT > Regenerate. The layout will display the new values of the parameters.
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To Obtain Information About a Global Parameter
The global parameter you inquire about should be available to the current object; that is, the system should be

using it either in the current model or in a layout referenced by this model.

Note: Pro/ENGINEER does not list layouts that have had their local version of the global entity deleted.

1. Choose Relations from the LAYOUT, PART, or ASSEMBLY menu. In the latter case, choose Part Rel and

select the part containing this parameter.

2. Choose Where Used.

The Where Used command in the RELATIONS menu provides information about global dimensions,

datums, axes, and user-defined parameters that belong to a layout. This information contains the type of

parameter, and the names of objects and layouts using it.

3. Select the name of the parameter where it appears, or choose Names and enter the name.

Note: You should not select dimension symbols in parts or assemblies, especially if you have given a

dimension symbol the same name as a real global parameter. The system locates the global parameter and

lists every place that it uses it.

4. The system lists in an Information window all direct references that use the global entity and writes them to

a file named parametername.txt in the current working directory.
The list shows the global type and name first, and then lists all objects where that global appears.

To Use a Parameter Spreadsheet
You can use layouts as spreadsheets to calculate results as parameter values change. You can also maintain

design intent for an object by regulating its parameter values.

Example: A Parameter Spreadsheet
The following figure, an example of a layout spreadsheet, shows the servo layout with the parameters that are

essential to the functioning of the servo appearing in graphical form.
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The next figure illustrates a layout spreadsheet used to calculate values. This shows that you can enter different

values for the core diameter of the servo. The system calculates the resulting value of the torque produced based

upon the value of the magnetic properties of the material.

The layout includes a message that indicates whether the ratio of the core height to the core diameter is within

an acceptable margin. In this case, if the ratio of the core height to the core diameter is less than 2, the message

that appears on the layout sheet reads "***WARNING*** Ratio is too large." Switch the symbolic and numeric

values of the parameters by using the Switch Dim command.

The following figure shows the relations that govern the spreadsheet:

RELATION  PARAMETER   VALUE

--------  ---------  -----

/*** Relations for section:

/***** CALCULATE SERVO PARAMETERS *****

Solve

TORQUE = 2.06e-1 * K * CORE_HEIGHT * CORE_DIA ^ 2

For CORE_DIA

   CORE_DIA  1.798957e+01

/***** CHECK FOR VALID CONFIGURATION *****

RATIO = CORE_HEIGHT / CORE_DIA  RATIO  3.335266e+00

IF RATIO > 2 

MESSAGE = "RATIO IS WITHIN ACCEPTED LIMITS" MESSAGE

ELSE

MESSAGE = "*** WARNING *** RATIO IS TOO LARGE"

ENDIF 
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About Declaring Layouts
You can associate layouts with other layouts or models to exchange information through global parameters and

their values. This can provide automatic assembly of models, or pass parameter values for calculations done in

layout spreadsheets. You establish associations by declaring layouts to other layouts, and models (parts and

assemblies) to layouts.

Layout Hierarchy

When you declare a layout to another layout, you establish a hierarchical relationship between them. The

current layout becomes a child of the layout to which it is declared, and the datums, axes, relations, and

dimensions of the parent layout may govern those of the current layout.

The following illustration shows layout hierarchy:

Datum_1
Axis_1
d1=Length

d2=Height

Datum_1

Axis_1
Length

Datum_1

Axis_1
d1

d2

Datum_1

Axis_1
Length

....

Height

LAY1 LAY2 PART

PARTLAY2LAY1

Before Declarations

LAY2 is declared to LAY1.
Local versions are deleted PART is declared

to LAY2.

Axis_1

Length
Height

After Declarations

However, the system does not create global references automatically. When you declare the layout, the system

prompts you, "Duplication of global symbol symbolname. Delete local version? [No]." If you decide you want a

global reference, answer Yes to the prompt. The symbol then actually deletes the symbol name from the current

layout and replaces it with a cross-reference pointing to the layout where the symbol resides. If you enter No,

the local parameter remains independent from the global one.

If you keep a local version, you can use the same symbol name in many layouts. For example, the symbol

Length can represent the length of a beam, a shaft, and a pipe. If all of these Length parameters are completely

independent (that is, modifying Length for one does not affect Length for another), the parameter name can be

the same for each model.
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The following illustration shows keeping the local version:

Datum_1

Axis_1

d1=Length

d2=Height

Datum_1

Axis_1

Length

..

Length

Height

LAY2 is declared to LAY1. Local
version of "Length" is kept.

PART is declared
to LAY2.

LAY1 LAY2 PART

The creation of a global reference, however, is very useful for controlling parameter values at a single location.

You can modify a single parameter in a parent layout, and the system then passes this modified value down

through the layout hierarchy to the associated models.

Passing Parameter Values from a Layout

Once you have declared a model to a layout, global dimensions and relations set in the layout can govern the

dimensional values of the model. The system accesses both global dimensions and relations by using relations

created in Part or Assembly mode, connecting model dimensions with global ones.

Datum_1

Axis_1

d1=Length

d2=Height

Datum_1

Axis_1

Length

..

Length

Height

 LAY2 is declared to LAY1. Local 

version of "Length" is kept.

PART is declared 

to LAY2.

LAY1 LAY2 PART

In the example shown, if there is the relation:

Length = Height * 2

in LAY2, then setting the part relations

d1 = Length

d2 = Height

causes dimension d2 to acquire the value of global dimension "Height," and the global relation governs d1.

Pro/ENGINEER processes relations in the order in which they appear in the relations file. Setting a later

relation for the same parameter overrides the previous one. For example, setting "d2 = 30" cancels the existing

relation for d2, "d2 = Height."

You can create as many levels of hierarchy as you like. You can also declare a layout to multiple unrelated

parents.

The following restrictions apply:

� You can modify a global reference only at the highest level at which it occurs.

� After you have declared a layout to another, to make a new parameter, do the following:

� To create a local parameter, place the parameter in the lowest level first.

� To create a global parameter, place the parameter in the highest level first.

� If you create a local parameter, to change it to a global parameter, redeclare the layout and delete the

local version of the parameter.
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You can access information about all declared datums, global dimensions, and the layouts that they reference

using the List Decl command in the DECLARE menu. [Lists declarations for the current model.].

Pro/ENGINEER displays the information in an Information window; then it writes it to a file named refitem.txt

in the current working directory. Three messages may appear when the name of the model datum no longer

corresponds to the name of the layout datum:

� "WARNING: 3D item has been deleted or suppressed." An axis or datum in the model is no longer present

to match its counterpart in the layout.

� "WARNING: 3D item reference is invalid—ignored." A name that has been declared to a layout is used to

name an undeclarable entity.

� "WARNING: 3D item has been renamed to [name in model]." An axis or datum in the model has a name

that is different from its counterpart in the layout.

If a declared name in the model is inconsistent with its counterpart in the layout, you can use the Undecl Name

command to rectify the problem.

When you add a declaration to a model declared to a layout, the system marks the layout as modified, and stores

it when it stores the part.

To Declare a Layout to Another Layout
1. Choose Declare from the LAYOUT menu. The system displays a list of layouts that are active in the current

session.

2. Select the name of the layout to which you want to declare the current layout.

Note: Although the name of the current layout appears in the list, you cannot declare a layout to itself. If

you do, Pro/ENGINEER issues a warning: "Declaration is circular." Similarly, you cannot declare two

layouts to each other or make other circular declarations.

To Declare a Model to a Layout
1. Retrieve a part or assembly model.

2. Choose Declare from the PART menu or ASSEM SETUP menu. The DECLARE menu appears.

3. Choose Declare Lay from the DECLARE menu. A namelist menu of layouts active in the current session

appears.

4. Select the name of the layout to which you want to declare the model.

The model now references values in the layout to which it is declared, and is able to use explicit or table

declarations in the assembly process.

You can declare a model to multiple layouts. If a model is declared to a layout that references one or more other

layouts, the model references those also. Therefore, you can explicitly declare and use global parameters from a

parent layout even if they do not exist in the layout to which the model is declared.

Skeleton Models and Layouts
The following rules apply to the relationship of skeletons and layouts:

� If a skeleton model is introduced to an assembly that already has layouts declared to it, you must confirm

that you want the system to declare the layout to the skeleton model as well.

� When declaring a layout to an assembly and it is not yet declared to its skeleton, you must confirm that you

want the system to declare it to the skeleton.

� When undeclaring a layout in an assembly that is declared to its skeleton, you must confirm that you want

the system to undeclare it in the skeleton also.

� You can use the Declare command in the SKEL SETUP menu to allow the skeleton model to have a layout

declared to it.

� You can declare layouts that were already declared to the assembly, but were not confirmed for the skeleton,

as well as declare layouts to the skeleton exclusively.
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To Undeclare a Layout from a Layout
You can undeclare a layout only when global references do not exist.

1. Choose UnDeclare from the LAYOUT menu. The system displays a list of layouts to which the current

layout is declared.

2. Select the name of the layout that you want to undeclare.

Tip: Remove Global References to Undeclare a
Layout
You can undeclare a layout only when global references do not exist. To remove them, you can do one of the

following:

� Delete relations containing global variables

� Redeclare or undeclare explicitly declared references

� Clear all tabular references

To Undeclare a Model from a Layout
You can undeclare a layout only when global references do not exist.

1. Choose Declare from the PART menu or ASSEM SETUP menu. The DECLARE menu appears.

2. Choose UnDeclr Lay from the DECLARE menu. The system displays a list of layouts to which the model is

declared.

3. Select the name of the layout that you want to undeclare.

About Declaring Datums
The global datums appearing in layouts refer to actual part or assembly datums. This makes automatic assembly

possible because the system aligns all datums on all parts that reference the same global datums. You can use

DeclareName to associate a model axis, datum plane, coordinate system, datum point, or planar surface with a

datum.

Before you can create any datum declarations, you must declare the model to the appropriate layouts. Then,

when declaring the datum, you use the name of an established datum within the associated layout. If the name

does not exist, the entity is not declared.

You can declare model datums explicitly or by creating a table.

Declaring Model Datums Explicitly

When you declare a datum explicitly, you simply select the part or assembly datum and enter the name of its

global reference. The datum then appears with the global name. Explicit declarations are simple to use and easy

to visualize; however, they have two limitations:

� You cannot have two datums on the same model with the same explicit declaration (two datums with the

same name).

� You cannot have one datum with two different declarations (one datum with two names).

If you need to do either of these things (for example, to assemble a bolt automatically into many holes in a

plate), you must use table declarations.

Creating a Table

When you create a table, model datums retain their names and the system connects them with the global names

by the text of the table. Table declarations require more organization, but they accommodate more sophisticated

assembly schemes.
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Consider the following example: You want to put a plate, with many holes in it, onto a base, put the pins into

each hole on the plate, and locate the plate on the base using two of the holes. Explicitly declare the base and

plate in the normal manner for automatic assembly. Then, create a table of declarations to place the pins

automatically. Note that two holes have multiple declarations (one explicit and one table-driven) and that all

holes share a common declaration (table-driven).

You can have multiple tables for a model corresponding to the references used in different assemblies. You

cannot have multiple explicit declarations, since these reference the datum name.

Note: During automatic assembly, Pro/ENGINEER considers explicit declarations before table declarations.

If you declare a datum plane, you may need to flip it so that one of its sides (red or yellow) corresponds to the

specified orientation in the layout. If the datum plane is explicitly declared, choose Flip from the ARROW FLIP

menu to flip the datum (or all the members of a pattern of datum planes); choose Okay if the datum plane is in

the proper orientation. In a tabular declaration, use a negative sign in front of the local datum reference to flip

the orientation.

The following rules apply for declaring datum planes:

� You can declare axes and datum planes only in Part mode.

� If you have used a reference axis or datum plane in declarations, you cannot delete it from a layout unless

you delete the corresponding part entities and undeclare the layout.

To Declare an Axis, Planar Surface, or Datum Plane
Explicitly
When each model datum has a unique reference, you can make declarations explicitly; however, you must

declare the model to the layout before creating an explicit declaration. You can select a planar surface to

declare, and the system automatically creates the appropriate BlendSection datum plane.

1. Choose Declare from the PART or ASSEM SETUP menu.

2. Choose DeclareName from the DECLARE menu.

3. Pick the axis, planar surface, or datum plane to declare. In Assembly mode, use only assembly datum planes

and axes.

4. If you select a plane, flip the orientation of the datum plane as necessary to correspond with its orientation in

the layout.

5. Enter the name of the global datum. The system renames the entity itself appropriately.

6. The system stores declarations with the model. To change the declaration of a datum, choose DeclareName

and select a previously declared datum. The REDECLARE menu appears. Choose Replace to redeclare the

entity, or Quit to retain the existing declaration.

If you try to declare a datum that you have already declared to another datum, the REDECLARE menu displays

the commands Replace and Quit. If you choose Replace, the system replaces the existing declaration with the

new one; if you choose Quit, the existing declaration remains.
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Example: Pin Model with Explicit Declarations
The illustration shows a Pin model with explicit declarations. AXIS_1 is a declared and renamed datum axis,

and DATUM_1 is a declared and renamed datum plane.

1

2

1 Declared and renamed datum axis

2 Declared and renamed datum plane

To Declare Datums by Table
You can make declarations with a table.

1. Retrieve a part or assembly model.

2. Choose Declare from the PART menu or ASSEM SETUP menu. The DECLARE menu appears.

3. Choose Table from the DECLARE menu. The TAB_DECLARE menu appears.

4. Choose any of the following commands:

� Add Xref

� Modify Xref

� Show Xref

Declaring Datums by Table
By organizing your declarations in a table, you can do the following:

� Declare different datums with the same global name (for example, for putting bolts automatically into many

single holes) by creating a table that contains the common declarations (for each hole).

or

� Declare individual datums with two different names (for example, to assemble parts into a subassembly

using a datum with one reference name, and then assemble the subassembly into the main assembly using

the same datum with a different reference name).

Each line in the table corresponds to a single assembly instance and must contain all of the declarations used to

assemble that instance automatically.

The following is the format for each line in the table:

local dtm ref #1 = global dtm ref # 1, local dtm ref #2 = global dtm ref # 2, ...
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A negative sign in front of a local datum reference indicates that you are going to assemble the plane in its

"flipped" state. Both global and model datum references can appear in multiple lines of the table. Also, note that

all references must have unique global names; you cannot have a datum axis and a datum plane declared with

the same name.

To Undeclare Datums
You do not have to delete a datum to undeclare it.

1. Choose the UnDecl Name command from the DECLARE menu.

2. Select the datum that you want to undeclare. Its original name replaces the name of the datum to which it

was declared.

About Automatic Assembly
Declaring the same datum in two different models creates a placement correspondence between them. When

Pro/ENGINEER is adding a component to an assembly, it gathers all correspondences between the new

component and the rest of the assembly. As a result, it can determine the placement constraints of the new

component. When this occurs, the AUTO/MAN menu displays the commands Automatic and Manual. If you

choose Automatic, the system places the component instantly; if you choose Manual, the PLACE menu

appears, and you must specify the placement constraints yourself.

If you assemble members of an assembly automatically through a layout, and then replace their parent with a

new parent, Pro/ENGINEER places them automatically if the new parent has all of the appropriate declared

datums.

To disable automatic assembly in Layout mode, set the configuration file option

auto_assembly_with_layouts to no. To enable it, set this option to yes (the default).

When Pro/ENGINEER is automatically placing a new component into the assembly, it matches up the explicit

references of the component with the explicit and table-defined references of the previously assembled parts; it

ignores the table-defined references of the component. However, once the part is a member of the assembly,

new components under assembly refer to the table for placement correspondences for that part.

To Assemble Components Automatically
1. Create a layout with global reference datums and dimensions with relations as necessary.

2. Add datums to the component parts to define the placement constraints. Declare these datums to existing

layout and global datums as necessary.

3. Create an assembly and begin assembling components. If enough correspondences are present to constrain

the component, the AUTO/MAN menu appears.

4. Choose Automatic. The system then automatically constrains and assembles the components.

Example: Automatic Assembly
The following figure presents a layout for an assembly with two members, pin and base. For this example, you

create the global axis A, as well as the global datum DATUM_1.

The parts pin and base each include axes, all declared to A, and planar surfaces, all declared to DATUM_1.

To assemble pin to base, you can do it by pattern automatically. The system automatically aligns the axes with

the same correspondence (A) and the planar surfaces with the same correspondence (DATUM_1). The system

then assembles all the pins to the base in the appropriate locations.
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The following figure shows the layout of the assembly:

The next figure, parts with axes and datums declared, shows the solid models pin and base. The pin has been

declared explicitly using DeclareName:

The base has been declared using a table as shown below.

Table Declarations for "Base"

A_1 = A, DTM1 = DATUM_1

A_2 = A, DTM1 = DATUM_1
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To create the assembly shown in the next figure, Pro/ENGINEER automatically assembles the parts, aligning

the datums and axes according to the correspondences established between the parts and the layout. The system

automatically assembles the parts using the correspondences as constraints. The figure shows the parts

automatically assembled:

About Annotating Layouts
You can add notes and display parameters, as in Drawing mode, to organize and annotate parameters and other

design information.

To Add Notes to a Layout
1. Choose DETAIL > Create > Note.

2. Choose commands from the NOTE TYPES menu.

3. Select the location for the note.

4. Type each line of text and press ENTER after each line. The text appears, beginning at the point you selected.
If you use ENTER on an empty line, the system quits the notemaking process.

5. When you have finished creating notes, choose Done/Return from the NOTE TYPES menu.

To Include Parameter Values in Notes
Notes are useful if you want to display the actual numeric value of a global dimension or user-defined variable

in a layout.

1. Create a relation or a parameter, giving a value to parametername.
2. Create a note and enter &parametername in the note.

The system substitutes for &parametername the numeric value, which changes parametrically according to

the modifications of the associated part.

About Case Studies
In some cases, you may want to make your layouts parametric. For example, you may need to determine the

size of an assembly envelope as the sizes of the assembly members change. To accomplish this, you can create

a case study. A case study is a two-dimensional parametric sketch, much like one created in Sketcher mode.

Unlike a regular section, however, a case study can contain global relations associated with a layout in addition

to relations associated with the sketch.

When you create a case study, the system displays a subwindow over the layout containing the sketcher grid.

You can create or retrieve two-dimensional geometry using typical sketcher facilities. In addition, you can copy

into the case study window any geometry that is undimensioned in the layout.
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You can create reference dimensions in case studies although you cannot do so in regular Sketcher mode. You

can use reference dimensions to control additional parameters of the model through relations so that you are not

limited to using only those dimensions that are necessary to solve the sketch.

To Create or Retrieve a Case Study
To use a case study, the current object must be a layout.

Choose Case Study from the LAYOUT menu to create or retrieve a case study.

To Copy Undimensioned Geometry into a Case
Study
1. Choose Sec Tools from the SKETCHER menu.

2. Choose Copy Layout. The GET SELECT menu appears.

3. Select the desired geometry in the layout (you can select only geometry).

4. Choose Done Sel when you have finished; the system immediately copies the selected geometry into the

case study subwindow.

Once you have sketched the desired entities, dimension the geometry and regenerate it.

To Create Reference Dimensions in a Case Study
Choose Dimension from the SKETCHER menu. The DIMENSION menu displays the following commands:

� Normal—Creates a regular dimension to solve the sketch.

� Reference—Creates a reference dimension. Reference dimensions have symbolic names (RD#). When the

system solves the sketch, they revert to the numeric form, but you cannot pick them for modification.

Note: If a case study sketch has reference dimensions, you cannot retrieve it outside the layout environment.

To Add Case Study Relations
You can add case study relations involving section dimensions or global dimensions by using the Relation

command from the SKETCHER menu.

Case Study Relations
The system uses case study relations to pass information from other layouts to the case study. You add them in

the same way in which you add geometry relations, but case study relations have additional functionality.

� When you choose Add from the RELATIONS menu, units appear in two formats:

� Dimensions are labeled as d1, d2, d3,...

� Entity lengths, coordinate systems, and points are labeled as e1, e2, e3,...

� You can write relations to perform procedures on entity lengths using the notation elen(#). For example, to

add the length of sides e1, e2, and e3, enter:

length=elen(1)+elen(2)+elen(3)
� You can write relations to perform procedures on the x and y distance between the first coordinate system

sketched to another coordinate system or point using the notation ecoord[x or y](#). For example, to

compute hyp, the shortest distance between the first coordinate system sketched and a point labeled e1,

enter:

hyp=sqrt(ecoordx(1)*ecoordx(1)+ecoordy(1)*ecoordy(1))
In a layout, you can include free notes with embedded relation symbols from a case study by using an

ampersand (&) before the symbol. For example, you could include a relation that would extract the value for

length, previously defined in the case study, and add it to the layout:

TOTAL LENGTH= &length
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To Modify Case Study Relations
To modify a relation, use either Show  Rel from the RELATIONS menu or Regenerate from the SKETCHER

menu to update it.

To Declare Case Study Dimensions
You can use global dimensions to make a declaration. The case study sketch has no associativity to the global

layout until you have declared the dimensions. You can specify case study dimensions to be the same as the

global layout dimensions. If you modify one, the other is automatically updated. To access global dimensions of

other layouts, use case study relations.

1. Define a relation using the global dimension as a parameter.

2. Regenerate the object so that the relationship takes effect.

3. Choose Sec Tools from the SKETCHER menu; then choose Sec Environ from the SEC TOOLS menu. The

SEC ENVIRON menu appears.

4. Choose Declaration.

5. Select a dimension in the case study sketch.

6. Enter the name of an existing global dimension in the layout.

Note: To change the constraints established by the declarations, you must remove the declarations.
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