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To Use Pro/PROCESS for ASSEMBLIES
1. Use the File menu to open or create an assembly process file.

2. Select Sequence/New Step to create an assemble step or general step to display the Step dialog box.

3. When creating the first assemble step, you retrieve the model for the design assembly to be fabricated. The

design assembly appears on the screen in a phantom line font. The process assembly references the design

assembly for placement of components and parameter information, but does not affect the design assembly.

4. Select components to be assembled directly from the screen or from the Model Tree. The line font of

assembled components changes from phantom to solid.

5. Define additional elements (such as, description of the step, a simplified representation, explode state, and

time and cost estimates) for defining the step. Explode-offset lines, which showi how components fit

together, are created in an explode state.

6. Click OK when you are satisfied that all desired elements are defined.

7. Define additional steps by selecting New Step from the STEP SEQUENCE menu. The remaining

unassembled components are displayed on the screen in phantom line font for selection during an assemble

step. To show the status of components being assembled and disassembled, add the Process Status column

to the tree tool.

8. Add additional fixtures and tools to the process assembly without affecting the design assembly by selecting

Add Model from the COMP SEL menu when you define an assemble step. To place the fixture, use a drag

and drop technique. To specify explicit assembly constraints such as mate and align, select Finalize from

the PACKAGE menu.

9. To replay the steps, select Play Steps from the ASM PROCESS menu.

10. Create detail drawings of the process assembly by adding the process assembly model to a drawing. The

Process State dialog box appears when the model is added to the drawing. The Process State dialog box

lists the steps in the process assembly. If you want to, select the desired step and a simplified representation

or explode state, and then click OK. The VIEW TYPE menu appears, from which you can place a view of

the model in the specified step.

11. Use Pro/REPORT to create a manufacturing BOM for the step, which lists only the components assembled

during the active step. The system lists a new set of report symbols, beginning with a prs prefix, and
unique to process steps.

12. When you create a view of another step, set the current step by selecting Views from the DRAWING menu,

and then Dwg Models, Set State. The system displays a dialog box. You can select a new step from the list

through this dialog box.

13. Select Views from the DRAWING menu, and then Disp Mode and Process Disp to display components in

different colors or fonts depending on their process status (that is, previously assembled or currently being

assembled).

Functionality with Other Modules
The table below lists the functionality available when Pro/PROCESS for ASSEMBLIES is used with other

Pro/ENGINEER modules.

If you have... You can...

Pro/ASSEMBLY � Create and modify simplified representations. These simplified

representations control the assembly components retrieved and

displayed in your Pro/ENGINEER session.

Pro/DETAIL � Set the step to be displayed in a view.

� Create tables in process drawings.

� Add sheets to drawings.

Pro/FEATURE � Create and modify groups of steps.

� Copy steps.

Pro/REPORT � Create repeat regions in process drawings.
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About Pro/PROCESS for ASSEMBLIES
Use Pro/PROCESS for ASSEMBLIES to create assembly process plans and serviceability documentation.

Specifically, you can use it to complete the following tasks:

� Define the steps of the assembly fabrication process

� Create a manufacturing BOM for each step in the process

� Regroup components independent of the design assembly to model the fabrication structure accurately

� Assemble tools and fixtures unique to a process step without affecting the design assembly

� Perform time and cost estimates for the assembly fabrication

� Create detailed drawings of each step in the process

� Customize the display of each process step by defining multiple explode states with jogged explode-offset

lines and by assigning different colors and line fonts to components based on their status in the step

About STEP SEQUENCE Menu Commands
When you choose Sequence from the ASM PROCESS menu, the STEP SEQUENCE menu opens with the

following commands:

� New Step—Create a new step. Opens the STEP TYPE menu with the following commands:

� Assemble—Opens the STEP: Assemble dialog box

� Disassemble—Opens the STEP: Disassemble dialog box

� Reassemble—Opens the STEP: Reassemble dialog box

� Reposition—Opens the STEP: Reposition dialog box

� General—Opens the STEP: General dialog box

� Copy—Copies steps

� Delete—Deletes steps. Opens the DELETE/SUPP menu with the following commands:

� Normal—Deletes the selected steps from the Select Step dialog box

� Clip—Deletes the selected entity and everything after it in the process

� Unrelated—Deletes everything but the selected entity

� Suppress—Suppresses steps. Displays the DELETE/SUPP menu

� Resume—Resumes suppressed steps. Displays the RESUME menu with the following commands:

� All—Resumes all suppressed steps

� Layer—Resumes the steps on current layer

� Last Set—Resumes the last set of suppressed steps

� Feat ID—Enters a step ID to resume

� Step Library—Groups steps together into a UDF (same UI as for UDF Library in other modes

� Group—Creates steps from UDFs

� Redefine—Redefines a step using the ODUI dialog box

� Reorder—Reorders steps

� Insert Mode—Activates or cancels Insert Mode

COMPONENT Menu Commands
When you click Component from the ASM PROCESS menu, the COMPONENT menu displays the

following commands:

� Package—Uses the Package functionality to move packaged components that are not in the design

assembly.

� Delete—Deletes components and their children from the assembly.
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� Redefine—Redefines one of the component constraints.

� Reroute—Reassigns component references.

� Replace—Replace an existing component with another one.

About PROCESS MOD Menu Commands
When you click Modify on the ASM PROCESS menu, the PROCESS MOD menu lists the following

commands:

� Mod Part—Opens the MODIFY menu to modify a part.

� Mod Subasm—Opens the MODIFY menu to modify a subassembly.

� Mod Assem—Opens the MODIFY menu to modify an assembly.

� Mod Dim—Opens the MODIFY menu to modify dimensions.

About STEP REGEN Menu Commands
When you choose Play Steps from the ASM PROCESS menu, the STEP REGEN menu lists the following

commands:

� Set Step—Selects a step from the Process Window.

� Previous Step—Rolls model back one step.

� Next Step—Regenerates model forward one step.

� Info—Displays information for current step and operation.

To Display Assembly Process Components
The display of components in an assembly process can be set based upon their status in the assembly process.

When a component is at a particular status, its line style will change. Using alternate line styles for displaying

components as you create your assembly process can help to differentiate one component from another.

1. From the View menu, click Model Setup > Process Display to open the PROCESS COMPONENT

DISPLAY dialog box.

Here you can modify the display method used for the different status levels of a component in your

assembly process.

2. Set a line style for components at each of the following status levels:

� Previous Components—Components in the process which have already been assembled as part of an

existing step

� Current Components—Components which are active in the current assembly step

� Unused Components—Components which have not yet been used in the assembly process or have

been previously disassembled

3.You can select a different display setting for each component at two different display stages:

� Process Display—Component display for all other operations in the assembly process including

playing steps, modifying components, and redefining steps

� Selection Display—Component display when defining steps in the assembly process

4. The component display can each be set to any of the following line styles:

� Current Environment—Current setting for that component status and stage

� Phantom—Phantom line font

� Blank—Blanked from the display

� Wireframe—Wireframe model

� Hidden Line—Hidden line style

� No Hidden—No hidden lines

� Shade—Shaded model.

Notes: Clicking Use Defaults in the PROCESS COMPONENT DISPLAY dialog box sets the Previous
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Components and Current Components status for both display stages to the Current Environment setting.

The Unused Components status for Process Display is set to Blank, while the setting for Selection Display is

Phantom.

Clicking Minimize Repaints overrides all Process Display settings with those for Selection Display. Using

identical settings for the display stages will minimize the repaints required after defining a step and redisplaying

the process assembly.

To Modify a Process Component Display
1. Click View > Model Setup > Process Display to open the PROCESS COMPONENT DISPLAY dialog

box.

2. Select the components whose display you want to modify.

3. Select the settings for Process Display or Selection Display that you want to use on the components.

Note: Display settings for specific components as well as a component's layer status will override any

process display setting for that component.

About the Assemble Step Type
Use the Assemble step to assemble parts, entire assemblies, and individual components from reference

assemblies into the process assembly. You specify the component type prior to the selection process.

If you are assembling individual components from an assembly, you must place them in the process assembly if

they are the first ones being placed from that assembly. This step type adds a new occurrence of the component

to the BOM.

To specify the reference components, you select them from a model window. The last model window that you

used to select components is the active window. If the object in the active window is an assembly, you must

specify the components in the assembly to be assembled in this step. To open an assembly without retrieving

the geometry (similar to the way Simplified Retrieve works), use the configuration option

display_comps_to_assemble.

When the display_comps_to_assemble configuration option is used, the assembly is represented by a

logical view only (in the graphic tree selection tool), and you can pick components to assemble by selecting

them from the logical view. If no geometry exists in the process assembly (no features or components are yet

created or assembled, or all components have been disassembled), the system places the component being

assembled in the default orientation and location (similar to assembling the first component of an assembly). If

geometry exists, the system uses the Package functionality to enable you to place the component

You can also specify components to assemble by selecting them in an already partially assembled reference

assembly that has either not been assembled yet, or has been disassembled. When you select components in the

process assembly, the system turns on the display of those components. If you have added components without

retrieving a reference assembly's geometry, use the tree tool the logical view of the process assembly to choose

the components.

If you activate a model that is already partially assembled in the process, you can choose to assemble a new

occurrence of the top-level component or continue assembling components from the already assembled

occurrence.

If a simplified representation of the process assembly is active, you can assemble a simplified representation of

another assembly or part into it using the SELECT REP menu. This is similar to the functionality in Assembly

mode, where you can assemble a simplified representation of a component into a simplified representation of

the top-level assembly.

To Open the Assemble Dialog Box
1. Click Sequence from the ASM PROCESS menu to open the STEP SEQUENCE menu.

a.  Click New Step from the STEP SEQUENCE menu to open the STEP TYPE menu.
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b.  Click Assemble; then click Done.

Step Element Descriptions
� Components—Select components for the process step (standard components, fabrication units, cable

features, pipe features, tools/fixtures, and bulk items). Indicate the type of component, then pick one or

more. You may then indicate another type, then pick. This is a required element— you must choose at least

one component to create a valid assembly step.

� Description (optional element)—Enter textual description of the process step. You can enter multiple lines

of text. Enter a new description in the Step Description dialog box. You can import text files into the Step

Description dialog box, so you can reuse information from another step, or import a standard text template.

Text is inserted at the cursor position.

� Simplfd Rep (optional element)—Select or create the simplified rep to be used when displaying this step.

The default is the currently set simplified rep. Use the SelectRep menu, with the Create command added.

� Explode State (optional element)—Explode state to be used when displaying this step. The default No

Explode will cause the assembly to be displayed in its unexploded state. Use the SelState menu, with the

Create and No Explode commands added.

� Time Estimate (optional element)—Specifies the estimated time to perform this step, in hours.

� Cost Estimate (optional element)—Specifies estimated cost to perform this step. Enter a value or write a

relation to calculate it.

Tip: Component Selection for Assemble Steps
After you select the Components element in the STEP:Assemble dialog box to define, the system displays the

COMPSEL and ACTIVATE MDL menus. When selecting components, the system assumes the top level

model is the one you used for the last assemble component selection—the active model.

To Change the Active Model
1. Click New Step from the STEP SEQUENCE menu.

1 When the STEP TYPE menu opens, click Done to accept default of Assemble.

2 Define required element components. You can select from the active assembly (displayed in phantom line

font) or select Add Model to retrieve a model other than the one that is currently active.

About the Disassemble Step
Use the Disassemble command in the STEP TYPE menu to disassemble components that are already

assembled. Select components from the process assembly. If you want to move the assembly to a different work

cell or fixture, you can disassemble all components. Disassembling a component does not remove the model

from the process assembly.

To Define Disassemble Step Elements
1. Click ASM PROCESS > Sequence to open the STEP SEQUENCE menu.

2. Click New Step to open the STEP TYPE menu.

3. Select Disassemble > Done to open the Disassemble dialog box.

The Elements in the dialog box are the elements to be defined for the process step.

Component Selection for Disassemble Steps
The Select option on the COMP/FAB menu displays the GET SELECT menu. You can only select

components that are currently part of the process assembly. If you pick a component that is part of a fabrication

unit, the entire unit is selected.
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About the Reassemble Command
Use the Reassemble command in the STEPTYPE menu to reassemble previously disassembled components.

Using the Reassemble step does not add another instance of the selected model to the BOM. If you want to add

another occurrence of the component to the BOM, you should use the Assemble step.

You only reassemble components that you have disassembled; therefore, only components that have been

disassembled are available for this step. Since you assembled the selected components in a previous step, you

do not have to specify a component type. You need to reconstrain all components that you select for this step

using the COMP/FAB menu.

To Reassemble Step Elements
1. Click ASM PROCESS > Sequence to open the STEP SEQUENCE menu.

2. Click  New Step on the STEP SEQUENCE menu to open the STEP TYPE menu.

3. Select Reassemble > Done to open the STEP:Reassemble dialog box.

About the Reposition Step Type
Using the Reposition step type, you can reposition a previously assembled component in the process assembly.

You select the component from the process assembly and move it using the Package functionality.

To reposition steps, you use the GET SELECT menu to select components and the COMP/FAB menu. You

can only select components that are currently part of the process assembly. If you pick a component that is part

of a fabrication unit, the entire unit is selected.

To Reposition Step Elements
1. Click ASM PROCESS > Sequence to open the STEP SEQUENCE menu.

2. Select New Step from the STEP SEQUENCE menu to open the STEP TYPE menu.

3. Select Reposition > Done from the STEP TYPE menu to open the STEP:Reposition dialog box.

� Components—Select components for the process step (standard components, fabrication units, cable

features, pipe features, weld features, tools/fixtures, and bulk items).You pick the components from the

process assembly. You must choose at least one component to create a valid reposition step. You can

only select components that are currently part of the process assembly.

� Position—Repositions selected components using the Package interface. This will define the

transformations for the components. Only components defined by the first element may be

repositioned. Only one Package operation is allowed per step. All of the components will be

repositioned together.

About the General Step Type
You use the General command in the StepType menu to create steps for miscellaneous operations such as

painting, cleaning, gluing and so on. Process steps are like features in that they consist of a set of elements, and

they can have geometric references.

To Select General Step Elements
1. Click ASM PROCESS > Sequence to open the STEP SEQUENCE menu.

2. Click New Step to open the STEP TYPE menu.

3. Click General > Done to open the STEP: General dialog box. You can select from the following elements

among others:

� Type—Selects the type from a list containing all default types as well as any user-defined types that

exist in the current model (Caulk, Clean, Drain, Fill, Inspect, Lubricate, Paint, Torque, Verify). If you

select New Type, all of the elements reset to default values and you must enter the name.

� References—Selects components, surfaces, edges, datums, and other common entities using the
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Reference Type interface. This interface is used with the Get Select interface in the same way that it is

used for the Layer, Add Item interface.

To Select Steps
The Select Step dialog box is used to select steps for Delete, Redefine and other step types. The dialog contains

an extended selection list showing the step number and type. It also contains an Info button to provide detailed

information about the selected step(s).

1. From the ASM PROCESS menu, click Play Steps to open the STEP REGEN menu.

2. Select Set Step to open the Select Step dialog box.

To Create and Modify Step Parameters
1. Click Set Up from the ASM PROCESS menu to the ASSEM SETUP menu.

2. Click Parameters to open the OBJTYPES menu.

c.  Click Step from the OBJTYPES menu to open the Select Step dialog box.

d.  Select the step from the list in the dialog box, and then click OK. This opens the
MODELPARAM menu, which has the following commands:

� Create—Creates a new parameter. Displays the ADDPARAM menu to select the type. For a Step

parameter, you must enter the parameter value.

� Delete—Deletes a parameter.

� Modify—Modifies a parameter. For Step parameters, you can change only the value.

� Designate—Designates a parameter.

� Info—Shows each parameter and the current value.

Note: You can create parameters for individual steps. Parameters in individual steps are similar to feature

parameters—they exist for that step only.

To Display Process Status
The system can display process status in the Info column of the Model Tree window.

1. To display the Process Status, click Tree > Column > Add/Remove to open the Add/Remove columns

dialog box.

2. Click Process Status from the left column in the box and move it to the right-hand column.

Process Status describes the current status of the process assembly. Components can be listed as:

� Assembling (assembled by the current step)

� Not Assembled

� Disassembled

Repositioned or reassembled components are listed as assembled. Top-level assemblies are listed as Design

Only.

About Process
A process is a Pro/ENGINEER assembly that contains the features defining the process steps. It follows the

naming convention process_name.asm. An assembly process has dependencies on one or more design

assemblies and fixture models. The process object has a required (for Pro/PDM purposes) dependency on the

assemblies that are assembled into it. If you assemble a part by selecting it from an assembly, the required

dependency is relative to the assembly, not the part. However, if you assemble a single part by selecting the part

directly from its part window, the required dependency is on the part.

A process consists of all referenced assemblies and parts, as well as the sequence of steps that define the process

actions: assemble, disassemble, reassemble, reposition and other steps related to fastening, preparing surfaces
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and so on.

The system retrieves the process model in whatever state it exists before the start of the process (that is, without

retrieving any components and without an active step). You must use the SET STEP menu to move to an active

step. The system displays only those components required by the indicated step.

To Enter Process Mode
In Process mode, you can create process plans to describe operations that are applied to a product.

1. From the File menu, click New or Open.

2. Either enter a name for a new assembly process file, or select an existing assembly process file. The ASM

PROCESS menu lists th following commands:

� Sequence—Manipulates a process step (add, create, redefine and so on). Opens  the SEQUENCE

menu.

� Component—Performs certain component operations. Opens the COMPONENT menu.

� Fab Unit—Creates, modifies, or deletes fabrication units. Opens the FAB UNIT menu.

� Modify—Modifies assembly or assembly component dimensions and features. Opens the PROCESS

MOD menu.

� Simplfd Rep—Creates, modifies, or sets simplified representations.

� Explode State—Creates and edits explode state(s). Opens the EXPLODE menu.

� Regenerate—Updates modified part and assembly dimensions.

� Play Steps—Views assembly at individual steps of the process plan. Opens the STEP REGEN menu.

� Relations—Adds and edits constraint equations.

� Set Up—Sets up additional process information.

� Layer—Performs layer operations.

� Program—Accesses Pro/PROGRAM.

� Integrate—Resolves differences between the source and target processes.

About Process Assembly Steps
Process steps describe the actions used to assemble the product. You activate a step by selecting it in the

Process window. You can only have one active step at any time. The graphics window displays the assembly in

the state created by the active step. Process step types are: Assemble, Disassemble, Reassemble, Reposition, and

General.

Unused components will not be displayed during general, reposition, and disassembled steps.

Using 3-D Notes with Process Steps
3-D Notes are displayed and cleared from the screen automatically when the step to which the note belongs is

displayed or cleared. When a step is active or is being used in a drawing step, a 3-D note created for the step

will be displayed. When the step is no longer displayed, the note also is not displayed. Creation of 3-D notes is

the default when creating a note in a step.

3-D notes can be displayed by selecting them from the screen or from the model tree; however, they are

displayed only when their step is active, even if their status in the tree is Shown. Erasure of 3-D notes works

similarly to their selection—only 3-D notes belonging to active steps can be erased.

About Fabrication Units
Fabrication units are representative of what is actually manufactured and shipped. Fabrication assemblies differ

from design assemblies in that they also include components that are used for shipping purposes only, and

components that represent documentation and other support material. For example, a pipe assembly often
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contains cap parts to protect the open-ended assembly from damage until it is assembled into a higher-level

fabrication assembly.

With Pro/PROCESS for ASSEMBLIES, you can use fabrication units to avoid permanently effecting the design

assembly structure. To create, modify, or delete information about fabrication units using the Fab Unit

command in the ASM PROCESS menu click File > New > Assembly Process Plan > ASM PROCESS.

Creating a Process Plan with Fabrication Units
Fabrication units are groups of components that you use to create a process plan that displays the actual build

Bill of Materials (BOM). Fabrication units appear in the process BOM as individual components. You define

fabrication units by grouping components and assigning a unique name to them as a fabrication unit.

You can use a fabrication unit as a component in an assembly. The system considers fabrication units to be part

of one unit for explode, simplified representations, Bill of Materials, and so on. You can also select them for the

other step types (disassemble, reposition, and so on).

When working with fabrication units, consider the following points:

� Fabrication units do not include placement constraints. The fabrication unit may include components that

have not been assembled. Add the placement constraints for these components when you assemble the

fabrication unit into the process.

� A fabrication unit contains components from a single assembly in the process. The components may come

from multiple levels of that assembly, but there must be a single assembly that ties them all together.

� You can have multiple occurrences of the same fabrication unit. If there is more than one other occurrence,

the system highlights them one at a time and asks you to select one. The process BOM and parts list

catalogs each occurrence of a fabrication unit.

� Fabrication units are listed in the manufacturing BOM as a unit. However, the BOM does not list all

components that belong to that unit.

Creating Fabrication Units
Because Pro/ENGINEER considers the groups of components comprising the fabrication units to be one unit

throughout the process plan, you should create them before you use any of the components in a process step.

You can create them even if some of the components are already in the plan; however, you should redefine that

step and assemble the fabrication unit instead of the individual component. The fabrication unit cannot include a

component that is used in one assemble step and a component that is used in another.

To Create a Fabrication Unit
1. Click File > New.

2. Click Assembly > Process Plan, and then enter a name to open the ASM PROCESS menu.

3. Click Fab Unit to open the FAB UNIT menu.

4. Click Create.

5. Enter the fabrication unit name.

6. Retrieve the top-level design assembly to define the Fab Unit.

The top-level assembly appears in a phantom font. Select components as you would add components to a

process step.

To Create Parameters for Fabrication Units
Click Parameters.

You are prompted to select an existing fabrication unit or to create a new fabrication unit.

After you specify the fabrication unit, the parameters associated with the fabrication unit are active. You can

create, delete, modify, or obtain existing information on the parameters of the active fabrication unit.
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To Delete a Fabrication Unit
1. Click Parameters > Delete to view a list of all of the existing parameters in the current fabrication unit.

2. Check the appropriate box or boxes to select the parameters that you want to delete.

3. Click Done.

To Display Fabrication Unit Information
1. Click Info to open the SEL FAB UNIT menu.

2. Check the Fab Unit for which you want information.

3. Click Done to open the Information Window dialog box. Information about the parameters in the current

fabrication unit is displayed.

To Modify a Fabrication Unit
1. Click Parameters > Modify to view a list of active fabrication unit parameters.

2. Select the parameter that you want to modify.

3. Enter a new value or values.

About Explode Functionality

In Process mode (as in Assembly mode), you can create explode states to define the exploded positions of all

components. For each explode state, you can change the explode locations of components, create explode offset

lines, and toggle the explode status of components. You can access this functionality by using the Explode

States command on the ASM PROCESS menu.

You can define multiple explode states for each assembly, and then explode the assembly using any of these

explode states at any time. You can also set an explode state for each step of the process plan and each drawing

view of an assembly. The default explode state positions each component based on its placement constraints.

To create other explode states, you position components with a drag and drop user interface similar to that of

the package functionality, using the mouse cursor to drag along components.

To Create Exploded Views

To create, set, and modify the explode states of the assembly follow the procedure below.

1. Click ASM PROCESS > Explode State. The EXPLD STATE menu opens.

2. Click Create, and then enter a name for the state. The Explode Position dialog box opens.

You can select a type of motion for the explode position. Motion types are:

� Translate—Select a component on which to base the motion

� Copy Pos—Select a component and copy its position

� Default—Place selected components in the default position

� Reset—Reset the position of selected components

3. Select from the list of entities in the Motion Reference field to select an entity as a reference to use in the

explode motion.

4. Select from the list of increments in the Motion Increments field. This determines how smooth the explode

motion will be.
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5. Click Preferences to open the Preferences dialog box with the following commands:

�   Move One—Moves one component at a time

�   Move Many—Moves multiple components simultaneously

�   With Children—Highlights the children of the selected component and moves the entire group as

one unit

6. Click a command from the Preferences dialog box.

7. Pick a component(s) to move. As you move it, the relative position is dynamically updated in the Position

field of the Explode Position dialog box.

8. You can Undo the explode motion.

9. Click OK to successfully explode the assembly components.

About Configuration File Options for Exploded
Views

In the configuration file, you can set the default color and font style for offset lines created for exploded views.

The following options are available as keywords:

� offset_line_def_font

� offset_line_def_color

EXPLD STATE Menu Commands

� Create—Creates a new explode state. Each time the system creates a new state, it creates it with no

components exploded.

� Set Current—Displays the SEL STATE menu listing available explode states.

� Copy—Copies an existing explode state using the SEL STATE menu.

� Redefine—Redefines an explode state by using the MOD EXPLODE menu.

� Delete—Deletes one or more explode states.

� List—Lists all currently defined explode states in an Information Window.

MTNPREF Menu Commands

� Preferences—Sets up preferences for dragging packaged components.

� View Plane—Uses the viewing plane as the reference plane (repositions the component in a plane that is

parallel to it).

� Sel Plane—Selects a plane other than the viewing plane as the reference plane (repositions the component

in a plane that is parallel to it).
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� Entity/Edge—Selects an axis, straight edge, or datum curve (repositions the component in a line parallel to

it).

� Plane Normal—Selects a plane as the reference plane and repositions the component in a line that is

normal to it.

� 2 Points—Picks two points or vertices (repositions the component in a line that is parallel to the line that

connects them).

� C-sys—Selects a coordinate system axis (repositions the component in the direction of it).

� Translate—Translates the selected components.

� Copy Pos—Copies the position instructions from one component to the selected components.

� DefaultExpld—Places selected components in the default explode position.

� Reset—Removes all explode instructions from the selected components (including the default explode) and

resets their positions.

� Undo—Undoes the last motion.

� Redo—Redoes the last motion that was undone.
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Example: An Exploded View

To Unexplode an Assembly

To unexplode an assembly, use the Un-Explode command in the COSM VIEW menu.

To Change the Explode Position

1. Click ASM PROCESS > Explode State.

2. Click Redefine from the EXPLD STATE menu.

3. Select an explode state from the SEL STATE menu to open the MOD EXPLODE menu.

4. Click Position to open the Explode Position dialog box.

5. Click a command from the Explode Position dialog box to set up preferences for components.
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To Change the Explode Status

1. Click ASSEMBLY > ExplodeState.

2. Click Redefine from the EXPLODE menu.

3. Select an explode state from the SEL STATE menu to open the MOD EXPLODE menu.

4. Click Expld Status to open the EXPLD STATUS menu and the SELECT MANY menu.

5. Take one of the following actions:

� Apply the selected action to all components in the Model Tree window by clicking Toggle Expld from the

EXPLD STATUS menu and Pick Mdl from the SELECT MANY menu.

� Use rules to select components and perform actions on them by clicking Toggle Expld  from the EXPLD

STATUS  menu and By Rule  from the SELECT MANY  menu.

About Modifying Exploded Views

In Drawing mode, you can edit explode positions and offset lines using the ExplodeStates command on the

VIEW MODIFY menu. The system stores these changes in the drawing, not in the assembly or process model.

A drawing may use an explode state from an assembly or a process.

The drawing references the assembly or process explode state as long as the reference is valid. The reference is

no longer valid if you modify the explode from inside the drawing. When this happens, the system copies the

explode state into the drawing and removes the reference to the assembly explode state.

About Offset Lines in Exploded Views

You can use offset lines to show how exploded components align when they are in their final positions, and

then modify or delete them when editing an exploded state. They display in a dashed font. Offset lines are

composed of three straight segments. You determine the direction of the end segments by selecting references

(parallel to an edge or curve or normal to a surface), and the middle segment connects the two end segments.

To Create Offset Lines

1. Click MOD EXPLODE > Offset Lines. The OFFSET LINES menu displays the following options:

� Create—Selects pairs of start and end anchor points.

� Modify—Selects a jog at the junction of two line segments.

� Delete—Removes the portion between two selected anchors.

� Mod Line Style—Changes the line style of existing offset line.

� Set Def Style—Sets the default line style to use for new offset.

2. Click Create.

3. Select pairs of start and end anchor points (on an axis, surface, edge, or the center of an arc). The system

displays the offset lines.
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To Modify Offset Lines

1. Click ASM PROCESS > Explode State to open the EXPLD STATE menu.

2. Click Redefine to open the SEL STATE menu from which you can select an existing explode state.

3. Click Done.

4. Click MOD EXPLODE > Offset Lines to open the OFFSET LINES menu.

5. Click Set Def Style to open the Line Style dialog box and change the line style and line color.

6. Select a start point or endpoint and drag it into the desired position. The offset line is associative; if one or

both of the jogs moves, the offset line updates to connect them.

By using the Mod Line Style and Set Def Style commands, you can modify the line style of individual

offset lines and specify a default line style to use for new offset lines.

To Make Multiple Jogs in Offset Lines

You can control how offset lines are created in exploded views by giving offset lines multiple jogs. Offset lines

with multiple jogs can more clearly represent the way an assembly is created. Multiple jogs allow the offset

lines to be of different shapes, and extra line segments and points are allowed for freedom in changing the

shape. The user can move as well as delete the points.

1. Click MOD EXPLODE > Offset Lines to open the OFFSET LINES menu.

2. Click Modify to open the Modify Offset Line menu.

3. Click any of the following menu commands opens the Get Select menu:

� Move—Default selection on this menu. You can pick a point or offset line to move.

� Add Jogs—You can select a connecting offset line and add a jog to it.

� Delete Jogs—You can select a point on an offset line and delete it, thus deleting a jog in the line.

To Set Configuration Options for Exploded Views

Configuration file options for the line font name are machine-specific.

1. Click Mod Explode > Offset Lines > Set Def Style to open the Line Style dialog box.

The scrolling Line Font list in the dialog box shows all available line font styles. Color is set as

percentages of red, green, blue.

Also, in the configuration file, you can set the default color and line font for models in drawing mode. All

options are available as keywords in the configuration file. Color is user-defined by percentages of red,

green, blue. Line font options are the same as those for offset lines discussed above.

2. For previously assembled components in the step, set the following variables:

� prev_proc_comp_def_font

� prev_proc_comp_def_color
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3. For components assembled in the step that is active in the current view, set the following variables:

� curr_proc_comp_def_font

� curr_proc_comp_def_color

Explode Position Dialog Box Commands

The Explode Position dialog box has several commands with multiple options, and it contains several fields

that you fill in by selecting an entity or by moving a selected entity.

� The Selected Component field displays the name of a component that you select to move in the explode

assembly.

� The Motion Type command has the following options:

� Translate—Translates the selected component

� Copy Pos—Copy the position of the selected component

� Default Expld—Place the selected component in the default explode position

� Reset—Reset the position of the selected component

� The Motion Reference command allows you to select a reference type to define the direction of the

explode motion:

� Entity/Edge—Translation occurs about the reference line in the plane that is normal to it and contains

the drag origin point.

� View Plane— Translation occurs about the component's drag origin in the same plane.

� Sel Plane—Translation occurs about the component's drag origin in the same plane.

� Plane Normal —Translation occurs about the component's drag origin in the plane that contains the

drag origin point and is parallel to the reference plane.

� 2 Points—Translation occurs about the reference line in the plane that is normal to it and contains the

drag origin point.

� C-sys—Translation occurs about the axis in the plane that is normal to it and contains the drag origin

point.

� The Motion Increments command allows you to define the smoothness of the explode motion by selecting

from the pull-down list of options.

� Position Relative window updates dynamically as you move components.

� Preferences allows you to setup preferences for moving components.

About Drawing Mode With Process Documentation

In Drawing mode, you can create customized documentation for the assembly process. Views of each step can

be placed, and component display can be controlled based on its status in the step. Also you can create report

tables using Pro/REPORT.
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Use Drawing mode to create views of a process at a particular step by first selecting a process assembly in

session, and then selecting a process step from a list. The system creates a default view of the process at that

step.

In Drawing mode, you can also do the following:

� Perform an explode in the context of the drawing (if you have not already exploded the process assembly at

that process step, or if the explode is not appropriate for that view). The system stores the explode

information in drawing.

� Control how the system displays the components in the process assembly in the drawing view. For each of

the Assembly Status values assigned to members of the process assembly, you can define the line color

and font. For example, you might want to display all assembled components in neutral gray, dashed font

and all components that you are assembling in red, solid font.

� Define the display colors and fonts by using the Memdisp menu.

Create a view of a process step similarly to the way you create a view of a part or assembly.

View Maintenance with Process Steps

You do not have to manage views manually, which can become a time consuming and difficult task as steps are

reordered or deleted. With each step that you create the step feature has a view element, so views can be defined

in the step feature, or an existing view can be attached to the step. This association of a view with the step

eliminates the need for manual maintainance.

Views are defined in the Orientation dialog box. You define a new view by setting the orientation, then naming

the view. Click Set to associate the view to the current step.

To Create a View of a Process Step

1. In Drawing mode, click DRAWING > Views.

2. Select the process model to open the Process State dialog box.

3. Using the Process State dialog box, select a process step, an explode state and a simplified representation

for that step.

Note: An existing drawing sheet can be used as a template to format new sheets in a process drawing. The

formats and views of the current sheet are used as a template for a new sheet in the drawing.

About the Process State Dialog Box

The Process State dialog box contains a scrollable tree tool that displays the process assembly sequence. You

can select a step to show in the view. If simplified representations are available, you can select one from the

drop-down list. You can also select an explode state from the explode state drop-down list. The system selects

the default representation and explode state for that process state by default.
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Object Parameters in Drawings

You can use object parameters in your assembly process drawings as you would any other object parameters.

The object parameters can be used in drawing notes just as you would with other drawings.

In particular, you may want to include the step description in your drawings. This description can be included as

a note which contains the following object parameter:

&description:FID_#

Where # is the feature ID for the step you are documenting.

To Change the Assembly State in a View

After you have created and placed a drawing view, you can change the process assembly state shown in that

view.

1. Change the state by clicking Process State from the VIEWMODIFY menu.

2. Select a view of a process model. The system displays the Process State dialog box with the process state,

explode state, and simplified representation used in the view selected in the lists.

3. When you change the process state, explode state, and/or the simplified representation, the system makes it

the current model when creating new views.

To Set the Assembly State of the Current Process
Model

1. Click DWG MODELS > Set State.

2. The Process State dialog box appears with the current process state, explode state, and simplified

representation selected in the lists.

About Explode Commands in Drawing Mode

In Drawing mode, you can use the Mod Explode command in the VIEWMODIFY menu to modify explode

positions. You can change the explode position of components and you can toggle the explode status of

components to be exploded or unexploded. Changes made from this menu become part of the drawing; they do

not affect the process assembly.

In steps that have components as references, you can control the display of components based on their status in

the current step. This is controlled from the DISPMODE menu.

To Control the Component Step Display

1. Click DRAWING >Views.

2. Click Disp Mode from the VIEWS menu. The DISP MODE menu appears.
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3. Choose Process Disp to open the Component Step Display dialog box. This dialog box allows you to

determine component display status according to whether or not the component is referenced in the current

step.

4. Change the display of the selected component.

About Using Pro/REPORT for Assembly Process
Drawings

Drawings of assembly processes are the same as drawings of any other Pro/ENGINEER object. However,

special parameters are available using Pro/REPORT to create a custom table detailing the assembly process.

Pro/REPORT Parameters for Pro/PROCESS for
ASSEMBLY

An entire list of available system parameters appears in the following table:

Parameter Name Definition

&prs.actstep.comp.name Lists the names of all assembly components in the

currently active step.

&prs.actstep.comp.param.name Lists the names of all parameters for each assembly

component in the currently active step.

&prs.actstep.comp.param.value Lists the values of all parameters for each assembly

component in the currently active step.

&prs.actstep.comp.type Lists the method of assembly for each component in

the currently active step.

&prs.actstep.comp.User Defined Lists the values of any user defined parameters for

each assembly component in the currently active

step.

&prs.actstep.desc Lists the descriptive phrase of the currently active

step.

&prs.actstep.name Lists the name of the currently active step

&prs.actstep.number Lists the currently active step number.

&prs.actstep.param.name Lists the names of all parameters associated with

the current assembly model.

&prs.actstep.param.value Lists the values of all parameters associated with

the current assembly model.

&prs.actstep.type Lists the names of all parameters associated with

the current active step.

&prs.actstep.User Defined Lists the values of any user defined parameters in
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the currently active steps.

&prs.step.comp.name Lists the names of all components for each step

displayed in your drawing.

&prs.step.comp.param.name Lists the names of all parameters for each assembly

component for each step displayed in your drawing.

&prs.step.comp.param.value Lists the values of all parameters for each assembly

component for each step displayed in your drawing.

&prs.step.comp.type Lists the type of component being assembled for

each step displayed in your drawing.

&prs.step.comp.User Defined Lists the values of any user defined parameters for

every assembly component displayed in your

drawing.

&prs.step.desc Displays the descriptive phrase of each step shown

in your drawing.

&prs.step.name Displays the name of each step shown in your

drawing.

&prs.step.number Displays the all step numbers for every step in your

drawing.

&prs.step.param.name Lists the names of all parameters associated with

the steps displayed in your drawing.

&prs.step.param.value Lists the values of all parameters associated with

the steps displayed in your drawing.

&prs.step.type Lists the methods of assembly being used for each

step displayed in your drawing.

Tip: User-Defined Parameters in Tables

An item's parameters can also be used in a Pro/REPORT table as a user-defined parameter. For example, the

COST parameter of a part can be used as a user-defined parameter in a Pro/REPORT table as

&prs.step.cost_estimate even though a system-defined Pro/REPORT parameter called &prs.step.cost_estimate

does not exist.

Example: Creating a Report

When creating a report, it is important to consider the structuring of the symbols in the report. Pro/REPORT

parameters used in Pro/PROCESS for ASSEMBLIES are based upon either the current step in the drawing or

all steps in the drawing.

&prs.actstep.number &prs.actstep.type &prs.actstep.comp.name

2 ASSEMBLE 8_PORT



Pro/PROCESS for Assemblies 27

2 ASSEMBLE 2_PORT

Example: Different Parameters in Reports

The table illustrates the slight differences between similar parameters

&prs.step.number &prs.step.type &prs.step.comp.name

1 REPOSITION BASE

2 ASSEMBLE 8_PORT

2 ASSEMBLE 2_PORT

In this case, instead of using the parameter &prs.actstep.number, the &prs.step.number parameter

is used. This parameter behaves differently than the other. While the &prs.actstep.number parameter

specifies the name of the step number, the &prs.step.number parameter lists the step number for all

models in your drawing, regardless of which model is the current one. This parameter is used to list report

information for all steps in a drawing with multiple models. The same principle can be applied to the other two

report parameters.

About Parameters in Reports

Pro/REPORT provides information based upon a hierarchy of specifications proceeding from left to right. In the

example, the parameter &prs.actstep.number provides the step number of the step in your assembly

process that is currently set as the active model. Similarly, &prs.actstep.type gives the assembly method

used in just the active step. The parameter &prs.actstep.comp.name provides the names of all assembly

components used in the active step.

About Working with Large Design Assemblies

There are a number of ways to work effectively with large design assemblies.

� Use simplified representations

� Retrieve the earliest step

� Set appropriate configuration options

About Simplified Representations in Process
Assemblies

Simplified representations are used to improve visual clarity and performance. They are used to simplify the

process assembly by excluding or substituting components for all steps or to simplify only the current state (that

is, step). Simplified representations of the design assembly can also be used when creating assemble steps in the

process assembly.
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To Create Simplified Representations

1. Click ASM PROCESS > Simplfd Rep.

2. Create or set the current representation.

Components are excluded or substituted for only one step in the process assembly by creating or setting the

current representation when defining or redefining the step.

To Apply a Simplified Representation to a Step

Create or set the current representation when defining or redefining the step.

1. Click Simplfd Rep from the STEP dialog box to set or create a simplified representation for the step.

2. You can use simplified representations of the design assembly when you create assemble steps in the

process assembly.

To Retrieve a Simplified Representation in a
Process Assembly

1. Create a simplified representation of the process assembly before adding the design assembly to the process.

2. Creating a simplified representation of the process assembly provides the Retrieve Rep menu command

when you add a model to the process.

Note:  Components excluded in the design assembly do not appear on the screen in phantom line font but

appear in the Model Tree of the assembly where they are selected.

Retrieving the Earliest Desired Step

Retrieving the earliest desired step when retrieving a process assembly limits the number of components

retrieved into memory because only those components required for the process step are retrieved and displayed.

All components of the design assembly are retrieved when adding a new step.

Using Configuration File Options

A configuration file option is available to enhance performance when working with complex assemblies. The

option is called display_comps_to_assemble with a default value of yes. Setting the option to no
enables design assemblies and components to be selected exclusively from the Model Tree without displaying

them on the screen until they are selected. Selecting the components from the Model Tree retrieves them into

memory and displays them in the process assembly.
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About Process User-Defined Features

You can create and store a user-defined feature (UDF) of one or more General process steps the same way you

would create a standard UDF in Part mode. You pick the step(s) to include in the UDF, and enter reference

prompts, variable elements, and other data. With a license for Pro/PROCESS for ASSEMBLIES,

Pro/ENGINEER provides a standard library of common process steps:

� Caulk

� Clean

� Drain

� Fill

� Inspect

� Lubricate

� Paint

� Torque

� Verify

You can customize the library by adding your own steps or changing the definition of the steps provided.

To Create a UDF

1. Click SEQUENCE > Step Library.

2. Group steps together into a UDF.

About Obtaining General Information

Using the Info command in the main View menu, you can access general information concerning mass

properties, Bill of Materials, measure, and so on. To obtain process-specific information such as cost, time

estimates, and component usage lists, use the Process Info command in the Info menu.

The Process Info menu lists the Sequence command that displays an Information window containing the

textual information from the process sequence, including the description and type of each step, all attribute

names, and the corresponding values.

Using these commands, you can access an Information window that displays the complete process sequence. It

includes information such as the step type, description, all attributes, and their values. The system saves this

information to a file as it is displayed, so you can print it without actually stepping through all of the steps.

BOM and Parts Lists

To show which components and tools are required to complete a step or group of steps, you can create and

export (to a file or print) a parts list based on Assembly Status (current, previously assembled, and so on.) and

Component Type (Design, Fixture, Bulk Item, and so on).
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You can use the following possible formats, and switch between them:

� Indented list to show hierarchy, as in simplified representations

� Current BOM format

� Flat list with no hierarchy, just a list of components

You can create the list based on a step or a group of steps. To create it for a list of steps, define the subset by

entering numbers separated by commas or hyphens.

Getting Step Information

You can obtain information about a particular step by using the Info command in the Select Step dialog box, or

the main View menu. If you choose one of these options, the system displays an Information window

containing the following:

� Step number and type

� References and reference type

� Abbreviated description of the step description

� Time estimate

� Cost estimate

� Simplified representation name

� Explode state name

� Full description

When you show the status of components in the design assembly, you can add a column in the model tree called

process status, which lists the current status of all components (that is, assembled, not assembled, assembling,

and so on).

Exporting Process Plans Using Pro/WEB Publish

If a license for Pro/WEB PUBLISH is available, the process steps created using Pro/PROCESS for

ASSEMBLIES can be exported for viewing on the World Wide Web.
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