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To Create Witness Lines

1. Choose ATTACH TYPE > Make Line.
2. Using the MAKELINE menu, do one of the following:
— Choose 2 Points and select two vertices. The system highlights them in white and draws a blue
phantom font line to indicate the line that you constructed between them.

— Choose Horiz Line or Vert Line and select a vertex through which the horizontal or vertical witness
line is to pass. You can select a datum curve endpoint, solid vertex, coordinate system origin, datum
point, cosmetic feature endpoint, or draft vertex. The system highlights the vertex in white, and
displays two blue arrows pointing horizontally or vertically away from the vertex.

About Modifying Witness Lines

When Pro/ENGINEER places a dimension on a model, it leaves a gap between the model and the witness line.
The drawing setup file option witness line offset controls the actual size of the gap. Sometimes this
gap is not visible on a drawing. However, it becomes noticeable when you plot the drawing. To see how the
drawing will look when you print it, choose File > Print > Screen.

A witness line can have both jogs and breaks. When you add jogs to a witness line that already has breaks, the
breaks that were created as simple breaks appear on the first unjogged segment of the witness line. If a witness
line has dimension breaks, jogging a witness line relocates a break to a new intersection point.

You can edit witness lines in the following ways:

e (Create parametric or simple breaks in dimension witness lines and in leader lines of notes and symbols.

e Resize the gap by using the Move command. You can simultaneously clip several dimensions that have the
same orientation so that their witness line endpoints all align. Using multiple selection, you can manipulate
witness lines in the following ways:

— Clip both witness lines of a dimension at the same time.
— Clip the witness lines of many dimensions at once. When you pick on the witness line of each
dimension, the system moves each of the endpoints together.

e Erase and resume witness lines.

e Skew witness lines.

e Add jogs to and delete them from linear (standard and ordinate) and angular dimension witness lines, note
leaders, and symbol leaders.

e (Create and modify angular, diametrical, radial, and linear dimensions with and without an elbow.

To Clip a Witness Line

1. Select the dimension with the witness line that you want to clip. Use the middle mouse button to end the
selection.

2. On the right mouse button pop up menu, select Move/Activate. The witness lines are highlighted, with a
"handle" at each end.

3. Drag the handles to the desired positions. Left click to finish.

To Erase a Withess Line

You can erase only one witness line of a dimension. If you attempt to erase the second one after erasing the first
one, the system erases the second one and restores the first one. You cannot erase both.

1. Select the dimension with the witness line to erase.

2. Click the right mouse button, and select Erase Wit Line from the pop up menu.

3. Click the witness line to erase. The system erases the dimensions and then redraws them. It blanks the
witness line and displays a double arrowhead in its place.

Note: You cannot erase the witness lines of ordinate dimensions (including ISO-standard ordinate dimensions
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with a cross-line between the baseline and the dimension).

You cannot blank the witness line of a clipped dimension (one that has been clipped as a result of view
clipping), and you cannot use Show to restore a witness line that has been automatically erased (clipped due to
view clipping).

To Restore an Erased Witness Line

1. Select the dimension with the witness line to restore.
2. Click the right mouse button, and select Show Wit Line from the pop up menu. The system redraws the
selected dimension and displays its witness line with a single arrowhead at the leader.

To Create a Break in a Leader or Witness Line

Select the dimension with the witness line to break. The dimension is highlighted.

From the right mouse button pop up menu, click Break.

On a line, select the first point of the break.

Select a second point on the same line to define the extent of the break. The system creates a gap between
these two points.

5. Use the line "handles" to size the break.

Note: You cannot break a radial or diameter dimension of an arc or circle because what you see is not a witness
line, but the extension of a dimension arrow.

R =

To Create a Parametric Break at an Intersection of
Witness Lines

You can make parametric breaks against dimension witness lines or snap lines. When you create a break against
a snap line, the break moves when the snap line moves, and is deleted when the other dimension is erased or
deleted.

Note: Parametric breaks cannot be created against note or symbol leaders.
1. Select the dimension with the witness line to break. The dimension is highlighted.
2. From the right mouse button pop up menu, click Break.
3. On aline, select the first point of the break.
The BREAK TYPE menu appears in the Menu Manager, letting you create either a simple break or a
parametric break. Selecting from this menu is optional—the system assumes that the break is a parametric
break if your next pick is on the witness line of another dimension or on a snap line. Both Simple and
Parametric are selected by default. Clear the Simple check box to ensure that a parametric break is created.
4. Select a witness line of another dimension or a snap line against which to break.
5. Using the BREAK SIZE menu in the Menu Manager, choose one of the following commands:
— Choose Default and specify the gap size for the selected intersection point. The system assigns the
default break size, which is equal to twice the witness line offset distance specified in the
drawing setup file.

— Choose Pick and set the break gap size by dragging the pointer along the witness line and using the left
mouse button to finish selecting gap size.

— Choose Radius and specify a radius value for the break.

The system creates a parametric break at the closest intersection point of the originally selected witness
line and the second witness line or snap line.
6. To delete all of the breaks pertaining to the selected dimension, choose BREAK > Remove.

To Modify Witness Lines

1. Select the dimension with the witness line to edit. The dimension is highlighted.
2. From the right mouse button pop up menu, click the action you want to perform.
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You choices are:

Move\Activate - Move label and arrows

Default Wit Line - Toggle the default witness line style.

Switch View - Move a selected dimension object from one view to another.
Make jog - Insert a corner in a line.

Nominal Val - Change selected dimension value.

Values/text - Open a dialog box to edit values and appearance of dimension.
Flip Arrows - Toggle arrows inside or outside witness lines.

Arrow Style - Change head style of selected arrows.

Break - Insert a break in a witness line.

Del Breaks - Remove previously made breaks.

Erase Wit Line - Hide a selected witness line.

Erase - Remove the dimension

To Skew Withess Lines

1. Select the dimension with the witness line to edit. The dimension is highlighted.

2. Use the cursor to select a handle on the end of a witness line. The cursor changes to an arrow, perpendicular
to the selected witness line.

3. Drag the handle to the desired location. Left click again to place the witness line.

1
c.hd

Drag handle (1) up and down to skew dimension position.

To Add a Jog to a Witnhess Line

Choose Insert > Jog.

Select the dimension to which you are adding a jog.

Select a point on a witness line. The remaining portion of the witness line moves with the pointer.

Select locations for jog points by pressing the left mouse button.

Press the middle mouse button. The system locates the jog.

Notes:

The first and last segments of a jogged witness line are always parallel.

When the system locates the jog, it remains in the same place on the drawing, regardless of where you move
the dimension.

About Using Dual Dimensioning

Using the drawing setup file option dual dimensioning, you can display dimension text in two sets of
units—primary or secondary (or both). These drawing setup file options work together with
dual_ dimensioning to modify the display of dual dimensions:

DA
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e dual secondary units specifies the secondary set of units used by the drawing.

dual digits_ diff specifies the number of decimal places that secondary units contain compared with
the primary units used.

e decimal marker specifies the character to use to mark the decimal point in secondary dimensions.

e dual dimension brackets specifies whether one of the units of dimensions appears within
brackets.

Note: When you are using dual dimensioning with dimensional tolerances, the system rounds the secondary
values so that they always fit within the range indicated by primary units (that is, so that they are tighter
than primary values), and retain the desired design intent.

To Place Dual Dimensions in a Drawing

To place dual dimensions, you can use various options in the Modify Dimension dialog box:

1. Select the dimension to modify.

2. Click Edit > Properties. The Modify Dimension dialog box opens.

e To place the secondary dimension below the primary dimension, select Below from the Dual Dimensioning
field

e To place the secondary dimension on the same line as the primary dimension, select To Right from the
Dual Dimensioning field.

e To specify the number of decimal places to use for the secondary dimension, type a value in the Dual
Number of Digits text box

3. Click OK.
Note: If you are using metric dimensions as primary or secondary units in dual dimensions, the metric
dimensions do not display as fractions if the fraction format is set.

To Add Text to a Dimension

Use this procedure to add prefix or "postfix" text to a dimension.

Select the dimension to modify.

Click Edit > Properties. The Modify Dimension dialog box opens.

Click the Dim Text tab.

Use the Name, Prefix and Postfix boxes to surround the dimension text.

Click OK. The system stores the dimension text with the model, and displays it in either Part mode or
Assembly mode when you select the feature the dimension is driving.

To Add Parameters to Dimension Text

Use this procedure to add prefix or "postfix" text to a dimension.

Nbhw =

1. Select the dimension to modify.

2. Click Edit > Properties. The Modify Dimension dialog box opens.
3. Click the Dim Text tab.

4. Type the parameter callout in the Prefix or Postfix field.

5. Click OK.

Note: You can place dimensions and parameter text in driven dimensions or associative dimensions owned by
the same model; however, you cannot place them in draft dimensions or associative draft dimensions.

To Overwrite Dim Value Display with a Text String

Use this procedure to replace any dimension value display with your own text string.

1. Select the dimension to modify.
2. Click Edit > Properties. The Modify Dimension dialog box opens.
3. Click the Dim Text tab.
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4. In the text field, replace the symbol "@D" with "@Q"; then type the desired text. The symbol "O"
represents overwrite; anything you type following this text overwrites the dimension value. The drawing
now displays the text string instead of the dimension value.

Note: Dimensions must always have a displayed value. If you do not type text after substituting "@O," the

system ignores the procedure when modifying driven dimensions and displays the "REF" text when modifying

reference dimensions.

To Modify Dimension Decimal Places

You can modify the number of decimal places a dimension displays individually or for a multiple selection of
dimensions.

For an individual dimension:

1. Select the dimension

2. From the right mouse button pop up menu, click Values / Text.

3. In the Number of Digits field, enter the number of decimal places.
4. Click Ok.

For multiple selection:

5. Click Format > Number of Digits.

6. In the prompt line, enter the value you want to assign.

7. Use the Get Select > Pick Many command on the Menu Manger toolbar to draw a selection rectangle
around all the dimensions you want to edit.

8. Click Done Sel. The decimal places are changed.

Notes:

To control the display of the dimension value for primary and secondary units in the drawing independently
(whether the dimension value has leading or trailing zeros), use the drawing setup file option
lead trail_zeros.

To specify whether the character used to indicate the decimal point in a dimension is a period, a comma, or a
comma only when the units are metric, use the drawing setup file option decimal marker.

To Show Dimensions in Degrees or
Minutes/Seconds

For an individual dimension:

1. Select the dimension (Hold down the Shift key for multiple selections.)
2. From the right mouse button pop up menu, click Values / Text.
3. In the Format field, click Fractional.

4. Click Ok.

For minutes/seconds:

Type the value [3600] in the Largest Denominator box. You can type a value of 60 if the drawing setup file
option draw_ang units is set to ang_min since this value essentially reduces any dimension to an integer
with minutes precision.

Setting the Default Decimal Places and Trailing
Zeros

e Change the number of decimal digits shown by setting the configuration file option
default ang dec_places to a value of 0 through 14 (the default is 1).

e Remove the trailing zeros to conform to ANSI standards by setting the drawing setup file option
draw_ang unit trail zeros to yes (the default). This applies only if the entire seconds or
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seconds/minutes field is exactly zero. Select Fractional and type [3600] in the Largest Denominator box to
be sure.

To Display Dimension Text Symbols

Select the dimension (Hold down the Shift key for multiple selections.)

From the right mouse button pop up menu, click Values / Text.

In the Modify Dimension dialog box, click Dim Text.

In the Dimension Text box, note the current @D setting. Backspace over the D and replace it with an S.
Click OK. The selected dimensions now display their symbolic values rather than their dimension values.
Type a prefix or a postfix if you want to add text to the value of the dimension.

To toggle the display of all dimensions temporarily, choose Info > Switch Dims

NhwN =

To Modify the Value of Dimension Symbols

1. Select the dimension (Hold down the Shift key for multiple selections.)

2. From the right mouse button pop up menu, click Values / Text.

3. Inthe Modify Dimension dialog box, the value in the Name box is the current dimension symbol. Type
new text to change the symbol value.

4. Click OK. The system stores the new dimension symbol as modified in the model and updates any relations
using the symbol.

To Show an Angular Dimension in Degrees, Minutes
and Seconds

1. Select the dimension (Hold down the Shift key for multiple selections.)
2. From the right mouse button pop up menu, click Values / Text. The Modify Dimension dialog box opens.
3. From the Angular Dim Units field, select one of the following from the drop-down list:

— Degrees—Shows the angular dimension in degrees

— Degrees, Min.—Shows the angular dimension in degrees and minutes
— Degrees, Min., Sec.—Shows the angular dimension in degrees, minutes and seconds.

4. The angular dimension is changed to the specified unit.
Note: You can also change the way you show angular dimensions globally by using the drawing setup file
option draw_ang_units.

About Cleaning Up Dimensions

Using the Edit > Clean Dimensions command, you can arrange the display of selected dimensions
automatically by doing any or all of the following:
e Clean dimensions by view, or by individual dimensions.

e Center dimensions between witness lines (including the entire text box with gtols, diameter symbols,
tolerances, and so on).

e Create breaks in witness lines where they intersect other witness lines or draft entities.
e Place all dimensions on one side of a model edge, datum plane, view edge, axis, or snap line.
e Flip arrows.

e Offset dimensions from edges or view boundaries.

To Clean Dimensions

Use this procedure to automatically clean up multiple dimensions at once.

1. Choose Edit > Clean Dimensions. The Clean Dimensions dialog box opens.
2. Using the Get Select options on the Menu Manager, select individual dimensions or an entire view; then
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click Done Sel. The Clean Dimensions dialog box activates.
Placement Tab

3. Type an initial uniform offset value in the Offset box. To place the selected dimensions, type an incremental
offset value in the Increment box.
4. In the Placement page, do one of the following:
— Select View Outline to offset the dimensions with respect to their view outlines. Go fo Step 6.

— Select Baseline to reposition only dimensions in the same view whose leaders are parallel to the
selected baseline. Go fo Step 5.

5. Select one of the entities in the drop down list to use as a cleaning baseline. An arrow appears to indicate the
offset direction. To change the direction click Flip Arrow.

6. Check Create Snap Lines to add dashed snap lines to the dimensions.

7. Check Break Witness Lines to break witness lines where they intersect other draft entities.

8. Click Apply. The system applies cosmetic cleanups to all dimensions. Click Undo to return them to their
pre-cleaned state and try again without reselecting dimensions.

Cosmetic Tab

9. In the Cosmetic.tab, by default, the system selects all of the check boxes. Clear any or all of them, as
necessary; then click Apply:
— Auto flip arrows flips the arrows inside the witness lines if they fit (without overlapping the text); if
they do not fit or they would be overlapping the text, they flip outside the witness lines.

— Center text centers the text of each dimension between its witness lines. If it does not fit, the system
moves the text outside the witness lines in the specified direction:
Horizontal moves the text to the left or right.

Vertical moves text of vertical dimensions up or down.

— Create snaplines creates snap lines under all moved dimensions (if the destination does not already
have a snap line in the vicinity). They appear only under dimensions that are parallel to baselines (if
you have selected a baseline) or parallel to a view border (if the view outline has been selected). Once
you clear this check box, it remains cleared for the remainder of your Pro/ENGINEER session.

To Relate Detail Items and Dimension Text

You can directly relate a note, draft geometric tolerance, or symbol to dimension text so that the detail item
moves with the dimension when the dimension changes location.

To relate an existing detail item to dimension text,

1. Click TOOLS > Relate Obj > Add Items.

2. Select the "host" object.

3. Select all other items you want to relate to the host.

4. Click Done Sel. All the objects are grouped and selected as one.

To remove objects from the group, use TOOLS > Relate Obj > Remove Items.

Note: When creating a new symbol, note, or free draft geometric tolerance, you can relate it to a dimension
when specifying its placement.

To Set Default Dimension Text Orientation

You can control the positioning of dimension text relative to the leader lines by setting the drawing setup file
option text_orientation.

e Ifyousetitto horizontal (the default), the dimension text always appears horizontally, centered with
regard to the leaders.

e Ifyousetitto parallel, the dimension text always appears parallel to the leader lines, regardless of their
orientation. You can use the drawing setup file option parallel dim placement to specify whether
the dimension values appear above or below the leaders. The dimension text must be parallel in order for
this option to have effect; it does not have any effect when dual dimensions are present.
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The drawing setup file option angdim text orientation—not text orientation—controls the
display of angular dimensions.

As illustrated in the following figure, angdim text orientation has the following values:
horizontal, horizontal outside, parallel outside, parallel above, and
parallel fully outside.

Displaying Text of Angular Dimensions

243.9° 243.9° %

horizantal horizontal outside

Fo
parallsel outside

parallel abowe parallel fully out=ide

When you retrieve a drawing that was created before Release 15.0, the values translate as follows:

e Ifthe value of text orientation isparallel,the value of angdim text orientationis
parallel outside.

e Ifthe value of text orientationishorizontal, the value of angdim text orientationis
horizontal.

To Set The Default Chamfer Dimension Text Display

By setting the configuration file option chamfer 45deg dim_text, you can control the display of chamfer
dimension text without affecting the leader. This only affects the text of newly created dimensions. To modify
dimensions that you created before changing the setting, you must manually edit the text. Using the drawing
setup file option chamfer 45deg leader_ style, you can control the leader type of a chamfer dimension
without affecting the text. You must use chamfer 45deg _dim text and

chamfer 45deg leader style together to meet the appropriate standard. To control the use of leading
or trailing zeros in the dimension value, use the drawing setup file option 1ead trail =zeros.

About Dimensional Tolerances in Pro/DETAIL

You can set the tolerance standard as ANSI or ISO, and set the tolerance display on or off. You can drive
dimensional tolerances using a set of tolerance tables. The system assigns each model a tolerance standard of
either ANSI or ISO.

e When you switch from ISO to ANSI, the system assigns the ANSI tolerances based on the nominal
dimension’s number of digits and deletes the tolerance table reference.

e When you switch from ANSI to ISO, a set of tolerance tables drives the ISO-standard tolerances.

52 Pro/DETAIL



To Create an ISO-standard Model in Drawing Mode

1. Click DRAWING > ADV DWG OPT > TOL SETUP > Standard > TOL STANDARD > ISO/DIN. or ANSI
Pro/ENGINEER loads the system and user-supplied tables, and the General table drives all dimensions.

Note:

The system loads the tolerance tables into the model when you create it as an ISO-standard model or switch the
tolerance standard from ANSI to ISO. To create the model as an ISO-standard model, set the configuration file
option tolerance_ standard to ISO. Since the tables determine how the model regenerates, the system
stores them permanently with the model, and you can only use them with driving dimensions. Four types of
tolerance tables are available:

e General (one per model)
e Broken Edge (one per model)
e Holes (several per model)

e Shafts (several per model)

When you create a dimension, the system assigns it to the General table. When you assign the dimension to the
tolerance table, the tolerance table and its dimension value now govern the tolerance values of the dimension.
You can switch the tolerance table reference of the dimension to any other table. Dimensions in ISO models,
which are driven by Holes or Shafts tables, appear as follows:

PLTIS MIHTTE—3 59 £ % il )
HOMIMAL—30£75.58)
LIMITS—5.89 17

To Change the Tolerance Class

Each ISO-standard model has an extra attribute called the folerance class which determines the general
coarseness of the model. The configuration file option tolerance class sets the default tolerance class for
ISO models (the default is medium). The system uses the tolerance class together with the dimension value
when retrieving tolerances for General or Broken Edge dimensions.

1. Click DRAWING > ADV DWG OPT > TOL SETUP > Model Class.

2. From the TOL CLASSES menu, select a class name.

3. All dimensions driven by the General or Broken Edge table obtain new tolerance values. Regenerate the
model.

Loading the System and User-Supplied Tables

The configuration file option tolerance table dir sets the default directory for a user-defined tolerance
table. All Holes and Shafts tables overwrite existing tables when loaded. When loading General and Broken
Edge tables, keep in mind the following:

e Ifyou load one table that has the same set of class names as the model’s, the system accepts the new table.

e Ifyou load a table that contains class names that conflict with those already loaded in the system, the system
does not load those class names.

e Ifyou load two tables with class names that do not conflict with those in the system, but that are different
from them, you overwrite the ones in the system.

o [fthe default class of the model does not exist in the new names, you must specify a new class.

To Load System and User-Supplied Tables

After you load the new tables, the system assigns the new dimension tolerances and you can regenerate the
model.

When you regenerate the model by choosing Regenerate from the DRAWING menu and Model from the
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REGENERATE menu, the system goes through all of the dimensions and reassigns their tolerances from the
tolerance tables. If you modify a dimension tolerance, the system deletes the tolerance table reference for that
dimension, and the tolerance value remains the same until you modify it again or reassign the tolerance table.

If the regeneration fails, all relevant dimensions acquire the backup tolerance values. However, the new
tolerance tables remain.

Example: A Tolerance Table

TABLE TYPE
TABLE NAME
TABLE UNIT
RANGE UNIT
BASIC SIZE
—3

3-6

6-10

10-18

18-30

30-40

40 - 50

50 - 65

HOLES
A

MICROMETER
MILLIMETER

9

295/270
300/270
316/280
333/290
352/300
372/310
382/320
414/340

10

310/270
318/270
338/280
360/290
384/300
410/310
420/320
460/340

11

330/270
345/270
370/280
400/290
430/300
470/310
480/320
530/340

12

370/270
390/270
430/280
470/290
510/300
560/310
570/320
640/340

13

410/270
450/270
500/280
630/300
700/310
710/320
800/340
820/340

Changing the Tolerance Table Reference

All instances in a family share the same set of tolerance tables, the same tolerance standard, and the same class.
When changing the tolerance table reference, keep in mind the following:

e [fyou modify model units, but keep all of the dimension values the same, the system updates the tolerance

values to reflect the change in the overall model size.

e [fa Holes or Shafts tolerance table drives a dimension’s tolerances, you cannot show it in a plus-minus
symmetric format. The system assumes that the General and Broken Edge tables have symmetric values.

e Ifyou place a dimension tolerance in a family table, the system deletes its tolerance table reference. Also, if
you switch a model from ANSI to ISO, or vice versa, it preserves the tolerances in the family tables and

does not assign table references to those dimensions.

e [fa dimension value falls outside ranges specified in the table, the system uses the closest range to obtain
tolerances (that is, it uses the last range in the system table (2000—4000) to determine tolerances for

dimension values of 2000 or greater).

To Change the Tolerance Table Reference

1. Choose TOL SETUP > Tol Tables. The TOL TBL ACT menu displays these commands:
— Modify Value—Displays the tables in the TOL TABLES menu. You can modify their contents using

Pro/TABLE.

— Retrieve—Retrieves a set of tables into the model.

— Save—Saves the tolerance table.

— Show—Displays the tolerance table, as shown next.

TABLE TYPE
TABLE NAME
TABLE_UNIT
RANGE UNIT

54

GENERAL
DEFAULTS
MILLIMETER
MILLIMETER
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DESCRIPTION 0.05-3

FINE 0.05—
MEDIUM 0.1
COARSE 0.2

VERY COARSE 0.5
2. Do one of the following:
— Choose Modify Value, select the table by choosing General Dims or Broken Edges, and select the
dimensions.

— Choose Holes or Shafts; then type the table name and class number

Setting the Tolerance Display

To set the tolerance display on and off, use the drawing setup file option tol display. You can set the
default display for dimension tolerances using the configuration file option tol mode.

Using the configuration file option maintain limit tol nominal, you can maintain the nominal value
of a dimension regardless of the changes that you make to the tolerance values. If you set it to yes, the system
does not modify the Nominal Value of a dimension with a Limits tolerance format when you set the format to
Limits or change the value of the upper or lower tolerance.

To Set the Tolerance Display for Individual
Dimensions

1. Select a dimension.

2. From the right mouse button pop up menu, click Properties.

3. In the Modify Dimension dialog box, select a tolerance format from the Tolerance Mode list. Specify
values in the appropriate fields:
— For the Limits format, specify values in the Upper Tolerance and Lower Tolerance boxes.
— For the Nominal and Plus-Minus formats, specify values in the Nominal Value, Upper Tolerance,
and Lower Tolerance boxes.

— For the +-Symmetric and As Is formats, specify a value in the Nominal Value box.

4. Click OK. When tolerances appear, the system lists the default tolerance values in the lower-right corner of
the screen. .

To Modify Dimensional Tolerances in a Note

You can create a note in which you substitute a dimensional tolerance, entered as a parameter, by its value. The
following figure illustrates the format to use. You can use a similar format to include an angular tolerance value
in a note. For example, type [&angular tol 0 0] to display "0.5" (the default for one decimal).
[sangular tol 0 00] to display 0.05 etc.

Because the system includes tolerances in a note as parameters, associativity exists between the tolerance value
in a note and a model. When you change tolerance values in a note, the system updates the default tolerance
table in Part mode.

To modify the tolerance value in a note,

1. Select the note.

2. From the right mouse button pop up menu, click Edit Text.

3. Type a new value for the tolerance. Click OK.

Note: Tolerance tables do not affect thread dimensions. Thread dimensions come into the model having the
same tolerances with which the system stored them.
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About Drawing Notes

In Drawing mode, a note can be part of a dimension, attached to one or more edges on the model, or "free."
Pro/ENGINEER creates note text using the default values (such as height, font) specified in the Format > Text
Style Gallery dialog box commands.

During the notemaking process, you specify the following characteristics:

e Leaders
— No leader or multiple leaders
— A leader attached to a model edge or draft entity, pointing anywhere on the drawing
— A leader attached to a model edge or datum point
— An ISO-standard leader line
— A leader that is normal to an entity
— A leader that is tangent to an entity
e Format/Placement
— Horizontal
— Vertical
— Displayed at a specified angle
— Left-justified
— Right-justified
— Centered
— Related to dimension text
e Text style

After you create your first note, Pro/ENGINEER creates subsequent notes using those attributes that you
specified previously.

The ATTACH TYPE Menu In Pro/DETAIL

¢ On Entity—Creates a note with a leader that is attached to a model edge or draft geometry. Selecting the
entity near its vertex locates the leader at the vertex.

e On Surface—Locates the leader on model geometry or surfaces. You can select model geometry, threads,
and datum surfaces. Once you make an attachment on a surface, if you reorient the view, the attachment
remains. If the size of the surface changes, the system updates the leader point accordingly.

e Free Point—Locates the leader anywhere on the drawing. You must have a Pro/DETAIL license to create a
note using this command.

e Midpoint—Locates the leader at the midpoint of a model edge or draft geometry. The next figure illustrates
where you can find the midpoint of entities such as splines, arcs, circles, and ellipses.

o Intersect—Locates the leader at the intersection of two model edges or two draft entities.
e Arrow Head—Creates a leader with an arrow head.

e Dot—Creates a leader with a dot.

o Filled Dot—Creates a leader with a filled dot.

e No Arrow—<Creates a leader with no arrow.

e Slash— Creates a leader with a slash.

o Integral—Creates a leader with an integral.

o Box—Creates a leader with a box.

¢ Filled Box—Creates a leader with a filled box.
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To Add a Drawing Note

1. Choose Insert > Note.
Use the Note Types menu on the Menu Manager to specify the note appearance and contents source:
Note Type:
No Leader— No leader
Leader— Leader attached to specified point.
ISO Leader—Two leaders converging in one note.
On Item—No leader, note is directly attached to selected item.
Offset—No Leader, select a point offset from a selected draft item.
Note Source, (Enter or File) and if a leader is used, leader orientation,
— Standard—Uses the default leader type.
— Normal Ldr—Makes the leader normal to the entity; in this case, the note can have only one leader.
— Tangent Ldr—Makes the leader tangent to the entity; in this case, the note can have only one leader.
2. Still n the same menu, specify the alignment, (Left, Center, Right) and text style.
(By default the note is made with the current style, or last one you used. Use Cur Style to select a new
current style from a list of defined styles, or click Style Lib to define a new style. or select one from the
library.)
3. When you have finished, choose Make Note. You are prompted to supply the contents of the note either by
selecting a file or by typing in the prompt line. Select the location on an edge or datum point for the note.
4. Type an angle for the note between 0 and 359 degrees.
Note: You cannot move notes that you created using On Item, but you can modify them in all other ways.

To Relate a Note to Dimension Text

1. Choose DETAIL > Create > Note > Dim Related and any of the other available commands from the NOTE
TYPES menu.

2. When you have finished, choose Accept.

3. Select dimension text and a location relative to the text.

To Enter a Note from a File

Choose Insert > Note. The NOTE TYPES menu opens on the Menu Manager.
Select all the norte-descriptive commands you need, including File. Click Done.
Select a location on the drawing for the note.
From the SELECT FILE menu, do one of the following:
— Use the Enter NAME: command to retrieve a note from a specific directory and type a filename,
complete with its extension (for example, filename.xxx, where xxx can be any combination of
alphanumeric characters).

=

— Use the Current Dir command to retrieve a note from the current directory.

— Use the Note Dir command to retrieve a note from the default note directory. Pro/ENGINEER does not
save notes by default with the ".txt" extension. If a filename does not have a ".txt" extension, it does not
appear in the default note directory.

The note appears in the specified location.
Note: You should not include tabs in the file since they justify the note text improperly on the drawing.

Entering Notes from a File or the Keyboard

When you are entering notes from a text file, the file can reside in the current directory, or can be present
anywhere within a search path that you have specified using the configuration file option "pro_note dir." You
can enter notes from a file that contain dimensions, parameters, special symbols, and superscripted or
subscripted text. However, you cannot enter information about characteristics such as text height, text width,
text angle, and slant angle. You must use the commands in the MODIFY TEXT menu to change this information
manually.
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When you use the keyboard to type note text manually, you can add blank lines, create superscripted and
subscripted text, add symbols, and include parameter information.

To Add a Blank Line to a Note

When typing the text of a note, press the ENTER key on a blank line to exit the note creation.
To include a blank line in the note text, press the SPACE bar and then the ENTER key.

To add a blank line between text strings in a single note, use the Full Note command to edit and add the blank
lines there.

To Write Notes to a File

From the Pro/ENGINEER menu bar, choose Info > Save Note.

Select a note to save.

Type the name of a destination file. If necessary, select another note and type the filename.
4. Choose Done Sel.

Creating and Saving Drawing Notes

Using the Pro/ENGINEER Info menu, you can write the following information to a file:

®e =

e Annotations to views.
e Notes with or without a leader, containing any number of lines.
e Parameters (the system substitutes parameters with their values after copying them to a file).

Notes written to disk using Info > Save Note are automatically appended with a .txt extension and a version
increment extension. This causes notes to appear automatically in the menus when you retrieve them when you
are creating notes.

The system saves each selected note in a separate file. When specifying the name of a destination file, type the
file name without an extension. The system then automatically appends the default .txt extension and a version
increment extension (for example, note.txt.1). You can save notes with another extension (for example,
note.ascii.1). The system uses your extension instead of .txt and appends a version increment extension
(note.ascii.1). If you type the same file name as an existing file name, the system updates the version increment
extension automatically so as not to overwrite an existing file (note.txt.2).

Note: During the process, Pro/ENGINEER loses boxes and underlining information, and does not save special
symbols. To save them, bring the note into a text editor and save it from within the editor.

Example: Creating a Balloon Note

=~ CEE)

1. A single balloon note.
2. A horizontally stacked balloon note.
3. A vertically stacked balloon note.
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To Add a Balloon Note

Choose Insert > Balloon.

Choose the appropriate commands from the NOTE TYPES menu on the Menu Manager .

Choose Done and select the leader type, if necessary.

Select edges or the start point for the leaders; then choose Done Sel.

Pick the location of the balloon note and type the text.

Note: You can use the pop-up menu to manipulate balloon notes the same way you would manipulate
drawing notes.

Adding Balloon Notes

Balloon notes consist of text enclosed in a circle. You can add them freely anywhere on the drawing, or attach
them to any number of edges. When you enter multiple lines of text for the balloon note, the system encloses
each line within a balloon, stacking them horizontally or vertically next to each other, depending upon whether
you choose Horizontal or Vertical from the NOTE TYPES menu. The size of these related balloons is equal to
the largest one necessary to enclose the longest text.

A e e

To restrict the size of a balloon, use the drawing setup file options max_balloon radius or
min balloon radius.

To Wrap Note Text

When a note is created the text string is entered as one line. Use this procedure to wrap the text to a desired
width.

1. Select the note. The text is highlighted and "handles" appear on either side of the string.

2. Use the cursor to drag the right side text area handle to the desired width. The text wraps according to the
width of the text area.

If you add text to a note, the new text is not wrapped. To wrap it, you can either

e Re-drag the text box to the desired width, or

e Select the note and from the right mouse button pop up menu, click Wrap Text. The note is wrapped to the
longest line.

To Create Superscripted and Subscripted Text

To create superscripted text, type [@+text@#]and to create subscripted text, type [@-text@#],where text is
the note text that is superscripted or subscripted.

You can superscript or subscript plain text and special symbols; however, you cannot super- or subscript
dimensions, instance numbers, other parameter values, or geometric tolerances. You can create superscripted
and subscripted text as a separate note or include it in a text line with regular text on either side of it, and then
modify it independently of the rest of the text line in which it appears. The system positions the text in reference
to the closest line of regular text, whether that text is part of another note, or part of the note currently being
created.

To Place Draft and Reference Dimensions in Notes
and Tables

You can place draft (add and dd) dimensions and reference (rd) dimensions parametrically in drawing notes and
tables using &add or &dd. Draft (driven) dimensions and reference dimensions created in the drawing are
updated when the model is regenerated.

To place draft dimensions and reference dimensions in drawing tables, choose TABLE > Enter Text. Select the
table cell, and enter the symbol of the dimension, preceded by an ampersand (&).
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To Enter Special Text Characters

When typing text strings into notes, you can use special text characters, special symbols, and drawing symbols.

You can add special symbols to text strings in notes by typing them from the keyboard, the palette window, or a
text file. For a table listing all of the special symbols available with Pro/ENGINEER, as well as their definitions
and ASCII character representations, see the Pro/ENGINEER Installation and Administration Guide.

Whenever you want to display the characters & or @ in the text of a note, you must type them twice. For
example, type [See Views 1 &s& 2 @@ Sheet 3] forthe note toread See Views 1 & 2 @ Sheet 3.

To Add Special Symbols to a Text Symbol Using the
Keyboard

1. Press CTRL-a to turn on the special symbol font file.

2. Type the ASCII characters that represent the special symbols.

3. Press CTRL-b to turn off the special symbol font file.

The system displays the special Symbol Palette window whenever you begin to enter note text.

The Symbol Palette Input Configuration File Option

You can use operating system commands to resize the palette window, but the window reverts to its normal size
each time that you press the ENTER key. If you set the configuration file option symbol palette input
to yes, the palette appears whenever you begin to enter a note. If you set it to no, it does not appear at all.

As you move the pointer over each symbol or character on the palette, the system highlights that symbol; if you
select it, it enters the symbol’s ASCII equivalent (enclosed between ~A and "B) in the text of the note you
create. To define your own special fonts and symbols, see the Pro/ENGINEER Installation and Administration
Guide.

To Add Drawing Symbols to Notes

You can include a drawing symbol in a note if its instance is present in the drawing. To include a symbol, use
the following format:

&sym (<symbolname>)
Type the symbol filename without an extension.

Note: You cannot call out drawing symbols in dimensions that are stored with the model (those of type d or
ad).
When you include an instance of a generic symbol, after you type the symbol name, select groups that compose
the instance (this is similar to creating instances of a generic symbol).

For example, if a drawing contains an instance of the symbol bevel, to include the symbol in a note, type
[ssym (bevel)].

When you edit a note using the Full Note or Text Line commands, the system represents the symbol in the
following format:

n:&sym(sym path)
where n is the number of the text element, and sym_path is the name or pathname of the symbol.

Note: Pro/ENGINEER displays a drawing symbol in the text note to which it is added, but it does not display it
in the dimension text line. Dimension text resides in Part mode; therefore, it may not acquire drawing symbols
that reside in Drawing mode.

To Include the Symbol:
1. Choose Insert > Note.
2. Type the note in the format described earlier.
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3. Specify the symbol height.

4. For an instance of a generic symbol, select groups to compose the instance. To complete the instance
description, type variable text, if necessary.

5. To finish the note, press the ENTER key twice.

To Use the Geometric Tolerance Dialog Box

To access the geometric tolerance functionality in Drawing mode, click Insert > Geometric Tolerance.
Using the four tabbed pages of the Geometric Tolerance dialog box, you can perform the following tasks:

e Specify the model and the reference entity to which to add the geometric tolerance, as well as place the
geometric tolerance on the drawing.

e Specify the datum references and material conditions for a geometric tolerance, as well as the value and
datum reference of a composite tolerance.

o Specify the tolerance value and the material condition.
o Specify the geometric tolerance’s symbols and modifiers, as well as the projected tolerance zone.

The left side of the dialog box displays the geometric tolerance symbols available for selection. The next table
shows the geometric tolerance types and the appropriate entities that you can reference. When you place the
cursor on one of the geometric tolerance symbols, the type appears in the dialog box as balloon help and in the
message status line.

After you have created a geometric tolerance, click New Gtol to create additional geometric tolerances. After
you have modified an existing geometric tolerance, click New Gtol to create a copy of the geometric tolerance
that was just modified.

Notes:
Reference Entity Types

Not all reference entity types are available for all geometric tolerance types. You must select a new entity
whenever you change the entity type. The system does not allow you to complete the creation of a geometric
tolerance until you select a reference entity. The reference entity is the geometry or feature that the geometric
tolerance controls; you should not use it in place of a set datum or as an attachment type for the gtol.

Removing GTOL Restrictions

Set the configuration option restricted gtol dialog to no to remove the standards restrictions
mentioned above when picking certain GTOL types.

Example: Geometric Tolerance Classes and Types

Class Type Symbol Reference Entity
Form Straightness — Surface of revolution, axis, straight edge
Flatness o Plane surface (not datum plane)
o
Circularity Cylinder, cone, sphere
Cylindricity Cylindrical surface
Profile Line o Edge
s
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Surface Surface (not datum plane)

Orienta- Angularity < Plane, surface, axis
tion i
Parallelism 1 Cylindrical, surface, axis
Perpendicularity Planar surface
Location  Position & Any
[
Concentricity = Axis, surface of revolution
Symmetry Any
Runout Circular ! Cone, cylinder, sphere, plane
ar
Total Cone, cylinder, sphere, plane

Model Refs Options

e Model—Specifies the model in which to add the gtol. You must explicitly select the model first. You can
select the top model from the Model list or click Select Model to select a submodel. By default, the current
geometric tolerance model is the current drawing model.

o Reference: To Be Selected—Specifies the reference entity type (edge, axis, surface, feature, datum, entity,
or none). Select an item from the Type list or click Select Entity.

e Placement—Places the geometric tolerance in the drawing. Click Place geometric tolerance and select an
item from the Type list:
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Dimension—Attaches the geometric tolerance to a dimension. The drawing setup file option

gtol dim placement determines its location below the dimension. You can attach multiple gtols
(stacked) to the same dimension, and they behave as a single tolerance when you manipulate the
dimension symbol.

Datum—Attaches the geometric tolerance to a datum. If the geometric tolerance is already attached
directly to a datum, the system selects this item for you.

Leaders—Attaches the geometric tolerance to multiple edges (including datum quilt edges) with leader
lines or to dimension witness lines.

Free Note—Places the geometric tolerance anywhere on the drawing. In Part mode, you cannot display

free gtols that were created in Drawing mode. You can use Free Note placement only when you have
selected The Drawing from the Model list as the top model.

Normal Leader—Attaches the geometric tolerance to an edge along a leader line that is perpendicular
to the selected edge.

Tangent Leader—Attaches the geometric tolerance to an edge along a leader line that is tangent to the
selected edge, orienting the geometric tolerance text box at the same angle as the leader.

Other Gtol—Attaches the new geometric tolerance to an existing one (you cannot attach the existing
geometric tolerance to a dimension).

Dim Related—Relates a geometric tolerance to specified dimension text. Select this item from the
Type list; then select dimension text and a location relative to the text. To relate an existing free
geometric tolerance to dimension text, choose TOOLS > Relate Obj.

Make Dim—Creates a driven dimension and attaches the dimension to it. This dimension belongs to
the drawing. The geometric tolerance appears in standard dimension format, but with the geometric
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tolerance instead of a dimension value.

Tip: Reference Entity Types

Not all reference entity types are available for all geometric tolerance types. You must select a new entity
whenever you change the entity type. The system does not allow you to complete the creation of a geometric
tolerance until you select a reference entity. The reference entity is the geometry or feature that the geometric
tolerance controls; you should 7ot use it in place of a set datum or as an attachment type for the gtol.

Datum Refs Options

e Datum References—Specifies the primary, secondary, and tertiary datum references for any geometric
tolerance that permits datum references. Click Primary, Secondary, or Tertiary and select an item from
the Basic and Compound lists. The lists contain the currently selected datum and all other datums in the
current geometric tolerance model. If you want to select another set datum or axis, click Select.... For basic
and compound datum references, you can also specify a material condition by selecting an item from the
Basic and Compound lists.

e Composite Tolerance—Creates a composite gtol. Type a value in the Value box and select the datum
references to show from the Datum Reference list.

e Unordered—Select this checkbox to allow two datum references to be listed in the same section of the
control frame.

Example: Datum References for a Composite
Tolerance

i 3
oo ot Totmzlotmr | | 001 [DTMITDTMZ] DT
1= 0] 2 oo o ToTmz
o 4

OO |DTMI | DTM2 | DTM | O {DTMT DTMZ [DTM |
1= 001 (DT — 0T DTMI | DTMZ2 | DTMI

No datum reference.
Primary datum reference.
Secondary datum reference.

B NS B S

Tertiary datum reference.

To Specify the Tolerance Value and Material
Condition

Using the buttons on the Tol Value page of the Geometric Tolerances dialog box, you can specify the
tolerance value and material condition.

e Tolerance Value—Specifies the tolerance value. Type a value in the Overall Tolerance box, or select the
Per Unit Tolerance check box and type a value in the Value/Unit and Unit Length boxes (or Unit Area
for some geometric tolerance types).
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e Material Condition—Specifies the material condition.

LMC {L) Least material condition

MMC {«) Maximum material condition

RFS Regardless of feature size

RFS/Default RFS, but does not show a symbol in frame

To Specify Symbols and Modifiers

Using the buttons on the Symbols page of the Geometric Tolerance dialog box, you can specify the gtol’s
symbols, modifiers, and the projected tolerance zone.

¢ Symbols and Modifiers—Specifies the geometric tolerance symbols and modifiers. Select the Statistical
Tolerance, Diameter Symbol, Free State, All Around Symbol, Tangent Plane, or Set Boundary check
box.

e Projected Tolerance Zone—Specifies the location of the projected tolerance zone. Select None, Below
Gtol, or Inside Gtol. You can also specify the height of the projected tolerance zone by typing a value in
the Zone Height box.

e Profile Boundary (available for Profile gtols only)—Specifies unilateral direction, bilateral direction, or
both. The Flip side allows you to modify the profile direction.

About Using Reference Datums

Before you can reference a datum plane or axis in a geometric tolerance, you must set it. When you set a datum,
its name is enclosed in a rectangle. Once you have set a datum, you can still use it in the usual way to create
features and assemble parts.

When displaying set datum planes, keep in mind the following:

e A set datum plane, attached to a dimension, appears in a drawing only when you show the dimension to
which it was associated.

e The system does not show a reference datum plane in a drawing unless it is perpendicular to the screen.

To Set a Datum in Drawing

When you set a datum, you can also choose to attach it to a dimension.

Select the name of the datum you want to set.

Click Edit > Properties. The Datum dialog box opens.

In the Type field, click the rectangle-surrounded "-A-."

Use the Placement field to specify whether the datum is free or part of a selected dimension.
Click OK.

To Place a Set Datum in a Dimension

1. Select the name of the datum you want to place.

2. Click Edit > Properties. The Datum dialog box opens.

3. Use the Placement field to specify whether the datum is free or part of a selected dimension.

4. Click OK.

Note: If you set the drawing setup file option gtol datums to STD_ASME or STD_ISO, you can also place
a set datum on a geometric tolerance. Click In geometric tolerance and Pick Gtol in the Datum dialog box;
then select a geometric tolerance in the model.

NhwD =
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To Create a Reference Datum Attached to a
Cylindrical Surface

1. Select the axis. Note: The axis must exist on the cylindrical view.

2. Click Edit > Properties. The Axis dialog box opens.

3. Click the rectangle-enclosed A in the Axis dialog box to change to ISO standard, and then select On
Geometry in the Placement area.

4. Select the cylindrical surface to which you want to attach the reference datum. The reference datum snaps to
the cylindrical surface.
Note: The reference datum attaches at the point where you made the selection on the surface.

5. Click OK.

Example: Geometric Tolerance Symbol with a
Compound Datum

L | o —B@

1  First datum feature.
2 Second datum feature.

About Basic Dimensions

Basic dimensions are theoretically exact dimensions that appear with the measurement value and any associated
text enclosed in a feature control frame. If the original dimension has tolerances, the system automatically
removes them; you cannot add tolerances to basic dimensions. You can transform existing dimensions into
basic dimensions, and set inspection dimensions according to the DIN standard.

To Set A Dimension as a Basic Dimension

1. Select the dimension to change.
2. Click Edit > Properties..

3. In the Display field, click Basic.
4. Click OK.

To Set a Dimension as an Inspection Dimension

Select the dimension to change.

Click Edit > Properties..

In the Display field, click Inspection. The dimension is enclosed in an oval.
Click OK.

About Drawing Datum Targets

Use datum targets to indicate critical measurement points on the plot. The target is drawn inside a scalable
circle with a leader. You can create a datum target specifying any set datum point, except one that has been
created using Offset Csys. Simple datum targets reference a selected set datum point on a surface or edge.

e NS
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Diameter datum targets contain a required diameter.

When a target is added, the lower part of the circle references the datum name, and adds an integer to note the
instance of the target symbol; for example, DTMS5 becomes DTM51, DTMS52, etc.

Draft targets do not resequence themselves if you delete one of them. For example, if there are three datum
targets (B1, B2, and B3), deleting B2 leaves B1 and B3, not B1 and B2.

Using the Show/Erase dialog box, you can show datum targets in multiple views.

To Create Datum Targets

1. Choose Insert > Target.
2. In the drawing, select a set reference datum. You can select draft datum planes and axes as well.
3. Using the TARGET menu in the Menu Manager, do one of the following:

— Choose Simple to contain the name of the referenced datum in the lower half of the datum target
symbol.

— Choose Diameter to select a dimension point for each datum point (shown in the top half of the datum
target symbol).

— Choose Line to select a datum curve. The curve you select must be a line, and it must reside in the view
where you selected the set datum plane or axis. You cannot select a datum curve that is not a line in this
view.

4. Using the GET DTM PNT menu, do one of the following:
— Choose Select Point to select a datum point in the drawing.

— Choose Create Point to create a new datum point.

5. Click on the location point for the target.
The target and leader are added to the drawing. You can move or resize the target symbol.

To Modify the Material Condition

Select a geometric tolerance.

Click Edit > Properties. The Geometric Tolerances dialog box opens.

Click the Tol Value tab.

Select a material condition from the drop-down list. The system updates the geometric tolerance on the
screen.

5. Click OK.

To Modify a Datum Reference to a Geometric
Tolerance

Select a geometric tolerance.
Click Edit > Properties. The Geometric Tolerances dialog box opens.
Click the Datum Refs tab.
Do one of the following:
— Add a new datum reference by converting an existing simple datum reference into a compound
reference feature. Add a secondary or tertiary datum reference clicking either Secondary or Tertiary.
Select a datum reference from the Compound list. Specify a material condition, if needed.

el
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— Replace a datum reference with another datum. Click Primary, Secondary, or Tertiary (whichever is
appropriate) in the Datum References box; then select a different datum name from the Basic or
Compound list. If the datum that you want to use is not on the list, click Select... to select it in the
drawing.

— Remove a datum reference. Click Primary, Secondary, or Tertiary in the Datum References box
(whichever is appropriate); then select None from the Basic or Compound list.

5. Click OK.
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Tip: Adding Geometric Tolerances to Notes

Every geometric tolerance symbol on a drawing has a symbolic representation. You can include a geometric
tolerance in a note as a parameter by typing its symbolic value in the format [sg#], where "#" is the number
indicating the order in which the geometric tolerance was created.

Example: Symbolic Representation

| /
=S[00 90

1  Geometric tolerance symbol.
2 Switched to symbolic format.

Example: Note Creation

Enter HOTE:The note includes &gl

The nete includes [&2]. 0020 |

1 Type a note at the system prompt.
2 This note appears on the screen.

To Delete Geometric Tolerances

In Drawing mode, you can remove a geometric tolerance by selecting it and using Delete from the right mouse
button pop up menu. However, a geometric tolerance remains intact in a note even if you delete it from the
drawing. If you delete it from Part mode, the system replaces it in the note with "***".

About Showing Geometric Tolerances in Different
Modes

You can create assembly, part, or draft (not associated with the model) geometric tolerances in Drawing mode.
However, geometric tolerances created in Part and Assembly modes do not automatically appear in Drawing
mode.

When you place a geometric tolerance on a dimension in Part mode, keep in mind the following rules:
e Ifyou place a geometric tolerance on a dimension in a part, and then create a drawing using that part, you
must show the dimension in the drawing first; otherwise, the geometric tolerance does not appear.

e Ifa geometric tolerance is attached to a part dimension that the system cannot display in an assembly
drawing, it does not display the geometric tolerance either.

You can use the View > Show and Erase dialog box to display geometric tolerances that were created in

Assembly and Part modes.
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About Surface Finish Symbols

You can add surface finish symbols to a model using standard surface finish symbols available with
Pro/DETAIL, or you can create your own surface finish symbols. However, you cannot attach surface finish
symbols to parts intersected by an assembly feature.

If you have a license for Pro/DETAIL, you can access a set of standard surface finish symbols in the
Pro/ENGINEER directory loaddirectory/symbols/surffins, as shown in the following table.

Generic Machined Unmachined
no_value v v v
standard v value v value o value

Surface Finishes for Drawings

Pro/ENGINEER reflects drawing surface finishes only in the drawing. It supplies a generic surface finish
symbol that consists of building blocks, or groups. To create a desired instance, you must select any groups that
you want to include in the symbol and specify required information. The generic surface finish symbol is
located in the system symbols area.

Surface finishes are associated with surfaces in the part, not the entities or views in the drawing. Each surface
symbol applies to the entire surface. When you specify a surface finish for a surface that already has one,
Pro/ENGINEER redefines the surface finish information in the part and replaces the old symbol with the new
one. Just as you cannot display the same dimension in two different views, in Pro/ENGINEER, you cannot
display the same surface finish in two views.

If you create and add your own surface finish symbols, specify their location by setting the configuration file
option pro_surface finish dir.

To Add Surface Finish Symbols

1. Choose Insert > Surface Finish.

2. Using the GET SYMBOL menu, do one of the following:

— Use Name to select a symbol from the namelist menu. This menu lists all of the symbols that are
currently in the drawing. When symbols appear to have the same names, but are, in fact, from different
symbol directories, the system identifies them in the SYMBOL NAMES menu with a number in
parentheses (#). The one-line help for each name provides the name and path for each symbol.

— Use Pick Inst to select a symbol by selecting any instance of the symbol in the drawing.

— Use Retrieve to select a symbol by choosing one from a list of symbols on disk. Selecting UP brings
you up one directory. Selecting another directory name brings you down to that directory. The menu
name is the name of the current directory. Unlike storing a symbol, you can retrieve one from anywhere
you have read permission, both up and down the directory tree.

Choose one of the commands from the INST ATTACH menu.

Respond to the system prompts and menu commands for the commands you chose.

5. Type a value for the surface roughness. The system places the symbol on each surface you select on the
drawing with the size relative to the default text height.

The INST ATTACH Menu

o Leader—Creates the symbol with a leader. Choose commands from the ATTACH TYPE menu .

W

o Entity—Attaches the symbol to an entity (model edge or draft geometry).

e Normal—Attaches the symbol to an edge, entity, or dimension. Positions it with the vertical reference
pointing up. When attached to an edge at an angle, a yellow arrow indicates To position it normal to the
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selected entity.
e No Leader—Creates a symbol that is unattached.

o Offset—Creates a symbol without leaders that is placed relative to a detail entity.

Valid Surface Finish Symbol Groups

The following table describes the groups that you can use to create a surface finish symbol. The first column
indicates whether it is an ANSI or ISO symbol, or both.

Creating a Surface Finish Symbol

ISO/
ANSI

ANSI
ISO

ISO
ANSI
ISO
ANSI
ISO only

ANSI
only

ISO
ANSI
ISO
only
ANSI
only
ISO
ANSI

GROUPS

LEADER

MACHINED

NO_REMOVAL

PROD METHOD

ROUGH_
SPACE

SAMPLE LEG

OTHER_ROUGH

DESIGNATION

REMOVAL
ALLOW

Pro/DETAIL

DESCRIPTION ILLUSTRATION
Used to create a symbol ;. S 23
leader.

Material removal by ?{
machining is required.
Material removal prohibited. ’9"{

Text used for specifying \/ prod method taxt

production method.

Required maximum
roughness spacing (mm or
inch).

Roughness sampling length or @E: ——_Zampla langth
cutoff rating (mm or inch).

E?"E =——zample langth

.\f—-—(mughness
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Text used for specifying other
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Text used for special
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machining that is required to
produce the surface (mm or
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ISO
ANSI

ISO
ANSI

ANSI
only

ISO
ANSI
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LAY

UNSPECIFIED

WAVINESS

ROUGHNESS

Designates direction of lay.
The system supports the
following types:

PARALLEL—
Approximately parallel to the
line representing the surface
to which the symbol is
applied.
PERP—Approximately
perpendicular to the line
representing the surface to
which the symbol is applied.

ANGULAR—Angular in
both directions to the line
representing the surface to
which the symbol is applied.
MULTI DIR—
Multidirectional.
CIRCULAR—
Approximately circular
relative to the center of the
surface to which the symbol
is applied.

RADIAL—

Approximately radial to the

center of the surface to which

the symbol is applied.
NON_DIR—
Nondirectional, or
protuberant.

Basic surface texture symbol.
You can produce the surface
by any method, except when
the bar or circle is specified.
Specified waviness (mm or
inch):

WAVE HEIGHT—
Maximum waviness height.

WAVE_SPACE—
Maximum waviness spacing.

Roughness rating indicates
permissible roughness range
(mm or inch). The system
supports these types:
AVERAGE—

Roughness average rating.

MAX MIN—Maximum and
minimum roughness average
values.

\/; y parallal
v/J__,,,_|:-E|r|:uE|n|:Ii|: ular

Vi{_"—angular

multidirectional

ru1-ll—

Vf.;-—circ ular
v/_

A*—radial

"*-z'/_ nondirec tional
p—

v

height  spacing
A

\frmmﬁ_
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roughness
—
Fr X
and 14
S —*=n
Frinimum
roughness
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About Drawing Tables

A drawing table is a grid of rows and columns in which you enter text. It has justified text, cells in which you
type text, and a specified number of characters and lines per cell. The text in a drawing table has complete
drawing text functionality; you can modify it using the MODIFY TEXT menu commands. You can enter
dimension symbols and drawing labels as well, and the system updates them as you modify the model or
drawing. You can include a drawing table in drawing formats, drawings, and layouts.

Using Pro/Report with Tables

The optional Pro/Report license lets you designate certain cells as "repeat regions" that automatically populate
with design data that you specify through special report parameters. If you define these regions in a report file,
(.rep) they are read-only. If you define them in a drawing however, you can edit values shown in the drawing
table and pass the edits back to the associated parts.

Click See Also for more information on this subject.
Using the Pop-Up Menu
Using the Pro/ENGINEER pop-up menu, you can modify and manipulate drawing tables in the following ways:

e Move them to another location on the drawing sheet.

o Edit cell text and text style as you would a note, with one exception. When you choose a cell belonging to a
repeat region, you can enter a Pro/REPORT symbol.

e Remove the contents of the cell or the entire table.

e Change the size of the row or column of the selected cell in either drawing units or text height/length units.
e Rotate the table 90 degrees about its origin.

e Specify a new origin for the table (you can only select a corner of the table segment of the active cell).

To Create a Drawing Table

1. Choose DRAWING > Table > Create.

2. From TABLE CREATE menu, choose a command.

3. Locate the table by clicking on the drawing. If you chose Descending and Rightward, the system uses the
position to indicate the upper-left corner of the table.

4. A scale of numbers appears. The system displays these numbers according to the current text height in the
drawing setup file. Mark off the width of each column (the number of characters that the row can contain at
the current text height) by selecting a number. Choose Done when you have finished.

5. Mark off the height of each row (the number of lines of text that the row can contain at the current text
height) by selecting a number. Choose Done when you have finished.

To Enter Text in a Table

To add text to or edit text in a drawing table,

1. Choose Enter Text from the TABLE menu.

2. Select a cell and type the text. You can type multiple lines.
If you set the configuration file option symbol palette input to yes, a palette window appears
listing special characters available with Pro/ENGINEER. To use the palette, first select a cell; then select
characters from the palette.

3. To finish, press Enter twice.

When you add text to the table, the system sets its height according to the drawing setup file option

drawing text height. To override the current setting, or to modify the parameters of the selected table

text, use the Mod Text Style command on the right mouse button pop up menu.

To Word Wrap Drawing Table Text

1. Select the table cell containing the text
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2. From the right mouse button pop up menu, click Wrap Text. The text wraps to the column width.
Note: If you need to extend the row height, use the Mod Row Height command on the right mouse button pop
up menu.

Tip: Tables on Layers

You can place drawing tables on a layer by choosing Dwg Table from the LAYER OBJ menu. Text in the table
has the same display status as the table.

To Copy Cell Contents

You can copy the contents of a cell into another (empty) cell or create a copy of the entire table in the drawing.

1. Choose Drawing > TABLE > Copy > Copy Cell.

2. Select a cell to copy.

3. Select destination cells. The system copies the contents of the highlighted cell. Click the middle button to
exit.

To Copy a Table

1. Choose Drawing > TABLE > Copy > Copy Table.
2. Click inside the table to highlight the original.
3. Using a command in the GET POINT menu, select a point on the screen to locate the origin of the new table.

To Merge the Cells of a Table

1. Choose Drawing > TABLE > Modify Table > Merge.
2. From the TABLE MERGE menu, choose Rows and Columns or Rows & Cols.
3. Select the opposite corners of the range of cells to convert by selecting within the cells.

Restrictions When Merging Cells
When merging cells, keep in mind the following restrictions:

e The columns or rows you are merging must be similar.

e The cell containing text must be positioned properly with respect to the origin of the table. For example, in a
rightward, descending table, a cell with text must be at the left (upper) end of the range of cells you are
going to merge, with the empty cell at the right (lower) end of the range.

e Only one cell in the range can contain text.

To Remesh the Rows and Columns of a Table

1. Choose TABLE > Modify Table > Remesh.
2. Select the range of cells to remesh by selecting the opposite corners of the range of cells. Only the first cell
in the range can contain any text.

MY
X X >

1  Pick here to get the resulting table.
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To Change the Origin of a Table

1. Choose TABLE > Modify Table > Origin.

2. Locate the fixed corner of the table by selecting within the corner cell. The system changes the table origin.
The default table origin is the upper-left corner. The specified corner now remains stationary when you add
rows or columns to the table.

To Rotate a Table 90 Degrees

1. Choose TABLE > Modify Table > Rotate.
2. Select inside the table. It rotates by 90 degrees in the counterclockwise direction about its origin.
3. Continue selecting inside the table; each time that you select, the table rotates 90 degrees.

To Blank or Display Lines in a Table

1. Choose TABLE > Modify Table > Line Display.
2. From the TABLE LINE menu, choose one of the following commands:
— Blank—Blanks the selected line segment.

— Unblank—Redisplays the selected line segment in the table.
— Unblank All—Redisplays all blanked lines in the table.

Tip: Blanking a Line at the End of an Element

In a region, when you attempt to blank a line at the end of an element that falls between elements of the same
range, you must confirm that you want to blank the selected line even at the end of the range.

Modifying the Line Font, Color and Width

You can modify the line font, color, and width of a table grid the same way you would modify geometry. The
changes apply to all grid lines in the table.

To Insert a Row or a Column

1. Choose TABLE > Mod Rows/Cols > Insert.
2. Do one of the following:
— Choose Row and select a horizontal line in the table. The system displays a new row between the two
rows that border the selected line.

— Choose Column; then select a vertical line in the table. The system inserts a new column between the
two columns that border the selected line.

To Remove a Row or a Column

1. Choose TABLE > Mod Rows/Cols > Remove.
2. From the ROW/COL OPTS menu, choose Row or Column.
3. Select inside the row or column to remove.

To Resize Rows and Columns

1. Choose TABLE > Mod Rows/Cols > Change Size.

2. From the ROW/COL OPTS menu, choose Row or Column.
3. Select inside the row or a column.

4. Type the new height for the row or the width for the column.

Working With Rows and Columns

Using the ROW/COLS OPTS menu, you can manipulate rows and columns in a table in the following ways:
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e Insert a row or a column.

e Remove a row or a column.

e Change the height of a row or a column.
e Modify the justification of cell text.

You can also manipulate multiple rows or columns at one time by continuing to select cell borders after the first
selection is made.

To Justify Text in a Column

1. Choose TABLE > Mod Rows/Cols > Justify.

2. From the HOR JUST TXT menu, set the horizontal justification.

3. Set the vertical justification.

4. Select columns to justify. The system justifies any text you add subsequently, as you specified.
Note: To clear a table cell justification after typing text, click File > Delete and select the text.

Horizontal and Vertical Justification Options

o Left—ILeft-justifies the text.

e Center—Centers the text.

e Right—Right-justifies the text.

e Hor Default—Horizontally justifies the text using the default setting (left).
o Top—Justifies the text to the top of the cell.

o Middle—Justifies the text to the center of the cell.

e Bottom—Justifies the text to the bottom of the cell.

e Ver Default—Vertically justifies the text using the default setting (top).

To Modify the Justification of Individual Table Text

1. Select the cell to modify.

2. From the right mouse button pop up menu, click Mod Text Style.

3. In the dialog box, do one of the following:
— Specify the horizontal justification by selecting a value from the Justify Horiz list.
— Specify the vertical justification by selecting a value from the Justify Vert list.

4. Click Apply. The system changes the justification of the text as you specified.

To Move a Table Within a Single Sheet of a Drawing

1. Choose TABLE > Move.

2. Select one of the corners of the table to move.

3. Select a new position for that corner.

4. To move a table to another sheet, choose Switch Sheet from the SHEETS menu.

To Delete a Table

1. Choose TABLE > Delete.

Note: This command deletes the entire table, not just a row or column.
2. Select the table to delete.
3. Type [Y] to confirm.

Storing and Retrieving Tables

Using the Save/Retrieve command in the TABLE menu, you can store a table and then retrieve it into any
drawing. You can store or retrieve a table in Drawing, Layout, Format, Report, and Diagram modes. If you
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retrieve a table into a drawing that is not the same size as the drawing in which it was stored, it retains its
absolute size, that is, the size that it was when it was created.

To Store a Drawing Table

1. Choose TABLESTORE > Store.

2. Select anywhere within a drawing table.

3. Type a name for the table. The system saves it to a file in your current directory and informs you that it has
saved tablename. tbl. It gives the filename a unique version number to prevent overwriting tables with
the same name.

To Store the Table Text

Choose TABLE > Save/Retrieve > Store Text.

2. Select the table.

3. Type the name of the file (without an extension) where you want to store the table text. The system creates a
file with the name £ilename. 1. It increments the file extension by 1 whenever you specify a name that
another text file in your directory already uses.

Tip: Column Width

The location of text entries in the text files corresponds to that in the drawing table except when column strings
exceed column width. When column entities have more characters than the column width allows, the file output
expands the column width to display all characters in the string.

—

To Retrieve a Saved Drawing Table into the Current
Drawing

1. Choose TABLE STORE > Retrieve.

2. Type the name of the table or type [ 2] to select the table from a namelist menu of stored tables.

3. The table’s outline appears with its upper-left corner attached to the pointer. Place the table by selecting the
location for the upper-left corner.

Tip: Listing Tables

Using the List command in the TABLE STORE menu, you can display an information window listing all tables
stored in the current working directory, pro_format dir, and sys format dir.

About Markups

A markup is an object that, like a set of transparent sheets on top of a drawing sheet, enables you to
superimpose text and sketched entities in a variety of colors to indicate where changes may be required.

A markup is an informal sketch that you can create within Pro/ENGINEER with text superimposed over any
object.

The basis for the markup is the object that you select to mark up. To create a markup, you use an object in the
mode in which it was created:

e Part (includes all objects with a .prt extension).

e Assembly (includes all objects with an .asm extension).

e Drawing

e  Manufacturing

e Layout

e Report
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e Diagram

The object accompanies the markup file, which uses the file extension .mrk. Note: The Orientation, Model
Display, and Advanced commands are not available in the Pro/ENGINEER View menu after you create a new
markup object. You must orient your three-dimensional object before you create it. The system saves the
orientation with the markup.

Each markup is like a separate transparent sheet laid over the object and contains sketched entities and/or notes
in a single color.

During the markup process, the system does not change the object in any way, and saves all sketched entities
and notes created in Markup mode with the markup file, not with the object. Since the driving object does not
change, the system does not store it when it stores the markup.

You can also create a markup for a multisheet drawing, continuing over all of the sheets.
Note the following rules of operation for Markup mode:

e  With assemblies, the following applies:

— When you create an exploded view for a markup item, it does not affect the exploded status of the
views in other items.

— You can simultaneously see only those markup items that have the same explode status, explode
dimensions, and view orientation.

—  You can modify explode dimensions by using Mod Explode in the ENTER MARKUP menu.
e The system displays three-dimensional objects with their colors as well as drawing colors.
e A markup file must reside in the directory of the object that the markup references.
e Layout dimensions appear as symbolic.

When doing a comparison with three-dimensional markup items using the Markup, Setup, and Show
commands, you can toggle between Seen and Unseen only with those items that have exactly the same view as
the current markup item.

To Create a Markup

Choose File > New.
In the New dialog box, click Markup and OK.
From the Markup dialog box, select or retrieve an object.
Type a name for the object you are creating. The default name is your user ID.
Choose any of the following commands from the MARKUP menu to mark and annotate the object:
— Setup—Changes the color of the markup, creates a plot of it, toggles its display, or changes to another
sheet of the markup and drawing. The MRKP SETUP menu displays the following commands:

Color—Changes the color of the markup. The default markup color is red.
Show—Lists the markups in the current working area along with their color. A check mark appears
next to the markup’s name and color if it is currently displayed. Choosing the markup name again
removes the check mark and turns off its display.
Switch Sht—Displays an abbreviated SHEETS menu, enabling you to view and mark other sheets of
the drawing.
Text Height—Sets the text height before creating notes.
Line Width—Sets the width of sketched entities before creating them.

— Note—Places a note without a leader.

DR

— Arrow—Sketches an arrow. Use the left mouse button to select the point to which the arrow points;
then select the point for the other end of the arrow. Press the middle button to abort arrow creation.

— Curve—Selects the points of a curve to which a spline is to be fitted. Use the left mouse button to
select the point, the middle button to stop the curve, and the right button to abort curve creation.

— Sketch—Sketches a curve without selecting points for it. Hold the left mouse button down to create a
free curve. Release the left button to end it.

— Line—Creates a line using the left mouse button.
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— Move—Moves a note, curve, or line.
— Modify—Changes the note text or line width of a markup item.
— Delete—Deletes a markup item (note, arrow, curve, sketch, or line).

Note: The Note, Arrow, Curve, Sketch, and Line commands are "sticky": once you have chosen one of
these commands, you can continue creating that type of entity until you choose another command.

To Modify the Markup

To modify the markup, choose Modify from the MARKUP menu, followed by Note or Line Width.

About Working with Multimodel Drawings
You can manipulate views of different models that appear in the same drawing in several ways:

e Display an assembly and all of its component parts.

e Clearly show all part and assembly dimensions in the same drawing.

e Display several members of the same family with different sets of features.

e  Work with detail items, tables, repeat regions, and so on, belonging to any one of the models.
When working with multimodel drawings, keep in mind the following:

e You must add all models that are shown in the drawing to the drawing before you can display them as
views.

e The system sets the drawing scale of each model independently (you may notice the scale value at the
bottom-left corner changing when you set different models). Modify this scale for each model when the
model is active.

e To add views of a particular model, you must set that model as active.

e  When you add relations, the system adds them to the current model. Therefore, select a model before
adding a relation.

e When you replace a generic assembly with an instance assembly that uses PART B instead of PART A,
you must choose View > Show and Erase, and click Dimension in the Show/Erase dialog box to show
dimensions of PART B.

To Add Models to the Drawing

Before you can use a model in a view, you must add it to the drawing. Adding a model to the drawing does not
place a view of the model on the sheet, but lets the drawing reference the model so that you can place a view.
To add the first model click DRAWING > Views from the menu and enter the model name. For all subsequent
models, click DRAWING > Views > DWG MODELS > Add Model.

®  You can remove a model by choosing Del Model from the DWG MODELS menu; however, you must delete
all views of the model first.

e You can replace one part with another by choosing Replace from the DWG MODELS menu if the parts are
members of the same family table.

Setting a Default Model

Pro/ENGINEER considers only one model in the drawing to be the default, or current, model. The last model
added to the drawing becomes the current model, but you can set any model as current by choosing Set Model
from the DWG MODELS menu.

The system references an active model when you are adding views, or for any function that requires a default
model. For example, when you add a repeat region to a drawing table, type report parameters in the repeat
region, and update the table, it lists information from the model that was the current drawing model at the time
that you added the repeat region to the table. In addition, the Pro/ENGINEER Info menu and the Regenerate
command in the DRAWING menu apply to the active model.
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To Set a Model as Current

1. Choose VIEWS > Dwg Models > Set Model.

2. Do one of the following:

3. Select the model with which you want to work from the namelist menu. It contains only model names that
you have added to the drawing.

4. Select a view of the model that you want to make active.

5. To highlight the active model, choose DWG MODELS > Model Disp > Hilite Cur.

6. To return the model display back to normal, choose MODEL DISP > Normal.

Note: The Set Model toolbar button is available as a shortcut to set the current drawing model and is included in

the Toolbar Customization dialog box, accessed from the Pro/ENGINEER Utilities menu.

To Merge Drawings

Using the Merge command in the ADV DWG OPTS menu, you can merge two drawings. Merging allows
increased performance and management of large drawings. Individual Pro/ENGINEER users can work in
parallel and then merge their separate drawings into a single drawing file. A source file is appended to the target
file as additional sheets; for example, when you merge a two-sheet source drawing into a four-sheet drawing,
the target drawing then contains six sheets. You can later use SHEETS > Reorder to rearrange sheet order.

Note: Merging removes the source file from memory. If you previously saved the source file to disk, it is
removed from session but still exists on disk.

1. Click File > Open and select and retrieve the target drawing or report file. The target drawing is the drawing
into which you will merge another drawing.

2. Choose DRAWING > Advanced > Merge.

3. Use the Open dialog box to select the source file to merge into the current drawing. When you select a file,
the source file is merged into the current (target) file.

4. Select additional source files to be merged, one file at a time, to add additional sheets to the current drawing.

Rules for Merging Drawings
The following rules and restrictions apply to merging drawings or reports:

e  The target drawing file must be in session.
e A drawing or report cannot be merged into itself.
e The source drawing is removed from memory after it is merged.

e The main drawing file can contain one or more formats. Each sheet can use a different format. When a
source drawing is merged into a target drawing that has a different format, the source format is not
automatically replaced. You can replace the source format after the merge.

e  When the source drawing to be merged contains dimensions that are the same as those of the target
drawing, Pro/ENGINEER automatically removes these duplicate dimensions from the source drawing.

e When files to be merged reference a different version of the same model, the latest version in memory is
used for the drawing.

e The source drawing and the target drawing must use the same drawing units.

e When the source drawing and the target drawing contain a model with the same name, even if these are
different models, the model currently in session is used in the final drawing.

e  After a file is merged, the drawing setup file options from the target drawing override the setup options
used by the source drawing.

e If'the source drawing contains a drawing program, it is deleted during the merge. To preserve a drawing
program, use the drawing that contains the drawing program as the target drawing.

e Drawing parameters in the source drawing are deleted during the merge.
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About Drawing Representations

Using drawing representations, you can improve performance, particularly when working with multimodel large
assembly drawings and drawings of complex models. Drawing representation functionality is available only
with an Advanced Assembly license.

A drawing representation is a series of commands that specifies a display configuration for the current drawing.
You can use drawing representations to control which models and which views of a drawing the system

retrieves and displays. For example, you can temporarily remove all models and views that are not necessary for
current work.

With drawing representation functionality you can perform the following operations:
e Improve drawing retrieval time and improve drawing performance by minimizing display calculations such
as view regenerations and repaints

e Configure the display of a drawing so that you can work with just the drawing information that you need
for current work and keep unnecessary data out of memory

e Turn off the display of views that you are not working on so that the system does not calculate unnecessary
display information and, in particular, does not retrieve models into session when you retrieve a drawing

e Load a drawing to a particular drawing sheet, zoom location, or view center—for example, retrieve only
specified sheets of a drawing without loading all the sheets and displaying every view on each sheet

To Create a Drawing Representation
You can create a drawing representation using one of two methods:

e Create a drawing representation while you retrieve a drawing
When you select a drawing to be retrieved, you can proceed as follows:
— Access an existing drawing representation.

After you retrieve the drawing, you can execute a drawing representation. The drawing and the
drawing representation are displayed, and the drawing is configured according to the drawing
representation.

— Access the Drawing Rep Tool dialog box.

After you specify the drawing to be retrieved, click Open Rep and then click Create New Drawing
Rep. The Drawing Rep Tool dialog box opens. You can now create a new drawing representation.
This method allows you to retrieve a drawing without bringing unnecessary views and models into
session.

e Create a drawing representation after you retrieve a drawing

When you already have a drawing in session, you can use the DRAWING > Advanced > ADV DWG
OPTS > Drawing Rep > Create command to access the Drawing Rep Tool dialog box and create a
drawing representation for the current drawing.
You give each drawing representation a name and execute it. When you save the drawing, the system also
automatically saves the drawing representation for that drawing.

You can also use the DRAWING REP menu to copy or redefine a drawing representation that you previously
created.

To Configure a Drawing Representation

You can configure a drawing representation to control view display and drawing display in the following ways:

e Display or erase all views

e Display or erase a particular view

e Display or erase views of a particular type, for example, all cross-sectional views
e Display or erase all views associated with a particular model

e Display or erase views on a specified sheet
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e Load the drawing to a specified sheet

e Load the drawing to a pan/zoom state

e Load the drawing to the center of a specified view
e Set tables to frozen or updating

A drawing representation is never active—it is always executed. The drawing is always in a stage of
configuration and can be changed at any time. Creating a drawing representation means that you are specifying
one or more commands to configure the current drawing. As you specify commands, you can apply each
command to the drawing immediately, or you can define several commands and then run them at once. A delay
option is provided to allow you to configure the drawing without retrieving data until the configuration is
complete.

The order in which you define commands is important. The system compiles a list of commands and runs them
in the order in which you define them. The commands interact with each other cumulatively. For example, you
can turn all views off (command #1) and then turn on all general views (command #2).

Drawing representations behave differently than simplified representations in Part and Assembly modes in that
if one representation is executed after another representation, the drawing will display the results of both
representations. For example, you could erase all views on sheet #1; then erase views on sheet #2; and then
display all views. Each command is applied and the last command, when implemented, counteracts the earlier
commands.

The DRAWING REP Menu

Use the DRAWING REP menu commands together with the Drawing Rep Tool dialog box to create and work
with a drawing representation.

When you first access the menu, only the Create, Execute, and Done-Return commands are available.
After you have created a drawing representation, the other commands are also available.
The DRAWING REP menu contains the following commands:

Create—Opens the Drawing Rep Tool dialog box and allows you to configure a drawing representation for the
current drawing. The dialog box automatically fills in the appropriate commands and updates the selections to
the current state of the drawing.

Execute—Opens the Select Rep dialog box and allows you to select a rep to execute from the list of existing
representations. Select a rep to execute, and click OK. The system executes the selected rep for the current
drawing. That is, it executes the commands required to configure a drawing as defined by the drawing
representation. To save the drawing representation, you must save the drawing.

Copy—Copies the selected user-defined drawing representation to a new drawing representation with an
updated name.

Redefine—Displays the selected user-defined drawing representation in the Drawing Rep Tool dialog box so
that you can modify it.

Delete—Deletes the selected user-defined drawing representation.
Info—Displays a printable window containing information about the selected rep.

Done-Return—Exits the DRAWING REP menu and returns to the ADV DWG OPTS menu.

The Drawing Rep Tool Dialog Box

The Drawing Rep Tool dialog box is divided into two pages and opens with the View Display page visible. The
View Display page allows you to control view display configurations, and the Drawing Display page allows
you to control sheet, pan/zoom, and table configurations. The following options are available for both pages:

Name—Displays a default name for the drawing representation that you can change
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Navigate Sheets—Allows you to navigate through the sheets of a drawing to display the current sheet

OK—Accepts all the drawing configuration settings, closes the Drawing Rep Tool dialog box, and returns to
the DRAWING REP menu

Execute—Executes the active command or applies all the listed commands to the drawing. When there is no
active command, Execute is not available as an indication that all listed commands have been applied.

Default Drawing Representations

The system automatically creates two default drawing representations named All Views and No Views for all
newly created drawings.

To create the default drawing representations for a previously saved drawing, retrieve the drawing and save it.
The All Views and No Views default drawing representations are created.

e All Views—Turns on all views to display the full drawing, keeps tables updating, and resets the pan/zoom
setting.
All the models are retrieved.
e No Views—Turns off all views on all sheets of the drawing, keeps tables frozen, and resets the pan/zoom
setting.
No model is in session.
You can use a No Views rep to create detail items such as notes and symbols that have no attachment to the
model. You can retrieve the drawing showing only the notes and work on them without loading any models.

To Copy a Drawing Representation

After you have saved a drawing representation, you can copy the rep, using the Copy command on the
DRAWING REP menu.

1. Choose DRAWING > Advanced > Drawing Rep > Copy. The Select Rep dialog box opens, listing the
saved representations.

2. In the Select Rep dialog box, select a rep to copy from the list of existing representations, and click OK.
You can copy only user-defined representations.

3. The system copies the selected drawing representation and opens the Drawing Rep Tool dialog box. The
drawing representation name is automatically updated, the dialog box is populated with the same commands
as those of the source rep, and the current commands are displayed in the command list area.

4. Rename and modify the new drawing representation.

To Redefine a Drawing Representation

After you have saved a drawing representation, you can redefine the rep, using the Redefine command on the
DRAWING REP menu.

1. Choose DRAWING > Advanced > Drawing Rep > Redefine. The Select Rep dialog box opens, listing the
saved representations.

2. In the Select Rep dialog box, select a rep to redefine from the list of existing representations, and click OK.
You can redefine only user-defined representations.

3. The system opens the selected rep in the Drawing Rep Tool dialog box.

4. Redefine the selected rep.

To Delete a Drawing Representation

After you have saved a drawing representation, you can delete the rep, using the Delete command on the
DRAWING REP menu.

1. Choose DRAWING > Advanced > Drawing Rep > Delete. The Select Rep dialog box opens, listing the
saved representations.
2. Select a rep to delete, and click OK. You can delete only user-defined representations.
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3. The system deletes the selected rep.

To Obtain Information About a Drawing
Representation

After you have saved a drawing representation, you can obtain information on screen about the rep, using the
Info command on the DRAWING REP menu

1. Choose DRAWING > Advanced > Drawing Rep > Info. The Select Rep dialog box opens, listing the saved
representations.

2. In the Select Rep dialog box, select a rep from the list of existing representations, and click OK.

3. An information window displays such information as the name of the drawing representation, the
commands that control view display, the commands that control the loading of the drawing. Choose
File > Save to write the information to a file named drawingrep.inf, or choose File > Save As to write the
information to a designated file.

To Create a New Drawing Representation While
Retrieving a Drawing

You can create a new drawing representation upon retrieving a drawing. This procedure allows you to go
straight to the Drawing Rep Tool dialog box in the No Views drawing representation state. No drawing models
are retrieved, and Delay View Command(s) Until Execute is selected by default.

Note: Delay View Command(s) Until Execute is selected by default for creating a drawing representation
upon retrieval. This is a safeguard against accidentally retrieving the models into session while defining the
drawing representation.

With Delay View Command(s) Until Execute selected, you can specify several commands to configure the

rep before executing any of them. Each command is added to the command list. The commands are not

executed, and the system does not retrieve data, until you click Execute.

When the Delay View Command(s) Until Execute check box is cleared, each command is executed

immediately.
Choose File > Open.
. Select a drawing from the File Open dialog box (click just once to select the drawing, not to open it) and
click Open Rep. The Open Rep dialog box opens, listing the two default drawing representations, All
Views and No Views.
3. Do not select a drawing representation, but select the Create New Drawing Rep check box, and click OK.
The Drawing Rep Tool dialog box opens.

4. Note: Selecting Create New Drawing Rep is a convenient way to access the Drawing Rep Tool dialog box
without retrieving any models. The system retrieves the selected drawing, with none of its views displayed
and its tables set to frozen. The models are not retrieved into session.

To Execute a Drawing Representation While
Retrieving a Drawing

You can execute a drawing representation directly into session while retrieving a drawing, using Open Rep in
the File Open dialog box.

N =

1. Choose File > Open.

2. Select a drawing from the File Open dialog box (click just once to select the drawing, not to open it) and
click Open Rep. The Open Rep dialog box opens, listing previously saved drawing representations and the
two default drawing representations, All Views and No Views.

3. Select the name of the drawing representation you want to execute, and click OK.

The system retrieves the drawing and configures the drawing to the selected drawing representation state.

5. Note: If the drawing is already in session and you close the drawing and then access the Open Rep dialog
box, clicking Cancel brings up the drawing, which defaults to its previous state (either retrieves or does not
retrieve models).

>
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To Create a Drawing Representation for the Current
Drawing

After you retrieve a drawing, you can create a new drawing representation for the drawing, using ADV DWG
OPTS > Drawing Rep > Create.

1.

Retrieve a drawing.

2. Choose DRAWING > Advanced > Drawing Rep > Create. The Drawing Rep Tool dialog box opens with

W

7.

the View Display page visible. The dialog box automatically fills in the appropriate commands and updates
the selections to the current state of the drawing. The current commands are displayed in the command list
area.

The View Display page can be used to configure view display.

In the Drawing Rep Tool dialog box, type a drawing representation name in the Name box or use the
default.

. In the Command Definition area of the dialog box, select Display or Erase to change the view display:

— Display—Turns on the display of specified drawing views
— Erase— Turns off the display of drawing views
An erased view is replaced by a green outline containing the name of the view. To prevent erased
views from being highlighted, clear Highlight Erased Views in the Environment dialog box.
You can switch between Display and Erase as you specify cumulative commands.
Change the selection of views:
— Select All to select all the views in the current drawing.

— Select Individual to specify a particular view in the current drawing. The selection tool is
automatically activated, and the GET SELECT menu appears, allowing you to select an on screen view.
You can use Navigate Sheets to navigate to select a view on another sheet. When you select a view, its
name appears in the box.

— Select Sheet to specify the sheet(s) on which to apply the commands. Type the sheet numbers in the
sheet box. Enter a sheet number or multiple numbers separated by a comma (1,3), or specify a range (5-
12).
— Specify views of a particular type by selecting Type, and then select a view name from the Type list.
The Type list includes the most frequently used view types:
e General

e Projection

e Detailed
e Auxiliary
e X-section
e Broken

e Partial

e Exploded

You can select more than one type in any applicable combination to refine the selection. For example, select
Projection to select all projection views; then select X-section to specify only cross-sectional projection
views.

Select Individual to select an unlisted view type such as Graph, Revolved, or Of Flat Ply.

— Select Model to select all views associated with the specified drawing model. Click the selection tool

and select a drawing model from the list of available models (models belonging to the current drawing).

Each command that you define is listed in the command list area. When a rep is executed, all the commands
are performed in sequential order, as they were entered. Control the command list as follows:

— After you select an option to configure the drawing, click Add to add the command to the command

list. Add has the same effect as Execute unless the Delay View Command(s) Until Execute check
box is selected.

— To insert a command into the command list, select a command in the list, then select an option, then
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click Insert. The new command is inserted into the command list above the selected command. When
the Delay View Command(s) Until Execute check box is selected, Insert does not execute until you
click Execute.

— To delete a command from the command list, select a command and click Delete. The command is
removed from the command list. When the Delay View Command(s) Until Execute check box is
selected, Delete does not execute until you click Execute.

8. At any time, or when all the commands are listed to configure the drawing representation, click Execute.
The system applies all the commands listed, in the order in which they are listed, to the current drawing.
When all listed commands have been applied, Execute is not available unless Delay View Command(s)
Until Execute is selected.

9. Click the Drawing Display tab.

The Drawing Display page can be used to automatically retrieve a specific sheet, go to a previously named
view, or center a specific view. It also controls the behavior of tables with repeat regions.

Use the Drawing Display options to control the cosmetic components of a drawing. In the Drawing
Location area of the dialog box, do one of the following:

— Select from the Go to Sheet list of available sheets in the current drawing to specify the sheet where to
load the drawing representation (for example, load to sheet 6 of a 10-sheet drawing). When you retrieve
a drawing representation, the specified sheet of the drawing is displayed. Only specified sheets are
loaded when you retrieve the drawing representation.

— To specify a named pan/zoom location for the drawing, select the name of a view from the Go to
Named Pan/Zoom State list. This list contains the same view names that are on the View > Saved
Views list (the views that you previously defined).

When you next retrieve the drawing representation, the drawing zooms to the selected view. This allows you
to make a minor change in a particular small part of the drawing without having to see the entire drawing.

— Select Go to Center of View to specify the location for the drawing representation. Centering a view
keeps the drawing from repainting other views. Selecting Go to Center of View automatically clears
Go to Sheet and Go to Named Pan/Zoom State.

Select the view to go to from the list of views and models, or use the GET SELECT menu to select a
view, and select the middle of the view. When you next retrieve the drawing representation, the
drawing centers the specified view.
10. In the Table Preferences area, specify table control:
— As Is—Leaves BOM tables in their current state

— Frozen—Freezes BOM tables—repeat region calculations are frozen so any changes to the BOM
assembly will not be reflected in the table
— Updating—Updates BOM tables—repeat regions automatically calculate changes to BOM assembly
information
11. When you have finished configuring the drawing representation, click OK to accept the commands. The
DRAWING REP menu appears.
After you have created a user-defined drawing representation, the entire DRAWING REP menu appears, and
you can execute, copy, redefine, or delete a drawing representation, or display information about it in a
printable window.
12. Save the drawing.
Note: Saving the drawing also saves the drawing representation.

Tip: Erasing Views by Menu or by Drawing Rep Tool
Dialog Box

The Drawing Rep Tool Erase and Display options are functionally distinct from the Erase View and Resume
View menu commands so that you can prevent previously erased views from reappearing when a drawing is
retrieved.

When you erase a view using the Erase option in the Drawing Rep Tool, you must use the Display option in the
Drawing Rep Tool to display the view again; any views that you erased using the menu command Erase View
remain erased.
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When you erase a view using the Erase View menu command, you must use the Resume View menu command
to display the view again.

To Execute a Drawing Representation

You can execute a new, All Views, or No Views drawing representation. An All Views rep configures the
drawing to turn on all views to display the full drawing, keeps tables updating, and resets the pan/zoom setting.
A No Views drawing representation configures the drawing to turn off all views on all sheets of the drawing,
keeps tables frozen, and resets the pan/zoom setting. When you load the drawing, no model is loaded.

1. Choose DRAWING > Advanced > Drawing Rep > Execute. The Select Rep dialog box opens.
2. Select the name of the drawing representation, and click OK. The system executes the selected drawing
representation.

About Verifying Differences Between Drawings

Using the Picture command in the Pro/ENGINEER Utilities menu, you can verify the differences between two
versions of a drawing. After storing a picture of the drawing, you can later retrieve it over the drawing.
Anything that is the same cancels out, leaving on the screen only the differences between the two.

To generate a report that lists the differences between two objects, choose Advanced from the DRAWING menu
and Integrate from the ADV DWG OPTS menu.

After you have retrieved an integration project file and the difference report, source object, and target object are
displayed, the INTEGRATE menu appears, listing commands for performing the integration:

e Next—Move to the next item (difference) in the report.

e  Previous—Move to the previous item (difference) in the report.

e  Show—In the active window, highlight the entity (feature, component, and so forth) corresponding to the
current item in the difference report. (This command is accessible only if the current item belongs to the
object in the current Pro/ENGINEER Window.)

e Info—Open the Information window, which contains information about the current item in the difference
report (model name, component number, internal ID number, part name, and parents and or children).

e Action—Open the ACTION menu. When you specify an action for one occurrence of an item (feature,
component, and so forth) in the report, the specified action is set automatically for that item every time it
appears in the report.

The ACTION menu contains the following commands:

— To Merge—Mark this source item to be merged automatically into the target.
— To Delete—Mark this item for automatic deletion from the target.

— To Ignore—Ignore this item (that is, take no merge or delete action on it even though a difference is
noted).

— Clear—Clear all pending actions or instructions to ignore an item.

— Do Manual—Integrate the item manually. This involves copying the item manually from the source
object to the target object.

— Merged—Mark an item as "Merged" after it has been merged manually.

— Deleted—Mark an item as "Deleted" after it has been deleted manually.

— All Changes—Accept and integrate all changes to the source and target drawings.
— Source Changes—Accept and integrate the changes to the source drawing.

— Target Changes—Accept and integrate the changes to the target drawing.

— Unspecified—Allows the indicated action to be applied to all items that do not already have an action
assigned to them.

— Overwrite—Allows you to assign an action to all items, even if actions have already been assigned to
the items. The new action overwrites the existing action.
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— Current Item—Allows you to apply an action to the current item.
— All Items—Allows you to apply an action to all items that can be acted on.
— By Type—Allows you to apply an action to items by type: DIM COSMETICS or PARAMETERS.

e Execute—Perform automatically the actions specified in the ACTION column of the difference report to
resolve differences between the source and target objects. Each item is marked as Merged, Deleted, or
Ignored according to the action that was specified for it.

e Save Report—Save the difference report in your local working area as an ASCII text file.

e Merge View—Display the difference report with the items sorted in the order in which they have to be
integrated to correctly resolve all the external references (for example, parents must be merged before
children and children must be deleted before parents).

o Diff View—(Default) Display the difference report sorted by object and, within object, by item type. This
display gives a quick report of where and what the differences are.

About Hole Charts

By using the ADV DWG OPTS menu in Drawing mode, you can create hole chart tables for drawings. When you
create a hole chart table, the system automatically creates a table for drillable hole features in a specified view.
The following information is specified in a hole chart:

e Location in X and Y coordinates

e Hole diameter

You can also create tables for datum points and axes. When you create a table listing datum points, their
locations are listed in X, Y, and Z coordinates. When you create a table listing datum axes, their locations are
listed in X and Y coordinates.

The HOLE TABLE menu presents options that allow you to create a hole chart table, set up your hole chart table,
update the hole chart table, or delete a hole chart table:

— Set Up—Allows you to set up the format for your hole chart table by:

— Num Decimals—Sets the number of decimals in values in the hole chart or table.

— Param Column—Defines a parameter column for the hole chart or table. When adding a parameter
column, the parameter type must be a feature parameter.

— Label Size—Defines the size of text used for labeling holes.
— Max Rows—Defines the maximum number of rows in a hole chart or table.
— Hole Naming—Defines the method of naming holes (alphanumeric or numeric).
— Sort Setup—Modifies the protocol for sorting entries in the hole chart or table.
— Create—Allows you to create one of the following:
— Holes—Creates a hole chart table.
— Datum Points—Creates a table of datum points.
— Datum Axes—Creates a table of datum axes.
— Update—Updates changes to a hole chart table or table on the current drawing.
— Delete—Deletes the entire hole chart table or table.
After you create the hole chart, the holes are labeled on the drawing numerically for ISO standards or
alphanumerically for ASME standards.

Note: You cannot update the table any other way other than using the HOLE TABLE menu.

To Create a Hole Chart, Datum Points Table or

Datum Axes Table

1. Click DRAWING > Advanced > ADV DWG OPTS > Hole Table > HOLE TABLE > Create.
2. From the List Type menu, choose one of the following:
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— Holes—Creates a hole chart table that lists the location of a hole in X and Y coordinates and lists its
diameter.

— Datum Points—Creates a table that lists the locations of datum points in X, Y, and Z coordinates.
— Datum Axes—Creates a table that lists the locations of datum axes in X and Y coordinates.
3. Select the coordinate system for listing.

4. Select the location for the top left corner of the hole chart or table. This action creates the hole chart or table.
Note: Only drillable hole features can be listed in the hole chart.

About Including a Bill of Materials in a Drawing

If you do not have the Pro/REPORT module, but you want to add a Bill of Materials (BOM) to your drawing,
you can create a BOM file in Assembly mode by choosing BOM from the Pro/ENGINEER Info menu. Add the
BOM file to the drawing as a note entered from a file. To format or arrange the information in the BOM, you
must use the system editor. You can fully edit the BOM displayed on the drawing as a note without affecting
the original BOM file.

Note: A BOM that you add to a drawing is not connected with the BOM file that you used to create the note. If
the composition of the assembly changes, you must create a new BOM and add it to the drawing as a new note.

To Add a BOM to a Drawing

Choose Insert > Note.

Click Note Types > File on the Menu Manager.

Click Make Note. Select a location for the note (BOM) to appear.

In the file browser, type the name of the BOM file, including the ".bom" extension. The BOM appears on
the drawing.

Note: When adding a BOM to a drawing as a note, justify the note using Default or Left. If you use Center or
Right, the system might format the BOM incorrectly on the drawing.

=

About Creating a Snapshot View

The Snapshot command in the VIEWS > Modify View > VIEW MODIFY menu converts drawing views into a
collection of draft entities that are no longer associated with the corresponding model. When you make a view
into a snapshot, the following changes occur:

e All visible geometry, axes, datums, and other entities in the view become draft entities.

e  All draft entities that were previously associated with the view become free.

e All attached drawing items (such as notes, geometric tolerances, symbols, and draft dimensions) become
unattached.

e All visible model dimensions convert to draft dimensions.

e View dimensions become unassociative draft dimensions.

Note: After you create a snapshot, notes and symbols attached to this view remain parametric unless you delete
a model using Del Model. However, model datums in a snapshot view become draft entities with notes.
Consequences of Creating a Snapshot

After converting a view to a snapshot, the system deletes the view, as well as child views, children on other
sheets, and erased children.

To Create a Snapshot of a View

1. Choose VIEWS > Modify View > Snapshot.
2. Specify view(s) by doing one of the following:
— Choose All Views to make snapshots of all views of all models in the drawing. Since draft entities are
associated only with the first model of a drawing, the first model must be the active model for you to be
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able to manipulate the resulting draft entities.
— Choose Pick View. In a multimodel drawing, this command makes snapshots of views of the current
model only.

3. Asyou select each view, confirm that you would like to convert it to draft entities.
Note: After you create a snapshot, the display of view arrows might change.

About Using Drawing Overlays

Using overlays, you can superimpose selected views or an entire sheet of one drawing over the current drawing
sheet. This functionality is available for drawings, layouts, reports, and diagrams; each can reference objects of
these four types, as well as formats.

When working with overlays, keep in mind the following:

e Opverlays are read-only in the current drawing.

e The system updates overlays to changes in the source drawing.

e Overlaid views appear with all detail items.

e You cannot select overlays for any drawing procedure.

e Ifthe size of the current drawing is different from the size of the source drawing, the overlays brought into

the current drawing maintain the same screen size (that is, they occupy the same portion of the graphics
window) as they had in the source drawing.

To Create an Overlay

1. Choose DRAWING > Advanced > Overlay > Add Overlay > Place Views.
2. Position the overlay properly by doing one of the following:
— If'the source drawing object has only one visible view on each of the sheets, position the origin by
using the GET POINT menu to select a new location. Press the middle mouse button or choose Done.
— If the source drawing object has more than one view on any sheet, choose PLACE VIEWS > Select
Views and select the desired views. (If the view that you want to use as an overlay is on another sheet,
choose Change Sheet and select the required sheet). Locate the origin of the main view by selecting a
point on the screen. To accept the current position of the view origin, press the middle mouse button or
choose GET POINT > Done. The system locates all of the dependent views correspondingly.

To Overlay a Drawing onto the Current Drawing

1. Choose DRAWING > Advanced > Overlay > Add Overlay > Place Sheet.

2. If'the source drawing has only one sheet, the system confirms it and overlays the source drawing onto the
current sheet.
Otherwise, if it has more than one sheet, type the appropriate sheet number. If you do not remember the
required sheet number, type [ 2] to display the source drawing in the subwindow. Find the sheet using
commands in the PLACE SHEET menu; then choose Done. The specified sheet overlays the current drawing
sheet.

To Delete an Overlay

1. Choose DRAWING > Advanced > Overlay > OVERLAY DWG > Del Overlay.
2. Do one of the following:
— Choose Sel Overlay to specify an overlay to delete by selecting the source drawing object from the
SEL OVERLAY menu.

— Choose All Overlays to delete all overlays.

To Move an Overlay

1. Choose DRAWING > Advanced > Overlay > OVERLAY DWG > Move Overlay.
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2. From the SEL OVERLAY menu, select an overlay name or select it on the screen.

3. From the SEL OVLY ITM menu, select a view. Specify the translation vector by using commands in the GET
VECTOR menu.
Note: You can move an overlay by choosing OVERLAY DWG > Move Overlay; however, you cannot move
overlaid sheets.

About Performing a Representation by View

Using the Represent command in the VIEWS menu, you can simplify an assembly in a drawing by performing
a representation by view. When performing a representation by view, keep in mind the following:

e You can use Simplify on a given drawing view only once. If you use it a second time on a view, the system
restores the previous simplifications when it completes the second simplification.

e Replacing a model in a drawing removes all representations from the drawing.

e You cannot remove from the display any components of a subassembly if assembly constraints are using
them.

e You can suppress a feature that you used for view orientation.

e The simplified model in Drawing mode is the same database object as the original, and contains no
specific information except that pertaining to suppressed features or members.
Note: To simplify models, you can also use more flexible techniques such as family tables (with a
simplified instance that has suppressed features), member display (by blanking components), and simplified
representations (by excluding models or features).

To Simplify an Assembly in a Drawing

1. Choose INSTANCES > Simplify; then choose All Views or Pick View. The assembly appears in a small
window.

2. Select the component of the assembly to simplify.

3. Choose COMP TYPE > Rep Part to simplify the model at the part level by suppressing features; or, choose
COMP TYPE > Rep Subasm to simplify the model at the subassembly level by suppressing a part.

4. A subwindow appears containing the selected part or subassembly. Choose INSTANCES > NEW or type the
name of a previously created representation.

— If'the representation is new, select the feature or part to suppress.

— Ifyou select a detailed view or parent of a detailed view for representation, the system displays a box
around both the parent view and the detailed view, indicating that it is going to perform this procedure
in both views.

The system simplifies the top-level assembly accordingly.

About Using Simplified Representations

Using commands in the DWG MODELS menu, you can retrieve, modify, and remove assembly model simplified
representations, as well as create assembly views using simplified representations. Pro/ENGINEER limits
simplified representations to assembly views, and you must specify them before adding a view. You can add
multiple views of an assembly, each of a different representation, to a drawing. Once you have added a view,
you can change the representation applied in that view only by deleting the view and adding a new view with a
new representation.

To Retrieve an Assembly Model Simplified
Representation

1. Choose DWG MODELS > Add Model.

2. Type an assembly name. The SELECT REP menu (in Assembly mode) appears when you retrieve the initial
assembly and for all assembly models that you add subsequently. It lists the Master Representation and all
simplified representations that exist for the current assembly. If none have been created for the assembly
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model, it does not appear, and the system automatically retrieves the Master Representation.
3. Select a representation. The system applies that representation to subsequent views. You can accept the
Master Representation as the default, or select a different representation to retrieve.

Changing the Representation of an Assembly Model

After adding an assembly model to a drawing, you can change its representation by choosing Set/Add Rep
from the DWG MODELS menu. However, the current model must be an assembly model. Selecting a view sets
the current representation to the representation shown in that view—you can select only views of the current
representation. You can use Sel By Menu to access a list of all representations that exist for the current
assembly. The system makes the specified representation the active representation and applies it to subsequent
views. If simplified representations have been made for the assembly model, it automatically retrieves the
Master Representation.

When creating simplified representations in Drawing mode and making changes to them, you should keep in
mind the following:

e In Assembly mode, simplified representations can contain substitute parts. In Drawing mode, you cannot
apply dimensions to these substitute parts.

e When you make changes to a simplified representation in Assembly mode, you may lose information in the
drawing. For example, when you change the status of a component by substituting a previously included
component, all references to the substituted component are lost.

e  When referencing an assembly or its components in a simplified representation, the system can find and use
only those components that actually exist in the simplified representation. Specifically, when you orient a
view, you cannot use datums belonging to or placed according to components that are not in the current
simplified representation.

e You can make projected, auxiliary, revolved, and detailed views from a general view of the same simplified
representation.

To Remove Simplified Representations from
Session

1. Choose DWG MODELS menu > Remove Rep. (The current model must be an assembly model having more
than one representation in session.) The RMV REP menu appears, listing only the representations that the
drawing references.

2. Select a representation that a view is not using. You can choose one view at a time. The system prompts you
for verification before deleting each one.

Removing Simplified Representations from Session

Once you add a representation of an assembly model to a drawing, it remains in session until you explicitly
remove it. If a drawing view refers to the particular simplified representation you choose to delete, the system
does not allow you to delete it while the drawing is in session, and it attempts to retrieve the Master
Representation. If you do remove it from session and delete it, this causes an error when you retrieve the
drawing. The system prompts you to select an existing representation from the RMV REP menu, and assigns this
representation to all views that previously referred to the deleted representation. If the Master Representation of
the assembly no longer exists, you cannot retrieve the drawing.

To Replace a View of a Simplified Representation

You can replace a view of a simplified representation (including the Master Representation) with another
simplified representation.

1. Choose VIEWS > Modify Views > View State.
2. Select a drawing view to replace.
3. Select a simplified representation from the list of available representations to use as a replacement.
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About Using Geometry Representations

When working with simplified representations in Drawing mode, you can use geometry representations—a type
of advanced simplified representation. Geometry representations require less time to retrieve than the actual part
because the system does not retrieve any of the parametric information, only the geometry. You can use them to
remove hidden lines, obtain measure information, and accurately calculate mass properties.

When working with geometry representations, keep in mind the following:

e By default, you cannot create drawing references to geometry representations (this includes dimensions,
notes, and leaders), but if you set the configuration file option
allow _reps to geom reps in drws to yes, you can create references. However, these
references may become invalid if the referenced geometry changes. This option is for advanced users who
are aware that some references to geometry representations may not be updated in drawings.

e  Graphics representations are not available. If you include graphics representations in a drawing view of a
simplified representation, the system changes those representations to geometry representations. For more
information, refer to the Assembly Modeling User’s Guide.

About Creating Drawing Programs

Using the Program command in the ADV DWG OPTS menu, you can create a drawing program to define how
a drawing will adapt to a change in the state of its model. Changes might occur when you re-execute the model
with new Pro/PROGRAM inputs, or replace it with another instance from a family of models. Typically, you
can distinguish one sequence, or state, from another by the values of some of the parameters in the model.

A drawing program is intended to be used to adapt a drawing to a part or assembly program. It contains logic
statements that control the drawing layout and perform various detail functions. For example, a part drawing
might include a detailed view of a particular feature, such as a keyway. If you suppress that feature, the system
should erase that detailed view, and move the other views to fill the space. If you make a state such as

no _detail view that erases the detailed view and organizes (moves) the other views appropriately, the
program queries the system to determine if the keyway is suppressed. If so, the drawing displays the
no_detail view state. If not, the drawing displays the detailed views of the model.

A drawing program has two portions: states and program text. A state is a named sequence of familiar
procedures, such as showing a dimension or moving a view, that you perform on a drawing to define how it
should appear. It is a record of modifications that you would like to make to the drawing. To create a state, you
type a name and then record various detail commands. You can play back these commands to determine what
the drawing state actually does, and then edit it, if necessary. As you create a drawing, you can create additional
states and delete others.

You can place dimensions, dimension breaks, and dimension clips on snap lines during the creation of a
drawing program state.

Once you have defined the drawing states, you can create a drawing program, as shown in the preceding figure.
The drawing program is a text file, embedded inside the drawing, which contains lines of text that set certain
states for the drawing, depending on the values of the conditional expressions that you use. You can use IF
statements, drawing parameters, and assignment statements to set previously defined drawing states. The
program first searches the drawing for a drawing parameter; if it does not find a parameter, it searches the
default model for a model parameter. If the drawing program recognizes the drawing parameter, it designates it
with the postfix ":d" (that is, drawing_attribute:d). If it is a model parameter, it designates it with the model
number.

e Commands to execute a drawing state take the following form: SET STATE name_of state.

e You can nest IF statements in the following form:
IF <expression>
ELSE IF <expression>
ELSE
ENDIF.
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An expression is a logical expression that you could use in a part relation. It could contain drawing attributes (as
found in the SET UP menu) or the feature suppressed function (that is, FEAT SUPPRESSED (model name,

feat id) to determine if a feature is suppressed; and FEAT SUPPRESSED (assembly name, comp_id) to
determine if a component is suppressed). For example:

IF FEAT SUPPRESSED (bolt,15)

SET STATE no_detail view
In this case, the system checks to see if feature ID 15 of the model named "bolt" is suppressed. If so, it sets the
state tono_detail view; otherwise, it does nothing.

e Assignment statements take the following form: var_name = expression, where var_name is a variable
name

e Comment lines take the following form: /* This is a comment line.

Note: The words IF, ELSE, ENDIF, SET, STATE, FEAT SUPPRESSED are reserved. You cannot use
them as variable names in a drawing program. Also, if using the equal sign (=) in an IF statement, use "==".
If using a statement to set a parameter value, use "=".

Example: Drawing Program Text

IF FEAT SUPPRESSED (shaft, 12)
SET STATE no_detail view
ELSE SET STATE all detail

To Create a Record of Modifications to a Drawing (a
State)

Choose DRAWING > Advanced > Program > Define States > Create State.

Type the name of the state.

Choose Record Cmds.

From the DWG COMMANDS menu, choose commands to move, erase, and show items in the drawing; then

save these changes (later, you can edit the state and highlight those items).

5. To undo any of the modifications that you have made, choose EDIT STATE > Undo Cmds. As shown in the
illustration of the Undo State Commands text-tool window, the system places the cursor on the command
that you last executed, and highlights in the drawing window the item that was acted on. If it highlights a
command line in red, it means that the system has undone it (the name field is not always filled in because
not all items have names).

6. After you create the state, the system resets the drawing to its default display. Choose Done to activate the

state and make the changes.

The EDIT STATE menu displays the following
commands:

e Record Cmds—Displays the DWG COMMANDS menu, a compound menu of possible commands and
object types upon which to operate. After choosing an action and item type, you can modify items in the
drawing. The following table presents those commands that you can record (marked with an "X"). In
addition to those commands included in the table as not being recordable, you cannot record the following:
moving leader jogs or dimension jogs; modifying the model grid; erasing, showing, and moving cross-
section arrows and view notes; erasing or moving ordinate dimensions; and modifying filled draft cross
sections.

bl e

e Play Cmds—Resets the display of the drawing to its original display (before starting the state), and plays
each saved command in the state, pausing in between. You can stop playback by selecting the stop sign
icon in the message area. The system skips commands that do not affect any displayed sheet.

¢ Undo Cmds—Removes commands. Displays the Undo State Commands text-tool window listing
commands in the state.
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e Layer States—Displays the DPM LAYER menu. You can blank, display, or set to normal the display status

of any drawing layer. You can also leave the status unchanged. Drawing programs can only control the
status of drawing layers and cannot affect model layers.

e Set Cur Sheet—Switches to another sheet of the drawing to modify it. You can also display another

drawing sheet by choosing Windows > New from the Pro/ENGINEER menu bar. This command does not

affect the current state in any way.

Commands That You Can Record (marked with an "X")

DETAIL
ITEMS

Dimensions

Reference
Dimensions

Notes

Balloon Notes

BOM

Balloons

Symbols

Gtols

Surf Finish
Symbols

Datum

Targets

Set Datums

Axes

Draft Entities

Draft Datums

Draft Axes

Draft Groups
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Mod
Attach

X

X

Erase

Show

Show
View

X

X

Switch
Sheet

Create
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Tables X X

Views X X X X

The UNDO COMMANDS menu displays these commands:

o Next—Executes the command at the next line and moves the cursor to that line.
e  Prev—Unexecutes the command at the previous line and moves the cursor to it.
e Run—Selects a line in the text-tool window. The system executes or unexecutes commands until that line.

e Toggle Cur—Undoes the command at the current line. The system updates the drawing window to this,
and highlights the command line. If you have already undone the current command, this command restores
it.

o Pick/Toggle—Selects a command line in the text-tool window. If you choose a command that you have not
undone, it undoes it. If you choose a command that you have undone, it restores it.

To Create Detail Items in a Drawing State

To create detail items such as dimensions, notes, and balloon notes in a drawing state, choose Create from the
DWG COMMANDS menu. Items that you create in one state are not visible in any other state or outside of the
drawing program.

To Redefine a Drawing State

To redefine a state, choose Edit State from the DRAW STATES menu. From the PRGM STATES menu, choose
the state to edit. If the drawing program is not using the state, the system plays it quickly; otherwise, it rolls the
program to the point where this state is executed, and displays the EDIT STATE menu.

To Remove a Drawing State

To remove a state, choose Delete State from the DRAW STATES menu. You can delete any state that the
drawing program is not currently using.

To Call a User-Defined Function

To call in a user-defined function that is already registered in a Pro/TOOLKIT application, choose User Func
from the DWG COMMANDS menu.

The Edit Program Menu

To create a drawing program, choose Edit Program from the DRAW PROGRAM menu. The EDIT PROGRAM
menu displays the following commands:

e Insert Line—Prompts you to type text lines into the program. To finish, type a carriage return.

e Delete Line—Deletes a range of lines from the program.

e Edit Line—Modifies the current line in the message area.

e Screen Edit—Edits the program directly in the text-tool window.

e File Edit—Edits the drawing program using the system editor.

e Set State—Displays a run-time menu of all drawing states. You can select a state from the menu, or create
a new state interactively.

e Next—Moves to the next executable line of the program.

e Prev—Backs up one line, undoing the modification that line caused to the drawing. If you get to this line
by using the Jump command, you back up to the line on which the jump was started.
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e Run—Executes the program forward or backward until reaching a certain line.

e Jump—Sets the current line as a specified line number without executing any line. You can only jump to
executable lines.

e Switch Dim—Changes the data display to symbols or numerical values. This command does not change
the program or the drawing.

e Set Cur Sheet—Sets the current sheet of the drawing for display purposes. You can display another
drawing sheet by choosing Windows from the Pro/ENGINEER menu bar, followed by New. This
command does not change the program or the drawing.

To Run the Drawing Program (Execute a State)

Along with the EDIT PROGRAM menu, the DRAW PROGRAM text-tool window opens, listing the lines of the
program. Using the commands in the EDIT PROGRAM menu, you can interactively add lines to the program,
remove lines from it, step forward and backward, and modify it. As you make each change, the system updates
the display of the drawing.

Notes:
— You cannot modify a value that the program is driving (such as the value of a drawing user attribute,
the sheet on which a draft entity should be). However, you can modify a value that the program is not
driving if the program moves the view.

— Ifyou delete an item that the drawing program controls, the system automatically removes from the
state the command in the program that controls that item.

— Ifyou convert a view to a snapshot, the system removes from their states all commands in the drawing
program that control the view and its subordinate items.

— The drawing program can only modify the drawing, not the models of the drawing.

When the program appears, the system positions the text-tool cursor after the last line executed. As you move
through the program, you can change the display by choosing commands from the SET STATE menu. After you
exit the DRAW PROGRAM menu, the system executes the program in its entirety and redisplays the drawing. It
automatically updates the drawing program to reflect changes made to parts when you retrieve a drawing,
switch to Drawing mode, or regenerate by choosing Draft from the REGENERATE menu (you can use Model
only if the model changes).

After you use one of the editing commands, the system reinterprets the entire text of the program, and re-
executes the program up to the cursor.

o Ifthe interpreting is successful, it converts all parameter names, model names, and keywords to uppercase.
In addition, the model postfix of a parameter appears automatically when needed (for example, if the
drawing has more than one model).

e If'the interpreting is unsuccessful, the system informs you that an error has occurred and highlights the
error line. It cannot execute any line that is not interpreted, so if you move the text-tool cursor into an
uninterpreted area of the program, it does not execute any states and does not change the drawing. Until
you correct the error, the system does not execute the program and make the changes that the program has
made to the drawing.

About Setting the Size of a Drawing View

You can set the size of a drawing view so that when you change dimensions of the model, the size of the
drawing view stays constant relative to a given model dimension. To do this, specify the model parameter
drawing scale factor, used in Drawing mode as a view scale factor. This parameter is a scale factor
that the drawing scale multiplies to determine the actual size of the entire drawing view.

Note: This does not change the value of "d#" in the drawing or the overall drawing scale, only the spatial
dimension of the displayed entities.

The following table shows how the system calculates the size of the drawing view using the drawing scale and
the drawing scale factor model parameter.
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Calculating the Size of a Drawing View

value Length  Drawing drawing Length  Comments
of d# para- _scale scale in the
meter _factor View
5 5 1 2 10 Changing drawing scale. Drawing

scale changed to 2; the edge length
in the view becomes 10.

5 5 1 1 5 Initial conditions.

Model edge has a corresponding
dimension d# = 5. If the drawing
scale is 1 and the edge length is 5,
the "drawing_scale factor" is set to
1.

10 5 .5 1 5 Changing dimension value.

Value of d# changed to 10 in Part
or Assembly mode, so
"drawing_scale factor" becomes
.5. Makes the calculated length in
the view half of its dimension
value (it remains 5 (unchanged)).

5 10 2 1 10 Changing value of "length"
parameter.

Value of "length" parameter
changed in the relation to 10, so
"drawing_scale

factor" becomes 2. Multiplies the
length of the edges in the view by
2.

5 10 2 2 20 Changing value of "length"
parameter at a given scale.

The edge with the dimension value
of 5 appears in the drawing with a
scale of 2. Changing "length"
parameter to 10 changes
"drawing_scale

factor" to 2, so the calculated
length of the edge in the drawing is
20.

To Set the Size of the Drawing View

1. Determine the edge that you want to use as the basis for setting the drawing scale factor. The
system uses the dimension value and the length of this edge in the drawing to calculate it. Whenever you
change either one of these variables ("length" or d#), it calculates the length of model edges according to the
following equation:

length in the view = (dimension value) x(drawing scale factor) x (drawing scale)
2. Add the following relation to the part or assembly:
drawing scale factor = length / dimension

where length is the parameter corresponding to the current drawing measurement of the above dimension
d#, and dimension is a model dimension, d#.
3. Regenerate the model.
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About Setting Draft Scale

By setting a draft scale using the drawing setup file option draft scale, you can create draft entities with a
scaled size. If you set it at 0.5, any entities that you create subsequently are one-half the size that you specified.
For example, creating a horizontal line of 4 inches (by selecting one endpoint and placing the second endpoint
using Rel Coords with x=4 and y=0), the line measures as 2 inches on paper, but dimensions as 4 inches. If you
change the draft scale after creating and associatively dimensioning draft entities, the dimensions change.

The draft scale, like other parameter values in the drawing setup file, is completely independent of a drawing
scale. When the drawing size changes, the value of the draft scale does not change. The system scales the draft
geometry by the proportion necessary to maintain its relative location on the sheet, and it appears to be the same
size that it was before. The geometry is, in fact, a different size (because the sheet is a different size), and this is
reflected by any new dimensions that you create for it; the ratio of the new dimension to the previous one is
equal to the ratio of the size of the new sheet to the old one. If you set the drawing setup file option

associlative dimensioning to yes (the default), when the size of dimensioned draft entities changes,
the system updates the dimensions to the latest value ).

Example: Drawing Setup File
h_dr det setup create ex.doc
!

! These options control text not subject to other options
!

drawing text height 0.156250

text thickness 0.000000
text width factor 0.800000

!

! These options control views and their annotations
!

broken view offset 1.000000
create _area unfold segmented YES

def view text height 0.000000

def view_ text thickness 0.000000
detail circle line_ style SOLIDFONT
detail view circle ON

half view line SOLID
projection_type THIRD ANGLE
show_total unfold seam YES

view note STD_ANSI
view scale denominator 0

view scale format DECIMAL

!

! These options control cross sections and their arrows
!

crossec_arrow_length 0.187500
crossec_arrow_style TAIL_ONLINE
crossec_arrow_width 0.062500
crossec_text place AFTER_HEAD
cutting line STD_ANSI
cutting line_adapt NO
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cutting line segment
draw_cosms_in_ area_xsec
remove_ cosms_from xsecs
!

! These options control solids shown in views
!

datum_point_size
datum_point_shape

hlr for pipe solid cl
hlr_for threads
location radius

mesh surface lines
thread_standard

hidden tangent edges
ref des display

!

! These options control dimensions
!

allow 3d dimensions
angdim_text_ orientation
associative dimensioning
blank zero tolerance
chamfer 45deg_leader_style
clip dimensions

clip dim arrow style
default dim elbows

dim_ fraction format
dim_leader_length

dim text gap

draft scale

draw_ang units
draw_ang unit trail zeros
dual digits diff

dual dimension brackets
dual dimensioning

dual secondary units
iso ordinate delta

lead trail zeros
lead_trail zeros_scope
ord dim standard
orddim text orientation
parallel dim placement
shrinkage value display
text orientation

tol display

tol text height factor
tol text width factor

use major_units

98

0.000000
NO
TOTAL

0.312500
CROSS

NO

YES
DEFAULT(2.)
ON

STD ANSI
DEFAULT
NO

NO
HORIZONTAL
YES

NO

STD _ASME_ANSI
YES
DOUBLE_ARROW
YES

DEFAULT
0.500000

0.500000

1.000000
ANG_DEG

YES

-1

YES

NO

MM

NO

STD DEFAULT
DIMS

STD_ANSI
PARALLEL
ABOVE
PERCENT SHRINK
HORIZONTAL
NO

STANDARD
STANDARD

NO
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witness line delta
witness_line_offset
!

! These options control text and line fonts

!

default font

aux_font

!

! These options control leaders

!

draw_arrow_ length
draw_arrow_style
dim_dot_box style
draw_arrow_width
draw_attach sym height
draw_attach sym width
draw_dot diameter
leader_elbow_length

!

! These options control axes

!

axis interior clipping
axis_line_offset

circle axis offset

radial pattern axis circle

!

! These options control geometric tolerancing information

!
gtol datums
gtol dim placement

new_iso_ set datums

asme_dtm _on dia dim gtol

!

! These options control tables, repeat regions, and BOM balloons

!

dash_supp_dims_in region

def bom balloon leader sym

model digits in region

show_cbl_term in region

2d region columns_ fit text

!

! These options control layers
!

draw_layer overrides model

ignore model layer status

!

! These options control model grids

!
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0.125000
0.062500

font
1 filled

0.187500
CLOSED
DEFAULT
0.062500
DEFAULT
DEFAULT
DEFAULT
0.250000

NO
0.100000
0.100000
NO

STD_ANSI
ON_BOTTOM
YES
ON_GTOL

YES
ARROWHEAD
YES

YES

NO

NO
YES



model grid balloon_ size 0.200000
model_grid_neg_prefix -

model grid num dig display 0

model grid offset DEFAULT
!

! These options control theoretical piping bend intersection

!

show_pipe theor cl pts BEND CL
pipe_pt_ shape CROSS
pipe_pt_size DEFAULT

!

! Miscellaneous options
!

decimal marker COMMA_FOR_METRIC_DUAL
drawing units INCH

line style standard STD_ANSI
max_balloon_ radius 0.000000
min_balloon_radius 0.000000
node_radius DEFAULT
sym flip rotated text NO

weld symbol standard STD_ANSI

yes_no parameter display TRUE_FALSE
default pipe bend note NO
2d_region_columns_fit_text

no, yes

Determines whether each column in a two-dimensional repeat region is autosized to fit the longest piece of text
in each column.

If set to "yes," autosizes each column in 2-D repeat regions so that the longest text in the column fits within the
column and does not overlap adjacent columns or force large gaps in the table. Columns with no text in them
use the default column width for the region (the width of the template cell).

Columns of tables that contain autosized 2-D repeat regions cannot be manually resized.

allow_3D_dimensions

no, yes
Determines if dimensions are shown in isometric views.

angdim_text_orientation

horizontal, parallel outside, horizontal outside, parallel above, parallel fully outside

Controls the placement of angular dimensions in drawings. If set to "horizontal," displays text of angular
dimensions horizontally at all times, centered between the leaders (equivalent to the value "horizontal" for the
drawing setup file option "text orientation"). If set to "parallel_outside," displays text parallel to the leader
lines, regardless of their orientation (equivalent to the value "parallel" for the drawing setup file option

"text orientation"). If set to "horizontal outside," displays text horizontally outside the dimension. If set to
"parallel above," displays text parallel to the dimension arc, but above it. If set to "parallel fully outside,"
displays text of angular dimensions (with a plus/minus tolerance) parallel to the leader lines. For more
information and an illustration, see How to Display Dimension Text Symbols on page 6 - 38.
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asme_dtm_on_dia_dim_gtol
on_dim, on_gtol

Controls the placement of a set datum attached to a diameter dimension. If set to "on_dim", the set datum
attaches to the diameter dimension. If set to "on_gtol", places it on the gtol in accordance with the ASME
standard

associative_dimensioning

yes, No

Associates draft dimensions to draft entities. The system associates only dimensions that you create while you
have this set to "yes" (see Draft Dimensions on page 6 - 5).

aux_font
1 filled, # font index name (# = 1 through 8)

Sets the auxiliary text font ‘#’ as the font identified in the specified font index. The system remembers the
number of the auxiliary font as corresponding to the name of the font that appears in the TEXT FONTS menu
listing available fonts. Do not include the suffix ".ndx"; for example, "1 gothicfont."

PTC and TrueType fonts are available. See default font HELP topic for detailed information.

aux_line_font
# font name (#=1 through 10,000)

Sets auxiliary line fonts as the font specified. Uses the integer number to associate a line font to draft geometry.
In this way, you can effect a blanket change by changing the font name associated with a number. You must add
this option to the drawing setup file whenever you want to set the auxiliary font.

axis_interior_clipping
no, yes
If set to "no," displays axes in a drawing according to the ANSI Y14.2M standard.

If set to "yes," you can adjust each axis individually by clipping and moving.

axis_line_offset
0.100000, value

Sets the default distance that a linear axis extends beyond its associated feature.

blank_zero_tolerance

no, yes

Controls the display of a plus or minus tolerance value. If set to "yes," does not display a plus or minus
tolerance value if you set the tolerance value to zero.

broken_view_offset
1.000000, value

Sets the offset distance between the two halves of a broken view.
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offset distance

B

chamfer_45deg_leader_style

std_asme_ansi, std_din, std_iso, std_jis

Controls the leader type of a chamfer dimension without affecting the text.

circle_axis_offset
0.100000, value

Sets the default distance that a circular cross-hair axis extends beyond the circular edge.

clip_diam_dimensions

yes, no

Automatically clips the diameter dimensions at the view border. Dimension endpoints outside of the view
border are clipped to the view border. No clipping occurs when both endpoints are inside view border.
The default is no for drawings created in earlier releases.

clip_dim_arrow_style
double_arrow, arrowhead, dot, filled dot, arrow, slash, integral, box, filled box, none

Controls the arrow style of clipped dimensions.

clip_dimensions

yes, no

Controls the display of dimensions in a detailed view. If set to "yes," does not display dimensions completely
outside of a detailed view boundary; shows dimensions that cross a detailed boundary with a special double
arrow. If set to "no," displays all dimensions.

create_area_unfold_segmented

yes, no

Makes the display of dimensions in area unfolded cross-sectional views similar to those in total unfolded cross-
sectional views. If set to "yes," displays the view in segments when creating a new view—one piece at a time—
corresponding to the straight segments of the cross-sectional sketch. [To draw view borders between view
segments, set "show_total unfold seam" to "yes."] This option only affects new views. Pro/ENGINEER does
not support detailed views of segmented area unfolded cross-sectional views or total unfolded cross-sectional
views. However, it does support detailed views of non-segmented area unfolded cross-sectional views.

crossec_arrow_length
0.187500, value
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Sets the length of the cross-section cutting plane arrowheads.

crossec_arrow_style

tail_online, head online

Sets the display style of cross-section arrows.

]

tail_online head_online

crossec_arrow_width
0.062500, value

Sets the width of cross-section cutting plane arrows.

I I width

crossec_text place

after_head, before tail, above tail, above line, no_text

Sets the location of cross-section text. If set to "no text," does not display any cross-section text.

I
"after_head" "befora_tail"
A A
crossec_type

old style, new_style
Improves the ability to create complicated cross section views in drawings, and reduces or eliminates the
number of occurrences when a cross section view cannot be created.

If setto old_style, the system uses a cut to remove geometry to create the cross section view. If set to
new_style, the system uses a z-clipping plane to create the cross section view.
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cutting_line

std_ansi, std_din, std_iso, std_jis, std_ansi_dashed, std_jis_alternate

Controls display of cutting line. If set to "std_ansi," uses the ANSI standard for cutting lines. If set to

"std ansi_dashed," uses dashed lines. Otherwise, uses the DIN standard cutting line. Displays its thickened
portion in white, and displays its thin portion in gray. If set to "std_jis alternate" and the drawing setup file
option "cutting line_segment" is set, displays view arrows as follows:

e The thickened portion of the cutting line forms an angle and the system displays it in blue.
o Displays the connecting portions of the cutting line segment between thickened segments in yellow.
e Displays arrow portions in white.

If you set the drawing setup file option "cutting_line segment" to "0," displays the entire cutting line as a
dashed yellow line. If the length of a cutting line segment is too large, the entire cutting line displays in blue.

cutting_line_adapt
no, yes

Controls display of line fonts used to show cross-sectional arrows. If set to "yes," all line fonts display
adaptively, beginning in the middle of a complete line segment and ending in the middle of a complete line
segment.

cutting_line_segment
0.000000, value

Specifies the length in drawing units of the thickened portion of a non-ANSI cutting line. If set to "0," the
length of the cutting line segment is 0.

dash_supp_dims_in_region
no, yes

Controls display of dimension values in Pro/REPORT table repeat regions. If set to "no," displays the values in
Pro/REPORT table repeat regions. If set to "yes," suppresses the dimension and displays a dash instead.

datum_point_size
default, value

Controls size of model datum points and sketched two-dimensional points. The system does not use the units of
the drawing or model; it always displays the point size in inches.

datum_point_shape

cross, dot, circle, triangle, square

Controls display of datum points.

decimal_marker

comma_for_metric_dual, period, comma

Determines which character marks the decimal point in secondary dimensions.
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default_dim_elbows

yes, no

Controls display of dimension elbows. If set to "yes," dimensions display with elbows.

default_font configuration file option

font, font index name

Sets default text fonts as those fonts listed in the specified font index. Do nof include the ".ndx" extension. The
fonts "font" and "filled" are in the setup file.

default_pipe_bend_note

no, value

Controls display of pipe bend notes in drawings. If set as text within quotation marks, uses that value when
creating bend notes. Text may include parameters such as "&bend name:att pipe_bend" and "&bend_tol:
att_pipe bend". If set as a directory path, references a previously created note saved as a file.

def_bom_balloon_leader_sym

arrowhead, dot, filled_dot, no_arrow, slash, integral, box, filled box

Sets the default arrow (attach point) style for BOM balloons in reports.

def_view_text_height
0.000000, value

Sets the height of text in view names used in view notes and in arrows in cross-sectional and projection detail
views.

def _view_text_thickness
0.000000, value

Sets default thickness for new text in view names used in view notes and in arrows in newly created cross-
sectional and projection detail views.

detail_circle_line_style
SOLID FONT, any available system-defined or user-defined line font

Sets line font for circles indicating a detailed view in a drawing.

detail_circle_view_ note

Yes No
View note within detail circle

detail_note_text

default, value

Sets the text in the detail view reference note.
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When set to default (the default setting), detail view reference notes have the localization of SEE
DETAIL<viewname> for their text.

If set to a different value, detail view reference notes have the localization of <detail note texts
<viewname> for their text.

detail_view_circle
on, off

Sets display of a circle drawn about the portion of a model that is detailed by a detailed view.

dim_dot_box_style
default, filled, hollow

Controls the arrow style display of dots and boxes only for leaders of linear dimensions. When set to "default"
(the default setting), uses the "draw_arrow_style" setting.

When set to "filled," fills dots and boxes for arrows of linear dimensions. Use "filled" to have new drawings
appear with dots and boxes filled for dimension arrows.

When set to "hollow," dots and boxes for arrows of linear dimensions are not filled.

When set to "default" for BOM balloon arrows, the drawing setup file option "def bom_balloon leader sym"
defines the default arrow (attach point) style for BOM balloons in reports.

dim_fraction_format configuration file option
default, std, aisc

Controls the display of fractional dimensions in drawings. Unless set to "default," this option supersedes the
configuration file option dim fraction format.

If set to "std," displays fractional dimensions in drawings in the standard Pro/ENGINEER format.
If set to "aisc," displays fractional dimensions in drawings in the AISC format.

If set to "default" (the default setting), displays fractional dimensions in drawings according to the setting of the
configuration file option dim fraction format.

Set the option to "AISC" to display fractional dimensions in the AISC format. The "AISC" setting also displays
architectural units according to AISC format for feet-inches dimensions.

Set the option to "default" to display fractional dimensions according to the setting of the config.pro option
"dim_fraction format".

The drawing setup file option "use_major units" is used to control whether fractional dimensions show in feet-
inches. Use the option as follows:

Set the option to "no" and fractional dimensions are not displayed in major units.

Set the option to "default" to display fractional dimensions according the setting of the config.pro option
"use_major_units"

The drawing setup options "dim_fraction format" and "use_major_units" control the display of dimensions
when you retrieve drawings created prior to Release 2000i. You can create dimensions and the configuration
file option controls the formatting of the fractional dimensions.

The drawing setup option "dim_fraction format" controls the display of fractional dimensions in drawings. The
drawing setup option supersedes the configuration file option "dim_fraction format" unless the drawing setup
option is set to "default.”
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The drawing setup option "use_major_units" controls the display of fractional dimensions in drawings in the
same way that the configuration file option "use_major_units" controls display of fractional dimensions in Part
and Assembly modes. The drawing setup option "use major units" supersedes the configuration file option
"use_major_units" in drawings unless the drawing option is set to "default."

dim_leader_length
0.500000, value

Sets length of dimension leader line when leader arrows are outside of witness lines.

dim_text_gap
0.500000, factor

Controls distance between dimension text and dimension leader line and represents the ratio between gap size
and text height.

For the diameter dimension, if "text orientation" is set to "parallel diam_horiz," "dim_text gap" controls the
extension of an elbow line beyond the text.

draft_scale
1.000000, value

Determines value of draft dimensions relative to actual length of draft entity on drawing.

draw_ang_units

ang_deg, ang_min, ang_sec

Sets display of angular dimensions in a drawing. If set to "ang_deg," creates decimal degrees; if set to
"ang_min," creates degrees and decimal minutes; and if set to "ang_sec," creates degrees, minutes, and decimal
seconds.

draw_ang_unit_trail_zeros

yes, no

Controls display of angular dimensions. If set to "yes," removes trailing zeros (in adherence to ANSI standards)
when showing angular dimensions in degrees/minutes/seconds format. If set to "no," does not display trailing
zeros in angular dimensions or tolerances.

draw_arrow_length
0.187500, value

Sets length of leader line arrow heads.

draw_arrow_style
closed, open, filled

Controls arrow style for all detail items involving arrows, including leaders of dimensions, notes, 3-D notes,
geometric tolerances, symbols, and balloons.
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draw_arrow_width

0.062500, value

Sets width of leader line arrow heads. Drives these drawing setup file options:
draw_attach sym_height

draw_attach sym_ width

draw_dot diameter

draw_attach_sym_height
default, value

Sets height of leader line slashes, integral signs, and boxes. If set to "default," uses value set for
"draw_arrow_width."

draw_attach_sym_width
default, value

Sets width of leader line slashes, integral signs, and boxes. If set to "default," uses value set for
"draw_arrow_width."

draw_cosms_in_area_xsec

no, yes

Controls display of cosmetic sketches and datum curve features that lie in the cutting plane in planar area cross-
sectional views. If set to "yes," shows all cosmetic sketches and datum curve features that lie in the cutting
plane. If set to "no," does not show them.

draw_dot_diameter

default, value

Sets diameter of leader line dots. If set to "default," uses value set for "draw_arrow_width."

draw_layer_overrides_model

no, yes

Directs drawing layer display setting to determine the setting of drawing model layers with the same name. If
set to "yes," implicitly includes drawing model layers in drawing layers with the same name for purposes of
setting the display. If set to "no," ignores nondrawing layers when the display status of layers is set in the
drawing model.

drawing_text_height
0.156250, value

Sets default text height for all text in the drawing using value set for "drawing_units."

drawing_units

inch, foot, mm, cm, m
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Sets units for all drawing parameters.

dual_digits_diff
-1, value

Controls number of digits to the right of the decimal that the secondary dimension differs from primary
dimension. For example, using the default value -1 results in the following when primary units are inches and
secondary units are millimeters: 10.235 [259.96].

dual_dimension_brackets

yes, no

Controls display of brackets with dimension units. This option works only when you are using
"dual_dimensioning." If set to "yes," displays dimension units that occur second in brackets; if set to "no," does
not display brackets.

dual_dimensioning

no, primary [secondary], secondary [primary], secondary

Controls format of dimension display. If set to "no," displays a single value for dimensions. If set to "primary
[secondary]," displays dimensions with primary units (established by the model) and secondary units; if set to
"secondary," only displays the secondary dimensions of the drawing, as if they were primary.

dual_secondary_units

mm, inch, foot, cm, m

Sets units for the display of secondary dimensions.

gtol _datums

std_ansi, std_ansi_mm, std_iso, std_jis, std_din, std_iso_jis, std_ansi_dashed, std_asme

Sets drafting standard followed for displaying reference datums in drawings. Display affects both axes and
datum planes, and display of reference part datums.

= T

[A]

std_ansi std_iso_|is

gtol_dim_placement configuration file option

on_bottom, under value

Determines location of a feature control frame of a geometric tolerance when attached to a dimension symbol
that contains additional text. If set to "on_bottom," places the geometric tolerance at the bottom of the
dimension symbol, beneath any additional lines of text. If set to "under value," places the geometric tolerance
immediately below the dimension value and before any additional lines of text.
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half_view_line
solid, symmetry, symmetry iso, symmetry asme, none

If set to "solid," draws solid lines where material is present. If set to "symmetry," draws a centerline extending
beyond the part and acting as a break line. If set to "symmetry iso," displays a half view symmetry line
according to ISO standard 128:1982 5.5— half view symmetry lines are displayed in yellow with thin linestyle,
and the "hash" marks at the ends of the symmetry line are also yellow with thin linestyle. If set to
"symmetry asme," displays a half view symmetry line according to ASME standard ASME Y 14.2M-1992—
half view symmetry lines are displayed in yellow with thin linestyle, and the "hash" marks are displayed in
white with thick linestyle.

If set to "none," draws the object a small distance past the symmetry line. You must select an offset datum to
create the half view; make sure there is a centerline indicating the actual half.

hidden_tangent_edges
default, dimmed, erased

Controls display of hidden tangent edges in drawing views. If set to "dimmed," plots hidden tangent edges in a
view using Pen 7. Lines appear dashed in same color as dimmed visible tangent edges. However, you must
select Hidden Line or No Hidden Line from the Display Style list in the Pro/ENGINEER Environment dialog
box. If set to "erased," removes all hidden tangent edges automatically from screen and plot.

hir_for_pipe_solid_cl
no, yes

Controls display of pipe centerlines. If set to "yes," hidden line removal affects pipe centerlines. If set to "no," it
does not. Operates only on pipes created in Pro/PIPING, not on pipe features in a part.

hir_for_threads

no, yes

Controls display of threads in a drawing depending on whether it complies with the ISO or ANSI standard (set
by the "thread standard" option). If set to "yes," thread edges meet ANSI or ISO standard for Hidden Line
display.

ighore_model_layer_status

yes, no

Controls whether the system considers layer status in models. If set to "yes," ignores changes to all layer status
in the models of the drawing made in another mode.

iIso_ordinate_delta

no, yes

Improves display of offset between an ISO-ordinate dimension line and witness line, referred to as the "witness
line delta." If set to "yes," displays offset correctly, according to value specified for the drawing setup file
option "witness_line delta." If set to "no," does not display offset exactly in accordance with the specified value
(it is "off" by about 2 millimeters).
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leader_elbow_length
0.250000, value

Determines length of leader elbow (the horizontal leg attached to text).

lead_trail_zeros
std_default, std_metric, std_english, both

Controls display of leading and trail zeros in dimensions. Can also control display of leading and trail zeros in
parameters, depending on the setting of the drawing setup file option "lead trail zeros scope." If
"lead_trail zeros scope" is set to "all," controls the display of leading and trail zeros for dimensions and also
for all floating point parameters on a drawing, including parametric notes, view scale notes, tables, symbols,
and cosmetic thread notes.

When dual dimensioning is used, controls the use of leading and trailing zeros in both standards independently.

If the units in the "dual_dimensioning" drawing setup file option are "primary[secondary],"
"std_english[std metric]" shows the primary units values with trailing zeros, while the secondary units show
values with leading zeros.

nn

If the units in the "dual_dimensioning" drawing setup file option are "secondary[primary]," "std_english
[std_metric]" secondary units show values with trailing zeros, while the primary units show values with leading
ZEeros.

If set to "std_default," displays the dimension or parameter according to its units. If set to "both," displays both
leading and trailing zeros in dimensions or parameters, regardless of whether metric or English units are used.

lead_trail_zeros_scope

dims, all

Controls whether only dimensions are affected by the setting of the drawing setup option "lead_trail zeros." If
set to "dims," the drawing setup option "lead_trail zeros" controls only dimensions. If set to "all," the drawing
setup option "lead_trail zeros" controls dimensions and also all parameters, including parametric notes, view
scale notes, tables, symbols, and cosmetic thread notes.

line_style_length
font_name default, font name value

Sets the length of elements composing a font. You must add this option to the drawing setup file whenever you
want to modify the length. Type the font name and then a desired value for the font length in system units. The
"default" setting indicates default length values.

line_style_standard

std_ansi, std_iso, std_jis, std_din

Controls text color in drawings. Unless set to "std_ansi," displays all drawing text in blue, and displays
boundary of detailed views in yellow.

location_radius
default (2.), 0.0, any value

Modifies radius of nodes indicating location, improving their visibility, particularly when printing drawings. If
set to "default," sets radius as 2 drawing units. If set to "0.0," displays location nodes, but does not print them.
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There is no maximum value for this setting.

max_balloon_radius
0.000000, non-zero , value

Sets the maximum allowable balloon radius. If set to "0," balloon radius depends only on text size.

mesh_surface _lines

on, off

Controls display of blue surface mesh lines.

min_balloon_radius
0.000000, non-zero value

Sets minimum allowable balloon radius. If set to "0," balloon radius depends only on text size.

model_digits_in_region
yes, no

Controls display of number of digits in two-dimensional repeat regions. If set to "yes," two-dimensional repeat
regions reflect the number of digits of part and assembly model dimensions.

model_display_for_new_views

default
Specifies the view display for hidden lines.

model_grid_balloon_size

0.200000, value

Specifies default radius of balloons shown with the model grid in a drawing.

model_grid_neg_prefix configuration file option

-, any string

Controls prefix of negative values shown in model grid balloons.

model_grid_num_dig_display
0, value (integer)

Controls number of digits displayed in grid coordinates that appear in grid balloons. Type an integer specifying
the number of decimal places, or use the system default (0) to display coordinates as integers.

model_grid_offset

default, value

Controls offset of new model grid balloons from the drawing view. If set to "default," offsets new model grid
balloons from the drawing view by twice the current model grid spacing. If set to a value, offsets balloons by
that number of inches (not drawing units) from the view.
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new_iso_set _datums

yes, no

Controls display of set datums. If set to "yes," displays set draft datums in accordance with the ISO standard.

node_radius

default, value

Controls display of nodes in symbols. If set to "default," system specifies radius of nodes. If the setting is so
small that the nodes do not appear, the system uses the default setting. There is no maximum value for this
setting.

ord_dim_standard

std_ansi, std_iso, std_jis, std_din

Sets the standard according to the display of ordinate dimensions. If set to "std_ansi," shows dimensions
without a connecting line (Figure a). Otherwise, places related ordinate dimensions along the connecting line
that is perpendicular to the baseline and starts with a circle (Figure b). Each segment of the connecting line ends
with an arrow. Displays arrows and the circle filled or open, according to the current setting of the drawing
setup file option "draw_arrow_style." Note that when witness lines are interconnected, moving any of the
related dimensions moves all of them.
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1) If set to "std_ansi"

2) If setto "std iso," "std din," or "std jis."

orddim_text orientation

parallel, horizontal

Controls ordinate dimension text orientation. If set to "parallel," displays dimension text parallel to the leader
lines. If set to "horizontal," displays it horizontally, parallel to the bottom of the drawing sheet.
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parallel_dim_placement

above, below

Determines whether dimension value displays above or below leader line when you set the "text orientation"
option to "parallel." This option does not apply to dual dimensions.

pipe_pt_shape
cross, dot, circle, triangle, square

Controls shape of theoretical bend intersection points in a piping drawing.

pipe_pt_size
default, value

Controls size of theoretical bend intersection points in a piping drawing.

projection_type
third _angle, first angle

Determines method for creating projection views.

radial_pattern_axis_circle

no, yes

Sets display mode for axes of rotation that are perpendicular to the screen in radial pattern features. If set to
"no," displays axis lines (Figure a). If set to "yes," a circular shared axis appears, and axis lines pass through the
center of a rotational pattern (Figure b).

ref_des_display
no, yes. DEFAULT

Controls display of reference designators in a drawing of a cabling assembly. If set to "DEFAULT," selects the
Reference Designators checkbox in the Environment dialog box.

remove_cosms_from_xsecs

total, all, none

Controls display of datum curves, threads, cosmetic feature entities, and cosmetic cross-hatching in a full cross-
sectional view. If set to "all," removes datums and cosmetics from all types of cross-sectional views. If set to
"total," removes features located entirely in front of the cutting plane from the cross-sectional view. Displays
these features in full only if they intersect the cutting plane. If set to "none," displays all datum quilts and
cosmetic features.

restricted_gtol_dialog
Yes (default value) No

This config controls the restrictions in the Geometric Tolerance Dialog. When set to YES (the default), the
dialog will adhere to standards when picking certain GTOL types. This is current behavior. Setting the value to
NO will cause the dialog to drop all restrictions. select_hidden edges in_dwg

yes, no
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Disallows the selection of No Hidden edges in drawings when using Query Select by rejecting edges behind the
first surface at the selection point.

show_cbl_term_in_region
no, yes

Allows use of the report symbols "&asm.mbr.name" and "&asm.mbr.type" to show terminators in Pro/REPORT
tables for cable assemblies having connectors with terminator parameters. If set to "yes" (you must set the
attribute Cable Info for the repeat region), shows terminators. When creating new drawings, the default value is
"yes." For existing drawings, the default value is "no."

show_pipe_theor_cl_pts
bend cl, theor cl, both

Controls display of centerlines and theoretical intersection points in piping drawings. If set to "bend_cl," shows
centerlines with bends only. If set to "theor cl," shows only centerlines with theoretical bend intersection
points. If set to "both," shows both bends and theoretical intersection points.

show_preview_default

remove, keep
Determines the default behavior for preview in the Show/Erase dialog. Set to Remove sets the default to be Sel
to Remove. Set to Keep sets the default to be Sel to Keep.

show_quilts_in_total xsecs

no, yes

Determines if surface geometry is included in a drawing cross section and whether the surface will be cut by the
cross section cutting plane. Set to no (default) to exclude surface geometry. Set to yes to include surface
geometry.

show_total _unfold _seam

yes, no

Controls display of seams (the edges of the cutting plane) in total unfolded cross-sectional views. If set to yes,
makes the seams; if set to "no," blanks them.

shrinkage_value_display
percent_shrink, final value

Displays dimension shrinkage in percentages or as final values.

sym_flip_rotated_text

no, yes

Flips any text in a Rotate Text symbol that is upside down, making it right-side up. If set to "yes" and the
symbol orientation is +/- 90 degrees, flips the text, rotating it along with the symbol (for an illustration, see
Manipulating Instances on page 10 - 28).

sym_rotate_note_center

yes, no
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Controls display of a symbol and its notes and their reorientation upon mirroring and rotation. If set to "yes,"
rotates symbol notes as if their origin was not at the bottom of the text, but in the middle of the height of the text
instead. If set to "no," rotates text by rotating its origin point, as it is.

tan_edge display_for_new_views

default
Specifies the tangent edge display.

text_orientation
horizontal, parallel, parallel diam_horiz, ISO_parallel, ISO_parallel diam_horiz

Controls orientation of dimension text in the drawing. If set to "horizontal," displays all dimension text
horizontally. If set to "parallel," displays text parallel to a dimension leader line. If set to "parallel diam_horiz,"
displays all dimensions except diameter dimensions parallel to their leaders; displays only diameter dimensions
horizontally. The elbow of a diameter dimension always extends through to the end of the text. To control the
elbow extension beyond the text, use the drawing setup file option "dim_text gap." If set to "ISO_parallel,"
displays text parallel to a dimension witness line. This differs from the value "parallel" since this will also allow
dimension tolerances to be displayed in ISO 406:1987 (E) format or British Standard Tolerance Format. If set to
"ISO_parallel diam_horiz," displays all dimensions except diameter dimensions parallel to their leaders. Limit
tolerances will be stacked in accordance with ISO standard.

The drawing setup file option "angdim_text orientation" (not "text_orientation") controls the display of angular
dimensions.

text_thickness
0.000000, 0<value<.5

Sets default text thickness for new text after regeneration and existing text whose thickness has not been
modified. Type the value in drawing units.

text_width_factor
0.800000, .25<#>8

Sets default ratio between the text width and text height. The system maintains this ratio until you change the
width using the Text Width command.

thread_standard

std_ansi, std_ansi_imp, std_iso_imp, std_iso_imp_assy, std_ansi_imp_assy, std_iso

Controls display of threaded hole with an axis (perpendicular to the screen as an arc (ISO standard) or as a
circle (ANSI) standard).

If set to "std_ansi_imp" or "std_iso_imp," does not display hidden thread lines when you select No Hidden
Line from the Display Style list in the Pro/ENGINEER Environment dialog box. When you select Hidden
Line, displays thread lines as leader lines (yellow). If set to "std_iso_imp_assy," displays threads in cross-
sectional assembly drawings in accordance with the ISO 6410 standard. If set to std_ansi_imp_assy," displays
them in accordance with the ANSI standard. The "std_iso" and "std_ansi" values are valid for drawings created
before Release 15.0.

tol_display configuration file option

no, yes
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Controls display of dimension tolerances. You cannot access the Pro/ENGINEER Environment dialog box
when this option is set.

tol_text_height_factor

standard, number > 0

Sets default ratio between the tolerance text height and dimension text height, when showing the tolerance in
"plus-minus" format. If set to "standard," the system uses 1 for the ANSI standard and .6 for the ISO standard.

tol _text width_factor

standard, number > 0

Sets default factor to maintain a proportion between the tolerance text width and dimension text width, when
showing the tolerance in "plus-minus" format. If set to "standard," the system uses .8 for the ANSI standard and
.6 for the ISO standard.

use_major_units configuration file option

default, yes, no

Controls whether fractional dimensions are measured in feet and inches. Controls the display of fractional
dimensions in drawings in the same way that the configuration file option use_major units controls the
display of fractional dimensions in Part and Assembly modes.

If set to "no," fractional dimensions are not displayed in major units.
If set to "yes," fractional dimensions are displayed in major units.

If set to "default" (the default setting), displays fractional dimensions according to the setting of the
configuration file option use major units.

view_note

std_ansi, std_din, std_iso, std_jis

If set to "std_din," creates a view-related note with the words "SECTION," "DETAIL," and "SEE DETAIL"
omitted.

view_scale_denominator

0, integer

Determines denominator for the view scale before simplifying the fraction. If set to a positive integer and

view scale_ format is a decimal, the view scale chosen for the first view of a model in the drawing is
rounded to the nearest value with the specified denominator. If the view scale is so small that rounding would
make the scale 0. 0, the value of view scale denominator is automatically changed by multiplying it
by the smallest power of 10, which would give a positive value if rounding the scale down (although rounding
up can happen). When you type a view scale value, you can round it to an allowable fraction. The system does
not round existing scale values after you have edited the setup file; they are approximate. Displays approximate
scales preceded by a tilde (~), if you set the configuration file option mark approx_dims to yes. If you set
it to 0, expresses the scale value in decimal format.

view_scale_format

decimal, fractional, ratio_colon
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Expresses a scale as a decimal or fractional value. If set to "ratio_colon," displays the view scale values as a
ratio. For example, instead of a view scale of 0.5, displays the view scale as 1:2. Since the ratio is just another
way of displaying a fraction, make sure that you set the "view_scale denominator" option appropriately.

weld_solid_xsec

weld_symbol_standard

std_ansi, std_iso

Displays weld symbols in a drawing according to the ANSI or ISO standard.

witness_line_delta
0.125000, value

Sets the extension of the witness line beyond the dimension leader arrows.

witness_line_offset
0.062500, value

Sets offset between a dimension line and object being dimensioned. This gap may be visible only when you plot
a drawing. To see the effect, use the screen plot.

Also controls the size of the break at the intersection of witness lines, when you use the "Dimension" type
break.

yes_nho_parameter_display
true_false, yes_no

Controls display of "yes/no" parameters in drawing notes and tables. When set to "yes_no," parameters can
have a "yes" or "no" value in drawing notes. When set to "true false," they can have a "true" or "false" value.

About Layers in Drawing Mode

In Pro/ENGINEER, a layer is a grouping of draft items (draft dimensions, sketches) as well as model items such
as features and datum planes. You may want to group items for several reasons (for example, for manufacturing
purposes only or for separate verification). The main reason for using layers is to blank construction geometry
(such as surfaces and datum curves) that you do not need to show in your drawing.

Although layers can represent different entities, they always have the following three properties in common:
name, display status, and contents. The display status (shown, blanked, or isolated) controls whether or not
items in the layer are displayed. Layers can include other items in a Pro/ENGINEER database such as features,
dimensions, notes, geometric tolerances (gtols), and other layers. You can place items on layers using two basic
methods: by copying them from other drawing, part, or assembly layers, or by selecting them directly from the
drawing.

Manipulating Layer Display Status in Individual Views

Drawing views do not have individual layers for each view—they use the layers in the drawing. However,
Pro/ENGINEER can control the layer display status of drawing layers separately for each view. You can
display drawing layers independently for individual drawing views or make the layer display dependent on the
drawing.

By setting the display of drawing layers independently of the models and individually for each view, you can do
the following:
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e Include items from parts and assemblies directly in a drawing layer without including them on a layer in a
model.

o Control the display of drawing layers to include items from the model without marking the model as
changed.

e Vary the display of a single model in different drawing views.

If you specify independent view display, it takes precedence over the main drawing for that view. When you
create an independent view, the layer display defaults to that of the main drawing. When you create a detailed
view, the layer display defaults to that of the parent view. You can then modify the display for any view
independently, or reset it to follow the drawing display. You can copy the display status for the drawing or a
view to any other view or the drawing, and then modify the display individually for each.

To Add Items To A Drawing Layer
Using the Add command on the Item menu in the Layers dialog box, you can add an item to a layer.

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.

2. Select one or more layers in the Layer Tree.

3. Choose Item > Add (or click the toolbar shortcut or use the RMB). The CONFIRMATION prompt appears,
asking whether you want to add the specified layer to the active drawing.

4. Click Yes, and the LAYER OBJ menu appears with a list of possible item types.

5. Choose one or more item types and specify item selections, using the menus that appear for each type of
item.

6. Select the particular items to place on selected layers:

— If'the drawing is Independent, you can select model items to place on a drawing layer. Select items in
the graphics window, or in the Model Tree, or by navigating through the menu structure.

— If the drawing is Dependent, you can place only drawing items on a drawing layer. Select items in the
graphics window or by navigating through the menu structure.

To Change the Display of Layers in a Drawing View

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.

2. Inthe Layers dialog box, select Drawing View from the Active Object list. The system highlights the view
outlines.

o The layer display of the view outlines shown in cyan is dependent on the layer display in the drawing.

The layer display of the view outlines shown in green is independent of the layer display in the drawing.

3. Click on a view to select it and manipulate its layer display. As soon as you select the view, its layer display
becomes independent of the drawing, and the system updates the Active Object window with the name of
the selected view.

4. Use the dialog box to change the display of various layers in the drawing view. When you have finished
working with the view, select another object from the Active Object list in which to manipulate layer
display.

To Ignore the Layer Status in a Drawing Model

Using the Layer Status Control dialog box, you can control the display of model layers in a drawing, without
having to make any change to the part or assembly in which that item was created.

You can force a drawing to ignore the layer status in its model completely when determining if it should display
an item on a layer. The system displays all items on model layers in the drawing, and you can manipulate them
separately at the drawing level. You can blank or display layers at the drawing level without making changes to
the part or assembly in which the item was created, and the model does not change. To set a drawing so that it
ignores the layer status of its model, do one of the following:

e Choose Preferences from the Status menu in the Layers dialog box, and select the first check box (Ignore
display status of layers in the model) in the Layer Status Control dialog box.

e Set the drawing setup file option ignore _model layer status to yes (the default value). If you set
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this option to no, the drawing layer status follows that of the model.

Tip: Modifying Drawing Layers does not Affect the
Model

Modifying the display of a layer in a drawing does not mark any parts or assemblies as modified. Therefore,
you do not need to save parts and assemblies and resubmit them to Pro/PDM when you toggle layers and save
them. Also, the drawing looks as it should when you retrieve it, regardless of the changes that you may have
made to the model layers. Because one of the benefits of the ignore_model layer status setting is that
changes will not be made to the model or model layers, you cannot add items or remove them from model
layers. However, you can manipulate items directly on drawing layers.

Invisible Drawing Model Items

If an item in the part or assembly does not have its display set in any way from the drawing, it shows by default.
Items in the drawing model are visible by default unless one of these conditions is met:

e The item is included directly on a drawing layer.

e The item is on a part or assembly layer with the same name as a drawing layer and the drawing setup file
option draw_layer overrides model is set to yes.

e The item is on a part or assembly layer which has been included in a drawing layer.

For these three cases, the system determines whether to show the item based on the drawing layer status
information.

To Control Model Layers with the Same Name from
the Drawing

You can set the display of drawing model layers to follow the display of drawing layers with the same name.
For example, if you blank the drawing layer datums, the system also blanks all items on the datums layers of
all drawing model components. If the model is an assembly and you then add another component with a layer of
the same name, it automatically sets the display of any items on a model layer named datums to be the same

as the drawing layer. To keep one component datums layer from being affected, put the desired layer directly
on another drawing layer. To set the display, do one of the following:

e Choose Preferences from the Status menu in the Layers dialog box, and select the second check box
(Change display of model layers with the same names in drawing only) in the Layer Status Control dialog
box.

e Set the drawing setup file option draw_layer overrides_model to yes. If you set this option to no
(the default value), the system ignores nondrawing layers when you set the display status of layers in the
drawing model with the same name.

Using the Layer Status Control Dialog Box
When using the Layer Status Control dialog box to manipulate layer display status, keep in mind the following:

e [fyou do not select the first check box (Ignore display status of layers in the model), the second check
box (Change display of model layers with the same names in drawing only) is unavailable. You can then
see changes to model layers in the model in the drawing.

e When you do not select any check boxes, if you blank any of the part layers in the drawing, the system
blanks the items in the drawing and in the part when you retrieve the part.
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To Make the Display of a Drawing View Dependent
on the Layer Display

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.

2. In the Layers dialog box, select Drawing View from the Active Object list; then select a drawing view
with independent layer display. When the active object is an independent drawing view, the Make
Dependent toolbar shortcut is available.

3. Change the drawing view to dependent using either of the following methods:

— Click the Make Dependent toolbar shortcut.

— Choose Status > Preferences, and in the Layer Status Control dialog box uncheck the first option,
Ignore display status of layers in the model.

4. When the system asks you if you really want the layer status of the drawing view to be dependent on the
layer status of the drawing, click Yes. The system updates the drawing and the Active Object returns to The
Drawing.

To Switch Items from One Layer to Another

Using the Switch command on the Item menu in the Layers dialog box, you can move items from one layer to
another in the active drawing. The Switch command is available when nothing is selected in the Layer Tree or
when at least one layer item is selected in the Layer Tree.

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.
2. Select one or more layer items in the Layer Tree.
3. Choose Item > Switch (or use the RMB). The Select Layers dialog box opens, listing available layers in
the active drawing. The source layer (the layer that contains the item to be switched) is highlighted.
4. Specify destination layers for the item(s). Only layers from the item's parent object are available. You can
leave the item in its original layer and add it to several other layers.
— To remove the item from a layer in which it is already present, clear the layer name.
— To add the item to a layer in which it is not already present, select the layer name.
If the item is not blanked, it is highlighted in green.
If the item is a blanked geometry feature (such as a hole or round), or a blanked component, the geometry is
still visible on the screen, but remains highlighted in red. The system tells you through the message area that
the item is blanked.
If the item is blanked and is not visible on the model (such as a datum or axis), the item is not highlighted on
the model at all.
Notes:

e You can select items that are shown or blanked. However, you cannot select suppressed items.

o [fthe items are visible on the model (whether or not they are blanked), they are highlighted in red after you
select them.

e Ifyou select a blanked component in an assembly, the component appears on the assembly highlighted in
red.

e Ifitems such as datums and axes are blanked, they are not visible on the model and so are not highlighted.

If the items are not blanked, the system highlights the first item you selected, in green, on the model and
displays its feature number and type in the message area, for example, feature 6 (ROUND). The LAYER SEL
menu appears with a list of the layers in the active model. The layers in which the item is already present (if
any) are highlighted.

5. Select Done Sel. The system clears the item (if it was previously present) from all the layers that are not
selected and adds it (if not already present) to all the layers that are selected.

6. Repeat for each additional item, if you selected more than one.

7. When you have finished, choose Done/Return.
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Tip: Adding Items

If you have many items, you can group them in a layer and then copy that layer as an item to other layers.

To Copy Items from One Layer to Another

Using the Copy command on the Item menu in the Layers dialog box, you can copy items from one layer to
another.

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.
2. Select one or more layer items in the Layer Tree.
You can copy an entire layer by selecting it as an item to be copied.
Choose Item > Copy (or use the RMB). The item(s) are copied to the clipboard.
Select one or more of the existing layers in the Layer Tree, or choose New Layer to create a new layer.
5. With all destination layers highlighted, choose Item > Paste (or use the RMB). The item(s) are placed on
the layers.
Note: Copying the items from one layer to another is a one-time task. If you add another item to the
original layer, the system does not add the item to the destination layer.

To Save a Model Layer to Disk

1. Choose Layers from the Pro/ENGINEER View menu. The Layers dialog box opens.

2. In the model, choose File > Save Status File. The system saves to a file the layers of the active model and
their current status.
You can use these layers and their display status for other objects, or retrieve them later.
Notes:
If you enter the name layer file inresponse to the prompt, the actual filename is layer file.pro.
The system does not save display changes with the model when it saves the model unless you click Save
Status before you exit the Layers dialog box.

To Replace Models

The Select Instance dialog box is available when you are replacing the model of one family table instance with
another. This dialog box displays all the available instances and allows you to replace the current drawing
model with another model in the same family, without having to remember and type the name of the
replacement instance.

W

If a model that you use in a drawing is a member of a family of parts or assemblies, you can replace that model
with other family members. The system maintains dimensions, attached notes, and other drawing annotations
when one model replaces another.

Use the Select Instance dialog box to select an instance with which to replace the model.

1. Choose VIEWS > Dwg Models > Replace.

2. Select the model that you want to replace as the active model. The Select Instance dialog box opens when

you are replacing the model of one family table instance with another.

Select the name of another family member to replace it.

4. The Select Instance dialog box displays a list of all instances of the currently selected family table model.
You can select one of these to use as the replacement model. You can select an instance by name when the
By Name page is visible (the default), or click the By Parameter tab to select an instance by parameter.

5. After selecting an instance to be the replacement, click Open. The current model is replaced by the selected
instance.
Note: When you are using automatic replacement, if the system shows dimensions in the assembly drawing
on a component that you have replaced with the new instance, it displays equivalent dimensions. However,
if you replace the component using manual replacement, it does not preserve the dimensions.

If a model that you use in a drawing is a member of a family of parts or assemblies, you can replace that model

with other family members. The system maintains dimensions, attached notes, and other drawing annotations

when one model replaces another.

W

122 Pro/DETAIL



To Enlarge an Area of a Drawing

1. Choose View > Pan/Zoom....

2. Define the area to enlarge by using the mouse to enclose it in a box. The system displays the enclosed area.
Zooming out on the drawing doubles the area of the drawing currently shown on the screen. To reduce an area
of a drawing, use Zoom Out in the PAN-ZOOM menu. Use the Reset command to resize the model so that the
entire model fits within the screen, keeping the current view orientation. If you perform a pan on a drawing, you
can select a new center for the screen.

To Pan the Center of the Screen

1. Choose PAN-ZOOM > Pan.
2. Select a location on the screen to become the new screen center.
Pro/ENGINEER shifts the display of the drawing on the screen so that the selected point is the center of the
screen display.
In Drawing mode, you can save, retrieve, and delete pan-zoom settings on drawing views. To save a pan-zoom
view, choose Saved Views... from the View menu, followed by Save. To retrieve a pan-zoom view, select its
name from the Saved Views dialog box; to delete a view, click Delete.

To Show Multiple Windows

By choosing New from the Pro/ENGINEER Windows menu, you can show multiple drawing sheets in multiple
windows (or the same sheet in multiple windows), and you can select any of them.

To Change the Display of Selected Views

To change the display of selected views, assembly components, or even individual edges, use Disp Mode in the
VIEWS menu. Note that the changes you make to the display mode using this command override the global
settings in the Environment dialog box.

Note: When you have set the display mode of views and edges to Hidden Line, they appear in phantom font on
the screen but are plotted as dashed lines.

You can assign a color to datum curve segments by choosing Model Display... from the Pro/ENGINEER View

menu and With Datum Curves from the Shade page of the Model Display dialog box.

View Display

By default, the drawing view display appears as specified in the Environment dialog box. During a
Pro/ENGINEER session, you can modify the default display. However, keep in mind that this changes the
display of all of the views in the drawing.

About Detail Iltems

If you have a license for Pro/DETAIL, you can create draft dimensions on a view. In Drawing mode, you can
also show dimensions of a model in a drawing.

You can include notes, symbols, and geometric tolerances in a drawing.

Manipulating Detail Items

Pro/DETAIL commands let you manipulate dimensions, notes, geometric tolerances, surface finish symbols,
cross-section arrows, set datums, and dimension text in the following ways:

e Move them (within a view or between views).

e Reattach leaders to another entity.

e Add more leaders.
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e Move jogs.

e Translate them.

e Remove them (erase) from the display.
e Display them.

e Delete them.

e Modify the values.

e Relate them to a view.

e Relate them to dimension text

To Create a Draft Dimension

1. Click Insert > Dimension, and then select New Refs..., Common Refs..., or Ordinate....
2. Select two entities or edges on the view.
3. Place the dimension using the middle mouse button.

To Move Dimensions of Draft Features

1. Click to select the item you want to move. The cursor changes to a four-pointed arrow. The dimension is
attached to the arrow.
2. Drag the mouse to move the dimension. Click again to place the dimension.

To Show or Hide Drawing Dimensions

Click View > Show and Erase.

In the Show/Erase dialog box, click Dimension in the Type box.

To specify the dimensions as ordinate, click Options and select Switch to Ordinate.

Click Pick Bases and select a baseline.

Select Feature, Feat & View, or View. To show all dimensions for the current model, click Show All.

To preview what the drawing will look like when you make the changes, click Preview and specify items to
show.

To Move Detail Items

1. Click to select the object you want to move. To select multiple items, hold down the Shift key as you select.
The object is highlighted and the cursor changes to a four-pointed arrow.

2. Drag the object to the new location.

3. Click again to position the object.

To Rotate Detail Items

1. Click Tools > Rotate.

2. Select the detail item or items to rotate. Click Done Sel.

3. Use the options on the Get Point submenu to pick a rotation point. You sre prompted to enter a degree of
counterclockwise rotation around the point.

4. Enter the degree number. Press Enter. The item is rotated

To Move an Item Dynamically

In drawings, when you move an item dynamically, the item dims to gray (marking the item’s original location).
As you move it, the system highlights it in red (all text appears as boxes to enable faster speed in moving the
items). Use the left mouse button to set the item in a new location; use the middle mouse button or a menu
command to return the item to the original location; and use the right mouse button to flip dimension arrows.
All statements in parentheses following each bulleted item below explain how you can perform these actions
using the menu selections.

Sk L=

You can perform the following tasks using dynamic move:
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e Move jogs in both witness and leader lines.

e Move dimensions, notes, geometric tolerances, draft entities, draft groups, symbols/surface finishes, axes,
datum tags, and Bill of Materials (BOM) balloons.

e Move the text of dimensions, notes, geometric tolerances, datum tags, symbols/surface finishes, and axes.

e Move the attachment of radial, chamfer, and constant draft feature dimensions; notes; geometric tolerances;
symbols/surface finishes; and BOM balloons.

e Align linear and ordinate dimensions.
o Skew the display of linear dimension witness lines and select the ends of the witness lines closest to the text.

¢ Clip dimension witness lines, datums, and axes The dimension does not appear in the original position
during the move.

e Change the location of a table within a single sheet of a drawing. The system erases the original table and
highlights the table in white.

To Move an Iltem Between Views

You can move items attached to the model with leader lines (or attached directly to an edge) from one view to
another of the same model.

1. Select an item to move.

2. Click Edit > Switch to View (or click Switch View in the right mouse button pop up window.)

3. Select the view to which you want to move the item. The item is attached to the new view, and activated to
move for adjustment.

To Attach a Leader to a New Object

1. Click to select a leader to modify.

2. On the right mouse button pop up menu, click Mod Attach.

3. Select a new entity at the point to attach the leader. Use the middle mouse button to set the leader in its new
placement.

To Add a New Leader

Select the item to which you would like to add the leader.

From the right mouse button pop up menu, click Mod Attach.

In the Menu Manager click MOD OPTIONS > Add Ref.

Select a reference point on the view for the leader. You can select several points if you want to.

Click the middle mouse button, or choose GET SELECT > Done Sel and ATTACH TYPE > Done. The leader
or leaders are attached at the specified points.

To Insert or Move Leader Jogs

To insert the jog

A e e

Click to select the leader.

From the right mouse button pop up menu, click Make Jog.

Click to select the jog point. The jog is inserted, and is attached to the cursor for placement.

Click the left mouse button to complete. The leader is still selected, you can select another point to put a jog.
Place another jog, or left click again to exit the command.

To Move Unattached Entities

To move draft entities and annotations not attached to an edge, use the Translate command. Unlike the Move
command, you can translate any number of items at one time.

1. Onthe Menu Manager, click DRAWING > Tools > Translate.
2. Select the draft items to translate; then choose Done Sel.
3. Define the translation vector by selecting the endpoints with the left mouse button. The endpoints

DR =
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correspond to the initial and final locations of a reference point on the screen. The system translates selected
items the distance equal to the length of the vector in the same direction as the vector.

About Displaying Cosmetic Features

Pro/ENGINEER displays cosmetic features (except cosmetic threads) in views unless their sketching plane is
perpendicular to the screen. You can control the display of threads in a drawing using the drawing setup file
option hlr for threads.Ifyousetitto yes, thread edges meet the ANSI or ISO standard for hidden line
display (set by the thread standard option). If you set it to no, the system displays thread edges as
surfaces as they would be in Part mode.

You can show or erase sketched cosmetic features, weld features, and cosmetic threads in a drawing view
without having to show or erase datum planes as well.

Note: The erasure or display of these items in a detailed view is always the same as that of the parent; you
cannot modify it individually.

To Show or Hide Cosmetics

To show cosmetic features, choose View > Show and Erase, then click Show and Cosmetic Feature in the
Show/Erase dialog box. To erase them, click Erase and Cosmetic Feature. You can entirely erase cosmetic
threads from a drawing view.

Note: Click Note in the Type box of the Show/Erase dialog box to erase pattern notes, the notes that display the
number of members of a pattern (2 HOLES, for example).

To Show Threads in Cross-Sectional Assembly
Views

To display threads in cross-sectional assembly drawings according to the ISO or ANSI standard, use the
drawing setup file option thread standard in conjunction with hlr for threads.

e To display them in accordance with the ANSI standard, set the drawing setup file option
thread standardtostd ansi imp assy.
e To display them in accordance with the ISO 6410 standard, setitto std_iso imp_ assy.
Note: In the ISO-standard display, if the bolt diameter equals the hole thread diameter, and the bolt thread
diameter equals the hole diameter, the bolt covers the hole’s crosshatch if one of these conditions exists:
e The bolt and hole are coaxial.
¢ Both axes are in the cross section.
e The cross section itself is planar and parallel to the screen (normal to the viewing direction).

In the case of an offset cross section, the portion of the cross section that intersects the bolt/hole pair must be
planar and parallel to the screen.

To Delete a Draft Item

Use the Delete command, to remove reference dimensions, notes, and geometric tolerances from a drawing, as
well as unset any reference datums.

1. Select the item to delete from the drawing. Hold down the shift key to select multiple items.

2. Click Edit > Delete.
Note: Using the Delete command on a set datum or on a basic dimension removes gtol referencing for that
item (but does not delete it).
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To Modify a Note or Dimension Value

You can modify the numeric values within geometric tolerances and surface finishes, as well as dimensions.
When modifying the value of dimensions, however, you must regenerate the drawing before the system updates
the part or associative draft dimensions to the new value.

1. Click Edit > Value.
2. Select the value to modify.
3. Type a new value. Press Enter.

To Associate Detail Items with a Drawing View

You can associate detail items (such as draft entities, notes, and symbols without leaders) with a view.

1. Choose VIEWS > Relate View > Add Items.

2. Select the view to which you want to associate detail items.
3. Select the detail items to associate; then choose Done Sel.
Note: When using this command, keep in mind the following:

e You cannot relate draft datums to a model view.

e Ifyou create a note or symbol using the Free Point command, you cannot relate it to a view. The system
attaches a standard note (one with a leader) to the view or draft entity.

e Draft items related to a drawing view take on the same behavior as the view. When you perform actions on
the view such as moving, erasing, or deleting, the system performs the same actions on the related draft
items.

To Dissociate Detail Items from a Drawing View

1. Choose VIEWS > Relate Views > Remove Items.

2. Select the items to dissociate; then choose Done Sel.

After associating items with a view, you can use the Pro/ENGINEER Info menu to identify the entities in any
view or in a specific view.

To Highlight Draft Entities

1. On the Pro/ENGINEER menu bar, click Info > Drawing > Highlight by Attributes.
2. In the Highlight By Attributes dialog box, select 2D Sketched Entity from the Item Type box.
3. Do one of the following:

— Select Any from the Displayed in View box to highlight attributes in any view.

— Select Selected and click Select View to choose a specific view.

The system highlights all of the currently displayed items that have been associated to the view or views
specified.

To Relate Draft Objects to Dimensions

After you create a note, draft geometric tolerance, or symbol, you can relate it directly to dimension text so that
it moves with the dimension when the dimension changes location. You can relate these detail items to a
dimension when specifying its placement.

1. Choose Tools > Relate Obj > Add Items.

2. Select a dimension to which the system should relate the items.

3. Select notes, symbols, or draft gtols to relate to the selected dimension.

4. To remove them, choose Remove Items from the Relate Obj menu.

Note: When you erase, redisplay, or delete a dimension, the system also erases, redisplays, or deletes all items
related to it.
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About Note Parameters

In addition to text and special symbols, notes can include model dimensions, pattern instance parameters,
symbols, drawing labels, and drawing parameters. The drawing setup file option
yes _no_parameter_ display controls the display of yes/no parameters in drawing notes and tables.

To Include Parameter Information in Notes

When you set the drawing set up file option yes_no_parameter display to yes_no, parameters can
have a yes or no value in drawing notes. When you set it to true false (the default value), they can have a
true or false value.

To specify parameter information in a note, use the following format:

e Dimensions—&d# or &ad#, where # is the dimension ID. Examples: &d12. &ad5s.
e Reference dimensions—&rd#, where # is the dimension ID. Example: &rd2 .

e Instance number—&p#, where # is the parameter ID. Example: &p8

e User-defined parameters—&xxxx where xxxx is a symbol defined in a relation.

e Datum names—&dtm_name, where name is the name of a datum plane.

e Drawing labels—You can add the following drawing labels to a drawing:

— &todays_date—Adds the date as of the note’s creation in the form dd-mm-yy (for example, 2-Jan-
92). You can edit it later as any other nonparametric note, using Text Line or Full Note. If you include
this symbol in a format table, the system evaluates it when it copies the format into the drawing.

— &model name—Adds the model used for the drawing.
— &dwg_name—Adds the name of the drawing.

— &scale—Adds the scale of the drawing.

— &type—Adds the drawing model type.

— &format—Adds the format size.

— &linear tol 0 0 through &linear tol 0 000000—Adds the linear tolerance values
for one to six decimal places.

— &angular tol 0 0 through &angular tol 0 000000—Adds the angular tolerance
values for one to six decimal places.

— &current sheet—Adds the sheet number for the sheet on which the note is located.
— &total sheets—Adds the total number of sheets for the drawing.

e Drawing parameters—&parameter : d, where parameter is the parameter name.

Considerations when Specifying Parameter
Information in a Note

When specifying parameter information in a note, keep in mind the following restrictions:

e  When you include dimensions in notes, the system removes them from their original views.
e You cannot add draft dimensions (associative—add # or nonassociative -dd#) to a note.

e A datum name in the note is read-only, so you cannot modify it; unlike dimensions, a datum name does not
disappear from the model view if it is included in a note. The system encloses its name in a rectangle, as if it
were a set datum.

e You cannot use drawing labels in drawing relations; you can only use them in drawing notes and tables.

e When the note appears, the system replaces dimensions and parameters by the corresponding numerical
values. If you set the configuration file option switch dims for notes to yes, dimensions appear
as their symbolic values during note creation. If you set it to no, they remain as numerical values.

e Before referencing a model in a parametric note, make sure that you add this model to the drawing.
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Otherwise, the system does not evaluate the model parameter referenced in the note.

* You can include a gtol symbol in a note by entering it as a parameter; however, you cannot include global
parameters (that is, parameters created in a layout) and draft dimensions in notes.

Example: Parameter Symbols for Notes
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Type the following: &p0 HOLES &d5 IN DIAMETER <ENTER>
&d6 FROM SIDE, &d7 FROM TOP <ENTER><ENTER>
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To Change a Text String

After you create a note, you can make changes to the text.

1. Click the text to modify.
2. Click and hold the right mouse button until the menu appears.
3. Click Edit Text to modify the note text.

Text Strings
When you are editing text, dimension values appear as follows:

e (@D (if displayed as a numerical value).

e (@S (if displayed as a symbolic value).

e @O (if the dimension does not have a value, @O locates the text origin).
e Special characters appear between the control characters ~A and "B.

When you edit a note using Text Line and Full Note, the system preserves all of the attributes (font, height,
width, or slant angle) applied to a portion of the text. However, the note appears much different from how it
does on the drawing. The system breaks up a text string into portions wherever there is a new line of text or a
parameter (such as dimensions), and encloses each portion of the text in braces ({}), giving it an integer label.
Labels identify the initial order of the text, and any attributes for that portion. When editing text, or adding more
lines, you can copy the attributes of a portion of text by using the same integer label.

Note: If you delete the special control characters when editing text, the text string changes. If you remove A,
all special characters become their ASCII equivalent; if you remove ~B, all text that follows becomes a
special character.

You can edit view-related notes, such as section, detail, and scale notes; however, be sure not to delete or

otherwise alter symbols that represent the name or scale of the view. If you edit these symbols, the system

ignores the change, and displays the original note:

e &view name—name of the view
¢ &view_scale—name of a general scaled view

e &det scale—scale of a detailed view

If you set the view note option in the drawing setup file to std_din, you can create a view-related note
with the words SECTION, DETAIL, and SEE DETAIL omitted. This only affects the creation of view-related
notes. If you switch from std_ansi to std_din, the system does not update view notes.

Guidelines for Using Note Labels

When using note labels, keep in mind the following:

o The system treats text that is not enclosed within braces, or is incorrectly labeled, as plain text.

e Text labeled with a number higher than that which is actually present uses the attributes of the highest
number label.

e You can display braces in the text string. For left braces, only include the brace. For right braces, so that the
system does not interpret it as the end of a portion of text, type two right braces together (} }). For example,
for "Origin {X,Y,Z}," enter [ {Origin {X,Y,Z}},}].

130 Pro/DETAIL



Example: Effects of Editing Note Text

This note contains dimensions (447.23 ), fonts Select this note to edit,

sltant angle and hergh?, usingFull Note.
and different widths.

v

{0:This note contains dimensions Note the braces and
(}{1:&D2}{2: ), fonts} colons that identify
{3:slant angle and height,} the different portions
{4:and different widths. of text.

{0:This note contains dimensions Modify the note, Notice
(H{1:&D2K2: ), fonts} how existing integer
{3:slant angle and height,} labels were used in the
{4:and different widths.} two new lines.

{3:This line uses slant and height

attributes from portion 3} Saving the changes
{0: and this one uses font causes the modified
attributes from 0} note to appear. Notice

that lines using the

same integer labels

appear the same.
This note conteins dimensions (447.23 1, fonis

siaont angle and herght,

and different widths.
This [ine yses s/ant and height atiributes from portion 3

and this one uses font mttributes from O

v

{0:This note contains dimensions Edit the note again. The
(¥{1:&D2}2: ), fonts} system automatically
{3:slant angle and height,} renumbered the last two
{4:and different widths.} lines to be in sequence
{5:This line uses slant and height with the other portions of
attributes from portion 3} text, but this does not alter
{6: and this one uses font the style of the lines in any
attributes from 0} way.

To Specify an Existing Text Style as the Current
Style

As you create a note, you can apply an existing text style by choosing Cur Style from the NOTE TYPES menu.
When you change the current style from the default to another text style, it only affects new notes, balloon text,
symbols, and table text.

If you choose Default from the SEL STYLE menu, the system uses the style that is defined by the drawing setup
file options drawing text height, text width factor,and text thickness.
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To Specify the Default Font

By default, Pro/ENGINEER creates text in regular ASCII font, referred to in menus as font. A thickened

version of the system default font (the filled font) is also automatically available to you as an alternative font.
You can specify the ISO font as the default font by setting the drawing setup file option default font to
isofont, or you can set any of the Pro/ENGINEER-supported fonts as the default for a particular drawing.

In addition to those fonts, Pro/ENGINEER supplies the four auxiliary fonts listed in the following table and 41

True Type fonts.

Leroy font set
Calcomp Alphabetical font set

Calcomp Greek and Mathematical Symbol set

ISO font set

The TrueType fonts are located in the Pro/ENGINEER loadpoint directory. Additional TrueType fonts can be
purchased and placed into the loadpoint directory. TrueType fonts are more complicated than PTC fonts and
therefore can take more time to repaint. Typically, any TrueType Font can be used by Pro/ENGINEER by
placing it in the pro_font dir. However, PTC does not guarantee the robustness of the TrueType Font. See
the Pro/ENGINEER Installation and Administration Guide for information about where to locate the font file in

the load directory area.

By default, any fonts placed in the loadpoint directory appear in the pull-down list in the Text Style dialog box.
A different directory other than the loadpoint directory can be specified using the configuration file option

pro_ font dir.

The following table lists the available TrueType fonts and their corresponding file names.

TrueTypeFonts

Font Name

Blueprint MT

Blueprint MT Bold

CG Century Schoolbook

CG Century Schoolbook Bold
CG Century Schoolbook Bold Italic
CG Century Schoolbook Italic
CG Omega

CG Omega Bold

CG Omega Bold Italic

CG Omega Italic

CG Times

CG Times Bold

CG Times Bold Italic

CG Times Italic

CG Triumvirate

CG Triumvirate Bold

CG Triumvirate Bold Italic

CG Triumvirate Condensed Bold
CG Triumvirate Italic

Garamond
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Setup Option File Name

bluprnt.ttf
bluprntb.ttf
schlbk.ttf
schlbkb.ttf
schlbkbi.ttf
schlbki.ttf
cgomg.ttf
cgomgb.ttf
cgomgbi.ttf
cgomgbit.ttf
cgtime.ttf
cgtimebd.ttf
cgtimebi.ttf
cgtimeit.ttf
trium.ttf
triumb.ttf
triumbi.ttf
triumcb.ttf
triumi.ttf

garamd.ttf
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Garamond Bold
Garamond Italic
Garamond Kursiv Halbfett
Garth Graphic

Garth Graphic Black
Garth Graphic Bold Italic
Garth Graphic Italic
Grotesque MT

Grotesque MT Bold
Microstyle Extended
Microstyle Extended Bold
Neographik MT

Sackers English Script

garamdb.ttf
garamdi.ttf
garamdbi.ttf
gargra.ttf
gargrabl.ttf
gargrabi.ttf
gargrai.ttf
grotesqg.ttf
grotesgb.ttf
microex.ttf
microexb.ttf
neograph.ttf
sackengs.ttf

Shannon shanno.ttf
Shannon Bold shannob. ttf
Shannon Extra Bold shannoeb.ttf
Shannon Oblique shannoo.ttf
Spartan Four MT sparton4.ttf
Spartan One Two MT spartonl2.ttf

Spartan One Two MT Bold spartonl2b.ttf

Triumvirate Inserat triin.ttf
If you need additional true type fonts, you can purchase more fonts. For information, contact the Agfa
Corporation at http:\\www.agfadirect.com.

Creating Your Own Fonts

You can create your own font and set it as a default or auxiliary font in a drawing. For information on creating
user-defined fonts, see the Pro/ENGINEER Installation and Administration Guide. Note that when you start
Pro/ENGINEER, the system first searches the local directory for the files specified in the index file. If it does
not find them, it searches the Pro/ENGINEER loadpoint directory. When you save user-defined fonts locally,
you should move them to a new location whenever you transfer the drawing. If the system does not find fonts
used in the drawings, it uses a different font and the appearance of the text changes accordingly. Therefore, you
should maintain font files in the load directory area.

To Modify Drawing Text Style

Click Format > Text Style.

Select text and choose GET SELECT > Done Sel.

In the Text Style dialog box, change the information in Character to modify the text style.
Click Apply. The text changes. To reset the text to the old style, click Reset Settings.

The Text Style Dialog Box

You can change the font, width, and color of an existing text style. However, the system does not automatically
update any text to which you previously assigned that text style (that is, before you modified it). The changes
that you make using this dialog box only affect text to which you assign a text style after modifying it.

PO =

Using the Text Style dialog box, you can:

e Change the font by selecting a font name from the Font list.
e Change the text by clearing the Default check box and typing a value in the Height box.
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® You can also modify the height by choosing MODIFY TEXT > Text Height.

e Change the width by clearing the Default check box and typing a value in the Width Factor box.

e Change the thickness by clearing the Default check box and typing a value in the Thickness box.

e Change the slant angle by typing a value in the Slant Angle box.

e Underline the text by selecting the Underline check box.

e Change the line spacing by clearing the Default check box and typing a value in the Line Spacing box.

e Rotate the text at an angle by typing a value in the Angle box (you can rotate a note about a point by
choosing TOOLS > Reotate).

e Specify the horizontal justification by selecting a value from the Justify Horiz list.

e Specify the vertical justification of table cell text in individual table cells by selecting a value from the
Justify Vert list.

o Flip the text so that it reads backwards by selecting the Mirror check box To mirror a note, you must first
select it; then select a mirror line.

Using True Type Fonts

TrueType fonts can be used with Pro/ENGINEER. Pro/ENGINEER supplies 41 TrueType fonts, and you can
purchase additional TrueType fonts and place them in the Pro/ENGINEER loadpoint directory. See the
Pro/ENGINEER Installation and Administration Guide for information about where to locate the font file in the
load directory area. TrueType fonts are more complicated than PTC fonts and therefore can take more time to
repaint.

To Modify the Color of Drawing Text Using the
System-Supplied Colors

Click Format > Text Style.

Select text; then click GET SELECT > Done Sel. The Text Style dialog box opens.

In the Text Style dialog box, select the Color box.

In the Color dialog box, select a system color from the System Colors box; then click OK. The system
displays the selected text in the specified color and closes the Color dialog box.

5. To reset the text to the old style, click Reset Settings. To reset selected text to its intrinsic color, click
Intrinsic in the Color dialog box.

To Create Your Own Color

1. In the Color dialog box, click New....

2. Using the Pro/ENGINEER Color Editor tool, define the new color by moving the RGB controls from right
to left incrementally. Click on the color bar at the desired color setting, or click OK. The new color appears
in the User-defined Colors box.

3. To create a color.map file for storing your user-defined text style colors, click Store Map in the Color
dialog box.

4. Click OK. The Color dialog box closes.

5. Inthe Text Style dialog box, click Apply. The system displays the selected text in the specified color, and
stores the color with the model. To reset the text to the old style, click Reset Settings.

Note: Use the 1ine style standard option in the drawing setup file to control text color in
Pro/ENGINEER drawings. Unless you set this option to STD ANST, all text in drawings appears in blue,
and the boundary of detailed views, broken views, and half views appears in yellow.

To Create and Edit Custom Text Styles

Use the Style Lib dialog box to create new text styles, as well as modify and delete existing ones.

bl

1. Click Format > Text Style Gallery. The Text Style Library dialog box opens.
2. Click New.... In the New Text Style dialog box, type a name fin the Style Name box, select an existing
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style from the Style Name list, or click Select Text....

3. Type a name in the Style Name box, select an existing style from the Style Name list, or click Select
Text....

4. After you have changed all attributes, click OK.

5. To close the dialog box and save the changes, click Close (Cancel changes to Close after you make a
change).

To Modify an Existing Text Style

You can modify the existing text styles of notes and other information in your drawing.

1. Click Format > Text Style Gallery. The Text Style Library dialog box opens.

2. Scoll through the items in the Styles container and select the text style name you want to modify. The
Modify Text Style dialog box opens.

3. Click Modify... and change the attributes for the style by making the appropriate selections or typing values
(for instructions on how to specify a particular attribute.

4. After you have specified all attributes, click OK. The text style changes.

5. To reset the text to the old style, click Reset Settings.

To Control the Format of the Date Displayed in a
Drawing

The configuration file option todays_date note_format controls the initial format of the date displayed
in a drawing. The format for the setting is a string consisting of three portions: the year, the month, and the date.
You can enter the portions in any order. The default value is $dd - $Mmm- $yy.
e Year
- %yy, for 97
- %yyyy, for 1997
e Month (if the month contains two digits (for example, 10),% mm, % m, or % m all produce the same result)
—  %Mmm, for Jan
- %MMM, for JAN
—  %Month, for January
— %MONTH, for JANUARY
—  %mm, for 01
— %m, for 1
— % m, for <space>1

e Date (if 2 digits are needed to represent the date, all three are the same. Therefore, "%dd %mm %yy"
produces "01 01 97," and "%MMM %d %yyyy" produces "JAN 1 1997")

—  %dd, for 01
- %d, for 1
- % d, for <space>1.
The following formats are also valid:

¢  %dd-%Mmm-%yy (= 01-Jan-97)
o %mm/%dd/%yy (= 01/01/97)
e %Mmm %dd,%yyyy (=Jan 01, 1997)
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To Reference Parameters Assigned to Objects

In model and drawing notes, to reference parameters that you assigned to object s in Part or Assembly mode,
use this format:

e For edges:

&<param_name>:EID <edge name>
e For surfaces:

&<param_name>:SID <surface name>
e For other objects:

&<param_name>

To Include a Feature Parameter in a Note

To include a feature parameter in a note, use this format:

&<param_name>:FID <feat ID>
or
&<param_name>:FID <FEAT NAME>

Example: Parameters in Notes

The following example illustrates the parameter’s usage in notes:

In Part mode, assign the name "A" to a surface.

Create a parameter with a name "RAD," of type Number.

Assign a value ".03" to this parameter.

In Drawing mode, create a note by typing [Break sharp edge with R = &RAD:SID A]. This note
appears: "Break sharp edge with R =.03".

If a drawing note has a single attachment (defined using On Item or one leader line), you can show the
parameters of the entity to which it is attached by typing the following string into the note: sparam name:att.
The system then interprets the param name in a series of contexts until it is able to evaluate it successfully.
First, it searches the immediate entity to which the note is attached, such as an edge. Next, it searches the
feature that owns the entity. If it still cannot evaluate the parameter, it then searches the model that owns the
feature. Finally, if applicable, it searches the component that refers to the model. If you want to specify the
exact context in which to interpret the parameter, specify a full "att " postfix instead.

PO =

After you create the note, if you choose Switch Dims from the Pro/ENGINEER Info menu, the system appends
the "att " postfix to specify the exact context in which it interprets the parameter.

Param_name:att_edge Edge
Param_name:att feat Feature
Param_name:att mdl Model
Param_name:att_cmp Component

For example, if a note is attached to an edge by a single leader line (or defined using On Item), you can set the
note to show a relational parameter of that edge by typing [sLength:att]. The note then appears as follows:
&Length:att edge.

Note: You must create the drawing note after you create the parameter; otherwise, the system does not evaluate
it correctly.

To Reference Model Notes in Drawing Notes

To reference a model note in a drawing note, do one of the following:

e Create a note in Part or Assembly mode by choosing Notes from the SETUP menu.

e Add a note parameter to the model using Add Param in the RELATIONS menu; the value for this parameter
is a note ID.
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To Include a Model Note in a Drawing Note

To include a model note in a drawing note, use the format &<param names.

Example: Including a Model Note in a Drawing Note

1. In a model, create this note: all surfaces must be painted withID 1.
2. Add a parameter part note with the value of 1.
3. In Drawing mode, type this note:
[Applies to all parts:
gpart note]
The following note appears:
Applies to all parts:
all surfaces must be painted
Note: You cannot insert the part note text side-by-side with any other note text. When you call out a
note parameter in another note, the called out parameter is displayed on a new line.

To Display Pro/PDM Data

You can display the name of a model’s product database on a drawing sheet, as well as the model’s revision in
that product database and its release level, by entering the following in a note:

e To display the model’s product database of origin, enter the parameter & PDMDB.

e To display the model’s revision, enter the parameter &PDMREV.

e To display the drawing’s revision number, enter the parameter & PDMREV : D.

e To display the model’s release level, enter the parameter & PDMRL.

To Reference a Mass Properties Symbol in a Note

You can create a parametric note that references a mass properties symbol. After the geometry changes, you can
update the note to reflect the latest value of the mass properties parameter.

1. Set a user-defined parameter. For example: [volume].

2. Add arelation, assigning this parameter to a mass properties symbol that you want to reference in a note.
For example: volume = mp_volume ("").

3. Add a note containing the user-defined parameter. For example: [svolume].

To Update a Parametric Note

1. Regenerate the model.
2. Do one of the following:
— Manually recompute mass properties by choosing Analysis > Model Analysis....

— Include a MASSPROP statement in the program of the model using Pro/PROGRAM.

Controlling the Number of Decimal Places in
Parameters

When you append certain parameter symbols with the characters "[.#]", the system displays those parameters
with the number of decimal places specified by #, which is an integer. The system rounds the number, but uses
the same value. This applies to the following parameters:

e User-defined model parameters or those defined in model relations
e Drawing labels, such as &scale (drawing scale) and &det _scale (detail view scale)

When adding the note that contains the parameter, append the parameter symbol with "[.#]", where # is the
number of decimal spaces to appear. For example, if a detailed view scale is 1.125, and you want to display
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only two decimal places, change the drawing label (by using Text Line or Full Note in the MODIFY TEXT
menu) to &det_scale[.2]. This displays the scale note as 1.13.

Restrictions with Dimensions and Other Model
Parameters

You cannot use this functionality on dimensions or other model parameters, such as pattern parameters.
However, if you make a user-defined parameter equal to the model parameter, and then add the user-defined
parameter to the note, you can control the display of the model parameter decimal places.

Example: Controlling the Number of Decimal Places
in Parameters

For example, for a model parameter "d1" with the value 12.37580:

1. Type the relation as [length = d1].

2. Add the drawing note.

3. When specifying the parameter, type [¢1ength[.3]]. The parameter appears as 12.376, but the value the
system uses in calculations is still 12.37580.

You can also use the Num Digits command to modify the number of decimals in a scale.

To Show the Scale of an Individual View

The drawing parameter scale_of view_x evaluates the drawing scale of whichever view has name X.
For example, to call out the scale of a view named DETAILED BAR, type
&scale of view detailed bar.

To Add a Jog to a Leader

1. Click Insert > Jog.

2. Select a note.

3. Select the leader to which you are adding the jog.

4. Select the location for the jog. The system adds the jog between the first pick and the second pick.

To Delete a Jog from a Leader

When the system adds a jog to a leader the jog remains in the same place on the drawing, regardless of where
you move the dimension. To delete the jog, choose Edit > Delete Jog, and pick the jog.
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Example: Adding Jogs to a Note with Leader

,—A THI:E-M-L HOLE THRU_ALL HOLE
(WmAp i I ] E =h .
m
] V/
1 6 ‘

1  Pick the leader at these points.
2 Pick these points as the new position.

To Add Another Leader Line to a Note

Click Insert > Note. The Note Type menu appears.

Click Leader and then Make Note.

Select the note to which you want to add the leader.

Choose MOD OPTIONS > Add Ref.

Choose a reference point on the view for the leader.

Choose GET SELECT > Done Sel and ATTACH TYPE > Done. The system adds the additional leader.
— To add more than one leader, repeat Steps 4 and 5.

— To delete a leader, choose MOD OPTIONS > Delete Ref.
— To break a leader, use the same procedure you would use to break dimension witness lines.

AN

— Attach a leader to any line of text by typing the placeholder parameter "@o" (alphabetic character, not
zero) at the beginning of that line. Add the parameter to the line as you create the note or enter it later
using Full Note or Text Line. If you add "@o" to more than one line of note text, the leader attaches to
the first line containing it.
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Example: Attaching a Leader to a Note

This is one hole
in a pattern of holes
which has eight instances.

This is one hole
in a pattern of holes
which has eight instances.

This Is one hole
in a pattern of holes
hich has eight insfances.

1 Edit the note using Full Note. Type "@o" before the beginning of the second line of text.
2 Edit the note using Full Note. Remove the"@o" from the second line and add it to the beginning of the
third line.

To Delete a Note

Deleting a note permanently removes it from the drawing. The system returns any dimensions or parameters
included in that note to their original locations on the drawing. (You can delete notes if you have a license for
Pro/DETAIL.)

1. Click File > Delete (to remove several notes at one time, use the Delete Many button in the
Pro/ENGINEER toolbar).

2. Select a note(s).

3. Choose GET SELECT > Done Sel. Choose Repaint, if necessary, to redisplay the drawing.
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To Erase a Note

You can erase notes using the Show and Erase command in the menu bar. Erasing a note obscures it from
view, but does not remove it from the drawing. The system also hides any dimensions or parameters that are
included in the erased note, and does not return them to their original locations elsewhere in the drawing.

1. Choose View > Show and Erase.

2. Inthe Show and Erase dialog box, click Erase and Note.

3. Select a button from the Erase By box. The corresponding notes no longer appear. When you have finished,
click Close.

4. To redisplay erased notes, click Show and Note.

To Change the Leader Type

If you create a note using the ISO Leader command in the NOTE TYPES menu, the system underlines the note.
To switch between the ISO-standard leader style and the non-ISO-standard leader style, choose Leader Type
from the MODIFY TEXT menu and use the GET SELECT menu.

To Enclose Notes in Text Boxes

To enclose words or characters in a box, type "@ [" in front and "@]" following the text when you edit, it using
the Text Line or Full Note command.

In a text string, you can place special symbols that indicate a box around text regardless of the location of
braces ({ }) that position text breaks.

Example: Enclosing Notes in Boxes

Editing with Text Line On the screen
{0: notes in drawings} notes in drawings
{0: @[notes@)] in drawings} in drawings
{0: @[no@]tes in drawings} [noltes in drawings

To Change Note Attachment Point

1. Click Edit > Attachment.
2. Select the note.

3. Click the new attachment point.

The leader is reattached at the new point.

To Copy a Free Note by Translating

Choose TOOLS > Copy > Translate.

Select notes to copy; then choose GET SELECT > Done Sel.
Define the translation vector.

Pick the first point; then select the destination point.

Type the number of copies.

AP e e
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To Copy a Free Note by Rotating

Nk v

Choose TOOLS > Copy > Rotate.

Select notes to copy; then choose GET SELECT > Done Sel.
Select the center point for rotation.

Type the rotation angle in the counterclockwise direction.
Type the number of copies.

Note: You can include notes in draft groups.

To Relate an Existing Note to Dimension Text

You can relate an existing note to dimension text—so that it moves with the dimension when the dimension
changes location—by using the Relate Obj command in the TOOLS menu. When you create a note, you can
relate it directly to dimension text by choosing Dim Related from the NOTE TYPES menu.

To Switch Notes to Another View

You can switch a note from one view to another view using Switch to View. Select the note that you want to
switch to another view; then select the new view on which to display the note. The note appears in the
corresponding location on that view.

To Show a Thread Note in a Drawing

1.

DR

142

To show thread parameters as a note, you must previously define them in the part by doing one of the
following:
— While creating a thread, supply parameter values through the Pro/TABLE environment.

— After creating a thread, edit parameters by choosing Parameter from the PART SETUP menu.

You can move and delete thread notes as regular notes. In Drawing mode, choose View > Show and Erase.
In the Show/Erase dialog box, click Show; then select Note from the Type box and Feat & View.

Pick the thread in the drawing view. A note listing thread parameters appears.

Show parameter values by choosing Switch Dims from the Pro/ENGINEER Info menu.
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Example: Showing a Thread Note

1

T

THREADS_PER_INCH-CLASS PLACEMENT

MO. 550 x 5.00072 A

1 When the note appears, it lists parameter names.
2 To show parameter values, switch dimensions.

About Creating Geometric Tolerances

In manufacturing, you can use geometric tolerances to specify the maximum allowable deviation from the exact
size and shape specified by designers. You can create, modify, display, and delete geometric tolerances (gtols)
in Drawing mode.

Geometric tolerances provide a comprehensive method of specifying where on a part the critical surfaces are,
how they relate to one another, and how the part should be inspected to determine if it is acceptable. When you
store a Pro/ENGINEER geometric tolerance in a solid model, it contains parametric references to the geometry
or feature it controls—its reference entity—and parametric references to referenced datums and axes. As a
result, the system updates a gtol’s display when you rename a referenced datum.

In Assembly mode, you can create a geometric tolerance in a subassembly or a part. A geometric tolerance that
you create in Part or Assembly mode automatically belongs to the part or assembly that occupies the window;
however, it can refer only to set datums belonging to that model itself, or to components within it. It cannot
refer to datums outside of its model in some encompassing assembly, unlike assembly-created features.

You can use the geometric tolerance functionality in Drawing mode, Part mode, and Assembly mode; however,
to create a geometric tolerance in Drawing mode, you must have a license for Pro/DETAIL.
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To Add a Geometric Tolerance to a Drawing

1. Click Insert > Geometric Tolerance. The Geometric Tolerance dialog box opens.

2. In the Geometric Tolerance dialog box, specify the model in which to add the geometric tolerance (the
system selects Model Refs). By default, the current geometric tolerance model is the current drawing
model.

3. Select the geometric tolerance type and the reference entity (the type of entity to which the geometric
tolerance applies).

4. Click Place Gtol. If the geometric tolerance is attached directly to a datum, it appears (the system selects
Datum for you from the Type list). Otherwise, select an item from the Type list and place the geometric
tolerance in the drawing.

Note: As you continue creating the geometric tolerance, the system updates it on the drawing. You can
check your work as you go along and make corrections, if necessary.

5. Specify the datum reference(s) and material condition(s), if applicable.

Type a tolerance value and material condition, if applicable.

7. Specify symbols and modifiers, the profile direction, and the projected tolerance zone, if applicable. The
completed geometric tolerance now appears in the drawing.

8. Do one of the following:

— Close the dialog box and save the changes by clicking OK. The system clears the reference entity
selection and placement information from the dialog box, but retains all other data. When you reenter
geometric tolerance Creation mode, it retains all commands in the previous session of geometric
tolerance creation for the object in the current window.

a

— Create another geometric tolerance by clicking New Gtol.

— Delete the geometric tolerance from the model by choosing GEOM TOL > Clear to delete the geometric
tolerance from the model.

— Exit geometric tolerance creation mode and cancel the changes by clicking Cancel.

Tip: Adding a Geometric Tolerance

To add a geometric tolerance (gtol) to a drawing, you can use two, three, or all four pages of the Geometric
Tolerance dialog box, depending on the specific characteristics of the geometric tolerance you are creating.

To Place a Geometric Tolerance

You can attach a geometric tolerance to a dimension, datum, single or multiple edges, or another geometric
tolerance. You can also create a driven dimension to which you can attach the geometric tolerance, place it free
(anywhere on the drawing), or relate it to dimension text. You can attach stacked (multiple) geometric
tolerances to another tolerance; or, if the first tolerance in a stack is attached to a dimension, you can attach
them to the same dimension. However, to attach a geometric tolerance directly to other geometric tolerances,
dimensions, or datums, it must belong to the same model as the item to which it is attached.
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Example: Ways of Placing Geometric Tolerances
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Set dimension.
Set datum.
First geometric tolerance created as a free note; the second was attached to it.

To Indicate an ISO Standard Projected Tolerance

Zone

1. After selecting the Location/Position button, specify referenced datums and their material conditions.
2. Click Symbols at the top of the dialog box.
3. Do one of the following:

The completed geometric tolerance appears with the specified projected tolerance zone. The following
figure presents an example.

Dimension attached to the edge with a leader.
Both gtols attached to the dimension.

To indicate the projected tolerance zone and specify the height, select the Zone Height box and type a

value.

To indicate the projected tolerance zone without specifying the height, placing it on a separate line
below the geometric tolerance, select Below Gtol.

To indicate the projected tolerance zone without specifying the height, placing it on the same line next
to the geometric tolerance, select Inside Gtol.

To specify no projected tolerance zone, select None.
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Example: Projected Tolerance Zone
@\@-001 @‘DTM1 @‘

1 —02 2

1 The projected tolerance zone height value.
2 The projected tolerance zone height symbol.

To Indicate a Standard Tolerance for Parallelism and
Perpendicularity

After selecting the Orientation/Perpendicularity or Orientation/Parallelism button, specify the reference
entity.

1. Click Tol Value.
2. Specify the tolerance value by doing one of the following:
— To show only the geometric tolerance, without indicating the restricted length, specify a value in the
Overall Tolerance check box.

— To indicate the restricted length to which the tolerance applies, select the Per Unit Tolerance check
box and type values in the Value/Unit and Unit Length or Unit Area boxes.

Specifying the Per Unit Length Area

To specify the "per unit length or area" of Form/Straightness and Form/Flatness geometric tolerances,
indicate the restricted length to which the tolerance applies by selecting the Per Unit Tolerance check box and
typing values in the Value/Unit and Unit Length boxes.

Creating Geometric Tolerances in Assembly
Drawings

When you create a geometric tolerance in the top-level model (that is, a part in a part drawing or top assembly
in an assembly drawing) the system associates the tolerance with the view in which you have selected a
reference entity. Reference datums that you specify for the geometric tolerance must belong to the same top-
level model; however, you can select them in any view. You cannot reference draft entities and draft datums.
Geometric tolerances applied to draft entities (draft gtols) can reference datums of the model. You can attach an
assembly geometric tolerance to a dimension, datum, or another geometric tolerance, provided they both belong
to the same assembly.

When you create a geometric tolerance in an assembly drawing, if you set the configuration file option
draw_models read only to yes, the system sets the Drawing command as the default in the Model list
of the Model Refs page of the Geometric Tolerance dialog box. The Part and Assembly commands are not
available for selection; if you choose them, an error message appears. If you set draw_models read only
to no, and there are no assembly views on the current page, the Part command is the default in the Model list.
If an assembly view is present, Assembly is the default.

To Create a Geometric Tolerance in an Assembly
Drawing

1. Click Insert > Geometric Tolerance > Specify Tol.
2. In the Geometric Tolerance dialog box, select Assembly from the Model list of the Model Refs page.
3. Click Place Gtol. If the geometric tolerance is attached directly to a datum, it appears (the system selects
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Datum for you from the Type list). Otherwise, select an item from the Type list and place the geometric
tolerance in the drawing.

Note: As you continue creating the geometric tolerance, the system updates it on the drawing. You can
check your work as you go along and make corrections, if necessary.

Specify the datum reference(s) and material condition(s), if applicable.

Type a tolerance value and material condition, if applicable.

Specify symbols and modifiers, the profile direction, and the projected tolerance zone, if applicable. The
completed geometric tolerance now appears in the drawing.

Do one of the following:

— Close the dialog box and save the changes by clicking OK. The system clears the reference entity
selection and placement information from the dialog box, but retains all other data. When you reenter
geometric tolerance Creation mode, it retains all commands in the previous session of geometric
tolerance creation for the object in the current window.

— Create another geometric tolerance by clicking New Gtol.

— Delete the geometric tolerance from the model by choosing GEOM TOL > Clear to delete the geometric
tolerance from the model.

— Exit geometric tolerance creation mode and cancel the changes by clicking Cancel.

Example: Adding a Geometric Tolerance to a
Drawing

Following the procedure below, use the characteristics and values given in this table to create a sample
geometric tolerance.

Sample geometric tolerance Characteristics and Values

Characteristic Value

Entity Hole

Tolerance Location As part of a diameter dimension

Class and Type Location/Position (a "true position" tolerance)

Overall Tolerance Value 0.25

Material Condition MMC

Primary Datum (A) Material Condition RFS/Default

Secondary Datum (B) Material Condition RFS/Default

1. Click Insert > Geometric Tolerance.

2. In the Geometric Tolerance dialog box, specify the model in which to add the geometric tolerance (the
system selects Model Refs). By default, the current geometric tolerance model is the current drawing
model.

3. Click Location/Position.

4. Specify the type of entity to which the tolerance applies. Select Feature from the Reference Entity Type
list; then click Select Entity to select the hole in the drawing.

5. Click Place geometric tolerance and select Dimension from the Type list. Select the hole’s dimension.
The geometric tolerance appears in the drawing below the dimension.

6. Click Datum Refs at the top of the dialog box:

— To specify the primary datum reference, click Primary; then select A and RFS (no symbol) from the
Basic lists.

— To specify the secondary datum reference, click Secondary; then select B and RFS (no symbol) from
the Basic lists.

7. Click Tol Value at the top of the dialog box and type [0.25] in the Overall Tolerance box. Select MMC
from the Material Condition list.

8. Click Symbols at the top of the dialog box. Select the Diameter Symbol check box to indicate that the

tolerance value refers to a diameter zone; then select None as the projected tolerance zone.
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9.

The completed geometric tolerance appears, as shown in the following figure. Click OK to close the dialog
box and save the changes.

Sample Gtol

About Modifying the Dimensioning Scheme

You can modify the dimensioning scheme of a feature in Drawing mode by using Edit > Dimension Scheme in

the

menu bar. When you select a feature, a subwindow opens and displays the model. You can then modify the

section of the feature using commands in the SKETCHER menu.

To Modify the Dimensioning Scheme of Feature or
Part

1.

In the menu bar, click Edit > Dimension Scheme.

2. Select a feature to redimension. If you selected the base feature, only the section of the base feature and

dimension values appear in a separate window. If you selected a later feature on the model, the system rolls
back the model and displays it in default orientation in a separate window. The section and dimensions of
the feature (if applicable) appear on the model.

In the dialog box that displays the elements in the selected feature, add dimensions, delete dimensions, or
change placement constraints, as necessary. You cannot modify existing dimension values or add or delete
features.

Click OK when you are done.

The system regenerates the model to reflect the changes. If you set the configuration file option
auto_regen_ views to no, you must choose View > Update > Current Sheet or All Sheets to observe
the change in the drawing views.

You can also modify the dimensioning scheme in Part mode.

About Using Snap Lines in Drawing Views

You can define snap lines on individual drawings to locate dimensions, notes, geometric tolerances, symbols,

and

surface finishes. The system positions the snap lines relative to the view outline, or a selected model edge

or datum plane. After you have placed an item on a snap line, the item moves along if the grid line moves (for
example, when the view outline expands).
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When placing and locating items on a snap line, keep in mind the following:

¢ When you move an item onto one snap line, its color changes to magenta. If you set the location by pressing
the left mouse button, the item snaps to the snap line. Until you move the item again, the snap line
determines its location.

e If you move an item onto the intersection of two snap lines, the system highlights one of the lines in red. If it
snaps that item to more than one set of snap lines at that location, you can navigate all possible sets using
the SEL SNAP LINE menu. When you choose Accept, the system locates the item on the intersection of the
two snap lines. When you move either snap line, the item moves with it.

To Create a Snap Line

1. On the menu bar, click Insert > Snap Line.
2. On the Menu Manager, do one of the following:
— Choose CR SN LINE > Att View. Select a view border, specify the offset from the border and the
number of lines to create. If you are creating more than one line, specify the space between the two
lines. The snap line attaches to the specified view border.

— Choose CR SN LINE > Att Geom/Snap. Select view geometry (such as an edge), a datum plane, or
another snap line; specify values for the offset, the number of lines to create, and the space between the
two lines (if you are creating more than one line). The snap lines attach to the specified view geometry,
datum plane, or snap line.

Restrictions When Using Snap Lines
When working with snap lines, keep in mind the following:

e Snap lines place and locate detail items. They are not a graphical part of the drawing, so the system does not
plot them.

e You can put snap lines on drawing layers and blank them, but once you blank them, you cannot add new
items to them. Existing items continue to snap.

* You cannot add entities of one view to another view’s snap line. In the case of broken views, you cannot
snap an item of one segment of the view to a snap line of another segment. The view of an item is defined as
the view to which the leader of the item is attached. In the case of multiple leaders, the item can snap to any
one of the views.

e When you delete a view, the system also deletes all of its snap lines.

e Ifyou place a dimension on an intersection of two snap lines, it does not behave the same way it would if it
was placed on only one snap line. Free items can snap to any snap lines.

To Place and Locate Items on a Snap Line

You can snap an item to one snap line or to the intersection of two snap lines. You can also attach clipped detail
entities (such as dimensions, witness line endpoints, set datum endpoints, and axis endpoints). Once you place
an item on a snap line, it moves when the snap line moves.

1. To place and locate the following items on snap lines, select the item(s) and move them to the snap line. An
item "snaps" to the line as you move it closer, and the line and entity colors change to magenta. You can
place the following items on snap lines:

e Dimensions

¢ Clipped dimension arrows
e Notes

e Symbols

e Set datum names

e Set datum line endpoints
e Geometric tolerances
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e Surface finishes

e View arrows

To Modify a Snap Line Attachment

1. Select a snap line, and then right-click the line to display the shortcut menu.
2. From the shortcut menu, choose Mod Attach. The MOD SNAP ATT menu opens in the Menu Manager.
Choose one of these commands:
— Keep Position—Maintains the position of the snap line.
— Change Orient—Reroutes the snap line, changing its orientation but assigning the offset of the
existing reference to the new reference.

— Att View—Reroutes the snap line attachment to a view border.
— Att Geom/Snap—Reroutes the snap line attachment to other geometry or another snap line.

3. Specify a new reference. The snap line attachment changes.
You can manipulate snap lines in several ways:

— To remove a snap line, select the line and then click Edit > Delete, or select and right-click the line and
then choose Delete from the shortcut menu. To select more than one snap line at once, hold down the
SHIFT key while selecting each line. Once you delete a snap line, any items located on it are free.

— To change the position of a snap line, select the line and then drag it to its new position. The system
updates all items located on the moved snap line after you choose a new location.

— To control the length (position of the endpoints) of a snap line, select the line and then click an
endpoint (handle). Move the pointer to the new location; the line lengthens or shortens as you move the
pointer. Click again to place the endpoint (handle) in the new location.

Note: Any modifications that you make are cosmetic and affect only the snap lines. You cannot
change the length of more than one snap line at a time.

— To change the spacing of snap lines, select the line, right-click on the line, and then choose Modify
Space from the shortcut menu. Enter a new spacing value and then press ENTER. The system updates
all items located on the moved snap line after you choose a new location.

To Control the Display of Snap Lines

1. Click Utilities > Environment. The Environment dialog box opens.
2. Under Display, select Snap Lines.
To turn on snapping:

Under Default Actions, select Snap to Snap Lines. By default, the system selects both commands. If snap
lines do not appear or you have cleared the Snap to Snap Lines checkbox, the items that are already snapped to
a snap line continue to move with their snap lines.

About Working with Drawing Parameters

Using MODEL PARAMS menu (DRAWING > Advanced > Parameters), you can access drawing parameter
functionality for drawings and drawing formats. Drawing parameters work in the same way as do model
parameters. A drawing parameter is nongraphical information you can add to a drawing. It is useful for keeping
some additional information with a drawing that you may not want to include in a note. You can show one in a
note by including [sparameter:d] in the note string.

When working with drawing parameters, keep in mind the following:

o The system associates parameters only with the object that is current at the time you add the parameter.

e Drawing attributes defined in versions of Pro/ENGINEER prior to Release 15.0 convert to drawing
parameters automatically.

e The system converts attribute names that begin with a number, but you cannot use them in notes.
* You cannot use drawing parameters in relations.
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¢ You can designate parameters for Pro/PDM.

To Create a Drawing Parameter

1. Choose ADV DWG OPTS > Parameters > Drawing > Create.
2. From the ADD PARAM menu, choose a command to specify the parameter type.
IntNumber-Adds a parameter in the form of an integer.
RealNumber-Adds a double parameter.
String-Adds a parameter in the form of a string.
Yes No-Adds a parameter with a value of yes or no.
3. Type the parameter name and the value.

To Modify or Delete an Existing Drawing Parameter

1. From the MODEL PARAMS menu, choose Modify or Delete.
2. From the PARAMETER menu, select a drawing parameter.
— To modify the parameter, type the new value.
— To delete it, choose Done.
3. To display an Information window showing all of the existing parameters and their values, choose MODEL
PARAMS > Info.
Note: You also have access to Part and Assembly mode parameters while in Drawing mode. Once you delete a
parameter, you cannot undo the deletion.

To Get Information About Drawing Parameters

1. Click DRAWING > Advanced > Parameters > Drawing.
2. In the MODEL PARAMS menu, click Info.
An information window opens and lists information about all parameters in the drawing.

To Save Drawing Parameter Information as a File

1. Choose DRAWING > Advanced > Parameters > Drawing > Info. An information window opens and lists
information about all parameters in the drawing.

2. Click File > Save As in the Information window.

3. Inthe Save As dialog box, navigate to the directory where you want to save the parameter information file.

4. In the New Name box, use the default file name or type a new name. Parameter information files always
contain the extension . inf.

5. Click OK to save the information file.

About Creating and Modifying Line Styles

A line style consists of the following elements: line font (a pattern of dashes, spaces, and/or dots), color, and
line width. Modifying a line style involves changing all or any of the line style elements. You can create,
modify, and delete line styles and line fonts of table grids, symbols, axes, draft entities, and cosmetic features.

When you are in Part mode, user-defined line fonts appear in solid font.

To Access Line Styles in Drawing Mode

When you are in Part mode, user-defined line fonts appear in solid font. To access the line style functionality in
Drawing mode, click Format > Line Style on the Pro/ENGINEER menu bar and choose options as necessary
in the LINE STYLES menu (Menu Manager).
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To Specify the Default Line Style Setting

1. On the menu bar, click Format > Default Line Style. The SEL STYLE menu opens in the Menu Manager.
2. From the SEL STYLE menu, choose one of these commands:
— Hidden—Displays as hidden line (gray) geometry on the screen, and plots as dashed lines.

— Geometry—Displays as regular visible geometry (white) on the screen, and plots as solid lines.

— Leader—Displays as dimensions (yellow) on the screen, and plots as yellow lines.

— Cut Plane—Displays as white phantom lines on the screen, and plots as phantom lines with Pen 1.
— Phantom—Displays as gray phantom lines on the screen, and plots as phantom lines with Pen 3.
— Centerline—Displays as yellow centerlines on the screen, and plots as centerlines.

To Assign a Line Style to Objects

Using Modify Line in the LINE STYLES menu, you can access the Line Style dialog box to assign attributes to
selected lines.

1. On the menu bar, click Format > Line Style.

2. From the LINE STYLES menu in the Menu Manager, choose Modify Lines.

3. Select the line you want to modify, and then choose Done Sel from the GET SELECT menu. The Modify
Line Style dialog box opens.
Note: In order to access this dialog box, you must choose Done Sel from the GET SELECT menu after
selecting lines.

o To assign a line style to entities, select a line style from the Style list; then click Apply.

e To set the line font, select a line font from the Line Font list; then click Apply.

e To set the width, type a value in the Width box; then click Apply (this text box is only available in Drawing
mode; it does not apply when modifying the line style of part entities in any other mode).

Accessing Line Style in Part Mode

In Part mode, you can access the Line Style dialog box by choosing Line Style from the MODIFY menu. It
contains a subset of the controls used in Drawing mode.

To Set the Color Using a System-Supplied Color

On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Choose Modify Lines from the LINE STYLES menu.

Select the item to modify; then choose GET SELECT > Done Sel.

In the Modify Line Style dialog box, click Color.

In the Color dialog box, select a system color from the System Colors box; then click OK. The system
displays the selected item with the specified color and closes the Color dialog box.

6. To reset the item to the old style using the old colors, click Reset and Apply.

To Create Your Own Line Color

On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Choose Modify Lines from the LINE STYLES menu.

Select the item to modify; then choose GET SELECT > Done Sel.

In the Modify Line Style dialog box, click Color.

In the Color dialog box, click New.

In the Pro/ENGINEER Color Editor tool, using the left mouse button, define the new color. Move the RGB
controls from right to left incrementally; then click on the color bar (or click OK) at the desired setting. The
new color appears in the User-defined Colors box.

7. Click Apply in the Modify Line Style dialog box. The system displays the selected item with the
specified color and stores the color with the model.
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8. To reset the item to the old style, click Reset and Apply.

To Create (or Add) a New Line Style

1. Do one of the following:
— On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Then, choose Edit Styles from the LINE STYLES menu.
— On the menu bar, click Format > Line Style Gallery.
In either case, the Line Style Library dialog box opens.
2. In the Line Style Library dialog box, click New.
3. Inthe New Line Style dialog box, type a name in the New Name box, select an existing style to copy from
the Style list, or click Select Line.
4. Set the line font, width, and color.
5. To accept the new line style as currently defined and change the contents of the Line Style Library, click
OK. The system adds the line style to the Line Style Library.

To Delete a User-Defined Line Style

1. Do one of the following:
— On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Then, choose Edit Styles from the LINE STYLES menu.
— On the menu bar, click Format > Line Style Gallery.

In either case, the Line Style Library dialog box opens.
2. In the Line Style Library dialog box, select an existing line style from the scrollable Styles container.
3. Click Delete.
4. In the Confirm Deletion menu, click Yes. The system removes the line style.

To Modify a User-Defined Line Style

1. Do one of the following:
— On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Then, choose Edit Styles from the LINE STYLES menu.
— On the menu bar, click Format > Line Style Gallery.
In either case, the Line Style Library dialog box opens.
2. In the Line Style Library dialog box, select an existing line style from the Styles list.
Click Modify.
4. In the Modify Line Style dialog box, modify the selected line style, as necessary:
— To change the font, select a font from the Line Font list.

— To change the width, type a value in the Width box.
— To change the color, click Color and select a color from the Color dialog box.

b

Note: The system does not automatically update an item that was previously assigned that line style (before
you modified it). The changes that you make using this dialog box only affect items to which you assign the
user-defined line style after having modified them.

About Creating and Modifying Line Fonts

Using the Edit Fonts command in the LINE STYLES menu, you can create your own line fonts by specifying
the font length and the font pattern, and you can modify existing fonts. A line font is a pattern of dashes and
spaces that are proportionate within the specified length. For example, 5 dashes and 5 spaces with a pattern
length of 1 inch results in two dashes and spaces for a 2-inch line in the drawing. The same pattern definition
with a 1/4-inch pattern length results in 8 dashes and spaces for a 2-inch line in the drawing. You can have a
maximum of 16 dash-space combinations in a line font file.
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To Create a New Line Font

1. Do one of the following:
— On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Then, choose Edit Fonts from the LINE STYLES menu.
— On the menu bar, click Format > Line Font Gallery.
In either case, the Line Font Library dialog box opens.
2. Inthe Line Font Library dialog box, click New.
3. Inthe New Line Font dialog box, type a name in the New Name box, select an existing font to copy from
the Font list, or click Select Line.
4. Specify the font length by typing the length of one unit in the Unit Length box.
5. Specify the font pattern by typing a series of dashes (-) and spaces () in the Font Pattern box.
6. Click OK to accept the font as currently defined. The system adds the font to the Line Font Library.

Accessing Line Font Files

User-defined line font files, "fontname.lsl," must reside in your local directory for you to be able to use them.
When you retrieve a drawing, and the system cannot find a line font file, it displays any line that has been set
with that style as solid and notifies you that it has not loaded a font file. If you have specified auxiliary font files
in the drawing setup file (this occurs automatically when you create the font when that drawing is active), it
identifies the font files that it could not find. To use line fonts in drawings other than those in which they were
created, set the drawing setup file option aux_1line font to specify the line font names and IDs:

aux_line_font # font filename
where "#" is an integer number between 1 and 10,000 representing the font ID in the drawing. It serves as a
cross-reference between geometry and the line font, enabling you to make blanket changes to fonted geometry
by modifying the drawing setup file and specifying a new font name for the same number. For example,
changing the value of aux_line font from "100 dash 1" to "100 solidfont" changes all geometry that was
originally "dash-1" to "solidfont."

To Set the Default Length of a Font

To set the default length of a font, use the drawing setup file option 1ine style length.

1. Click DRAWING > Advanced > Draw Setup. The Options dialog box opens.
2. Addthe option 1ine style length to the drawing setup file.
After you add this option to the drawing setup file, you cannot delete it by deleting the row from the file or by
retrieving a different ".dtl" file into the drawing. You must change the value of this option to "default" to
eliminate the option from the drawing setup file. Use the following format:

line style length font name value/default
where font name is the name of the font that you want to modify, value is the desired value for the font
length in system units, and default tells the system to use the default length value. You must specify this
option in the drawing setup file whenever you want to modify the length. To set the length of sketched lines
using 1ine style length, you must set the drawing setup file option axis interior clippingto
no. The drawing setup file option "line_style _length" only affects sketched entities.

Note: Any modifications that you make to the length of a font in a drawing using the Modify Line Font dialog
box override the default setting that you specify in the drawing setup file.

To Modify a Line Font

1. Do one of the following:
— On the menu bar, click Format > Line Style. The LINE STYLES menu appears in the Menu Manager.
Then, choose Edit Fonts from the LINE STYLES menu.

— On the menu bar, click Format > Line Font Gallery.
In either case, the Line Font Library dialog box opens.
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2. Inthe Line Font Library dialog box, select an existing font from the scrollable Fonts container.
Click Modify.
4. In the Modify Line Font dialog box, make the necessary modifications to the selected font:

— Change the length by typing a new value in the Unit Length box.

had

— Change the font pattern by typing a series of dashes (-) and spaces () in the Font Pattern box.

5. Click OK to accept the modifications and change the contents of the font library. The Modify Line Font
dialog box closes.

To Delete a Line Font

To delete a line font from the drawing, change the value of the drawing setup file option aux_line font to
<number> solidfont.

To Import and Export User-Defined Fonts

In Drawing mode, the configuration file option iges_out dwg_line font controls the export of user-
defined line fonts through IGES, while iges _in dwg line font controls importing. Pro/ENGINEER
processes the IGES line font definition entity (type 304, form 2) when you set these options to yes.

About Using Model and Draft Grids

When you are working with a drawing, you can use a three-dimensional (model) grid that was defined in Part or
Assembly mode or a two-dimensional grid. To use model grids, click View > Model Grid, and then use the
Model Grids dialog box. To use draft grids, click View > Draft Grid, and then use the GRID MODIFY menu in
the Menu Manager.

To Create or Modify a Model Grid

You can create a model grid in Part or Assembly mode by choosing Grid from the SET UP menu and then
selecting a coordinate system to define the origin of the grid from the Model Grids dialog box. In an assembly,
this coordinate system must belong to the top-level assembly.

To create a model grid in Drawing mode:

1. On the menu bar, click View > Model Grid. The Model Grids dialog box opens.
2. Use the various options on the Grids and Settings tabs to create the model grid.
To modify the model grid, follow the same procedure.

To Delete a Model Grid from a Part or Assembly

Note: You can only delete a grid when you are in Part or Assembly mode.

1. In Part or Assembly mode, click Set Up > Grid on the Menu Manager. The Model Grids dialog box opens.
2. Click Delete Grid. The grid disappears.

The Model Grids Dialog Box

Create and modify model grids by using the Model Grids dialog box. To access the dialog box in Drawing
mode, click View > Model Grid on the menu bar. In Part or Assembly mode, click Set Up > Grids in the
Menu Manager.

The Grids tabbed page contains the following options:

e Origin—Allows you to select the coordinate system for the grid origin.
e Display—Allows control over the grid display.
— Show—Show the grid and grid labels by view, line, or sheet.
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— Erase—EFrase the grid and grid labels by view, line, or sheet.
— Show/Erase by:
— View—Show or erase the grid in selected views.
— Line—Show or erase individual grid lines.
— Sheet—Show or erase the grid over the entire sheet. All relevant views snap to the grid.
e Spacing—Allows you to assign the same spacing to the entire model grid or individually by axis.
— All—Spaces all the grid lines at the distance you define in the text box.
— By Axis—Spaces the grid lines on any axis individually, at the distances you define in the text box.
— View—Applies modifications to the model grid after you display the model grid.
e Delete Grid—Deletes the grid in the current view.
The Settings tabbed page contains the following options:

e Setup Options—Allows you to assign various values to the following:
— Balloon Radius— Type in the balloon radius.
— Offset Distance—Type in the offset distance of the grid lines.
— Decimal Places—Type in the number of decimal places.
— Negative Prefix—Type in the symbol for the negative prefix to be displayed in balloons. The default

nn

sign is "-".
— Text Orientation—Assign the text to be horizontal or parallel to the grid line.
— Text Position—Assign the text to be centered, above the grid line or below the grid line.
— Display Balloon—Allows you to display a balloon.
e Label Text

— Show Additional Text—Select this check box if you want to type additional text as a prefix or suffix
on any axis.

Considerations When Using the 3-D Model Grid

When using the 3-D model grid, keep in mind the following:

e Ifyou reorient a view with a grid, the system may erase the grid from the display. Therefore, before
completing the procedure, you must confirm that you want to reorient the view.

e When you change the view scale, the model grid adjusts to cover the entire view.
e The system extends the grid lines beyond a drawing view outline at a distance that equals two default grid

spaces. It uses the default grid when the model grid first appears. You can modify it later, but the extension
distance does not change.

To Display a Model Grid in a Drawing

When in a drawing, you can use commands in the DWG MDL GRID menu to display and erase the model grid.
To display it, you must orient the views so that one axis of the coordinate system is normal to the screen and
one axis is parallel to a drawing sheet border.

1. Choose View > Model Grid > Show Grid. The Model Grids dialog box opens.

2. Using the Grids and Settings tabs, specify the display.
Note: If you add a view to a sheet that has a sheet grid, the view’s model has a defined grid origin, and the
view is in planar orientation to this grid, the system moves the view origin to the grid origin and snaps that
point to the grid point of the sheet.
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Example: Model Grid
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1 Invalid views for model grid.
2 Model grid shown by view.

To Erase a Model Grid from a Drawing

1. On the menu bar, click View > Model Grid. The Model Grids dialog box opens
2. Do one of the following:
— To erase the grid by view, click View and then select the view. Click Erase. The system erases the grid
but does not permanently remove it from the model.

— If you want to erase a grid line, click Line and then select individual lines of the grid. Click Erase.

— If you want to erase by sheet, click Sheet. The system will ask you if you want to erase the grid on the
current page. Accept the default response yes.

3. To redisplay individually erased lines, click Show > View.

Modifying Model Grid Size

You can set the default model grid spacing by specifying the value for the configuration file option
model grid spacing in drawing units. You can also use the Spacing options in the Model Grids dialog
box (View > Model Grid).

To Modify the Grid Size

1. On the menu bar, click View > Model Grid. The Model Grids dialog box opens.

2. If the system displays the grid on individual views, select the view that you want to change.

3. Under Spacing, Type a new spacing for the grid. The system updates the grid automatically in all views in
which it appears.

To Show Model Grid Balloons

You can show model grid balloons by using the Model Grids dialog box or by using the configuration options
model grid balloon size,model grid neg prefix,model grid num dig display, and
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model grid offset.
You access the Model Grids dialog box by clicking View > Model Grid.

e To specify the default grid balloon size, use Setup Options in the Model Grids dialog box, or set
model grid balloon size.

e To control the prefix of negative values in grid balloons, use the Negative Prefix option in the Model Grids
dialog box, or set model grid neg prefix. The default value is "-."

e To set the number of digits displayed in grid balloons, use the Decimal Places option in the Model Grids
dialog box, or setmodel grid num dig display.

To specify the offset of new model grid balloons from the drawing view, set model grid offset.Ifyou

set it to default (the default value), the system offsets new model grid balloons from the drawing view by

twice the current model grid spacing. If you specify a number as the value, the system offsets balloons by that

number of inches (not drawing units) from the view.

To Erase Balloons

When you erase a balloon, you blank it from the display. The balloon still exists in the background. You can
redisplay the balloon using the Show/Erase dialog box, accessed by clicking View > Show and Erase in the
menu bar.

1. Select the balloon(s) you want to erase, and then right-click anywhere in the drawing window to display the
shortcut menu.
2. Click Erase. The selected balloons display in grey, indicating that they have been erased from the display.
Note: If you have erased a balloon in error, you can undo the erase operation immediately if you have not yet
clicked another place in the drawing window. While the greyed-out version of the balloon still exists on the
screen, right-click and select Unerase from the shortcut menu. The balloon becomes highlighted in magenta; if
you click anywhere else in the drawing window, the balloon then displays in the normal system color. The
Unerase option is not available if you have repainted or regenerated the display, or if you have clicked another
place in the drawing window after erasing the balloon.

About Creating a Draft Grid

Using commands in the GRID MODIFY menu (accessed by clicking View > Draft Grid on the menu bar), you
can create two types of draft grids in a drawing: Cartesian and Polar. The system creates a Cartesian grid by
locating points on a plane, measuring their distance from either of two intersecting straight-line axes along a
line parallel to the other axis. It creates a Polar grid by locating points in a plane, measuring their distance from
a fixed point on a line and the angle this line makes with a fixed line. To change from one type to another,
choose Type from the GRID MODIFY menu.

When using a two-dimensional draft grid in a drawing, keep in mind the following.

e The grid snap falls on the grid lines when grid snap is on (set in the Environment dialog box).

e The grid origin and angle affect the coordinate values specified for geometry points. The x-axis is always
along one direction of the grid, while the y-axis is along the other.

e The grid origin affects the coordinate values appearing in the message area when sketching.
e Ifyou use the GET SELECT menu to select an entity, the entity does not snap to grid.

To Change the Grid Display

1. Click View > Draft Grid. The GRID MODIFY menu appears in the Menu Manager.

2. Use the Show Grid and Hide Grid commands in the GRID MODIFY menu.

Note: Turning on the display of the grid does not affect the snapping of sketched entities to grid intersections.
To change to grid snap, select Snap to Grid from the Environment dialog box.
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Places Where you can Locate the Grid Origin

You can locate the grid origin at one of the following places. Use View > Draft Grid on the menu bar, then
click Origin on the GRID MODIFY menu.

e Sketched entity endpoint or center

e Sketched point

e Datum point

e Edge or curve vertex

To Move the Grid Origin

1. On the menu bar, click View > Draft Grid. The GRID MODIFY menu opens in the Menu Manager.
2. Choose GRID MODIFY > Origin.
3. From the GRID ORIGIN menu, choose the type of entity to set the origin:

— Get Point—Selects a point to be the origin.

— Edge/Entity—Selects a point on an edge or entity.
— Default—Uses the default grid origin.
4. If you choose Get Point or Edge/Entity, select the entity to locate the origin of the grid.

To Modify Grid Spacing

Using the following procedure, you can modify the spacing and angle of the grid lines. The commands that are
available depend upon the type of grid. The system saves the values for the grid spacing and retrieves them with
the drawing.

1. On the menu bar, click View > Draft Grid. The GRID MODIFY menu appears in the Menu Manager.

2. Choose Grid Params from the GRID MODIFY menu. For a Cartesian grid, the CART PARAMS menu
displays. For a Polar grid, the POLAR PARAMS menu displays.

3. Modify the grid spacing according to the menu that displays as mentioned in the preceding step.

The CART PARAMS Menu and the POLAR PARAMS

Menu

Depending on whether the draft grid in a drawing is Cartesian or Polar, the CART PARAMS or POLAR
PARAMS menu is displayed when you click Grid Params on the GRID MODIFY menu (View > Draft Grid).
Cartesian grid (and thus the CART PARAMS menu) is the default draft grid.

For a Cartesian grid, the CART PARAMS menu displays these commands:

e X&Y Spacing—Sets the spacing of the grid lines in both the x-direction and y-direction to the same value.

e X Spacing—Sets the x-spacing of the grid lines only.

e Y Spacing—Sets the y-spacing of the grid lines only.

e Angle—Modifies the angle between the screen horizontal and the x-direction grid.

For a Polar grid, the POLAR PARAMS menu displays these commands:

e Ang Spacing—Sets the angular spacing between radial lines. The value you type must divide evenly into
360.

e Num Lines—Sets the number of radial lines to use. The angular spacing is 360 per number of lines.

e Rad Spacing—Modifies the spacing of the circular grid.

e Angle—Modifies the angle between the horizontal and the 0-degree radial line.

Pro/DETAIL 159



About the Pro/ENGINEER Drawing Modes

Pro/ENGINEER offers functionality for working with engineering drawings in two separate components:
Drawing mode and an optional add on module, Pro/DETAIL.

Using the Pro/ENGINEER Drawing mode, you can create drawings of all Pro/ENGINEER models, or import
drawing files from other systems. You can annotate the drawing with notes, manipulate the dimensions, and
use layers to manage the display of different items. All views in the drawing are associative: if you change a
dimensional value in one view, the system updates other drawing views accordingly. Moreover,
Pro/ENGINEER associates drawings with their parent models- the model automatically reflects any
dimensional changes that you make to a drawing. In addition, corresponding drawings also reflect any changes
that you make to a model (such as the addition or deletion of features and dimensional changes) in Part,
Sheetmetal, Assembly, or Manufacturing modes.

Pro/DETAIL

Pro/DETAIL, the optional add-on module, extends the drawing capability offered by Pro/ENGINEER. You can
use it with basic Pro/ENGINEER or as a standalone module to create, view, and annotate models and drawings.

Pro/DETAIL supports additional view types and multisheets, offers numerous commands for manipulating
items in a drawing, and lets you add and modify different kinds of textual and symbolic information. In
addition, you can use it to customize engineering drawings with sketched geometry, create custom drawing
formats, and make multiple cosmetic changes to drawings.

With Pro/DETAIL, you can also use a pop-up menu to modify any object in a drawing from anywhere in the
menu tree. At any time when a drawing window is active, you can interrupt your current process and activate a
drawing object for modification .

Drawing Interfaces

With a license for Pro/INTERFACE or Pro/DETAIL, you can access various interface commands for exporting
drawing files to other systems and importing files into Drawing mode.

To Export a Model from Drawing Mode
You can export the following models from Drawing mode to a data file: IGES, DXF, DWG, SET, STEP.

Click File > Save As. The Save a Copy dialog box opens.

Under New Name, enter the desired new file name.

From the Type list, select the desired file type to which you want to export the current drawing.
Click OK to save the drawing and close the Save a Copy dialog box.

To Export a Drawing as an Image File

There are several ways to export drawings as image files. You can capture the current screen using the Save a
Copy command, or you can "plot" any number of the drawing sheets to an image file using the Print command.

PO =

You can also use the File > "Save as Picture" command to create PTC .pic files of sheets at various stages of
design, and compare them to current sheets for differences using the Analysis > Compare Sheet to Picture
command.

The following types of image files are supported:
JPG - Compressed file for Web viewing (Plot Only)
TIFF - Detail-rich image file suitable for printing (Screen capture or Plot)

PIC - A proprietary PTC format. used for file previews, picture-to-file comparisons and the Model View
program.
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To save a TIFF file of the current screen:

Click File > Save a Copy. The Save a Copy dialog box opens.

Under New Name, enter the desired new file name.

From the Type list, select TIFF.

Click OK .You prompted "Pop the current window?" Click Yes. The file is created.
0 plot a whole sheet (or sheets) as a TIF or JPG file:

il B

1. Click File > Print. The Print dialog box opens.

2. Click Destination > Add Printer Type > TIFF or JPEG.
3. Check To File.

4. Click OK. The Print to File dialog box opens.

5. Use the dialog box to name the new file. Click OK.

6. The new image file is created.

To save a sheet as a .PIC file

1. Click File > Save as Picture.

2. The pic file is created, using the drawing name. It is appended with a successive number, for example
part.pic.1, part.pic.2, etc.

To Compare a Drawing to a Saved Image File

You can compare a drawing sheet to a previously saved .pic file of the sheet. (Use the File > Save as Picture
command to save .pic files.) You can compare the whole sheet or use any portion of it in magnification.

1. Click Analysis > Compare Sheet to Picture. The File Open dialog box opens

2. Select the .pic file to compare.

The pic file is "layered" over the drawing page. Common items are suppressed, and any different items,
either added or deleted, are shown.

3. To return to the current drawing click Repaint.

About Importing Draft Data from External
Applications

You can add draft entities to a Pro/ENGINEER drawing if you have a license for Pro/DETAIL or
Pro/INTERFACE. If you have a license for Pro/DETAIL, you can import the following file types:

e |GES

e SET

e DXF

e STEP

e CGM

e STL

e VRML

e DWG

e POLTXT
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e ACIS file

e VDA

e Neutral

e CADAM
e CATIA

e PDGS

e ECAD

If you have a license for Pro/INTERFACE, you can import the same files, but you cannot modify the entities if
you do not have Pro/DETAIL.

To Import External Draft Entities into the Current
Drawing

1. Click Insert > Data from File.
In the Open dialog box, use Look In to navigate to the directory that houses the file you want to import,
and then select the file.

3. Click OK. The system imports the selected file into the current model.

To Create Groups of Entities That Maintain Their
Group Associativity

To create a group of entities which maintain their group associativity through an IGES export:

1. Onthe DRAWING menu, click Advanced > IGES Groups > Create.

2. Enter the IGES group name, and then select the items that you want to belong to the group. You cannot
select items from different views. When you are done selecting items, click Done Sel.

The system creates the group.

About Drawing Setup File Options

Pro/ENGINEER saves drawing setup file options with each individual drawing and drawing format. These
setup file options determine such characteristics as the height of dimension and note text, text orientation,
geometric tolerance standards, font properties, drafting standards, and arrow lengths.

The system gives default values to these setup file options, but you can modify the values to customize a
drawing, and save them to use in other drawings. The system saves (and retrieves) the values in a drawing setup
file named filename .dt1. The file that you specify in the configuration file option

drawing setup file establishes the default drawing setup file option values for any drawing that you
create during a Pro/ENGINEER session. If you do not set this option, the system uses the default drawing setup
file option values. If you have a license for Pro/DETAIL, you can install sample drawing setup files for DIN,
IS0, and JIS from the loadpoint/text directory with the following names:

e din.dtl
e iso.dtl
e jis.dtl

Retrieve these setup files to set the desired environment in your drawing. You use DRAWING > Advanced >
Draw Setup on the Menu Manager to create, retrieve, and modify a drawing setup file. This command opens
the Options dialog box.

Note: A drawing format always has its own setup file—independent of the drawing setup file—but it is
restricted.
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To Create a Drawing Setup File

Using Advanced > Draw Setup on the DRAWING menu, you can create a drawing setup file by saving a copy
of the default setup file under a different file name, and then editing the copy. Drawing setup files contain the
extension .dt1.

1. Inthe Menu Manager, click DRAWING > Advanced > Draw Setup. The Options dialog box opens and
displays the options in the current drawing setup file. The options are organized in the list according to the
function that they perform.

2. Save a copy of the current file under a different file name by clicking B = S open the Save a Copy
dialog box. Then, save a copy of the current file under a different file name.

3. Click === to open the new setup file, and then make edits to the file as desired.

4. After editing the file, click Apply to apply your changes, and then click Close to exit the Options dialog
box. The new file is saved to the current working directory and is available for use by other drawings.

5. To update the drawing, do one of the following:
—  Click View > Repaint
—  Click the Redraw button

—  Click View > Update > Current Sheet or All Sheets, and then use the GET SELECT menu to select
the view you want to update.

The system updates the drawing using the parameter values of the new drawing setup file.

To Change the Default Text Editor for Drawing
Setup Files

To change the default text editor for drawing setup files, you can use the configuration file option
drawing file editor. The default setting is protalb, which specifies Pro/TABLE as the default text
editor.

To use an editor other than the system editor (Pro/TABLE):

1. On the menu bar, click Utilities > Options and set the configuration file option
drawing file editortoeditor.

2. Open the drawing setup file by clicking DRAWING > Advanced > Draw Set Up on the Menu Manager.
Then, set the drawing setup file option pro_editor command. The value for this option must be the
full path to the executable file of the new text editor. For example, if you wanted to specify Notepad as the
default text editor, you would type the full path to the executable for the Notepad application in the Value

box (in the Options dialog box). The value might appear as follows:
C:\Winnt\notepad.exe

To Retrieve a Drawing Setup File

You retrieve an existing drawing setup file in the same way you retrieve a configuration file from within the
Options dialog box. When you retrieve a drawing setup file, Pro/ENGINEER reads in its values to the current
(active) drawing.

1. Choose DRAWING > Advanced > Draw Setup. The Options dialog box opens and displays the options in
the current drawing setup file.

2. Click “==2. The File Open dialog box opens and displays the files in the current working directory.

3. Choose a drawing setup file from the file list, and then click Open. The selected drawing setup file opens
and its options display in the Options dialog box.

4. Click View > Repaint, or click the Repaint button, or click View > Update. The system updates the
drawing using the parameter values of the retrieved file.
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Specifying Your Setup Files Directory

Using the configuration file option pro_dtl setup_ dir, you can specify the complete path to the directory
that contains your drawing setup files. When you choose Advanced > Draw Setup from the DRAWING menu,
The Options dialog box opens and automatically displays the directory that contains your drawing setup files. If
you do not specify the pathname using this configuration file option, the system brings you into the default
setup directory.

To Modify the Current Drawing Setup File

1. Choose DRAWING > Advanced > Draw Setup. The Options dialog box opens and displays the options for
the current drawing setup file.

2. Edit the values as necessary, and then click Apply to save your changes.

Click Close to close the Options dialog box.

4. Click View > Repaint, or click the Repaint button, or click View > Update. The system updates the

drawing using the new setup file option values.

Note: If you modify the option values for the current drawing setup file, the system modifies only the
current drawing. It does not modify drawing setup files on the disk unless you save the current values by
choosing Save.

To Work in Multiple Windows

You can show multiple drawing sheets in multiple windows (or the same sheet in multiple windows), create a
new sheet in a new window, and select any window.

1. Click Windows > New.
2. At the prompt, type the sheet number to appear in the new window, and then press ENTER. You can also
add a new sheet to the drawing. The new window appears with the specified sheet.

Selecting in Multiple Windows

You can select items in multiple windows using commands in the GET SELECT menu, but keep in mind the
following:

W

* You can select from any active sheet in any window. For example, you can select details to delete in all
windows.

e Ifyou select an item in a window other than the current window, the selected window becomes the active
window. For example, if you select a dimension in a window, that window becomes active. You can then
locate the dimension.

Objects and Procedures that are Changed in All
Windows

When you are working with multiple windows, Pro/ENGINEER simultaneously reflects the changes in all
windows of the same drawing for the following types of objects:

e Dimensions

e Notes

e Axes

e Symbols
e Datums
e Views

The system also simultaneously reflects the following procedures in all windows of the same drawing:

e Modifying the color of draft entities, cosmetic features, notes, or symbol instances
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e Creating or modifying a draft entity
e Manipulating draft datums
e Deleting geometric tolerances

Customizing Your Environment

Many configuration file options and several commands in the Environment dialog box control the display of
items in a drawing and access to files. Environment dialog box settings supersede configuration file settings.
Therefore, if you seldom use a particular command (such as the drawing grid), you could use the configuration
file option to keep it cleared, and use the Environment dialog box button only when you decide to use the
drawing grid.

Configuration File Options for Drawing Mode

The following configuration file options are specific to Drawing mode functions. See Configuration File
Options in Pro/HELP for full information about these options and for a complete list of configuration file
options available for Pro/ENGINEER.

allow move_view with move
allow mod attach draft dim
allow _move attach in dtl move
auto_associative dimensions
auto regen views

create drawing dims only
default draw_scale

dim fraction format
display dwg tol tags
display in adding view

disp trimetric dwg mode view
draw_models read only
draw_points_in_model_ units
drawing file editor

drawing setup file

drawing view_origin_csys

dwg select across pick box
force wireframe in drawings
format_setup_ file
highlight erased dwg views
highlight new dims

make parameters from fmt tables
make proj view notes

pro dtl setup dir
pro_format_dir

rename drawings with object
save _drawing picture file
save_modified draw_models_only
selection of removed entities
switch dims_ for notes
sym_leader_orient_ move_ text
todays date note format
variant drawing item sizes

About Retrieving Drawings in View-Only Mode

If you have a license for Pro/DETAIL, you can significantly reduce the amount of time it takes to retrieve a
drawing or report by using View-Only mode.
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The system does not retrieve any of the associated solid models if you retrieve a drawing by choosing Open
from the Pro/ENGINEER File menu, and then select the Retrieve Drawing as View Only check box from the
list in the upper-right corner of the File Open dialog box. Since the solid models are not in session, the system
temporarily freezes the drawings, so you cannot modify them.

View-Only Mode Restrictions
The following restrictions apply to View-Only mode:

o [fthe geometry display of a view is missing, the system displays an empty view boundary.

e Since Pro/ENGINEER does not retrieve any of the associated solid models, plotting (for example, complex
overlap checking) does not function the same way that it does in Drawing mode because much of the
information is missing.

e Ifyouretrieve a drawing that is already in memory into the current window in a different mode (for
example, the drawing is in View-Only mode, and you retrieve it using Search/Retrieve, or vice versa), the
drawing remains in its original mode and Pro/ENGINEER displays a warning message.

* You cannot modify or store drawings unless you use Retr Models in the VIEWONLY DRW menu to retrieve
all of the models.

e Ifyou store the display with snap lines in Drawing mode, the system plots them in View-Only mode.

e On a multisheet drawing, if you retrieve only one sheet, but you want to store the display, the system gives
you only the display of one sheet because it has not yet regenerated the other views.
To regenerate all sheets, choose View > Update > All Sheets on the Pro/ENGINEER menu bar. You must
do this manually before storing the drawing if you want the View-Only functionality to work for all sheets.
e Ifyou save the display (by selecting Save Display from the Environment dialog box or setting the
configuration file option save_display to yes), Pro/ENGINEER does not have to calculate the view
display. As a result, you can significantly reduce the retrieval time in Drawing mode.

Tip: Saving the Display

If you set the configuration file option save display to yes, the system stores view geometry and detail
items such as solid dimensions, and displays them when it retrieves the drawing in View-Only mode. If you set
this option to no, it does not display them. However, instead of modifying your configuration file, you can
select Save Display from the Environment dialog box since it performs the same function.

To Display a Drawing in View-Only Mode

1. Save existing display information by selecting Save Display from the Environment dialog box or setting
the configuration file option save display to yes. To regenerate an entire view or the display for the
current sheet (or all sheets), click View > Update.

2. Click File > Save to save your drawing with the display information you need.

Click File > Open; then click 3 and select the Retrieve Drawing as View Only option from the list.

4. Retrieve the drawing. The system displays the drawing in View-Only mode. Choose Sheet from the
VIEWONLY DRW menu to switch to another sheet.

5. To determine if any display information is missing, click Info > Session Info. If all information is there,

the system displays a message. If any is missing, it displays a text window, identifying the missing

information.

To Modify a Drawing in View-Only Mode

1. Choose Retr Models from the VIEWONLY DRW menu
2. Click Confirm. The system enters Drawing mode and retrieves all models for the current drawing.
3. Modify the current drawing as necessary.

W
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About Storing Drawings

Pro/ENGINEER saves some of the entities and information that you can create or modify in a drawing with the
model, rather than with the drawing. This is important, since such changes made to the drawing could affect the
model that it documents. For example, when you set a dimension as basic, the dimension becomes theoretically
exact, and the system removes any of its tolerances.

Pro/ENGINEER saves with the drawing strictly cosmetic information such as the following:

e All draft entities

e The view in which an entity appears

e The placement of an entity on the sheet

e Jogs and breaks in leaders and dimension lines

e The insertion of dimensions in notes

e The font, height, width, and slant angle of text

However, it saves with the model much of the information you add to a drawing, such as the following:

e Geometric tolerances (you can also save them in the drawing)
¢ Dimension information (also reference and driven dimensions), including the following:
— Additional text
— Standard/ordinate dimension type
— Attached geometric tolerance list
— Attached set datum or axis reference
— Value and tolerance information
— The difference between the primary and secondary units, when you have explicitly set them
— Basic and inspection attributes
—  Set datum and axis information
—  Datum target point information
— Surface finishes, including type and value
— Simplifications (using By View and All Views)
— Layer membership information for all entities in the model

To Disallow Changes Affecting the Model

To disallow changes made in Drawing mode that affect the model, set the configuration file option
draw_models read only to yes. In this case, when you attempt to make a change that affects the model,
Pro/ENGINEER issues a warning and does not make the modification.

To Save the Drawing without Storing the Model

Whenever you save a drawing after making changes that affect the model, Pro/ENGINEER saves the model
with the drawing. However, if you do not make changes to a model, and you want to save the drawing without
storing the model, set the configuration file option save modified draw models only to yes.

About Regenerating Views and Drawings

When you regenerate a drawing, Pro/ENGINEER recreates the drawing and the model that it represents; it does
not simply redraw them. Consequently, if you changed any dimension values in the model within Drawing
mode, the system updates the model to reflect these changes when you regenerate the drawing. The regenerated
drawing displays the updated model and any changes that you made to it.

If you create driven dimensions or draft dimensions, you must regenerate the drawing after you move draft
entities and when you want to show changes made to the drawing setup file option draft_scale.
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Regenerating the drawing updates the driven dimensions and snaps back the associated dimensions to the draft
entities. If you use driven dimensions in model relations, you must regenerate the model in the drawing to
update them.

Regenerating a View

The Update command in the Pro/ENGINEER View menu works together with the configuration file option
auto_regen views. The options for Update are as follows:

e Drawing View—Allows you to select the view(s) you want to regenerate.
e Current Sheet—Regenerates the current sheet.
o All Sheets—Regenerates all sheets in the drawing.

The auto_regen_views Configuration File Option

When you set the auto_regen views configuration option to yes, the system automatically updates the
drawing display by a repaint when you change from one window to another, such as when you modify a model
in a subwindow while you are working on a drawing in the main window. You can repaint or regenerate the
drawing to reflect changes made to the model. When you regenerate it, the system updates the model to reflect
the changes made in the drawing.

If you set auto_regen views to no, you can update only the drawing by choosing Update from the View
menu, and then selecting Drawing Views, Current Sheet, or All Sheets. Neither the Update command in the
View menu nor the Regenerate command in the DRAWING menu updates the drawing when you have this
option set to no, even if you make the change to the model in Drawing mode (such as modifying a dimension
value). You can select as many views as you want to regenerate at the same time.

If you try to modify a view that you have not updated, Pro/ENGINEER displays an error message informing
you that it is not going to make changes to the drawing until you apply the Update or Regenerate command to
the view.

Note: When you regenerate a parent view, its child views do not automatically regenerate; you must
individually select each view on the drawing, including detail views. Whenever you save changes to the model,
the system displays them on the drawing the next time that you retrieve it, regardless of whether you
regenerated the drawing views.

To Update a Drawing View
To update (regenerate) a drawing view after making changes to its source model,

e Click View > Update, and then choose one of the following options:

— Drawing Views—Regenerates the selected views. Select the views you want to regenerate, then click
Done Sel from the GET SELECT menu.

— Current Sheet—Regenerates all views on the current sheet only.
— All Sheets—Renerates all views on all sheets in the current drawing.

Note: Regenerating a drawing view is not object-action oriented. That is, you cannot regenerate a view by first
selecting the view and then choosing View > Update. You must choose the command first, and then select the
view(s) you want to regenerate.

To Regenerate a Model or Draft Dimensions

Whenever you change a model, use the Regenerate command on the DRAWING menu to regenerate it and to
update drawing views accordingly. Using this command, you can also update associative draft dimensions when
draft entities change.

1. Choose DRAWING > Regenerate.
2. Do one of the following:
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— To update the model and redraw all views accordingly, choose REGENERATE > Model.

— To regenerate only associative draft dimensions, choose REGENERATE > Draft (this command does
not regenerate a model, even if you change it).

About Drawing and View Scales

You can use two types of scales in a drawing: global, or drawing scale (when adding views using the No Scale
command) and individual scale (when adding views using the Scale command).

e With a global scale (or drawing scale), the system scales drawings according to the drawing SCALE
parameter at the bottom of the drawing sheet. For example, a value of .25 means that it scales the drawing
views at one-quarter of the actual size of the model. You can set a default drawing scale using the
configuration file option default draw_scale, or you can override your settings by modifying the
scale.

o With an individual view scale, the system gives views an individual scale factor that appears below each
view, shown in a note "Scale value." When you modify the drawing scale, these views do not change, since
the scale factors are independent.

When you change the size of the drawing, the drawing scale changes to match, to keep the views in proportion

to the size of the sheet. However, detailed and scaled views retain their original scale regardless of changes to

the drawing size.

View Scales Driven by Relations

You can use relational expressions to drive a view scale of a view that you placed using the Scale command,
however, you cannot use them to drive any views that you scale globally using the No Scale command. When
you type a relational expression for the view scale, the system calculates the expression and retains the
information. This functionality enables you to relate the view scale using dimensions within the model. The
system stores the relation with the model and updates the view scale each time the dimension in the model
changes, along with all items related to it.

Note: When you rescale a scaled drawing view, Pro/ENGINEER also rescales all related parent/child views
(projected views, broken views, etc.).

To Modify the Relational Expression for the View
Scale

1. On the menu bar, click Edit > Value.

2. Select the view scale in the lower-left corner of the screen.

3. Type the real value or relational expression and press ENTER.

Note: When using a relational expression, type on/y the right-hand side of the expression. The system calculates
the left-hand side as the view scale.

Drawing Scale Format

You can express drawing scales in a decimal or fractional format by setting the drawing setup file option
view scale format (decimal format is the default). To establish the pattern of fractional scales, use
the drawing setup file option view scale denominator.

About Multisheet Drawings

If you have a license for Pro/DETAIL, you can use the Sheets command in the DRAWING menu to create
multiple sheet drawings and move items from one sheet to another. You can view the sheets of a multisheet
drawing using basic Pro/ENGINEER. If a drawing has more than one sheet, an additional tag, SHEET # OF /],
appears at the bottom of the main window.

When working with multisheet drawings, keep in mind the following:
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e  When you switch a projection view to another sheet, it becomes independent. You can then move the parent
view, and the system does not update the projection view on another sheet. If you switch these views again
to the same sheet, the projection view immediately becomes a child of the parent.

® You can change drawing scales on each sheet independently.

e When you change the scale on a sheet, partial views on other sheets do not change.

e [fyou erase a view on one sheet, you can resume it on any other sheet.

* You can change which sheet is currently active by using the Sheet spin box located on the toolbar.

To Add a New Sheet to a Drawing

On the DRAWING menu, click Sheets > Add. Pro/ENGINEER automatically adds a new sheet to the end of
the drawing.

To Remove Sheets from a Drawing

1. Onthe DRAWING menu, click Sheets > Remove.

2. Enter the sheet numbers of the sheets you want to remove. You can separate them by using commas or
dashes and insert spaces anywhere, for example, [1,3-5,12,15-20]. The number to the left of a dash
must always be less than the number to the right. Press ENTER when you are done.

The system removes the specified sheets from the drawing. If it removes the current sheet, it sets the first
remaining sheet as the current sheet.

Tip: If Sheet Removal Automatically Cancels

Pro/ENGINEER cancels the procedure and does not remove any sheets if you perform any of the following

actions:

e Press ENTER without specifying any numbers.

e Use incorrect syntax in the input line.

e Type pairs of numbers without putting them in ascending order and separating them by a dash.

¢ Include nonexistent sheets (however, you can include the same sheet more than once; for example, [1-
5,3-8] isthe same as [1-81]).

e Specify the removal of all of the sheets of a drawing (if only one sheet is present, the Remove command is
not available).

o Specify the removal of a sheet that holds the parent view of a child view shown on another sheet that is kept
(however, you can remove both sheets at once).

To Reorder the Sheets in a Drawing

1. Onthe DRAWING menu, click Sheets > Reorder. Pro/ENGINEER displays the range of page numbers
for the drawing.

2. Type a new number for the current sheet. The system rearranges the sheets of the drawing, inserting the
current sheet into the specified position in the drawing.

To Move Items to Another Sheet

Using the Switch Sheet command in the SHEETS menu, you can move items to another sheet.

1.  Onthe DRAWING menu, click Sheet > Switch Sheet. The DWG ITEMS menu opens and displays the
following commands:
— Dwg Views—Switches drawing views.

— Draft Items—Switches detail items without leaders.
— Dwg Tables—Switches drawing tables.
2. Choose a command; then select items to switch.
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To confirm your selection, choose Done Sel. The system highlights the selected items in magenta.

4. Choose DWG ITEMS > Done and type the destination sheet number. You can also start a new sheet on the
fly by entering a new sheet number. If you type the current sheet number for the destination sheet, the
system prompts you to retype the number. Press ENTER when you are done.

5. The items appear on the specified sheet. To continue switching items, choose Sheet > Switch Sheet and

repeat the process.

Tip: Moving Draft Iltems

You cannot move draft items that have leaders attached to entities such as balloons, notes, and dimensions. If
the drawing has only one sheet, the system automatically creates a second sheet after you choose items to move.

To Move Items to Any Place on Another Sheet

1.  On the DRAWING menu, click Sheets > Switch Sheet >Switch/Move.

2. Choose a command from the DWG ITEMS menu.

3. Select items to switch. To confirm your selection, choose Done Sel. The system highlights the selected
items in magenta.

4. Choose DWG ITEMS > Done and type the destination sheet number. Press ENTER.

5. Select a method of defining the translation vector by choosing the appropriate commands from the GET
VECTOR menu:

6. Items appear on the specified sheet at the indicated location. To continue switching items, choose Sheets >
Switch Sheet and repeat the process.

The GET VECTOR Menu

The GET VECTOR menu allows you to translate (move) items to any place on another drawing sheet by
defining a translation vector. For information on moving items to another sheet, refer to To Move Items to Any
Place on Another Sheet in Pro/HELP.

The following options for defining a translation vector are available on the GET VECTOR menu:
e Horiz—Translates the entities along the horizontal direction. Type a value, in drawing units, to translate the

entities. Positive direction is toward the right of the sheet.

e Vert—Translates the entities along the vertical direction. Type a value, in drawing units, to translate the
entities. Positive direction is toward the top of the drawing sheet.

e Ang/Length—Translates the entities at an angle, and a specified distance in that direction, measuring the
angle relative to the horizontal in the counterclockwise direction. An arrow appears showing the positive
direction of translation.

o From-To—Translates the entities along a vector defined by using a start point and endpoint.

Maintaining Size and Position of Drawing Models

When moving items from one sheet to another in a two-dimensional drawing model, use the configuration file
option variant drawing item sizes to control whether drawing items maintain their size and position
on paper if you change the sheet size or drawing units.

e Ifyou set this option to yes, some items scale and/or reposition to be the same size or in the same place
when you plot them on paper, while other items scale and/or position themselves to be the same size or in
the same place on screen.

e Ifyou set it to no, items that you move or copy to a different sheet of the same or different 2-D model (or
items on a sheet that changes size and/or units) retain the same size on paper and the same relative
orientation as they did previously.
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About Drawing Templates

Drawing templates are used when creating a drawing. They automatically create the views, set the desired view
display, create snap lines, and show model dimensions based on the template.

Drawing templates contain three basic types of information for creating new drawings. The first type is basic
information that makes up a drawing but is not dependent on the drawing model, such as notes, symbols, and so
forth. This information is copied from the template into the new drawing.

The second type is instructions used to configure drawing views and the actions that are performed on that
view. The instructions are used to build a new drawing with a new drawing object (model).

The third type is parametric notes. Parametric notes are notes that update to new drawing model parameters and
dimension values. The notes are re-parsed or updated when the template is instantiated.

Use the templates to:

e Define the layout of views
e Set view display

e Place notes

e Place symbols

e Define tables

e (Create snap lines

e Show dimensions

You can also create customized drawing templates for the different types of drawings that you create. For
example, you can create a template for a machined part versus a cast part. The machined part template could
define the views that are typically placed for a drawing of a machined part, set the view display of each view
(for example, show hidden lines), place company standard machining notes, and automatically create snap lines
for placing dimensions. Creating a template allows you to create portions of drawings automatically, using the
customizable template.

To Create a Drawing Template

1. Click File > New. The New dialog box opens.
. Click Drawing, and then type the name of the template you are creating or accept the default.

3. Select the Use default template checkbox (selected by default), and then click OK. The New Drawing
dialog box opens.

4. Click Empty or Empty with format.
If you click Empty with format: Under Format, specify the format you want to use. Then click OK.
Pro/ENGINEER creates a new drawing with the specified format.
If you click Empty: Under Orientation, specify the template orientation by clicking Portrait, Landscape,
or Variable. For Portrait or Landscape, choose a standard size under Size. For Variable, specify a size
using the Width and Height boxes, and specify a unit by selecting Inches or Millimeters.

5. Click OK to create the template.

Click Applications > Template to enter Drawing template mode, and then in the TMPLT DWG menu,

click Views > Add Template. The Template View Instructions dialog box opens.

Type the View Name or accept the default, and then specify the view orientation.

In the Model ""Saved View' Name text box, orient the view.

Specify view options and view values in the View Options and View Values areas.

0 Click Place View and select the location of the General view.

Note: After you place the view, you now have the options to move the symbol, edit the view symbol, or to
replace the view symbol.

11. To place additional views, click New, type the new view name, and orient the new view. Specify the view
options and view values of the new view.

12. When you are done placing all of the desired views, click OK. Save the template.

&

S
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To Create a Drawing Using a Drawing Template

Click File > New. The New dialog box opens.

Click Drawing, and then type the file name for the drawing you are creating or accept the default name.
Clear the Use default template checkbox, and then click OK. The New Drawing dialog box opens.
Select the model from which you want to create the drawing.

Specify the template by clicking Use template. Type the name of the template you want to use or select a
template from the Template list. Click OK. The drawing is created.

Note: The views with the correct attributes in both the template and the model are created. If attributes that are
defined in the template do not exist in the model, errors occur when the drawing is being created. The Drawing
Template Error Info dialog box opens and lists the errors.

AP e e

To access the Drawing Template Error Info dialog box, click Info > Template Errors.

The Template View Instructions Dialog Box

The Template View Instructions dialog box is accessed from the TMPLT DWG menu (on the Menu
Manager), which appears when you click Application > Template in Drawing mode. For more information
about Drawing template mode, refer to To Create a Drawing Template in Pro/HELP.

Use the following options in the Template View Instructions dialog box to customize your drawing templates:

e View Name—Set the name of the drawing view that will be used as the view symbol label.
e View Orientation—Create a General view or a Projection view.
e Model "Saved View" Name—Orient the view based on a named view in the model.

View Options View Values
X-Section—Set cross-section. Only full, total cross-sections are X-Section Name
supported Arrow Placement View
Scale—Enter the scale value or no scale. View Scale

Explode State—Set the exploded view. Explode Name

Simplified Rep—Set the view as a simplified representation. If it ~ Simplified Rep Name
is not a simplified representation, the default is a master

representation.

Process Step—Set the process step for the view. Step Number

Model Display—Set the view display for the drawing view. Wireframe, Hidden Line,
No Hidden, Default

Tan Edge Display—Set the tangent edge display. Tan Solid, No Disp Tan,

Tan Ctrln, Tan Phantom,
Tan Dimmed, Tan Default

Snap Lines—Set the number, spacing and offset of the snap lines.  Number, Incremental
Spacing, Initial Offset

Dimensions—Show dimensions on the view. Create Snap Lines,
Incremental Spacing, Initial
Offset

Balloons—Show balloons on the view.
e Place View—Places the view after you have set the appropriate options and values.

o Edit View Symbol—Allows you to edit the view symbol using the Symbol Instance dialog box.
e Replace View Symbol—Allows you to replace the view symbol using the Symbol Instance dialog box.
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About Assembly Drawings

In an assembly drawing, you can show and erase assembly and part dimensions. You can also create dimensions
on individual components directly in an assembly view. However, keep in mind the following:

e You can display parameters for assembly features and all assembly components in assembly drawing notes,
but you cannot type part parameters.

e The dimensions in an assembly drawing are visible for modification only if the assembly for which the
drawing was created is in session.

Resuming Cosmetics

When you suppress parts or subassemblies in an assembly drawing, the system retains information about certain
cosmetics of these views. When you resume them, you also resume these cosmetics:
e Dimension placement

e Surface finish symbol placement

e Parametric text in notes and symbol instances

e Cross-hatching cosmetics

e References to cross-sectional edges

e Detail axis cosmetics

e Member, edge, and set datum display information

e Draft geometric tolerances that reference part datums

About Getting Drawing Information

By using the Info, Edit, and Analysis menus, you can access information about a drawing. You can:

e Highlight currently displayed items using filters. By using Edit > Find in Sheet, you can filter the display
of specified items according to item type (such as dimension, note, or geom tol), layer, and view.

e Perform measurement analyses on draft entities that exist in the drawing, by using Analysis > Measure
Draft Entities. You can get information about distance, angle, intersection point, and tangent point.

e Display geometric and cosmetic information about an entity, and save the information to a file, by using
Info > Draft Entity.

e Save a note as a text file, by using Info > Save Note.
e Display the grid angle and spacing values, by using Info > Draft Grid.

e Obtain information about out-of-date displays in the drawing, by using View > Check Display Status. You
can save the information to a file and select a recommended action to update the drawing (such as repainting
and regenerating).

e Obtain information about why a template failed when you attempted to open it, by using Info > Template
Errors.

To Get Information About Draft Entities

Use the following procedure to obtain cosmetic and geometric information about a selected draft entity, and to
save the information on the screen or to a file.

1. Click Info > Draft Entity.
2. Select a draft entity using the GET SELECT menu.

An Information window appears containing information about the selected draft entity.
3. To save the information on screen or to a file, click File > Save As.

To Perform Measurement Analyses on Draft Entities
1. Click Analysis > Measure Draft Entities. The Draft Measure dialog box opens, and the GET SELECT
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4,

6.

7.

menu appears.
In the Type list, select the type of draft to measure (Distance, Angle, Intersection Point, or Tangent
Point).

Under From and To, select the first and second entities to measure.

Note: To redisplay the GET SELECT menu, click the Select button LI

If you selected Angle, you can select Use horizontal to calculate the angle, instead of selecting a second
entity.

Click Compute. The computations appear under Results. The results include Angle, Distance,
Intersection Point,and Tangent point.

Click Compute to perform another analysis, and Info to display the results in an Information window.
Click Close to remove the Draft Measure dialog box.

To Save a Drawing Note as a File

Use the following procedure to save drawing notes as .txt files.

1.
3.
4.
3.

Click Info > Save Note.

Select the note you want to save.

At the prompt, type the file name for the note, and then press ENTER. You do not need to type the file
extension; the system inserts it automatically.

The note is saved in your working directory.

Click Quit Sel to exit the GET SELECT menu.

To Display Drawing Grid Information

Use this procedure to display the grid angle and spacing values for a grid in a drawing.

Click Info > Draft Grid.

The angle and spacing values for the grid are displayed in the message area.

To Get Information About Out-of-Date Displays in a
Drawing

1.

2.

Click View > Check Display Status. An Information window appears displaying the sheet number, view
ID, view name, any information about missing display status, and the recommended action to update the
drawing.

To save the information to a file, click File > Save As in the Information window.

To Get Information About Drawing Template
Failures

Use this procedure to obtain information about why a drawing template failed when you attempted to open it.

Click Info > Template Errors.

An Information window opens displaying the errors encountered when you attempted to open the template.

To Highlight Iltems by Type and Attributes on the
Current Sheet

Use this procedure to highlight displayed items on the current sheet, using the type and attributes filters
provided in the Highlight by Attributes dialog box.

L.
2.

Click Edit > Find in Sheet. The Highlight by Attributes dialog box opens.
Under Item Type, select the types of items you want to highlight.
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3. Under Owner Model:

— To highlight items that were created in the drawing (but not in the associated model or models), select
The drawing.

— To highlight items that were created in the current model, and shown in the drawing, select A 3D
model. In a multimodel drawing, the system highlights only items that were created for the current
model.

Both options are selected by default.
4. Under On Layer, select one of the following options:

— Any or none—Highlights the specified items, whether or not they exist on a layer.

— Atleast one—Highlights only specified items that exist on at least one layer. Items that are not on any
layer are not highlighted.

Selected and Select Layers—Highlights only specified items that are on the layers you specify.
5. Under Dimension Type, select the attributes of the type of dimensions you want to highlight.

— Owned by a model—Highlights dimensions that were created and reside in the associated model or
models (such as assembly and feature dimensions). In multimodel drawings, all dimensions that reside
in all associated models are highlighted.

— Created and associative—Highlights dimensions that were created in the drawing and are associative;
that is, they update when the referenced entity is regenerated (resized).

Note: If you have set the drawing setup file option associative dimensioning to no, this
option is disabled.

—  Created but non-associative—Highlights dimensions that were created in the drawing, but are non-
associative; that is, they do not update when the referenced entity is regenerated.

6. Under Displayed in View, select Any to display all items of the specified type in any and all views. Select

Selected or click Select View to select a view in which to display the items, using the GET SELECT menu.

7. Click Highlight to highlight the specified items. The items are highlighted in magenta. Click Close to close
the dialog box.

About Standard Formats

You can use a standard or a sketched drawing format in any number of drawings, and then modify it or replace
it at any time. A format is a customized layout for a drawing sheet. It includes a title block, a border, tables, and
your company logo. To create standard formats, you must be in Format mode and you must have a license for
Pro/DETAIL. You can select the desired format size from a list of standard drawing sizes, or create a new size
by specifying values for length and width. To create sketched formats, you must use Sketcher mode in basic
Pro/ENGINEER. Since you can modify them parametrically, you can create nonstandard size formats or
families of formats.

Standard formats consist of note text, symbols, tables, and draft geometry, including draft cross sections and
filled areas. You create or modify a standard format as you would a drawing, and you also use drawing setup
files. If you have a Pro/DETAIL license, you can do the following in Format mode:

e Create draft geometry and notes.

e Move, mirror, copy, group, translate, and intersect geometry.

e Use and modify the draft grid.

e Specify user attributes.

e (reate drawing tables.

e Use interface tools to create plot, DXF, DWG, SET, TIFF, CGM, and IGES files.

e Import IGES, DXF, and SET files into the format.

e C(Create user-defined line styles.

e Create, use, and modify symbols.

e Include draft cross sections in a format.
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To Create a Standard Format

1. From the Pro/ENGINEER menu bar, choose File > New.
In the New dialog box, click Format and type a format name in the Name box, or accept the default name.
Click OK.

3. Inthe New Format dialog box, specify the format size by doing one of the following:
— Under Orientation, click Portrait, Landscape, or Variable.

— Ifyou selected Portrait or Landscape, select a size from the Standard Size list.

— Ifyou selected Variable, you must define both the height and width dimensions. Select Inches or
Millimeters and type values in the Width and Height boxes.

4. Click OK. The system displays the format as specified, and the FORMAT menu appears.

To Create Format Geometry

To create format geometry, you use draft entities. To sketch draft geometry, use the Sketch menu, or use any of
the sketcher icons in the side menu.

Sheet Outline

The sheet outline is the border of the standard drawing format you selected, as shown in the following figure.
Because it is the actual border, it may not appear on pen plots unless you use a paper size larger than the
drawing size. Everything within the sheet outline border is also plotted, but you should make an allowance for
the plotter hold-down rollers.

To Modify a Standard Format

To modify the values of symbol text, symbol height, and note text in a standard drawing format, use the same
commands that are available during format creation.

1. Click File > Open, and retrieve the format using the File Open dialog box.
2. Use the options on the Format menu in the menu bar (Text Style, Arrow Style, Line Style, and so forth).

Placing Parametric Notes in a Format

When you place a parametric note in a format, the note in the format acquires the appropriate value when you
use it in a drawing. For example, if you create the note &model name in a format, the system displays the
actual model name in the note.

For the system to update these parameters when you add the format to a drawing, you can include in parametric
notes only the drawing labels listed in Appendix B, System Parameters for Drawings (except
&todays_date). You must include all user-defined model and drawing parameters in format table cells in the
form of &param using Enter Text in order for the system to update them in a drawing. Format mode interprets
the following types of parametric notes:

e Notes with symbol instances

e Notes with standard system symbols

e Notes with drawing labels

e Notes with a default tolerance

To Add a Table to a Standard Format

Using the Table command in the FORMAT menu, you can include tables in drawing formats. When you add a
format to a drawing, Pro/ENGINEER copies all of the tables in the format into the drawing. After it copies
them, the tables are independent of the original format, and you can move, modify, or delete them.

1. Make sure that the format file to which you want to add a table is the active file.
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2. On the FORMAT menu, click Table > Create. The TABLE CREATE menu opens.

3. Choose from the following options on the TABLE CREATE menu:

Descending or Ascending—Lets you choose the direction in which to create rows from the starting
point.

— Rightward or Leftward—Lets you choose the direction in which to add columns from the starting
point.

— By Num Chars or By Length—Lets you define the length of columns and rows using drawing units
(such as inches or millimeters) or by specifying the number of characters as the unit.

4. Use the options on the GET POINT menu to locate the starting corner of the table on the format. The
starting corner depends on the choices you made in the TABLE CREATE menu, as specified in the
preceding step.

— Pick Pnt—Lets you select a point on the format and specify it as the starting corner.
— Vertex—Lets you select a vertex and specify it as the starting corner.
— On Entity—Lets you select an entity on the format and specify it as the starting corner.

— Rel Coords—Lets you specify relative coordinate values for placing the starting corner by entering
relative values for the X- and Y-Axes.

— Abs Coords—Lets you specify absolute coordinate values for placing the starting corner by entering
absolute values for the X- and Y-Axes.

w

At the prompt, enter the width of the first column in drawing units, and then press ENTER.

6. Continue entering the width of additional columns until you have the number of columns you want. Then
press ENTER again without typing another column width value.

7. At the prompt, enter the height of the first row in drawing units, and then press ENTER.

8. Continue entering values for the height of additional rows until you have the number of rows you want.
Then press ENTER again without typing another row height value.

The table displays on the format sheet.

About Using Tables in a Standard Format

Using the Table command in the FORMAT menu, you can create tables and add them to drawing formats. Then,
when you add a format to a drawing, Pro/ENGINEER copies all of the tables in the format into the drawing.
The copied tables are independent of the original format, and you can move, modify, or delete them.

When you Add/Replace a format or Remove it (using DRAWING > Sheets > Format > Add/Replace (or
Remove), the system highlights the table copied from the old format and asks if it should remove the table. You
can choose one of the following: (Y)es, (N)o, (K)eep all, (R)emove all.

If you add a table to a format, the drawings that already reference this format do not display the new table. The
table must be part of the format when you initially copy it into the drawings. To use the modified format in the
drawing, you must choose Sheets from the DRAWING menu, Format from the SHEETS menu, and
Add/Replace.

When you add a format to a drawing that contains the format table, the system stores the values you specified
for the table as drawing parameters if you have set the configuration file option

make parameters from fmt tables toyes. You can access the parameters using the Parameters
command in the ADV DWG OPTS menu. If you set this configuration option to no, when you add a format to a
drawing, the system prompts you to retype all of the values every time, and it does not evaluate the values on
subsequent sheets of the drawing in the format table. These values are nonparametric text. For the system to
reprompt you for the parameter text, you must choose Sheets from the DRAWING menu, Format from the
SHEETS menu, and Add/Replace.

Note: You cannot use reserved model parameters. If you set make parameters from fmt tablesto
yes in the configuration file, Pro/ENGINEER does not prompt you to type a value for reserved model
parameters because it cannot add them to the drawing.

If you change the format size of a drawing with a table, the system scales the table (in the same way that it

scales any views and draft entities) to maintain its location relative to other items and the sheet boundaries.

Since the drawing setup file option drawing text height controls the height of any text in the table,
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Pro/ENGINEER does not scale text that you include in the table. Therefore, it does not maintain a size that is
proportional to the rest of the table. You must modify the text height manually.

To Use Parameters as Labels in a Format Table

You can include parametric labels, such as the drawing name, model name, and sheet number, as text in a
format table. For a multimodel drawing, you can type into the format table any parameters related to both the
first model and the second model. To include the parametric labels in the table:

1. Onthe FORMAT menu, click Table > Enter Text.

2. Select the table cell where you want to place the label text.

3. At the prompt, enter the appropriate label (such as &dwg name) and press ENTER. To create additional
lines of text, continue entering text for each line. When you are done entering text, click the middle mouse
button. The label appears in the table exactly as you typed it until you add the format to a drawing.

Guidelines for Using Parametric Labels in a Format
Table

The following rules apply to including parameters as labels in format tables:

e Pro/ENGINEER correctly evaluates parametric labels that you include in a format table only if you create
the drawing first, add the model, and then add the format. It does not evaluate the labels correctly if you
create the drawing, add the format, and then add the model.

e  When you add a format to a drawing with more than one model present, parametric notes can reference only
the active drawing model.

e To include text in a table as a title block, use the Enter Text command in the FORMAT > TABLE menu. If
you move the table, the system does not keep the text that you add as a note with the table.

When you add the format to a drawing, Pro/ENGINEER parses any and all that are present of the standard
parametric symbols that it supports and displays the correct values in the table. It does this for every sheet of the
drawing on which you use the format, so that the drawing name, model name, or any other standard parameter
that you used appears on every sheet that uses that format.

To Give a Format the Same Parameter Values as the
Drawing

Each drawing format that you create has its own setup file—one that is completely independent of the drawing
setup file. The configuration file option format setup file assigns a specified setup file to each format
that you create, but does not do so for drawings. For these two setup files to have the same values, you must edit
them separately. To give a format the same parameter values as a drawing to which you are adding it:

e Retrieve the drawing setup file into the format using the Set Up command in the FORMAT menu. The
system reads only those format setup file options that formats are using.

Format Setup File Restrictions
The format setup file is restricted. You can use only the following options:

e drawing units (you cannot modify this option)
e drawing text height

e draw _arrow_style

e draw_arrow_length

e draw dot diameter

e draw_attach sym width

e draw _attach sym height
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e Jleader elbow_ length

e default font

e aux font

e text width factor

e line style standard

e node radius

e yes no parameter display
e sym flip rotated text

To Reuse a Format from a Legacy System

To reuse an existing format (that is, one that was created in another system), use the interface options (such as
DXF, SET, IGES, TIFF, and so on) to import it into your format.

To Save a Standard Format

Before you can use standard drawing formats in a drawing, you must save them. To save a format:

e Choose Save from the Pro/ENGINEER menu File menu; then type the format name and press ENTER.

About Sketched Formats

To create a sketched format, you must be in Sketcher mode. When you create it, Pro/ENGINEER gives it the
name filename. sec. The first time you add the format to a drawing, it makes a copy of it in memory and
gives it the file extension . frm.

When Pro/ENGINEER creates £ ilename . frm, that file ceases to have any relationship or associativity with
the section from which it was created; therefore, £ilename . frm does not reflect changes that you make to
filename. sec, and vice versa.

When you add a sketched format to a drawing, the system aligns the lower-left corner (the origin) of the format
to the lower-left corner (the origin) of the drawing, and then centers all items in the drawing on the new sheet in
the locations that correspond to their positions on the original sheet. If necessary, it adjusts the drawing scale,
maintaining relative distances between items.

Note: To copy a file, you must save the £ilename . frm file by choosing Save As from the Pro/ENGINEER
File menu, and typing the format name.

To Create a Sketched Format

1. From the Pro/ENGINEER menu bar, choose File > New. The New dialog box opens.
2. Select Sketch. In the Name box, type the name of the sketch to use for the format or accept the default file
name. Click OK to close the New dialog box and create the sketch.
3. Sketch the boundary, title block, and so on, and then dimension them.
4. When Pro/ENGINEER successfully regenerates the section, save it using File menu commands. You
cannot save text with a sketched format.
5. Create a drawing and add the sketched format to the new drawing by doing one of the following:
— During creation of the drawing, in the New Drawing dialog box, select Empty with format, and then
click Browse to find and open the sketch name. Click OK to create the drawing with the sketched
format.

—  After creating the drawing, choose DRAWING > Sheets > Format > Add/Replace. Choose the sketch
name (set the type filter to sketcher).
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Effects of Format Size

Pro/ENGINEER automatically assigns a correct paper size to a sketched format. For example, if a format is
7x10 inches, it automatically places the format on an A-size sheet. It does this even if the drawing was
originally created in another size. If you add a format of a different size to the drawing, the drawing assumes the
size of the format. It scales all views and draft entities accordingly.

Valid Format Extensions

Using Sketcher mode, you can retrieve and change a sketched format. When replacing formats,
Pro/ENGINEER looks first for a format with a . £rm extension, and does not accept . sec as a valid extension
for format names.

To Replace an Existing Format with a Modified
Format

To replace the existing version of the format with the modified one, do one of the following:

e Rename the sketch of the modified format, so that the name is different from the current format, and then
use the Add/Replace command (DRAWING > Sheets > Format > Add/Replace) to replace the modified
sketch in the drawing.

e Use the Remove command (DRAWING > Sheets > Format > Remove) to remove the existing format and
rename its . frm file. Add the modified sketch to the drawing.
Note: You must rename one of the formats; otherwise, if you try to replace the current format, it simply
replaces itself with the same filename. frm.

To Modify and Replace a Sketched Format in
Sketcher Mode

1. Retrieve the sketch of the format into Sketcher mode (using File > Open). Pro/ENGINEER cannot retrieve
a filename. frm into Sketcher mode, so filename . sec must exist.

2. Modify the sketch. You can resketch or redimension, but you cannot add notes, symbols, or draft entities.

3. Save the format sketch.

About Using Formats in a Drawing

Pro/ENGINEER saves drawing formats in a separate file. When you revise a format, it automatically updates it
in all drawings that use it. When retrieving a drawing, if it cannot find the format that the drawing uses, it
displays an error message in the message area.

For a multisheet drawing, you can have two default formats—one for the first sheet and another for the
remaining sheets. The first sheet you create assumes by default the first sheet format. All of the remaining
sheets use the second sheet format.

You can change the format on any sheet (including the first sheet) independently of the formats on other sheets;
therefore, you could use a different format on each sheet of the drawing. To add or replace a single format on all
existing sheets of a drawing, you must add the format to each individual sheet.

Each drawing format that you create has its own setup file—one that is completely independent of the drawing
setup file. The configuration file option format setup file assigns a specified setup file to each format
that you create, but does not do so for drawings. For these two setup files to have the same values, you must edit
them separately. For more information, click See Also.
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To Add or Replace a Format in an Existing Drawing

1. Using Window > Activate, set the drawing in which you want to add or replace a format as the active
drawing.

2. On the DRAWING menu, click Sheets > Format > Add/Replace. The Open dialog box opens and
displays the contents of the System Formats directory on your local system.

3. Select the format file you want to add or replace. Format file names contain the extension .frm. Sketched
format files use the extension . sec.

To Add a Format to a Drawing While Creating the

Drawing

1. Click File > New... > Drawing > OK. The New Drawing dialog box opens.
Under Specify Template, click Empty with format.
3. Under Format, select a format name by doing one of the following:
— Choose a name from the list in the Format box.
— Type [2] in the Format box and press ENTER; then select a name from the Open dialog box.
—  Click Browse, and then select a name from the Open dialog box.
4. Click OK. The system creates the new drawing and includes the specified format.

To Remove a Format from a Drawing

1. Using Window > Activate, make sure that the drawing from which you want to remove the format is the
active drawing.

2. On the DRAWING menu, click Sheets > Format > Remove. The DWG SIZE TYPE menu and the DWG
SIZE menus appear.

3. Assign a new format to the drawing by doing the following:
— (Optional) Select a new drawing size from the DWG SIZE TYPE menu.
—  On the DWG SIZE menu, select a new drawing format size to use in the drawing.

The system removes the current format and adds the newly specified format to the drawing.

To Blank or Unblank a Format on a Drawing

1. Using Window > Activate, make sure that the drawing from which you want to remove the format is the
active drawing.

2. On the DRAWING menu, click Sheets > Format > Blank or Sheets > Format > Unblank.
The format is blanked from the drawing (or redisplayed on the drawing if you selected Unblank).

To Display a List of Available Formats

1. Using Window > Activate, make sure that the drawing from which you want to remove the format is the
active drawing.

2. On the DRAWING menu, click Sheets > Format > List.
The system displays an Information window with a list of formats that are available in the current directory.

To Create Sheet Templates for Process Assembly
Drawings

When working with a drawing of a Pro/PROCESS for ASSEMBLIES or Pro/PROCESS for COMPONENTS
model, you can use the following procedure to create drawing sheet templates:

1. Inthe DRAWING menu, click Sheets > Copy Process to create a template from the current sheet. The
Process State dialog box opens.

2. Choose from the options in the dialog box, and then click OK. The system adds a sheet to the drawing
using the current sheet as the template.
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The new sheet contains copies of the views and tables that were on the template sheet, and they reference
the step that was highlighted when you clicked OK. The views retain their orientation.

Guidelines for Creating Drawing Sheet Templates
The following rules apply for creating sheet templates:

e You cannot use a sheet as a template if it contains views of more than one model.

e The Copy Process command appears in the SHEETS menu only if you are working with a drawing of a
process assembly and you have a license for Pro/PROCESS for ASSEMBLIES or Pro/PROCESS for
COMPONENTS.

To Set Up a Format Library

You use the configuration option pro_format_dir to set a path name (directory) where your company
formats will be stored. When you use this configuration option, Pro/ENGINEER automatically searches the
specified directory for company formats when adding or replacing formats in your drawing and layout.
Pro/ENGINEER places modified formats in this directory when you save them.

1. Click Utilities > Options. The Options dialog box opens.
Enter the configuration file option pro_format dir. This option uses a path name (directory) as its
value, so you can create a single set of formats that everyone on the system can use, and place them all in a
single directory.

3. Under Value, enter the path name and directory where you want to store all formats.

To Retrieve a Format from the Format Library

Using the File Open dialog box, you can retrieve formats from a format library directory within
Pro/ENGINEER. To retrieve a format:

1. Click File > Open. The File Open dialog box opens.
2. Select System Formats from the Look In list. Navigate the menu tree until you locate the format.
3. Click Open. The selected format opens.

To Create a Drawing

When creating a drawing, you can specify a model in which to automatically place views.

1. Click File > New.

2. Inthe New dialog box, click Drawing and type a drawing name in the Name box (or use the default); then
click OK. The New Drawing dialog box opens.

3. In the Default Model box, type the name of a model that resides in the current directory to use as the
default. When you specify the optional default model, the system automatically brings in a format with
parametric callouts (for example, &model name) because the drawing searches the model for the
parameter names. You can also type [?] or click Browse... to select a name from the Open dialog box. The
default name is the last current model. Click OK when you are done.

4. Under Specify Template, do one of the following:

— Touse a Pro/ENGINEER drawing template, click Use Template, and then select a template from the
list.

— To create a drawing without a template but with an existing format, click Empty with format. Under
Format, specify the format you want to use.

—  Specify the drawing size or retrieve a format. To specify the size, do one of the following:
Click Portrait or Landscape in the Orientation box and select a standard size from the Standard
Size list. Portrait makes the height larger than the width, and Landscape makes the width larger than
the height.
Or
Click Variable in the Orientation box to define both the height and width dimensions. Select Inches
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or Millimeters and type values in the Width and Height boxes.
To retrieve a format, select Retrieve Format and select a name from the Name list in the Format box.
You can also type [ 2] or click Browse to select a name from the Open dialog box.

5. Click OK. The system displays the drawing as specified and the DRAWING menu appears.

To Add a Format to a Drawing

1. Choose DRAWING > Sheets > Format > Add/Replace.
2. Inthe Open dialog box, select a previously created drawing format residing in the System Formats
directory, or type [ ?] to select from a menu of previously created formats. To select from a namelist:
— Under Look In, Choose the name of another directory to access formats in other locations.
The system adds the format to the drawing, with the lower-left corner of the format coinciding with the
lower-left corner of the drawing sheet.

Importing Drawing Formats
You can also import drawing formats through IGES, DXF, TIFF, CGM, or SET.

You can add the following items to your drawing in any order you require: drawing formats, draft geometry,
and model views. For more information, refer to the topics , Before and After Adding Views, and To Add a
Format to a Drawing.

Before and After Adding Views

Before you start adding views, you must add the first model to the drawing (if you did not already do so during
creation of the drawing by specifying the optional default model. For more information, refer to the topic To
Create a Drawing). If you retrieve a model that has an instance, you must specify whether you want to retrieve
the instance or the generic model. You can use a single model to create any number of drawings. When creating
each new drawing, give the drawing a unique name.

After you add the first view, the information at the bottom of the main window changes according to that view.
Pro/ENGINEER sets the scale so that several views can fit on the drawing. You can modify this scale any time
after you add the first view.

To Add the First Model to a Drawing

If you did not specify a model to which the drawing refers during creation of the drawing, you can use the
following procedure to add the first model to the empty drawing.

1. Choose DRAWING > Views. The Open dialog box opens.

2. In the Name box, type the name of the model you want to add, or locate the desired model using the Look
In box. Click Open when you are done.

3. Add the first view by choosing VIEWS > Add View; then select view specifications from the VIEW TYPE
menu.

Retrieving Drawings

Using the File Open dialog box (click File > Open to access the dialog), you can retrieve an existing drawing
by selecting it from a list of drawings in the current directory. The list includes the names of all directories
contained in the current directory and buttons to go up to the next directory level. You can also use the Look In
box to navigate to the directory where the drawing resides. If you click the Working Directory button, the
system lists all drawings in the working directory. When you retrieve the drawing, it retrieves the associated
model(s) and regenerates the drawing.

To Retrieve a Model into the Current Session

To open a model from within Drawing mode, you can use File > Open, or you can use the Model Tree.
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1. Click File > Open. The File Open dialog box opens.
2. Navigate to and select the model you want to open, and then click Open.
The model is retrieved into the current session in a separate Pro/ENGINEER window.

Using the Model Tree

1. In the Model Tree, select the model you want to retrieve, and then right-click to display the shortcut menu.
2. Choose Open from the shortcut menu. The model is retrieved into the current session.

To Copy Drawing Files With Object Rename

Using the configuration file option rename drawings with object, you can copy a drawing and a part
simultaneously with its associated part or assembly file (using File > Save As) and then rename the drawing.
The drawing adopts the same new name as the name of the copied part or assembly file.

1. Click Utilities > Options. The Options dialog box opens.

2. Type the configuration option rename drawings with object in the Option box.

3. Select a value for the option from the Value drop-down list.
When you specify the value as both, part, or assembly, and then choose Save a Copy from the
Pro/ENGINEER File menu for a part, the system also renames the drawing file associated with the renamed
part, as long as it has the same name as the part.

To disable this option, set this configuration option to none (the default setting).

The following diagram illustrates the renaming process when you use Save As to save a part or assembly file
that has an associated drawing.

pi.prt pl.drw
p.pri p2.dr

About Adding Views

The first view that Pro/ENGINEER adds to a drawing is a general view. Initially, it displays it on the sheet in
the default orientation, but you can orient it using the VIEW TYPE menu (accessed by clicking DRAWING >
Views > Modify View > View Type). For each view, you must specify the following properties:

e The type of view, or how it is created (such as oriented independently of other views, projected from an
existing view)

e How much of the view is shown

e Ifthe view has a cross section

o [Ifthe view is scaled, or if you want to create a perspective view

The next table summarizes valid menu combinations of these view types.

Valid View Type Menu Combinations

Projection Auxiliary General Detailed Revolved Graph

Full X X X X X X
View
Half View X X X
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Broken

View

Partial X X X X

View

Section X X X X

No Xsec X X X

of X X X

Surface

Scale X X X
No Scale X X X X X

Note: You can also use the Orientation dialog box (accessed by clicking DRAWING > Views > Modify View
> Reorient). However, this dialog box contains limited options for reorienting a view.

Draft Views

Using the Draft View command (DRAWING > Tools > Draft View), you can set a drawing view to be the
current draft view so that Pro/ENGINEER associates all new draft entities with that view. When you have
associated draft entities with a drawing view, they move with the view when you move it, maintaining their
location relative to that view. Also, when you scale the view or the drawing, the system scales all draft entities
associated with a view by the same factor.

The system uses the view scale of the current view when you create draft entities.

When a view is set to be current (using DRAWING > Tools > Draft View > Set Current), the system uses the
view scale of the current view for draft entities that you sketch, such as lines and circles, as well as for
dimensions related to draft entities.

The current draft view scale is used only when the current view is on the current sheet of the drawing.

Using the current draft view illustrates the associativity between draft entities and the current draft view. You
can associate notes without leaders, symbols, and geometric tolerances with a draft view in addition to draft
geometry. However, you cannot associate draft datums and datums with a draft view.

Controlling How a Drawing View Is Displayed

The configuration file option display in adding view controls how Pro/ENGINEER displays a model
in a drawing. If you set this option to wireframe, the system adds each new view in wireframe and displays
datums. If you set it tominimal wireframe, it initially displays each new view in wireframe without
datums, axes, or silhouette edges. You can also use the default view display to add views with or without hidden
lines.

To Create a General View

1.  Onthe DRAWING menu, click Views > Add View > General, and then accept the default commands Full
View, No Xsec, and No Scale. Click Done.

2. Select a location on the drawing as the center point for the new view. The view appears centered in the
selected location. The Orientation dialog box opens.

3. Orient the view using commands in the Orientation dialog box. If you want to retrieve a previously saved
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view of the model in that orientation, click Saved Views and select the view name.
4. After you have specified an orientation, click OK to close the Orientation dialog box; then, click
Done/Return on the VIEWS menu.
When you create a projection view and move the general view, the projection view follows the main view to the
new location.

Example: Creating and Orienting the General View

\\ SCALE 1.0

1  The general view appears in default orientation with datums shown.
a Select this surface for the Top.

b Select this datum for the Front.

2 The system orients the view as specified. If Display Datum Planes is selected in the Environment dialog
box, datums perpendicular to the screen remain visible.

To Set a Drawing View as the Current Draft View

1. Click DRAWING > Tools > Draft View > Set Current.

. Select a view to be current. The system sets the selected view as the current view.

3. To add existing draft entities to the current draft view, choose Add on the DRAFT VIEW menu, and then
select the entities you want to add. To associate the entities with the view, you must add the draft entities to
the view first and then dimension them. If you have previously associated an entity with another view, the
system automatically removes it (disassociates) from the original view when you add it to this view.

— To delete the draft entities, click Remove, and then select the entities you want to remove from the
current view. Once you remove them, the system disassociates those entities from the view.
— Note: Add and Remove are available only when the current view is set.

— To unset the current draft view, leaving no view set as current, use Unset Cur.

About Working with Model Datum Planes

Pro/ENGINEER shows datum planes in the drawing under these conditions:

e Temporarily, when you are orienting the model while creating a drawing view (this is the only time it
displays a datum plane that is not perpendicular to the screen).

e  When the datum is a draft datum. When you have selected Display Datum Planes in the Environment
dialog box (or when you have selected Planes in the Datum Display dialog box) and the datum planes are
perpendicular to the screen.

e  When you have set the datum plane as a reference datum and it is perpendicular to the screen.

To manipulate set datums, use Edit > Properties on the menu bar. Set datums appear regardless of the setting
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in the Environment or Datum Display dialog boxes. You can erase them from a view by choosing View >
Show and Erase on the menu bar, or by blanking them individually or on a layer.

You can also use shortcut menus (accessed by clicking the right mouse button on an object) to modify and
manipulate 3-D set datums in the following ways:

e Move them to a different location on the drawing sheet.
e Redefine them.

e Erase and unerase them.

To Create a Datum Plane Feature

In Drawing mode, you can create datum plane features in a model; however, you cannot create a datum plane
on the model if the model is read-only in the drawing.

1. Choose Insert > Datum > Plane.
2. In the Datum dialog box, type a name in the Name box. If you do not specify a name, the system assigns
the name as DTM#.
3. Do one of the following:
— Click Define, and then constrain the datum by choosing commands from the DATUM PLANE menu;
then click Done.

— Click On Surface to place the datum plane feature on a planar model surface.

4. Under Type, choose the type of datum you want to create.

5. Ifyou are creating a set datum, click Free or In Dim to specify its placement.
When the system has fully constrained the datum, it creates it; however, it displays the datum only if it is
perpendicular to the screen and you have selected Display Datum Planes in the Environment dialog box (or
if you have selected Planes in the Datum Display dialog box).

6. To continue creating datums, click New, type another name in the Name box, and click Define... or On
Surface....

To Rename a Model Datum

Click Edit > Properties.

In the drawing window, select the datum you want to rename. The Datum dialog box opens.
Type a new name in the Name box.

Click OK to save the name change and to close the dialog box.

To Modify the Display of a Set Datum Plane

You can lengthen or shorten set datum planes by moving or clipping them. Moving a datum plane moves either
side of the datum. Clipping moves the end opposite to the datum name.

bl a

1. Select the datum you want to modify. The datum is highlighted and its handles display.
2. Do one of the following:

— To move the datum, select anywhere in the drawing window and the datum text moves to a
corresponding location along the datum. The name of the datum also flips to the side of the datum
where you selected.

— To clip the datum, select anywhere and the datum plane moves to a corresponding point along the
datum. The datum name does not move.

To Show Datum Planes

Datum planes that you have already set as reference datums appear automatically in those views where the
datums are perpendicular to the screen (on edge). If you have erased a set datum plane, use this procedure to
show it again.

1. Click View > Show and Erase.
2. In the Show/Erase dialog box, click Show.
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3. Under Type, click the Datum Plane button.
4. Click OK when you are done. The system displays all datum planes.

To Erase a Set Datum

1. On the Pro/ENGINEER menu bar, click View > Show and Erase.

2. In the Show/Erase dialog box, click Erase.

3. Click the Datum Plane button in the Type box; then select a button in the Erase By box to specify the
feature, view, or part.

To restore it, click Show, the Datum Plane button in the Type box, and a button in the Show By box to specify

the feature, view, or part.

Erasing a Set Datum from a Member of the
Assembly

If a drawing has several occurrences of the same part in an assembly, you can erase a set datum from a
particular member of the assembly without causing the selected set datum to disappear from other occurrences
of the member.

Note: You can erase only set datum planes from the drawing. To remove from display any other model datum
planes (not draft datums), clear Display Datum Planes from the Environment dialog box, or clear Planes
from the Datum Display dialog box (View > Datum Display).

To Create a Draft Datum Plane

1. On the Pro/ENGINEER menu bar, click Insert > Draft Plane. The GET POINT menu opens in the Menu
Manager, and Pick Pnt is selected by default.

2. Click the left mouse button to begin drawing the datum plane.

3. Extend the datum plane to the proper orientation. Place the endpoint by clicking the left mouse button.

4. Type the name of the datum plane.

Note: To move or reorient draft datums, select a datum and then click anywhere in the drawing window to
relocate or clip it. You can also click DRAWING > Tools > Rotate or DRAWING > Tools > Translate.

Displaying Datum Planes

Pro/ENGINEER shows datum planes on edge, making both red and yellow sides visible. You can move, delete,
and restore draft datums using the shortcut menu (accessed by right-clicking on the datum).

To Control the Size and Shape of Datum Points

To control the size of model datum points and sketched datum points in Drawing mode, use the following
drawing setup file options:

e Specify a value for the drawing setup file option datum_point size. To open the drawing setup file,
click Advanced > Draw Setup on the DRAWING menu. The default size is . 3125.

e To display draft or datum points as a cross, dot, circle, triangle, or square, specify a value for the drawing
setup file option datum point shape.

Note: These drawing setup file options control the display of points in Drawing mode only. To modify the
datum point symbol display for Part or Assembly mode, set the configuration file option
datum point symbol.

About Working with Model Axes

You can manipulate the axes of cylindrical or conical surfaces independently of the Environment dialog box
settings. However, keep in mind the following:
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o The system shows the axis as a line whenever you view it from the side, or as a cross hair whenever you
orient the axis normal to the screen.

e In Drawing mode, if you have not cleared Display Datum Axes from the Environment dialog box, axis
names do not appear on the drawing. You can control the display of axis names independently of the axis
display by selecting or clearing Axis Tags on the Datum Display dialog box (View > Datum Display).

® You can create axes in the drawing if you have a Pro/DETAIL license; however, these axes belong to the
drawing, not to the model.
e A draft axis always appears as a centerline.

By right-clicking a selected axis and using the shortcut menu, you can modify set and unset model axes in the
following ways:

e Move them to a different location on the drawing sheet.
e Modify their attachment.
e Redefine them.

e FErase and unerase them.

To Create a Datum Axis

The system displays draft axes in leader style with centerline font.

On the Pro/ENGINEER menu bar, click Insert > Datum > Axis.

In the Axis dialog box, type a name in the Name box.

Click Define....

Constrain the datum axis by choosing commands from the DATUM AXIS menu; then choose Done.
To continue creating datum axes, click New, type another name in the Name box, and click Define....

To Rename a Datum Axis

1. In the drawing window, select the datum axis you want to rename, and then right-click and select Redefine
from the shortcut menu.

2. In the Axis dialog box, type a new name in the Name box.

3. Click OK to close the dialog box. The axis is renamed.

To Create a Set Datum Axis

1. In the drawing window, select the datum axis on the screen, and then right-click and select Redefine from
the shortcut menu.

2. In the Axis dialog box, click -A- (set). The system encloses the axis in a feature control frame.

3. Click OK to close the Axis dialog box.

To Specify the Placement of a Set Datum Axis

1. In the drawing window, select the axis you want to place or relocate, and then right-click and select
Redefine from the shortcut menu.

2. Click In Dim and then Pick Dim in the Axis dialog box.

3. Select a dimension in the model. The system places the set axis under the dimension on the screen.

4. Click OK to close the dialog box and save the change.

Note: If you set the drawing setup file option gtol datums to STD_ASME or STD_ISO, you can also place
a set datum axis on a geometric tolerance. Click In Gtol and Pick Gtol...; then select a gtol in the model.

Tip: How the Show and Erase Command Affects
Axis Display

The Show and Erase command in the View menu (menu bar) displays the axes of cylindrical and conical
surfaces on the drawing and erases axes that the system shows in a drawing. Because axes belong to the model,
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like dimensions, you cannot delete them.

Note: Showing or erasing an axis in a radial pattern affects corresponding axes in all pattern instances.

To Display Axes on a Drawing

1. On the Pro/ENGINEER menu bar, click View > Show and Erase.

2. In the Show/Erase dialog box, click Show.

3. Click the Axis button in the Type box; then select a button in the Show By box to specify the feature, view,
or part. If you select Feat_View or Part_View, select the feature or part, choose Done Sel, and then select
the view in which to show the axis.

Controlling the Display of Axes

By setting the drawing setup file option axis interior clipping to no, you can set the axis display
according to these three ANSI Y 14.2M standard requirements:

e Line starts and ends with a dash.

e Perpendicular axes of a centerline intersect at a short dash.

e Very short centerlines are unbroken.

Axes that are set to CTRLFONT actually are shown as CTRLFONT_S_L or CTRLFONT L _L, depending on
their orientation. You can control them by setting 1ine style lengthto CTRLFONT S L or
CTRLFONT_L_L, not CTRLFONT. To control axes that are perpendicular to the view, set

line style lengthto CTRLFONT S _L;to control axes that are parallel to the view, set it to
CTRLFONT I, L.

This option affects the axis display in the following ways:

o Axes parallel to the screen appear in one line in a centerline font, beginning and ending with a long dash;
choose Move from the Edit menu (menu bar) to modify either endpoint.

e Axes perpendicular to the screen appear in two lines, each of them drawn in two segments.

e Perpendicular lines intersect at a short dash.

® You can only control endpoints using the Move command (the Clip command is not available for
perpendicular axes).

¢ You cannot move an endpoint of a perpendicular axis beyond the axis center.
e When any axis is too short, it appears in a solid line font.

Using the drawing setup file option radial pattern axis circle, you can set the display mode for
axes of rotation that are perpendicular to the screen in radial pattern features. When you set the option to yes, a
circular shared axis appears, and the axis lines pass through the center of a rotational pattern (see Appendix A,
Drawing Setup File Options, for details). However, this only affects patterns that you create using the Dim
Pattern command. The following restrictions apply when you set this drawing setup file option to yes:

e You cannot move, clip, or modify the line style of a circular shared axis that appears once you choose the
Show command button from the Show/Erase dialog box (accessed by clicking View > Show and Erase on
the menu bar).

e You cannot use the Mod Attach command on axis lines or circles of patterned features.

e Ina clipped view, the system only displays portions of lines and circles that are inside a view boundary.
e You cannot use radial patterns of group features.

* You cannot show radial pattern axis circles for reference patterns.

To Modify the Line Style of a Model or Draft Axis

1. On the Pro/ENGINEER menu bar, click Format > Line Styles. The LINE STYLES and GET SELECT
menus open in the Menu Manager.

2. Select the axis name or the axis itself (for model axis features). The Line Style dialog box opens.

3. Inthe Line Style dialog box, select a line style from the Style list.
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4. Click Apply. The axis acquires the specified line style. To reset it to the old style, click Reset and Apply.
Note: When you set the drawing setup file option axis interior clipping to no, you can still
change the axis line style. However, this disables the automatic adjustment of a pattern.

To Modify Axis Length

To extend or shorten the axis lines, move or clip the lines. Moving the lines moves whichever end you select.
Clipping the lines moves the portion of the axis within the circle closer or farther from the origin.

To Move an Axis, when the Axis is parallel to the screen

In the drawing window, click on the axis to select it, and then pick on either endpoint (handle ) and drag the axis
to its new location.

To Extend or Clip Axis Lines when the Axis is Perpendicular (normal) to the Screen

o Click on the axis to select it. The crosshairs, endpoints (handles), and axis name highlight. Then do one of
the following:

— To clip or extend only a portion of the axis, select and drag a single handle (endpoint).
— To clip or extend all axis lines at same time, select and drag the axis name.

To Create a Break in a Model Axis Line

In the Graphics window, select the axis line in which you want to create the break.

2. On the Pro/ENGINEER menu bar, click Insert > Break. The BREAK menu opens in the Menu Manager.
Add is the default selection.

Select the first location on the axis line to begin the break.

4. Select the second location to finish the break. The system creates the break.

To Delete a Portion of a Normal-to-Screen Axis

Select an axis line, and then click Edit > Delete.

2. To resume the display of all portions of the axis, click View > Show and Erase The Show and Erase
dialog box opens.

Click Axis in the Type box.

4. Click Show All. The deleted axis lines are redisplayed and highlighted in a different color. If Preview is
selected in the dialog box, click Accept All. All axis lines are restored to the display.

Note: If you choose the normal-to-screen axis, the system erases all of the lines for that axis.

To Create an Axis Symmetry Line

Using the following procedure, you can create an extension between axis cross hairs showing that the axes are
symmetrical about a dimension.

—

et

—

hed

1. On the menu bar, click Insert > Symmetry Line Axis.

2. Select two axes that are perpendicular (normal) to the plane of the screen (shown as cross hairs). To extend
the symmetry line to either side, grab a handle of the axis with the mouse pointer and click anywhere
outside of the line.
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Example: Axis Symmetry Lines

. &0

1. Axis symmetry line.

About Rotating Axes

Using the Mod Attach option in the right mouse button shortcut menu, you can rotate model axes that are

normal to the screen. When you rotate the axis, it rotates according to another reference entity that you select,
such as an edge or point, as shown in the following diagram. The rotated axis remains normal (perpendicular) to
the screen; however, the cross reorients according to your specifications. To open the shortcut menu and access

the Mod Attach option, select and then right-click on the axis.

Rotating Axes

e

Hotate this axis using  Pick this

Parallel to this edge, ——
rotate this axis using !
the Parallel option. the Pick Point option.  paint.

The Rotate Axis menu displays the following options:

e Through Geom—Picks an edge, datum point, or center of an axis normal to the screen through which the

axis line that is closest to that point passes.

e Pick Point—Picks a point on the screen through which the axis line passes.

e Parallel—Picks a linear edge or datum curve to which the axis line is parallel.
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e Horizontal—Returns the axis to its standard orientation.

o Enter Angle—Specifies an angle for axis rotation about the X-axis.

To Rotate an Axis

1. Select the axis you want to rotate, and then right-click on the axis to display the shortcut menu.

2. Click Mod Attach in the shortcut menu.

3. Select another axis center or edge as a rotation reference to orient the selected axis, and then press ENTER.
The axis rotates in reference to the edge or second axis reference.

To Create a Draft Axis

1. On the Pro/ENGINEER menu bar, click Insert > Draft Axis.

2. Click the left mouse button to start drawing the axis.

3. Move the mouse pointer to extend the axis to the proper orientation (the axis line drags with the mouse).
Place the endpoint by clicking the left mouse button.

4. Type the name of the axis. The system displays the name.

5. To move or reorient the axis, you can move or clip it by selecting the axis and then clicking anywhere in the
drawing window, or choose Rotate or Translate from the DRAWING > TOOLS menu. You can also use
the right mouse button shortcut menu, as described in the topic About Using the Shortcut Menu.

About Using the Shortcut Menu

Using a shortcut menu or the Edit menu (menu bar), you can modify any object in a drawing from anywhere in
the menu tree. At any time when a drawing window is active, you can interrupt your current process and
activate a drawing object for modification. When you finish making modifications, the system returns you to
your original location in the menu tree.

Manipulating Snap Lines

Using the shortcut menu, you can modify and manipulate snap lines in the following ways:

e Change the spacing.

e Change the attachment.
e Delete snap line ends.
e Move snap line ends.

Modifying Items Using the Shortcut Menu

When using the right mouse button shortcut menu or the Edit menu (menu bar) to modify a detail item, keep in
mind the following:

e [fyou move a note in a table by choosing Move from the Edit menu or Move/Activate from the shortcut
menu, the system moves the table.
¢ You cannot modify unset 3-D datums.

e When you are removing dimensions, the same restrictions apply to the Delete commands in the Edit menu.
For example, you cannot delete dimensions that belong to features.

Using the Box Handles

As in Sketcher mode, you can use the box handles to manipulate entities in a variety of ways, including the
following:

e Rubberband the radius of a draft circle by selecting one of the handles.

e Drag the endpoint of a line by using one of the handles.

e Select a handle on the minor or major axis of an ellipse and then rotate and resize the centerpoint while
leaving the other axis fixed.
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e Move the text of a dimension that does not have an elbow.
e Move one endpoint of an arc, while leaving the other one fixed.

To Modify an Iltem Using the Shortcut Menu

1. Select an item in the drawing window. The item is highlighted and handles appear to emphasize the portions
of the item that you can move. The pointer changes as you move over the handles. Then, press the right
mouse button. A shortcut menu appears with options for modifying the selected item. The options on the
shortcut menu vary depending on the item you have selected. For example, if you select a witness line, the
shortcut menu displays the options Erase Wit Line and Default Wit Line, among other appropriate
options.

Note: You may need to press the right mouse button for about one-half of a second before the pop-up menu
appears.

Note: At any time during this process, you can also use the right mouse button to display the pop-up menu
again and choose a command from that menu.

2. Edit the selected item as necessary or appropriate. To deactivate the selected object, click anywhere in the
drawing window or select another object. With some actions, such as exploding a symbol, the system
deactivates the active item automatically because the object no longer exists in the same form.

About the Major View Types

You access the VIEW TYPE menu by choosing DRAWING > Views > Add View on the Menu Manager.
Using the VIEW TYPE menu, you can specify eight major view types, as well as how much of the model to
show in a view, whether the view is of a single surface or has cross sections, and how the view is scaled.

o A general view is a view that is independent from other views in the drawing, and shown in the default
orientation specified in the Pro/ENGINEER environment.

o A detailed view is a portion of a model shown in another view. Its orientation is the same as the view from
which it is created, but its scale may be different so that you can better visualize the portion of the model
that you are creating. The display of edges in a detailed view follows that of the view from which it is
created (its parent view).

e A projection view is an orthographic projection of another view’s geometry along a horizontal or vertical
direction. You can specify the projection type in the drawing setup file by basing it on third angle (default)
or first angle rules.

e An auxiliary view is a projection of the geometry of another view at right angles to a selected surface or
along an axis. The selected surface in the parent view must be perpendicular to the plane of the screen.

e A revolved view is a planar area cross section from an existing view, revolved 90 degrees around the cutting
plane projection, and offset along its length. It can be full, partial, exploded, or unexploded.
Note: Detailed, projection, auxiliary, and revolved views have the same representation and explosion
offsets, if any, as their parent views. You can simplify, restore, and modify the explosion distance of each
view without affecting the parent view. However, detailed views always appear with the same explosion
distances and geometry as their parent views.

o A graph view shows the sketch of a graph feature and its dimensions. The system updates any changes
parametrically.

e An of flat ply view is a flat single-ply view of a composite model. It can exist in a regular drawing or in
sequence drawings.

® A copy & align view is an aligned partial view based on a specified view boundary and an alignment
relative to the existing partial view.
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To Create a Drawing View Using Saved Part and
Assembly Views

In Drawing mode, you can recall views saved as named view orientations in Part and Assembly modes and use
them to create a drawing view.

1. Choose DRAWING > Views > Add View on the Menu Manager.
Add a general view. When you place the view on the screen, the Orientation dialog box opens.
Note: The recalled view uses the default view as a starting point for its orientation. If you have selected a
different default view type in the Environment dialog box since the view was created, it does not look the
same. If this occurs, change the default view. Select a name from the Saved Views list in the Orientation
dialog box when reorienting the general view.

3. Select the name of the saved view from the list, and then click Set. The view being created assumes the
orientation of the saved view. Its scale, however, does not change.

4. Click OK to close the Orientation dialog box.

General Views

The first view that you add to a drawing is a general view. You add other general views in the same way that
you add the first one. The system places them on the screen in the default orientation. If you reorient a general
view that has dependent views in the drawing, the system reorients those views as well. You can move general
views anywhere on the drawing and scale them, if necessary.

Changing the Default Orientation

A model appears on the screen in its default orientation if you set the configuration file option

disp trimetric dwg mode view to yes. If you set it to no, a model does not appear until you choose
Default from the Orientation dialog box. However, when you create a drawing view using the default
orientation, if you change the setting of this configuration file option, the system does not change the
orientation. Once you set a view in the default orientation, the system freezes it.

For example, if you place a general view with default orientation and select Trimetric from the Default Orient
list in the Environment dialog box, the system does not reorient the view if you select Isometric or retrieve the
drawing in an isometric environment. To reorient the view, choose Views > Modify View > Reorient from the
DRAWING menu (Menu Manager). Select a general view to reorient, and then, in the Saved Views section of
the Orientation dialog box, select Default.

When changing the default orientation of a drawing view, keep in mind the following:

e Ifyou delete or suppress geometry that the system is using to orient a view, it changes that view and all of
its children to the default orientation. You cannot recover the original view orientation if the geometry was
deleted. Resuming the suppressed feature, however, restores the original orientation of the view.

o The system freezes the orientation of default views in any pre-Release 18.0 drawings after you save them in
Release 18.0.

e Before placing a cross section defined as planar in the view, you must orient the view so that the plane of
the section is parallel to the plane of the screen. If the cross section is revolved, the plane of the section must
be perpendicular to the screen.

196 Pro/DETAIL



J o

O O

1 A general view with scale factor.

To Add a General View

The procedure for adding a general view to a drawing differs slightly depending on whether an active model is
open in the background.

If the Model is Active:

1. On the DRAWING menu, choose Views > Add View.

2. From the VIEW TYPE menu, select the type of view you want (the default is general), and then click Done.

3. Place the view onto the drawing sheet by clicking a location on the sheet. The active model displays in 3-D
orientation, in isometric view. The Orientation dialog box opens and prompts you to orient the model.

4. Select orientation references. The model reorients automatically. Then, click OK.

If the Model is Not Active

1. Choose Views > Add View. The system prompts you to select a model and opens the Open dialog box.
2. Select a model in which to place the view, and then click Open. Once the model is open, you can follow
steps 2 through 4 in the preceding procedure.

To Reorient a View

You can reorient a view, including changing the view angle, by using the following procedure.

1. Choose DRAWING > Views > Modify View > Reorient, and then select the view. The Orientation dialog
box opens.

2. Ifthe view has any dependent (child) views, the system highlights them and warns you that it is going to
reorient them also. Type [Y] to continue.

3. Using the Orientation dialog box, follow the standard procedure to specify the view orientation.

Detailed Views

A detailed view displays a portion of the model shown in another view. To create one, you define a spline
boundary around the portion of an existing view that you want to show in detail. As shown in the following
figure, the system displays the view name and scale value below it, circles the portion of the parent view that is
detailed, and attaches a note identifying the detailed view.

The display of a detailed view follows that of the view from which you created it. For example, if the parent
view displays hidden lines in the area that is detailed, the detailed view (which is simply a portion of its parent)
also displays those hidden lines. Also, if you erase a feature from the parent view, the system also erases it from
the detailed view. Because of this dependency, you can modify such characteristics as cross-hatching and
hidden line display in a detailed view only if you modify the parent view as well. However, you can make a
detailed view independent of its parent.
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To Add a Detailed View
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On the DRAWING menu, choose Views > Add View. The VIEW TYPE menu appears.

Choose Detailed and other available commands from the VIEW TYPE menu.

Choose Done to accept the commands, or Quit to quit the creation of a new view.

Select the location of the new view on the drawing.

Type the scale value for the view.

Select a point on an edge in an existing view. The selected geometry is highlighted and a red cross appears,
representing the reference point on the geometry to be in the detailed view. The system needs this reference
point to properly regenerate the detailed view.

Enclose all of the geometry that you want to show in the detailed view. Sketch a spline around the red cross
without intersecting other splines to define an outline. Press the middle mouse button when you are done.
Type a name for the detailed view (the system prefixes the name with the word "DETAIL"). Press ENTER.
From the BOUNDARY TYPE menu, choose Circle, Ellipse, H/V Ellipse, Spline, or ASME 94 Circ. Sketch
a spline on the parent view that reflects the selected boundary type, and then press the middle mouse button
to close the boundary. If the spline boundary does not enclose the red cross, you must resketch the
boundary. The sketched spline and the new detail view display.

If you selected Circle, Ellipse, H/V Ellipse, or Spline as the boundary type, select the location for the detail
note that is attached to the parent view.

If you selected Ellipse, H/V Ellipse, or Spline as the detailed view circle type, select the leader attachment
point for the detailed view note. The system displays the view with its name and scale below it. A circle
appears around the parent view approximating the size of the sketched boundary.

Make the following modifications, as necessary:

— Modify the size of the sketched boundary.

— To change the scale for the view, choose Modify View from the VIEW menu, then choose Change
Scale from the VIEW MODIFY menu. Select the detail view, and then type a new scale and press
ENTER. Erase the scale name using the Show/Erase dialog box (click View > Show and Erase on the
menu bar).

— Edit the name of the detailed view by choosing Modify View on the VIEW menu, then View Name on
the VIEW MODIFY menu. Select the detail view as the view you want to rename, and then type the
new name (the view name can contain up to 80 characters).

— Change the display of the circle, leader, and note by modifying the setting of these drawing setup file
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options:
e detail circle_line_style
e detail circle view note
e detail view circle
e view note
— Make the display of the detailed view independent of its parent view by choosing Disp Mode from the
VIEWS menu, then choose View Disp > Det Indep. To reset the dependency, choose From Parent.
— Use the Move command in the Edit menu (on the menu bar) to move the detailed view name along the
ASME 94 circle.
— Erase the detailed view note using the Show/Erase dialog box (View > Show and Erase on the menu
bar).
Note: When you create a detailed view of a part containing an axis that lies off the part (that is, model
geometry does not enclose it), the axis does not appear in the detailed view.

Projection Views

Pro/ENGINEER automatically creates projection views by looking to the left, right, above, and below the
selected view location to determine the orientation. The arrows in the next figure show the direction the system
looks to create projection views. When it finds conflicting view orientations, you must select a view to be the
parent view. It then constructs a view from the selected view. If the system cannot find another view within its
line of sight, you must select again at another location to place the projection.

A projection view acquires the scale of its parent view.

Examples: Adding Projected Views

1 Yo

1 Arrows added for partial projection view: TOP_1".
2 VIEW TOP 1".

To Add a Projection View

On the DRAWING menu, choose Views > Add View. The VIEW TYPE menu opens.
Choose Projection (default selection) and other available commands from the VIEW TYPE menu.
Choose Done to accept the commands, or Quit to quit the creation of a new view.
Select the location for the new view on the drawing. The system displays the projection view.
Make the following modifications, as necessary.
— Show or delete arrows that point back to the view from which you created the projection by choosing

DR

Pro/DETAIL 199



Modify View from the VIEW menu, and then choosing Add Arrows or Del Arrows from the VIEW
MODIFY menu.
— Automatically add view names to projection views in the format "VIEW viewname-viewname" by
setting the configuration file option make proj view notes to yes.
6. Change the view name or projection view arrow name by choosing VIEWS > Modify View > View Name.
Then select the projection view and type a new view name.

Auxiliary Views

Auxiliary views discern the true size and shape of a planar surface on a part. The system makes a projection of
the model perpendicular to a selected edge. You can create an auxiliary view from any other type of view.

To Add an Auxiliary View

1. Choose VIEWS > Add View > Auxiliary and other available commands from the VIEW TYPE menu.

2. Choose Done to accept the commands, or Quit to quit the creation of a new view.

3. Select the location of the new view on the drawing.

4. Select an edge of, or axis through, the surface of the model in the view from which to create the auxiliary
view. If the selected edge is from a view that has a trimetric or similar orientation, the system reorients the
new view as it did the base feature section. Otherwise, it orients it with the selected surface parallel to the
plane of the drawing.

Note: After you create an auxiliary view, you can simplify or restore it without affecting its parent view.

5. Choose Modify View from the VIEWS menu, and then choose Add Arrows or Del Arrows from the VIEW

MODIFY menu to show or delete arrows that point back to the view from which you created the projection.

Example: Auxiliary View

O|0

P

1,7

1  Select an edge of a surface that is perpendicular to the screen.
2 Placement pick.

Revolved Views

Revolved area cross-sectional views can be either full or partial views. Pro/ENGINEER creates a revolved area
cross-sectional view from the parent view in which the cutting plane for the section is normal to the screen. It
revolves the section 90 degrees around the cutting plane projection and offsets it along its length.
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When you create this type of view, the system automatically creates a line of symmetry as well; however, this
centerline is not an axis. You can move revolved views parallel to the cutting plane in the parent view, and their
centering about the line of the cutting plane always remains the same. You can also modify the line of
symmetry in various ways.

To Add a Revolved Cross-Sectional View

1. Choose Views > Add View > Revolved > Section > Done. The XSEC TYPE menu does not appear; the
system creates the cross section automatically as an area cross section.

2. Select the location for the view, approximately along the cutting plane projection in the parent view; then
select the parent view.

3. Choose the cross-section name from the menu. The revolved cross-sectional view appears in the default
location, with all of the datum planes and axes temporarily shown. Pro/ENGINEER names it using the
convention revolved <view ids.

4. Modify the centerline of symmetry, as necessary:

Replace the butting plane extension as the centerline of symmetry by selecting a datum plane or axis in
the revolved view that is parallel to the cutting plane projection in the parent view. The system centers
the revolved view so that the selected plane (or axis) is co-linear with the cutting plane in the parent
view. If you press the middle mouse button instead, the cutting plane passes through the center of the
revolved view.

Erase and resume the centerline by clicking View > Modify View and then clicking Del Arrows or
Add Arrows in the VIEW MODIFY menu.

Clip the centerline by choosing Edit > Move on the menu bar. Select an endpoint of the centerline and
the new location; then press the middle mouse button.

If you select a real axis (one that is normal to the screen) to center the view, display the axis by clicking
Axis in the Type box of the Show/Erase dialog box (click View > Show and Erase on the menu bar).

Example: Revolved Cross-Sectional View

1 The cutting plane.
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2 Revolved cross sectional view.
3 The parent view.

Graph Views

Using the Graph command in the VIEW TYPES menu, you can show views of graph features in a drawing. You
would typically use a regular graph feature in a relation to control a variable section sweep for creating
geometry. The graph is an actual datum feature that you would sketch in Sketcher mode using the Datum and
Graph commands. The system shows the sketch of a graph feature and its dimensions in a drawing view and
updates any changes parametrically. If there are no graph features for the current drawing model, the Graph
command is not available in the VIEW TYPE menu.

A typical example of a part that uses a graph feature is a cam. A cam designer might want to show the cam
profile to illustrate the linear motion of a cam follower as the cam rotates. The following figure shows a cam
part and its corresponding profile represented by a graph feature that drives a variable section sweep. The
system uses the variable section sweep to make the surface around the part; in other words, the graph feature
(cam profile) controls the radius of the cam.
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To Add a Graph View

1. Choose DRAWING > Views > Add View > Graph.
Note: If there are no graph features for the current drawing model, the Graph command is not available in
the VIEW TYPE menu.

2. Choose No Scale or Scaled and type a value. For scaled graph views, the scale label appears on the drawing
below the view name.

3. Select a centerpoint for the drawing view.

4. From the GRAPHS menu, select a graph to show in the view. The system places the view, displaying the
graph feature name below the bottom view boundary outline.
Note: Since the graph feature is only two-dimensional, you do not need to orient it.
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5. Make the following modifications, if necessary:

— Change the view scale by selecting the value on the screen or choosing MODIFY VIEW > Change
Scale.

— Redefine the view type (from No Scale to Scaled or vice versa) by choosing VIEWS > Modify View >
View Type.

— Show the dimensions of the graph feature in the view by using the Show/Erase dialog box.
— Show or erase the graph feature view name by using the Show/Erase dialog box.

Aligned Partial Views

Once you have a partial view in the drawing, you can create an aligned partial view by specifying the view
boundary and indicating the direction of alignment relative to the existing partial view. You can also align an
aligned partial view to a detailed view. You can align a partial view to another partial view in a drawing along
the selected straight entity (such as an axis, edge, datum curve, or cable segment). This enables you to create
multiple partial views that selectively show model geometry in the same view orientation, as well as maintain
relative placement between these partial views.

The initial partial view—the parent view—determines various properties of successive aligned partial views,
such as the following:

e The aligned view uses the same view attributes (for example, attributes specifying whether the view is
scaled or exploded) as its parent view.

e You cannot change the scale of the aligned partial view independently, but it does change when you modify
the scale of the parent partial view.

* You cannot reorient aligned partial views using the Reorient command directly (DRAWING > Views >
Modify View > Reorient), since they are dependent views. However, if you reorient the parent view, the
system realigns aligned partial views.

Because the aligned partial view is a dependent view, its location depends on its parent (the view to which it

was aligned). Therefore, whenever you move the parent view, the location of the aligned view also adjusts. You

can move the aligned view only in the direction of alignment, closer or farther away from the parent. If you
erase the parent view or move it to another sheet, you can move the aligned view without restrictions until you
resume the parent view or switch it back.

Note: An aligned partial view that you create using the Copy & Align command has its own local cross
sections. That is, when you create it, it does not have the local cross sections of its parent view. You can
add them and remove them later.

To Add an Aligned Partial View

Choose DRAWING > Views > Add View > Copy & Align, accept the defaults, and choose Done.

Select the center point for the view.

Select an existing partial view to which you are aligning the current view.

The aligned view temporarily appears in full. Select a reference point to define the center of the partial view.
Sketch a spline to define the boundary of the partial view.

On the current partial view, select a straight entity: edge, axis, datum curve, or cable segment. The current
partial view aligns with the existing partial view along the selected entity.

7. Use Ref Point, Boundary, Add Arrows, Del Arrows, and Snapshot in the VIEW MODIFY (DRAWING >
Views > Modify View)menu to modify the view as you would a regular projection view. You can modify
the display of an aligned partial view for each partial view individually, regardless of the parent-child
relationship that may exist between the views. If it does not have any dependent views, you can delete it.
Note: The Origin and Perspective commands in the VIEW MODIFY menu, and the Add Breakout and Del
Breakout commands in the VIEW BNDRY menu (Views > Modify View > Boundary) are not available for
aligned partial views.

S
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Example: Aligned Partial View

1 Parent view.
2 Aligned partial view.
3 Use these segments to establish the direction of alignment.

About Modifying Views

Using commands in the VIEW MODIFY menu, you can perform the following procedures:

e Rename a view

e Change the scale of a view

e Redefine views by changing the view type

e Change the process state of a process assembly view
e Reset the view origin

e Change the view alignment

e Change or resketch view boundaries

e Change the explosion distances of exploded views

e Exclude all graphics behind a specified plane using Z-Clipping
e Modify, remove, or replace view cross sections

e Change crosshatch

In addition, using the Disp Mode command in the VIEWS menu, you can modify the display mode in various
ways.

To Rename a View

Using the View Name command in the VIEW MODIFY menu, you can change the name of a view in session.

1. Choose VIEWS > Modify View > View Name.
2. Select the view to rename.
3. Enter the new name.

View Type Change Restrictions

Using the View Type command in the VIEW MODIFY menu, you can redefine drawing views in the following
ways:

e Change the orientation type among these view types:
—  Projected, auxiliary, and general
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—  Full, half, and partial
e Change the orientation type between these view types:
— Total cross section and area cross section
—  Scale and no scale
— Exploded and unexploded
When redefining a view, the following restrictions apply:

* You cannot redefine views that are defined as Of Flat Ply, or Copy & Align.
® You cannot redefine a projection view to a broken view.

e You cannot change the following view types to a view of the same type, showing a different portion of the
model:

—  Broken view
— Perspective view
—  Of Surface view
— Revolved view (the only possible change for a revolved view is from partial to full, or from exploded
to unexploded)
— View with a total unfolded cross section
— View with an unfolded area cross section
— Aligned view
Note: You cannot modify the view type of the first, or general, view.

To Change the View Type

Note: You cannot modify the view type of the first, or general, view.

1. Choose VIEW MODIFY > View Type.

2. Select a drawing view to redefine.

3. Choose commands from the VIEW TYPE menu. (If the view is to be cross-sectional, the XSEC TYPE menu
appears with all current commands highlighted. You can then change between commands in the top half of
the menu, and among Area Xsec, Total Align, and Total Xsec.)

4. After you make all modifications to the view, the system redraws the view. If you modify the view to
projected or auxiliary, and it was a general view previously, the system highlights all views that the change
could affect, and you must specify if you still want to reorient the view. If you choose not to reorient it, it
remains general.

When defining or redefining a projected or auxiliary view, keep in mind the following:
— For a projected view, you must select its parent view. For an auxiliary view, you must select a face or
axis as a reference, as in view creation.

—  When you convert a projected or auxiliary view to general, you do not have to reorient the view.
Instead, the system copies the orientation information from the parent view.

About Changing the View State

Using the View State command in the VIEW MODIFY menu, you can modify views of assembly drawings, as
well as Pro/PROCESS for ASSEMBLIES or Pro/PROCESS for MANUFACTURING drawing views, in the
following ways:

e Change the process state

e Modify the simplified representation

e Replace the simplified representation

You can also use the View State command to change the simplified representation of the model of a drawing
view.
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Note: The View State command is available only if you are working with a process state view or models of
simplified representations.

To Change the View State

You can use this procedure to change the view state, or to change the state of the model on an existing view.

1. Click DRAWING > Views > Modify View > View State.

2. Select the view whose state you want to change. The Process State dialog box or the Open Rep dialog box
opens containing a list of the available modification options.

3. Set the desired options for changing the view state or the model state on an existing view. Click OK when
you are done.

Resetting the Origin

By default, the origin of a drawing view is in the center of its outline. Using the Origin command in the VIEW
MODIFY menu (DRAWING > Views > Modify View > Origin), you can reset the origin of a drawing view by
parametrically referencing model geometry. This attaches the selected geometry to its current location on the
drawing and prevents it from shifting whenever the model geometry changes.

You can reset the origin of general, auxiliary, and broken views any time after you create them, but it does not
change the current position of the view. The effect of the new origin is noticeable only when the system updates
the views to reflect changes in model geometry. However, if you reset the origin of a perspective view, it alters
the current position of the view because the view origin is part of the orientation.

Note: You cannot change the view origins of total unfolded cross-sectional views.
To select the point for the origin, you can choose a model edge, datum curve, datum point, coordinate system,
or cosmetic feature entity. However, when selecting a point, keep in mind the following:

e For a general view, the selected point becomes fixed.

e For a projection and auxiliary view, the system passes the selected point onto a ray passing through the
origin of the parent view in the direction of projection. This projected point becomes the origin of the view.

e To select a coordinate system as the origin of a newly created view or of a modified view, specify its name
as the value for the configuration file option "drawing_view_origin_csys." If you do not want the system to
use a coordinate system that you set previously, specify the value as "no."

To Reset the Origin of a View

1. On the DRAWING menu, choose Views > Modify View > Origin > On Item.

2. Select a view.

3. Select a point to indicate the origin of the view. Use commands in the GET SELECT menu, if necessary.
Note: If the geometry referenced in a view is suppressed or deleted, the system warns you that model
geometry is missing. For views oriented with the suppressed or deleted reference, the view returns to its
default orientation.

4. After setting the origin of the view, you can proceed to set the origin of another view, or choose

Done/Return on the VIEWS menu.

Tip: Resetting the Origin of Broken Views

You can set the origin of a broken view at any time in any one of the members using the same method that you
would use to set the origin of a general, projection, or auxiliary view. The new set origin is the origin for all of
the members. You can unset it at any time by choosing At Center from the VIEW ORIGIN menu (DRAWING >
Views > Modify View > Origin > At Center). If a broken view does not have an origin, the default view
center is at the center of the 3-D model in the first broken view.
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To Align a View

1. Click DRAWING > Views > Modify View > Alignment > Align View.
Select the view that you want to align.
3. Select the view to which you want to align the highlighted view. You can align the view either vertically or
horizontally.
4. After you select the view to align to, the first selected view snaps to its new location and is now aligned
with the second view.
Note: The view will remain aligned and move like a projection view until it is unaligned.

To Unalign a View

1. Click DRAWING > Views > Modify View > Alignment > Unalign View.
2. Select the view to unalign.
3. Click Done Sel or the middle mouse button. The view is no longer aligned with any other view.

To Modify the Alignment of a View

1. Click DRAWING > Views > Modify View > Alignment > Modify Align.
2. Select a view to modify. Click Confirm.
3. Click Parent or Child to determine an alignment base point on the parent or child.
—  Click Origin to make the alignment base point the view origin.
—  Click Selection to select a point in the view to be the alignment base point.
4. The child view snaps to its new location, using the new alignment base point.
Note: When the selected view is a parent/child to other views, all of the related views highlight in blue and
may also move when you modify the alignment.

Changing the Boundaries

You can modify the outer borders of detailed, partial, and broken views by moving their reference points. You
can also resketch the view boundaries.

To Modify a Reference Point

1. Choose DRAWING > Views > Modify View > Ref Point.
2. Select a view to modify.
3. The system highlights the reference point in red. Select a new location for it:
— For a detailed view, select the parent view.
— For a partial view, select the view inside the breakout boundary. If you want to choose a point outside
the view boundary, modify the breakout first.

— For a broken view, reselect the reference point for each side of the view.

To Resketch a Boundary of a Detailed View

1. Choose DRAWING > Views > Modify View > Boundary. The VIEW BNDRY menu opens.
2. Select a detailed view.
3. Choose VIEW BNDRY > Mod Breakout.

To Erase or Show the Outer Boundary

1. Choose DRAWING > Views > Modify View > Boundary.
2. Select a detailed or partial view.
3. Choose Erase Outer or Show Quter; then choose
VIEW BNDRY > Done. The system updates the view.
Note: You cannot display or erase the border of a detailed or partial local cross-sectional view.
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About Excluding Graphics Behind a Specified Plane

If you have a license for Pro/DETAIL, you can specify a plane parallel to the screen and exclude all graphics
behind it by performing Z-Clipping.

When you perform Z-Clipping in a view, keep in mind the following:

e [fthe system cannot regenerate the reference for the clipping plane, Z-Clipping does not take effect for the
view (an error message appears).

e The Z-Clipping of a detailed view is always the same as that of its parent. You cannot modify it
individually.

To Exclude Model Graphics Behind a Specified

Plane

1. Choose DRAWING > Views > Modify View > Z-Clipping.

2. Select a view to modify. The Z-CLIPPING menu opens.

Note: You cannot perform Z-Clipping in the following types of views: unfolded cross-sectional, area cross-

sectional, exploded, and perspective.

Choose Z-CLIPPING > Add/Change.

4. For the reference point, select an edge, surface, or datum plane that is parallel to the view. You can place it
on any view. The reference point appears in magenta in the selected view and in any of its projected or
auxiliary views (if the selected view is a projected or auxiliary view, the reference point appears in magenta
in its general view).

All geometry behind the defined Z-Clipping does not appear, but any geometry that the plane contains
entirely does appear. The system clips geometry that intersects the plane. Only the portion in front of the
plane appears.

W
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Example: Excluding Graphics Behind a Specified

Plane

@

O

1 Select this surface as the reference point.

2 Select this view.

3 The geometry intersecting the plane is clipped.
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About Specifying the View Scale

As you create a view, you can specify an independent scale or a predefined scale value. To create the view with
an independent scale value shown under the view, choose Scale from the VIEW TYPE menu (DRAWING >
Views > Scale). To create a scaled view with the default scale shown in the lower-left corner of the screen, use
the No Scale command. By setting the configuration file option default draw_ scale, you can control the
initial setting of the default scale; otherwise, the system bases it on the size of the model.

Modifying the Scale

A newly created view takes on the value of the drawing scale, unless you specify a different scale value. You
can change the scale of any existing view. A modified view scale changes independently of the drawing scale. If
you change the drawing scale, only those scales for views whose scales have not been modified and are
therefore equal to the drawing view remain dependent on the drawing scale. To show or erase the view scale
note, use the Show/Erase dialog box (click View > Show and Erase on the menu bar).

Drawing Scale

The drawing scale value, displayed in the lower-left corner of the drawing sheet, represents the drawing-to-
model scaling. For example, for a value of 0.25, Pro/ENGINEER scales the drawing views at one-quarter (1/4)
of the actual model size.

When creating a new view on a drawing sheet, if you do not enter a value for the view scale, the scale takes on
the value of the drawing scale. You can scale a view (change the scale of an existing view). The drawing view
scale does not change with changes in individual view scale. In other words, the drawing scale parameter shown
at the bottom left corner of the main window controls the scale for all views except detailed and scaled views.

To Modify the Drawing Scale

1. On the menu bar, click Edit > Value.

2. At the lower-left corner of the drawing window, select the label or value for the Scale (drawing scale).
3. At the prompt, enter a new drawing scale value.

All views of the active drawing model (except for detailed and scaled views) change in size corresponding to
the new drawing scale value.

View Scale

Using the Change Scale command in the VIEW MODIFY menu (DRAWING > Views > Modify View > View
Scale), you can modify the scale of a view. However, if the parent view of a projection view is a scaled view,
you cannot use this command to modify the scale of the projection view.

To Change the Scale of a View

You can change the scale value for a scaled view using object-action or action-object orientation.

Method 1

1. Select a scaled view.
2. Press the right mouse button and select Change Scale in the shortcut menu.
3. Type the new scale value. The system modifies the view scale and redisplays the view.

Method 2

1. Click DRAWING > Views > Modify View > Change Scale.
2. Select the view whose scale you want to modify, and then type the new scale value.
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About Modifying Cross Sections

Using commands in the VIEW MODIFY menu (DRAWING > Views > Modify View), you can modify cross
sections in the following ways:

e Change the reference points of a local cross section in a general or projection view
e Change the boundary of a local cross section in a general or projection view

e Create a full cross-sectional view when deleting a breakout

e Modify a partial view with a local cross section

e Modify a broken view with a local cross section

e Remove or replace a cross section

o Flip a full total cross-sectional view

Using additional commands, you can also display set datum planes in area cross-sectional views and move
cross-section arrows or cross-section text. To redefine the side and direction of offset cross sections, you can
use the XSEC MODIFY menu.

To Modify the Reference Points of a Local Cross

Section

1. Choose DRAWING > Views > Modify View > Ref Point.

2. Select a general or projection view. The system highlights boundaries and reference points of the local
cross sections.

3. Select a reference point and move it.

4. You can continue to modify other local areas. When you have finished, choose EXIT > Done.

To Modify Boundaries of a Local Cross Section

1. Choose DRAWING > Views > Modify View > Boundary.
Select a general or projection view. The system highlights boundaries and reference points of the local
cross sections.

3. Choose Breakout from the BROKEN VIEW menu, and then choose Mod Breakout from the VIEW
BNDARY menu.

4. Select a boundary and resketch it.

5. When you have finished, choose VIEW BNDRY > Done.

To Create a Full Cross-Sectional View When

Deleting a Breakout

1. Choose DRAWING > Views > Modify View > Boundary > Del Breakout.
Select a breakout. If it is the last breakout, specify whether you want it to be a full cross-sectional view.
3. Ifyou type [yes], the system creates a full cross-sectional view. When you have finished, choose VIEW
BNDRY > Done.

To Modify a Partial View with Local Cross Sections

1. Choose DRAWING > Views > Modify View > Boundary.
. Select a partial view.
3. Using commands in the VIEW BNDRY menu, do one or all of the following:
— Resketch a spline boundary of a local cross section by choosing Mod Breakout.

— Relocate a reference point for a local cross section by choosing Move Ref Pnt.
— Add a new local cross section by choosing Add Breakout.
— Delete a local cross section by choosing Del Breakout.
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4.

When you have finished, choose VIEW BNDRY > Done.

To Modify Reference Points of a Broken View

1.

a

7.
8.

Choose DRAWING > Views > Modify View > Ref Point, and select a broken view.
Do one of the following:
— To modify the reference points of local cross sections, go to Step 5.

— To modify the reference points of outer boundaries of the broken view, choose MOD REF POINT >
View Break. The system displays the current reference points.

Select a reference point that you want to redefine and specify a new location. Do the same for any other
reference points that you want to modify.

After you have specified the new locations, choose GET SELECT > Done and EXIT > Done. The system
updates the view.

To modify the reference points of local cross sections on the broken view, choose MOD REF POINT >
Breakout.
Note: Half views cannot have breakouts. If you choose Half and the view has breakouts, the system
removes them if you choose Done.

Type [Y] to temporarily display the broken view in full. The current reference points appear.

Select a reference point and select its new location.

After modifying the view, choose EXIT > Done.

To Modify a Boundary or Local Cross Sections of a
Broken View

1.
2.

hed

0 N oLk

Choose DRAWING > Views > Modify View > Boundary.

Select a view to modify.

To modify local cross sections, go fo Step 6. To modify the outer boundaries, choose BROKEN VIEW >
View Break.

Select lines that share the same splines; then choose Done Sel.

Resketch the spline; then choose EXIT > Done.

To modify local cross sections on the broken view, choose BROKEN VIEW > Breakout.

Type [Y] to temporarily display the broken view in full.

Choose VIEW BNDRY > Mod Breakout and select a boundary. Resketch it; then choose Done.

To Remove or Replace a View Cross Section

1.

3.

212

Choose DRAWING > Views > Modify View > X-Section.

Select the drawing view that contains the cross section to remove or replace.

Select a cross-sectional portion of the view, as you would to modify crosshatch (if the view is a cross-

sectional view with breakouts, selecting in a breakout selects its cross sections; selecting in the view, but

outside any breakout, selects the outer cross section).

Choose a command from the XSEC ENTER menu:
If you choose Create to make a new cross section, you must select a view in which to display arrows if
they are not already shown. If the same cross section reappears in multiple breakouts, the new cross
section replaces the old one in all of its breakouts. (You cannot reassign only some of the breakouts
from one cross section to another. To do so, use Boundary and delete or recreate the breakouts.)

— Ifyou choose Retrieve and then retrieve the same cross section, but it is a planar cross section, the
system resets the viewing direction of the cross section.

— If you choose Retrieve and then retrieve an offset cross section, choose Flip or Okay.

— Ifyou choose None, the system strips the selected cross section and all of its breakouts from the view
and its detailed children.
The system updates the view, and all details reappear.
Note: When the system regenerates a cross section in a drawing, and you add or remove model geometry, it
creates new edges in the drawing that you can reference. Because these edges are permanent additions to the
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system, the model changes when those edges are first created. The model owns the cross section.

Flipping a Full Total Cross Section

Using the Flip command in the MOD VW XSEC menu (DRAWING > Views > Modify View > X-Section),
you can flip a full total cross-sectional view to retain the opposite half of the cut part. This command is modal—
if you want to flip another full total cross section, you can immediately select another view. To replace the cross
section with another, choose Replace from the MOD VW XSEC menu. The Flip command switches—between
one side of the model and the other—the portion of the model removed by the cross-sectional cut. The cross-
section arrows that appear on a perpendicular view flip their orientation to reflect this change. They flip because
cross-section arrows always point toward the portion of the model that remains after using the cross section to
remove material from a model view.

Note: Using the Flip command does not reorient the model in the view. It flips only the cross section. You
should choose Reorient from the VIEW MODIFY menu to create a new view orientation for the cross-sectional
view.

To Delete a Cross Section from a Model

Using the Delete command in the MOD VW XSEC menu, you can delete a cross section from a model without
having to retrieve the model.

1. Choose DRAWING > Views > Modify View > X-Section > Delete.
2. From the DRAW MODELS menu select the name of the model from which to delete a cross section.
3. From the XSEC NAMES menu select the name of the cross section to delete. The cross section is removed
from the model.
Notes:
—  You cannot delete a cross section when it is being used by a drawing in session.

— Deleting a cross section in the drawing also deletes it in other drawings.

To Rename a Cross Section in Drawing Mode

Using the Rename command in the MOD VW XSEC menu, you can rename a cross section currently in use in a
drawing without having to enter Part or Assembly mode to retrieve a model.

1. Choose DRAWING > Views > Modify View > X-Section > Rename.

2. Select a view that contains the cross section to rename and enter the new name.
The system updates the name of the cross section in the current drawing, in the model that contains the cross
section, and in any drawing that already was using the cross section.

To Display Cross Section Datum Planes

Using the Show/Erase dialog box (View > Show and Erase on the menu bar), you can display set datum
planes in area cross-sectional views. Set datums that you display this way behave identically to those in other
views; you can perform all usual detail actions on them, including dimensioning.

Moving Cross-Section Arrows and Text

If you have a Pro/DETAIL license, you can move cross-section arrows or cross-section text. When you select a
cross-section arrow, you can move it independently of the other cross-section arrowhead. To move the arrows
simultaneously, select the arrow line. To change the cross-section text, change the name of the cross section in
either Part or Assembly mode.

For more information about moving items in Drawing mode, refer to the topic To Move or Clip Items in
Drawing Mode.
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To Move Cross-Section Arrows or Text

1. Do one of the following:
—  Select text to move independently of the arrows
— Select an arrowhead to move the arrow and text together, independently of the other cross-section
arrowhead
—  Select an arrow line to move the arrows simultaneously
2. Click to place the arrow in the new location.

To Modify Cross-Section Text

On the menu bar, click Format > Text Style.

Select any of the cross section names.

In the Text Style dialog box, clear the Default check box for Height, and type a new value.

Clear the Use Default check for Width Factor, and type a new value.

Click Apply. The height and width of the selected item changes.

To reset the text to the old style, click Reset Settings, and then click Apply.
Note: To show or erase a cross-sectional view name, use the Show/Erase dialog box (View > Show and
Erase).

To Control the Cutting Line Display

You can control the display of the cutting line in a cross-sectional view by setting the following drawing setup
file options.

1. Click DRAWING > Advanced > Draw Setup. The Options dialog box opens.
2. Set the following drawing setup file options:
— cutting line—Determines the standard (ANSI, ISO) for the cutting line display

S e

— cutting line adapt—Sets the display of all line fonts used to display cross-sectional views
adaptive so that they begin in the middle of a complete line segment and end in the middle of a
complete line segment

— cutting line segment—Controls the length of the thickened portion of the cutting line

To Redefine Offset Cross Sections

You can redefine the side and direction of offset cross sections by using the Redefine command in the XSEC
MODIFY menu in either Part or Assembly mode, not Drawing mode.

1. In Part or Assembly mode, choose X-Section and Modify Xsec.
. Select the name of the cross section from the XSEC NAMES menu.
3. Choose XSEC MODIFY > Redefine and one of these commands from the REDEFINE menu:
— Attributes—Redefines the cross section from one side or both sides

— Direction—Redefines the direction
— Section—Redefines the cross section of the offset cross section
— Scheme—Redefines the scheme of the offset cross section

About Working with Draft Cross Sections

Using Edit > Fill and then Hatched or Solid in the menu bar, you can fill or hatch a draft cross section.
Pro/ENGINEER defines a draft cross section boundary by a closed loop of draft geometry.

When working with draft cross sections, keep in mind the following:

e You can define islands, or unfilled and uncrosshatched areas, within the closed loop.
o Islands cannot intersect the outer boundary, nor can they intersect each other.
e You can include any number of loops.
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e You can include both types (filled and crosshatched) in nonparametric drawing formats, if desired.

e The system does not consider a draft cross section to be a single entity. Therefore, to place it on a layer, you
must add the contour and crosshatch pattern individually.

* You can modify only one draft cross section at a time. You cannot modify a draft cross section that contains
open loops.

® You can delete either the entire cross section (with the cross-hatching or filling and boundary) or the cross-
hatching/filling.

Example: A Draft Cross Section

i 2
S

4,
1 Define islands.

2 Define outer boundaries.

To Create a Draft Cross Section or Filled Area

1. Select a closed draft entity, or a series of entities that form a closed area, from which you want to add a draft
cross section. Note: You can use the Pick Many command to select multiple entities. Click See Also below
for more information.

2. On the menu bar, click Edit > Fill, and then select Hatched or Solid.

3. At the prompt, enter a name for the cross section. When you press ENTER, the draft cross section is created.

Using Pick Many to Select Entities

You can use Pick Many to select entities in a closed loop. The system highlights incorrect entities (that is, those
that do not form a loop) in magenta. If the entities almost form a loop, but leave a slight gap, it highlights the
endpoints of the entities at the gap.

To Modify a Draft Cross Section

1. Select the draft cross section by selecting the cross section boundary or on the cross-hatching.

2. Click Edit > Properties. The MOD XHATCH menu opens in the Menu Manager.

3. Choose commands from the MOD XHATCH menu. You can retrieve a previously saved crosshatch pattern to
use in the draft cross section.

To Delete a Crosshatched or Filled Area Without
Deleting the Boundary

1. Select the crosshatched area you want to delete, and then click the right mouse button to display the shortcut
menu.

2. Choose Delete from the shortcut menu.

Select inside the crosshatched or filled area.

4. Choose DWG SELECT > Done Sel. The system deletes the cross-hatching or filling, leaving the bounding
entities. If the border is not visible, choose Repaint.
Note: To delete the entire cross section with its boundary, select a point on the contour; then choose Done
Sel.

et
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About Grouping Draft Entities

Using the Group command in the TOOLS menu, you can create, suppress, resume, and explode draft groups.
Pro/ENGINEER acts upon all of the entities within a group in the same way. However, modifying the line style
of a grouped entity affects only that entity.

When grouping entities, keep in mind the following:

e You cannot use other commands such as Intersect or Trim to modify entities belonging to a group.

* You can put draft entities on a layer and blank them all at once by selecting that layer. You can also blank
individual draft entities without having to blank all entities on a layer.

® You can include notes, symbols, and geometric tolerances, except those created using On Item, in draft
groups.

e The system creates a draft cross section as a group containing the cross-hatching and the bounding entities.
You cannot explode the cross-hatching, but you can delete it.

To modify grouped notes, dimensions, and symbols, use Format > Text Style in the menu bar as you would for
notes.

To Create a Draft Group

1. Choose DRAWING > Tools > Group > Create.
2. Using the GET SELECT menu, select all of the entities to include in the group.
3. Type a group name.

To Suppress a Draft Group

1. Choose DRAWING > Tools > Group, and then on the DRAFT GROUP menu, choose Suppress.
2. Using the GROUP ACCESS menu, do one of the following:
— Choose Select and select a group.

— Choose By Name and type the group name.

To Resume a Suppressed Group

1. Choose DRAWING > Tools > Group, and then on the DRAFT GROUP menu, choose Resume.
2. Do one of the following:

— Select the group to resume from the GROUP NAMES menu.
— Choose Names and type the group name.

To Explode a Resumed Group

1. Choose DRAWING > Tools > Group, and then on the DRAFT GROUP menu, choose Explode.
2. Do one of the following:
— Select the group to explode by selecting one of its entities with the mouse.

— Choose GROUP ACCESS > By Name and type the group name.

To Modify a Draft Group

1. Choose Choose DRAWING > Tools > Group, and then on the DRAFT GROUP menu, choose Edit.
2. Do one or both of the following, as necessary: Do one of the following:

— Select a group by selecting one of its entities with the mouse.

— Choose GROUP ACCESS > By Name and type the group name.

— Add draft entities to the group by choosing Add and selecting the entities to add to the group.

Note: You cannot add draft datums, 3-D datums, draft axes, symmetry lines, or balloons to draft groups.
3. Delete entities from the group by choosing Remove and selecting the entities to remove from the group.
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About Cut, Copy and Paste

You can manipulate detail items using cut, copy, and paste functionality. When you cut, copy or paste items
such as notes, symbols, draft entities and tables, the selected items are copied temporarily to the clipboard and
then pasted onto the same sheet, a different sheet, or a different drawing.

The detail items that you can cut, copy and paste are as follows:

e Notes (with and without leaders)

e Balloons

e Symbols

e Draft entities

e Draft dimensions

e Tables

Notes, balloons, and symbols with leaders are copied with their leader. The leader is copied as it looks on the
source drawing. You are able to move the end of the leader on the target drawing by dragging the endpoint and
jog to the desired location.

The parameters in the notes are copied as parameters and are evaluated on the target drawing. If the parameter
cannot be evaluated on the target drawing, three asterisks are displayed to indicate this.

Tables with regular text (no repeat regions) are copied as text. When pasted, the text looks as it does on the
source drawing. Tables with repeat regions are copied with the report symbol names and have to be updated on
the target drawing using Update Tables.

The Cut, Copy, and Paste commands are available from the Edit menu or directly from the toolbar icons on
the top toolbar. They allow you to copy detail items and paste them between drawings, reports, formats, layouts
and diagrams. The following from - to combinations are supported:

e Drawing — Drawing, Report or Format

e Report — Drawing, Report or Format

e Format — Drawing, Report or Format

e Layout — Layout (limited to same type only)

e Diagram — Diagram (limited to same type only)

Keyboard accelerators can also be used to perform cut, copy and paste functions:

e Cut—CTRL+X
e Copy—CTRL+C
e Paste—CTRL+V

The Cut command works similarly to the Copy command in that the selected detail item is copied to the
clipboard. However, the Cut command moves the selected item from its original location to its new location.

To Copy Detail Items on the Same Sheet Using the
Clipboard

1. Click Edit > Copy, or click on the toolbar.

2. Select the detail items you want to copy to the clipboard, and then click ™= . The Drawing Clipboard
dialog box opens and contains the copied detail items.

3. Define the translation origin point by picking a point in the Drawing Clipboard dialog box. The translation
origin point appears as a yellow square.

4. Select the location on the drawing where you want to place the copied items. This action pastes the copied
items.

o Y Ero
Note: If you want to move detail items, use Cut & instead of Copy .
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To Copy Detail Items from one Sheet to Another
Sheet Using the Clipboard

Click Edit > Copy, or click on the toolbar.
Select the detail items on the source sheet you want to copy to the clipboard.
Move to the target sheet by working from the Sheets menu or by using the Sheets spin box on the toolbar.

ER N N

When you are in the target sheet, click

items from the source sheet.

5. Define the translation origin point by picking a point in the Drawing Clipboard dialog box. The translation
origin point appears as a yellow square.

6. Select the location in the target sheet where you want to place the copied items from the source sheet. This

action pastes the copied items.

. The Drawing Clipboard opens and contains the copied detail

o Y Ero
Note: If you want to move detail items, use Cut & instead of Copy .

To Copy Detail Items from one Drawing to Another
Drawing Using the Clipboard

Click Edit > Copy on the menu bar, or click on the toolbar.
Select the detail items on the source drawing you want to copy to the clipboard.
Select the target drawing from the Window menu on the menu bar. This action opens the target drawing.

S e

Click Edit > Paste on the menu bar, or click

detail items from the source drawing.

5. Define the translation origin point by picking a point in the Drawing Clipboard dialog box. The translation
origin point appears as a yellow square.

6. Select the location in the target drawing where you want to place the copied items from the source drawing.

This action pastes the copied items.

. The Drawing Clipboard opens containing the copied

o X Ero
Note: If you want to move detail items, use Cut & instead of Copy )

To Copy Detail items from a Drawing to Another
Drawing

Using the Copy command from the TOOLS menu, you can copy detail items, such as drawing tables, notes,
symbols, draft entities, and balloons, from one drawing to another. Items commonly used on all drawings can be
stored in one main drawing to be copied to new drawings.

1. Choose Edit > Copy from Other Drawing.

2. In the Open dialog box, select the name of the source drawing from which to copy items. The selected
drawing is displayed in another Pro/ENGINEER window, and the DETAIL ITEMS menu appears.

3. Ifthe source drawing contains more than one sheet, use the commands in the PLACE SHEET menu to switch
to the correct sheet, and choose Done.

4. Choose a command from the DETAIL ITEMS menu to specify the items to copy. If you choose Draft Items
or Dwg Tables, select the items to copy and choose Done Sel; then click Done.

— Entire Sheet—Copies all the current items on the current sheet onto the other drawing.

— Draft Items (selected by default)—Allows you to select draft items to copy from the source drawing.
— Dwg Tables—Allows you to select drawing tables to copy onto the other drawing.

— Done—Copies selected items to the target drawing.

— Quit—Cancels current selections and returns to the TOOLS menu.

5. Select a point on the source drawing to define the first point of the translation vector. This selected point
indicates where the items will be placed on the target drawing.
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6. Select a point on the target drawing to define the final point of the translation vector. The items are placed
on the drawing relative to the first point of the translation vector.
After the selected items are copied to the target drawing, the system returns to the TOOLS menu.
You do not have to scale the items after they have been placed on the target drawing. The system
automatically scales the items copied between drawings of different size. For example, when items are
copied from an E size to a B size drawing, the items are scaled by the same factor.

Rules for Copying Detail Items from Drawing to
Drawing

The following rules and restrictions apply to copying detail items from drawing to drawing:

e The source and target drawings must use the same units.

e Notes, balloons, and symbols with leaders are copied with their leader. The leader is copied as it looks on
the source drawing. You can move the end of the leader on the target drawing by dragging its endpoint and
jog to the desired locations.

e Notes that contain dimension parameters (that is, &d23) cannot be copied. Notes that contain other
parameters can be copied.

Tables are copied as follows:
— Tables without repeat regions are copied as text and look the same as they do on the source drawing.

— Tables with repeat regions are copied with the report symbol names and have to be updated on the
target drawing using Update Tables.

To Translate and Copy Draft Entities

Using the Copy command in the TOOLS menu, you can copy draft entities or free notes by translating them in
an x- and/or y-axis direction, or by rotating them about a point. To translate or rotate the draft entities without
creating any copies, use the commands available in the MOD ENTITY menu.

Note: You cannot rotate symbols.

1. Choose TOOLS > Copy > Translate.

2. Select all of the entities to copy and translate. Choose Done Sel.

3. Choose Horiz, Vert, or Ang Length from the GET VECTOR menu to specify the direction for translating
the new entities.

4. Type the number of copies to create and press ENTER. The system copies the entities and moves them

The GET VECTOR Menu

You can use the GET VECTOR menu for various operations, such as translating and copying draft entities. In
this case, you use the GET VECTOR menu to specify the direction for translating new draft entities.

e Horiz—Translates the entities along the horizontal direction. Type a value, in drawing units, to translate the
entities. Positive direction is toward the right of the sheet.

e Vert—Translates the entities along the vertical direction. Type a value, in drawing units, to translate the
entities. Positive direction is toward the top of the drawing sheet.

e Ang/Length—Translates the entities at an angle, and a specified distance in that direction, measuring the
angle relative to the horizontal in the counterclockwise direction. An arrow appears showing the positive
direction of translation.

o From-To—Translates the entities along a vector defined by using a start point and endpoint.

To Rotate and Copy Draft Entities

1. Choose TOOLS > Copy > Rotate.
2. Select all of the entities to copy and translate. Choose Done Sel.
3. Type a rotation angle for the entities and press ENTER. The system measures the angle from the horizontal
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in the counterclockwise direction.

4. Select the center point for the copy rotation using GET POINT menu commands.

5.

Type the number of copies to create and press ENTER. The system creates the copies and rotates them.

To Mirror an Entity

Using the Mirror command in the TOOLS menu, you can create copies of draft entities, unattached symbols,
and unattached notes by mirroring them about a draft line.

1.
2.
3.

Choose TOOLS > Tools > Mirror.

Select detail items to mirror; then choose Done Sel.

Select a draft line about which to mirror the entities. The system creates a copy of the selected entities as
mirror image of the source entities.

Example: Mirroring Entities

| rmirrored copy | original
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To Break Two Entities at their Intersection

1.

Choose DRAWING > Tools > Intersect.

2. Select two intersecting entities.

The system creates breaks at the intersection of both entities, thereby creating four separate entities. If there
is more than one possible intersection, such as a spline crossing a line in several places, the system creates
the intersection closest to the point you selected. Intersected construction geometry becomes regular draft
geometry.

Note: If the selected entities do not actually intersect, the system does not find an intersection. In this case, use
the Trim command.

To Trim Draft Geometry

Using the Trim command in the TOOLS menu, you can lengthen or shorten draft geometry. The system uses the
geometry definition to find its intersection with the bounding entity.

1.
2.
3.

Choose DRAWING > Tools > Trim.

Choose a command from the TRIM menu.

Select the entity to trim (you cannot trim construction geometry). To shorten the entity, select the portion of
the entity that you want to keep in the drawing. To lengthen it, select it anywhere.

Choose Done Sel.
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Tip: When a Spline Does Not Intersect the Bounding
Entity

When a spline or the continuation of an arc does not intersect the bounding entity, the system cannot calculate
the intersection, so it does not trim the entity.

The TRIM Menu

The following are the options on the TRIM menu, accessed when you choose DRAWING > Tools > Trim.

e Bound—Trims to a specified entity or point.
e Length—Trims to a specified length.
e Increm—Trims or extends by a specified amount.

e Corner—Trims two entities to their intersection.

To Offset Draft Geometry

Using the Offset command in the TOOLS menu (DRAWING > Tools > Offset), you can offset draft geometry
from other draft entities and model geometry. You can select an axis line, datum plane, draft datum plane, or
draft datum axis for creating an offset draft entity. This axis line can come from any shown axis, without regard
to orientation. When you create an offset from the axis perpendicular to the screen (that is, the crosshairs), you
must create an offset for the horizontal and the vertical separately.

The resulting offset draft line is not associative to the axis line or datum. This means that when the axis or
datum is clipped, moved, or erased, the draft line remains unchanged.

The new draft line is automatically related to the view. When you offset a draft entity from a model edge or
another draft entity already related to a view, the system automatically relates it to the view from which you
selected the model edge or the other draft entity.

Choose DRAWING > Tools > Offset > Single Ent.
Select either a parallel or a perpendicular axis.
Choose the attributes of the draft line from the OFFSET TYPE menu and choose Done/Return.
Enter the offset distance.
When you choose Single Ent from the OFFSET OPER menu, the OFFSET TYPE menu displays the following
commands:
— Fixed—Creates a draft entity with a single offset value.

el S

— Tapered—Creates a draft entity with a different offset at each endpoint.

— Trimmed—Offsets only a portion of the draft entity. Determine the trimmed boundaries by selecting a
draft point on the entity, or by selecting some arbitrary point on the entity.

— Untrimmed—Creates a draft entity that uses the whole length of the original draft entity.

Using the Ent Chain command in the OFFSET OPER menu, you can simultaneously select several entities to
offset. The entities must all be connected, but you can select them in any order or use the Pick Box command.

Note: The Ent Chain command is not available for selecting axes.
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Example: Creating Draft Entities Using Offset

-— 1

Original draft entities.
Created using Single Ent, Tapered, and Trimmed.
Created using Single Ent, Fixed, and Untrimmed.
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Created using Ent Chain.

About the Translate Command

Using the Translate command in the TOOLS menu (DRAWING > Tools > Translate), you can move draft
entities and annotations about the drawing if they are not attached to an edge. The Translate command differs
from the Move command in the following ways:

® You can translate any number of items simultaneously.
e Once you have translated the selected entities, the system unselects them automatically. Using the Move
command, you can move the item repeatedly until you press the middle mouse button.

Note: You cannot use Translate in the TOOLS menu to copy entities as you would use Copy in the TOOLS
menu, followed by Translate in the COPY TYPE menu.

To Translate Draft and Unattached Entities

1. Choose DRAWING > Tools > Translate.

2. Select draft entities to translate. Choose Done Sel when you have finished.

3. Choose a command from the GET VECTOR menu to specify the direction for translating the new entities,
and then follow the system prompts. The system uses the specified distance values between each copy of the
draft geometry.

To Move Draft Entities to Another Sheet

Using the GET SELECT menu, you can select draft items that are not associated with any view and move them
to another sheet. The system moves draft items that are associated with a view to another sheet if you switch the
view to which they belong to that sheet.
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To Break a Draft Entity

1. On the menu bar, click Insert > Break. The BREAK menu opens in the Menu Manager. Add is the default
option.

2. Select an entity.

3. Indicate breaks by selecting the start point and endpoint of each break.

4. After the system breaks a draft entity into two separate draft entities, select the first break point on either of
the two entities to start another break.

To Stretch a Draft Entity

1. Choose DRAWING > Tools > Stretch.

2. Use the left mouse button to specify two opposite corners of a selection box within which to enclose the
entities you want to stretch.
Note: Filled draft entities cannot be stretched.

3. To edit your selection, use the GET SELECT menu to select individual entities that you want to exclude
from the selection and press the middle mouse button.

4. Define the translation vector by selecting the first location—the from location; then select the final
destination point. The specified entities are stretched.

Stretching Draft Entities

The stretching process does not affect the location of entities outside the selection box.

Lines that cross the selection box stretch so that the system translates their location point within the box along
the translation vector.

The stretching process does not affect circles and arcs with centers outside the box.

The system does not preserve tangency in the process of stretching.

To Divide a Draft Entity

1. Click DRAWING > Tools > Divide.

2. Select the entities to divide, and then type the number of equal segments into which you want to divide the
entity. If you select multiple entities, the system divides them all the same way into equal segments. After
the entity divides, it highlights the break points.

To Change the Line Style of Draft Entities

To change the line style of selected entities as well as redefine some or all line style elements such as line font,
color, and line width (thickness):

1. Inthe menu bar, click Format > Line Style.
2. Choose one of the following options in the LINE STYLES menu:
— Modify Lines—Allows you to select draft entities whose line styles you want to modify, using the
Modify Line Style dialog box.

— Edit Styles—Opens the Line Style Library dialog box, from which you can create a new line style,
edit an existing style, or delete a style.

— Edit Fonts—Opens the Line Font Library dialog box, from which you can create a new font, edit an
existing font, or delete a font.

— Clear Style—Undoes the last line style change you made.

The Rescale Command

Using the Rescale command in the TOOLS menu (DRAWING > Tools > Rescale), you can modify the size of
draft geometry. When the system regenerates the drawing, it updates associative dimensions to the resized
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geometry. However, you must scale nonassociative dimensions with the geometry to maintain their relative
positions. These values do not change with scaling.

To Scale Draft Geometry

Choose DRAWING > Tools > Rescale.

Select draft geometry and dimensions to scale, and then click Done Sel.

Use the GET POINT menu commands to select the point about which to scale the entities.

Type a scale value and press ENTER. A number greater than 1 makes the entities larger; a number less than
1 makes them smaller. For example, a value of .25 scales the drawing to one-quarter (1/4) of the actual size
of the model.

5. Regenerate, if necessary, to recalculate associative dimensions.

To Modify the Diameter of an Arc or Circle

When you modify the diameter of an arc or circle, the system does not update unassociated draft dimensions to
reflect changes in the entity size.
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1. Select the draft entity (circle or arc) whose diameter you want to modify, and then right-click to display the
shortcut menu.

2. Choose Mod Arc Diam from the shortcut menu.

3. Type a new diameter for the draft entity. The entity reappears at its modified value.

4. To update any associated draft dimensions, choose DRAWING > Regenerate > Draft.

Using a Model Edge

Using the Use Edge command in the TOOLS menu (DRAWING > Tools > Use Edge), you can create a draft
entity using a model edge, and the system automatically relates it to the view. When you erase the view, the
system erases all attached detail items with it. When you delete the view, the system deletes all attached detail
items; however, you can use Relate View in the VIEWS menu (DRAWING > Views > Relate) to remove the
draft items and make them independent of the view.

To Create a Draft Entity Using a Model Edge

1. Choose DRAWING > Tools > Use Edge.

2. Select a model edge and choose Done Sel.

3. Type [Y] to erase the selected edge. Regenerate the view to redisplay the selected view (View > Update on
the menu bar).

About Modifying Splines

In Drawing mode, you can modify splines in the following ways:

e Move a single point or a range of points on the spline

e Add points to the interior of the spline, or extend the spline by adding points to the exterior
e Delete points from the spline

e Use a deviation value to reduce the number of spline points

e Smooth the spline

e Use the spline control polygon to modify the spline

To Move a Single Spline Point

1. Select the spline, and then right-click to display the shortcut menu.

2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus appear in the
Menu Manager.

3. To move a single point on the spline, click Single Pnt, and then select the point you want to move. The
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point and the part of the spline that is affected moves as you move the mouse pointer to another location on
the screen.

4. Click in the new location to place the point.

5. Click Done Modify when you are finished. To cancel the move operation, click Quit Modify.

To Move a Range of Points on a Spline

1. Select the spline, and then right-click to display the shortcut menu.

2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus appear in the

Menu Manager.

Select two spline points limiting the adjustment range.

Select the point (within the adjustment range) you want to move.

5. To place the point in a different location, click another location on the drawing window. The selected point
moves to its new location, and the part of the spline enclosed within the range adjusts accordingly.

To Add Points to a Spline

You can add points to the interior of a spline, or to the exterior, thus extending the spline.

Bw

1. Select the spline, and then right-click to display the shortcut menu.
2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus open in the
Menu Manager.
In the MOD SPLINE menu, click Add Points. Interior is selected by default in the NEW POINTS menu.
4. Do one of the following:
— Choose Interior and add points to the interior of the spline by selecting any location on the spline
between any two existing points.

W

— Choose Exterior and extend the spline by adding points beyond its current endpoints. Select the spline
endpoint to extend; then select additional points.

To Modify a Spline Using Control Poly

You can modify a spline by using its control polygon (the polygon that the system creates to surround the spline
when you first create it). The control polygon displays in white when you choose the Control Poly command.

1. Select the spline, and then right-click to display the shortcut menu.

2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus open in the
Menu Manager.

3. Choose MOD SPLINE > Control Poly.
The spline’s control polygon appears in white. Spline control points appear with line segments between
them on the spline. The line segments begin and end at the startpoint and endpoint of the spline, and
intermediate segments remain tangent to the spline. These line segments are visual aids for modifying the
shape of the spline.
Note: You cannot use this command on a spline that has a tangency condition defined for one end only.

4. Adjust the shape of the spline by selecting a point on the control polygon and dragging it to a new location.
You cannot select endpoints. The spline rubberbands to its new shape as you move the point.

5. Place the control point by pressing the left mouse button.

To Delete Points from a Spline

1. Select the spline, and then right-click to display the shortcut menu.

2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus open in the
Menu Manager.

3. Choose MOD SPLINE > Delete Points.

4. Select a spline point to delete. Click Done Sel, then Done Modify, when you are finished removing points.
The system redraws the spline according to the new shape created when you removed the points.

5. Repaint the drawing to see the new spline shape.
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To Decrease the Number of Spline Points Using a
Deviation Value

1. Select the spline, and then right-click to display the shortcut menu.

2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus open in the

Menu Manager.

Choose MOD SPLINE > Sparse.

4. Type a deviation value to redraw the spline with fewer points. This value must be a positive number. The
system highlights the spline and tells you how many points it is going to remove.

5. To accept the changed spline, choose Accept; to reject it, choose Reject and type a different deviation
value. (For each spline, you might need to try several different deviation values before achieving the desired
result.)

To Smooth the Spline

1. Select the spline, and then right-click to display the shortcut menu.
2. Choose Modify Spline from the shortcut menu. The MOD SPLINE and MOVE PNTS menus open in the
Menu Manager.
3. Choose MOD SPLINE > Smooth.
4. Type the number of points to average in order to smooth the spline:
— Type [1] to keep the spline as is.

b

— Type [3] to average the centermost point out of the group and one point on each side of it.
— Type [5] to average the centermost point in the group and two points on each side of it.

5. The resulting spline appears in green. To accept it, choose Accept; to reject it, choose Reject and try again
with a different number of points.

To Move or Clip Iltems in Drawing Mode

You can move items from one location to another in the drawing window. You can move individual objects as
well as entire views. You can also extend or shorten the length of lines and other boundaries. The moving and
clipping features in Pro/ENGINEER work differently when you are in Drawing mode than when you are in Part
or Assembly mode. To move or clip an item while you are in Drawing mode:

1. In the drawing window, select the item. The item is highlighted and contains handles (boxes).
2. Do one of the following:
— To clip or extend a line, click a handle, and then click anywhere outside of the item to extend or shorten
its boundary.

— To move an item, click anywhere in the drawing window. The item moves to the selected location.

About Controlling the View Type

You can control the extent to which the model is visible in a drawing by creating full, half, partial, and broken
views.

As you specify a major view type, you can use the commands in the VIEW TYPE menu to control how much of
the model is visible in the drawing:

e Full View—Shows the model in its entirety.

e Half View—Removes a portion of the model from the view on one side of a cutting plane.

e Broken View—Removes a portion of the model from between two selected points, and closes the
remaining two portions together within a specified distance.

o Partial View—Displays a portion of the model in a view within a closed boundary. The system displays the
geometry appearing within the boundary, but removes the geometry outside of it.
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Creating Half Views

When Pro/ENGINEER creates a half view in a drawing, it cuts the model at a plane, erasing one portion of it,
and displaying the rest. The cutting plane may be a planar surface or a datum, and must be perpendicular to the
screen in the new view. The Half View command is available only for projection, auxiliary, and general views.

Example: Half View
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1 The view temporarily appears in full.
2 Select this datum plane as the cutting plane.
3 The resulting half view.

To Create a Half View

1. Follow the procedure for adding a projection, auxiliary, or general view; then choose VIEW TYPE > Half
View.

2. Select the cutting plane from any other view on the drawing (it must be perpendicular to the screen in the
new view).

3. Arrows appear on the new view pointing to the side that is to remain in the view. Choose Flip to flip the
direction of the arrow or Okay to accept the direction and continue.
The view that was on the screen changes. The system discards the portion of the view that was behind the
cutting arrows, and the cutting arrows do not remain in the drawing.

Creating Partial Views

To create a partial view, you define and orient a view, and then sketch a closed boundary around the new view.
The system displays the geometry within the closed boundary, but not geometry outside of it. The Partial View
command is available only for projection, auxiliary, and general type views. You can scale them, cross-section
them, and create them with several boundaries or breakouts to include a local area cross section.

Example: Partial View

L]

1 Sketch this spline to define the view boundary.
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To Create a Partial View

1. Follow the procedure for adding a projection, auxiliary, or general view; then choose VIEW TYPE > Partial
View.

2. Select a point on an edge in the new view. A red cross appears, representing the reference point on the
geometry to be displayed in the new view. The system needs this reference point to properly regenerate the
partial view.

3. Draw a boundary around the red cross, enclosing all of the geometry that you want to display in the partial
view. Select points using the left mouse button. To close the boundary, press the middle mouse button. Only
the portion of the view that was inside the spline appears.

Creating Broken Views

You can create broken views in both vertical and horizontal directions with as many breaks as you want. You
can also create broken views with local cross sections.

The space between the breaks—the offset distance—is defined as a vertical or horizontal distance between two
subsequent pieces of the view. The display of a broken view maintains a constant offset distance between the
displayed pieces of the view when you change the following:

e Model geometry
e Scale of the drawing
e Reference points of the broken view

You can control the offset distance when you first create a break by setting the drawing setup file option
broken view offset. The default spacing is 1 drawing unit. You can change the spacing by using Move
View to move one of the subviews, or portions, of the broken view.

You can draw the break line for a broken view in three ways:

e Sketch—Sketch a spline

e S-Curve—An S-Curve shaped spline is created for the break line

e Heartbeat—A heartbeat-shaped spline is created for the break line

When you select S-Curve or Heartbeat to use as your spline type, the following two options are available:

e View Outline—Scales the spline based on the view outline in that direction
e Geometry— Scales the spline based on the distance between two selected points

You can create a projection view from a broken view. The break points are projected, allowing you to draw new
splines in the child view.

Note: The shape of the S-curve and Heartbeat is invariant; that is, any change in size affects both length and
width proportionally.

To Create a Broken View

1. Choose Projection or General and Broken View from the VIEW TYPE menu.

2. Select the location for the center of the new view. The object appears. Orient the view if necessary.

3. For each break in the view, define the boundaries of the vertical or horizontal area to remove. Choose Add
or Delete from the ADD/DEL BRK menu, or choose Vertical or Horizontal from the BREAK DIR menu.
Note: You cannot add horizontal break lines on a horizontally projected broken view, or add vertical break
lines to a vertically projected broken view.

4. To add a break line, select on a model edge. For every two break lines that you add, the system creates one
break and removes the portion of the view that is between them.
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View with Break Lines

5. When you have finished adding break lines, choose ADD/DEL BRK > Done. The system removes the area
between break lines and displays the model, indicating the break by a single horizontal or vertical line.
View with Area Between Break Lines Removed

(3

6. Sketch the spline break representations. Select all breaks in the same direction that are to use the same
spline. You must sketch vertical and horizontal breaks separately.
Sketch of Spline Break Representations

7. Choose Done Sel; then sketch the spline. Do this for every break that has a different spline representation. If
you do not sketch a spline for a break, the break representation is in a straight line. For multiple break lines
with a single sketch, sketch the break line at the location of the first break selected; otherwise, the break
lines all shift.

8. Choose Done when you have finished. The view expands at the breaks with the contours just sketched and
an initial gap between each portion (determined by the drawing setup file option "broken view offset").

Completed Broken View

To Add a Segment to a Broken View

Click Views > Modify View > Boundary.

Select the view you want to redefine. The view segments temporarily snap together.

On the VIEW BREAK menu, click Add Segment. The view segments return to their previous positions.
Select a view border to which you want to create a new segment. Doing this creates the new broken view
segment. You can repeat this step as many times as you want to create additional segments.

Note: The new broken view segment is created in the view and any appropriate projected views. The new
segment has the same reference points and spline shapes as its neighbors, and it is offset at the same
distance.

To Delete a Segment from a Broken View

1. Click Views > Modify View > Boundary.
2. Select the view you want to redefine. The view segments temporarily snap together.
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On the VIEW BREAK menu, click Del Segment. The view segments return to their previous positions.
Select the segment you want to delete. The segment is highlighted.

5. Select a side of the highlighted segment where you want to keep the spline shape. Doing this deletes the
segment.

Note: The deleted segment is deleted in the current view and any appropriate projected views.

Tip: Moving Broken Views

When you move a broken view, for any subview (or portion of the view) that you select to move, all subviews
to its right and below it move the same distance. To move the entire broken view to a different location on the
drawing, select the upper-left subview. This moves the entire view without altering the gaps between the
subviews. Selecting any other subview moves all subviews below it and to the right of it the same distance.

B

Moving a Broken View
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1  Select this subview to move the view as a whole.

2 Move vector.

About Exploded Assembly Views

When you are making a drawing of an assembly, you can add an exploded view of the assembly without having
to explode it in Assembly mode. If you save an assembly in its exploded state in Assembly mode, and then
retrieve the view in Drawing mode by selecting a name from the Saved Views list in the Orientation dialog box,
the system places the view in the proper orientation, but not in its exploded state.

To Create an Exploded View

Choose Views > Add View.

Choose commands from the VIEW TYPE menu, Exploded, and Done.

Select the center of the view.

Specify the orientation type using the Orientation dialog box. The system adds the exploded assembly view
to the drawing.

Note: If you have a license for Pro/PROCESS for ASSEMBLIES, the SEL STATE menu appears. You can
then select an explode state and orient it.

Creating Exploded Views

You can create multiple exploded views in the same drawing. When you create an exploded view using the Add
View command, Pro/ENGINEER copies current exploded dimensions of the model into the view. After that, the
explosion distances of that view are independent of the other views and of the model itself.
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If you have modified the Expld Status values of an assembly in Assembly mode (by switching them on and
off), the system may not show more than one exploded view. You can control exploded dimensions in Drawing
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mode, but to control components globally, use the Expld Status command in Assembly mode.

Changing Explosion Distances for Exploded Views

The explosion values specified in the assembly control the explosion distance between components in the
model. You can modify exploded dimensions in a drawing view by choosing Mod Explode from the VIEW
MODIFY menu. However, this command only alters the drawing cosmetically and does not modify the actual
exploded dimensions of the model. If you modify an assembly in Assembly mode by choosing Redefine from
the EXPLD STATE menu, you cannot change these explosion parameters in a drawing.

To Modify the Explosion Distances Between

Components

Click VIEWS > Modify View. The VIEW MODIFY menu appears.

Click Mod Expld and then select a view to modify.

Choose EXPLD STATE > Redefine > Position.

Change the explosion distances by using commands in the MTNPREF menu.

Note: If you do not have a license for Pro/PROCESS for ASSEMBLIES, the MOD EXPLODE menu appears
instead of the EXPLD STATE menu. You can choose Position to access the MTNPREF menu, or Explode
Status.

When you choose Exploded from the VIEW TYPE menu, you must specify which explode state to use by
selecting it from the SEL STATE menu. If the view that you want to use is a process model view, you must
select the explode state from the SEL STATE menu.
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Creating Single-Surface Views

If you have a Pro/DETAIL license, you can create single-surface views out of a solid surface or datum quilt.
Pro/ENGINEER always displays them in wireframe, but it does not display datums, cosmetic features, and
coordinate systems. It erases all geometry other than the selected surface. You can create regular projection
views as well as single-surface projection views from single-surface views.
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Example: Single Surface Views

2
O
]
5
4
General Full view.

General Single-Surface view.
Projection Full view.

General Full view.
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Projection Single-Surface view.

To Create a Single-Surface View

1. Click VIEWS > VIEW TYPE > Of Surface and any other commands except Detailed.
2. If the single-surface view is General, orient the model as usual.
3. Select the single part surface to show. The system erases all other geometry.

About Perspective Views

You can create a perspective view of a model in a drawing by specifying an eyepoint distance, or focal length,
and a view diameter.

Creating Perspective Views
When creating and modifying perspective views, keep in mind the following restrictions:

e You can display only general views in perspective.
e Perspective views cannot have cross sections.
e You cannot use perspective views for creating projection or detailed views.
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e Dimensions, datum planes, and axes do not appear in perspective views (except when orienting the view).

e You cannot use the Intersect and Midpoint attachment commands to attach items with leaders to
perspective views.

e In Part mode, if you create a From/To perspective view and then name it (by typing a name in the Name
box of the Orientation dialog box), you cannot use this named view in a drawing. The system places it in the
default view.

Example: Perspective View

S
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1 General view

2 Perspective view. The view diameter is 1.5000. The eyepoint distance is 20.000.

To Create a Perspective View

Click VIEWS > Add View > General > Full > No Xsec > Perspective > Done.

Select a point to locate the view.

Type the eyepoint distance in model space units (inches).

Type the view diameter in paper units (inches).

The general view appears in perspective. Orient the view using commands in the Orientation dialog box;
then choose Done/Return to finish.

To Modify a Perspective View

1. Click VIEW MODIFY > Perspective.
2. Select the view on the screen.
3. Using the MOD PERSPECT menu, do one or both of the following, as necessary:
— Change the eyepoint distance by choosing Viewing Dist and entering a value.

Nk w =

— Change the diameter by choosing Diameter and entering a value.

About Cross-Sectional Views

You can create a cross section in Part and Assembly modes and show it in a drawing or you can add it to a view
in Drawing mode while you are creating it. If you have a license for Pro/DETAIL you can use commands in the
XSEC TYPE menu to create ten types of cross sections:

e A full cross section displays the whole view, whereas a local cross section shows a portion of the model
within a closed boundary cross-sectioned, but not outside the closed boundary.

— A full & local cross section shows a full cross-sectional view with local cross sections.
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e A half cross section shows a portion of the model on one side of a cutting plane, but not on the other side.

e A total cross section shows not only the cross-sectioned area, but the edges of the model that become visible
when a cross section is made.

e An area cross section displays only the cross section without the geometry.

® An aligned cross section displays an area cross-sectional view that is unfolded around an axis, whereas a
total aligned cross section shows an aligned cross section of a general, projection, auxiliary, or full view.

e An unfolded cross section shows a flattened area cross section of a general view, whereas a total unfolded
cross section shows a total unfolded cross section of a general view.

Assigned and Displayed Crosshatching Patterns in
Cross-Sectional Views

When creating a drawing view that contains a cross-section of the associated model, keep in mind that assigned
crosshatching patterns for model cross-sections may be based on the assigned material of the part. For example,
if you created a cross-section of a part or assembly and the cross-section cuts through a part that has a defined
material (such as steel), the system looks for a crosshatching pattern that has the same name as the assigned
material (without the extension .xch). If the system finds such a pattern, it automatically assigns it instead of the
standard default crosshatching pattern to the cross-section. The assigned crosshatching pattern is displayed in
Part and Assembly modes, and also in Drawing mode when you create the cross-sectional view.

If the cross-section cuts through a part that does not have a defined material, the system assigns the default
crosshatching style to the cross-section. Again, the default style displays in Part, Assembly, and Drawing
modes.

Note: If either of the two parameters default xhatch angle and default xhatch spacing are
defined for the part containing the cross-section, these parameter settings supercede other definitions of the
crosshatching style. That is, the existence of an assigned material name is no longer relevant to the assignment
of the crosshatching style.

To Include Surface Geometry in Cross-Sectional
Views

Include surfaces in drawing cross sections by changing the no value of the

show quilts_in total xsecs detail setup file option to yes. Exclude surfaces by changing the yes
value back to no.

Surface geometry (surfaces and surface quilts) will only be cut by the cross-section cutting plane in a drawing
view when the cross-section is created as a Model & Qlts or Surf/Quilt cross-section in part or assembly mode.
If the cross-section is created as a Model (default), the surface geometry will not be cut by the cutting plane.

Full Cross-Sectional Views

When you create a view, you can retrieve any of the existing cross sections or create a new cross section on the
fly. To control the display of datum curves, threads, cosmetic feature entities, and cosmetic crosshatch in a full
cross-sectional view, use the drawing setup file option remove cosms_from xsecs.Ifyousetittoall,
you can remove datums and cosmetics from all types of cross-sectional views.

To Create a Full Cross-Sectional View

1. Click VIEW TYPE > Section and then Done.
2. Choose the cross-section type from the XSEC TYPE menu and then click Done.
3. Using the XSEC ENTER menu, do one of the following:
— Choose Create and make a cross section on the fly.
— Choose Retrieve and select a cross section from the XSEC NAMES menu.
4. Select Planar from the XSEC ENTER menu to create a planar cross section or select Offset to create an
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offset cross section.
5. Choose Done and type a name for the cross section.
6. Create a section.
7. Continue with the process of creating a view.

Half Cross-Sectional Views

Using the Half command in the VIEW TYPE menu, you can create a half cross-sectional view. The portion of
the model cross-sectioned depends on the direction of the cutting arrow. The cutting arrow’s direction is
reversible.

Example: Half Cross-Sectional View

OTMz

1 Select the datum plane as the boundary for the cross section.

To Create a Half Cross-Sectional View

1. Select the view type from the VIEW TYPE menu.
Note: Half is only available if you choose Full View from the VIEW TYPE menu. This command is not
available for partial, broken, or half views.

2. Choose XSEC TYPE > Half > Done.
Note: The XSEC TYPE menu appears only if you have Pro/DETAIL. Otherwise, the system selects Area
Xsec automatically.

3. Orient the view as desired; then select a reference plane for a half cross section.

4. Arrows show the direction of creation of the half cross section. Confirm the direction by choosing Okay, or
reverse it by choosing DIRECTION > Flip.

5. Select or create a cross section using commands in the XSEC ENTER menu.

6. Select the view to show cross-section arrows, or press the middle button for none.

Local Cross-Sectional Views

You can create a partial projection, auxiliary, general, or revolved view with breakouts for a local cross section.
You can create local cross sections as you create a view, or you can add them later by modifying the view. In
both cases, the VIEW BNDRY menu provides the following commands to add, delete, or modify local cross
sections:
e Mod Breakout—Modifies boundaries of a local cross section
e Add Breakout—Adds a local cross section
e Del Breakout—Deletes a local cross section
e Move Ref Pnt—Relocates a reference point of a local cross section

Note: You cannot create nested breakouts in views with local cross sections.
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To Create a Local Cross-Sectional View

1.

Choose VIEW BNDRY > Add Breakout.

2. Indicate a cross section to use for a local cross section by selecting one of the following from the NEW

BREAKOUT menu:
— Current Xsec—Uses the cross section that was referenced by the previously created cross section.

— Choose Xsec—Creates a cross section on the fly, or retrieves an existing one. Use commands in the
XSEC ENTER menu.

Select a view to show arrows or press the middle mouse button for none. (You need not perform this step if
you choose Current Xsec.)

Select a reference point on the view geometry to be the center for a local cross section.

Sketch a spline without intersecting other splines. Finish the spline by pressing the middle mouse button. To
finalize cross sections that you created, choose Done.

Example: Local Cross-Sectional View

1
2

—-..

Select on the edge to locate the center of the local cross section.
Sketch this spline to define the cross-section boundary.

To Create a Partial or Broken View with Local Cross
Sections

1.

From the VIEW TYPE menu, choose Partial View or Broken View.

2. Choose Section > Done > Local.

v
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Note: Local is not available for half views. It is available only if you choose Full View or Partial View
from the VIEW TYPE menu.

Select a center point for the view and orient the view as desired.

Create or retrieve a cross section for a local cross section to reference. Use commands in the XSEC ENTER
menu.

Select a view for arrows or press the middle mouse button for none.

Do one of the following:

— Ifyou are creating a partial view, select a center point for the partial view, sketch a spline defining
partial view boundaries, and select a center point for a breakout. To create more local cross sections,
specify a cross section to reference and then define the center and boundaries of the breakout. Choose
VIEW BNDRY > Done.

— Ifyou are creating a broken view, select a center point for the breakout and follow Steps 7 and 8.

Add breaks by selecting reference points and choose
ADD/DEL BRK > Done.

Select lines to share the same spline; then sketch a spline.
Choose EXIT > Done.
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Example: Partial View With Local Cross-Sections

- I—V%

SELTION AD-A0
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Select this point for the center of the partial view.

Sketch this spline to define the view boundary.

Sketch this spline to define the boundary of the local cross section.
Select this point for the center of detail.

To Create a Full Cross-Sectional View with Local

C

1.

[

SANRANE ol

8.
9.
10.
11.

12.
13.

ross Sections

From the VIEW TYPE menu, choose Projection or Auxiliary; then choose Full View or Partial View.

Note: This view type can be a total cross-sectional view only.

Choose Section > Done > Full & Local.

Note: Full & Local is not available for broken and half views.

Select a center point for the view and orient the view as desired.

Select or create a cross section using commands in the XSEC ENTER menu.

Select a view for arrows or press the middle button for none. The system creates a full cross section.

For a partial view, create an outer boundary by picking a reference point and sketching the boundary.

Note: Boundaries and reference points of local cross sections appear in orange; outer view boundaries and

reference point appear in green.

Specify another cross section for the local cross section to reference by choosing one of the following from

the NEW BREAKOUT menu:

— Current Xsec—Uses the current cross section for creating a local breakout. This command is valid if

you want to choose the cross section that was already referenced by a previously created local cross
section.

— Choose Xsec—Specifies a cross section for the a local cross section to reference. Create or retrieve one
using commands in the XSEC ENTER menu.

Select a view for arrows or press the middle mouse button for none.

Select a center point for the local cross section.

Sketch a spline without intersecting other splines. The spline appears in orange.

If desired, create more local cross sections by first specifying a cross section to reference and then defining
the center and boundaries of a breakout.

Choose VIEW BNDRY > Done when you have finished.

Modify the crosshatch pattern for local breakouts so that it differs from that of the full cross section.
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Example: Full Cross-Sectional View with Local
Cross-Sections

Section B

Section &

1 Created a full cross section using section A.

2 Created breakouts for the local cross sections by referencing section B. Modified crosshatch after the view
was created.

Total and Area Cross-Sectional Views

A total cross section shows not only the cross-sectioned area, but the edges of the model that become visible
when a cross section is made, whereas an area cross section displays only the cross section without the
geometry. Area cross sections display only geometry that lies in the cutting plane. Cosmetic features, datums,
and coordinate systems do not appear. Quilts do not appear in total cross sections; however, they do appear in
area cross sections created using the Model & Quilts command. In planar area cross-sectional views, you can
show all cosmetic sketches and datum curve features that lie in the cutting plane by setting the drawing setup
file option draw_cosms_in area xsectoyes.

To Create a View with a Total Cross Section or an
Area Cross Section

1. Add a view using General, Section, Full, and Total Xsec or Area Xsec.
Note: Total Xsec or Area Xsec are only available if you choose Full from the XSEC TYPE menu.

2. Select the location for the view.

Select or create a section using commands in the XSEC ENTER menu.

4. Select the view for showing arrows and set the direction of viewing by choosing DIRECTION > Flip >
Okay. If you do not select a view to show arrows, press the middle mouse button.

W
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Examples: Total and Area Cross-Sectional Views

1  Total cross section.
2 Area cross section.

Aligned Cross-Sectional Views

An aligned cross section displays an area cross-sectional view that is unfolded around an axis. The system
revolves all cutting planes of an offset cross section about the selected axis until they are oriented parallel to the
screen (sheet). Aligned cross sections create area-type cross sections. A fotal aligned cross section shows an
aligned total cross section of a general, projection, auxiliary, or full view. You can make a detailed view from
an aligned cross-sectional view.

The following restrictions apply to both aligned cross-sectional views and total aligned cross-sectional views:

e You can align offset cross sections only.

e The axis around which the cutting planes revolve must be parallel to the screen.
e The axis must lie on all cutting planes.

e The axis must be coaxial with all cylinders in the section.

e In an aligned cross section, you cannot show model dimensions. Dimensions can be created within one
segment of the cross section.

o [fthe view is to be general, orient the model so that the axis around which you are going to unfold is parallel
to the screen.

e Pro/ENGINEER creates aligned and unfolded cross-sectional views as area cross sections. No crosshatch
appears unless you have a Pro/DETAIL license.

To Create an Aligned or Total Aligned Cross-
Sectional View

1. From the VIEW TYPE menu, choose Projection, Full View, Section, No Scale, and Done.

2. From the XSEC TYPE menu, choose Full, Align Xsec (or Total Align), and Done.

Note: The Align Xsec and Total Align commands are only available if you choose Full from the XSEC

TYPE menu.

Select a center point for the view.

Select or create an offset section to use to unfold the view. Use commands in the XSEC ENTER menu.

5. Select the axis about which the cutting planes is to revolve to be parallel to the screen. Follow the applicable
restrictions.

6. Select a view that displays arrows designating the viewing direction and the cutting plane outline. Press the
middle button for none.

7. Choose Flip and Okay to change or confirm the direction of viewing arrows.

Unfolded Area Cross-Sectional Views

You can create an unfolded cross section or a total unfolded cross section of a general drawing view by
unfolding (stretching) cutting planes until they become parallel to the screen.

W
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When you are unfolding a cross section, the following restrictions apply:

® You can only unfold offset cross sections that were created using the Both Sides command.
e The entities that you use to define the cross section must be lines.

e You cannot create a projected view from an unfolded cross-sectional view.

e Pro/ENGINEER does not support part dimensions in unfolded cross section drawing views.
e You cannot create partial and half total unfolded views.

e You cannot create projection views of total unfolded views.

® You can show dimensions of features in the view if each dimension stays within a single segment of the
section.

e Ifyou deleted the offset section of a total unfolded cross-sectional view from the model or you cannot
regenerate it (such as when the sketching datum plane is suppressed), the total unfolded cross-sectional view
becomes a regular general view.

You can control the display of seams (the edges of the cutting plane) in total unfolded cross-sectional views by

using the drawing setup file option show_total unfold seam. When you set it to yes, the seams are

visible. When you set it to no, the system blanks them. To update the view display after you reset the drawing
file setup option, choose Update > Drawing View from the Pro/ENGINEER View menu.

To Create an Unfolded or Total Unfolded Cross-
Sectional View

1. Click VIEWS > Add View.
2. From the VIEW TYPE menu, choose General, Full, Section, No Scale (or Scale), and Done.
3. Do one of the following:
— To create an unfolded cross-sectional view, choose Full, Unfold Xsec, and Done from the XSEC TYPE
menu.

— To create a total unfolded cross-sectional view, choose Full, Total Unfold, and Done from the XSEC
TYPE menu.

Note: Unfold Xsec and Total Unfold are on/y available if you choose Full from the XSEC TYPE menu.

4. Select the location for the view.

Select or create a section using commands in the XSEC ENTER menu.

6. Select the view for showing arrows and set the direction of viewing by choosing DIRECTION > Flip >
Okay. If you do not select a view to show arrows, press the middle mouse button.

7. After the view appears, you can leave it as is or orient it by rotating it at an angle. Choose FLAT ORIENT >
Angles > Norm. Type the value for the rotation angle (an angle about the normal axis), and choose
Done/Accept. The view appears in its new orientation.

8. To conclude view creation, choose Done Orient. To abort the process, choose Quit Orient.

About Location Callouts

You can define a zone or location grid to drawing formats by creating location callouts. You define the location
grid by using the existing lines of a format or by using equally spaced increments. Use this location grid to
locate drawing views using parametric notes to indicate both the sheet and drawing location of a view.
Parametric location callouts allow for intelligent notes to be added to drawings to indicate the location of a
detail or section view, saving time and preventing out-of-date notes.

Location callouts are created using a standard syntax:

e View location—&pos_loc:view:<view names>

e

e Sheet of view—&sheet :view: <view names>
¢ Note location in parent view—&pos_loc:parent note:<view namex>
e Sheet location of note—&sheet :parent note:<view names

For example, if Detail A is located in A3 on the location callout grid and on sheet 2, type the note:
See Detail A at &pos_ loc:view:detail a on sheet &sheet:view:detail a
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The note text shows as:

See Detail A at A3 on sheet 2.

The syntax for the location callouts is customizable, which allows for additional text to be added based on
individual company standards. The detail setup option pos_loc_ format is provided to specify the syntax of
the pos_loc and sheet parameters in the callout. The default of pos loc format is %s%x%y, and
appears as 2D4.

%r added to pos_loc_format will repeat the syntax string for the same item appearing several times in
different locations. This applies to items such as symbols and connectors, but not to views because views have
unique names. The syntax will be %s%x%y, %r where %r means to repeat the substring from the first special
character to the last.

&pos_loc Behavior:

The location note updates upon regeneration if the view is moved on the drawing. If the view is erased or
moved outside of the grid, the value of the location callout changes to ***. The callout updates when the view is
resumed or the view is moved back onto the grid. If the view is deleted, then the location callout is no longer
parametric and the value changes to ***.

&sheet Behavior:

If you switch the view to a different sheet, the location callout automatically updates to the new sheet number.
If the view is erased, the value of the location callout changes to ***. The callout updates when the view is
resumed. If the view is moved outside of the grid, the value remains as the correct sheet number. If the view is
deleted, then the location callout is no longer parametric and the value changes to ***,

You specify which corner of the location grid you want as the origin. The grid origin is shown as a yellow X.
The default grid origin is the lower right corner of the location grid.

To Define the Location Callout Grid

1. In Format mode, click Advanced > Location Grid > Define.
2. Choose one of the following to define:
— Grid Outline—Specify the grid outline by using the rubberband box or by papersize (equal to the size
of the page).
— Grid Origin—Pick a point to indicate the grid origin. The lower right-hand corner is the default origin.

— Columns—Specify the amount and location of grid columns by number or pick points, and then
specify the grid labels by letter, number, or custom.

— Rows— Specify the amount and location of grid rows by number or pick points, and then specify the
grid labels by letter, number, or custom.

3. Click Done/Return.

To Show the Location Callout in a New Drawing

1. In Drawing mode, click Insert > Note.
2. Select the location for the location callout.
3. Type a note, and then type the following:
— To show the view location on the grid: &pos_loc:view:<view names>

— To show just the sheet location: &sheet :view:<view name>
— To show the note location in the parent view: &pos_loc:parent note:<view namex>
— To show the sheet location of the note: &sheet :parent note:<view names>

4. Click Done/Return. The location callout is created.

Example: A Location Callout

To show the location of a view named Main_view, type the following in the Enter NOTE text box:
Main view is located in &pos_loc:view:main view
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The note shows as:

Main view is located in 3B

According to the location callout grid you specified, Main_view is located in section 3B.

About Manipulating Views
Using commands in the VIEWS menu, you can manipulate views in several ways:

e Move views

e Switch views to another sheet
e Delete views

e Relate views to draft entities
e Erase and resume views

Moving Views

If you move a view from which other views were projected (parent view), the projected views (children) also
move to maintain view alignment. For example, if you move the front view in the following figure vertically,
the right side view also moves to maintain alignment because it was projected from the front view.

You can only move the front view vertically because it is a child of the top view and must maintain alignment
with it. This alignment and parent/child relationship between projected views remains intact even as the model
changes. You can move general and detailed views to any new location because they are not projections of
other views.

Using the GET POINT menu, you can do exact drafting to place the view where you want it. For example, to
exactly align one view with another general view, set the view origin using Origin in the MODIFY VIEW menu
and the GET POINT menu. This establishes a reference point for moving the view, so that you can easily place it
anywhere on a drawing relative to another view.

To Move a View

You can move the origin of a view or any point on the view to a new location.

1. Select the view to move and then click the right mouse button.
Click Move. The borders of all views appear, along with handles at the four corners of the border and at the
origin.

3. You can move the view to any location using a drag-and-drop operation.
To move the origin or a corner of a view, select a point close to the view’s handle. To move another point of
the view, select a point on the view. To do exact drafting, use the GET POINT menu commands (such as Rel
Coords and Abs Coords) to specify the exact coordinates, an offset, entity, or vertex.

4. Select the desired location for the view. The view moves to the selected location.

To Switch Views to Another Sheet

You can move drawing views from one sheet of a drawing to another using the Switch Sheet command in the
SHEETS menu.

To Delete a View

To delete views in a drawing, use the Delete View command in the VIEWS menu. You cannot remove a parent
view while its children still exist; you must first remove the child views.
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To Relate Detail Items to a View

Using the Relate View command in the VIEWS menu, you can associate detail items with a specified view in a
multimodel drawing.

About Erasing and Resuming Views

You can erase a drawing view from a drawing without affecting other views, notes, or cross-section arrows.
Erasing and resuming views is an effective technique for improving the view regeneration and repaint times of
complicated drawings.

The following rules apply:

e Ifanote or symbol is attached to the erased view as well as to other views, the system also erases the
leaders attached to the erased view. When you resume the view, the leaders reappear.

* You cannot show dimensions on other views if they appear on the erased view.

e Ifyou erase a parent view of a detailed view containing a local area cross section, the system transforms the
local cross section in the detailed view into a full cross section.

e When you resume a view that was erased from the current sheet, the name of the view appears in the menu
for selection, and the outline of the view appears on the sheet.

e  When you resume a view that was erased from another sheet, the name of the view appears in the menu for
selection. No outline appears. You can still resume the view to a different sheet.

e To control the display of erased view outlines use the environment option Highlight Erased Views. You
can control this option using the configuration file option highlight erased dwg views (the
default is yes).

e Erased view outlines and names are not plotted.

To Erase a View

1. Select a view to erase.
2. Remove any arrows or circles associated with the view (if they are present).
3. Choose VIEWS > Erase View. The system erases the view.

To Resume an Erased View (or Views)

1. Click VIEWS > Resume View.

2. Select view names from the namelist menu. If you want to apply the change to all views, choose Select AlL
To unselect all of the views, choose Unsel All.

3. A cyan border outlines the selected views. Choose Done Sel and the views reappear.
Note: If you switch the view to another sheet and then erase it, you can resume it on the original sheet or on
the current one.

About Using Model Colors in Drawings

You can toggle color display of selected views in Drawing mode between the assigned drawing colors and the
colors used in the original model. Click See Also for more information.

Important Points about Using Model Colors in Drawings

e Views that are displayed in the original model colors are plotted (printed) as such.

e Changing the color of individual geometry does not change the colors in views that display the original
model colors.

e If you change model colors in the associated model, the new model colors are updated automatically in the
drawing, if you set the drawing views to use model colors.

e Hidden lines in drawing views always take on the original standard hidden line color in the model.
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e Any assigned process assembly colors always supercede the setting for using model colors or assigned
drawing colors in the drawing.

To Use Model Colors in Drawing Views

1. On the DRAWING menu (Menu Manager), click Views > Disp Mode > View Disp. The GET SELECT
menu appears.

2. Select a view or views for which you want to use the original model colors, and then click Done Sel.

3. Inthe VIEW DISP menu, click Model Color, and then click Done. The model colors are displayed in the
selected views.

Note: Model colors and assigned drawing colors in a drawing for a process assembly are always superceded by

any existing process assembly colors.

To Use Drawing Colors in Drawing Views

1. On the DRAWING menu (Menu Manager), click > Views > Disp Mode > View Disp. The GET SELECT
menu appears.

2. Select a view or views for which you want to use the assigned drawing colors, and then click Done Sel.

3. Inthe VIEW DISP menu, click Drawing Color, and then click Done. The drawing colors are displayed in
the selected views.

Note: Model colors and assigned drawing colors in a drawing for a process assembly are always superceded by

any existing process assembly colors.

About Modifying Crosshatch

Using the Edit > Properties command, you can modify the crosshatch of detailed views and individual
members of assembly cross-sectional views.

o Assembly cross sections—When modifying an assembly cross section, you can modify individual
components of the assembly intersected by the cross section.

e Detailed views—The crosshatch of a detailed view can follow that of its parent view, or you can make the
detailed view independent of its parent. To modify the crosshatch of a detailed view, you must make the
detailed view independent of its parent by using the Det Indep command in the MOD XHATCH menu.

Note: If you have overlapping crosshatch patterns in your drawing (any combination of crosshatched
cosmetic features, cross-sectional views, or draft cross sections), choose Query Sel from the GET SELECT
menu to select the crosshatch to modify.

Using Smart Default Crosshatch

When you create an assembly cross section, the system automatically applies a "smart" crosshatch pattern on
the parts that provides a superior visual representation of the cross section. Smart crosshatch applies crosshatch
spacing appropriate to the model size and assigns different angles to different parts in the assembly. Smart
crosshatch uses a randomized slant angle between adjacent components, making it easier to distinguish different
parts in assembly drawings and also reducing the amount of time required to clean up drawings with cross
sections and crosshatch.

The following rules apply:
e Smart default crosshatch affects newly created cross-sectional views only. When you retrieve previously

saved drawings, smart crosshatch is not in effect.

e For assembly cross sections, smart default crosshatch applies to both spacing and angle. For part cross
sections, smart default crosshatch applies to spacing only. By default, the angle is 45 degrees for parts.

e To override smart default crosshatch for newly created cross sections, define cross section parameters
default xhatch spacingand default xhatch angle. Cross sections of other surrounding
parts that are not defined adjust accordingly.

e Smart default crosshatch no longer applies after you modify the crosshatch until you create a new view.
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e Modifications made in Drawing mode do not display in Part mode or Assembly mode. Modifications
automatically override smart default crosshatch in a drawing.

Controlling the Spacing and Angle of Crosshatch Using Parameters

By setting parameters, you can control the default spacing and angle of crosshatch in newly created planar and
offset cross sections. To control the display, set the number parameters default xhatch spacing and
default xhatch angle using the SETUP menu or the RELATIONS menu. These parameters only affect
new cross sections—they do not affect cross sections previously created in a part or assembly.

Modifying Crosshatch Characteristics

You can modify the following characteristics of crosshatch, as well as create a filled area and retrieve and save
crosshatch patterns:

e Spacing
e Angle
e Offset

e Line style
e Number of lines

To Modify Crosshatch Patterns

1. Select the cross-sectional views to modify.
2. Click Edit > Properties..
3. Usmg the MOD XHATCH menu on the Menu Manager , do one of the following:
Modify the spacing. Choose Spacing; then choose Half, Double, or Value from the MODIFY MODE
menu. Specify which lines to change by choosing Individual or Overall. The system automatically
scales the crosshatch offset, as well as the spacing, according to the command you choose for spacing.
— Modify the angle. Choose Angle; then choose Individual or Overall from the MODIFY MODE menu.
The system changes only the first line of the pattern. Choose an angle (0, 30, 45, 60, 90, 120, 135, 150)
or Value to specify a different angle.
— Modify the offset. Choose Offset; then type a value for the offset in drawing units.
— Modify the line style. Choose Line Style; then use the Line Style dialog box to change the line style.
— Modify lines in the pattern. Choose Next Line and Prev Line to select a pattern line; then choose Add
Line or Delete Line.
Note: You can also modify crosshatch characteristics to cosmetic features and closed datum curves.

About Creating a Filled Area

You can display cross-sectional drawing views as filled areas (that is, displayed in solid color) by changing the
crosshatch to fill, but you must first create a cross-sectional view. To switch between a hatched and filled cross
section, use the Hatch and Fill commands in the MOD XHATCH menu.

When creating filled cross-sectional drawing views, keep in mind the following rules:

e You can create filled cross sections only in views without clipping. If you attempt to change the crosshatch
of a clipped view (such as a detailed view, broken view), the system issues an error message and does not
allow you to proceed.

e [fa cross-sectional view that you want to fill has detailed views, the system warns you that this view has
dependent children views before allowing you to make the change. The detailed view appears without either
crosshatch or filling; you can then set its crosshatch to be independent of its parent.

® You can modify only planar cross sections to be filled.
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To Create a Filled Cross-Sectional View

1. Select the cross section.

2. Choose Edit > Properties > MOD XHATCH > Fill > Done. .

3. Once you have defined the cross section as filled, you can use Line Style to set the appropriate color for the
filled area, or Save to save it to disk with a ".xch" extension. Later, you can use Retrieve to read it in as a
saved crosshatch pattern.

Saving Crosshatch Patterns

You can assign a name to a crosshatch pattern and save it for later retrieval by using the configuration file
option pro_crosshatch_dir to specify a default directory for crosshatch patterns. Its value is the full path
name of the default directory.

To Save a Crosshatch Pattern

1. Select the view containing the crosshatch pattern that you want to save. For an assembly cross section, you
may need to use Next Xsec or Prev Xsec in the MOD XHATCH menu to select the member.

2. Click Edit > Properties.
3. On the Menu Manager, click Save.
4. Type a name for the crosshatched pattern.

5. If you have not set the configuration file option pro _crosshatch dir, the system saves the crosshatch
pattern in the current directory, giving it the name that you specified and the extension .xch. If you want
to save the pattern in a separate directory containing crosshatch patterns, you must save the pattern first,
and then move it to its new location using operating system commands.

To Retrieve a Crosshatch Pattern

1. Select a cross-sectional view.

2. Click Edit > Properties.

3. Choose MOD XHATCH > Retrieve.
Pro/ENGINEER searches through the current directory, the pro_crosshatch_dir configuration file
option, and the system directory. It then displays a namelist menu that contains the names of any crosshatch
patterns in the current directory, all crosshatch patterns in the default crosshatch directory, and the nine
standard crosshatch patterns provided with Pro/DETAIL.
Note: The selected crosshatch pattern replaces the view’s (or assembly member’s) current crosshatch. When
you change the crosshatch type in the drawing, the model does not reflect it; conversely, if you change it in
a model, its drawings do not reflect it.
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Examples: Crosshatch Patterns
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1 Aluminum.
2 Copper.
3 Electric.
4  Glass.
5 Iron.
6 Plastic.
7  Steel.
8 Titanium.
9 Zinc.

Modifying Assembly Cross Sections

When modifying an assembly cross section, the MOD XHATCH menu displays five additional commands: Excl
Comp, Restore Comp, Next Xsec, Prev Xsec, and Pick Xsec.

e Using Excl Comp and Restore Comp, respectively, you can exclude components of an assembly cross
section from or resume them in the cross-sectional view.

e Using Next Xsec and Prev Xsec, you can navigate through all components.

Pro/DETAIL 247



e Using Pick Xsec, you can select directly in the graphics window instead of navigating through all
components (this command is also available when you are modifying crosshatch in Assembly mode).

To Modify the Display of an Assembly Member in a
Cross Section

Select the cross-sectional view to modify.

Select the appropriate member of the assembly cross section.

Click Edit > Properties.

Choose Excl Comp on the Menu Manager to remove a member from the cross-sectional display, or choose
Restore Comp to resume a member that you have excluded. Surfaces of a member that you have excluded
are displayed as they would be in a noncross-sectional view, unless the excluded member is part of an area
cross section. If you exclude a member of an area cross section, it disappears entirely.

Note: Crosshatch is not affected by HLR and is therefore not obscured by excluded components.

About Modifying Display Mode

Using the Disp Mode command in the VIEWS menu, you can change the display mode (Hidden Line,
Wireframe, No Hidden) of an individual view, edge, or assembly member.

LR =

The configuration file option hlr for quilts controls how the system displays quilts in the hidden line
removal process. If you set it to yes, the system includes quilts in the hidden line removal process. If you set it
to no, the system does not include quilts in the hidden line removal process.

To Modify the Display Mode of Individual Views

1. Choose VIEWS > Disp Mode > View Disp.

2. Select views to modify; then choose Done Sel.

3. From the VIEW DISP menu, choose one of the following:
—  Wireframe—Sets the display mode to wireframe

— Hidden Line—Sets the display mode to hidden line

— No Hidden—Sets the display mode to no hidden

— Default—Sets the display mode as set in the Environment dialog box

— QIt HLR—Includes quilts in the hidden line removal process (except cross-sectional views)

— No QIt HLR—Excludes quilts from the hidden line removal process in all views (except cross-
sectional views)

— Tan Solid—Displays tangent edges

— No Disp Tan—Turns off the display of tangent edges

— Tan Ctrin—Displays tangent edges in centerline font

— Tan Phantom—Displays tangent edges in phantom font

— Tan Dimmed—Displays tangent edges in dimmed color

— Tan Default—Sets the display of tangent edges as set in the Environment dialog box

4. Choose Done. The system updates the selected views.
Note: Once you have set the display mode for a specific view, it remains set regardless of the setting in the
Environment dialog box, unless you choose Default in the VIEW DISP menu.

Disallowing the Selection of No Hidden Edges in
Drawings

With complex models, it is sometimes difficult to find the exact edge you want to select. When you are in No
Hidden display mode, you can disallow selection of edges in drawings while using Query Select.
The configuration file option select hidden edges in dwg enables you to disallow the selection of
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No Hidden edges in drawings. This configuration file option disallows the selection of No Hidden edges by
rejecting edges behind the first surface in the viewing plane. The following requirements apply:
e Selection is disallowed for drawing views in No Hidden display mode only.

e View regeneration is required on cross-sectional views.
e You can disallow the selection of edges in general and cross-section views.

To Modify the Display of a Detailed View

After making a detailed view independent of its parent, you can specify the circle representation of a detailed
view, as well as change the type of entity around the parent view.

Click Modify View > DISP MODE. The DISP MODE menu appears.
Click View Disp.

Select a detailed view on the screen; then choose Done Sel.

Click View Disp > Det Indep.

Choose the appropriate specifications and then click Done.

To Specify the Circle Representation of a Detailed
View

Click VIEWS > ADD VIEW > Detailed and then click Done.
Select a center point location for the drawing view.

AR S R

Type a scale dimension for the view and then click ﬂ

Select the center point for detail on an existing view.

Type a name for the detailed view.

Sketch the spline around the area that you want to detail.

Click one of the following from the BOUNDARY TYPE menu:

Nk D

— Circle—Draws a circle in the parent view for the detailed view.
— Ellipse—Draws an ellipse in the parent view for the detailed view to closely match the spline, and
prompts you to select an attachment point on the ellipse for the view note.

— H/V Ellipse—Draws an ellipse with a horizontal or vertical major axis and prompts you to select an
attachment point on the ellipse for the view note.

— Spline—Displays the actual spline boundary on the parent view for the detailed view, and prompts you
to select an attachment point on the spline for the view note.

— ASME 94 Circ —Displays an ASME standard compliant circle in the parent view as an arc with
arrows and the detailed view name.

8. Except for ASME 94 Circ, choose a location for the detailed view note. The note in the parent view is
attached to the chosen boundary entity and places another detailed note below the detailed view.

9. The parent view appears with the specified boundary. You can modify the detailed view boundary and
reference point on the parent view by clicking VIEWS > Modify View > Boundary and selecting the
detailed view.

Note: You can convert detail view boundary types to an ASME 94 circle. However, once a view is displayed in
ASMEY4, it cannot be changed.

To Change the Type of Entity Around the Parent
View

1. Click VIEWS > Modify View > Boundary.

2. Select a detailed view.

3. From the VIEW BNDRY menu, choose one of the following:
— Circle—Draws a circle in the parent view for the detailed view. Creates the detailed note in the parent
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view attached to the chosen boundary entity and places another detailed note below the detailed view.

— Ellipse—Draws an ellipse in the parent view for the detailed view to closely match the spline, and
prompts you to select an attachment point on the ellipse for the view note.

— H/V Ellipse—Draws an ellipse with a horizontal or vertical major axis and prompts you to select an
attachment point on the ellipse for the view note.

— Spline—Displays the actual spline boundary on the parent view for the detailed view, and prompts you
to select an attachment point on the spline for the view note.

The system modifies the entity around the parent view as specified.

To Change the Edge Display of Detailed Views

If the edge display of a detailed view is the same as that of its parent view, you cannot use the Edge Disp
command in the DISP MODE menu to modify it independently of the parent. To change the edge display of a
detailed view, choose Edge Disp and select the parent of the view. You must choose Regen View from the
Pro/ENGINEER View menu (nof the Repaint command) to update the display of the detailed view properly
after modifying the parent view.

Note: You can change on/y the edge display of the detailed view if it is different from that of its parent view.

Manipulating Edge Display

Using commands in the VIEWS > DISP MODE > Edge Disp menu, you can set the display mode for individual
edges that are usually visible on the screen. To modify edge display, clear the Wireframe command in the
Environment dialog box. A/l model edges must be visible.

You should use the Edge Disp command in the DISP MODE menu to make minor cosmetic changes, and to
unblank selected hidden edges in views with the display mode set to No Hidden. You cannot use it to erase the
following items:

e Boundaries of all cross sections

e Outside edges intersecting clipped splines

e Cosmetic threads in drawing views (choose Show and Erase from the View menu; then click the Cosmetic
Feature button in the Type box of the Show/Erase dialog box)

o Silhouette edges, except for the following:
— Silhouette edges of cylinders and cones

— Silhouette edges of torii that are arcs, that is, the axes of the torii are either parallel or perpendicular to
the screen

— Silhouettes of general surfaces of revolution whose axes are parallel to the screen

Note: If you erase one silhouette edge, the system erases all silhouette edges that belong to the same surface
as well.

Selecting Entities

When the configuration file option "selection_of removed entities" is set to "yes," you can select entities and
activate them for performing such actions as showing dimensions and placing items on a layer. You can also
activate entities for choosing features that are in front of a cross section (planar or offset), have been removed
via Z-Clipping, or have been erased using Erase Line in the EDGE DISP menu.

Note: If you have set the view display mode to Wireframe, the system does not erase or redisplay its edges
until you change the view display to Hidden or No Hidden.

Tangent Lines

Using commands in the TAN EDGEDISP menu (a submenu of the EDGE DISP menu), you can select certain
tangent lines to display in drawing views, while erasing others:

e Tan Solid—Displays selected tangent edges regardless of the tangent edge display setting in the
Environment dialog box. A tangent edge is the intersection at which two surfaces become tangent. For
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example, a round always produces a tangent edge with the surfaces it intersects.

Tan Ctrln—Displays selected tangent lines in the centerline style regardless of the tangent edge display
setting in the Environment dialog box.

Tan Phantom—Displays selected tangent lines in the phantom line style regardless of the tangent edge
display setting in the Environment dialog box.

Tan Dimmed—Displays selected tangent edges in dimmed color.

Tan Default—Displays tangent edges according to the setting in the Environment dialog box.

Note: The Erase Line and No Hidden commands in the EDGE DISP menu take precedence over the TAN
EDGEDISP menu commands. If you choose Erase Line or No Hidden, the selected tangent edge does not
appear.

If you set the drawing setup file option hidden tangent edges to dimmed, you can plot hidden tangent
edges in a view using Pen 7. The lines appear dashed in the same color as the dimmed visible tangent edges.
However, you must select Hidden Line or No Hidden Line from the Display Style list in the Environment
dialog box. If you set this option to erased, the system removes all hidden tangent edges automatically from
the screen and the plot.

To Modify Display of Individual Edges

1.

Choose VIEWS > Disp Mode > Edge Disp.

2. Choose one of these commands from the EDGE DISP menu:

— Erase Line—Erases a visible line from the view display

— Wireframe—Shows a selected edge in wireframe style

— Hidden Style—Shows a selected edge in hidden line style

— Hidden Line—Shows a hidden edge as a hidden line

— No Hidden—Removes a hidden edge from view display

— Default—Displays the edge using the current environment setting

Specify the selection technique by choosing one of these commands from the EDGE DISP menu:

Choose GET SELECT > Pick Many to select the edges. The system selects coincident edges covered entirely
by the top edge.

Choose ERASE DISP > Highlight Mod to highlight all modified edges of the model.
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Examples: Types of Edge Displays

‘ ]

1 Hidden.

2 Erase.

3 No Hidden.
4  Hidden Style

Manipulating the Display of Assembly Members

You can manipulate the display of assembly members by changing their hidden line display, changing their line
style, or blanking and unblanking them.

If you choose Member Disp from the DISP MODE menu, the MEMB DISP menu displays the following
commands:

o HLR Display—Changes hidden line display of selected components, overriding the view display.
e Style—Modifies the line style of selected assembly members.

¢ Blank—Removes selected assembly members from the display.

e Unblank—Returns previously blanked components to the display. Temporarily outlines in blue only the
views containing blanked components. Select the appropriate view in order to highlight blanked components
for selection. You can also select components from the Model Tree.

You can also specify where you want to effect the changes by choosing Picked View, This Sheet, or All Views
from the MEMB DISP menu.

Changing the Hidden Line Display

You can change the hidden line display of selected components (overriding the view display), using the HLR
Display command in the MEMB DISP menu. You can set the display of selected components on a per view or
per sheet basis, or in all views.

If you choose Hidden Line from the HLR DISPLAY menu, and then select a component, the results are as
follows:

e Ifyou have set the view to No Hidden, the system shows the component’s hidden lines.
e Ifyou have set the view to Hidden Line, it does not affect the component’s hidden line display.
e Ifyou have set the view to Wireframe, it does not affect the component’s hidden line display.
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If you choose No Hidden from the HLR DISPLAY menu, and then select a component, the results are as
follows:

e Ifyou have set the view to No Hidden, it does not affect the component’s hidden line display.
e Ifyou have set the view to Hidden Line, the system does not display the component’s hidden lines.
e Ifyou have set the view to Wireframe, it does not affect the component’s hidden line display.

If you have selected one component, or all of the components that you have selected have the same setting, the
HLR DISPLAY menu indicates the setting by highlighting the command in the menu. If you have selected more
than one component, but they have different settings, the system does not highlight a command in the HLR
DISPLAY menu.

Note: The setting assigned by the Edge Disp command takes precedence over any setting assigned by the
HLR Display command, but the setting assigned by the HLR Display command takes precedence over any
setting assigned by the View Disp command.

Display of Pipe Centerlines
If you set the drawing setup file option hlr for pipe solid cl to yes, hidden line removal affects pipe
centerlines. If you set it to no (the default), it does not.

Note: The hlr for pipe solid c1 option operates only on pipes created in Pro/PIPING, not on pipe
features in a part.

To Modify the Line Style of Selected Assembly

Members

1. Click VIEWS > Disp Mode > Member Disp > Style.
2. Select the assembly components; then choose Done Sel. You can use Sel By Menu in the GET SELECT
menu to select parts or subassemblies for modification.
3. Change the style by selecting a command from the MEMB STYLE menu:
— Standard—Displays the selected member view in solid line style.

— PhantomOpque—Displays the selected member view in phantom line style.

— PhantomTrnsp—Displays the selected member view in phantom line style, but the hidden line
removal process does not affect it.

— User Color—Creates a user-defined color and assigns it to an assembly member.
4. Choose Done.

Examples: Modified Line Styles of Selected
Assembly Members

If you set the view using No Hidden, the system hides the objects behind it if you display them in the
PhantomTrnsp, PhantomOpque, or Standard style.
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Examples Using Standard Font

Standard —— %

Stand

PhantomTrnsp

PhantomOpque

all Standard

If you change the line style of a selected member to PhantomOpque, it appears in phantom line font. If you set
the view using No Hidden, the system hides the objects behind it if you display them in the PhantomOpque,

PhantomTrnsp, or Standard style.
Examples Using PhantomOpque Style

all PhantomOpque PhantomOpque .[ _—_——7\
[ I = 7\
| _.._'YZZ;'\'; : "_-_—f —‘:»—-—-3
T \ R
S PhantomTrnsp
PhantomOpque A 7\
.\ .
___'x>
\-_.._.._..‘S' Standard

If you change the line style of a selected member to PhantomTrnsp, it appears in phantom line font. If you set

the view using No Hidden, the system hides the objects behind it if you also display them in the

PhantomTrnsp style. However, if you display the objects in the PhantomOpque or Standard style, it does

not affect the hidden line removal process, so you can see their edges.
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Examples Using PhantomTrnsp Style
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About Drafting in Drawing Mode
In Draft mode, you can do the following:

e (Create construction geometry

e Chain geometry

e Make dimensions of draft entities associative

e Create draft geometry

e Define draft cross sections

e Modify, copy, and move draft geometry

e Obtain information about draft geometry

You can add draft entities to a drawing at any time. Pro/ENGINEER considers the following to be draft entities:

o Entities created using the Skecth menu (for example, 2-D draft geometry).

o Entities selected during the creation of the entity (for example, attaching a geometric tolerance symbol to a
draft dimension).

o Entities read in to a drawing from an IGES, DXF, or SET file.
e Annotations placed without any associativity to a Pro/ENGINEER model (for example, a free note).
Draft Geometry

Using commands in the Sketch menu, you can create various geometry types: lines, circles, arcs, splines,
ellipses, points, and chamfers.

To Create a Construction Line

Construction geometry entities are lines and circles that you can use to locate and create 2-D draft geometry.
They appear on the screen in phantom font, but you can transfer them through IGES files and plot them.

1. Click Sketch > Construction Line.
2. Using the Construction Line menu, do one of the following:
— Choose Horiz or Vert to create a horizontal or vertical line. Use commands in the GET POINT menu to
locate the lines.
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— Choose Crossed Pair to create two construction lines perpendicular to each other at a given angle. Use
the GET POINT menu to select a point on the drawing; then type a rotation angle. The system creates
two construction lines, with both lines passing through the selected point. One of the lines is at the
specified angle; the other is perpendicular to the first.

— Choose Angle to create an angled line. Use the GET POINT menu commands to locate the pivot point of
the line; then type an angle for every line that you want to create. Each angle is absolute—a positive
value for counterclockwise and a negative value for clockwise. Press ENTER on an empty line to quit.

— Choose Offset to create a line offset from another. Select the line from which to offset; then type an
offset value. A positive value offsets in the direction of the arrow; a negative value reverses the
direction. Each offset that you type after the first one is relative to the line you just created. Press
ENTER on an empty line to quit.

— Choose Pnt/Angle to create a construction line through a point and at a specified angle to a selected
entity. Use the GET POINT menu to select a point that the construction line will pass through. Then
select an entity that you want as the angular reference. Type an angle between —360° and 360°. The
construction line at the specified angle is created counterclockwise from the selected entity.

Tip: Creating a Construction Line

Note: You cannot offset a construction line from an axis line.

Example: Construction Lines

g ~

Angle line.

Vertical line.

Angle line.

Horizontal line.

Offset direction arrow.
Perpendicular lines.
Offset line.

~N N B W N~
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To Create a Construction Circle

1. Click Sketch > Construction Circle.
2. Use commands in the CIRCLE menu to create a circle.

Example: Construction Circles
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1 This circle is filleted to two lines.
2 This circle is centered in the drawing and passes through the center of the other circle.

To Chain Entities During Sketching

You can chain geometry to create a series of entities by selecting points on previous entities as starting points
for new ones.

To initiate chaining, click Sketch > Chain. To end chaining, choose End Chain, or exit the DRAFT GEOM
menu. When chaining is in effect, a small yellow square indicates the point from which the chain continues.
When sketching entities while chaining is in effect, if you select points with the left mouse button, the chain
continues; if you select them with the middle mouse button, the system creates an endpoint and the chain
pauses, or stops at that point. If you have finished creating chained draft entities, you can choose End Chain or
continue making draft geometry. The newest entity begins where you paused at the end of the last chain. To
begin a different set of chained entities, choose End Chain to finish the first chain and choose Start Chain to
start a new one; otherwise, the new chain of draft entities simply continues from the previous one.

Chaining Entities During Sketching

Chaining geometry affects only the creation of the entities. Once you have created them, each entity exists
independently of any others, regardless of any shared center points or endpoints.

You can chain together circles and ellipses when they use the same centers. Once you have established the
center of the first ellipse or circle of the chain, the system uses it for every circle or ellipse that follows, until
you end the chain.
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Examples: Chaining Geometry

Chaining geometry using endpoints.

Start. Choose Line and select first point.
Pick 2.

Pick 3. Then select Arc and continue.
Pick 4.

Pick 5.

Pick 6.

Pick 7. Then select Line and continue.
Pick 8.

Pick 9.

O 0 3 O i A W N —

Chaining geometry using centers.

1 Start. Select Circle and pick center.
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2 Pick2.
3 Pick3.
4  Pick 4. Then select Ellipse and continue.
5 Pick5.
6 Pick6.

To Create a Line

Click Sketch > Line to open the Line menu. Using commands in the Line menu, you can sketch the following
types of lines continuously as a chain or as individual entities:

e Horizontally or vertically between any two points

e At an angle measured from the x-axis (0)

e Tangent to a curve at its second endpoint

e Parallel or perpendicular to a specified line

e Normal to a curve

e Tangent to an arc or a spline

e Tangent to two circles or splines

e Tangent to a curve and parallel or normal to a reference line

To Create a Circle

Click Sketch > Circle to open the Circle menu. Using commands in the Circle menu, you can create a circle by
doing the following:

e Locating its center and defining a point

e Making it tangent to other entities

e Locating its center and defining a point as the tangency with another entity

e Specifying its center and the circle radius or diameter

e Making it tangent to three other entities

e Making it tangent to two other entities, with a specified radius

e Using any three points that lie on the circle

To Create an Arc

Click Sketch > Arc to open the Arc menu. Using commands in the ARC menu, you can create an arc by doing
the following:

e Selecting an endpoint that is tangent to another open entity (that is, not a circle or an ellipse)

e Selecting any three points that lie on the arc

e Using the arc center and two endpoints

o Using the arc center, a start point, and an angle that strokes the arc from the start point in a counterclockwise
direction

e Making it tangent to three other entities
e Making it tangent to two other entities, with a specified radius

To Create a Spline

Using the Spline command in the Sketch menu, you can create a spline by defining the start point and any
number of interpolation points.

1. Click Sketch > Spline.
2. Using the GET SELECT menu, select the start point and then any number of interpolation points to define the
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spline.
3. To end the spline at the last selected point, press the middle mouse button.

To Create an Ellipse

Using commands in the Sketch > ELLIPSE menu, you can create ellipses by doing the following:

e Selecting the center, a point to locate the major axis, and an angle that rotates the geometry about the major
axis.

e Defining the length and orientation of the major axis and specifying the rotation angle about the major axis.

e Locating the center, a point locating the major axis, and a point locating the minor axis.

e Selecting two points to define the major axis, and a third point anywhere else on the ellipse.

e Using a rotation angle about the major axis. The angle represents what you see of a circle after you have
rotated it; the more you rotate it, the less you see of it. For example, if you type 0 degrees, the system
creates a circle; if you type 90 degrees, it creates a line.

Example: Creating an Ellipse

QO 7/

1 0 degrees.

2 30 degrees.
3 60 degrees.
4 90 degrees.

To Create a Fillet

A fillet rounds the corner of a selected line intersection to a given radius.

1. Click Sketch > Fillet.
2. Click a point on each line where you want the fillet to start.

3. Enter a radius or accept he default at the prompt line.

To Create a Chamfer

Chamfers are lines that intersect and trim other lines. The system calculates the intersection of the lines, so the
lines do not have to actually touch; it applies chamfer dimensions at this intersection point. When it creates a
chamfer, it discards the chamfered portion of the lines. Using commands in the Sketch > Chamfer menu, you
can create chamfers by doing the following:

e Creating a line between two other lines 45 degrees from the first selected line and of dimension "d" along
both selected lines

e Using the same dimension value along both of the selected lines

e Using a different chamfer dimension for each selected line

e Using a chamfer dimension at an angle to the reference entity
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Selecting Draft Entities for Sketching

When selecting points for sketching in Pro/DETAIL, you can select draft entities or model geometry. To define
the endpoints and centers, use commands in Abs Coord to locate a point relative to the current drawing
coordinate system.

The GET POINT Menu

e Pick Pnt locates a point anywhere on the screen.
e Vertex locates a point at the endpoint as well as at the midpoint of an open curve (line, arc, spline), the
center of a draft arc or circle, or the intersection between two entities.

¢ On Entity locates a point anywhere along an entity (draft or model). The system places the point on the
selected entity closest to where you selected. If you select the end of the entity, it locates the point at the
endpoint.

e Rel Coords locates a point relative to the last point that you selected using specified x- and y-coordinate
values in drawing units.

Tip: Selecting Points for Sketching

Use the configuration file option draw_points in model units to define the current draft view’s
coordinate values as model units rather than drawing units. The GET POINT menu uses the scale of the draft
view and the draft view’s model units for relative and absolute coordinate entry and display in the message area.

To Select Several Draft Entities

You can select several draft entities for modification simultaneously by choosing Pick Many from the GET
SELECT menu, followed by Pick Box. If you choose Inside Box from the submenu, you can only select items
that are completely within the box. If you choose Across Box, you can select all draft entities that are partly or
completely within the box. Use the left mouse button to specify opposite corners of the box, press the middle
button, and press the left button to complete the action.

Tip: Selecting Several Draft Entities

If you set the configuration file option dwg_select across_pick_ box to yes, the system highlights the
Across Box command by default when the PICK MANY menu appears. If you set this option to no, it highlights
the Inside Box command by default.

About Draft Dimensions

Draft dimensions and the geometry that they reference are completely independent of each other, unless
associative dimensioning is in effect. You can make the dimensions of draft entities associative—so that the
system updates them to reflect changes in draft entities—by setting the drawing setup file option

associlative dimensioning to yes (the default value). The system considers the parent/child
relationship between draft entities and their associative dimensions, and performs the following procedures on
them:

e Deletion

e Switching to another drawing sheet
e Translation

e Rotation

e Rescaling, including change of drawing format size

Notes:
The system assigns associativity status to new dimensions only.
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Draft dimensions are driven dimensions. When the scale of draft entities changes, the values of their
associative dimensions also change.
If you select a draft entity for any of the preceding procedures, you implicitly select all of its dimensions. For all
procedures except deletion, if you select a dimension, you also select the parent entity and all of its other
dimensions. If you have implicitly selected a dimension by selecting an entity:

o Unselecting the entity unselects the dimension as well, unless the dimension was also selected as another
entity’s dimension, or by itself.
* You cannot unselect the dimension until you unselect the entity itself.

Pro/ENGINEER considers draft groups for the preceding procedures to be parents of all of the dimensions of
their entities.

Draft Scale Independent of View Scale

Draft scale is completely independent of view scale. Although a draft entity associated with a view appears as a
different size on the screen, when the scale of that view changes, the dimension values of the draft entity do not
change in any way.

Examples: Drawing Format Change and Moving
Draft Entities

The following figure shows that when you reduce the size of the drawing by half, the system scales the views
and draft entities to fit, although they are the same size on the screen. The text height does not change, but the
system halves the draft cross section’s dimension value.

Effects of Drawing Format Change on Associative Draft Dimensions

@5.45 B2.13
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Moving Draft Entities Without Associative Dimensioning
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f
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1  The system translates the draft cross section vertically, but since associative dimensioning was not set, it
leaves behind the diameter dimension.

2 Model view.

About Obtaining Geometry Information

To identify draft geometry on a drawing, choose Drawing from the Pro/ENGINEER Info menu, followed by
Highlight by Attributes. To obtain information about specific draft entities, choose Measure Draft Entities...
from the Pro/ENGINEER Info menu.

To Measure a Distance

To measure the distance between two parallel lines, two points, or a point and a line, choose Distance from the
Type container; then use the selection tools in the Definition box to select two entities. In the Results box, the
system displays the distance measurement.

To Measure an Angle

To measure the angle between two selected lines, choose Angle from the Type container; then use the selection
tools in the Definition box to select two lines. In the Results box, the system displays the angle measurement.

To Determine the Slope of Two Entities

To determine where the slope of two selected entities are equal, choose Tangent Point from the Type
container; then use the selection tools in the Definition box to select the entities. In the Results box, the system
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displays the angle of slope at the tangency points, the distance between the two tangency points, and the
coordinates of the tangency points.

To Determine the Intersection Point of Two Entities

To determine the intersection points of two selected entities, choose Intersection Point from the Type
container; then use the selection tools in the Definition box to select the entities. In the Results box, the system
displays the angle of slope at the

intersection point for both entities and the intersection coordinate values (to the current drawing coordinate
system).

About Showing Dimensions in a Drawing

Using the View > Show and Erase dialog box, you can display model dimensions in a drawing as well as show
dimensions for a range of features. To show dimensions in an isometric view, set the drawing setup file option
allow 3D dimensions to yes. The location of displayed model dimensions depends on the view
orientation. Note the following special cases:

e When the sketching plane of an extruded or revolved section is neither parallel nor normal to the screen, the
system still shows the linear dimensions of the section that are parallel to the screen.

e For clipped views, Pro/ENGINEER rotates the dimensions of a revolved section up to 180 degrees to bring
them into the view outline.

e When the system cannot show the dimensions of a normal-to-trajectory sweep on the sketching plane, it
shows them on the other end or, if that is impossible, on some intermediate plane.

e Pro/ENGINEER does not show the dimensions (in a view) of features that you have suppressed using By
View. If possible, it displays them in another view.

To Display Model Dimensions in a Drawing

Click View >Show and Erase. The Show/Erase dialog box opens.

In the Show/Erase dialog box, click Show.

Click Dimension or Reference Dimension in the Type box.

Select a button in the Show By box to specify where to show the dimensions in the drawing.
Click Preview to view the changes. Select With Preview to specify the items to show.
Click Close.

To Specify Dimensions for a Range of Features

Click View >Show/Erase. The Show/Erase dialog box opens.

In the Show/Erase dialog box, click Show.

Click Dimension in the Type box and Feature (or Feat & View).

Choose GET SELECT > Sel By Menu. Select the model for which you want to show the range of feature
dimensions.

Choose SPECIFY BY > Number Range.

6. Type the lower limit and upper limit of the range of feature numbers.

Displaying Dimensions in Detailed and Partial Views

A dimension that references nonsolid geometric features (axes, datum points, datum planes, and so forth) can be
present in a detailed or partial view only when the following requirements are satisfied:
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o At least one of the entities being dimensioned must be within the spline boundary.

e This entity must also be within the view boundary of the view—the view boundary is defined by the solid
geometry of the part. (Nonsolid geometric features are not considered to be solid geometry.)

Check that these requirements are met before you change a view to a detailed or partial view, or dimensions will

264 Pro/DETAIL



disappear from the new view.

The drawing setup file option clip dimensions affects the display of dimensions in detailed views. When
you set it to yes, dimensions that are completely outside of the view boundary do not appear. Dimensions that
cross the view boundary appear, and the leader that seems to have no geometric reference appears with a double
arrow (>>). To change the arrow style, set the default arrow style of clipped dimensions by specifying a value
for the drawing setup file option clip dim arrow_ style (double arrow is the default).

Showing Dimensions in Assembly Drawings

In assembly drawings, you can display the parameters of assembly features and all assembly components;
however, you cannot show the dimensions of subassemblies. The dimensions in an assembly drawing are
visible only at the assembly level. You must have the assembly from which a drawing was created in session in
order for the dimensions to appear for modification.

Note: When you use automatic replacement to replace an assembly model with another model of the same
family, the equivalent dimensions appear if the system shows dimensions in the assembly drawing on a
component that you replace with the new instance. If you use manual replacement, it does not preserve the
dimensions.

To Show Dimensions in an Assembly Drawing

1. Click View > Show and Erase. The Show/Erase dialog box opens.
2. Click Show and then click Dimension in the Type box.
3. To display the dimensions of a part without showing the dimensions of a merged feature, do one of the
following:
— Select Part from the Show/Erase dialog box and select the part on the screen.

— Choose GET SELECT > Sel By Menu to select dimensions of the original part from the namelist menu.

4. To display the dimensions of a merged feature in an assembly drawing, select Feature in the dialog box and
choose GET SELECT > Query Sel to select the feature of the part that was used for reference or copy.

To Erase Dimensions from a Drawing

You can remove dimensions from the display by erasing them, but this does not delete them from the model.
Pro/ENGINEER does not recall the location of a dimension after it erases it. If you show the dimension again, it
might not appear at the same location as before.

Click View > Show and Erase. The Show/Erase dialog box opens.
In the Show/Erase dialog box, click Erase.
Click Dimension or Reference Dimension in the Type box.
In the Erase By box, select one of the following:
— Selected Items—Erases specified dimensions.

PO =

— Feature—Erases dimensions in the selected feature.

— Feat & View—Erases dimensions in the selected feature that belong to the selected view.
— Part—Erases dimensions associated with a part at the selected assembly location.

— Part & View—Erases dimensions associated with a part in a view.

— View—Erases all dimensions in the selected view.

— Erase All—Erases all dimensions in the drawing.

To Show and Erase View Notes

To erase and show view notes (detail view name, view scale, cross section name, graph feature view name), use
the Show/Erase dialog box.
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To Show Model Notes in a Drawing

Using the Show/Erase dialog box and (optionally) the Model Tree Window, you can show model notes in
drawings. Their location within the drawing is dependent upon their actual placement in the model. Unplaced
notes appear in a default location when you show model notes in the drawing. You can use the text of a model
note to create a drawing note by reading in a model note from a file.

Model Notes in Drawings
When working with model notes in drawings, consider the following:

e Once you show a model note in a drawing, the system does not make changes to its attachment or location if
you change either in the model. Also, if you make any changes to the note’s attachment or location in the
drawing, the system does not make those changes in the model.

* You cannot access drawing-level notes in models.
e When you modify the contents of a model note in a drawing, the model changes.

e To disallow modifications to model notes, you must set the configuration file option
draw_models_read onlytoyes.

About Creating Dimensions

In Drawing mode, you can create the following types of dimensions:
Driven Dimensions

Driven dimensions are derived directly from the model dimensions as laid out in sketcher. Changes in the model
drive their values as shown in the drawing.

When working with driven dimensions, keep in mind the following:

e Driven dimensions appear in the drawing in which they were created, but the system stores them with the
model. You cannot see them in other drawings, or in Part or Assembly mode.

* You can modify the number of digits (decimal places) in driven dimension values, but the rounded
dimension value does not drive the model geometry. Driven dimensions do reflect changes to part or
assembly geometry, but you cannot modify their values from the drawing.

Draft Dimensions

A dimension shown between two draft entities (for example a sketched object or construction line) or between a
model object and a draft object is called a Draft dimension. The value is based on the draft scale (specified by
using the drawing setup file option draft scale) and the actual drawing sheet units and size.

Draft scale is the relation between what the entity size appears to be versus its actual dimension. For example,
assume that an edge of a part is 4 inches long:

o [fthe draft scale is 1.0, the entity appears to be 4 inches in the drawing.

o [fthe draft scale is 4.0, the entity appears to be 16 inches in the drawing (it appears to be four times larger
than it actually is).

e If'the draft scale is 0.5, the entity appears to be 2 inches in the drawing (it appears to be one-half the size it
actually is).

Note: Regular nonassociative draft dimensions do not change with draft scale.

Associating a dimension with a draft entity links the two together so that the dimension reflects changes to the

entity. When you have made a draft dimension associative (using the drawing setup file option

associative dimensioning), the draft dimension’s value changes if you change the draft scale, move

the entity, and trim and intersect the entity. The system reflects the changes to the draft scale in the value of the

draft dimension when it regenerates the drawing and creates new draft entities at the scale value.
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Reference Dimensions

While in Drawing mode, you can create reference dimensions using model geometry in a drawing view. The
system saves dimensions with the model and associates them with the view in which they were created. All
reference dimensions have the notation "REF" to distinguish them from other dimensions. The system encloses
them in parentheses if you set the configuration file option parenthesize ref dimto yes.

Saving Dimensions to the Part or to the Drawing

When you create dimensions in Drawing mode, the configuration file option
create drawing dims_ only determines whether the system saves them in the associated part or in the
drawing itself.

When set to yes, it saves all new dimensions created in the drawing in the drawing only.

When set to no, (the default), it saves all new model dimensions (not draft dimensions) created in the drawing to
the associated part or assembly. Draft dimensions are still saved to the drawing.

The setting should depend on your particular work scenario. If you are using Intralink, if the dims are stored in
the model, the model will be marked as modified and will have to be re-submitted back to intralink. To avoid
this every time you reference a model for drawing, you can set the option to yes.

Alternately, if you want to use a set draft datum in a gtol attached to a dimension, the dimension has to be stored
in the model, so you would set the option to no.

To Create a Driven or Reference Dimension

1. Click Insert > Dimension or Reference Dimension. (Dimension is the driven dimension.) Use the fly-out
menus to specify use of New References, a Common Reference, or an Ordinate dimension. The
ATTACH TYPE menu appears on the Menu Manager.

2. Select an edge, an edge and point, two points, or a vertex using the ATTACH TYPE menu commands:

— On Entity—Attaches the dimension to the entity at the pick point, according to the rules of creating
regular dimensions.

— Midpoint—Attaches the dimension to the midpoint of the selected entity.

— Center—Attaches the dimension to the center of a circular edge. Circular edges include circular
geometry (holes, rounds, curves, surfaces, and so forth) and circular draft entities. If you select a
noncircular entity, attaches the dimension to the entity, as does On Entity.

— Intersect—Attaches the dimension to the closest intersection point of two selected entities.

— Make Line—References the current x- and y-axes in the orientation of the view of the model.

Note: To create an arc-length driven dimension, select the ends and the middle of an arc; then choose ARC
DIM TYPE > Arc Length.

3. Locate the dimension. If you have selected two arcs or circles (the system highlights each arc or circle in
turn), use the ARC PNT TYPE menu to do one of the following:

— Choose Center to create a dimension between the centers of the arcs, ellipses, or circles.

— Choose Tangent to create a dimension between the circle, arc, or ellipse edges—the tangency closest
to where you selected.

4. From the DIM ORIENT menu, choose one of these commands:

— Horizontal—Reflects the horizontal distance.

— Vertical—Reflects the vertical distance.

— Slanted—Reflects the shortest distance between two attachment points (available only when the
dimension is attached to points).

— Parallel—Reflects the distance in the direction parallel to another entity.

— Normal—Reflects the distance in the direction normal to another entity.
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Using a Common Reference

Use Common Ref to create standard dimensions from a common reference. However, to use a common
reference, the last dimension that you created must have more than one reference object. If, for example, the last
dimension that you created is an angular dimension measuring the spanning angle of an arc, there is only one
reference object (the arc), so the system does not use it as the first reference for the next dimension. The same
condition applies to draft entities.

To Create a Standard Dimension from a Common
Reference

1. Click Insert > Dimension or Ref Dim > Common Ref.
2. The system highlights the first reference of the last dimension that you created and uses it as the first
reference of the next dimension that you create.

Example: Creating a Standard Dimension from a
Common Reference

d1 1

o O

1 A common reference.

Using Driven and Reference Dimensions in
Relations

You can use driven (or "ad" type) and reference dimensions on the right side of relations only (to drive the
value of other dimensions or parameters). If you have used a driven dimension in a relation to drive a model
dimension, the model dimension also changes until you regenerate the model in Drawing mode. You can use
reference dimensions to drive model dimensions because they regenerate in Part or Assembly mode; however,
you should not use driven dimensions to drive model dimensions because incorrect model dimensions might
occur when you change the model in Part or Assembly mode. To add relations, use the Relations command in
the DWG SET UP menu. Driven dimensions can reference a coordinate system.

Adding Jogs to Ordinate Dimensions

You can add a jog to an ordinate dimension when you are creating a baseline reference; however, you must
choose this command before selecting the dimension for modification. You can also add a jog to an existing
ordinate dimension.

To Create a Jog

1. Click Edit> Lin to Ord.

2. Select the dimension to convert from linear to ordinate. The dimension disappears from the screen.

3. Click One Jog.

4. Make two pick points corresponding to the first and second knuckle in the ordinate dimension witness line.
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The system always locates the dimension text the same distance from the model as it was in the linear
dimension, so you should select points along the witness line and between the dimension text and the model.

To Create a Coordinate Dimension

AP e e

Click Insert > Coordinate Dimension....

Use the GET SELECT menu to select model geometry to which to attach the coordinate dimension leader.
Select an edge, entity, or axis where the coordinate dimension is attached.

Select the location of the dimension symbol.

Select the appropriate x- and y-dimension. The system creates a coordinate dimension with these values.
Note: You cannot select ad, dd, and ordinate dimensions as coordinate dimensions.

To Move a Dimension Between Views

1.

2.

3

Select a dimension to move. To select several dimensions at one time you can use Pick Many in the GET
SELECT menu.

Choose Edit > Switch to View.

Select a view.

Notes: If Pro/ENGINEER cannot display a dimension in the selected view, it issues a warning and does not
move it.

When you select a patterned feature dimension, all dimensions of the pattern move.
When you switch the view of an ordinate baseline, all ordinate dimensions that reference it also switch views.

To Modify the Arrow Style of Leaders

Use Arrow Style to modify the arrow style of leaders for dimensions, notes, 3-D notes, geometric tolerances,
symbols, or balloons. For example, you can change an arrow to a dot or a box.

1.

Click Format > Arrow Style.

2. Select the arrow of the entity to modify, and choose one of the arrow styles from the ARROW STYLE menu.

Note: The drawing setup file option draw_arrow_style controls arrow style for all detail items
involving arrows, including leaders of dimensions, notes, 3-D notes, geometric tolerances, symbols, and
balloons.

The drawing setup file option dim dot box_style controls the display (filled or hollow) of dots and
boxes only for leaders of linear dimensions.

You can also manipulate dimension leader arrows as follows:

3.

4,

Set the default arrow style of clipped dimensions by specifying a value for the drawing setup file option
clip dim arrow style (double arrow is the default).

Switch their direction by choosing Flip Arrows from the right mouse button shortcut menu.

Note: You cannot modify the arrow style of angular, diameter, and radial dimensions.

To Create Dimensions Without an Elbow

1.
2.

Set the drawing setup file option default dim_elbows to no.
Create the dimension in the drawing. The system assigns the dimension an elbow with a default value of
zero and does the following:

— Centers the line of text containing the dimension value on the end of the leader line.

— Trims back the leader line to the box surrounding all of the lines of dimension text.

— Pads the character height by half.

— Displays the text center-justified about the endpoint of the dimension line.

Note: A dimension with a leader that does not have an elbow appears different, with its text center-justified
(this is the default justification).
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To Flip Dimension Extension Lines

1. Choose Move; then select dimension text.
2. Move the dimension text between the extension lines.
3. Move the dimension to the opposite side.

To Modify a Dimension So the Dimension Symbol
AIways Appears

. Select the dimension.
2. Click Edit > Properties. The Modify Dimension dialog box opens.
3. Click the Dim Text tab. Replace the symbol "@D" that shows the dimension value with "@S" to show the
dimension symbol. Any text that was previously added to the dimension is lost.
Note: To change the dimension back to normal display, use the preceding procedure and modify @S back to
@D or @O (for drawing dimensions that show text instead of a dimension value).

You can replace the symbol without invalidating relations where the dimension appears.

About Dimension Types

Dimensions can be standard or ordinate.
e Standard dimensions are used to describe a dimension between two selected points. They use two witness
lines and a leader.

e Ordinate dimensions are used to describe the dimensions between several points and a common base
reference. They use a single witness line with no leader. All dimensions that reference the same baseline
must share a common plane or edge. To create an ordinate series you must first convert a standard
dimension, and select one of its witness lines as the baseline.

6.29
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Ordinate Dimensions

About Working with Ordinate Dimensions

You can modify linear dimensions so that they appear as ordinate dimensions. When you change dimensions to
an ordinate type in a drawing, they appear the same way in Part or Assembly mode, and in any other drawing in
which the model appears. Ordinate dimensions use a single witness line with no leader, and are associated with
a baseline reference, shown in the next figure as ".00". All dimensions that are to reference the same baseline
must share a common plane or edge. You can then use the common plane or edge for a baseline reference.

Example: Drawing with Ordinate Dimensions
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Changing from Linear to Ordinate

To modify a dimension type from linear to ordinate, you must first establish a reference baseline. For any set of
related dimensions (dimensions that share a common plane or edge), you need to create only one baseline
reference. If you just created a baseline, it remains set until you set another, or until you exit the MOD DIM
TYPE menu. Only one baseline reference can be current (set) at one time. To set another, choose Set Base and
select the existing baseline reference that you want to set. You can select dimensions that have witness lines
coincident with the set baseline and convert them from linear to ordinate dimension type.
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When converting the dimension, you can also add a jog to the witness line to improve the spacing of the
dimensions.

To Convert a Linear Dimension to an Ordinate
Dimension

The dimension to be converted to ordinate must be shown as linear. The following dimensions cannot be
converted to ordinate:

— A diameter dimension shown as linear
— A centerline dimension
Click Edit > Linear to Ordinate.
Select the dimension to convert.
3. Select the witness line to be the baseline reference. The dimension changes automatically to an ordinate type
dimension, indicated with a value of .00.
4. Select linear dimensions. The system places each one at the end of the witness line that is not coincident
with the current baseline.
Notes:

o -

e You cannot select dimensions that do not share the same baseline reference.

¢  When you switch dimensions from linear to ordinate, the baseline reference regenerates. However, if an
orphan baseline (one that does not have dimensions associated with it) has driven children (dimensions), the
baseline and the children do not regenerate. If many driven dimensions in a drawing reference an orphan
baseline, modify the dimensioning scheme by selecting a side from which to attach the baseline. The
baseline then regenerates at the correct location. To update children, choose Regenerate from the
DRAWING menu, followed by Draft.

e Ifyou attempt to create associative dimensions using a nonassociative baseline, the system asks you to
confirm that you want to create associative ordinate dimensions using the baseline reference.

e Baseline references appear on the drawing or in the model as ".00". Using the Show/Erase dialog box, you
can erase them from the drawing for cosmetic reasons. Also, you can select and delete baseline references
that are no longer necessary (if ordinate dimensions are not associated with them).

Showing Linear Dimensions as Ordinate
You can show dimensions or reference dimensions as linear or ordinate dimensions.

e [fthe system cannot show a dimension as ordinate from the selected baselines, it does not show it at all.
e If it shows dimensions as ordinate on the drawing, it shows them as ordinate on the model as well.

Typically, Pro/ENGINEER does not show negative or positive values for dimensions unless you set the
configuration file option show_dim signto yes. However, if you create dimensions which reference
features offset from a coordinate system, or assign a negative value to them, the negative value appears even if
you have set this option to "no."

To Change Ordinate Dimensions to Linear

When you convert an ordinate dimension to linear, the dimension loses its association with the baseline
reference. If you convert the dimension back to an ordinate dimension, you can select any appropriate baseline
reference.

1. Click Edit > Ordinate to Linear.
2. Select any ordinate dimension to convert.

To Convert Diameter Dimensions to Linear

You can convert a diameter dimension to a linear dimension, or convert a linear dimension for a diameter to a
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diameter dimension without switching the view. When you switch views on one of these converted dimensions,
Pro/ENGINEER tries to display the dimension in the format type prior to the conversion, then in the converted
format type, and finally in its original displayed view.

1. Select the diameter dimension to convert to linear.

2. Click Edit > Properties. The Modify Dimension dialog box opens.

3. Select the Show as linear dimension check box and then click OK.

Note: You cannot convert a linear dimension (for example, the depth of an extruded slot) to a diameter
dimension.

Creating and Deleting Ordinate Driven Dimensions

When creating ordinate driven dimensions, you must create a baseline in the required direction by converting a
standard dimension into an ordinate dimension, and then create ordinate dimensions using the baseline
reference.

When creating ordinate driven dimensions, keep in mind the following:

® You cannot create ordinate dimensions from a baseline dimension when the configuration file option
create drawing dims only is setto yes and a dimension with a d or ad type symbol (denoting
either a driving model dimension or an associative draft dimension) is the active ordinate baseline.

e To control the orientation of the ordinate dimension text, set the drawing setup file option
orddim text orientation to either parallel or horizontal.

e Ifyouset the drawing setup file option ord _dim standard, you can connect ordinate dimensions
measured from one baseline with a line. When extension lines are interconnected, all related dimensions
move when you move one.

e You cannot switch ordinate driven dimensions to another view.

To Create Ordinate Dimensions

Before you can create ordinate dimensions you must have a standard dimension defined on the baseline object.
You convert one of the dimension's witness lines into the baseline for the succession of ordinate dimensions.

1. Click Insert > Dimension > Ordinate. In the Menu Manager click ORD MAKE > Create Bases.
Select the standard dimension to convert into an ordinate dimension. The dimension and witness lines are
highlighted.

3. Select the witness line to be the baseline. The ordinate dimension is created, and the other witness line is
dimensioned from the base.

4. Click ORD MAKE > Create Dims. Select the next edges to dimension. The baseline remains selected until
after you place the dimensions. You can create more than one ordinate dimension at a time.

5. Once you have finished selecting edges, click the middle mouse button. The system places the dimensions.

To Delete Driven Ordinate Dimensions

You can delete driven ordinate dimensions, or those created by using Ordinate to Linear.

The process for deleting a baseline for ordinate driven dimensions is different from the process for deleting the
baseline when you have converted dimensions with a common witness line from linear to ordinate. You cannot
delete the baseline and the dimension that was converted to create the baseline until you convert them to a linear
dimension.

To Delete the Baseline

1. Click Edit > Ordinate to Linear.
Select the ordinate dimension that corresponds to the baseline, but not the baseline itself. The dimension
converts from ordinate to linear.

3. Return to the menu bar and click File > Delete.
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4. Select the linear dimension (that was previously assigned to be the ordinate dimension baseline) for
deletion.
5. Choose Done Sel. A ".00" reference appears for any remaining ordinate dimensions.

To Reroute Dimensions with Lost References

References to dimensions are lost when modifications or additions are made to features. Lost references occur
when parts are suppressed, during feature redefinitions or creations, and so forth. Features in a model change
and driven dimensions on the drawing no longer reference the same feature. You can identify lost references in
a drawing by the color magenta.

1. Click the lost dimension to reroute and then use the right-mouse button to see a shortcut menu.
2. Click Reroute Attach to reroute dimensions to new references.

To Automatically Dimension Radial Patterns

To automatically dimension a radial pattern feature (such as a bolt circle):

3. Click Insert > Dimension or Ref Dim > Common Ref. The Attach Type menu opens on the Menu
Manager.

4. Inthe Attach Type menu click Center.

5. Select the axis of one of the pattern features. You are prompted to select additional entities to dimension.

6. Select the base point to dimension against. (For example, you can select a csys at the center of the pattern or
an entity outside of the pattern.)

7. Click Done Sel. The Dim Orient menu appears.

8. Select an orientation. You are prompted: "Create Dims to the other members of the feature pattern?"

9. Click Yes. The remaining pattern members are dimensioned.

About Symbols

Symbols are collections of draft geometry and text. When you use them in a drawing, they become single
entities or instances. You can add as many instances of a symbol as you like.

Accessing Symbols

Pro/ENGINEER symbols exist in two different areas: the user-defined symbols area and the system symbols
area. The user-defined symbols area is the default storage area for user symbols. The system symbols area is
read-only and contains system symbols provided by Pro/ENGINEER with the Pro/DETAIL module (such as the
Welding Symbols Library).

To Set the User-Defined Symbols Area

To specify the area in which you want to store user-defined symbols, set the configuration file option
pro_symbol dir. This option automatically creates a search path to the specified directory.
Pro/ENGINEER saves all symbols into and retrieves them from this directory by default if you add this option
to your configuration file. If you change the value, the system does not delete symbols used in the drawing;
once you add them, it stores the definitions locally in the drawing.

You should establish a single directory as your user library for all standard symbols. If you do not specify one,
the system searches in the current working directory. You can change the default area for user-defined symbols
by entering a new value for the pro_symbol dir configuration file option. When you change this directory,
you do not have to modify the configuration file; however, this change is valid only for the current
Pro/ENGINEER session. Use this option to define new symbols that you store in a local or temporary directory;
you can still easily retrieve symbols from the standard symbols area.
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To Use the System Symbols Area

The system symbols area contains libraries of Pro/ENGINEER symbols that are available with the Pro/DETAIL
module. This area is read-only. To retrieve a symbol in Drawing mode, click Insert > Symbol Instance. In the
Symbol Instance dialog box, click Retrieve. The Open dialog box then opens, and you can retrieve a system
symbol from disk.

The Welding Symbols Library, for example, provides a collection of generic system symbols according to the
ANSI standard, and a collection of symbols according to the ISO standard. Using this library, you can create a
variety of welding, brazing, and examination symbols in a drawing. Before you create an instance, familiarize
yourself with the procedure for adding instances.

To Create Your Own Library

You can create your own symbols library. For information on how to create and locate your own library of
symbols, see the Pro/ENGINEER Installation and Administration Guide.

To Change the Symbol Directory

Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click Symbol Dir.

Type the pathname of the directory for the new pro_symbol dir.

To restore the default pathname in the current session, do one of the following:

— Repeat this process and substitute the original pathname.

— Choose Utilities > Options from the Pro/ENGINEER menu bar and reload the configuration file in
which this option resides.

D=

Simple and Generic Symbols

Pro/ENGINEER supports two kinds of symbols—simple and generic. A simple symbol is a symbol instance
that is identical to the symbol. A generic symbol defines a family of similar symbols; it contains all entities
pertaining to this family. You can arrange geometry and text in a generic symbol in groups and subgroups,
creating a tree structure of symbol definition.

To Delete a Symbol Definition

Using the Delete command in the DWG SYMBOL menu, you can remove a symbol definition and all of its
instances from a drawing.

Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click Delete.

Specify the symbol by choosing Name or Pick Inst from the GET SYMBOL menu.
Type [Y] to remove the symbol definition and its instances.

Storing Symbols

You can store symbols in a specified area by setting the configuration file option pro_symbol dir. Ifyou
do not specify a path, Pro/ENGINEER stores symbols in the working directory. When storing a symbol, you
can enter an offset path that branches off from pro_symbol dir. For example, for a UNIX-based system, if
you have specified "pro_symbol dir" as /usr/proe/symbols:

el S

e [fyou press ENTER, the system places the symbol in /usr/proe/symbols.
e Ifyoutype [down one dir], it stores the symbol in /usr/proe/symbols/down _one_dir.
* You cannot go up the directory tree by typing [..].

e If you want to store the symbol in a directory that you cannot access as an offset of the current
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pro_symbol dir,change pro symbol dir before you begin.

¢ You do not have to store the symbol in order to continue using it in the drawing. However, if you do not
write it to disk, the system only stores it locally in the drawing and does not make it available for use in
other drawings or by other users.

To Store a Symbol

Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click Write.

Specify the symbol by choosing Name or Pick Inst from the GET SYMBOL menu.

Type the offset directory path from the directory specified by pro symbol dir in which to store the
symbol.

Redefining Symbols

Using the Redefine command in the DWG SYMBOL menu, you can add, move, delete, or change detail items
composing a symbol.

bl o M

You can modify a symbol by doing the following:

e (Create new entities composing a generic symbol.

Modify existing entities composing a generic symbol.

Change the attachment style.
e Change group definition by adding or removing entities from groups, or deleting one or all groups.

Effect of Symbol Redefinition on Instances

When you redefine a symbol, it affects the display of all subsequent instances and all symbol instances that you
have added to a drawing using the By Reference command.

Updating Symbols Used in Drawings

When you place a symbol that you have redefined, it is possible, but not necessary, to update the symbol in the
drawing to reflect the most recent definition. The system prompts you to update a symbol when the version of a
retrieved symbol is later than the version of the symbol with the same name on the drawing.

Updating the drawing symbol changes every symbol in the drawing with that name. If you do not update the
symbol in the current drawing, any additional instances of the symbol that you create are of that version, not the
most recent one. To update an existing symbol, choose Retrieve from the GET SYMBOL menu, and select its
name in the existing drawing. Type [Y] to update all instances of the symbol in the current drawing to the most
recent version.

To Redefine a Generic Symbol

1. Click Format > Symbol Gallery. The DWG SYMBOL menu appears.
2. Click Redefine and then select a symbol instance.
3. The symbol edit window displays the generic symbol. Create, delete, or modify any of the symbol entities
by choosing an appropriate editing command from the SYMBOL EDIT menu:
— Detail—Creates, deletes, moves, translates, and performs other procedures on items composing a
symbol in a way similar to manipulating draft entities in drawings.
— Mod Text—Changes text.
— Mod Xhatch—Modifies cross-hatching immediately upon its creation in the symbol edit window.
After you exit the window, it becomes a collection of individual entities.
— Import—Imports items into the Pro/ENGINEER symbol edit window.
— Attributes—Respecifies a leader type, if any, and symbol size characteristics.
If you have created new entities, they automatically belong to the uppermost level and appear in all
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instances. If you have deleted an entity, the system automatically removes it from all groups and
subgroups to which it previously belonged.

4. To add the entity (that you have just created) to a group, use the group editing commands.

Choose SYMBOL EDIT > Groups.

6. Choose SYM GROUPS > Edit. The TOP LEVEL menu displays the top-level groups. Choose a group to
indicate the branch that you want to follow. The system highlights in blue all entities associated with this
group.

7. To add the entity, choose EDIT GROUP > Add, and select the entity. Confirm the selection by choosing
Done Sel.

8. To pass down this entity to a lower level group, choose Change Level. Select the top-level group with
which you have just associated the entity. Only entities belonging to the selected group appear in the symbol
edit window, while the namelist menu lists subgroups of the selected group. This indicates that now you are
one level down.

9. Choose Edit. Choose the desired subgroup from the namelist. Choose Add, and select the entity. This
associates the entity with the subgroup you have indicated.

10. If you want to go further down, repeat Steps 7 and 8.

11. After you finish the editing process, you can respecify attributes. When you have redefined the symbol, you
can store the new symbol definition by choosing DWG SYMBOL > Write. The system creates a new
symbol file with the version number to retain the old symbol definition file.

Note: When you redefine a symbol, any cross-hatching that exists in the symbol is no longer a group, so
you should manipulate it accordingly.

To redefine a simple symbol, follow Steps 1 through 6 of the preceding procedure for generic symbols; then

choose Attributes from the SYMBOL EDIT menu to respecify attributes. Store the symbol by choosing Write

from the DWG SYMBOL menu.

hd

About Simple Symbols

To define a simple symbol, you must specify the symbol entities (geometry), attributes, origin or attachment
point, and any variable text needed. Using the SYMBOL EDIT menu, you can define a simple symbol using draft
entities in a format or file.

To Define a Simple Symbol

1. Create the draft geometry and add notes to include as fixed or variable text in the symbol. The text size and
placement should be proportional to the geometry. Symbol text and geometry remain proportional when you
modify the symbol height.

2. Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click Define.

4. Type a name that an existing symbol is not already using (in the directory where you are going to store the
symbol) unless you intend to overwrite the existing symbol. The symbol edit window appears.

5. Choose Copy Drawing to copy entities from the format or drawing into the symbol edit window. Click
GET SELECT > Pick Many > Pick Box to select all entities quickly.

6. Choose GET SELECT > Done Sel to confirm your selection. All selected entities appear in the symbol edit
window.

7. Choose SYMBOL EDIT > Attributes.

Select the desired attributes from the Symbol Definition Attributes dialog box; then click OK.

9. Choose SYMBOL EDIT > Done. The system confirms that it has successfully defined the symbol.

W

o
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Example: Selecting Origins for Symbol Placement

\WELD PROCESS\

2

1 Select the center as the origin for the Left Leader.
2 Select anywhere as the origin for No Leader.
3 This is variable text.

To Specify Entities of a Simple Symbol

To specify entities to be included in the definition of a symbol, you begin by selecting the draft geometry,
nodes, unattached notes (defined as variable or fixed text), and filled areas to compose the symbol. Using the
commands in the SYMBOL EDIT menu, you can create symbol entities in a number of ways:

e In the symbol edit window, create geometry and text using the Detail command.
e In a drawing, create geometry and text; then copy what you need into the symbol edit window using the
Copy Drawing command.

e Using the Copy Symbol command, retrieve a selected symbol into the symbol edit window (for a generic
symbol, when adding a symbol, you must select groups to include) and use its entities to define your own
symbol. Once the symbol appears in the symbol edit window, the system ungroups its entities, and you can
manipulate them individually.

e Import entities into the symbol edit window using the Import command in the Pro/ENGINEER File menu.
You can import IGES, DXF, SET, and CGM drawing files or input from a tablet.
Notes:
— You cannot modify cross-hatching in a symbol instance because the symbol is a grouped entity. When
you ungroup it, the cross-hatching explodes into individual entities. This behavior also occurs when
you are redefining the symbol in the SYMBOL EDIT menu.

— You cannot include dimensions and coordinate systems in symbols.

278 Pro/DETAIL



Example: Entities Allowed in a Symbol

1\\r 3
® ’

/A \\\‘WELD PROCESS\
2

1 Filled area.
2 Draft geometry.
3 Variable text.

Specifying Attributes
Using the Symbol Definition Attributes dialog box, you can specify the following symbol attributes:

e Placement type

— Free, on an entity, or normal to an entity

— Left, right, or radial leader
e Symbol instance height

— Fixed

— Variable in drawing units, model units, or text-related
e Position and other characteristics

— Ata fixed text angle

— With an elbow

— Mirror image of the original geometry or text
e Variable text

To Specify Placement Type of a Simple Symbol

When you choose one of the allowed placement types for a symbol, you must select the origin. You can attach
symbols to coordinate systems using leader attachments or using the On Entity check box while placing a
symbol instance.

Symbol Instance Height

To relate the height of a symbol to a model view that was defined using the On Item or Free Note placement
attributes, select Variable - Model Units from the General page of the Symbol Definition Attributes dialog
box. The system then remembers the height of instances of the symbol in model units. If you change the view
scale of the model units, it automatically adjusts the symbol’s visible size to maintain a constant proportional
relationship with the model.

You can proportion symbols, such as diameter symbols, to the text that follows. In such cases, define the
symbol attributes by selecting Variable - Text Related from the Symbol Instance dialog box. However, if a
symbol (for example, a diameter symbol) does not contain any text to which you can make it proportional, you
can create symbol text with a blank line by doing one of the following:

o Create a one-line note in the symbol. From the DRAWING menu, choose Mod Text and Full Note, and
change whatever text you had in the note to a single blank line (make sure to retain the braces and other
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special characters). To include this note when defining the symbol, choose Pick Box and select Variable -
Text Related from the Symbol Instance dialog box to define the symbol.
Include a variable text note when defining the symbol. Select Variable - Text Related from the Symbol

Instance dialog box to define the symbol. When you create an instance of this symbol, backspace over the
default text in the Var Text box so that text does not appear in the symbol.

To Relate a Symbol's Height to a Model View

1.
2.

3.

Select Variable - Model Units from the General page of the Symbol Definition Attributes dialog box.
Relate the symbol instance to a model. Press the middle mouse button to relate the symbol to the whole
drawing, which determines its height in drawing units, or select a specific view.

Note: Symbols placed on an item or normal to an item are either on an edge of the model and related to that
model, or on a draft entity and related to the whole drawing. If a free symbol is located entirely within the
view boundary box of a single view, the system automatically selects its view model. Otherwise, you must
select a view in which to place the symbol.

Specify a value for the symbol instance height in the units of the model.

To Create a Leader with an Elbow

To create a leader with an elbow, select Allow Elbow from the Attributes box of the Symbol Definition
Attributes dialog box. This command is unavailable until you specify a placement type using a leader.

Example: Attaching a Symbol to a Leader with an
Elbow

v

..

1
2

Specify the lowest point as the attachment point.
You can change the length of the elbow using the Move Text command.

To Control Mirror Properties of a Simple Symbol

You can control the way in which a symbol and its notes appear and reorient themselves upon mirroring and
rotation by using one of the following three methods:

Set the drawing setup file option sym_rotate note center to yes (the default value). The system
rotates the symbol note as 1f 1ts origin were in the middle of the height of the text, rather than at the bottom
of the text. If you set it to "no," the system rotates the text by rotating its origin point, as it is. Changing the
value of this setup option changes the position of existing rotated texts when you repaint.

Specify attributes in the Symbol Definition Attributes dialog box. You can make a mirror image copy of the
original symbol geometry by choosing Mirror from the TOOLS menu and selecting a draft line. If you do
not select Geom. Will Mirror from the Symbol Definition Attributes dialog box, the system mirrors only
the symbol origin about the mirror line, and the symbol geometry appears in the same orientation as the
symbol you are copying. When you have also selected Text Will Mirror, the newly created text is a mirror
image of the original text, with the origin translated about the mirror line as well. Thus, the text appears
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backward compared to the original text, and its angle and origin also are mirrored.

e Use the Toggle Rotate command in the NOTE ROTATE menu. To rotate individual notes with a symbol,
choose Redefine from the DWG SYMBOL menu, Note Rotate from the SYMBOL EDIT menu, and Toggle
Rotate from the NOTE ROTATE menu. You can then select a note in the symbol edit window so that it does
rotate with the symbol. The Show Fixed command highlights notes in the symbol edit window that
currently remain fixed in orientation (angle) when their symbol is rotated. This highlighting disappears
when you repaint.

To Control Variable Text of a Simple Symbol

Using the Var Text page in the Symbol Definition Attributes dialog box, you can specify default values and
additional predefined values of variable text for a symbol:

e The specification consists of a list of compound items and an input text area (field).
e Each compound item in the list represents variable text.
e The label to the left of a compound item indicates the name of the variable text.

The system uses the default value (to the left of the variable text name) when it first creates the symbol instance.
When you type [&dim] as the default text for symbol definition, you must select a dimension for a particular
instance. The value of the dimension disappears from its previous location and appears as the text of the
symbol. When you modify variable text, if the default value is &dim, you must select a dimension when you
place the symbol. In addition to the default, you can specify other preset values for each variable text.

You can use variable text to create a unique instance of a symbol by replacing the default text in the symbol
with a numeric value, text, or dimension when creating the instance. Pro/ENGINEER adds variable text as an
unattached note with the text enclosed in backslashes (}).

Note: Variable text may consist of only one zex? structure. Since Pro/ENGINEER parses special characters as
separate texts, you cannot use backslashes to define the value of variable text.

About Defining Generic Symbols

A generic symbol defines a family of similar symbols; it contains all entities pertaining to this family. You can
arrange geometry and text in the generic symbol in groups and subgroups, creating a tree structure of symbol
definition. Each level of symbol definition, containing more than one group, is characterized by the group
attribute restricting the selection of groups at the specified level. That is, you can choose Exclusive from the
GROUP ATTR menu to define groups, so that you include only one of them in the symbol instance, or you can
use the Independent command to define them, so that you can select any number of groups (or none). The
following figure illustrates how to use groups to assemble symbol instances.

The tree definition structure helps you create symbol instances. When you specify the groups to include, the
system assembles an instance out of predefined blocks, or groups. A group can consist of other subgroups and
independent entities. The system always selects these independent entities on each level when you select the
group to which they belong. Subgroups of different subgroups can share the same name.
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Example: Creating a Generic Symbol Definition

Generic
/N Symbol

VoA e 1

Group A Group B

VA AN
Group A + Ent 3 roup B + Ent 3

Instance 1 Instance 2

AVARRVAN

Group A Group B =

VA AN %
Group A + Ent 3 Group B + Ent 3/ \Groups A +B + En

Instance 1 Instance 2 Instance 3

Note: The line is not included in any group because it must appear in all instances.

1  ARRANGEMENT 1: Groups A and B are exclusive.
2  ARRANGEMENT 2: Groups A and B are independent.

Moving Along the Symbol Definition Tree

When defining and redefining symbols, you can move between groups and subgroups using the Change Level
command in the SYM GROUPS menu. This displays the GROUP menu with the list of existing groups at the
current level. Choosing a group from the list moves you down a level so that you can work on the lower level.
Choosing This Level tells the system that you are on the required level and want to proceed with an action. If
you choose UP, you move up one level in the symbol definition tree.

To Create a Tree Definition Structure

Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click Define.

Type the symbol name, [FILLET].

Choose SYMBOL EDIT > Copy Drawing to copy entities into the symbol edit window. Choose GET

SELECT > Pick Many > Pick Box to select all entities quickly.

Choose Done Sel to confirm your selection. All selected entities appear in the symbol edit window.

Choose SYMBOL EDIT > Groups > Create.

7. Type the group name as [ARROW_SIDE]. Select all of the entities that belong to the arrow side except the

reference line. The system does not include the reference line in any group because it must appear in all

symbol instances.

After you select all entities, confirm by choosing Done Sel.

9. To create another top-level group, choose SYM GROUPS > Create, type the name of the group
[OTHER_SIDE], and select entities located on the other side of the reference line. Conclude by choosing
Done Sel.

10. For this example, top-level groups are exclusive. Choose
SYM GROUPS > Group Attr > Exclusive.

11. To create subgroups of the top-level groups, choose SYM GROUPS > Change Level.

b S
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12. The TOP LEVEL menu displays the list of groups at the current level and the This Level command. Choose
ARROW_SIDE; all entities pertaining to this group appear in the symbol edit window.

13. Choose ARROW_SIDE > This Level.

14. To specify subgroups at the current level, choose Create, type the group name, and select the corresponding
geometry or text line. When creating subgroups, use the following table:

Group name What you select on the screen
WELD_SIZE /weld_size/

LENGTH /length/

PITCH /pitch/

CONTOUR /
letters C, G, H, M, R, U

FINISH 9 / on top of one another

Note: The system does not include the fillet in any subgroups because it must always be in any arrow-side
instance.
By default, the system sets the group attribute to Independent; therefore, you do not have to use the GROUP
ATTR menu. Groups are independent because you can include all groups in a single instance.

15. To specify the subgroups of the group CONTOUR, choose Change Level > CONTOUR. The symbol edit
window displays entities from the current group.

16. Choose SYM GROUPS > Create. Create these three groups:

Group name What you select on the screen

FLUSH /
CONVEX _//

CONCAVE //’

17. Choose SYM GROUPS > Group Attr > Exclusive (you can choose only one of the preceding subgroups
under the group CONTOUR at one time).

18. Choose Change Level > UP > FINISH. To select the proper character on the screen, use Query Sel. Create
groups as follows:

Group name What you select on the screen

CHIP
GRIND

MACHINE
HAMMER

ROLL
UNSPECIFIED

cCxoxTIT Z MmO

19. Choose SYM GROUPS > Group Attr > Exclusive. You have completely described the symbol along the
arrow-side branch.

20. To specify subgroups along the other-side branch, choose Change Level > UP to return to the TOP LEVEL
menu.

21. Choose OTHER_SIDE and proceed to create groups, following a procedure similar to the one described in
Steps 8 through 19.

22. When you finish the symbol definition, choose SYM GROUPS > Done.
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23. Choose SYMBOL EDIT > Attributes.

24. From the Symbol Definition Attributes dialog box, select items characterizing the attachment point, leader
type, and symbol size. For this example, click Left Leader and Variable.

25. Select the leader origin on the left side of the symbol; then click OK.

26. Click the Var Text tab to type values for notes created between slashes as variable text entries.

27. The system informs you that it has defined the symbol. To save the generic symbol on a disk, choose
SYMBOL EDIT > Write. Type the directory path or accept the default.

About Adding Nodes

While defining symbols or after defining them, you can add nodes (also referred to as pins) as valid wire attach
points on components and connectors. You can also generate, modify, store, and view parameter sets.

Creating Nodes

If you include a node in a symbol, the system identifies it by placing its name in a note. When you create nodes
during symbol definition, it automatically adds the PIN command and node name value to the symbol parameter
file. The drawing setup file option node_radius controls the display of nodes in symbols.

To Create a Node

Click Format > Symbol Gallery >Redefine to retrieve the symbol to include a node.

In the SYM EDIT dialog box, click Insert > Node.... The SYMBOL NODE menu appears.

Click Make Node.

Type the node name in numeric or alphanumeric form.

Select the node location on the symbol. A green dot indicating a node with the node name appears on the
symbol.

Referencing Parameters in Node Notes

You can edit node notes as text to include the following references to other parameters:

NhwN =

e Node name, for example, &node name

e Node parameters, for example, &signal name

e Top-level symbol parameters, for example, &ref des

e Any valid drawing parameters included as labels, for example &scale

Note: You can reference only those symbols to which you have assigned values in the symbol parameter
set. If you delete a parameter that a note references, "***" appears in the note instead of the missing
parameter value.

Modifying Parameters in Node Notes

You can modify the node name in a node note only by recreating the node on the symbol using the
Definition and Redefine commands.

In symbol definitions, a node note referencing a parameter has a parameter name displayed in a note while the
actual parameter value appears in the message area. Therefore, changing the parameter value is not noticeable in
a note; the new parameter value appears only in the message area. When you create a symbol instance, the
system replaces parameters included in a node note by their values. Modifying a parameter value updates the
node note to show the current parameter value. If you modify symbol or node parameter values in a node note
the system updates the values of the corresponding parameters listed in the symbol parameter table.
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To Blank Parameters in Node Notes

By default, the system shows node notes when it creates them. To blank all node notes:

1. Click Format > Symbol Gallery >Redefine to retrieve the symbol that includes a node.
2. Click Insert > Node.... The SYMBOL NODE menu appears.
3. Click Erase Notes. To redisplay them, choose Show Notes.

About Including Symbol Parameters
In Pro/DETAIL, you can include two types of parameters in a symbol:

e Node parameters identifying nodes (only if nodes are present in the particular symbol).

e Symbol definition parameters, or the top parameter set, identifying the symbol. The system replaces them
with the corresponding information when you add the symbol to the drawing. Fixed text appears the same
for any instance of the symbol. You can use the following parameters in symbol definition:

— Any of the system parameters for drawings
— Any user-defined parameters
—  &dwg_name
#- &!'#-  &-...Note: You cannot use a note parameter for the value of variable text.
Depending on the application, a symbol can include the following categories of parameters:
e Required
e Optional, system-defined
e Optional, user-defined
If an application uses a symbol with required parameters, but they are missing, the system issues an error
message and you can edit the symbol parameter file. The next figure shows the format of the parameter file.

Parameter Set Format

Symbolparameters Values
TYPE COMPONENT or CONNECTOR <read-only>
REF_DES instance reference name <text>
Top parameter set MODEL NAME name of reference solid model <text>
NUM_OF_PINS number of nodes <integer>
GENDER MALE or FEMAL <read-only>
o Node parameter Node parameter
Node name
SIGNAL_NAME SIGNAL_VALUE
. PIN
List of nodes [ Value Value Value
PIN

Pro/ENGINEER uses symbols containing an individual parameter set to create electrical diagrams. You can
define Pro/DIAGRAM symbols in Drawing mode and Diagram mode. However, if you want to use them in
Pro/DIAGRAM, you must define them as components or connectors by providing the parameter set appropriate
for the type of object the symbol represents (component or connector). The following tables list component and
connector parameters (the required parameters are shown in bold type).

Component Parameters

PARAMETER DESCRIPTION
DESCRIPTION The description of the component (such as FUEL GAUGE).
TYPE The object type (COMPONENT).

Pro/DETAIL 285



REF _DES The reference designator name. You must store the default name with the
symbol definition. When placing a component symbol, you must supply a
unique REF_DES name to be stored with the symbol instance and used in
wire lists.

MODEL NAME The name of the reference solid model, that is, the physical model
represented by the component symbol.

NUM_OF_PINS The number of logical pins. The system determines the number of visible
pins by the number of nodes in the symbol definition.

PIN .. .. .. Pin names and signals information. For each node included in the symbol
definition, the system generates a line in the following format: PIN
PIN. NAME  SIGNAL NAME SIGNAL VALUE ENTRY PORT
PIN_NAME is supplied automatically; SIGNAL NAME and
SIGNAL VALUE are optional; you can type them manually.

Connector Parameters

PARAMETER DESCRIPTION
DESCRIPTION The description of the connector (such as 12 PIN FEMALE).
TYPE The object type (CONNECTOR).
REF DES The reference designator name.

MODEL NAME The name of the reference solid model, that is, the physical model
represented by the connector symbol.

GENDER MALE or FEMALE.

PIN .. .. .. Pin names and signals information. For each node included in the symbol
definition, the system generates a line in the following format: PIN
PIN. NAME  SIGNAL NAME SIGNAL VALUE ENTRY PORT
PIN_NAME is supplied automatically; SIGNAL NAME and
SIGNAL VALUE are optional; you can type them manually.

NUM_OF PINS Number of logical pins. Number of visible pins for fixed connectors is
defined by the number of nodes in the symbol definition, for parametric
connectors, by the Num Vis Pins attribute value.

You can perform the following procedures on parameters:

e Generate, edit, or view a symbol definition parameter set.

e Store a symbol definition parameter set in a file.

To Generate a Parameter Set

To create a parameter set, you can do one of the following:

e Generate a set of default parameters by reading in data (system- or user-defined).
e Type parameter names and their values in a table using the Pro/TABLE environment.

To Generate a Set of Default Parameters

You can generate a set of default parameters to symbols.
1. Click Format > Symbol Gallery. The DWG SYMBOL menu appears.
2. Click DWG SYMBOL > Refine to locate the symbol to assign default parameters.
3. Click SYMBOL EDIT > Parameters > Read.
4. Using the READ SYM PRM menu, do one of the following:
— Choose Comp Default and retrieve a system set of default parameters for components.

— Choose Conn Default and retrieve a system set of default parameters for connectors.
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— Choose Other and retrieve a user-specified file (with the extension ".spm") containing the appropriate

parameters.

To Create Parameters in Pro/TABLE

5. Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

&

Click DWG SYMBOL > Refine to locate the symbol to assign default parameters.

7. Click SYS PARAMS > Modify. A blank Pro/TABLE window appears unless you read in a parameter file

previously.

8. Using the Pro/TABLE editor, type parameters and their values in a required format. Use the Pro/TABLE
Help command or Edit. Choose Keywords (equivalent key is F4) when needed. You can edit the parameter

set later as needed.

System Parameters for Drawings

The following table lists all system parameters available for use in drawings, classified according to

functionality.
PARAMETER NAME

&d#

&ad#

&rd#t

&ptt

&g#
&<param_name>

&<param_name>:att_cmp

&<param_name>:att edge

&<param_name>:att_feat

&<param_name>:att mdl

&<param_name>:att_pipe bend

&<param_name>:att_spool

Pro/DETAIL

DEFINITION

Displays a dimension in a drawing
note, where # is the dimension ID.

Displays an associative dimension in a
drawing note, where # is the dimension
ID.

Displays a reference dimension in a
drawing note, where # is the dimension
1D.

Displays an instance number of a
pattern in a drawing note, where # is
the pattern ID.

Displays a gtol in a drawing note,
where # is the gtol ID.

Displays a user-defined parameter
value in a drawing note.

An object parameter that indicates the
parameters of the component to which
a note is attached.

An object parameter that indicates the
parameters of the edge to which a note
is attached.

An object parameter that indicates the
parameters of the feature to which a
note is attached.

An object parameter that indicates the
parameters of the model to which a
note is attached.

An object parameter that indicates the
parameters of the pipe bend to which a
note is attached.

An object parameter that indicates the
parameters of the spool to which a note
is attached.
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&<param_name>:EID_ <edge name>
&<param_name>:FID <feat ID>
&<param_name>:FID <FEAT NAME>
&<param_name>:SID_<surface name>

&angular tol 0 0

&current_sheet

&det _scale

&dtm_name

&dwg_name

&format

&linear tol 0 0

&model name

&parameter:d

&pdmdb

&pdmrev
&pdmrev:d

&pdmrl
&scale
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An object parameter that references
edges.

An object parameter that includes a
feature parameter in a note by ID.

An object parameter that includes a
feature parameter in a note by name.

An object parameter that references
surfaces.

Specifies the format of angular
tolerance values in a note from one to
six decimal places.

Displays a drawing label indicating the
current sheet number.

Displays a drawing label indicating the
scale of a detailed view. You cannot
use this parameter in a drawing note.
Pro/ENGINEER creates this parameter
with a view and places it in notes
automatically. You can modify its
value, but you cannot call it out in
another note.

Displays datum names in a drawing
note, where name is the name of a
datum plane. The datum name in the
note is read-only, so you cannot
modify it; unlike dimensions, a datum
name does not disappear from the
model view if included in a note. The
system encloses its name in a
rectangle, as if it were a set datum.

Displays a drawing label indicating the
name of the drawing.

Displays a drawing label indicating the
format size (for example, Al, A0, A,
B, and so forth).

Specifies the format of dimensional
tolerance values in a note from one to
six decimal places.

Displays a drawing label indicating the
name of the model used for the
drawing.

Adds drawing parameters to a drawing
note, where parameter is the parameter
name and .d refers to the drawing. .

Displays the database of origin of the
model.

Displays the model revision.

Displays the revision number of the
model (where :d refers to the drawing).

Displays the release level of the model.
Displays a drawing label indicating the
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&scale of view detailed bar
&sym(<symbolname>)

&todays date

&total sheets

&type

&view_name

&view_scale

Pro/REPORT System Parameters

&asm.mbr.comp....

&asm.mbr.cparam....

&asm.mbr.cparams....

&asm.mbr.name

Pro/DETAIL

scale of the drawing.

Includes a drawing symbol in a note,
where symbolname is the name of
the symbol.

Displays a drawing label indicating the
date on which the note was created in
the form dd-mm-yy (for example, 2-
Jan-92). You can edit it as any other
nonparametric note, using Text Line
or Full Note.

If you include this symbol in a format
table, the system evaluates it when it
copies the format into the drawing.

To specify the initial display of the
date in a drawing, use the
configuration file option
"todays_date note format."

Displays a drawing label indicating the
total number of sheets in the drawing.

Displays a drawing label indicating the
drawing model type (for example, part,
assembly, etc.).

Displays a drawing label indicating the
name of the view. You cannot use this
parameter in a drawing note.
Pro/ENGINEER creates it with a view
and places it in notes automatically.
You can modify its value, but you
cannot call it out in another note.

Displays a drawing label indicating the
name of a general scaled view. You
cannot use this parameter in a drawing
note. Pro/ENGINEER creates it with a
view and places it in notes
automatically. You can modify its
value, but you cannot call it out in
another note.

Retrieves information about the
component from the model data and
displays it in the report table.

Retrieves a given component
parameter.

Lists information pertaining to all
component parameters for the current
model.

Displays the name of an assembly
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&asm.mbr.param....
&asm.mbr.type

&asm.mbr.User Defined

&dgm....
&fam....

&harn....

&lay....
&mbr....
&mdl....

&prs....

&rpt....

&weldasm....
&asm.mbr.cblprm....
&asm.mbr.cblprms....
&asm.mbr.connprm....

&asm.mbr.pipe....

&asm.mbr.generic.name....

&asm.mbr.topgeneric.name. ...
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member. To show tie wraps and
markers, the region attributes must be
set to Cable Info.

Displays information about parameters
in an assembly member.

Displays the type (part or assembly) of
an assembly member.

Lists the specified user-defined
parameter for the respective assembly
components. Note that "&asm.mbr."
can be used as a prefix before any

user-defined parameter in an assembly
member.

Retrieves family table information
about the model.

Shows cable harness parameters for 3-
D harness parts and flat harness
assemblies.

Retrieves layout information about the
model.

Retrieves parameters about a single
component.

Retrieves information about a single
model.

Retrieves process-specific report
parameters used to create reports on
the entire process sequence.

Displays information about each
record in a repeat region.

Retrieves welding information about
the model.

Lists values for a given cabling
parameters.

Lists values for cabling and wire
parameters.

Lists parameters for connector pins in
flat harness assemblies.

Shows pipeline, pipe segment, and
Pro/REPORT bend information
parameters.

Lists the generic name information for
a family table instance in a table.

Lists the top generic name information
for a family table instance in a table
when working with a nested family
table.
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To Edit Symbol Parameters

Once you have created a parameter set, you can modify symbol and node parameters by editing the parameter
file using the Pro/TABLE editor. You can change the parameter value, add user-defined parameters, or delete
parameters. If the system encounters errors after you have edited the parameter file, it displays an Information
Window indicating the type of errors. You can use commands in the REEDIT menu to resolve the discrepancies.

To View Symbol Parameters

Using the Show command in the SYM PARAMS menu, you can view the symbol definition parameter set.

1. Click Format > Symbol Gallery. The DWG SYMBOL menu appears.
2. Click DWG SYMBOL > Refine to locate the symbol to view parameters.
3. Click SYMBOL EDIT > Parameters > Show.

Storing Symbol Parameters

While working with a symbol definition, you can save the parameter set to a file in your working directory, and
read it in later to create similar parameter sets for other symbol definitions.

To Store a Parameter File

Click Format > Symbol Gallery. The DWG SYMBOL menu appears.

Click DWG SYMBOL > Refine to locate the symbol to store parameters.

Click SYMBOL EDIT > Parameters > Write.

Type the filename without an extension. The system stores the file with the name "filename.spm" to disk.

If the name that you typed for the parameter file already exists in your working directory, type [Y] to replace
the existing file or [N] to avoid overwriting; then type a new filename.

About Adding Symbols to a Drawing

The Symbol Instance dialog box is used to transfer symbols to and from the drawing and symbol instance
pallette. When you add a symbol to a drawing, you create an instance. To find the name and directory path of
the symbol corresponding to an instance, use the Show Name command in the DWG SYMBOL menu. Using
the Symbol Instance dialog box, you can create new symbol instances and preview them during the creation
process. Specifically, you can do the following:

NhWD =

e Specify placement characteristics:
— Content
— Height
— Angle
— Position
e Specify the groups to include in the symbol.
e Modify variable text.
e Adjust instance location.

Symbol instances exist only in the drawing format. In Drawing mode, you cannot edit symbols that you created
and added to formats in Format mode if you add the format to a drawing. To edit the symbol, retrieve the format
in Format mode and make any of the necessary changes. To access format symbols in Drawing mode, write the
symbol to disk and retrieve it into the drawing from the appropriate directory in which the file is stored.

To Place a Symbol Instance

1. Click Insert > Symbol Instance. The Symbol Instance dialog box opens.
2. In the Symbol Instance dialog box, choose one of the following options:
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— Pick in Draw — Select a symbol in the drawing.
— Retrieve — Retrieve a system symbol from disk.
— Sym Palette — Select a symbol from another drawing.

Note: In order to use Sym Palette, the configuration option linking to the drawing containing the symbol must
be established.

3. Specify the height of the instance by typing a value in the Height box.
4. Specify the placement type by selecting an item from the Type list.
5. Click Place Inst... to place the symbol in the drawing.
— Ifyou chose alternative specifications in the Symbol Definition Attributes dialog box (such as On
Entity and Free) before adding an instance to the drawing, indicate how to place the instance by using
commands in the INST ATTACH menu.

— Ifyou define a symbol with a leader command, specify the leader attachment type by choosing a
command from the ATTACH TYPE menu.

6. The system displays the symbol as specified.

To Create a Symbol Instance

1. Click Insert > Symbol Instance. The Symbol Instance dialog box opens
2. Click Pick in Draw to select a symbol in the drawing, Retrieve to retrieve a system symbol from disk, or
Pick in Palette to use the symbol palette.
3. Type the height and value of the instance.
Specify the placement type by selecting an item from the Type list.
5. Click Place Inst... to place the symbol in the drawing.
— Ifyou choose alternative specifications in the Symbol Definition Attributes dialog box (such as On
Entity and Free) before adding an instance to the drawing, indicate how to place the instance by using
commands in the INST ATTACH menu.

— Ifyou define a symbol with a leader command, specify the leader attachment type by choosing a
command from the ATTACH TYPE menu.

B

To Repeat a Symbol Instance

1. Inthe Symbol Instance dialog box, click Pick in Draw to select a symbol in the drawing, click Retrieve to
retrieve a system symbol from disk, or Pick in Palette to use the symbol palette.

2. Click Place Inst, and then select a location to place the symbol instance.

3. In the Symbol Instance dialog box, click Repeat Inst. This action creates a copy of the last symbol
instance you selected.

4. Select a location to place the symbol instance.

Example: Symbol with Leader

symbol height
QVELD PROCESS\

LN

To Relate a Symbol Instance to Dimension Text

Before or after you create a symbol, you can relate it directly to dimension text so that it moves with the
dimension when the dimension changes location. When specifying the placement of a new symbol instance,
select Offset from the Placement Type list in the Symbol Instance dialog box. Then select dimension text and a
location relative to the text. To relate an existing symbol to dimension text, choose Relate Obj from the TOOLS
menu.
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To Create an Offset Attachment to a Symbol or Note

You can attach a symbol or note that is offset from a dimension leader arrow endpoint.
1. Click Format > Symbol Gallery >Redefine to retrieve the symbol to create an offset attachment.
2. Inthe SYM EDIT dialog box, click Insert > Note. The SYMBOL NODE menu appears.
3. Click Insert > Note > Make Note.
4. Select one of the following:
— Dimension

— Dimension arrow

— Note

— Balloon

- GTOL

— Symbol instance

— Reference dimension

5. Select the location for the symbol or note, and then select a symbol from the Symbol Palette dialog box or
type the note in the text box.

Creating an Offset Attachment to a Symbol or Note

Symbols and notes can be attached with an offset to other symbols and notes. When the parent symbol or note is
moved, the child symbol or note moves with it and maintains the offset distance. You can also attach a symbol
or note that is offset from a leader arrow endpoint.

Specifying the Grouping of a Symbol Instance

Using the Grouping page of the Symbol Instance dialog box, you can display the tree representation of the
grouping hierarchy of the symbol.

To expand and contract tree elements, select the square to the left of the subgroup name as follows:

e Select the subgroup once to include it in the instance.
e Select it again to remove it (and all subgroups) from the symbol.

Enabling or disabling a group does not expand or contract its subgroups; however, you can select the square to
the left of the subgroup name to modify the tree view. If you include a subgroup, this enables all parents
recursively (if you have not already enabled them). If you disable a parent, you disable all children. If you re-
enable a parent, the system restores the status of its subgroups.

To Create an Instance of a Generic Symbol

1. Click Insert > Symbol Instance.

2. In the Symbol Instance dialog box, click Pick in Draw to select a symbol in the drawing, or click Retrieve

to retrieve a system symbol from disk.

Specify the height of the instance by typing a value in the Height box.

Specify the placement type by selecting an item from the Type list.

5. Click Grouping to specify the groups and subgroups to include in the particular instance. Only the groups
that you select from group namelist menus appear in the instance.

6. The dialog box displays a tree representation of the grouping hierarchy of the symbol. Select groups as
follows:

— If groups are independent, select any number of groups.

W

— If groups are exclusive, select only one group to include in the symbol.
7. Expand the tree structure to show the subgroups, and select the ones that you want. Click OK.
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Modifying Variable Text in an Instance

Using the Var Text page of the Symbol Instance dialog box, you can change the content of a note included in a
symbol instance if the text was created as variable text.

You can modify text parameters when redefining the symbol. However, when you attempt to modify text
parameters in instances, you should consider the following:
e For variable-height symbols, you cannot modify text height independently of the symbol size.

e For fixed-height symbols, you can modify text only when you are redefining a symbol. Choose Mod Text
from the SYMBOL EDIT menu to access text editing commands.

To Modify the Values of Variable Text

1. Click Insert > Symbol Instance.

2. Select the symbol instance to modify.

3. In the Symbol Instance dialog box, click Var Text. The dialog box displays a set of predefined values for
the symbol instance from which you can choose only one. The predefined values, like the default values of
variable texts, are part of the symbol definition.

4. Specify default values and additional predefined values of variable text, or select variable text of the
instance in the drawing in the preview window and then modify it.

To Adjust Instance Location

You can change the position of a symbol instance any time after you add it to the drawing. Using the Move,
Move Text, or Mod Attach buttons in the Symbol Instance dialog box, you can adjust the location of an
instance by dragging it. As you place a symbol, it moves dynamically, attached to the cursor. When you place it,
the fixed symbol text appears.

o [fthe symbol has variable text, type the text value.

e Ifyou are relocating a symbol and decide not to place it dynamically, press the middle mouse button to exit
(this functionality is not available for Variable - Model Units symbols).

About Manipulating Instances

Using the Pro/DETAIL menu, you can modify, display, erase, and delete instances; include instances in notes;
and relate instances to dimension text. You can also show symbols for welds that you create in Pro/WELDING.

Modifying Instances
After you create a symbol, you can use the Symbol Instance dialog box to modify it in the following ways:

e Explode (snapshot) a symbol instance.

e Change the symbol height.

e Change the rotation angle.

e Move the origin of the symbol.

e Change the grouping attributes.

e Modify variable text.

You can also reattach instances and add new leader lines.

To Modify a Symbol Instance

1. Click Insert > Symbol Instance. The Symbol Instance dialog box opens.
2. Select an instance.
3. Using the Symbol Instance dialog box, modify the instance by doing one or all of the following:
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— Explode the instance by selecting Explode from the Symbol Definition Usage list. Pro/ENGINEER
copies the entities of the selected instance to a drawing, and deletes the instance. A node is represented
by a filled dot, and the note that the system creates by exploding the node note is attached to the dot. It
only copies visible symbol entities, and deletes the symbol leader (if it exists).

— Change the symbol height by typing a value in the Height box.

— Change the rotation angle by typing a value in the Angle box.

Note: Before rotating a symbol instance, you can reset the parameter that controls text positioning by
redefining the symbol definition using the Attributes command in the SYMBOL EDIT menu; however,
modifying symbol attributes affects a/l instances of this symbol definition.

— Move the origin by clicking Move Origin and selecting a view.

4. When you have finished, click OK to update the display of the instance.

To Rotate Symbols with Text

When you are rotating a symbol, any text included in a symbol behaves according to how you defined it in
symbol attributes (that is, whether you selected the Fixed Text Angle check box in the Attributes box of the
Symbol Definition Attributes dialog box).

Using the drawing setup file option sym flip rotated_ text, you can flip the text of a rotated symbol. If
you set it to yes (the default is no), and the symbol orientation is +/- 90 degrees, all of the text that you defined
in the Attributes box of the Symbol Definition Attributes dialog box menu flips, rotating along with the
symbol.

Examples: Rotating Symbols with Text

Rotating a Symbol with Text

1 N 2 3

1 The symbol in its original position.
2 The symbol created when using the Fixed Text Angle check box.
3 The symbol created when using Fixed Text Angle and rotating the symbol during instance creation.
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Flipping Text Using "sym_flip rotated text"
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To Reattach a Symbol Instance

Using the Mod Attach command in the Pro/DETAIL menu, you can reattach a symbol instance with a leader
any time after you have added it to a drawing by doing one of the following:

e Reattach the symbol leader to a new point on geometry in a drawing.
e Reattach a symbol leader to a new point on an entity that includes a symbol.

Adding New Leader Lines

You can add leaders to symbols (and delete them) following the same procedure that you use to add leaders to
drawing notes. However, the following restrictions apply:
¢ You cannot add new leaders to BOM symbols or to datum target symbols.

e To add a leader to a user-defined symbol, you must specify an attribute in the symbol definition to place the
symbol with a leader. Similarly, to delete a leader from a user-defined symbol, you must specify an attribute
in the symbol definition to place the symbol without the leader.
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To Add Another Leader Line to a Symbol

1. Click Edit > Attachment.

2. Select a reference point on the view for the leader.

3. Click Add Ref.

4. Choose GET SELECT > Done Sel and ATTACH TYPE > Done. The system adds the additional leader.

— To add more than one leader, repeat Steps 2 and 3.
— To delete a leader, choose Delete Ref.

To Erase and Display Symbol Instances

Using the Show and Erase dialog box, you can erase symbol instances from a drawing by blanking selected
symbols. To redisplay them, click Show.

To Delete Symbol Instances

You can remove symbol instances from a drawing by using Delete in the Pro/DETAIL menu. When you delete
an instance from the drawing, the system does not delete the symbol definition from the drawing. To remove it,
choose Delete from the DWG SYMBOL menu.

About Working with Parametric Weld Symbols

You can show weld symbols in drawings for welds that were created in Pro/WELDING, as well as redefine the
system-supplied parametric weld symbols to improve your flexibility and productivity.

Showing Symbols for Welds Created in Pro/WELDING

You can show and erase weld symbols in drawings that correspond to welds that were created in an assembly
using Pro/WELDING. You can also do the following:

e Modify the number of decimal places (num digits) shown in dimensions contained within a weld feature.
e Add or delete leader lines to weld symbols.

To display weld symbols from Pro/WELDING in drawings according to the ANSI or ISO standard, set the
value of the drawing setup file option weld symbol standardto STD ANSI or STD_ ISO, respectively.

Restrictions on the Use of Weld Symbols in Drawings
When you are working with weld symbols, the following restrictions apply:
o The display of the weld feature does not affect the display of the weld symbol, and it does not update its

point of attachment when you blank, resume, erase, or show the weld feature. However, when the system
first shows a weld symbol, its default attachment adapts to the display status of its feature.

e The system shows a weld symbol only once in a drawing, similar to assembly geometric tolerances and
surface finishes.

e Revision 15.0 and later revisions support the following compound welding symbols:

— Reinforced Welds: square groove, bevel groove, flared bevel groove, and J-groove (all reinforced welds
can also be two-sided).

— Two-sided Welds: fillet, square groove, V-groove, bevel groove, U-groove, J-groove, flared V-groove,
flared bevel groove.

To Show Weld Symbols in a Drawing

1. Choose View > Show and Erase.
2. Inthe Show and Erase dialog box, click Show and select Symbol from the Type box.
3. Select an item from the Show By box to specify a feature, view, or part in which to show the weld symbols.
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To Erase Weld Symbols

1. Choose View > Show and Erase.

2. In the Show and Erase dialog box, click Erase and select Symbol from the Type box.

3. Choose the appropriate buttons to select weld features, and specify the appropriate weld symbols. The
system erases the specified symbols.

To Show or Erase Weld Features in a Drawing

1. Choose View > Show and Erase.
2. Inthe Show and Erase dialog box, click Show or Erase; then select Cosmetic Feature from the Type box.
3. Choose the appropriate option buttons and commands to show weld features in the drawing or erase them.

Modifying the Number of Decimal Places of a Fillet
Weld Feature

When you are using Num Digits to modify a value of a fillet weld feature (simple, two-sided, or reinforcing a
groove) that has differing leg length values shown in the symbol, such as "L1 x L2," the number of decimal
places shown in the two values are linked. That is, if you select this portion of the symbol for modification, the
system highlights the entire "L1 x L2," and both values change to the number of decimal places you specify.

To Regroup Weld Symbol Instances

To regroup weld symbol instances, set the configuration file option sym leader orient move_ text to
yes (the default is no). The system then regroups an instance after you move the text.

User-Defined Parametric Weld Symbols

You can replace the Pro/ENGINEER-supplied library of system weld symbols with user-defined ones. After
you define the symbols, the system uses them for automatic weld annotation. By customizing your weld
symbols in advance, you can increase your flexibility and productivity throughout the processes of creating and
modifying drawings.

Note: Before performing this procedure, you should copy the system-supplied welding symbol library to a
backup directory.
However, when creating user-defined weld symbols, the following restrictions apply:

o All of the groups that existed in the original definition must remain in the new definition, and you cannot
add new ones or change the names of existing ones.

e Ifyou add new variable text, or change the name of an existing piece of variable text, the new name must be
the same as that of the existing variable text in the original.

e The height type of the symbol instance must be the same in the new user-defined symbol as it was in the
original.

e The Left Leader and Right Leader placement types must both exist in the new user-defined weld symbol.

ISO Welding Symbols

This section presents examples of symbols that enable you to create welding, brazing, and examination symbols
in a drawing according to the ISO standard. To help you create symbol instances, it provides the following
information for each symbol:

e The symbol name

e An example of an instance created from this symbol and the associated menu picks

e Listings of groups and subgroups in menu format reflecting a tree symbol definition structure

298 Pro/DETAIL



You can also refer to Glossary of Menu Picks below for an explanation of menu selections for welding
symbols.

Welding Symbols Library

The Welding Symbols Library, available with Pro/DETAIL, provides a collection of symbols based on the
standards of ISO-2553-1984. Using this library, you can create a variety of welding, brazing, and examination
symbols in a drawing.

To retrieve a symbol from the Welding Symbol Library, choose System Syms from the Select File menu to
access the Pro/ENGINEER symbols area.

Glossary of Menu Picks

This glossary describes terms that are unique to the ISO Welding Symbol Library and identifies information
you are prompted to enter. Menu pick names track the ISO Welding Symbol Library to the fullest extent
possible. (For terms that are also used in the ANSI Welding Symbol Library—and are, therefore, not unique to
the ISO Welding Symbol Library—see Glossary of Menu Picks in Appendix B, ANSI Generic Welding
Symbols).

In the ISO Welding Symbol Library, two lines form the reference line, one solid and one dashed. Weld symbols
attached to the solid line are "arrow-side." Weld symbols attached to the dashed line are "other-side." The
dashed line is only omitted for symmetrical welds. When creating a welding symbol, you first select whether
the weld is arrow side, other-side, or symmetrical. If you choose ARROW_SIDE or OTHER_SIDE, the system
prompts you to create the weld symbol above or beneath the reference line. It then places the dashed line
appropriately in the symbol depending on whether it is arrow-side or other-side.

Table 1: ISO Weld Characteristics Menu Selections

MENU PICK OPTION DESCRIPTION
ABOVE REF Creates the weld symbol above the solid
reference line.
AS ABOVE_REF Indicates (for combination welding symbols

only) whether the arrow-side welding
symbol is placed above or beneath the
reference line.

BENEATH REF Creates the weld symbol beneath the solid
reference line.
BUTT SIZE Refers to the final size of the weld,

depending on the symbol type (arrow-side,
other-side, symmetrical, or staggered). It
might have the suffix "AS" (arrow-side) or
"OS" (other-side) to indicate the appropriate

weld side.

CONTOUR SMOOTH_BLEND Describes the final shape of the weld. This
choice indicates that the toes of the weld are
blended smoothly.

FINISH In the ANSI standard, this specifies the

method of finishing. In the ISO standard, the
system adds a machine finish surface texture
symbol above the contour symbol.

FILLET SIZE Refers to the final size of the weld,
depending on the symbol type (arrow-side,
other-side, symmetrical, or staggered). It
might have the suffix "AS" (arrow-side) or
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FIL_SIZE

HOLE_DIA
OS_ABOVE_ REF

PROJECT DIA
SEAM_WIDTH
SPOT DIA

STYLE

SYMMETRICAL

TAIL

WELD_SIZE

WELD TYPE

300

CONTINOUS

INTERMITTENT

REFERENCE
WELD PROCESS

"OS" (other-side) to indicate the appropriate
weld side.

Refers to the final size of the weld,
depending on the symbol type (arrow-side,
other-side, symmetrical, or staggered). It
might have the suffix "AS" (arrow-side) or
"OS" (other-side) to indicate the appropriate
weld side.

Refers to the diameter of a plug weld.

Indicates (for combination welding symbols
only) whether the other-side welding
symbol is placed above or beneath the
reference line.

Refers to the diameter of a projection weld.
Refers to the width of a seam weld.

Refers to the diameter of a spot or fusion
weld.

Refers to the longitudinal dimension of a
weld. Two choices are available:

Weld joint continuously for the specified
length.

Creates weld beads of specified length,
distance between adjacent weld elements,
and specific number of beads.

Refers to a welding symbol for creating
identical welds on both arrow-side and
other- side.

Creates a tail on the opposite end of the
welding symbol from the leader attachment.
Provides two choices:

Enters reference text or note.
Specifies a welding process.

Refers to the final size of the weld,
depending on the symbol type (arrow-side,
other-side, symmetrical, or staggered). It
might have the suffix "AS" (arrow-side) or
"OS" (other-side) to indicate the appropriate
weld side.

For combination welding symbols, indicates
the type of weld being created and whether
it is created arrow-side or other-side (e.g.,
FILLET AS).
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Bevel Butt Symbol: Bevel Butt.sym

EXAMPLE 1
PICKS
1. arrow_side 10. strip
2. above ref 11. left
3. style 12. removable
4. contour 13. field
5. back_type 14. all around
6. finish 15. tail
7. leader orient 16. weld_process
8. intermittent
9. convex
7 10S00000) 7 gy
MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference

TYKO
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EXAMPLE 3

PICKS

1. symmetrical 11. convex
2. style as 12. flat
3. style os 13. left
4. contour as 14. all around
5. contour os 15. field
6. finish as

7. finish os

8. leader orient

9. intermittent

10. continuous

B

‘ 8x30(60)
300

|
&
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Symbol Definition Structure

BEVEL BUTT.SYM

ARROW SIDE

ALL AROUND
FIELD
TAIL

REFERENCE
WELD PROCESS

Pro/DETAIL

OTHER™SIDE
SYMMETRICAL

[ STYLE AS
STYLE—OS

[ CONTOUR AS

CONTOUR™OS
FINISH AS
FINISHTOS

LEADER_ORIENT

ABOVE REF
BENEATH_REF,
CONTINUOUS
INTERMITTENT
LEADER ORIENT
A srvee -
v | CONTOUR
- BACK_TYPE
FLAT FINTSH
CONTINUOUS CONVEX
INTERMITTENT | | SMOOTH_BLEND
CONTINUOUS
INTERMITTENT
BACK_SIZE
STYLE
CONTOUR
FINISH
FLAT BACKING LEEL
CONVEX STRIP
SMOOTH_BLEND
PERMANENT
FLAT
REMOVABLE ELAT o
SMOOTH_BLEND|

LEFT
RIGHT

ALL AROUND
FIELD

TAIL

REFERENCE
WELD PROCESS
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Inclined Joint Symbol: Inclined_Joint.sym
EXAMPLE 1

PICKS

arrow_side
weld size
finish

flat

leader orient
left

field

all around
tail

weld process

O W 00 Joy U b WN

=

DFST32

EXAMPLE 2
PICKS

other side
weld-size
leader orient
left

field

all around
tail
reference

O J oy U wDN R

__________ GHFR45
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Symbol Definition Structure

INCLINED_ JOINT.SYM

" ARROW_SIDE
+ OTHER SIDE

WELD SIZE
FINISH

FLAT
LEADER_ORIENT

]

LEFT
RIGHT

ALL_AROUND
FIELD
TAIL

REFERENCE
WELD PROCESS
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Bevel Butt with Broad Root Face: Br_Root_Bevel.sym

EXAMPLE 1

PICKS

1. arrow side 11. strip

2. above ref 12. left

3. weld size 13. removable
4. style 14. field

5. contour 15. all around
6. back type 16. tail

7. finish 17. weld process
8. leader orient

9. intermittent

10. convex

o

)

8 P/ 10x50(100
MR

— — ATM- |
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference

3 8x30(50)_ STEEL

306
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Pro/DETAIL

EXAMPLE 3

PICKS

1. symmetrical 11. intermittent

2. weld size as 12. continuous

3. weld size os 13. convex

4. style as 14. flat

5. style os 15. left

6. contour as 1l6. a}l_around
- 17. field

7. contour os

8. finish as

9. finish os

6
4

'i 10x50¢ 100)
}\ 200

307



Symbol Definition Structure

BR_ROOT_BEVEL.SYM

ABOVE REF

Y

BENEATH REF|<¢—— ARROW SIDE

WELD SIZE
STYLE
CONTOUR

BACK TYPE

~ FINISH

— LEADER ORIENT

OTHER SIDE
SYMMETRICAL

y

I

CONTINUOUS | g [
INTERMITTENT]

LEFT
RIGHT

— ]

FLAT
CONVEX
SMOOTH_BLEN

g

CONTINUOUS
INTERMITTENT
A
FLAT M
CONTINUOUS CONVEX
INTERMITTENT | | SMOOTH_BLEND
BACK SIZE
STYLE
CONTOUR
FINISH
FLAT BACKING
CONVEX STRIP
SMOOTH_BLEND
PERMANENT
REMOVABLE
ALL AROUND
FIELD
TAIL
Y
REFERENCE

WELD PROCESS

308

WELD SIZE AS
WELD SIZE OS
STYLE AS
STYLE—OS
CONTOUR AS
CONTOUR™0S
FINISH AS
FINISH OS
LEADER_ORIENT

LEFT
RIGHT

ALL AROUND
FIELD
TAIL

REFERENCE
WELD PROCESS

Pro/DETAIL



Slot Symbol: Iso_Slot.sym

EXAMPLE 1

PICKS

arrow_side
slot width
style
contour
finish

intermittent
convex

left

field

O W O Jo U whk

=

leader-orient

11. tail
12. weld process

10x40(100)

EXAMPLE 2

DFRQ45

PICKS

other side
slot width
style
contour

continuous

left
field
tail

oW JdJ oy Ul WP

[

leader orient

smooth blend

11. reference

=== HJKG45

Pro/DETAIL
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Symbol Definition Structure

CONTINUOUS
INTERMITTENT

FLAT

CONVEX
SMOOTH_BLEND

ISO_SLOT.SYM

ARROW_ SIDE
OTHER SIDE

SLOT WIDTH
STYLE
CONTOUR
FINISH

LEADER_ORIENT

LEFT
RIGHT

FIELD
TAIL

REFERENCE
WELD PROCESS

310
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Spot Symbol: Iso_Spot.sym
EXAMPLE 1

PICKS

fusion 11. tail

above ref 12. weld process
spot dia

number pitch

contour

finish

leader orient

convex

left

field

O WV OJdo O W

=

\hz @ 12040) SEaTer

EXAMPLE 2

PICKS

resistance
spot dia
number pitch
leader orient
left

field

tail
reference

O J o 0w

re /TN 30040)
_ -, FGTR35
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EXAMPLE 3

PICKS

. projection
project dia
number pitch
leader orient
left

tail

. reference

~ o U b W DN

\Pm /N 12040)
XDSC
% N

Symbol Definition Structure

ISO_SPOT.SYM

FUSION
ABOVE REF - RESISTANCE
BENEATH REF t PROJECTION

FLAT SPOT DIA SPOT DIA PROJECT DIA
CONVEX NUMBER PITCH NUMBER PITCH NUMBER PITCH
CONCAVE CONTOUR LEADER ORIENT| | LEADER ORIENT
SMOOTH_BLEND FINISH —

LEADER _ORIENT

H

LEFT LEFT
RIGHT RIGHT
FIELD
FIELD
TATL TAIL
REFERENCE REFERENCE

WELD PROCESS WELD_PROCESS

312 Pro/DETAIL



Seam Symbol: Iso_Seam.sym

EXAMPLE 1

PICKS

above ref 12. tail
seam width
style

contour
finish

leader orient
intermittent
convex

left

O W O Joy U W

=

fusion 11. field

13. weld process

Dk

20x50(80)

EXAMPLE 2

DFWR3

PICKS

1. resistance
2. seam width
3. style

4. leader orient
5. continuous
6. left

7. field

8. tail

9. reference

-—

Pro/DETAIL

GHTU80
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EXAMPLE 3

PICKS

1. projection
2. seam width
3. style

4. intermittent

P5.5 _#::}_ 20x50(80)
4(:7F

Symbol Definition Structure

ISO_SEAM.SYM

y

RESISTANCE T
CONTINUOUS ABOVE REF - FUSION
INTERMITTENT BENEATH REF PROJECTION
FLAT CONTOUR SEAM WIDTH
CONVEX FINISH STYLE
CONCAVE LEADER ORIENT —LEADER ORIENT
SMOOTH BLEND SEAM WIDTH —
STYLE
CONTINUOUS
Y INTERMITTENT
LEFT LEFT
RIGHT RIGHT
FIELD
FIELD
TATL TAIL
REFERENCE REFERENCE
WELD PROCESS WELD PROCESS
314
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Plug Symbol: Iso_Plug.sym

EXAMPLE 1

=

O © o Joy Ul b WN

PICKS

arrow side 11.

hole dia
number space
contour
finish

leader orient
convex

left

field

tail

weld process

EXAMPLE 2

SDRTS5

1
2
3
4.
5.
6
7
8
9
0

PICKS

other side
hole dia
contour
number space
leader orient
smooth blend
left

field

tail
reference

Pro/DETAIL

FGHJ45

315



Symbol Definition Structure

ISO_PLUG.SYM

ARROW_SIDE
OTHER SIDE

FLAT
CONVEX
SMOOTH_BLEND

HOLE DIA
NUMBER SPACE
CONTOUR
FINISH

LEADER ORTENT

LEFT
RIGHT

FIELD
TAIL

REFERENCE
WELD_ PROCESS

316
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Fillet Symbol: Iso_Fillet.sym

EXAMPLE 1

PICKS

1. arrow_side 8. intermittent

2. above ref 9. convex

3. fillet size 10. left

4. style 11. field

5. contour 12. all around
O 13. tail

6. finish 14. weld process

7. leader orient a

4‘\\%i]0x50H00)

______________ DFX$32

EXAMPLE 2

PICKS
1. other side 8. flat
2. beneath ref 9. lgft
3. fillet size 10. field
4. stvle - 11. all around

- SHY 12. tail
5. contour 13. reference
6. leader orient
7. continuous

—_—————— DWRT45
6];27; 400
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EXAMPLE 3

PICKS
1. symmetrical 11. intermittent
2. fil size as 12. continuous
3. fil size os 13. concave
4. style as 14. flat
5. style os 15. left
6. contour as 16. all around
7. contour os 17. field
8. finish as
9. finish os
10. leader:orient
A\
8 10x50(100)
4 ‘/V 400
EXAMPLE 4
PICKS
1. staggered
2. fil size as
3. contour_ as
4. leader orient
5. smooth blend
6. left
7. all around
8. field
r |%
8 10x50 i 100)

318 Pro/DETAIL



Symbol Definition Structure

’ ISO_FILLET.SYM

Y
CONTINUOUS r ABOVE REF 4.4£:é$§g§—§%gg
INTERMITTENT | BENEATH REF [ SYMMETRICAL
| STAGGERED
FLAT FILLET SIZE
CONVEX <—L STYLE —
CONCAVE | CONTOUR FIL SIZE AS
SMOOTH_BLEND FINISH FIL_ SIZE_OS
LEADER_ORIENT| [T STYLE OS
CONTOUR_AS
CONTOUR_0S
i“““‘* FINISH AS
; FINISH OS
CONTINUOUS LEADER ORIENT
LEFT INTERMITTENT =
RIGHT vAJ
— LEFT
RIGHT
FLAT
FIELD CONVEX
ALL AROUND CONCAVE
TAIL SMOOTH_BLEND
FIELD
ALL AROUND
TAIL
REFERENCE —
WELD PROCESS
REFERENCE

WELD_ PROCESS
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J Butt Symbol: J_ Butt.sym

EXAMPLE 1
PICKS
1. arrow side 11. strip
2. above ref 12. left
3. weld size 13. removable
4. style 14. field
5. contour 15. all around
6. back type l6. tail
7. finish 17. weld process
8. leader orient
9. intermittent
10. convex
= _8 _H IOKSE(lOE) DFTR
MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference
3 [0x50(100)

SQRT

320 Pro/DETAIL



EXAMPLE 3

PICKS

symmetrical
weld size as
weld size os
style as
style os
contour as
contour os
finish as
finish os
leader orient

S 0 0w Jo Ubdw N

=

11.
12.
13.
14.

15.
l6.
17.

intermittent
continuous
convex

flat

left
all around
field

0x50(100)

400

Pro/DETAIL

A
P
' N
A\
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Symbol Definition Structure

J_BUTT.SYM

ABOVE REF
BENEATH REF <4 ARROW SIDE
OTHER SIDE
SYMMETRICAL
CONTINUOUS
INTERMITTENT
} WELD SIZE
A sryiE
v CONTOUR
BACK TYPE
FINISH
FLAT —
CONTINUOUS CONVEX LEADER ORIENT —
INTERMITTENT | | SMOOTH BLENT WELD SIZE AS
- WELD SIZE_OS
CONTINUOUS STYLE AS
INTERMITTENT ] sTYLE0S
CONTOUR AS
U CcoNTOUR0S
BACK SIZE FINISH &S
STYLE FINISH 0S
CONTOUR LEADER ORIENT
FINISH E
Y ; ; LEFT
LEFT RIGHT
FLAT BACKING RIGHT
CONVEX STRIP
SMOOTH_BLEND

- |

PERMANENT
FLAT la
REMOVABLE ey
SMOOTH_BLEND

322

WELD PROCESS

REFERENCE

ALL AROUND
FIELD
TAIL

ALL AROUND
FIELD
TAIL

REFERENCE

WELD_PROCESS

Pro/DETAIL



Square Butt Symbol: Iso_Square.sym

EXAMPLE 1

PICKS

1. arrow side 11. strip

2. above ref 12. left

3. weld size 13. removable
4. style 14. field

5. contour 15. all around
6. back type 16. tail

7. finish 17. weld process
8. leader orient

9. intermittent

10. convex

A

4‘ ‘ 20x40(100)

- L = SPG25

MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient l6. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference

4 [ 0x50(100) SPG46

)%
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EXAMPLE 3

PICKS
1. symmetrical 11. intermittent
2. weld size as 12. continuous
3. weld size os 13. convex
4. style as 14. flat
5. style os 15. left
6. contour as 16. all around
7. contour os 17. field
8. finish as
9. finish os
10. leader orient
‘ ‘ 10x50(100)
324
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Symbol Definition Structure

ISO_SQUARE.SYM

ABOVE REF
BENEATH REF

< | ARROW SIDE
OTHER_ _SIDE

SYMMETRICAL
CONTINUOUS

INTERMITTENT
WELD SIZE
A | sty
§ | CONTOUR
BACK TYPE
FLAT _ | FINISH

CONTINUOUS CONVEX —| LEADER_ORIENT
INTERMITTENT| | SMOOTH_BLEND

WELD SIZE AS
WELD”SIZE OS
CONTINUOQUS STYLE AS
INTERMITTENT{ STYLE OS

CONTOUR AS

CONTOUR™0S
BACK SIZE FINISH &S
STYLE FINISH OS
CONTOUR LEADER ORIENT
FINISH =
{ ; LEFT
RIGHT
FLAT BACKING ﬁ%ggT
CONVEX STRIP
SMOOTH_BLEND
ALL AROUND
' FIELD
PERMANENT TAIL
REMOVABLE FLAT <
CONVEX
SMOOTH_BLEND
REFERENCE
ALL AROUND WELD_PROCESS
FIELD
TAIL

REFERENCE
WELD_PROCESS
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V Butt Symbol: V_Butt.sym

EXAMPLE 1
PICKS
1. arrow side 11. left
2. above ref 12. removable
3. style 13. field
4. contour 14. all around
5. back type 15. tail
6. finish l6. weld process
7. leader orient
8. intermittent
9. convex
10. strip
SRV
MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference
3 6x30(80) GHTR

___/R_s_so___
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EXAMPLE 3

PICKS
1. symmetrical 11. convex
2. style as 12. flat
3. style os 13. left
4. contour as 14. all around
5. contour os 15. field
6. finish as
7. finish os
8. leader orient
9. intermittent
10. continuous
Xz
\\V//GXGO(IZO)
/\ 50
ﬁ\
Pro/DETAIL
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Symbol Definition Structure

V_BUTT.SYM

ABOVE REF
BENEATH_REF | g ARROW SIDE
OTHER SIDE
SYMMETRICAL
CONTINUOUS
INTERMITTENT“TA
STYLE
CONTOUR
{444447 BACK TYPE
— FINISH
——— | FLAT — LEADER_ORIENT
CONTINUQUS CONVEX Y
SMOOTH BLEND|
INTERMITTENT . Ten s
A FINISH 0OS
CONTINUOUS L STYLE &S
INTERMITTENT| <L S7vTF 03
+ CONTOUR_AS
BACK SIZE (L CONTOUR—0S
STYLE LEADER_ORIENT
CONTOUR
FINISH
{4444744444} LEFT
RIGHT
FLAT BACKING REEET
CONVEX STRIP
SMOOTH_BLEND 4‘
ALL AROUND
‘ FIELD
PERMANENT TATL
REMOVABLE FLAT 1
CONVEX
SMOOTH BLEND]
REFERENCE

WELD PROCESS
ALL AROUND —

FIELD
TAIL

REFERENCE
WELD_PROCESS
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U Butt Symbol: U_Butt.sym

EXAMPLE 1
PICKS
1. arrow_side 11. strip
2. above ref 12. left
3. weld size 13. removable
4. style 14. field
5. contour 15. all around
6. back type 16. tail
7. finish 17. weld process
8. leader orient
9. intermittent
10. convex

— > L IO{??}LPQ) STEEL

MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back_size 20. reference
4 10X50C100) SDRE

___/_J%_Eoo___
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EXAMPLE 3

PICKS
1. symmetrical 11. intermittent
2. weld size as 12. continuous
3. weld size os 13. convex
4. style as 14. flat
5. style os 15. left
. 16. all around
6 t -
conrour_as 17. field
7. contour_ os
8. finish as
9. finish os
10. leader orient
8w20x30(60)
6/J\ 400
330
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Symbol Definition Structure

U_BUTT.SYM

ABOVE REF
BENEATH_REE

ARROW SIDE
OTHER SIDE
SYMMETRICAL

CONTINUOUS
INTERMITTENT

WELD SIZE
A | sTyie
y | CONTOUR
BACK TYPE
FLAT — FINISH
— LEADER ORIENT
CONTINUOUS CONVEX x

INTERMITTENT| | SMOOTH_BLEND

WELD SIZE AS

WELD_SIZE_OS
CONTINUOUS |gf| SIYLE_AS
INTERMITTENT| STYLE 0S
] CONTOUR AS
CONTOUR_0S
BACK SIZE CONTOUR 2
ot FINISH OS
foNTen” LEADER_ORIENT|
FINISH _
;4444’4444} LEFT
RIGHT
FLAT BACKING RoEET
CONVEX STRIP
SMOOTH BLEND AAAAAAAAAAAJ
ALL AROUND
‘ FIELD
PERMANENT TATL
FLAT e
REMOVABLE ELAT
SMOOTH_BLENT
REFERENCE
WELD_PROCESS
ALL AROUND _
FIELD
TAIL

REFERENCE
WELD PROCESS
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Surface Joint Symbol: Surface Joint.sym
EXAMPLE 1

PICKS

1. arrow side

2. weld size

3. leader orient
4. left

5. field

6. all around

7. tail

8. weld process

EXAMPLE 2

STRP45

PICKS

other side
weld size
leader orient
left

field

all around
tail
reference

0 ~J o U WDN R

HJGF66

332
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Symbol Definition Structure

SURFACE_JOINT.SYM

ARROW_SIDE
OTHER SIDE

WELD SIZE
LEADER_ORIENT

LEFT
RIGHT

ALL AROUND
FIELD
TAIL

REFERENCE
WELD PROCESS

Pro/DETAIL
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Surfacing Symbol: Iso_Surfacing.sym

EXAMPLE 1
PICKS

arrow_side 11. weld process

weld size
contour
finish

leader orient
concave

left

field

all around
tail

O W O Joy U Wb

=

EXAMPLE 2

PICKS

other side
weld size
contour
leader orient
flat

left

field

all around
tail
reference

O WO ~J oy U b WN -

=

——A——w—— SADFG
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Symbol Definition Structure

ISO_SURFACING.SYM

ARROW_SIDE
OTHER_SIDE

FLAT

CONVEX
CONCAVE
SMOOTH_ BLEND

b

WELD SIZE
CONTOUR
FINISH
LEADER_ORIENT

LEFT
RIGHT

FIELD
TAIL

ALL AROUND

REFERENCE
WELD PROCESS

Pro/DETAIL
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Steep-flanked V-butt Symbol: Steep V.sym

EXAMPLE 1

PICKS

1. arrow_side 11. left

2. above ref 12. removable
3. style 13. field

4. contour 14. all around
5. back type 15. tail

6. finish 16. weld process
7. leader orient

8. intermittent

9. convex
10. strip

2

_____ 10x500100)_ “hsTh42

MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back_type 15. smooth blend
6. leader orient l6. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back_size 20. reference

3 [0x50(100) DFRT3

WANE
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EXAMPLE 3

PICKS

symmetrical
style as
style os
contour as

finish as
finish os
leader orient
intermittent

1
2
3
4
5. contour os
6
7
8
9
0. continuous

11.
12.
13.
14.
15.

convex
flat

left

all around
field

0x50(100)

Pro/DETAIL
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S
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Symbol Definition Structure

STEEP_V.SYM

ABOVE REF

WELD PROCESS

338

BENEATH_REF | o ARROW SIDE
OTHERSIDE
SYMMETRICAL
CONTINUOUS
INTERMITTENT ‘L
STYLE
CONTOUR
; FINISH
| BACK TYPE
FLAT | LEADER ORTENT
CONTINUOUS CONVEX Y
INTERMITTENT| | SMOOTH_ BLEND FINISH AS
FINISH OS
CONTINUOUS | ] STYLE AS
INTERMITTENT STYLE0S
| it
BACK SIZE
STYLE LEADER ORIENT
CONTOUR
FINISH
{44447 ‘ LEFT
RIGHT
FLAT BACKING g%ggT
CONVEX STRIP
SMOOTH_BLEND| AAAAAAAAAAAAJ
ALL AROUND
‘ FIELD
PERMANENT TAIL
FLAT
REMOVABLE T e -
SMOOTH_BLEND
REFERENCE
WELD PROCESS
ALL AROUND -
FIELD
TAIL
REFERENCE

Pro/DETAIL



Steep-flanked Bevel Butt Symbol: Steep Bevel.sym

EXAMPLE 1
PICKS
1. arrow side 11. left
2. above ref 12. removable
3. style 13. field
4. contour 14. all around
5. back_type 15. tail
6. finish 16. weld process
7. leader orient
8. intermittent
9. convex
10. strip
S ‘_/'0"_50_( 00)  “spre4s
MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient le. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference
4 NSx30(60) ADFR32
{\ 400
Pro/DETAIL
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EXAMPLE 3

PICKS

1. symmetrical 11. convex

2. style as 12. flat

3. style os 13. left

4., contoar_as 14. all around
5. contour os 15. field

6. finish as

7. finish os

8. leader orient

9. intermittent

ra
‘/mxsouom
N

500

VAN
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Symbol Definition Structure

STEEP_BEVEL.SYM

ABOVE REF

ALL AROUND

Y

REFERENCE
WELD PROCESS

Pro/DETAIL

FIELD
TAIL

BENEATH_REF|<¢—| ARROW SIDE
OTHER SIDE
SYMMETRICAL
CONTINUOUS
INTERMITTENT|<¥
STYLE
CONTOUR
¥ BACK_TYPE
y —{ FINISH
FLAT — LEADER ORTENT
CONT INUOUS SMOOTH BLEND
INTERMITTENT - FINISH AS
FINISH OS
CONTINUOUS STYLE AS
<+{| STYLE0S
INTERMITTENT STERE 95 o
—{| conTOUR—0S
BACK SIZE LEADER ORIENT
STYLE =
CONTOUR
FINISH
; LEFT
RIGHT
FLAT BACKING
CONVEX STRIP
SMOOTH_BLEND
Y
ALL_AROUND
‘ FIELD
PERMANENT TAIL
REMOVABLE FLAT 1-
CONVEX
SMOOTH_BLEND
REFERENCE

WELD PROCESS

341



V-butt with Broad Root Face Symbol: Broad Root V.sym

EXAMPLE 1
PICKS
1. arrow side 11. strip
2. above ref 12. left
3. weld size 13. removable
4. style 14. field
5. contour 15. all around
6. back type 16. tail
7. finish 17. weld process
8. leader orient
9. intermittent
10. convex
_ & T 10x50(100) “spgy
MR
EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. field
8. flat 18. all around
9. backing 19. tail
10. back size 20. reference
__ 23080 ASTM-38
300

342
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EXAMPLE 3

PICKS

symmetrical
weld size as
weld size os
style as
style os
contour as
contour os
finish as
finish os

O W O J o U WD

=

leader orient

intermittent
continuous
convex

flat

left
all around
field

Y

10x50(100)

Pro/DETAIL
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Symbol Definition Structure
ABOVE REF
BENEATH_REF
CONTINUOUS
INTERMITTENT
A444447 WELD SIZE
STYLE
i —| CONTOUR
BACK TYPE
FLAT | FINISH
CONTINUOUS gggg%é BLEND — LEADER_ORIENT
INTERMITTENT —_
CONTINUOUS < [
INTERMITTENT]

BACK S
STYLE
CONTOU
FINISH

IZE
R

—

FLAT
CONVEX

BACKING
STRIP

SMOOTH_BLEND

BROAD_ROOT_V.SYM

ARROW SIDE

OTHER”SIDE
SYMMETRICAL

Y

LEFT
RIGHT

— ]

PERMANENT
REMOVABLE

ALL AROUND

FIELD
TAIL

REFERENCE
WELD PROCESS

344

WELD SIZE AS
WELD SIZE OS
STYLE AS —
STYLE—OS
CONTOUR_AS
CONTOUR__OS
FINISH AS
FINISH 0OS
LEADERORIENT

FLAT
CONVEX
SMOOTH_BLEND

LEFT
RIGHT

ALL AROUND
FIELD
TAIL

REFERENCE
WELD PROCESS

Pro/DETAIL



Fold Joint Symbol: Fold_Joint.sym

EXAMPLE 1

PICKS

. arrow_side

. weld size
leader orient
left

field

all around
tail

. weld process

O J oy U Wi

EXAMPLE 2

SDTR45

PICKS

. other side

. weld size
leader orient
left

field

. all around

. tail

. reference

O J o Ul b w N

Pro/DETAIL
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Symbol Definition Structure

y

’ FOLD_JOINT.SYM

—

ARROW_SIDE
OTHER_ SIDE

/

WELD S

LEADER ORIENT

IZE

]

LEFT
RIGHT

ALL AROUND
FIELD
TAIL

H

REFERENCE
WELD PROCESS

346
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Combine Symbol: Combine.sym

EXAMPLE 1
PICKS
1. as_above ref 11. machine as
2. weld type as 12. concave
3. weld type os 13. square os
4. weld size as 14. contour_os
5. weld size os 15. flat
6. weld length as 16. continuous
7. weld length os 17. intermittent
8. leader orient 18. left
’ — 19. all around
9. u weld as 20. field
10. contour_as 21. tail
22. weld process
s
_ f\f{ 50 pes
61—| 10x50(100)
EXAMPLE 2
PICKS
1. os_above ref 11. machine as
2. weld type as 12. convex
3. weld type os 13. fillet os
4. weld size as 14. contour_os
5. weld size os 15. smooth blend
6. weld length as 16. intermittent
7. weld length os 17. continuous
8. leader orient 18. left
’ = 19. field
9. bevel broad as 0. tail
10. contour_as 21. reference

f AIX 500
) == = ==== FGRT
6 }\ 10x50(100) RT80

=
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Symbol Definition Structure

CONTOUR AS
MACHINE AS

FLAT

CONVEX
CONCAVE
SMOOTH BLEND

CONTINUOUS
INTERMITTENT

COMBINE. SYM

L |

AS ABOVE REF
OS”ABOVE REF

SQUARE AS
V_WELD_AS

J WELD AS

V BROAD AS
BEVEL BROAD AS
FILLET AS

SQUARE AS

V WELD AS
BEVEL AS

U WELD AS

J WELD AS
V_BROAD AS
BEVEL BROAD AS
FILLET AS

v

Y

—

WELD TYPE AS
WELD TYPE  OS -
WELD SIZE AS
WELD SIZE OS

WELD LENGTH Ad|]

WELD LENGTH OS]
LEADER_ORIENT

WELD TYPE AS
WELD TYPE OS
WELD SIZE AS
WELD SIZE OS

WELD LENGTH AS
WELD LENGTH OS

LEADER ORIENT

LEFT
RIGHT

REFERENCE

ALL AROUND

LEFT
RIGHT

ALL AROUND
TAIL

v

WELD PROCESS|<€ FIELD
- TATL
CONTOUR AS — +
MACHINE AS | o | SOUARE_OS
— V WELD OS
* BEVEL OS
U WELD OS
FLAT J WELD OS
CONVEX V" BROAD OS
CONCAVE BEVEL BROAD OS
SMOOTH BLEND FILLET_OS

SQUARE 0OS
V_WELD 0S
BEVEL 0OS

U WELD OS
J _WELD”0OS
V_BROAD 0S8
BEVEL BROAD OS
FILLET OS

I MACHINE”AS

CONTOUR AS

FLAT

CONVEX
CONCAVE
SMOOTH BLEND

CONTINUOUS
INTERMITTENT

FIELD |

REFERENCE
WELD PROCESS

- MACHINE AS

CONTOUR AS

v

FLAT

CONVEX
CONCAVE
SMOOTH BLEND
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Edge Flanged Symbol: Iso_Edge Flange.sym

EXAMPLE 1

PICKS

1. arrow side 11. strip

2. above ref 12. left

3. weld size 13. removable
4. style 14. field

5. contour 15. all around
6. back type 16. tail

7. finish 17. weld process
8. leader orient

9. intermittent

10. convex

/54 7&0@0(\00) -
MR

EXAMPLE 2
PICKS
1. other side 11. style
2. beneath ref 12. contour
3. style 13. finish
4. contour 14. intermittent
5. back type 15. smooth blend
6. leader orient 16. left
7. continuous 17. all around
8. flat 18. field
9. backing 19. tail
10. back size 20. reference
_ 3 /7 N\0xS0(100) DFSA
/ 400
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Symbol Definition Structure

ISO_EDGE_FLANGE.SYM

ABOVE REF
BENEATH REF ARROW SIDE
- OTHER__SIDE

CONTINUOUS
INTERMITTENT
 } WELD SIZE
STYLE
Y CONTOUR
BACK TYPE
ggﬁgEX ] FINISH
CONTINUOUS | LEADER ORIENT
INTERMITTENT | | SMOOTH_BLEND
BACK SIZE
STYLE
CONTOUR
FINISH
FLAT BACKING LEFT
CONVEX STRIP RIGHT
SMOOTH_BLEND

\_+

PERMANENT FIELD
REMOVABLE ALL-AROUND
TAIL
REFERENCE

WELD_PROCESS
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Edge Symbol: Edge Weld.sym

EXAMPLE 1

PICKS

arrow side
weld size
style

contour
finish

leader orient
intermittent
convex

left

field

O W oW Jo U b WN

[y

11. all around

12. tail
13. weld process

EXAMPLE 2
PICKS
1. other side 11. reference
2. style
3. contour
4. leader orient
5. continuous
6. smooth blend
7. left
8. field
9. all around
10. tail
********** DFTR32
o
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Symbol Definition Structure

EDGE_WELD.SYM

Y

ARROW_SIDE
OTHER SIDE

CONTINUOUS
INTERMITTENT

i WELD SIZE
| S STYLE
f“““* CONTOUR
BACK_TYPE
FLAT FINISH
CONVEX LEADER ORIENT

SMOOTH BLEND

LEFT
RIGHT

H

ALL_AROUND
FIELD
TAIL

H

REFERENCE
WELD PROCESS

About the Symbol Instance Palette

The Symbol Instance palette is a customized drawing that contains symbols created and manually added by you.
Symbol definition attributes such as height, angle, grouping, variable text value, and so forth can be used for
each specific symbol instance created. However, these attributes can be modified only while creating the
symbol instance and not within the customized symbol instance palette.

The Symbol Instance palette file is stored in a location specified by the following configuration option:

symbol instance palette file

This option’s value is the directory and file name used to store the palette and where the palette is retrieved
between sections.

You can perform the following functions using the Symbol Instance dialog box:
e Select a symbol instance in the palette and place it in a drawing.
e Add a symbol drawing to the Symbol Instance palette.

e Arrange symbols in the Symbol Instance palette.
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To Select a Symbol Instance in the Palette

You can select a symbol instance in the Symbol Instance Palette and place it in a drawing. The Pick in Palette
button, located in the Symbol Instance dialog box, opens the Symbol Instance Palette dialog box that contains
the same characteristics as a typical drawing window. Therefore, zooming, panning, and other functions can be
applied.

1. Click Insert > Symbol Instance. The Symbol Instance dialog box opens.

2. Click Pick in Palette. The Symbol Instance Palette dialog box opens. Click the symbol that you want to
insert in the drawing. The symbol is displayed in the preview area and the GET POINT menu appears.

3. Place the symbol instance in the drawing by clicking on the desired location.

Note: Pick in Palette is a quick way of selecting only one symbol. If a symbol is selected in the palette and
then cancelled by selecting Quit from the GET POINT menu, you cannot select a different symbol. You must
click Pick in Palette again to select another symbol.

To Add a Drawing Symbol to the Palette

You can create or obtain a drawing symbol and then add it to the Symbol Instance palette.

1. Click Insert > Symbol Instance. The Symbol Instance dialog box opens.

2. Click Add to Palette. The Symbol Instance Palette dialog box opens and the GET POINT menu appears.
The symbol shown in the symbol definition field appears in the Symbol Instance Palette. If the Symbol
Instance Palette dialog box is not already opened, the message, Select Symbol Location appears.

Note: The ATTACH TYPE menu may appear, depending on the active symbol attributes.
3. Place the symbol in the palette by clicking on the desired location.

To Arrange and Delete Symbols in the Palette

You can arrange and delete symbols in the Symbol Instance palette by using the Move Symbol and Delete
Symbol buttons.

To move a symbol within the symbol instance palette:

1. Click Move Symbol and then click the symbol that you want to move.
2. Relocate the symbol anywhere within the Symbol Instance palette. Use the middle mouse button to cancel
move activity.

To delete a symbol within the Symbol Instance palette, click Delete Symbol and then click the symbol that you
want to delete.

The system prompts you to confirm or reject changes when you close the Symbol Instance palette.

To Create a User-Defined Weld Symbol

Redefine an existing system weld symbol by doing one or all of the following:

e Add as many copies of variable texts as you want.
o Change the default values of variable texts.

e Add and delete as many notes and entities as you want, and place new ones in any group (or in no group at
all).

o Redefine the cosmetics of existing notes and entities.

—

Save the symbol by assigning a new temporary name.

2. Move the original (system-supplied) symbol from the system weld library to another directory or rename it.
The system weld symbol libraries are located in the installation directory path

<install dir>/symbols/library syms/weldsymlib.
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3. Move the new user-defined symbol into the system weld library and assign it the same name as the original.

About Creating Reports

In Drawing mode, you can use Pro/REPORT to create dynamic, customized reports with drawing views and
graphics. Pro/REPORT also works with Pro/HARNESS-MFG, Pro/PIPING, Pro/MFG, and Pro/DIAGRAM. By
defining repeat regions, you can add model data to a report, which expands and shrinks as the model changes.
You can also use the following techniques to manage the data that appears in a report:

e Add filters to eliminate specific types of data from appearing in reports, drawing tables, or layout tables.

e Search recursive or top-level assembly data for display.

e List duplicate occurrences of model data individually or as a group in a report, drawing table, or layout
table.

e Directly link assembly component balloons to a customized BOM and automatically update them when you
make assembly modifications.

You can generate several kinds of output using Pro/REPORT such as family tables, associative reports, and

graphical wirelists. A common example of a report is a customized Bill of Materials (BOM), such as the one

shown in the next figure.

Report with Assembly Views

WA TH_WESSEL ASSEMBLY

Compenant Sub-Compenant|Componant oy, Tost
Hame Hame Type leal

LARGE_P IPE ASSENBLY |
LARGE_G_RING |FART |
LARGE_FLATE | FART | 14,360
LGE_RGLT PART 6 |. 450
LGE_RUT PART 3 0_BSh -
|
|
|
|
|
2
|
|
|

3,240

A [HP | FE PART 213760

Z SHALL_P IPE_ASSY ASSINBLY
BOLT PART

|

0. 530

LOZK_SCREW PART
HUT PART
0_RING PART
PLATE PART
SMALL_PIPE PART

I. 150
2 0. 450
1. 240

2.270
a0, S0k

El SUPPGRT_BASE PART 67980

DETRIL 4
SCALE 4708

Parametric Technology Corporation| A
MAIN VESSEL ASSEMBLY

Creating Reports

In Report mode, you can display data in tabular form in reports just as it is in drawing tables. The system takes
the data that it reports in the tables directly from a selected model and updates it when you change the model.
However, you cannot modify all model dimension values and geometry in Report mode—they are read-only.
The system gives report files the file extension .rep.
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Report Mode Menus

Report mode menus are abbreviated versions of the Drawing mode menus. This mode provides all of the
associative abilities that Drawing mode offers, except that you cannot modify the model. Refer to the
appropriate chapters of this guide for additional information on drawing commands.

To Create a Report

1.
2.

3.

From the Pro/ENGINEER menu bar, choose File > New....
In the New dialog box, click Report and type a name in the Name box (or accept the default); then click
OK.
In the Create Report dialog box, specify the report size or retrieve a format:
To specify the size, select Set Size and do one of the following:

— Click Portrait in the Orientation box (to make the height larger than the width) and select a standard
size from the Standard Size list.

— Click Landscape in the Orientation box (to make the width larger than the height) and select a
standard size from the Standard Size list.

— Click Variable in the Orientation box to define both the height and width dimensions. Select Inches
or Millimeters and type values in the Width and Height boxes.

To retrieve a format, click Retrieve Format and select a name from the Name list in the Format box. You
can also type [?] or click Browse to select a name from the Open dialog box.

Click OK. The system displays the report as specified and the REPORT menu appears.
Create a drawing table on the drawing sheet by choosing REPORT > Table > Create.
Define a repeat region by choosing TABLE > Repeat Region > Add.

Select cells to repeat with model information.

reating a Repeat Region

[ ] B

Selecting A yields highlighted (one-row) repeat region

Selecting B yields highlighted (two-row) repeat region

8.

9.

10.
11.

12.
13.

Choose Enter Text and type title text in a row or column outside of the repeat region (unless you want that
text to repeat with every occurrence of model data).

The repeat region in the table must contain symbol parameter information to be shown in the table. Choose
TABLE > Enter Text > Keyboard; or choose ENTER CELL > Report Sym.

Add the assembly model to the report by choosing REPORT > Views and typing the name of the assembly.
The system automatically chooses Add View from the VIEWS menu, and the VIEW TYPE menu appears.
To add views of the assembly to the report, add a general view to the sheet. If you do not want views of the
model in the report, choose

VIEW TYPE > Quit and VIEWS > Done/Return. The system still adds the model to the report, but it does
not display it on the sheet. You can add drawing views at any time.

If necessary, choose Repaint to display the contents of the table.

Add a drawing format to the report or change it by choosing SHEETS > Format > Add/Replace. You can
predefine tables on these drawing formats, save them, and recall them at any time into a report or drawing.
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You may also add the drawing table used in the report by including it in a drawing format that you can
retrieve. When you add a drawing format containing a table to a report, drawing, or layout, the table
becomes independent of the format. If you decide to replace the format, the system highlights the table, and

you can delete it.

Including Report Parameters in a Repeat Region

Pro/ENGINEER extracts values for parameters from model data and displays them in tables when the
parameters are included within a repeat region. These parameters can be user-defined or they can already be

defined by Pro/REPORT.
Pro/REPORT Parameters
PARAMETER NAME

&asm.mbr.cparams.name

&asm.mbr.cparams.value

&asm.mbr.cparam.User Defined

&asm.mbr.name

&asm.mbr.param.name
&asm.mbr.param.value
&asm.mbr.type

&asm.mbr.User Defined

&fam.inst.name

&fam.inst.param

356

DEFINITION

Lists the names of all user-defined
parameters in an assembly
component. This parameter is
defined for the parts making up the
connector outside of the cabling
environment.

Lists the values of all user-defined
parameters in an assembly
component. This parameter is
defined for the parts making up the
connector outside of the cabling
environment.

Lists the specified user-defined
parameters used in an assembly
component. These parameters are
defined for the parts making up the
Connector outside of the cabling
environment.

Displays the name of an assembly
member. To show tie wraps and
markers, the region attributes must
be set to Cable Info.

Lists the names of all user-defined
parameters in an assembly member.

Lists the values of all user-defined
parameters in an assembly member.

Displays the type (part or assembly)
of an assembly member.

Lists the specified user-defined
parameter for the respective
assembly components. Note that
"&asm.mbr." can be used as a
prefix before any

User-defined parameter in an
assembly member.

Displays the name of a family table
instance.

Displays the dimensions of
suppressed features in a 2-D repeat
region as dashes.
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&fam.inst.param.id
&fam.inst.param.name
&fam.inst.param.value
&lay.param.name
&lay.param.value
&mdl.param.name
&mdl.param.value
&rpt.index

&rpt.level

&rpt.qty

Assembly Component Parameters
The following system parameters exist for parameters that you enter into an assembly as feature relations and

those that exist at the assembly level only:

Note: These parameters do not exist at the part level as "asm.mbr.parametername" and other parameters can.

"&asm.mbr.cparams.name"
"&asm.mbr.-cparams.value"

"asm.mbr.cparam.parametername”

This is not a complete symbol; only

suppresses dashed dimensions if the

drawing setup file option

"dash supp dims_on_ region" is set
to "yes," the default.

Displays the ID of a family table
parameter if it is a dimension.
Displays the name of a family table
parameter.

Displays the value of a family table
parameter for an instance.

Lists the names of all user-defined
parameters in a layout.

Lists the values of all user-defined
parameters in a layout.

Lists the names of all user-defined
parameters in a model.

Lists the values of all user-defined
parameters in a model.

Displays the number assigned to
each record in a repeat region.
Shows the recursive depth of an
item.

Displays the quantity of an item.

In the next example, subassembly "LARGE_PIPE" is assigned three parameters:

The part "LARGE PLATE" is given the "price" parameter as well. In subassembly "SMALL PIPE," one
occurrence of part "O_RING" is assigned the "price" parameter also; the parameter exists in assembly
"SMALL PIPE" and not in part "O_RING." When the system parses the component parameters for the top-

"price," a number parameter
"availability," a string parameter
"in_house,” a "yes_no" parameter

level assembly "Main Vessel," it includes the parameter. Every parameter that is assigned to a component in this
example is added to its parent assembly as a feature relation. This figure shows the repeat region template using
the component parameters.

Repeat Region Template Using the Component Parameters

MEMBER MNAME

MEMBER TYPE

PRICE

PARAMETER

VALUE

asm.mbr . name

asm.mbr . type

asm.mbr . cparam. price|asmombr . cparams . name

asm.mbr.cparams.valu
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About Using Pro/REPORT with Pro/MFG

You can use Pro/REPORT with Pro/MFG to access manufacturing parameters at various levels and create
customized reports on the manufacturing process to suit your specific needs.

About Using Pro/REPORT in a Piping Assembly

You can use Pro/REPORT functionality with Pro/PIPING to tailor the piping bend machine and bend location
information to suit your required format by switching columns, subtracting a constant, and/or changing the sign
of the values.

About Repeat Regions

Repeat regions are user-defined rows and columns, or combinations of rows and columns (cells) that duplicate
themselves to accommodate the amount of data that the model currently possesses. They contain the following:

e System and user-defined parameters for which the values are extracted from the model that is associated
with the report

e Standard table text

By using repeat regions, your tables containing report data can expand and contract with varying quantities of

data supplied by the models. The following example shows a BOM with repeat regions.

BOM with Repeat Regions

Top-Level Assembly BOM
Index Component Name Quantity
1 LARGE_PIPE 1 A
2 SMALL_PIPE_ASSY 1 <J
3 SUPPORT_BASE 1

A - Expanded Repeat Region

If you have a license for Pro/REPORT, you can create a repeat region in any mode in which you can create a
table (Drawing, Report, Layout, Diagram, or Format mode). You can nest repeat regions or make them two-
directional.

Note: You can specify multiple repeat regions for a single table, but they cannot overlap.

About Using Assembly Simplified Representations

You can use assembly simplified representations in a drawing to control a repeat region of the model, and you
can also show BOM balloons on the representation. When you use assembly simplified representations to
control a repeat region, simplified representations of the same assembly behave entirely as different models.

A repeat region that reports on a simplified representation of a model reports on information within that
simplified representation, as opposed to reporting on the assembly itself. This includes the following:

e Ifyou substitute a component with anything other than a simplified representation of itself, the assembly
tree itself is different.
e The system does not show excluded components, even if they are in memory.

e Parameter values set by assembly relations (except mass properties) reflect the represented states of the
models within the assembly.

e A repeat region is automatically associated with the current model or simplified representation.

— If'the current simplified representation changes, the repeat region is always associated with the original
simplified representation when it was created or loaded.
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— If'the current model is an assembly, the repeat region is associated with that assembly model.
— Ifthe current model is a simplified representation, it is associated with the simplified representation.

e Ifyou substitute a part or subassembly with a simplified representation, the system still displays it in the
correct location in the assembly tree.

For example, if you substitute a part in the third level of the assembly with a simplified representation of the
part, the report displays the substitution in the third level. This applies only to substitutions by simplified
representations.
You can create a table or Bill of Materials with piping information in a drawing, so that the system updates the
table automatically to reflect changes in the piping assembly. You can also customize drawing tables to reflect
practices specific to your particular company.

Naming Conventions for Simplified Representations
in a Repeat Region

The naming conventions for simplified representations in a repeat region are as follows:

e [fyou substitute a component with a simplified representation, the system gives it the original part name.
e Ifyou substitute a component with a family table instance, the system gives it the instance name.

e Ifyou substitute a component with an envelope, the system gives it the envelope component name.

e [fyou substitute a component with a geometry snapshot, the system gives it the original part name.

e If you substitute a component with an interchange group, the system gives it the interchange part or
assembly (and part) names.

Restrictions When Using an Assembly Simplified
Rep to Drive a Repeat Region

The following restrictions apply when you use an assembly simplified representation to drive a repeat region:

e Pro/REPORT supports designated parameters of geometry snapshots only in repeat regions, not in notes.
e Component parameters are not available for substituted parts.
e The system supports the following report symbols for simplified representation models:
— asm (including cable)
— harn
- rel
— mdl
- rpt
—  weld.asm
— piping
In the following figure, a table has been added to a report. A model has not been added to the report yet, so data
is not listed in the columns. In the next figure, an assembly model has been added to the report that contains the

two subassemblies, "Large Pipe" and "Small Pipe," so the repeat region grows to accommodate the requested
data.

Table Created on a Report

before update_|  Top-Level Assembly BOM
for model data [ |,yex | Component Name | Quantity

repeat region [
—
row
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Growing Repeat Region

report table .
after model is

added
g

Top-Level Assembly BOM

Index

Component Name

Quantity

1

LARGE_PIPE

1

2

SMALL_PIPE_ASSY

1

expanded repeat region

If you add an additional component to the assembly, the system updates the repeat region accordingly. In the
following figure, the part "Support Base" was added to the same assembly and after updating the table, the
repeat region grows to accommodate the new component member.

Part Added to Assembly

Top-Level Assembly BOM

Index

Component Name

Quantity

1

LARGE_PIPE

1

2

SMALL_PIPE_ASSY

1

3

SUPPORT_BASE

1

expanded
repeat region

Defining Repeat Regions

Throughout most of this chapter, an assembly named "Main Vessel" is used to illustrate the properties of repeat
regions. The following figure illustrates the composition of this assembly.

Sample Assembly Structure

Main Vessel
Assembly
Small Pipe Large Pipe
Assembly S;gggn Assembly
@Olt (x12) @ock Scre@ é&ergi?]g Large Plate
Nut (x12) O-Ring (x2) Large \ | [Large
Bolt (x6 Nut (x6)

If you set the drawing setup file option "model digits_in_region" to "yes," two-dimensional repeat regions
reflect the number of digits of the part and assembly model dimensions. To change the number of digits of the
dimension in the drawing, you must show the model dimensions on the drawing and use the Num Digits
command.

To Add a Simple Repeat Region to a Table

1. Choose TBL REGIONS > Add > Simple.
2. Select the uppermost row of the repeat region.
3. Select the bottom row of the repeat region.

To Remove a Repeat Region from a Table

1. Choose TBL REGIONS > Remove.
2. Do one of the following:
e Choose RMV REGION > Pick Region.
— If the table is in numeric mode, the system freezes the region’s contents into nonparametric text. If
other regions exist in the table, it repaginates them (with page breaks only possible inside the remaining

360 Pro/DETAIL



regions). Otherwise, it appends all segments to the first, and strips pagination information.

— Ifthe table is in symbolic mode, it shrinks the region to its template and then removes it (this returns the
table to its precise state just before creating the region).

e Choose RMV REGION > All Regions. If the table has multiple segments (and is in numeric mode), the
system asks you if you want to explode all paginated table segments into separate tables. If you confirm, it
creates separate tables for each existing segment. Otherwise, it concatenates all segments into one big table,
and strips the pagination information.

To Display a Different Model

Using the Model / Rep command in the TBL REGIONS menu, you can display a different model or simplified
representation to control a region. If you change the model associated with the repeat region, the current model
appears as the default choice.

1. Choose TBL REGIONS > Model / Rep.
2. Select a region and type a new model name. For example: ASM_1.ASM.
3. Choose Confirm to delete BOM Balloons and model-dependent region items.

To Create a Table with No Duplicates and with
Recursion

Choose REPORT > Table > Repeat Region > Attributes.

Select within the repeat region.

Using the REGION ATTR menu, do one of the following:
Choose Recursive and search all levels of the assembly.

Choose No Duplicates and merge all occurrences of the same member into one line, accompanied by a
value for quantity in the right column. This affects your BOM balloon display. BOM balloons related to
instances with the same parameters merge the balloons into one.

o W N —

Example: Table After Choosing No Duplicates and
Recursive

IHDEX HAME ATy
| BOLT Iz
g LARGE _O_F | NG I
3 LARSE_F|FE |
4 LARGE_FLATE I
5 LEE_BOLT B
E LEE_HUT B
7 LOCK _SCREW |
& MATH_FIFE I
B Mo H_WVESEEL I
[ HUT [
I 0_R| HG [
Ie FLATE I
E] SMALL_FIFE
| 4 EMALL _FIFPE_ASEY] |
[ RIFFART R4SF I

To Enter Report Parameters into a Table

If one or more repeat regions already exist, you can type report parameters into a table manually or by choosing
them from a menu.

1. Choose ENTER CELL > Report Sym.
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2. Select the cell of the table in which you want to type the text. The REPORT SYM menu displays commands
for the first parameter elements: asm, dgm, fam, harn, and rpt.

3. Choose an element. If it needs another, the REPORT SYM menu appears again, with commands for the next
parameter element. You can use UP to navigate through the tree structure. Whenever an element needs
another element, the system follows the element name by ellipses (...).

The next figure presents a report with a table consisting of three columns and two rows.

A repeat region contains the cells from the entire lower row.

Repeat Region with Cells from Entire Lower Row

¢ e |
[ ]
those two cells selected to
create repeat region

In the next figure, the column header text is typed. In this example, an index, the assembly member name, and
the quantity information are intended to be shown.

Repeat Region with Column Header Text

Index Component Name | Quantity

The report parameter symbols "&rpt.index," "&asm.mbr.name," and "&rpt.qty" are typed into the three cells
that make up the repeat region. The system automatically includes an ampersand preceding all parameter
symbols if you enter the text by choosing Report Sym from the ENTER CELL menu. The result appears in the
following figure.

Repeat Region with Report Parameter Symbols

Index Component Name Quantity

- - — - 1T - — - — - — - — - /7

 Sretindex | Sasmmbrname | &rptaty

To add the top-level assembly, "Main Vessel," to the report, choose Views, and then type [Main Vessel]. You
do not have to place the drawing view of the assembly at this time. The table expands after you select the
model. All of the default attributes are chosen for this repeat region (that is, duplicates, flat). The quantity
values are not listed in this expanded table because the Duplicates command lists all occurrences of assembly
members separately. Therefore, all quantities are assumed to be 1. The resulting table appears as shown in the
following figure.

Report with Top-Level Assembly

Index Component Name Quantity
1 LARGE_PIPE
2 SMALL_PIPE_ASSY
3 SUPPORT_BASE

Tip: Assigning Feature Relation Parameters

When you assign feature relation parameters to assemblies, you must select the assembly component, not a
feature of the component. For example, when you query-select to assign the parameter, the message area reads
"Showing partname component No. X in assemblyname," instead of "Showing feature X (feature type) in part
partname." If you select the feature inadvertently, the assigned parameter values do not parse on the report
because the report symbols "&asm.mbr.cparam(s)" search only for assembly parameters. When the system
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parses the symbols, the table looks like the example in the following figure.

The repeat region has attributes of Duplicates and Recursive specified. The column with the heading "PRICE"
lists only values for the parameter symbol "price." The column with the heading "PARAMETER" lists the
names of all of the user-defined parameters assigned to each component. The column with the heading
"VALUE" lists the values of all of the user-defined parameters assigned to each component. These parameters
are sorted in the order in which they were added to the model. Note that where a component has multiple
parameters (assembly "Large Pipe"), multiple entries are present. (You might want to use a nested repeat region
in this case to differentiate the multiple entries from the other assembly components.)

Table with Parameter Symbols Parsed

MAIN_PIPE PART 105.500 PRICE 105.500
MAIN_PIPE PART 105.500 AVAILABILITY 07 Jul 93
MAIN_PIPE PART 105.500 IN_HOUSE False
LARGE_O RING PART
LARGE_PLATE PART
LGE_BOLT PART
LGE_BOLT PART
LGE_NUT PART Table is
LGE_NUT PART broken for
SUPPORT_BASE PART 67.500 PRICE 67.500 display
SMALL_PIPE_ASSY | ASSEMBLY purposes
SMALL_PIPE PART s0 as not
PLATE PART to show all
— O_RING PART 0.450 PRICE 0.450
LOCK_SCREW PART Eg}ttserannec?
BOLT PART nuts
Note: only BOLT PART
one |
O-Ring NOUT PART
f BOLT PART
a:rsl(l;gened BOLT PART
BOLT PART
parameter BOLT PART
BOLT PART
BOLT PART
— O_RING PART

About Cabling Component Parameters

You can include cabling parameters in drawing and report tables using the "asm.mbr.cbprm.User Defined"
parameter symbol in a repeat region. This parameter symbol displays any user-defined parameters used in
cabling components. If you use the parameter symbol "asm.mbr.cbprms.Name/Value" in a repeat region, any
pre-defined cabling parameter names and values (such as wire type units, name, and so on) appear.

When you include any of these parameter symbols in a repeat region, the commands Cable Info and No Cbl
Info appear in the REGION ATTR menu. You must choose Cable Info to display any cabling information in the
selected region. The No Cbl Info command displays only non-cabling assembly information in the table. If you
choose Cable Info for a repeat region, the table expands to include all spool names, tie wraps, and markers that
exist on the model when "asm.mbr.name" or "asm.mbr.type" parameter symbols are used in the repeat region.
You cannot use repeat region attributes No Duplicates or No Dup/Level when you use the
"asm.mbr.cblprms.name" parameter symbol in that region.
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About Creating Pro/REPORT Tables in Flat
Harnessed Drawings

Using the top-level report symbol, "mbr," you can create Pro/REPORT tables in a flat harnessed drawing for a
single assembly component/connector. When you enter an "mbr" symbol such as "mbr.name" into a repeat
region, the system arbitrarily selects a component from the default drawing model and reports only on that
component, producing the relevant subset of the table that would be produced if you had typed the "asm.mbr"
symbol instead.

To change the component that is driving the repeat region, you must display it in the view. When you choose
Model / Rep from the TBL REGIONS menu and select a region driven by the symbols beginning with "mbr," the
system prompts you to select a component in a view. When you select a component, that component then drives
the repeat region.

About Showing Terminators in Report Tables

You can show terminators in report tables for cable assemblies that have connectors with terminator parameters
by using the report symbols "&asm.mbr.name" and "&asm.mbr.type." To show the terminators, set the drawing
setup file option "show_cbl_term_in_region" to "yes" (the attribute Cable Info must be set for the repeat
region). When creating new drawings, the default value is "yes." For existing drawings, the default value is
"no.ll

To Use Report Parameters in Multi-Model Drawings

To create tables that display data for different models, you must change the active model, and then create a new
repeat region and type the parameters. Otherwise, the system takes data from the last active model.

Repeat regions always remember the models from which the system is extracting their values. A report
parameter that you type in a repeat region on the drawing while a certain model is active reads values from that
model only. The system extracts report parameter values only when you include the parameters within a repeat
region. For example, if you type a set of report parameters in a table without a repeat region, the system does
not read parameters from the active model until they are enclosed by a repeat region.

If the report parameter symbol "&asm.name" resides inside a table but outside of a repeat region, it can have a
postfix number (for example, "&asm.name:3") to specify the assembly in a multi-model drawing from which it
is reading its information. These postfix numbers always begin counting at "0."

To Enter Report Parameter Values into Empty
Repeat Region Cells

You can type a user-defined parameter value in an empty repeat region cell for an assembly member that does
not have that parameter value. If you type the parameter value in the table, the system automatically adds it to
the corresponding assembly member.

You can use this method only for the report parameter symbol "asm.mbr.parametername," where
parametername is a user-defined parameter, and the repeat region template must contain the parameter symbol
"asm.mbr.parametername." That is, you specify the parameter value to appear in the table by typing the
parameter name symbol, but the values do not exist in the models and consequently do not appear.

To Enter the Value of a User-Defined Parameter

1. Choose DETAIL > Modify > Value (or choose Modify from the LAYOUT or DIAGRAM menu).
Select an empty repeat region cell (empty of value only, the region has the parameter symbol). If it contains
more than one parameter symbol that does not have a value, a menu displays the parameters in the region
for which you can type a value.
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3. Type the value for the parameter. The system adds the parameter value to the corresponding assembly
member.

4. Choose Update Table, Regenerate, or Repaint to update the value of the parameter in other repeat
regions (or any command that redisplays them).

Modifying Values
You can type the value of a user-defined parameter in Drawing, Layout, or Diagram mode, but not in Report

mode. Report mode is read-only and modifications do not reflect back to the model database. However, you
can modify the following parameter values in Report mode, and the value does reflect back to the model
database:

e "&asm.mbr.parametername"
e "&asm.mbr.param.value"
e "&mdl.param.value"

e "&lay.param.value"

You can modify the value of these user-defined report parameters within repeat regions using the Modify and
Value commands. Modifying these values on the sheet on which they appear changes them throughout the
database. You can also modify them if they appear in notes.

To Modify Repeat Region Attributes

You can modify repeat region attributes in Format, Report, Drawing, and Layout modes. When you choose
Attributes from the TBL REGIONS menu, the REGION ATTR menu displays the following commands:

e Duplicates—Lists duplicate occurrences of a parameter individually in a repeat region. This command sorts
by feature number any data from the "&asm.mbr.name" parameter symbol display.

e No Duplicates—Lists duplicate occurrences of a parameter singly, along with a quantity if you use the
parameter "&rpt.qty" in the region. This command sorts by parameter value any data from the
"&asm.mbr.name" parameter symbol display.

e No Dup/Level—For a selected level of the region, lists duplicate occurrences of a parameter singly, along
with a quantity if you use the parameter symbol "&rpt.qty" in the region. This command allows you to list
duplicates only if the object resides in different levels of the assembly. There are no duplicates per level in
the assembly. It sorts by parameter value any data generated from the "&asm.mbr.name" parameter symbol
display.

e Recursive—Searches all levels of data for parameters.

e Flat—Searches only the top level of data for parameters.

e Min Repeats—Sets the minimum number of repetitions for a repeat region. The default minimum is "1."
The system leaves extra rows blank. If the minimum is set to "0," it avoids blank lines caused by the lack of
data.

o Start Index—Begins the index numbering of a repeat region (the value of "&rpt.index") where the index
numbering of another repeat region ended. You cannot assign this attribute to nested repeat regions.

e No Start Idx—Begins the index numbering of a repeat region at 1.
e Cable Info—Displays the cable parameter information in tables containing appropriate parameter symbols.

e No Cbl Info—Displays only assembly parameter information in tables (that is, no cabling information
appears).

e Bin By Part—When you suppress or replace a component to which a BOM balloon is attached, this
command reattaches the balloon to another placement of the same part.

¢ Bln By Comp—Specifies that simple BOM balloons reattach themselves to whatever component replaced
the one that originally owned the BOM balloon.

Note: The template cell drives the number of digits of a quantity. In a two-directional repeat region,
modifying the number of digits in the first column affects every column.
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Example: Controlling Attributes

The next figure presents the same table as that shown in Entering Report Parameters into a Table on page 11 -
17. The repeat region contains the system parameter symbols "&rpt.index," "&asm.mbr.name," and "&rpt.qty"
(for system parameters. The default repeat region attributes of Duplicates and Flat are used. In Report mode,
the assembly "Main Vessel" is added to a report, and then the table is added to the report.

Repeat Region Containing System Parameters

Index Component Name | Quantity

&rpt.index &asm.mbr.name &rpt.qty

The resulting table looks like the one in the following figure. The index numbers appear in the left column and
the names of the members of the assembly appear in the middle column. No quantity appears since the attribute
Duplicates is being used and the quantity is always "1."

Table Added to Report, and Then Assembly Model

Index | Component Name Quantity

1 LARGE_PIPE

2 SMALL_PIPE_ASSY
3 SUPPORT_BASE

About Obtaining a Summation

Using the Summation command in the TBL REGIONS menu, you can add a summation parameter to the
drawing and include it in a note, or delete the summation parameter from the drawing.

To Obtain a Summation of the Parameter Values of a
Repeat Region

Choose TABLE > Repeat Region > Summation.
Select a region in the drawing; then choose TBL SUM > Add.
Select a report parameter in the repeat region.
Type a parameter name. You must select a table cell in which to place the parameter. The system adds a
new parameter to the drawing whose value is the summation of the values of the selected report parameter.
Note: The parameter is like any other parameter that is accessible using Parameters in the DWG SET UP
menu, except that you cannot modify or delete it.
5. When the system prompts you to update the value, choose TBL REGIONS > Update Tables. The system
updates the table and the makes the summation parameter visible.
Note: To update the summation parameter, you must use Update Tables.

Example: Summation Parameters

To create the following example, create a table for the exploded assembly, and obtain a summation of the
parameter symbol value "asm.mbr.cost" in the fourth column.

L=

At the system prompt, type the summation parameter name as cost_sum. From the keyboard, type &cost sum in
the second cell in the last row, and type Total Cost in the first cell in the last row. After you update the table, the
summation appears as 60.000. To create the "total cost/part" column, add the repeat region relation

total cost per part=rpt qty * asm_mbr cost.

Note: For quantities greater than one for any particular part, you must have a "cost/part" column and a "total
cost/part" column, as shown in this example.
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Example of Obtaining a Summation

2 2 2
%N %M ﬁ‘ NUH [ NAME GTY [COST/PART[TOTAL £OST/PART

. __ __ . I |BASE | 30,000 |30.900
T FIN 3 10, dad | 30.990

K| FLATE | b R L Il | I 1

- - - Tetal Cast gp.qgy | 51990

SCALE @, 204

Summation Parameter Notes

You can show a summation parameter in notes just like any other drawing parameter.
However, when adding or deleting summations of parameter values, the following rules apply:

e Ifyou delete a repeat region or table, the system deletes its summation parameter automatically.
¢ You cannot delete or modify summation parameters by choosing Parameters from the DWG SET UP menu.

e Ifyou cannot add the report parameter values (for example, if the value types are nonnumerical), the system
assigns the drawing parameter a value of "***" and displays it in that form.

* You cannot copy the summation parameter by using the Copy Table command in the TABLE COPY menu
or by storing the table to disk.

Tip: Storing Relations and Summations with
Drawing Tables

Using the Save/Retrieve command in the TABLE menu, you can store existing repeat region relations and
summation parameters with a report table. When you retrieve a saved table containing a summation parameter
into a drawing, the system checks whether the drawing already has a parameter of that name. If it cannot find
one, it adds one for you. However, if it does find a parameter by that name, you must enter a name to replace it
in the table. It then uses that name for the summation parameter. If you do not enter a name, it retrieves the
table, but ignores the parameter.

About Nesting Repeat Regions

Nested repeat regions are repeat regions entirely contained by another repeat region. Repeat regions cannot
overlap. When you nest them, you can define a double loop, such as one that searches through all subassemblies
of an assembly and through all parts in each subassembly.

To Create Nested Repeat Regions

To create nested repeat regions, you define an initial oufer region by selecting the cells to define the boundary,
and adding another inner repeat region by selecting cells that are completely enclosed by the outer region.

You can remove an outer (enclosing) repeat region without removing the enclosed repeat region.
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Examples: Nested Repeat Regions

Top-Level Assembly BOM
Index Component Name | Quantity
?
]
| these two cells define an

outer repeat region

Index Component Name Quantity

L these two cells define an
inner repeat region (note
the two cells are BOTH
enclosed by the outer
region)

The following figure shows a table with a nested repeat region. The regions do not overlap. The attributes for
both the inner and the outer repeat regions have been set using No Duplicates and Flat.

Table with a Nested Repeat Region

outer repeat region

ITEM NAME x SUB-ITEM MWAME GTY
dasm.mbr.name drpt.qty
[ - Raam. mbr _name hrpt. gty

inner repeat region

When the model assembly "Main Vessel" is added to the report, the resulting table appears as shown in the next

figure.

Model Assembly "Main Vessel" Added

ITEM NAME SUB-ITEM
NAME

LARGE PIPE

LARGE_O RIN
G

LARGE_PLATE
LGE_BOLT
LGE_NUT
MAIN_PIPE

SMALL_PIPE
ASSY

BOLT
LOCK_SCREW
NUT
O RING

368

QTY

_— = O\ O\

12

12
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PLATE 1
SMALL PLATE 1

SUPPORT BAS 1
E

Entries in the outer repeat region are listed under the header "item name," while entries in the inner repeat
region are listed under the header "sub-item name." Since item "Support Base" is a part and has no subitems, the
row beneath its entry is blank. If you set the minimum number of repeats for the inner repeat region to 0, this
prevents blank lines if there is no information at that level.

In the following figure, the attributes of the inner repeat region have been changed to Duplicates and Flat.
Notice that the subitems have multiple entries where possible, and no value for quantity is listed for them.
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Attributes of Inner Repeat Region Changed to Duplicates and Flat

ITEM NAME SUB-ITEM NAME QTY
LARGE_PIPE 1

MAIN_PIPE
LARGE_O_RING

LARGE_PLATE

LGE_BOLT
LGE_BOLT
LGE_BOLT
LGE_BOLT
LGE_BOLT
LGE_NUT
LGE_NUT
LGE_NUT
LGE_NUT
LGE_NUT
LGE_NUT

SMALL_PIPE_ASSY SMALL_PIPE 1
PLATE
O_RING
LOCK_SCREW
BOLT

BOLT
BOLT
BOLT

O_RING

SUPPORT BASE 1

Note: Table is broken for display purposes so
as not to show all patterned bolts and nuts.

In the next figure, the attributes for the outer repeat region have been changed to No Duplicates and Recursive.
The attributes for the inner repeat region have been changed to No Dup/Level and Recursive. To display the
No Dup/Level attribute, the part "O Ring" was added to the assembly "Large Pipe" for this example only. The
"O Ring" part now exists in two levels of the "Main Vessel" assembly ("Small Pipe" assembly and "Large Pipe"
assembly).
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Attributes of Outer Repeat Region Changed to No Dup/Level and Recursive

MAIN_VESSEL 1
MAIN_VESSEL 1
LARGE_PIPE 1
MAIN_PIPE 1
LARGE_O_RING 1
LARGE_PLATE 1
LGE_BOLT 6
LGE_NUT 6
— O_RING 1
SUPPORT_BASE 1
SMALL_PIPE_ASSY 1
SMALL_PIPE 1
PLATE 1
— O_RING 2
LOCK_SCREW 1
BOLT 12
NUT 12
NUT 12
NUT 1
O Ring is listed twice in the table because Table is broken soas —
it exists at two levels in the "Main Vessel" to show only the area
assembly, but is only listed once per level. of No Dup/Level.

About Creating Two-Directional Repeat Regions

Two-directional (2-D) repeat regions are used to display information in a model’s family table. These two-
directional repeat regions allow tables to expand both vertically and horizontally with model data and actually
consist of three separate repeat regions.

e The first of these three regions is the outermost region, in which the other two subregions are completely
enclosed.

e The second and third repeat regions are one-directional regions that define how the overall two-directional
repeat region expands. They define the horizontal and vertical expansion characteristics. One cell must be
common to all three of these regions. This cell defines the corner boundary cell between the horizontal and
vertical expansion, and it should be at the end of the two inner, subregions.

To Create a Two-Directional Repeat Region

1. Choose TABLE > Repeat Region > Add > Two-D.

2. Select two points to define the outer repeat region.

3. Select the cell to be the upper border of the row and column subregions.

The first cell selected is the one that remains fixed after the table expands horizontally and vertically. Next,
double-click the cell that is diagonally across from the first selected cell. (For a table created as the
Descending/Rightward type, first select the upper left cell and then double-click the lower right cell).

Tip: Deleting as a Unit
You can delete as a unit the three repeat regions that compose the 2-D repeat region.
The column and row subregions can have their own independent attributes, filters, and sorting keys.

Note: You can paginate 2-D repeat regions if they run off the bottom edge of a sheet, but not if they run off a
side edge.
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Examples: Two-Directional Repeat Regions

mTT === ]—'I“ first, all-enclosing region

| H— subregion defining the

'l horizontal expansion (note the
two vertical cells selected to
define this region)

cell common to both subregions
and defining the top-left corner
of the expanded array
subregion defining the vertical

expansion (note the two horizontal

cells selected to define it)

The next figure shows a table that was created to display parameter values for every instance in a family table
library part.

Note: The arrangement of the repeat regions is the same as in the previous illustration. Some cells were merged
to clarify the expanded table.
Table with Parameter Values for Instances in a Family Table Library Part

region one: the
T all-enclosing region

L _region two: the
horizontally
\ ® - expanding region

cell common to

region three: the vertically both regions

expanding region

In the following figure, the heading text and parameter values were entered for the library model
"ELMFEMWS.prt" .

Heading Text and Parameter Values Entered for Library Model "ELMFEMWS .prt"

Generic Part Name: &model_name

I Model Parameters

IL.fam.inst.param.name
Instance Name !‘

| &fam.inst.name i&fam.inst.param.valud

This 2-D repeat region expands downward and to the right because the table was created as the
Descending/Rightward (default) type in the TABLE CREATE menu. You can create a 2-D repeat region to
expand up or down, left or right by creating the table accordingly. When part "ELMFEMWS.prt" is added to the
report from the Pro/ENGINEER BASIC LIBRARY, the result appears as shown in the next figure.

You can merge the blank cells to form a continuous blank space.
The columns of the horizontally expanding region will have the same width.

To remove unwanted columns, create a filter using the syntax &fam.inst.param.name = "parameter name". For
example, if the NUM_OF TEETH parameter is not required in the table shown in the next figure, use the filter
&fam.inst.param.name = "NUM_OF TEETH".
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2-D Repeat Region Displaying a Family Table

Generle Part Wome; ELHPEWME
Hedw| Paramitara
1 cutter_dlan tnt_length FLUTE_MINBER length HUN_4F _TEETH shork_dla
nztonca Ham
ELEMI b 230 1750 4.000 ERr 4.000 0,373
ELEWE 03l 2. 040 4,000 A, Ti0 4. 000 0,375
ELEW2 0,375 2840 4,068 4., 260 4. 000 0,375
ELEH4 0. 590 3000 4.000 5.000 4.000 0.500
ELEHS 0. E25 4040 4.0 4. 125 4. 01D 0.E25
ELEW b 70 4.040 4.000 4. B0 4.000 0,750
ELEHT 0,475 £.090 4,000 T, Bl 4. 000 0,076
ELEME [HIT] 040 4000 & 500 4,000 1.0
ELEWY |. 220 A_1a0 q.101 & 509 B.D0D 1. 250
ELENID 1. 3db B.0&0 6.0 10. 50D E. 0D 1.250
HOLDER
r |0
(v
HOLOER
: __Lip
TIP HNH

About Paginating Report Tables

You can paginate report tables that are on the same drawing sheet, and you can break a table into arbitrarily
placed segments on the same sheet. As you add more information to the table, the system flows the information
into each segment and adds more sheets as necessary, copying the table format (if there is one). It chooses the
segments to create the new sheet as follows:

e The system copies the segment definitions from the format if the table was copied from a format, the table
on the format was paginated on two sheets, and the drawing table currently has only one sheet.

e Otherwise, it copies segment definitions from what was previously the last sheet of the table.

To Paginate Report Tables That Are on the Same
Drawing Sheet

1. Choose TABLE > Pagination.

2. Select a table that has at least one repeat region.

Note: The Save command in the Pro/ENGINEER File menu is not available while you are in the TBL
PAGIN menu.

3. Ifthe table contains only one segment (on any sheet), choose TBL PAGIN > Set Extent and select a lower
extent for that one segment. Otherwise, select a table segment for which to set the extent. Tables always fil/
down to use up as much of their extent as possible.

4. Choose Add Segment and add a new segment on the current sheet. Locate the origin of the new segment
and then its extent.

5. To change the pagination, choose Clear Extent to clear all pagination information from the table. The
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system removes all segments other than the first, appends their contents to the first segment, erases the
table, and draws it in its unpaginated state. Repeat Steps 2 through 4.

6. Choose TBL PAGIN > Done to accept all modifications and add any remaining sheets, or choose TBL
PAGIN > Quit to remove all modifications after responding to the confirmation.

About Creating Header and Footer Titles

When working with tables containing multiple segments, you can place a title at the top of each segment (as a
header) or at the bottom of each segment (as a footer).

When creating titles, keep in mind the following rules:

e Two-directional repeat regions cannot have titles.
e For single-row headers and footers, you must select the row twice for the first and second rows.

e A region can have only one header and one footer. However, since a table can have more than one paginated
region, a table can have more than one header and more than one footer.

e  When selecting rows to be used in a title, you cannot choose a row that is part of a repeat region.

e Two titles cannot intersect each other. That is, when creating a new title, you cannot select a portion (one or
two rows) of an existing title to be used in the new title. However, you can define the same rows to be both
the header and the footer of the same region or to be titles of a number of regions.

® You cannot create a header or footer title in a row that has cells merged in a column.

o The system inserts a header at the top of a segment, and inserts a footer at the bottom of a segment,
regardless of the direction of the table’s growth (that is, ascending or descending).
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Example: Using a Header Title in a Table with a
Descending Repeat Region

The next figure illustrates how to use a header title in a table with a descending repeat region.

Example of Table Segments with Header Title in a Table with a Descending Repeat Region

INDEX COMPONENT QUANTITY
4
1 TESTPLATE
2 PLUG
Header
appears for 3 PLUG
both
segments 4 PLUG
5 WASHER_PART
INDEX COMPONENT QUANTITY

WASHER_PART

WASHER_PART

SQUARE <NUT>

SQUARE <NUT>

SQUARE <NUT>

To Add a Header or Footer Title to a Table

Choose TABLE > Pagination; then select a table that contains at least one repeat region.

Choose TBL PAGIN > Add Title; then select a repeat region in the current table.

From the REGION TITLE menu, choose Header or Footer.

Select the first row (one that is nof in a repeat region) to be used as the header or footer title of the selected
region.

5. Select the second row. The segments of the table appear with the specified header or footer title.

About Specifying Indentation

Using the Indentation command in the TBL REGIONS menu, you can specify an indentation for report data in
recursive repeat regions. The cell to which you apply the indentation must be in a repeat region that has
Recursive specified as one of its attributes, and should contain a recursive report parameter symbol (such as
"asm.mbr.name"), although this is not a requirement. If you select a cell that does not contain a recursive
parameter, the system informs you, but it indents the data if you specify a value.

el S

Pro/ENGINEER expresses indentation for a repeat region cell using a number between 0 and 100. The number
indicates the value in characters (at the default text size) by which that data is indented in a recursive repeat
region. Pro/ENGINEER increments the indentation by the specified amount at each new level in the table.
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To Specify Indentation for a Repeat Region Cell

1. Choose TBL REGIONS > Indentation.

2. Select the cell in a repeat region template for which you want to specify the indentation.

3. Type a value for the indentation.

4. Choose Update Tables to redisplay the table with indentation.

Note: If you specify the indentation for a cell in an existing table, you must choose TBL REGIONS > Update
Tables before you can view the result.

Example: Repeat Region Cells Using Indents

Indentation has been specified for the second column, containing values of "asm.mbr.name," and the third
column, containing values of "asm.mbr.type." For each cell, the indentation was specified as 5. Note how this
indentation is incremented at each recursive level.

Indented Information in a Recursive Repeat Region

LEVEL NAME TYPE Note: table
1 MAIN_VESSEL ASSEMBLY broken for
2 LARGE_PIPE ASSEMBLY display
3 MAIN_PIPE PART purposes so
3 LARGE_O_RING PART as not to show
3 LARGE_PLATE PART all patterned
3 LGE_BOLT PART bolts and nuts
3 LGE_BOLT PART
<4
3 LGE_NUT PART
2 SUPPORT_BASE PART
2 SMALL_PIPE_ASSY ASSEMBLY
3 SMALL_PIPE PART
3 PLATE PART
3 O_RING PART
3 LOCK_SCREW PART
3 BOLT PART
.<_
3 BOLT PART
3 BOLT PART
3 O_RING PART

About Adding Filters

Using the By Rule command in the FILTER REG menu, you can remove multiple items that match a specified
pattern. You can use filters in the following forms to further specify the information to appear:

o  <symbol>—Any parameter that is valid in a repeat region
o <comparison operator>—~Any of the operators <, >, <=, => == and !|=
o <literal value>—Any integer, floating point, or string value

Filters exclude from a repeat region any record that uses one of the filtered parameters and whose value does
not match the constraint defined by the filter. The system omits the entire record from the table, not just the
parameter affected by the filter. For instance, the filter &asm.mbr.type==part in a repeat region omits all records
of objects other than parts from the report.

Note: If you filter in a two-directional repeat region, it only removes the particular cell, not the entire record.

A filter such as &asm.mbr.material!=steel excludes all records of assembly members with a material parameter
value (user-defined) of "steel" from the report.
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You can also enter filters that work for multiple values, such as &asm.mbr.name==part_a,part_b,part j, which
would exclude from the report all records of assembly members other than "part a.prt", "part b.prt", and
"part_j.prt". A line can contain up to 80 characters. When creating a filter with multiple acceptable values such
as this one, you can only use the operators "=="and "!=".

When using filters with these operators in a repeat region, keep in mind the following:

e Ifyou add filters with the operator "=="to more than one line in a repeat region, all entries are blanked and
the table appears to be empty.

e For "==" operators with more than one value, the values are linked by "or." For example, for the filter
&asm.mbr.name==part_1,part 2 part 3, the repeat region would exclude all objects other than those parts
having the name "part 1," "part 2," or "part 3."

e For "!=" operators with more than one value, the values are linked by "and." For example, for the filter
&asm.mbr.name!=part_a,part_b,part_c, the repeat region would exclude those parts having the name

"part_a," "part_b," and "part c."

About Using Wildcard and Backslash Characters in
Filters

You can use wildcard characters (*) in report filters, but they are only allowed in filters that use the operators
"==" or "!="; filters of any other type that contain "*" are in error, and you are prompted to re-type the filter.
For example, you can use the wildcard in these filters:

e &asm.mbr.name==part*
e &asm.mbr.name==*my*, *your*

The first filter would match the strings "part," "part1," "part A," and "partabcdefg." The second filter would
match the strings "my," "this_is_my_assembly," "autonomy," "not_yours," and "your."

If you add a backslash (\) in the right-hand side of a filter (after the operator), the system reads the character
after the backslash literally (as itself), not as a special character. You can then filter for an asterisk character.
For example, &asm.mbr.name>=part\* matches strings that are alphanumerically greater than or equal to the
string "part*".

The system interprets backslashes in report parameters or between string quotes literally as backslash
characters. It interprets the parameter "&asm.\mbr.name" as a report symbol named "asm.\mbr.name" (an
invalid name), and the filter:

&asm.mbr.name=="match this\"
matches only the string "match this\".

It treats a backslash that is not in a report parameter, not enclosed by string quotes, and not followed by another
character as a null string (" "). It interprets anything between two string quotes literally; the filter:

&asm.mbr.name<":\\¥**"
matches strings that are alphanumerically smaller than ":\\***"_ For filters created prior to Release 11.0 that
contain the wildcard character, the system interprets the character literally (as an asterisk).

Note: You should not use filters on the system parameter symbol "&rpt.index".

To Add a Filter to a Repeat Region

Choose TBL REGIONS > Filters.

Select the repeat region to which you want to add a filter.

Choose FILTER REG > Add. Type the filter expression.

Choose Done to add the filter. Existing repeat regions regenerate to accommodate the filter.

Rl S e
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Examples: Using No Dup/Level and Recursive

Attributes

The attributes for the inner repeat region are specified as No Dup/Level and Flat.

Attributes for Outer Repeat Region Specified as No Dup/Level and Recursive

ITEM NAME SUB-ITEM NAME QTyY

MAIN_VESSEL 1
LARGE_PIPE 1

SUPPORT_BASE 1

SMALL_PIPE_ASSY 1

LARGE_PIPE 1
MAIN_PIPE 1

LARGE_O_RING 1

LARGE_PLATE 1

LGE_BOLT 6

LGE_NUT 6

MAIN_PIPE 1
LARGE_O_RING 1
LARGE_PLATE 1
LGE _BOLT 6
LGE_NUT 6
SUPPORT BASE 1
SMALL_PIPE_ASSY 1
SMALL_PIPE 1

PLATE 1

O_RING 2

LOCK_SCREW 1
BOLT 12
NUT 12

SMALL_PIPE 1
PLATE 1
O_RING 2
LOCK_SCREW 1
BOLT 12
NUT 12

When the filter &rpt.level>1 is added to the outer repeat region, the resulting table looks like the example in the
next figure. The row containing "Main Vessel," the first level of the assembly, is removed. Only those members
with a level value higher than 1 remain.
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Filter "&rpt.level>1" Added to Outer Repeat Region

ITEM NAME SUB-ITEM NAME QTY

MAIN_VESSEL 1
LARGE_PIPE 1

SUPPORT BASE 1

SMALL_PIPE_ASSY 1

LARGE_PIPE 1
MAIN_PIPE 1

LARGE_O_RING 1

LARGE_PLATE 1

LGE_BOLT 6

LGE_NUT 6

MAIN_PIPE 1
LARGE_O_RING 1
LARGE_PLATE 1
LGE _BOLT 6
LGE_NUT 6
SUPPORT_BASE 1
SMALL_PIPE_ASSY 1
SMALL_PIPE 1

PLATE 1

O_RING 2

LOCK_SCREW 1
BOLT 12
NUT 12

SMALL_PIPE 1
PLATE 1
O_RING 2
LOCK_SCREW 1
BOLT 12

NUT 12

Moving a Filter to Another Repeat Region

In the following figure, the filter asm.mbr.type==assembly is added to the inside repeat region, so no parts are
listed there.
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Filter "asm.mbr.type==assembly" Added to Inside Repeat Region

ITEM NAME SUB-ITEM NAME QTY
LARGE_PIPE 1
MAIN_PIPE 1
LARGE_O_RING 1
LARGE_PLATE 1
LGE_BOLT 6
LGE_NUT 6
SUPPORT BASE 1
SMALL_PIPE_ASSY 1
SMALL_PIPE 1
PLATE 1
O_RING 2
LOCK_SCREW 1
BOLT 12
NUT 12

In the next figure, that filter is cleared from the inside repeat region and added to the outside repeat region.
Again, all parts have been omitted from the region.

Filter Cleared from Inside Repeat Region and Added to Outside.

ITEM NAME SUB-ITEM NAME QTY
LARGE_PIPE 1
MAIN_PIPE 1
LARGE_O RING 1
LARGE PLATE 1
LGE_BOLT 6
LGE_NUT 6
SMALL_PIPE ASSY 1
SMALL_PIPE 1
PLATE 1
O_RING 2
LOCK_SCREW 1
BOLT 12
NUT 12

About Excluding Items from a Repeat Region

You can exclude items from a repeat region by graphically selecting them in the report using the FILTER TYPE
menu. However, when removing selected items from a repeat region, the following restrictions apply:

e The system preserves the exclusion attribute if you rename the model by choosing Rename... from the
Pro/ENGINEER File menu or using Pro/PDM.

® You cannot filter items if the table is frozen.

e This functionality is not available in Pro/DIAGRAM.

® You cannot exclude the following:

— Items in 2-D repeat regions and subregions (you can use By Rule to filter out columns or rows in 2-D
repeat regions).

— Records that have comment cells and dash items.

— Records that have no associated parametric attachment information.
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o The system does not preserve the exclusion attribute in the following situations:

— When the region has the No Duplicates attribute and the assembly does not have at least one copy of
the excluded item during the assemble/disassemble process.

— If you switch among the Duplicates, No Duplicates, and No Duplicates/Level attributes.

To Remove Selected Items from a Repeat Region

1. Choose TBL REGIONS > Filters > By Item > Exclude >
Pick Many.

2. Select repeat region records to exclude. Be sure that the selection box encloses the outer boundary of the
region on both sides.

Example: Excluding Items from a Repeat Region

index type name level qty
1 PART | TESTPLATE 1
Select 5 PART T PIlG 1
:Zizfds o PART | PLUG 1
nd —[5 PART | WASHER PART 1
exclude. 6 PART | WASHER PART 1
7 PART | WASHER PART 1
8 PART | SQUARE 1
TSR
updates the
rep_eat t index type name level qty
regonio 4 PART | TESTPLATE 1
show the 2 PART | SQUARE 1
new order. 3 PART | SQUARE 1
4 PART | SQUARE 1

About Setting Recursive or Flat ltems in a Repeat
Region

You can select individual items graphically in a repeat region to make them recursive—displaying items within
the assembly—or flar—not displaying items within the assembly. When you set an item as flat or recursive, the
system marks it until you choose Default or Default All to change it. [tems that you set individually remember
their setting even if you change the default attribute of the region from Flat to Recursive or vice versa.

To Set an Item as Flat

1. Choose TBL REGIONS > Flat/Rec Item > Flat.

2. Select a record in the table. Use Pick Many to select more than one. Be sure that the selection box encloses
the outer boundary of the region on both sides.

3. Choose Done Sel. The system updates the repeat region.
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Example: Setting an Item as Flat

Select
these
items to
make flat.

382

indax |nams typs laval |qty
[ HEWTOP [ASSEMELY |1
2 Pl FART 2
3 SUB1  [ASSEMBLY |2
4 Pz FART 3
5 SUB 1A [ASSEMBLY |3
B Pz FART 4
7 P4 PART 4
& $UBZ  [ASSEMBLY |2
5 P FART 3
14 Pé BART ]

Recursion
stops at
these
items.

index |nams  |type level |qty
! HEWTOP [ASSEMBLY ||
2 Pl FART 2
3 SUB|  [ASSEMBLY |2
4 SUBZ  [ASSEMBLY |2
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Example: Setting an Item as Recursive

index |namsg type level |qty
] - [ Pl PART 2
Each record is recursed.
2 SUBI  [ASSEMBLY |2
Select these two records
to make recursive.
3 Pz PART 3
index |nams [type level |qty
4 SUBIA |ASSEMBLY |3
P PART 2 [ sUB2  |ASSEMBLY |2
2 SUB I ASSEMBLY |2 & P5 FART 3
3 SUB2  [ASSEMBLY |2 7 P FART 3

To Set an Item as Recursive

Choose TBL REGIONS > Flat/Rec Item > Recursive.

2. Select a record in the table. Use Pick Many to select more than one record. Be sure that the selection box
encloses the outer boundary of the region on both sides. You cannot select the following:

Items in 2-D repeat regions or subregions.

—

Records that cannot have comment cells and dash items.

Records that do not have any associated parameter attachment information.

3. Choose Done Sel. The system updates the repeat region to display the new order. The recursion starts one
level from the item that you select.

About Sorting in a Repeat Region

Using the SORT REGION menu, you can sort the contents of a repeat region to change the order in which the
system lists entries in a table:

e  When you choose Default Sort, it sorts entries forward, by ASCII character value.

e When you choose No Default, it sorts entries in database order.

You can specify more than one parameter symbol for sorting a region; the system sorts entries by the first
parameter, and then by each succeeding parameter, if necessary. You can enter user-defined parameters as
sorting parameters. You can sort a region forward (in ascending order) or backward (in descending order).

For the purposes of sorting, the system considers a text string in a repeat region to consist of two parts:

e A nonnumerical part, which comprises everything in the string that precedes the numerical part.

e A numerical part, which comprises all contiguous numbers at the end of the string, possibly including a
decimal point.
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Note: The system considers a leading "+" or "-" to be a portion of the numerical part of the string if the

string contains no other nonnumerical data.
In any given string, either the numerical or the nonnumerical part can be empty. The system determines the sort
order by making a comparison between each pair of strings in the field selected as the sort key. Instead of
comparing each pair of strings strictly as strings, it considers the numerical and nonnumerical parts separately.
If the nonnumerical parts of two strings are identical, it determines the order by considering their numerical
parts as numbers. A sorting parameter is valid only for the specified repeat region. Repeat regions that are
nested are not affected by sorting parameters at a higher region.

To Add a Sorting Parameter to a Region

Choose TBL REGIONS > Sort Regions.

Select within the region you need to sort.

Choose SORT REGION > Add.

From the SORT ORDER menu, choose Forward or Backward.

Select the repeat region parameter by which you want to sort. Choose Done Sel when you have finished.
Choose SORT REGION > Done. The system reorders the entries in the repeat region.

About Sequentially Indexing Separate Repeat
Regions

You can link the indexing of separate repeat regions in the same table by using the REGION ATTR menu. By
doing so, you can specify that the index numbering for one repeat region should continue in sequence from
where the numbering for another repeat region ended.

SR S

To Link the Indexing of Two Repeat Regions

1. Choose TBL REGIONS > Attributes.
. Select inside the repeat region for which you want to set the indexing.
3. Choose REGION ATTR > Start Index. Select the repeat region from which you want to continue the
indexing.
4. Choose Done/Return to finish; the system updates the value of "&rpt.index" for the selected repeat region.
Note: You cannot use sequential indexing within nested repeat regions.

Example: Sequentially Indexing a Report with Two
Repeat Regions

In the following report, the index number in the second region begins at 1. This might not be desirable, since the
assemblies listed in the second region are still members of assembly "Main Vessel," like the parts in the first
region. The Start Index command continues the numbering in the second region in sequence from where the
numbering in the first region ends.

Index Number in the Second Region Beginning at 1

INGE X HAME TYPE aTy
| FUPPORT _BASE |
[HDEX HAME TVPE ary
| LARGE_F IPE |
z SMALL_PIPE_AESY I
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To Display the Table Shown Next

1. Choose TBL REGIONS > Attributes and select the second repeat region.
. Choose Start Index and select the first repeat region.
3. Choose Done/Return. The system updates the index numbering of the second repeat region so that it

continues the numbering begun in the first region. To return the index numbering to its original state so that
it starts at 1, choose REGION ATTR > No Start Idx.

Example: Updated Index Numbering of Second
Repeat Region

IHGEX HAME TYPE aTy
| FUPPORT _BASE I
IHGEX HAME TYPE QTY
2 LARGE_PIPE I
3 SMaLL_PIPE_AESY I

About Fixing an Index

Using the Fix Index command in the TBL REGIONS menu, you can fix the index of a repeat region record so
that it remains the same even after you insert additional items into the repeat region or sort the repeat region
differently. When fixing an index of a repeat region, keep the following restrictions in mind:
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If you fix the index of a record to be larger than the size of the repeat region, that record appears at the end
of the repeat region.

If you remove a record from a repeat region whose index has been fixed (for example, a component is
suppressed in an assembly), the fixed index does not appear in the repeat region until you unfix it or use it
for another record.

If you change the attribute of a repeat region from Duplicate to No Duplicate (or vice versa), the fixed
index no longer appears. However, if you change the attribute back to its original setting, the system
replaces the fixed index.

You cannot use an index with these symbols:

— All symbols of the type "asm.mbr.cparam"

— All symbols of the type "asm.mbr.cparams"

— All symbols of the type "asm.mbr.cblprm"

— All symbols of the type "asm.mbr.cblprms"

— All harness symbols

— All family table symbols

— All symbols showing cabling terminator names or types
If a record cannot have comment cells and dash items, you cannot fix its index.
If you fix a record’s index, you cannot dash its "rpt.index," and vice versa.
You cannot use a fixed index for 2-D repeat regions.
You cannot fix the index of a process symbol (that is, all symbols of type "prs").
A fixed index takes precedence over the following:

— Report relations.

— Start index of a repeat region. For example, if a repeat region starts at index 12 (taken from the last
index of another repeat region), but one of its records is fixed at 2, that record appears first in the repeat
region with index 2.

— Sort keys of a repeat region. The system determines the position of a record by its fixed index if it has
one. For example, a record is always at the beginning of a repeat region if its index is fixed to 1.
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To Fix the Index of a Repeat Region

1. Choose TBL REGIONS > Fix Index; then select a repeat region. The FIX INDEX menu displays the
following commands:
e Fix—Fixes one or more indexes for one or all records in a repeat region.

o Unfix—Unfixes an index, all indexes in a record, or all indexes in a repeat region.
e Record—Fixes or unfixes one or all indexes in a record of a repeat region (use with Fix or Unfix).
¢ Index—Unfixes an index (this command is only available if you choose Unfix).

e Region—Fixes all indexes in all records in a repeat region, or unfixes all fixed indexes in a repeat region
(use with Fix or Unfix).

2. Choose Fix and Record. Select a record in the current repeat region (to fix the indexes in all records in a
repeat region, choose Fix and Region).
3. Type the desired index for that record (you cannot use indexes that are already fixed for other records).
4. Choose Done. The system fixes the index for that record.
Note: To display any changes that you make using the commands in the FIX INDEX menu, you must choose
Done.

To Unfix an Index of a Repeat Region

e To unfix all indexes in a record, choose Unfix and Record. The system highlights all records whose indexes
are fixed. You can then select the records that you want to unfix.

e To unfix one index, choose Unfix and Index; then type a fixed index.

e To unfix all fixed indexes in all records in a repeat region, choose Unfix and Region; then choose Confirm
from the CONFIRMATION menu.

About Adding Comment Cells

A comment cell is a cell in a repeat region that contains user-supplied text rather than data that is read from a
model. Using comment cells, you can annotate data in a row of a repeat region and your additional text remains
associated with that row, even if the row’s location within the region changes.

Pro/ENGINEER tracks a comment cell to a particular model (not a parameter value), so that when the model
name changes, the comment is not lost. You can use comment cells in all reports except those for family tables
and cable harnesses. However, you cannot use comment cells with the following parameter symbols:
e All parameter symbols of the following type:

— "asm.mbr.cparam"

— "asm.mbr.cparams"

— "asm.mbr.cblprm"

— "asm.mbr.cblprms"

"PRS"

e All harness parameter symbols
e All family table symbols
e All parameter symbols showing cabling terminator names or types

Before creating a comment cell, you must list the data in the table so that you can choose a particular object to
comment.

To Create a Comment Cell

1. Choose TBL REGIONS > Comments > Define Cell.
2. Select an empty cell within an existing repeat region template. In Report and Format mode, the system
highlights the cell in cyan. All cells in that column are now comment cells.
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3. Choose TABLE > Enter Text and type text in the comment cell for a particular entry. The text remains
associated with that entry regardless of how the system sorts the region.

To Delete a Comment Cell

1. Choose RPT COMMENTS > Clear Def.

2. Inthe repeat region template, select a comment cell to delete. The system removes all comment text from
this cell and from all of the comment cells that follow it.

Whenever you remove a row in the repeat region from the table (either by using a filter or by changing the

setting for Duplicates/No Duplicates/No Dup/Level or Recursive/Flat), the system deletes the text of a

comment cell in that row. It does not redisplay the text if you return the row to the table by clearing the filter or

resetting the region attributes.

To Use Dash Items

Using the Dash Item command in the TBL REGIONS menu, you can convert selected "rpt.qty" and "rpt.index"
values in a drawing or report table to a dash "-". To remove a dash symbol from the table, select the symbol and
the appropriate parameter value redisplays in the table.

You cannot use a Dash item with the following
parameter symbols:

e All parameter symbols of the following type:
— "asm.mbr.cparam"
— "asm.mbr.cparams"
— "asm.mbr.cblprm"
— "asm.mbr.cblprms"
e All harness parameter symbols
o All family table symbols
e All parameter symbols showing cabling terminator names or types
Whenever you change a table value to or from a dash symbol, the system updates the table. If "rpt.qty" or
"rpt.index" parameter symbol values appear more than once in a repeat region, and you convert any of them to a
dash symbol, the system converts all like occurrences of these values in that region to a dash symbol. Likewise,

if you remove a dash symbol from a table region containing multiple occurrences of the same parameter value,
the system converts all like parameter values containing dashes.

When a "rpt.index" parameter symbol value converts to a dash symbol, it does not disturb the continuity of the
remaining index values. For example, if the system converts the third record in a table index to a dash symbol,
the index appears as 1, 2, -, 3, 4, ... . If it converts any "rpt.qty" parameter symbol value in a table to a dash
symbol, it has no effect on the table’s evaluation of relations, sorting, or filtering. The table evaluates relations,
sorts, and filters as if the true quantity value was displayed. BOM balloons containing "rpt.qty" or "rpt.index"
parameter symbol values that have been replaced in the table by a dash symbol do not appear until you remove
the Dash symbol in the table.

Tip: Dash Symbol Associativity

Dash symbols are associated with the data they replace, just as table comments are, and can be lost if you
modify the repeat region’s attributes. For example, if you replace a report quantity value of 3 with a dash
symbol, and then modify the region’s attributes to duplicates, the system warns you that the content of comment
cells or dash items can be lost and asks you if you want to continue. If you continue, it converts the dashed
symbols to the appropriate parameter value display.
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About Writing Relations

Using the Relations command in the TBL REGIONS menu, you can write relations among parameter symbols in
a repeat region and output the computed information in the same repeat region. The system stores the relations’
parameter symbols created in a repeat region with it and you cannot reference them outside of the region. In
assignment statements, you can put only new parameter symbols on the left-hand side. You must refer to
parameter symbols in repeat regions by specifying their full name and converting the period (.) to an underscore
(), as shown in the following figure. To use the following example, you must add "rpt_qty" as a repeat region
parameter symbol.

Example of Relation

IF asm mbr type=="BULK ITEM"
Qty=50

ELSE
Qty=rpt_qgty

ENDIF

To Write a Relation Among Parameter Symbols in a
Repeat Region

1. Choose TBL REGIONS > Relations > Add.

2. Create a relation using the report parameters of the selected region, or create new parameters to show in the
same region.
Note: If a report parameter is not in a repeat region, you can use it to create a relation if you add it to the
relation set first by choosing RELATIONS > Add Param.

3. Choose rpt, rel, and User Defined from the REPORT SYM menu to use this relation in the repeat region.

4. Type the name of the parameter in the repeat region relation.

Tip: Accessing Dimension Values

To access dimension values in a repeat region, use the report parameter symbol "asm.mbr.d*". To use them in a
relation, type paraml =asm _mbr_dl * asm_mbr_d2. If the report parameter symbols "asm_mbr_d1" and
"asm_mbr_d2" are not in the repeat region text, you can add them as parameters into the repeat region relation
first by choosing Add Param from the RELATIONS menu. You can only access dimension values of the current
model.

About BOM Balloons

Using the BOM BALLOON menu, you can display BOM balloons for any model in a drawing or report that has a
repeat region associated with it. You can show balloon notes for members of an assembly in a view so that they
visibly correspond to a record in a repeat region containing BOM information. Each balloon contains a number
that corresponds to that member’s index number (the value of &rpt.index) in the repeat region (by default), and
can also contain a quantity for that member as well (the value of &rpt.qty).

Pro/ENGINEER updates the contents of the balloon note to reflect changes in the order or quantity of the
corresponding records. It also updates BOM balloons to reflect the addition or removal of assembly
components. When you are working with BOM balloon notes, the following restrictions apply:

e BOM balloons are available only for non-nested repeat regions.

e Erasing or deleting balloon notes removes them from the display, but you can redisplay them by showing
them.

e BOM balloons do not display on another view if you erase the view to which they are attached.
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¢ You cannot modify the size of a quantity BOM balloon. However, you can modify a simple BOM balloon
size by changing the drawing setup file options min_balloon radius and max balloon radius.

¢ You can show BOM balloons only for model components in an assembly. The system does not consider the
spools and tie wraps used in cabling assemblies to be assembly model components, and you cannot assign
BOM balloons to them even though you can display them in a table with a report index value. It does
consider cabling harnesses to be assembly model components, and you can assign BOM balloons to them.

e BOM balloons are supported only when the model name is listed in the repeat region of a table.

Regenerating Balloons for Suppressed Components

The system preserves report cosmetics such as BOM balloons, dash items, and comments of suppressed
assembly members. When you resume suppressed features, it also restores the report cosmetics on the drawing
associated with them. For BOM balloons of suppressed components, Pro/ENGINEER attempts to find a
placement of the same model that is not suppressed and reroute the balloon to that placement. If it is unable to
find the placement, it erases the balloon, but it resumes when you resume the component.

When you suppress or replace a component to which a BOM balloon is attached, Bln By Part reattaches the
balloon to another placement of the same part.

BlIn By Comp specifies that simple BOM balloons reattach themselves to whatever component replaced the one
that originally owned the BOM balloon.

When you set a region using the Bln By Comp command in the TBL REGIONS menu, the system regenerates
simple BOM balloons as follows:

e [fthe component that owned the BOM balloon no longer exists, the system deletes the balloon.

e If you suppress the component, it suppresses the balloon.

e Ifyou replace the component with another component, and there is not already a balloon for the model that
replaced the original component, the balloon becomes a balloon for the replacement component.

e The balloon’s position on the drawing is not affected, but the leader attachment does change.

o If the replacement component already has a balloon, the system suppresses the balloon for the original
component. It resumes it if some other component without a balloon replaces the replacement component.

Balloons can properly forward their attachments in this manner for automatic family table replacement. For the
following situations, the system deletes the balloon for the replaced component (but you can show a new
balloon in the usual manner):

e Manual replacement

e Replacement by interchange

e Substitutions by simplified representations other than with a simplified representation of the same part
Note: These BOM balloon rules do not apply to quantity or custom BOM balloons.

To Change BOM Balloon Index Numbers

The order of the records in the repeat region controls the index numbers for BOM balloons. You can change
these numbers by entering or changing the region’s sorting parameters or by fixing the indexes of report items.

You can also specify a different parameter for the index field by choosing Set Param from the BOM BALLOON
menu.

Examples: Changing the Display of BOM Balloons

The next figure shows the default display of simple (index-displaying) BOM balloons for a drawing with two
assemblies; each repeat region is sorted in the default manner, in alphabetical order.
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ASSEMBLY: ASM.|

DATE: 25-Mar-93

INDEX NANE TYPE ary. | PRICE
BASE PART . 500

PIN PAR] . 500

PLATE PART . 750

L —®
®
—0

ASSEMBLY: ASN.2

DATE: 25-Mar-93

INDEX NANE TIPE PRICE
BOTTON PAR 500
COVER PAR .350
INSERT PAR .650

f 8o
———)
[ O

The next figure shows how the system updates BOM balloons for ASM 1 when using the sorting parameter

symbol &asm.mbr.price to sort its repeat region instead (price is a user-defined parameter).

ASSEMBLY: ASM.|
DATE: 25-Nor-93

INDEX NAME TYPE ary. | PRICE
PIN PART 500

PLATE PART . 150

BASE PART .500

|MIEULT: ASN.2
DATE: 25-Mar-93
INDEX NANE TIPE PRICE
BOTTON PAR .500
COVER PAR .350
INSERT PAR .850

Quantity BOM balloons display both the index of the assembly member and its quantity in the assembly. The
first figure that follows shows the display of quantity BOM balloons for ASM 1. Notice that the index number
is in the top half of the balloon and the quantity is in the bottom half.

Note: You cannot mix simple BOM balloons and quantity BOM balloons for the same repeat region; the
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balloons must all be of a single type.
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ASSEMBLY: ASM.|

DATE: 23-Mar-93

INDEX HAME TYPE PRICE
BASE PART 500
PIN PART . 500
PLATE PART -150

ASSEMBLY: ASN.2

DATE: 25-Mar-93

INDEX NANE TYPE QT1. | PRICE
BOTTON PART . 500
COVER PART L]
INSERT PART ML)

if

In the second figure, the quantity for the pin part is redistributed among three balloons, each pointing to two
occurrences of the model.

ASSEMBLY: ASM.I

DATE: 25-Nar-93

IMDEX NAME TYPE PRICE
BASE PART -500
PIN PART 500
PLATE PART 150

S

—D

ASSEMBLY: ASN.2

DATE: 25-Mar-93

INDEX T TYPE 4TT. | PRICE
BOTTOM PART . 500
COVER PART +350
INSERT PAR] 1850

if

Showing BOM Balloons

You can show BOM balloons for any model in a drawing or report that is associated with a repeat region, as
well as show BOM balloons in assembly simplified representations using the same method.

You can also show BOM balloons for multiple repeat regions in a single table for the same model or in multiple

tables for multiple views of the model. Also, by creating multiple repeat regions, using filters, and fixing
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indexes, you can show different parameters for a model in a table, but show the same BOM balloon callouts on
a view.

When showing BOM balloons, keep in mind the following:
¢ You can show BOM balloons only on views to which the repeat region is associated. You cannot switch

BOM balloons shown on one simplified representation to a different simplified representation.

e After a simplified representation is attached to a repeat region, if you change the simplified representation
(that is, substitute a part with a simplified representation), all references remain with it, including the
following:

— Balloon attachment
— Parameters

— Comments

— Fixed indexes

— Dash items

To Show BOM Balloons

1. Retrieve a report, drawing, or layout that already contains a table with a repeat region.
2. Choose TABLE > Bom Balloon > Set Region > Show > By Comp.

3. Select a component in the drawing (for example, a part plate); then choose Done. The BOM balloon
appears in the drawing.

Example: Showing the Part Plate Balloon

Note: The BOM balloon (number 2) attached to the part component.

HUM | HAKHE BT | GOsT

%‘G ﬁm{ %"E I |PIN 3 lg.aan
’_@ ¢ |PLATE | 20,900
[ T T T T T T T

I |BA3E H.q0p

Total Cost G000

SCALE 0,204

Tip: Setting the Default Arrow Style for BOM
Balloons

Note: To set the default arrow style for BOM balloons in reports, set the drawing setup file option
"def bom balloon leader sym."

To Change the Type of BOM Balloon Displayed

1. Choose TABLE > BOM Balloon > Change Type.

2. Select the repeat region for which you want to change the BOM balloon type. The system highlights the
region and the BOM BAL TYPE menu appears with the current type highlighted.

3. Choose Simple or With Qty, followed by Done/Return.
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4. Choose BOM BALLOON > Show to redisplay the BOM balloons in their new type. If multiple models are
present in the drawing or report, you must select the repeat region again for the new balloons to appear.

To Change the Default Balloon Symbol for a Repeat
Region

To change the default balloon symbol for a repeat region, choose Change Type from the BOM BALLOON
menu and Custom from the BOM BAL TYPE menu; then select a new symbol.

Creating Customized BOM Balloons

Using the Custom command in the BOM BAL TYPE menu, you can create customized balloons with user-
defined symbol instances. When you use a customized symbol to show balloons, the system substitutes variable
text with corresponding report parameters. If the default value of the variable text matches a report symbol
specification, it displays the value of that report symbol in the symbol.

For example, if the variable text default value is asm.mbr.name, the system displays the member name in the
balloon. It updates (in the symbol instance) only the report parameters that it displays in the balloon region;
other variable texts simply display their default values. In addition to report parameters displayed in the table,
the system uses two special keywords as default values for variable text: it replaces "qty" with the quantity, as
in default quantity balloons, and it treats "index" as the index field in default balloons. By default, for variable
text whose default value is "index," it fills them in with the value of "rpt.index."

You can use the Set Param command in the BOM BALLOON menu to specify a different parameter for the
index field. The system considers a customized balloon to be a quantity custom balloon if it contains variable
text whose default value is "qty."

To Create a Customized Balloon

1. Choose REPORT > Table > BOM Balloon > Change Type.

2. Select the region where you want to change the balloon.

3. Choose BOM BAL TYPE > Custom > Retrieve and retrieve user symbols from a file.
Note: You cannot select user-defined symbols that do not contain variable text.

To Replace An Individual Custom Symbol with
Another Custom Symbol

1. Choose BOM BALLOON > Alt Symbol; then select a balloon region.

Select quantity or custom balloons of the selected repeat region, or components; then choose GET SELECT
> Done Sel.

3. From the GET SYMBOL menu, select a user-defined symbol. Any selected balloons change to match the
selected symbol, and the system redisplays the new balloons using the selected symbol for any selected
components.

4. For regions that use a user-defined symbol to display balloons, choose GET SYMBOL > Reg Default. The
selected balloons revert to the default symbol of the region, and the system shows new balloons for the
selected components using that symbol.

Note: You cannot change individual simple-customized balloons to quantity-customized balloons, and vice
versa. All balloons for any given region must be either quantity or simple balloons.

Splitting and Merging Balloons

To split and merge customized balloons, use the same method you would use to split and merge quantity
balloons, except that you need not enter quantity-related information. When you first merge custom or quantity
balloons, the system orients them horizontally relative to the balloon to which they are merged. You can change
the orientation of the balloon with respect to its parent by using the Move command in the DETAIL menu.
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To Merge Quantity or Custom BOM Balloons

1.
2.

Choose BOM BALLOON > Merge.
Select a from balloon and a fo balloon. They need not point to the same model. The from balloon can be a
to balloon from a previous merge.
If the firom and fo balloons point to the same model, the system deletes the from balloon and adds its
quantity to the zo balloon.

If the balloons point to different models, it deletes the leader of the from balloon and attaches the firom
balloon to the o balloon.

If you later use Detach to separate the merged balloons, the firom balloon reattaches itself to its original
model.

Note: To change the orientation of a merged BOM balloon with respect to its parent, choose DETAIL >
Move.

To Redistribute Quantity Among BOM Balloons

1.
2.
3.

4.

Choose BOM BALLOON > Redistribute.

Select a BOM balloon with a quantity greater than 1.

Type the quantity that you want to subtract from this balloon and add to another balloon for the same
model.

Select the balloon for the same model to which you want to add the quantity. The quantities of the balloons
change accordingly.

To Split Quantity BOM Balloons

1.

3.

394

Choose BOM BALLOON > Split.
Select a quantity BOM balloon with a quantity greater than 1.
Type the quantity that you want to subtract from this balloon and use to create another balloon for the same
component.
Select an attachment point for the new balloon by selecting an occurrence of the component that does not
have a balloon.
Note: You cannot select for attachment any silhouette edges of torii that are not perpendicular to the screen.
Select a location on the sheet to place the new balloon. The system creates the new balloon, displaying the
quantity that you subtracted from the first balloon.
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